Agilent OpenLAB Data Store for MS

Installation Guide
Notices

© Agilent Technologies, Inc. 2013

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

M8620-90001

Edition

July 2013

Printed in USA

Agilent Technologies, Inc.
3501 Stevens Creek Blvd.
Santa Clara, CA 95051 USA

Microsoft ® is a U.S. registered trademark of Microsoft Corporation.

Software Revision

This guide is valid for A.01.03 Agilent OpenLAB Data Store for MS software.

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

U.S. Government Restricted Rights. Software and technical data rights granted to the federal government include only those rights customarily provided to end user customers. Agilent provides this customary commercial license in Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212 (Computer Software) and, for the Department of Defense, DFARS 252.227-7015 (Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial Computer Software or Computer Software Documentation).

Safety Notices

CAUTION

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.
Contents

1 Introduction  5
   About This Guide  6
   The Agilent OpenLAB Data Store Software  6
   Before You Begin  7

2 Configuration of Windows Server 2008 R2 SP1  9
   Install Windows Server 2008 R2 SP1  10
   Configure Windows Server 2008 R2 SP1 Settings  10
      Configure Windows updates  10
      Disable the application experience service  10
      Set local security policy  11
      Set region and language options  11
      Set time zone  11
      Apply security settings  11
      Enable non-http activation  11
      Change server authentication to mixed mode  12
         (SQL Server only)

3 Install the OpenLAB Data Store Server Software  13
   Step 1: Start the Application  14
   Step 2: Run the System Configuration Checker  14
   Step 3: Prepare Third Party Tools  15
      Install Adobe PDF Reader  15
      Install Adobe Flash Player  15
      Disable Auto-Update Notification in Flash Player  15
   Step 4: Run OpenLAB Data Store Installer  16
      OpenLAB Master Installer  16
      License Agreement Screen  16
      Installation folder screen  16
Contents

Installation type screens 16
Summary screen 18

4 Configure OpenLAB Data Store 19
Configure OpenLAB Shared Services to use Data Store 20
Create Users 21
   Add users (Internal Authentication only) 21
   Import users (Windows Domain Authentication only) 22
   Add users to a role 22
Install Your License 23
   Obtain your software license online 23
   Obtain your software license offline 24
   Add your license to the Control Panel 25

5 Install the OpenLAB Data Store Client Software 27
Step 1: Prepare Third Party Tools 28
   Install Adobe PDF Reader 28
   Install Adobe Flash Player 28
   Disable auto-update notification in Flash Player 28
   Disable compatibility view in Internet Explorer 28
Step 2: Run the OpenLAB Data Store Installer 29
   License Agreement Screen 29
   Installation folder screen 29
   Installation type screens 29
   Summary screen 30

6 Uninstall the Software 31
About Uninstallation 32
Run the OpenLAB Uninstallation Wizard 32
This chapter gives you an overview of the OpenLAB Data Store for MS software and includes the requirements needed for pre-installation.
Introduction

About This Guide

This installation guide is designed to help system administrators and other users install the Agilent OpenLAB Data Store for MS software quickly and correctly.

The Agilent OpenLAB Data Store Software

The Agilent OpenLAB Data Store for MS, along with Agilent OpenLAB Chromatography Data System (CDS), Agilent OpenLAB Enterprise Content Manager (ECM), and OpenLAB Data Store With Lab Applications plus several add-ons make up the Agilent OpenLAB software suite.

These integrated solutions form a system designed to grow with customers' needs, from a small standalone analytical lab to a global network with hundreds of locations. Using the OpenLAB software, instruments from multiple vendors can connect to any size network; from individual workstations and workgroups to global enterprises. With full instrument control, centralized administration and ease-of-support, users can achieve lower operational costs and better instrument use. See your Agilent representative to learn how other products in the OpenLAB suite can help you.

The Agilent OpenLAB Data Store for MS software is provided on one DVD, M8623-60001.
Before You Begin

1 Acquire administrator privileges for all servers and clients. Power user privileges are not sufficient (The installation will not start.).

2 Decide on a server and a directory location to store files related to the Data Store content and indexes.

3 Obtain the Data Store server:
   • Database name
   • Database administrator user name and password
   • Authentication mode
   • Administrator user credentials (domain, user name, password)

4 Review the following PDFs in the installer Planning and Resources menus before you install the software:
   Under the Installer Planning menu:
   • Hardware and Software Requirements – Use this PDF to determine if your hardware and software will support the system.
   • Installation Guide for OpenLAB Data Store – An electronic copy of this installation guide is provided in PDF format for your convenience.

   Under the Installer Resources menu:
   • License Agreement – Use this PDF to review the license terms.

   **CAUTION**

Keep your computers disconnected from the internet until you have installed the appropriate security patches and hot fixes.

Agilent strongly recommends installation of the latest security fixes and virus protections prior to connecting to a network.
1 Introduction
This chapter describes the necessary installation and configuration of the Windows Server to prepare it for the installation of the Data Store server.
Install Windows Server 2008 R2 SP1

1. Install Windows Server 2008 R2 SP1. During the setup of Windows Server 2008 R2 record the computer name, administrator password, and network settings.

2. Download and install the service pack (SP1) from the Microsoft web page (http://support.microsoft.com/kb/976932).

3. Join an existing domain or set up the system in workgroup mode.

4. To guard your systems against viruses, install an AntiVirus program. Running AntiVirus programs can influence the behavior and performance of your computer. Agilent OpenLAB Data Store was tested to run with Symantec’s Norton Antivirus.

5. Confirm that no server role or feature is installed.

Configure Windows Server 2008 R2 SP1 Settings

These settings optimize the application performance.

Configure Windows updates

1. Select Start > Control Panel.
2. Select System and Security > Windows Update > Check for updates.
3. Apply updates.
4. Select Change Settings. For Important updates, select Never check for updates. Disable the other update options.
5. Select OK to close the window.

Disable the application experience service

1. Go to Start > Control Panel.
2. Select Administrative Tools > Services.
3. In the Service list, right-click Desktop Window Manager Session Manager and select Properties.
4. For Startup type: select Disabled click Apply and then OK to close the window.
5. In the Service list, right-click Application Experience and select Properties.
6. For Startup type: select Disabled click Apply and then OK to close the window.
7. Close the Services window and the Administrative Tools window.
Set local security policy

4. In the displayed dialog, select Classical - local users authenticate as themselves from the drop-down list.

Set region and language options

1. Select Start > Control Panel > Regional and Language Options.
2. From the Formats tab, Format list, select English (United States), Chinese (Simplified PRC), or Japanese (Japan).
3. Select OK to close the window.

Set time zone

1. Select Start > Control Panel > Date and Time > Change time zone. Use the same time zone for server and clients.
2. From the Date and Time tab, select Change time zone.
3. Select your time zone from the Time zone list and select OK.
4. Select OK to close the window.

Apply security settings


Enable non-http activation

1. Select Start > Control Panel > Programs.
2. Select Programs and Features > Turn Windows features on or off.
3. In the Windows Feature section, expand the Microsoft .NET Framework 3.5.1 node and select the Windows Communication Foundation Non-HTTP Activation check box.
4. Select OK.
Change server authentication to mixed mode
(SQL Server only)

1 Start SQL Server Management Studio.
2 In the Object Explorer, right-click the server name, and select Properties from the context menu.
3 In the Server Properties dialog, select the Security page.
4 Under Server authentication, select SQL Server and Windows Authentication mode.
5 Click OK.
6 Enable login for user sa.
   a In the Object Explorer, navigate to Security > Logins.
   b Right-click the user sa, and select Properties from the context menu.
   c In the Login Properties dialog, select the General page.
   d Provide a strong password.
   e Select the Status page.
   f Under Login, select Enabled.
   g Click OK.
7 Restart the SQL Server service, and log in with SQL Server Authentication.
3 Install the OpenLAB Data Store Server Software

Step 1: Start the Application   14
Step 2: Run the System Configuration Checker   14
Step 3: Prepare Third Party Tools   15
Step 4: Run OpenLAB Data Store Installer   16

The installation is automated for you by the included OpenLAB Master Installer. This tool installs the various components of OpenLAB Data Store.
Step 1: Start the Application

Insert the installation disk. Autorun.inf will automatically run Agilent.OpenLab.CDSInstaller.exe and display the OpenLAB Master Installer Planning screen. If the program does not start automatically, select setup.bat from the DVD.

Step 2: Run the System Configuration Checker

1. From the Planning screen, select System Configuration Checker.
2. From the Site Preparation Tool window, select Software list, select OpenLAB Data Store MSSQL Server A.01.03 or OpenLAB Data Store PostGreSQL Sever A.01.03, depending on your installation type.
3. Select your operating system from the list.
4. Select OK.
5. Complete the Contact Information—System details by typing in the fields provided.
   - System Location fields
   - System Information fields
   - Configuration fields.
6. Select Go > Start to begin the software check. A summary report is displayed showing the results for each check category. Results are expressed as Pass, Warning, Critical Warning, or Fail.
   - Fail results must be corrected before continuing with the installation. Agilent recommends investigating and correcting any Critical Warnings and Warnings whenever possible before proceeding.
7. To view details of the report, select the appropriate link: System Hardware Details or Operating System and Software Details.
9. Select File > Exit and Yes to close the Site Preparation Tool window.
10. Select Cancel to close the Site Preparation Tool window.
11. E-mail the saved report to your Agilent Service Representative for evaluation, and for validation of your personal computer for Agilent Software Systems Installs.
Step 3: Prepare Third Party Tools

The OpenLAB Master Installer offers a list of tools that can be installed directly from the Installation screen.

Install Adobe PDF Reader

1. From the Master Installer, select Installation and Third Party Tools, Adobe PDF Reader.
2. Follow the instructions in the Adobe Reader - Setup program to install.

Install Adobe Flash Player

1. From the Master Installer, select Installation and Third Party Tools, Adobe Flash Player.
2. Follow the instructions in the Adobe Flash Player Installer program to install.

Disable Auto-Update Notification in Flash Player

Adobe periodically updates the Flash Player with new features or security fixes, and notifies users with an installed Flash Player when an update is available. To disable the notification of updates:

1. Right-click on any Flash content, select Settings, Advanced and click the Global Notifications Settings tab in the Flash Player Settings Manager.
2. Clear the Notify me when an update to Adobe Flash Player is available check box to stop receiving notifications.
3. Close the Settings Manager. The Flash Player automatically remembers the new settings.
Step 4: Run OpenLAB Data Store Installer

**CAUTION** Record and store the selections that you use during this installation in a different physical location. The information will be needed to restore your system in the unlikely case of your system becoming inoperable due to a hardware or software failure.

**OpenLAB Master Installer**

1. From the OpenLAB Master Installer, select **Installation**.
2. Select OpenLAB Data Store.

**License Agreement Screen**

1. Read the terms of the License Agreement. Master Installer provides a printable PDF of the license agreement under Resources.
2. Select I agree with the terms and conditions. You cannot proceed with the installation until you agree to these terms.
3. Select Next to proceed to the Installation Folder screen.

**Installation folder screen**

1. Type the folder name or browse to the folder where you want to store the application components. Folders must have English names.
2. To run an installation qualification as part of this installation, select Run Installation Qualification.
3. Select Next to proceed to the Installation type screen.

**Installation type screens**

1. Select Server.
2. Select Next to proceed to the Database Type Selection screen.
3. Select your database. (PostgreSQL or Microsoft SQL)
4. For Select installation type, choose either New database server (PostgreSQL only) or Connect to existing database server (PostgreSQL or Microsoft SQL Server).
5 Use one of the procedures below according to your database installation:

**To create and use a new PostgreSQL database:**

a. For Select installation type, select New database server.
b. Use the default Data file directory, or select a different location.
c. Select Next to proceed to the PostgreSQL database screen.
d. Use the default Database name or enter a different Database name.
e. Select the authentication mode. If you select PostgreSQL server authentication, complete the username and password fields.

**To use an existing PostgreSQL database:**

a. For Database Type Selection, select PostgreSQL.
b. For Select installation type, select Connect to an existing database server.
c. Select Next to proceed to the PostgreSQL database screen.
d. Enter the Database name.
e. Select the authentication mode. If you select PostgreSQL server authentication, complete the username and password fields.

**To use an existing Microsoft SQL Server database:**

a. For Database Type Selection, select Microsoft SQL Server.
b. Enter the Database server name.
c. Select Use default instance or Use named instance. If you select Use named instance, enter the Database instance name.
d. Select Next to proceed to the Server connection type screen.
e. Use the default Database name or enter a different Database name.
f. Select the authentication mode. If you select SQL authentication, complete the username and password fields.
g. To verify the connection from this machine to the SQL server, select Test Connection. The system displays a Connection succeeded message if the check is successful.

6 Select Next to proceed to the Additional items screen.

7 In the Data Store Server Content files directory field, enter a suitable location to store the content files for OpenLAB Data Store or use the default content folder.
8 Under OpenLAB Shared Services Language, select the correct language from the list.

9 Select Next to proceed to the Summary screen.

**Summary screen**

1 Review the installation activities. Select Back as necessary to change installation activities, or Cancel to cancel the installation.

2 Select Start to begin installation.

   The system performs an automated system check before it proceeds with the listed activities.

   If a system check passed message appears, installation continues.

   If a system check failed message appears, either:
   - Decline to view the system report, and continue installation.
   - View the system report, and decide to continue installation.
   - View the system report and postpone installation until the problem is fixed.
   - Decline to view the system report and postpone.

   If the installation of any vital application or component fails, the installation will roll back (uninstall). If a failed component can be installed at a later time without affecting basic installation, the installation will proceed. In this case, you will be notified of any failure, and that further steps are necessary to fully complete installation.

3 If an IQ was completed as part of this installation, review the Installation Qualification Report. If the report indicates failure, verify the computer requirements and reinstall. Do not use the system until an Installation Qualification Report gives a 'pass' result.

4 Click Next to proceed to the Installed Features screen.

5 Click Finish to close the installer.

6 Reboot the server after the installation.
4
Configure OpenLAB Data Store

Configure OpenLAB Shared Services to use Data Store  20
Create Users    21
Install Your License    23
Configure OpenLAB Shared Services to use Data Store

1. Start the OpenLAB Control Panel shortcut on the desktop or go to Start > All Programs > Agilent Technologies > OpenLAB > OpenLAB Control Panel.
2. From the navigation pane, select Administration > System Configuration.
3. In the System Configuration toolbar, select Edit System Settings.
4. In the Edit System Settings window, select your authentication provider from the list. (Internal or Windows Domain)
5. Select the storage type, Data Store, from the list.
6. Select Next.
7. Select a user to administrate the system.
   a. If you selected Internal as an authentication provider:
      b. In the Create Administrator Account dialog box, enter a Name and a Password.
   b. If you selected Windows Domain as an authentication provider:
      a. Select the check box to activate the input fields.
      b. Enter a Domain, User, and Password.
      c. Select Select Account.
      d. Enter a search string.
      e. In the Search Users dialog box, select Search to view a list of users.
      f. Select a user.
8. Select OK
9. Activate Data Store.
   a. Enter the URL of the Data Store server (http://<server name>).
   b. Click Activate.
      A success message is shown. Click OK to confirm. If activation fails:
      * Verify URL and credentials.
      * Restart the AlfrescoTomcat service.
      * Check the firewall.
      * Check for port conflicts. Port 80 must be open.
   c. Enter a root folder for project data on the Data Store server.
10. Select Next.
11. Review your settings, and select Apply.
Create Users

Use the OpenLAB Control Panel to manage the roles and privileges that affect Data Store users. You can create custom roles, or assign one or more of the 5 predefined Data Store roles listed in Table 1, to give users varying degrees of Data Store access.

Table 1  Data Store predefined roles

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Data Store Approver</th>
<th>Data Store Contributor</th>
<th>Data Store Reader</th>
<th>Archivist</th>
<th>System Administrator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electronically sign files</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Save or modify content</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>View content</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View projects</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Archive and de-archive content</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Modify system settings</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Manage security</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>X</td>
</tr>
</tbody>
</table>

Add users (Internal Authentication only)

1. From the navigation pane, select Administration > Users.
2. In the Users toolbar, select Create.
3. In the Create User dialog box enter a Name and Description for the user.
4. Select the General tab and enter a Password for the user. Confirm the password. Password length is set under Security policy.
5. Enter the users Full name, Email address, and Contact Information if desired. The full name is used in activity log entries and the welcome message at the lower right of the Control Panel.
6. Select password options:
   - To prevent the user from changing the password assigned here, enable the User cannot change password.
   - To require the user to create a new password the next time they log on, enable the User must change password at next logon.
To allow the user to use the password assigned here or change it at any time, disable both the **User cannot change password** and the **User must change password at next logon**.

7 To create a user profile but prevent the user from logging on Control Panel, enable **User disabled**.

8 Select OK.

**Import users (Windows Domain Authentication only)**

To add users to your system, you must have privileges to obtain user and groups information from the domain.

1 From the navigation pane, select **Administration > Users**.
2 In the Users toolbar, select **Import**.
3 In the Search Users dialog box, enter search string for the windows domain username.
4 From the Search Results list, select the user you want to import and select **Add**. The user is added to the Selected Users list.
5 Repeat steps 2 and 3 until you have added all the user names that you want to import to the Selected Users list, then select OK.

**Add users to a role**

1 From the navigation pane, select **Administration > Roles**.
2 In the Roles window, select the role you want to assign to users.
3 In the Roles toolbar, select **Edit**.
4 In the Edit Role dialog box, select the **Members** tab.
5 Select **Add user or group**.
6 In the Search Users and Groups dialog box, select **Search** to view a list of all users and groups.
7 Under **Search Results**, select a user or group and select **Add**.
8 Select OK.
Install Your License

A license file will contain your software license. This file is installed to the license server—the workstation computer or OpenLAB Shared Services Server to which your product was installed. The license file is 'bound' to this server address, and cannot be moved to another server.

Information in the license file defines the number of instruments that may be used concurrently with your system.

Obtain your software license online

The most efficient way to and manage and maintain your license is through the Internet, however if you are lacking an Internet connection, See “Obtain your software license offline” on page 24.

Gather the following information from the lavender envelope containing your Software Entitlement Certificate. If you have not received a lavender envelope, contact your vendor or internal support.

- The authorization code label
- The URL for SubscribeNet

Create a SubscribeNet account (New users only)

If you are a new user who has not registered with SubscribeNet, you must first create an account.

If you are already registered with SubscribeNet, skip to the section, Generate your License.

To create a new account

1. From any computer with Internet access, enter the SubscribeNet URL in an Internet browser.
2. At the bottom of the login page, click **click HERE to register**.
3. On the registration page, enter the authorization code from the label and complete the profile information. The email address you enter will become your login ID.
4 Select **Submit**. An account name is generated and displayed. The system will also send an email message with the following information:

- Account name
- Login ID
- Password
- A link to access your license pool at the SubscribeNet site

**Generate your License**

1. From your Data Store server, use the link to open the SubscribeNet site.
2. Log into SubscribeNet using your login ID and password.
3. Select the SubscribeNet account associated with this authorization code, if you have more than one account.
4. Select **Generate licenses** from the left navigation bar and follow the prompts to generate your new license.
   
   - The computer **HOST NAME** you enter must match the network name of the computer where the OpenLAB Control Panel is running. Do not include any DNS suffix (domain.com) references in the entered machine name. If the computer name or domain are changed after the license is installed, this license must be removed and a new license must be created in SubscribeNet, downloaded, and installed.

   - The MAC address is that of the shared services server. To retrieve your MAC address, see the Control Panel online help topic, **Manage license server > To copy MAC address**. If the network adapter that provides the MAC address used during license creation is removed from the machine, your license will no longer be valid. A new license will need to be generated with a currently available MAC on the license server.

5. When the system generates the license, select **Download License File** and save the license file to your computer, and to a backup location (such as a portable storage device).

**Obtain your software license offline**

If you are lacking an Internet connection, you or your local on-site service engineer can collect the necessary information from you to allow Agilent to create a license account on your behalf.
To Obtain Your Software License Offline

1 Collect the required Customer Information
   - Company Name
   - Lab/Department Name
   - First Name
   - Last Name
   - E-mail address
   - Job Title
   - Phone number
   - Address, City, State/Province, Postal Code, Country
   - The authorization code label provided in the lavender envelope containing your Software Entitlement Certificate.

2 Contact your local Agilent sales and service center. Once the required information is provided, Agilent will work on your behalf to generate a license file through SubscribeNet. The license file will either be sent to your shipping address on a CD, or delivered by your local FSE on a USB-stick.

Add your license to the Control Panel

For your system to be fully operational, you must add your license to the Control Panel.

To add license

1 Start the Control Panel from any machine connected to the Data Store server.
2 From the navigation pane, select Administration > Licenses.
3 In the Licensing toolbar, select Add.
4 In the Add Licenses dialog box.
5 Select Browse.
6 In the Open dialog box, navigate to and select the license file (on CD, USB, or network folder).
7 Select Open.
4 Configure OpenLAB Data Store
5
Install the OpenLAB Data Store Client Software

Step 1: Prepare Third Party Tools  28
Step 2: Run the OpenLAB Data Store Installer  29

Use these procedures to install the software to any number of clients connected to the server.
Step 1: Prepare Third Party Tools

The OpenLAB Master Installer offers a list of tools that can be installed directly from the Installation screen.

Install Adobe PDF Reader

1. From the Master Installer, select Installation and Third Party Tools, Adobe PDF Reader.
2. Follow the instructions in the Adobe Reader - Setup program to install.

Install Adobe Flash Player

1. From the Master Installer, select Installation and Third Party Tools, Adobe Flash Player.
2. Follow the instructions in the Adobe Flash Player Installer program to install.

Disable auto-update notification in Flash Player

Adobe periodically updates the Flash Player with new features or security fixes, and notifies users with an installed Flash Player when an update is available. To disable the notification of updates:

1. Right-click on any Flash content, select Settings, Advanced and click the Global Notifications Settings tab in the Flash Player Settings Manager.
2. Clear the Notify me when an update to Adobe Flash Player is available check box to stop receiving notifications.
3. Close the Settings Manager. The Flash Player automatically remembers the new settings.

Disable compatibility view in Internet Explorer

When Compatibility View is turned on, the website you are viewing will be displayed as if you were using an earlier version of Internet Explorer. To disable Compatibility View on your workstations:

1. Open Internet Explorer.
2. Click the Tools menu, and then click Compatibility View Settings.
3. Clear the Display intranet sites in Compatibility View check box.
Step 2: Run the OpenLAB Data Store Installer

1. Insert the installation disk. Autorun.inf will automatically run Agilent.OpenLab.CDSInstaller.exe and display the installer Planning screen. If the program does not start automatically, select setup.bat from the DVD.

2. From the OpenLAB Master Installer screen, select Installation.

3. Select OpenLAB Data Store. The OpenLAB Installation Wizard opens.

License Agreement Screen

1. Read the terms of the License Agreement. Master Installer provides a printable PDF of the license agreement under the Resources option of the main menu.

2. Select I agree with the terms and conditions. You cannot proceed with installation until you agree to the terms.

3. Select Next to proceed to the Installation Folder screen.

Installation folder screen

1. Type the folder name or browse to the folder where you want to store the application components.

2. To run an installation qualification as part of this client installation, select Run Installation Qualification.

3. Select Next to proceed to the Installation type screen.

Installation type screens

1. Select Client.

2. Enter or browse to a location to store files while they are waiting to be uploaded.

3. Select Next. The system will perform a connectivity check for the server. If the connectivity test fails, verify that the server name was entered correctly, without spaces, and select Next to run the test again. If the test is still unsuccessful, you can:
5 Install the OpenLAB Data Store Client Software

- Enter a new server and try another test.
- Call internal support for assistance if you cannot connect to a server.

When a connectivity test has run successfully, the system will proceed to the Additional items screen.

4 Select Next to proceed to the Summary screen.

Summary screen

1 Review the installation activities that you have selected in the preceding steps. Select Back as necessary to change installation activities, or Cancel to cancel the installation.

2 Select Start to begin installation.

3 If an IQ was completed as part of this installation, review the Installation Qualification Report. If the report indicates failure, verify the computer requirements and reinstall the data system. Do not use the system until an Installation Qualification Report gives a ‘pass’ result.

4 Click Next to proceed to the Installed Features screen.

5 Click Finish to close the installer.
6 Uninstall the Software

About Uninstallation  32
Run the OpenLAB Uninstallation Wizard  32

This chapter contains information on the uninstallation by using the OpenLAB Uninstallation Wizard.
About Uninstallation

Like the installation, the uninstallation of OpenLAB Data Store is automated by the Master Installer.

To uninstall OpenLAB Data Store, you need to have administrator privileges for all servers and clients. Power user privileges are not sufficient (the uninstallation does not start).

Run the OpenLAB Uninstallation Wizard

1. Insert the Installation disk.
2. From the Master Installer Planning screen, select Maintenance from the side bar menu.
3. Select OpenLAB Uninstallation. The OpenLAB Uninstallation Wizard opens.
4. Select Start to start the uninstallation.
5. If you want to abort the uninstallation, select Cancel.
   All listed components are automatically uninstalled.
   When a component is uninstalled correctly, the status shown in the Status field of the Maintenance screen changes from Installed to Uninstalled successfully.
6. When the uninstallation has finished, click Finish to close the Uninstallation Wizard.
7. Reboot the system to complete the installation.