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In This Guide...
In This Guide...
 In the Compliance mode, MassHunter GC/MS Acquisition and Quantitative Analysis, in 
conjunction with Agilent OpenLab Enterprise Content Manager (ECM), supports the 
requirements of the U.S. Food and Drug Administration (FDA) regulations on the handling 
of electronic records and electronic signatures published as 21 CFR Part 11. Records are 
treated as regulated records.

This book describes how to set up and use MassHunter GC/MS Acquisition B.07.03 and 
MassHunter Quantitative Analysis B.07.01, in the Compliance mode. OpenLab ECM version 
3.4.1 SP2 or higher is required to support MassHunter Compliance mode.

NOTE: The Compliance mode does not support Qualitative Analysis.
1. Agilent OpenLab ECM - 
Overview
Chapter 1 describes the general steps you should follow to set up ECM when used with 
MassHunter GC/MS Acquisition and Quantitative Analysis running in the Compliance 
mode. It also details the differences between retrieving and checking out a file directly 
from ECM.

Details for setting up and managing ECM users, groups, roles, etc, are beyond the scope of 
this document. Those details are included in the OpenLab ECM Online Help. 
 

2. MassHunter GC/MS 
Acquisition - Setup and 
Configuration
Chapter 2 describes how to install MassHunter GC/MS Acquisition in Compliance mode, 
depending on which version is currently installed. It then details how to assign users to 
Windows security groups and configure instruments and settings.
3. MassHunter GC/MS 
Acquisition - Routine Tasks
Chapter 3 describes routine tasks performed in MassHunter GC/MS Acquisition in 
Compliance mode. 
4. MassHunter Quantitative 
Analysis - Setup and 
Configuration
Chapter 4 provides general guidance on how to install and set up MassHunter Quantitative 
Analysis depending on which version is currently installed. It then details how to associate 
ECM roles with MassHunter Quantitative Analysis command groups.
5. MassHunter Quantitative 
Analysis - Routine Tasks
Chapter 5 describes routine tasks performed in MassHunter Quantitative Analysis in 
Compliance mode. 
6. Audit Trails
 Chapter 6 describes how to view or print audit-trail logs and how to enable or disable the 
audit reasons shown in logs in both MassHunter GC/MS Acquisition and Quantitative 
Analysis.
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In This Guide...
7. MassHunter Quantitative 
Analysis Command Groups
Chapter 7 provides a complete list of all the commands in each MassHunter Quantitative 
Analysis command group: Batch Analysis, Method Development, Batch Review, and 
Report. 
8. MassHunter Acquisition 
Windows Security Groups
Chapter 8 provides a list of the default privileges assigned to the pre-defined Windows security 
groups Analyst I, Analyst II, Analyst III, and Manager which are used in MassHunter GC/MS 
Acquisition. The permissions are grouped by their function.
9. Supported Network Topologies 
for Compliance Security Mode
Chapter 9 includes examples of the network configurations supported by MassHunter 
compliance mode.

All supported configurations require an ECM server installation of version 3.4.1 SP2 or 
greater.
Where to find more information
 

In addition to MassHunter’s online Help, the Federal Registry 21 CFR Part 11, and the ECM 
documentation accompanying your hardware and software, Agilent also provides a 
comprehensive collection of:

• Manuals
• Videos
• User Applications
• Method development tools 
• A MassHunter GC/MS Software Compliance Assessment document 

These are located on the: 

• Agilent GC and GC/MS Manuals and Tools DVD set or Agilent Hardware DVD

• Agilent GC/MS Software Information and Manuals memory stick

 

To Install Your Hardware Library 

Insert Disk 1 into your DVD drive and follow the prompts.

This can be installed by anyone who has authority to copy 
information onto the receiving computer.

To Install Your Software Library 

Insert the memory stick into a USB port and follow the prompts.

This can be installed by anyone who has authority to copy 
information onto the receiving computer.

© 2013 Agilent Technologies, Inc. 
All rights reserved.

Made in USA

Agilent Technologies
GC/GCMS Hardware User Manuals and Videos

S1

Disk 2/3

To install:
1. Insert disk into DVD drive
2. Follow the instructions on the screen.
3. If autoplay is not enabled, double-click
   "index_xx.html" on the DVD
    where xx is:
          en for English
          ch for 中文 
           jp for 日本語
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Chapter 1 describes the general steps you should follow to set up ECM when 
used with MassHunter GC/MS Acquisition and Quantitative Analysis running in 
the Compliance mode. It also details the differences between retrieving and 
checking out a file directly from ECM.

Details for setting up and managing ECM users, groups, roles, etc, are beyond 
the scope of this document. Those details are included in the OpenLab ECM 
Online Help. 



1. Agilent OpenLab ECM - Overview Introduction
Introduction
 

OpenLab ECM version 3.4.1 SP2 must be installed and tested prior to installing 
MassHunter. 

When using MassHunter in the Compliance mode, all regulated records are stored in ECM, 
with digital signatures being applied using ECM. 

The workstation on which MassHunter is running must be connected to an ECM server 
(version 3.4.1 SP2 or greater) and the ECM client must be installed on the workstation and 
be operational.

MassHunter GC/MS Acquisition and MassHunter Quantitative Analysis programs must 
both be configured to the same ECM database account.

Users of both MassHunter GC/MS Acquisition and Quantitative Analysis require an ECM 
user account on the ECM database account that is configured for their MassHunter 
workstation.

ECM stores user IDs and privileges that apply to the ECM database as well as to the 
MassHunter GC/MS Acquisition and Quantitative Analysis programs.

ECM user account information can be authenticated directly by ECM (Built-In) or by a 
Windows Domain server.

MassHunter GC/MS Acquisition running in the Compliance mode uses Windows security 
groups on the local MassHunter workstation to associate Windows users with MassHunter 
privileges. 

• A GC/MS Acquisition user is assigned to an ECM user group, and the group is then 
assigned to a Windows security group.

• The Agilent GCMS Configuration Editor associates MassHunter GC/MS Acquisition 
commands with these Windows security groups.

MassHunter Quantitative Analysis running in ECM Compliance mode uses roles created 
in ECM to associate users with MassHunter privileges. For MassHunter Quantitative 
Analysis: 

• A Quantitative Analysis user is assigned to an ECM user group, and the group is then 
assigned to an ECM role. 

• The MassHunter Audit Trail Map (ATM) program associates MassHunter Quantitative 
Analysis command groups to ECM roles.
10



1. Agilent OpenLab ECM - Overview Set up the ECM server
Set up the ECM server
 Follow these steps to prepare your OpenLab ECM for use with MassHunter Compliance 
mode.

Details for setting up and managing ECM users, groups, roles, etc, are beyond the scope of 
this document. Those details are included in the OpenLab Enterprise Content Manager 
Administrator's Guide. Please refer to that document for complete details. 
1. Create an ECM database account 
for MassHunter workstations.
A single ECM database account is required to allow sharing of users across 
MassHunter GC/MS Acquisition, Quantitative Analysis, and ECM. 

ECM privileges will be used to control access to database folder Locations from 
MassHunter.

MassHunter GC/MS Acquisition and MassHunter Quantitative Analysis, must both be 
configured to the same ECM database account.
2. Set up MassHunter users in 
ECM.
 

Both MassHunter GC/MS Acquisition and Quantitative Analysis require that every user be 
identified in ECM and granted ECM file privileges. 

ECM Users can be added through the ECM built in account or from your Windows Domain 
users list.
3. Create ECM user groups for 
MassHunter Quantitative 
Analysis users and add members 
to the groups.
Consider how you organization will be operating and create appropriate groups in ECM for 
Quantitative Analysis users. Then assign users to each group.

Two such groups could be: 

• Developers = Who could have access to all Quantitative Analysis commands.

• Analysts = Who could have access to just a part of the Quantitative Analysis 
commands.
4. Create ECM user groups for 
MassHunter GC/MS Acquisition 
users.
Similar to the groups you established for Quantitative Analysis users, create appropriate 
groups for the Acquisition users. Then assign users to this group. A typical group could be: 

• MassHunter GC/MS Acquisition Users.
5. Create ECM Quantitative 
Analysis roles and add 
Quantitative Analysis groups to 
these roles.
Two such roles could be:

• Developers = Who could have access to all Quantitative Analysis privileges. See 
“Sample ECM Developer Role for Quantitative Analysis” on page 12.

• Analysts = Who could have access to just a part of the Quantitative Analysis 
commands. See “Sample ECM Analyst Role for Quantitative Analysis” on page 13.
11



1. Agilent OpenLab ECM - Overview Set up the ECM server
6. Assign the built in ECM 
Contributor role to both 
MassHunter GC/MS Acquisition 
and MassHunter Quantitative 
Analysis users or groups.
In addition to assigning users to the custom roles (such as Developer and Analyst), also 
include them in the built-in ECM role entitled:Contributor. The Contributor role contains 
ECM privileges such as: 

• File reading

• File Creation

• File retrieving
Sample ECM Developer Role for 
Quantitative Analysis
 

This role could allow a developer access to all the Quantitative Analysis commands.
12



1. Agilent OpenLab ECM - Overview Install the ECM Workstation Client
Sample ECM Analyst Role for 
Quantitative Analysis
This role could allow the analyst access to all commands except those required for editing 
the Quantitation method.
 

Install the ECM Workstation 
Client
After the ECM server is installed and accessible over a network from the MassHunter 
workstation, you can install the ECM workstation client as described below.
1. Gather the following from the 
ECM server Administrator.
Record your details here for future reference, if desired.

Item Typical Value Your Values

ECM Server URL http://ECMServerName/ecm

ECM Username UserName

ECM Password *************

ECM Account ABCD

Domain Local or Domaina

a. If you do not have a corporate domain, ECM supports a “Built-in” domain.

ECM LCDF location GCMSb

b. In ECM file system terminology, this could be an L, LC, LCD, or LCDF depending on your ECM storage 
structure.
2. From Internet Explorer, go to the 
ECM server URL.
An ECM Login screen is displayed.
13
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1. Agilent OpenLab ECM - Overview Install the ECM Workstation Client
3. Enter a valid user name, 
password, account, and domain 
provided by the ECM account 
Administrator, and click Login. 
4. ECM Components are 
downloaded.
 

The first time you access the ECM server from the computer where your MassHunter 
workstation is installed, the ECM server will download and install the following components 
onto the MassHunter workstation:

• Agilent OpenLab ECM API

• Agilent OpenLab ECM Client

• Agilent OpenLab ECM Resources

We recommend you do not install the ECM Scheduler or ECM Cyberprinter because the 
MassHunter GCMS Acquisition software is not tested with these components.
5. To complete the installation, 
restart your machine.
14



1. Agilent OpenLab ECM - Overview Test User’s ECM Credentials
Test User’s ECM Credentials
 To verify file access rights are properly configured in both Windows and ECM, have each 
user do the following before attempting to log in to MassHunter. 
1. Log into the workstation.

2. Open Internet Explorer and go to 
the ECM URL.

3. Create a folder within their 
assigned ECM environment.

4. Upload a file to their assigned 
ECM environment.
Retrieve Versus Checkout
 

When users log into ECM directly from Internet Explorer, they may, depending on their 
privilege, be able to retrieve or checkout a file.

• Retrieved files are not locked in ECM. 
The file in ECM is still available to anyone else.

• Checked out files are locked in ECM. 
Only the individual who checked out the file can check the file back in to ECM, or undo 
the Checkout. However, with appropriate permissions, users may retrieved a copy of a 
checked out file.
Important!
 Please remember that users can access and check out files from ECM in two ways: 

• By logging in to ECM via Internet Explorer

• By logging in to ECM via MassHunter

Regardless of how a user accesses ECM, files that are checked out of ECM remain 
unavailable to MassHunter until they are checked back in to ECM, or the checkout is 
canceled. A batch file that is checked out can be accessed as Read-Only. 

If a file is checked out by anyone, and MassHunter GC/MS Acquisition attempts to load 
that file, a message similar to the following is displayed. 

In MassHunter GC/MS Acquisition, files (methods, sequences, and mass spectral data) 
are automatically checked in to ECM.

Files downloaded from ECM by GC/MS Acquisition (e.g., methods and sequences) are 
retrieved, by default. They are not checked out and locked. 
15



1. Agilent OpenLab ECM - Overview Retrieve Versus Checkout
To retrieve a file:

1. Add the ECM server to the list of 
Trusted Sites in Internet Explorer 
on your workstation.
In Internet Explorer, select Tools > Internet Options > Security > Trusted Sites > Sites. In 
the window that appears, uncheck Require server verification (https:) for all sites in this 
zone. In the Add websites to the zone: field, type the URL for your ECM server and click 
Add. Click Close > OK. Restart Internet Explorer to apply the changes.
2. Access the file in OpenLab ECM 
Explorer via Internet Explorer. 

3. Right-click and select Retrieve.

4. Navigate to the designation 
folder and click OK. 
 

• The file is copied to your selected destination. 

• The file in ECM is still available to anyone else.

See your ECM documentation for more complete details on using the checkout option in 
ECM. 
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Chapter 2 describes how to install MassHunter GC/MS Acquisition in 
Compliance mode, depending on which version is currently installed. It then 
details how to assign users to Windows security groups and configure 
instruments and settings.



2. MassHunter GC/MS Acquisition - Setup and Configuration Review the Installation and Setup Steps
Review the Installation and 
Setup Steps

1. Verify the prerequisites.
 Before installing MassHunter GC/MS Acquisition in Compliance mode, ensure: 

• The LAN is an Agilent supported LAN (page 81) layout.

• You are logged on with Local Windows Workstation Administrator credentials.

• The PC is running under Windows 7 Professional SP1 (64-bit).

• The standalone ECM (3.4.1 SP2) server is operational.

• Agilent OpenLab ECM - Overview (Page 9) has been set up for MassHunter GC/MS 
Acquisition and MassHunter Quantitative Analysis.

• The ECM client (page 13) has been installed on the MassHunter workstation.
2. Select your installation type, and 
Install MassHunter GC/MS 
Acquisition.
 

NOTE: Details for installing MassHunter GC/MS Acquisition are included in the Agilent 
MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide.

The instructions here provide general guidance only. Please refer to the above document 
for complete installation details.

There are three general conditions under which you may be installing MassHunter GC/MS 
Acquisition in Compliance mode. See the pages listed below for details on your particular 
setup.

• The workstation has no previous version of MassHunter GC/MS Acquisition Installed 
(page 24).

• The workstation has MassHunter GC/MS Acquisition installed in the Standard 
Workflow mode (page 25).

• The workstation has MassHunter GC/MS Acquisition installed in the User Management 
and Audit Trail mode (page 26).
3. Review Windows security groups 
and privileges.
During installation, MassHunter GC/MS Acquisition created four Windows security groups:

• Acquisition Analysts I

• Acquisition Analysts II

• Acquisition Analysts III

• Acquisition Managers

Each of these groups has a different set of access privileges (called Roles and 
Responsibilities).

• The highest level group is Manager. This group has access to all privileges. Each lower 
level group has a subset of the privileges of the next higher level. 

• The lowest level group is Analyst I.
18



2. MassHunter GC/MS Acquisition - Setup and Configuration Review the Installation and Setup Steps

 

Before assigning users to groups, review the default privileges assigned to each group and 
edit the privileges, if required, for your organization. 

See “MassHunter Acquisition Windows Security Groups” on page 73. 

See “Change Group Privileges” on page 79 for details on how to change these settings.

MassHunter GC/MS Acquisition also created a new user "GCMSCFR11" as part of the 
local administrator group. This user has the needed windows privileges to run the 
MassHunter GC/MS Acquisition application, and the Configuration Editor. Task manager 
here shows that the user GCMSCFR11 is running the msinsctl.exe (MassHunter GC/MS 
Acquisition) program. 
19



2. MassHunter GC/MS Acquisition - Setup and Configuration Review the Installation and Setup Steps
4. Assign each user to a group. 
After reviewing the four MassHunter GC/MS Acquisition Windows security groups, assign 
each user to one of the groups.

See “Assign Users to a Windows security group” on page 22 for details on how to do this. 

REMEMBER: Before a user can access MassHunter GC/MS Acquisition, they must:

• Be assigned to one of the four MassHunter Windows security groups. (page 22) The 
userID and Password must be the same as those set up for this user in ECM.

• Have a valid ECM user account. Refer to your ECM documentation for details on how to 
set up ECM user accounts.

If either one of these two requirements is missing, users will not be able to access MassHunter 
GC/MS Acquisition.
5. Configure one instrument. 
After you have installed the ECM components and MassHunter GC/MS Acquisition on 
your workstation, you may configure one instrument. See “Configure an Instrument” on 
page 27 for details.
6. Create the initial LCDF structure.
 

After configuring ECM on the ECM server, and downloading the ECM components to the 
workstation, the first time you login to MassHunter GC/MS Acquisition as the 
Administrator, you will be presented with a series of screens to identifying the ECM server 
path for your Data, Methods, Sequences, Tune Evaluations, and Air and Water reports.

This first screen identifies where in ECM your Data will be saved. This will be followed by a 
screen for methods, sequences, tune evaluations, and air and water.

• To accept the default and continue, click OK. If the path is not already set up in ECM, 
the system will set it up now and display the next screen. This may take several seconds.

• To create a new Cabinet, Directory or Folder in ECM, and click Browse to access ECM 
and create the path.
7. Tune the instrument.
 At the completion of the wizard, tune the instrument. Initializing the instrument will have 
overwritten the default tune, atune, etune, etc.
20



2. MassHunter GC/MS Acquisition - Setup and Configuration Review the Installation and Setup Steps
8. Configure MassHunter GC/MS 
Acquisition.
To complete your installation process, access the Configuration Editor, and:

• Configure an instrument (page 27)

• Set the User Password Reset interval (page 28)

• Set the Idle Timeout interval for MassHunter GC/MS Acquisition (page 29)

• Review Roles and Responsibilities (page 73)

• Enable/Disable Audit Reasons (page 56)

• Edit the Pre-defined "Reason for Change" List (page 57)
9. Assign users to a Windows 
security group.
 

The privileges each user has in MassHunter GC/MS Acquisition are based on the 
Windows security group to which they have been assigned. After you have reviewed the 
roles and responsibilities associated with these groups, assign each MassHunter GC/MS 
Acquisition user to one of the groups. See “Assign Users to a Windows security group” on 
page 22.

• To review the default privileges, see “MassHunter Acquisition Windows Security 
Groups” on page 73.

• See “Change Group Privileges” on page 79 for details on how to change these defaults.
21



2. MassHunter GC/MS Acquisition - Setup and Configuration Assign Users to a Windows security group
Assign Users to a Windows 
security group

1. Click Start then type edit local 
and press Enter.
 

2. The Local Users and Groups 
dialog displays. Double-click 
groups.


22



2. MassHunter GC/MS Acquisition - Setup and Configuration Assign Users to a Windows security group
3. To add local or domain users to 
the Acquisition Groups, double-
click the group to which the user 
needs to be added, and click add. 
• If adding a domain user and the domain is not shown in From this location, click 
Locations and select the domain name.

• If adding a local user and the workstation is not shown in From this location, click 
Locations and select the workstation name.
 

4. Enter the user id and click Check 
Names. If the user id entered is 
correct, then click OK. In this 
example, the updated user name 
would be under the Acquisition 
Managers properties.


5. Click Apply to update the page.
 
23



2. MassHunter GC/MS Acquisition - Setup and Configuration Installation where no previous version of 
Installation where no 
previous version of 
MassHunter GC/MS 
Acquisition is installed
NOTE: Details for installing MassHunter GC/MS Acquisition are included in the Agilent 
MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. The instructions here provide general guidance only. Please refer to the 
above document for complete installation details.

There are three general conditions under which you may be installing MassHunter GC/MS 
Acquisition in Compliance mode. See the pages listed below for details on your particular 
setup.

• The workstation has no previous version of MassHunter GC/MS Acquisition Installed 
(shown below, on this page) (page 24).

• The workstation has MassHunter GC/MS Acquisition installed in the Standard 
Workflow mode (page 25).

• The workstation has MassHunter GC/MS Acquisition installed in the User Management 
and Audit Trail mode (page 26).

To install MassHunter GC/MS Acquisition B.07.03 in the Compliance mode on a 
workstation that has no previous version of MassHunter GC/MS Acquisition installed: 
1. Insert the DVD and follow the 
prompts to access this screen. 
 

2. Select Activate Compliance, and 
click Next to continue.











3. During the installation of 
MassHunter GC/MS Acquisition, 
you may be prompted to install or 
update some Windows 
components and reboot your PC.
 After you reboot and log in to your PC, the Installation wizard will proceed to complete the 
installation of the required Windows components.
24



2. MassHunter GC/MS Acquisition - Setup and ConfigurationInstallation where MassHunter GC/MS Acquisition 
Installation where 
MassHunter GC/MS 
Acquisition is installed in 
the Standard Workflow 
mode
NOTE: Details for installing MassHunter GC/MS Acquisition are included in the Agilent 
MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. The instructions here provide general guidance only. Please refer to the 
above document for complete installation details.

There are three general conditions under which you may be installing MassHunter GC/MS 
Acquisition in Compliance mode. See the pages listed below for details on your particular 
setup.

• The workstation has no previous version of MassHunter GC/MS Acquisition Installed 
(page 24).

• The workstation has MassHunter GC/MS Acquisition installed in the Standard 
Workflow mode (shown below, on this page) (page 25).

• The workstation has MassHunter GC/MS Acquisition installed in the User Management 
and Audit Trail mode (page 26).

If MassHunter GC/MS Acquisition B.07.03 is already installed on your workstation in the 
Standard Workflow mode, you may use this procedure to activate the MassHunter GC/MS 
Acquisition B.07.03 Compliance mode. 

Note: If MassHunter GC/MS Acquisition was pre-installed on your Agilent supplied 
workstation at the factory, it will be in the Standard Workflow mode. 
 
1. From the Control Panel, select 
Programs and Features.

2. Select Agilent MassHunter GC/
MS Acquisition and click 
Change.
3. Select Activate Compliance and 
click next.
4. Follow the installer program 
prompts to complete the process.
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2. MassHunter GC/MS Acquisition - Setup and ConfigurationInstallation where MassHunter GC/MS Acquisition 
Installation where 
MassHunter GC/MS 
Acquisition is installed in 
the User Management and 
Audit Trail mode
NOTE: Details for installing MassHunter GC/MS Acquisition are included in the Agilent 
MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. The instructions here provide general guidance only. Please refer to the 
above document for complete installation details.

There are three general conditions under which you may be installing MassHunter GC/MS 
Acquisition in Compliance mode. See the pages listed below for details on your particular 
setup.

• The workstation has no previous version of MassHunter GC/MS Acquisition Installed 
(page 24).

• The workstation has MassHunter GC/MS Acquisition installed in the Standard 
Workflow mode (page 25).

• The workstation has MassHunter GC/MS Acquisition installed in the User Management 
and Audit Trail mode (shown below, on this page) (page 26).

MassHunter GC/MS Acquisition Compliance cannot be activated on a workstation that 
currently has MassHunter GC/MS Acquisition installed in the User Management and Audit 
Trail mode.
 

To activate the Compliance mode, 
uninstall the current version then, 
insert the MassHunter GC/MS 
Acquisition B.07.03 installation disk 
and select Activate Compliance 
during the re-installation procedure. 
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2. MassHunter GC/MS Acquisition - Setup and Configuration Configure an Instrument
Configure an Instrument
 After you have installed ECM on the server, downloaded ECM components to the 
workstation, and installed MassHunter GC/MS Acquisition B.07.03 in Compliance mode, 
you may configure one instrument.
1. Login to your workstation with 
Windows Administrator 
privileges.
2. Double-click the Configuration 
Editor Icon.
3. Provide a valid user name and 
password, and click Login.
 

4. Complete the configuration for 
your instrument as applicable.
Notice that, because you have 
installed MassHunter GC/MS 
Acquisition in the Compliance 
mode, the Regulated Workflow 
Mode is selected in the 
configuration editor. This cannot 
be changed.
5. Click OK to complete the 
configuration. Your configured 
instrument may look similar to 
this in the Configuration Editor. 
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2. MassHunter GC/MS Acquisition - Setup and Configuration Set the Password Reset Interval
Set the Password Reset 
Interval
To set or modify the interval required for users to reset their password: 
1. In the Configuration Editor, select 
Configure > Specify Secured 
User Password Reset.
2. Enter the number of days after 
which the password must be 
changed, and press OK. 
 

28



2. MassHunter GC/MS Acquisition - Setup and Configuration Set the Idle Timeout Interval
Set the Idle Timeout Interval
 Part of the requirements of FDA CFR21 Part 11 is that unattended workstations should 
automatically lock. For MassHunter GC/MS Acquisition that timeout interval is set in the 
Configuration Editor. 

If MassHunter GC/MS Acquisition detects no activity from the current user for a specified 
time, it will automatically lock the system and display the MassHunter GCMS Account 
Login dialog.

Once MassHunter GC/MS Acquisition is locked, any user with a valid UserID and 
Password may log into the system and unlock it. The menu items available are those 
permitted to the user that unlocks MassHunter GC/MS Acquisition.
To modify the inactivity timeout interval: 

1. In the Configuration Editor, select 
Configure > Specify Idle 
Timeout interval.
 

2. Enter the time, in minutes, you 
wish to use for the idle timeout 
interval, and press OK. 
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2. MassHunter GC/MS Acquisition - Setup and Configuration Set the Idle Timeout Interval
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3
MassHunter GC/MS Acquisition - 
Routine Tasks

Manually Lock and Switch Users    32

Review User Access Privileges    32

Understand ECM Storage Locations and File Types    33

Save and Retrieve Data, Methods, and Sequence Files    34

Change the ECM Storage Locations    35

Test the Communication with the ECM Server    36

View the Current LCDF path to the ECM Server    37

Open the ECM Server via Internet Explorer    38

Import a Method from a Location Outside the ECM Server    39

Chapter 3 describes routine tasks performed in MassHunter GC/MS Acquisition 
in Compliance mode. 



3. MassHunter GC/MS Acquisition - Routine Tasks Manually Lock and Switch Users
Manually Lock and Switch 
Users
MassHunter GC/MS Acquisition defers the electronic signatures of records to an ECM 
activity. Therefore, the operator doesn't have to sign every record. However, it is the 
operator's responsibility to manually lock the MassHunter GC/MS Acquisition program 
each time they walk away from the workstation.
1. To manually lock MassHunter 
GC/MS Acquisition, click the 
Lock and Switch User icon. 
The system displays a login box with the cancel button disabled. 
2. When a valid UserID and 
Password are entered, the 
system resets the MassHunter 
GC/MS Acquisition allowed 
operations to those assigned to 
the windows security group that 
the logged in user is a member.
 

The only way to unlock MassHunter GC/MS Acquisition is to login with valid user 
credentials.
Review User Access 
Privileges
When using MassHunter GC/MS Acquisition in the Compliance mode, menu options that 
are displayed to each user are based on the user's access privileges. For MassHunter GC/
MS Acquisition, those privileges are control by the Windows security group to which they 
are assigned. 

See “MassHunter Acquisition Windows Security Groups” on page 73… for the default 
settings of menu items available to each group.

See “Change Group Privileges” on page 79 for details on how to change these defaults. 
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3. MassHunter GC/MS Acquisition - Routine Tasks Understand ECM Storage Locations and File Types
Understand ECM Storage 
Locations and File Types
 

When using MassHunter GC/MS Acquisition in the Compliance mode, all regulated 
records are stored in ECM, with digital signatures being applied using ECM. 

Default settings will look similar to this structure, however, your ECM administrator can 
modify this as needed for your organization. 
• L = Location, identifies the physical place where file cabinets are stored 
• C = A file Cabinet 
• D = Contains Drawers
• F = Inside the Drawers are Folders 
• F = Inside the Folders are Files

 

 
Location
Cabinet
Drawer
Folder

Files saved to ECM from MassHunter GC/MS Acquisition may include the following files 
types:
• Data (.D.SSIZIP) 
• Method (.M.SSIZIP) 
• Sequence (.XML.ZIP) 
• Tune (.CSV) 
• Air Water (.CSV) 
• Tune Evaluation (.CSV) 

Data files (.D.SSIZIP) include a zipped version of the data folder with all its contents 
(including a audit-trail log file if one exists) in a single compressed file.

Method files (.M.SSIZIP) include all method components, including the method's 
cumulative audit-trail log if one exists, in a single compressed file.

Sequence files (.XML.Zip) includes the sequence dataset file and the cumulative audit-trail 
log file (if one exists) in a single compressed file.
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3. MassHunter GC/MS Acquisition - Routine Tasks Save and Retrieve Data, Methods, and Sequence Files
Save and Retrieve Data, 
Methods, and Sequence 
Files
 

Access to Method and Sequence files (while operating in the Compliance mode) is through 
standard Load and Save menus. For example:

• To Load a Method, select Method > Load Method

• To Save a Method, select Method > Save Method

• To Save a Method as a different mane, select Method > Save Method As...

• To Load a Sequence, select Sequence > Load Sequence

• To Save a Sequence, select Sequence > Save Sequence

• To Save a Sequence as a different mane, select Sequence > Save Sequence As...

When data, methods, and sequences are stored in ECM, all the associated data is 
packaged together in a single file with a SSIZIP extension.

This file type is a standard ZIP file and can be extracted with standard unzip applications. 

When you save a file to ECM or retrieve a file from ECM the packaging and un-packaging of 
the files is automatically handled for you.
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3. MassHunter GC/MS Acquisition - Routine Tasks Change the ECM Storage Locations
Change the ECM Storage 
Locations 

1. Select ECM > Review/Change 
ECM Preferences.
2. Select the folder you wish to 
change, and click OK.
 

3. Modify the path as required and 
click OK.
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3. MassHunter GC/MS Acquisition - Routine Tasks Test the Communication with the ECM Server
Test the Communication 
with the ECM Server
The ECM diagnostic option allows you to check your connection to OpenLab ECM by 
uploading a test file to ECM and reporting the results in a dialog to you.
1. Select ECM > ECM Diagnostic.
2. At the prompt, enter the number 
of times you wish to test the 
connection (10, for example), and 
click OK.
 

The system attempts to upload and download a test file the number of times specified (e.g., 
10 in this example), and reports the results of the test in a dialog. 
3. Review the test results in the 
bottom line of the instrument 
control screen.
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3. MassHunter GC/MS Acquisition - Routine Tasks View the Current LCDF path to the ECM Server
View the Current LCDF path 
to the ECM Server

1. Select ECM > Report ECM 
Configuration.
2. Review the path shown.
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3. MassHunter GC/MS Acquisition - Routine Tasks Open the ECM Server via Internet Explorer
Open the ECM Server via 
Internet Explorer

1. Select ECM > Run ECM 
Explorer.
2. View the ECM server from 
Internet Explorer.
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3. MassHunter GC/MS Acquisition - Routine TasksImport a Method from a Location Outside the ECM Server
Import a Method from a 
Location Outside the ECM 
Server

1. Select Method > Import Method 
components from another 
method…
 
2. Navigate to and select the 

desired file.
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3. MassHunter GC/MS Acquisition - Routine TasksImport a Method from a Location Outside the ECM Server
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MassHunter Quantitative Analysis - 
Setup and Configuration

Review the Installation and Setup Steps    42

Installation where there was no previous version of MassHunter 
Quantitative Analysis    43

Installation where MassHunter Quantitative Analysis B.07.01 is installed 
in the Standard Workflow mode    44

Installation where MassHunter Quantitative Analysis B.07.01 is installed 
in the User Management and Audit Trail mode    45

Installation where an older version of MassHunter Quantitative Analysis 
is installed (pre B.07.01)    46

Associate ECM Roles to MassHunter Quantitative Analysis Command 
Groups    47

Chapter 4 provides general guidance on how to install and set up MassHunter 
Quantitative Analysis depending on which version is currently installed. It then 
details how to associate ECM roles with MassHunter Quantitative Analysis 
individual commands and command groups.



4. MassHunter Quantitative Analysis - Setup and Configuration Review the Installation and Setup Steps
Review the Installation and 
Setup Steps

1. Verify the prerequisites.
 Before installing MassHunter Quantitative Analysis in ECM Compliance mode verify the 
following: 

• The LAN layout is supported by Agilent.

• You have local Windows workstation administrator credentials.

• The workstation is running Windows 7 Professional SP1 (64-bit) or Windows 10.

• The standalone ECM (3.4.1 SP2 or newer) server is operational.

• The ECM client is installed on the MassHunter workstation.
2. Select your installation type, and 
Install MassHunter Quantitative 
Analysis.
 

NOTE: The installation of MassHunter Quantitative Analysis is covered in detail in the 
Agilent MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. Refer to that document for complete details. This section is intended to 
provide general guidance only.

There are four general conditions under which you may be installing MassHunter 
Quantitative Analysis in the Compliance mode. Each of these cases is described on the 
pages indicated below:

• The Workstation has no previous installation of MassHunter Quantitative Analysis 
(page 43)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in Standard 
Workflow mode. (page 44)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in the User 
Management and Audit Trail mode. (page 45)

• The Workstation has a version of MassHunter Quantitative Analysis that pre-dates 
B.07.01. (page 46)
3. Associate ECM Roles with 
MassHunter Quantitative 
Analysis Roles (Command 
Groups).
Before anyone can access MassHunter Quantitative Analysis:

• They must have a valid ECM user account that is associated to an ECM role. (Refer to 
your ECM documentation for details on how to set up ECM user accounts).

• ECM roles can contain MassHunter Quantitative Analysis commands. Quantitative 
Analysis commands are associated with ECM roles in ECM or in the Quantitative 
Analysis ATM Configuration program.

See “Associate ECM Roles to MassHunter Quantitative Analysis Command Groups” on 
page 47 for details.
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4. MassHunter Quantitative Analysis - Setup and ConfigurationInstallation where there was no previous version of 
Installation where there 
was no previous version of 
MassHunter Quantitative 
Analysis
NOTE: The installation of MassHunter Quantitative Analysis is covered in detail in the 
Agilent MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. Refer to that document for complete details. This section is intended to 
provide general guidance only. 

There are four general conditions under which you may be installing MassHunter 
Quantitative Analysis in the Compliance mode. Each of these cases is described on the 
pages indicated below:

• The Workstation has no previous installation of MassHunter Quantitative Analysis 
(shown below on this page) (page 43)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in Standard 
Workflow mode. (page 44)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in the User 
Management and Audit Trail mode. (page 45)

• The Workstation has a version of MassHunter Quantitative Analysis that pre-dates 
B.07.01. (page 46)

If the Workstation has no previous version of MassHunter Quantitative Analysis 
installed: 
 

1. Insert the DVD and follow the 
prompts to access this screen. 

2. Select Activate Compliance, and 
click Next to continue.
3. During the installation, you may 
be prompted to install or update 
some Windows components and 
reboot your PC. After you reboot 
and log in to your PC, the 
Installation Wizard will proceed 
to complete the installation of the 
required Windows components.

4. If Report Templates were copied 
to the workstation, upload them 
from the workstation to a 
location in ECM that MassHunter 
Quantitative Analysis users will 
be able to access.
Report templates used must be from the same version of MassHunter Quantitative 
Analysis that is being used.

Remember: Upload the report templates from your local drive to ECM.
43



4. MassHunter Quantitative Analysis - Setup and Configuration Installation where MassHunter Quantitative 
Installation where 
MassHunter Quantitative 
Analysis B.07.01 is installed 
in the Standard Workflow 
mode
 

NOTE: The installation of MassHunter Quantitative Analysis is covered in detail in the 
Agilent MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. Refer to that document for complete details. This section is intended to 
provide general guidance only. 

There are four general conditions under which you may be installing MassHunter 
Quantitative Analysis in the Compliance mode. Each of these cases is described on the 
pages indicated below:

• The Workstation has no previous installation of MassHunter Quantitative Analysis 
(page 43)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in Standard 
Workflow mode (shown below on this page). (page 44)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in the User 
Management and Audit Trail mode. (page 45)

• The Workstation has a version of MassHunter Quantitative Analysis that pre-dates 
B.07.01. (page 46)

If MassHunter Quantitative Analysis B.07.01 is already installed on your workstation in the 
Standard Workflow mode, you may use this procedure to activate the MassHunter 
Compliance mode. 

Note: If MassHunter Quantitative Analysis was pre-installed on your Agilent supplied 
Workstation at the factory, it will be in the Standard Workflow mode. 
1. Click Control Panel > Start and 
enter Programs and Features.

2. Select Agilent MassHunter 
Quantitative Analysis and click 
Change.
3. Click Change.

4. Select Activate Compliance.

5. Continue to follow the prompts. 

6. If Report Templates were copied 
to the workstation, upload them 
from the workstation to a 
location in ECM that Quantitative 
Analysis will have access.
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4. MassHunter Quantitative Analysis - Setup and Configuration Installation where MassHunter Quantitative 
Installation where 
MassHunter Quantitative 
Analysis B.07.01 is installed 
in the User Management 
and Audit Trail mode
 

NOTE: The installation of MassHunter Quantitative Analysis is covered in detail in the 
Agilent MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. Refer to that document for complete details. This section is intended to 
provide general guidance only. 

There are four general conditions under which you may be installing MassHunter 
Quantitative Analysis in the Compliance mode. Each of these cases is described on the 
pages indicated below:

• The Workstation has no previous installation of MassHunter Quantitative Analysis 
(page 43)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in Standard 
Workflow mode. (page 44)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in the User 
Management and Audit Trail mode (shown below on this page). (page 45)

• The Workstation has a version of MassHunter Quantitative Analysis that pre-dates 
B.07.01. (page 46)

MassHunter Compliance cannot be activated on a workstation that currently has 
MassHunter Quantitative Analysis B.07.01 installed in the User Management and Audit 
Trail mode. To activate the Compliance mode, uninstall the current version then, reinstall 
version B.07.01 and select Activate Compliance during the installation procedure. 

If Report Templates were copied to the workstation, upload them from the workstation to a 
location in ECM that Quantitative Analysis will have access.
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4. MassHunter Quantitative Analysis - Setup and ConfigurationInstallation where an older version of MassHunter 
Installation where an older 
version of MassHunter 
Quantitative Analysis is 
installed (pre B.07.01)
 

NOTE: The installation of MassHunter Quantitative Analysis is covered in detail in the 
Agilent MassHunter Workstation Offline Qualitative and Quantitative Analysis for GCMS 
Installation Guide. Refer to that document for complete details. This section is intended to 
provide general guidance only. 

There are four general conditions under which you may be installing MassHunter 
Quantitative Analysis in the Compliance mode. Each of these cases is described on the 
pages indicated below:

• The Workstation has no previous installation of MassHunter Quantitative Analysis 
(page 43)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in Standard 
Workflow mode. (page 44)

• The Workstation has MassHunter Quantitative Analysis B.07.01 installed in the User 
Management and Audit Trail mode. (page 45)

• The Workstation has a version of MassHunter Quantitative Analysis that pre-dates 
B.07.01 (shown below on this page). (page 46)

MassHunter Compliance is not supported in versions prior to B.07.01. If you have a version 
of MassHunter Quantitative Analysis that is earlier than B.07.01, uninstall that version and 
install version B.07.01 or higher, and select Activate Compliance when prompted during 
installation. 

If Report Templates were copied to the workstation, upload them from the workstation to a 
location in ECM that Quantitative Analysis will have access.
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4. MassHunter Quantitative Analysis - Setup and ConfigurationAssociate ECM Roles to MassHunter Quantitative 
Associate ECM Roles to 
MassHunter Quantitative 
Analysis Command Groups
Access privileges for MassHunter Quantitative Analysis are controlled through the Audit 
Trail Map (ATM) program. The following describes how to associate ECM roles to 
MassHunter Quantitative Analysis roles using the Audit Trail Map (ATM) program.
1. Start the Audit Trail Map (ATM) 
program.
2. Enter ECM system administrator 
credentials.
 

3. Notice the four MassHunter 
Quantitative Analysis Roles 
(Command Groups) and ECM 
roles.

See “Overview” on page 74 for a 
complete listing of the 
commands in each group.




MassHunter Quantitative Analysis Roles

ECM Roles
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4. MassHunter Quantitative Analysis - Setup and ConfigurationAssociate ECM Roles to MassHunter Quantitative 
4. Select the Batch Analysis 
command group or select 
individual commands under 
Batch Analysis, and enable the 
ECM roles that should be allowed 
these privileges (e.g., Analyst and 
Developer). 
 

Users assigned to this role may create a batch, review the results of a batch, integrate and 
quantitate the results, and print batch reports.

Click the arrow in front of Batch Analysis to display the full list of commands associated 
with this role.

Click the arrow once again to return to the previous view.
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4. MassHunter Quantitative Analysis - Setup and ConfigurationAssociate ECM Roles to MassHunter Quantitative 
5. Select the Method Development 
command group or select 
individual commands under 
Method Development, and 
enable the ECM roles that should 
be allowed these privileges (e.g., 
Developer).
Users assigned this role may run all the commands in the Method Development command 
group. For example, they may create, modify, delete, and save methods.
6. Select the Batch Review 
command group or select 
individual commands under 
Batch Review, and enable the 
ECM roles that should be allowed 
these privileges (e.g., Analyst and 
Developer).
Users assigned this role may open and review a batch.
 

7. Select the Report command 
group or select individual 
commands under Report, and 
enable the ECM roles that should 
be allowed these privileges (e.g., 
Analyst and Developers).
Users assigned this role may generate reports.
8. Select File > Save to save your 
changes before exiting ATM.
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4. MassHunter Quantitative Analysis - Setup and ConfigurationAssociate ECM Roles to MassHunter Quantitative 
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5
MassHunter Quantitative Analysis - 
Routine Tasks

Review User Access Privileges    52

Understand ECM Storage Locations and File Types    52

Access Files from Quantitative Analysis    53

Add Quantitative Analysis Report Templates to ECM    53

Chapter 5 describes routine tasks performed in MassHunter Quantitative 
Analysis in Compliance mode. 



5. MassHunter Quantitative Analysis - Routine Tasks Review User Access Privileges
Review User Access 
Privileges
When using MassHunter Quantitative Analysis Compliance software, menu options that 
are displayed to each user are based on the user's role assignment in ECM.

The ECM roles are then assigned to Quantitative Analysis individual commands or 
command groups in the Quantitative Analysis ATM program. A Users privileges in the 
Quantitative Analysis program are limited to the ATM command groups to which their ECM 
role is assigned.

See “Associate ECM Roles to MassHunter Quantitative Analysis Command Groups” on 
page 47 for details on changing privileges for a user in the Quantitative Analysis program.
Understand ECM Storage 
Locations and File Types
 

All regulated records are stored in ECM, with digital signatures being applied using ECM. 

Default settings will look similar to this structure, however, your ECM administrator can 
modify this as needed for your organization. 

• L = Location, identifies the physical place where file cabinets are stored 

• C = A file Cabinet 

• D = Contains Drawers

• F = Inside the Drawers are Folders 

• F = Inside the Folders are Files

Files saved to ECM may include the following files types:
• Data (.D.SSIZIP) 
• Method (.M.SSIZIP, .quantmethod.xml) 
• Batch (batch.bin.ssizip)
• Libraries (.L.SSIZIP, mslibrary.xml, reflibrary.xml)

Data files (.D.SSIZIP) include a zipped version of the data folder with all its contents 
(including a audit-trail log file if one exists) in a single compressed file.

Method files (.M.SSIZIP, .quantmethod.xml) include all method components, including the 
method's cumulative audit-trail log if one exists, in a single compressed file.

The .SSIZIP file type is a standard ZIP file and can be extracted with standard unzip 
applications. 
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5. MassHunter Quantitative Analysis - Routine Tasks Access Files from Quantitative Analysis
Access Files from 
Quantitative Analysis
Access to files (while operating in Compliance) is through standard menus. For example:

• To create a new Batch, select File > New Batch

• To Save a Batch, select File > Save Batch

• To generate a report, select File > Generate

When you save a file to ECM or retrieve a file from ECM the packaging and un-packaging of 
the .SSIZIP files is automatically handled for you.
Add Quantitative Analysis 
Report Templates to ECM

1. Open Internet Explorer and go to 
the ECM URL.
See your ECM administrator or the ECM Online help for information on the ECM privileges 
required to perform this procedure.
2. Create the LCDF structure 
required by your organization, 
such as the example shown here.
 

To use report templates for Quantitative Analysis, users must have access to the ECM 
location where the templates are stored.

See “Associate ECM Roles to MassHunter Quantitative Analysis Command Groups” on 
page 47 for details on changing privileges for a user in the Quantitative Analysis program

.
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5. MassHunter Quantitative Analysis - Routine Tasks Add Quantitative Analysis Report Templates to ECM
3. Add the report templates to the 
ECM folders.
 

See the ECM Online help for details on adding files including installing and using the Send 
To > Agilent OpenLab ECM menu.
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Audit Trails

GC/MS Acquisition - Enable/Disable Audit Reasons    56

GC/MS Acquisition - Edit the Pre-defined “Reason for Change” List    57

GC/MS Acquisition - View Instrument Audit Trail    58
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Chapter 6 describes how to view or print audit-trail logs and how to enable or 
disable the audit reasons shown in logs in both MassHunter GC/MS Acquisition 
and Quantitative Analysis.



6. Audit Trails GC/MS Acquisition - Enable/Disable Audit Reasons
GC/MS Acquisition - 
Enable/Disable Audit 
Reasons
Depending on how you configure MassHunter GC/MS Acquisition, each time a user 
initiates an action which may result in modification to a sequence file, method file, or 
instrument configuration, they may be prompted for a reason for that modification. The 
reasons they enter are recorded in the audit-trail log.

With this feature enabled, when a user modifies a regulated record they will be prompted 
for a reason for the change. The user may then: 

• Select a reason from a pre-defined list of reasons. 
(There are three separate pre-defined lists; one for Methods, one for Sequences, and 
one for Instrument Configurations.)

• Enter a custom reason as free-form text. The length of the free-form text will be limited 
only by available system resources.

With this feature disabled, when a user modifies a regulated record, the date, time, and 
user's name of the change is still recorded; however, the reason for the change (the 
description column) is left blank.
To enable or disable this feature:
1. Access the Configuration Editor.
2. Select: Audit Trail > Enable/
Disable Audit Reasons.
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6. Audit Trails GC/MS Acquisition - Edit the Pre-defined “Reason for Change” List
GC/MS Acquisition - 
Edit the Pre-defined 
“Reason for Change” List
If the Audit Reasons feature is enabled, when a user modifies a method, sequence, or 
instrument configuration, he will be prompted for a reason for the change. He can then:
• Select a reason from a pre-defined list of reasons, or
• Enter a custom reason as free-form text. 

There are three separate pre-defined lists, one for:
• Method changes
• Sequence changes
• Instrument Configuration changes
To modify one of these pre-defined 
lists: 
1. In the Configuration Editor, select 

Audit Trail > (Manage Method 
Audit Reason lists), (Manage 
Sequence Audit Reason lists), 
or (Manage Instrument Audit 
Reason Lists).
2. To edit or delete an item: 
 

a Select the pre-defined reason you want to edit or delete, and click Edit/Clear. 

b Edit the pre-defined text or clear the text shown to delete the reason, and click OK.
3. To add a new item to the list: 
a Click New.

b Enter the text you want to show in the list of pre-defined reasons (for example, 
changed oven ramp parameters), and click OK.
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6. Audit Trails GC/MS Acquisition - View Instrument Audit Trail
GC/MS Acquisition - 
View Instrument Audit Trail
To view a log of any edit made to the 
instrument configuration, in the 
Configuration Editor, select Audit 
Trail > View Instrument Audit Trail.
 

GC/MS Acquisition - 
View and Print a Method 
Audit-Trail Log
In MassHunter GC/MS Acquisition, select Method > View Method Audit-Trail Log. 
(Displays the Audit-Trail log for the currently loaded Method.)

• To print the Summary Audit-Trail log, view the log, and then click Print.

• To print the Details Audit-Trail log, view the log, select Detailed Print, and then click 
Print. 

• To preview the log before printing, view the log, and then click Print Preview. This 
displays a copy of the report in the Microsoft Report View, which you may review before 
printing. 
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6. Audit Trails GC/MS Acquisition - View and Print a Sequence Audit-Trail Log
GC/MS Acquisition - 
View and Print a Sequence 
Audit-Trail Log
In MassHunter GC/MS Acquisition, select Sequence > View Sequence Audit-Trail Log. 
(Displays the Audit-log for the currently loaded Sequence.)

• To print the Summary Audit-Trail log, view the log, and then click Print.

• To print the Details Audit-Trail log, view the log, select Detailed Print, and then click 
Print. 

• To preview the log before printing, view the log, and then click Print Preview. This 
displays a copy of the report in the Microsoft Report View, which you may review before 
printing. 
GC/MS Acquisition - 
View and Print an 
Instrument Configuration 
Audit-Trail Log
In the Configuration Editor, select 
AuditTrail > View Instrument Audit-
Trail. (Displays the log for each 
configured instrument.)
 

• To print the Summary Audit-Trail log, view the log, and then click Print.

• To print the Details Audit-Trail log, view the log, select Detailed Print, and then click 
Print. 

• To preview the log before printing, view the log, and then click Print Preview. This 
displays a copy of the report in the Microsoft Report View, which you may review before 
printing. 
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6. Audit Trails Quantitative Analysis - Audit Trail Overview
Quantitative Analysis - 
Audit Trail Overview
 

MassHunter GC/MS Quantitative Analysis operating in the Compliance mode provides 
audit reports that include details of each time a Batch Analysis, Method Development, 
Batch Review or Report command is used. 

Additionally, as this mode is designed to support the requirements of the U.S. Food and 
Drug Administration (FDA) regulations and the handling of electronic records and 
electronic signatures published as 21 CFR Part 11, records are treated as regulated 
records.

Based on the settings in the Audit Trail Management program (ATM), each time a user 
issues a command in MassHunter Quantitative Analysis, they may be prompted to supply 
one, or both, of the following:

• Supply a reason for the change

• Supply their valid user name and password

The information entered at the time they issue the command is included in the audit 
reports.
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6. Audit Trails Quantitative Analysis - Generate an Audit Report
Quantitative Analysis - 
Generate an Audit Report
Audit reports are generated in the same manner as all other reports in MassHunter 
Quantitative Analysis. Refer to your online Help for more details on generating reports. The 
following is a brief summary of generating a batch audit trail report.
1. Select Report > Generate...
2. Click New to create a method 
template for the Audit Trail 
Report.
 

3. Click Add Template... . Navigate 

to the location in ECM where you 
saved your report templates, and 
select, the report template you 
wish to use. (For example, 
AuditTrail.report.xml.)
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6. Audit Trails Quantitative Analysis - Generate an Audit Report
4. Be sure to check the Audit Trail 
box. If using the PDF report 
template, you do not need to 
check the Audit Trail box.
5. Click Save and Exit.

6. Click OK. The report is generated 
to the destination listed. 
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6. Audit Trails Quantitative Analysis - Enable/Disable Audit Reasons
Quantitative Analysis - 
Enable/Disable Audit 
Reasons
The Audit reason feature is enabled on an individual command basis.
To enable or disable this feature for a 
command:

1. Start the Audit Trail Map (ATM).
2. Enter ECM system administrator 
credentials.
 

3. There are four MassHunter 
Quantitative Analysis Roles 
(Command Groups).

Select the group to which the 
command belongs. For example, 
select the Batch Analysis group if 
the command is a Batch Analysis 
command.
MassHunter Roles
(Command Groups)

ECM Roles
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6. Audit Trails Quantitative Analysis - Enable/Disable Audit Reasons
4. Click the arrow in front of the 
group name to display the full list 
of commands associated with 
this group.
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6. Audit Trails Quantitative Analysis - Enable/Disable Audit Reasons
5. Select the command for which 
you want to activate the User 
Validation and Reason feature.
In this example the AddSample command is selected.
6. Enable either one or both of the 
validation requirements.
 

7. Select any additional commands 
in this group and set their 
validation requirements, as 
desired.

8. Click the arrow once again to 
return to the previous view and 
repeat the process for commands 
in another group, if desired.

9. When you are finished, select 
File > Save to save the changes.

10. Now, when a user completes this 
command in MassHunter, they 
will be presented with a screen 
similar to the following.
If either one of the validation reasons was unchecked in ATM, it will be greyed out on this 
screen. If both “Required Command Reason” and “Requires User Validation” were checked 
in ATM, both must be completed in MassHunter, as shown in this example.
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6. Audit Trails Quantitative Analysis - Enable/Disable Audit Reasons
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7
MassHunter Quantitative Analysis 
Command Groups

Overview    68

Batch Analysis Command Group    69

Method Development Command Group    70

Batch Review Command Group    71

Report Command Group    71

Chapter 7 provides a complete list of all the commands in each MassHunter 
Quantitative Analysis command group: Batch Analysis, Method Development, 
Batch Review, and Report. 

See“Associate ECM Roles to MassHunter Quantitative Analysis Command 
Groups” on page 47 for details on how to associate these to Quantitative 
Analysis users.



7. MassHunter Quantitative Analysis Command Groups Overview
Overview
 

Before using MassHutner Quantitative Analysis, each user must be assigned to an ECM 
Role (listed in the right column of the ATM program). 

Each ECM Role is associated with one or more MassHunter Quantitative Analysis 
individual commands or command groups (shown in the left column of the ATM program).

There are four MassHunter Quantitative Analysis command groups in ATM:

• Batch Analysis

• Method Development

• Batch Review

• Report

The tasks a user may perform in MassHunter Quantitative Analysis are based on which 
Command groups are associated with the ECM Role to which they are assigned. See 
“Associate ECM Roles to MassHunter Quantitative Analysis Command Groups” on page 47 
for details.

For example, here all users included in the System Administrator, Analysts, and Developer 
ECM Roles, have access to the MassHunter Report commands. 

Each Command group is described below.

MassHunter Roles
(Command Groups)

ECM Roles
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7. MassHunter Quantitative Analysis Command Groups Batch Analysis Command Group
Batch Analysis Command 
Group
In the Batch Analysis command group there are commands used for routine batch analysis 
tasks such as: 

• Add or Remove samples

• Analyze, Calibrate, and Integrate the Batch

• Save 

The complete list is shown below. Notice, in this example, only those users assigned to 
either the Analysts or Developer group will have access to these commands in 
MassHunter Quantitative Analysis.
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7. MassHunter Quantitative Analysis Command Groups Method Development Command Group
Method Development 
Command Group
In the Method Development command group there are commands used for routine method 
development tasks such as Create, Import, and Save a new Method.

The complete list is shown below. Notice, in this example, only those users assigned to the 
Developer group will have access to these commands in MassHunter Quantitative 
Analysis.
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7. MassHunter Quantitative Analysis Command Groups Batch Review Command Group
Batch Review Command 
Group
In the Batch Review group there is a single command: 

• OpenBatchTable

Notice, in this example, those users assigned to either the Analysts or Developer group 
will be able to Open a Batch in MassHunter Quantitative Analysis.
Report Command Group
 

In the Report group there are two commands: 

• EditReportMethod

• Generate Report

Notice, in this example, those users assigned to the System Administrator, Analysts, and 
Developer group will be able to use these commands in MassHunter Quantitative Analysis.
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7. MassHunter Quantitative Analysis Command Groups Report Command Group
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8
MassHunter Acquisition Windows 
Security Groups

Overview    74

Sequence Menu    75

GC - Instrument Menu    75

MS - Instrument Menu    76

CTC/PAL - Instrument Menu    76

Miscellaneous Instrument Menu    77

View Menu    77

Batch Menu    78

Checkout Menu    78

Change Group Privileges    79

Chapter 8 provides a list of the default privileges assigned to the pre-defined 
Windows security groups QuantAdministrators, QuantBatchAnalyzer, 
QuantBatchReviewer, QuantMethodDeveloper, and Quant Report Generator, which 
are used in MassHunter GC/MS Acquisition. The permissions are grouped by 
their function.

The privileges each user has in MassHunter GC/MS Acquisition are based on 
the Windows security group to which they have been assigned. After you have 
reviewed the roles and responsibilities associated with these groups, assign 
each MassHunter GC/MS Acquisition user to one of the groups. See “Assign 
Users to a Windows security group” on page 22



8. MassHunter Acquisition Windows Security Groups Overview
Overview
 The privileges each user has in MassHunter GC/MS Acquisition are based on the 
Windows security group to which they have been assigned. After you have reviewed the 
roles and responsibilities associated with these groups, assign each MassHunter GC/MS 
Acquisition user to one of the groups. See “Assign Users to a Windows security group” on 
page 22
Method Menu
 

Default privileges to entries under the Method menu and Method icons are listed in the 
following table. See “Change Group Privileges” on page 79 for details on how to change 
these settings.
 

Method Menus and Icons
Analyst 
I

Analyst 
II

Analyst 
III


Manager

Additional method information    

Load Method    

Run Method    

RTL – Acquire RTL Calibration Data   

RTL – Unlock Method or Relock Method   

Edit Entire Method  

Edit Method Information  

Print Method  

Save or Save As Method  

Intelligent Sequence 
Parameters – Edit or Print

 

Use Classic DA menu  

Edit Intelligent Sequence Parameters  

Edit Method  

Set Default Paths 

View Method Audit Trail 

Zip/Unzip Method and Data 
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8. MassHunter Acquisition Windows Security Groups Sequence Menu
Sequence Menu
 Default privileges to entries under the Sequence menu and icons are listed in the following 
table. See “Change Group Privileges” on page 79 for details on how to change these 
settings.

Sequence Menus and Icons Analyst I Analyst II Analyst III Manager

Simulate Sequence    

Load Sequence    

Run Sequence    

Save Sequence   

View Sequence Log   

View Sequence Quality Log   

Edit Sequence   

Position and Run Sequence   

Print Sequence Log   

Save Sequence As  

Additional Sequence Options  
 
GC - Instrument Menu
 Default privileges to entries under the GC segment of the Instrument menu and icons are 
listed in the following table. See “Change Group Privileges” on page 79 for details on how 
to change these settings.

GC - Instrument 
Menus and Icons


Analyst I


Analyst II


Analyst III


Manager

GC Show/Hide Status    

GC Sleep    

GC Wake    

GC Parameters  

GC Real Time Plots  

GC Sample Prep  

GC Configuration 
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8. MassHunter Acquisition Windows Security Groups MS - Instrument Menu
MS - Instrument Menu
 

Default privileges to entries under the MS segment of the Instrument menu and icons are 
listed in the following table. See “Change Group Privileges” on page 79 for details on how 
to change these settings.

MS - Instrument 
Menus and Icons


Analyst I


Analyst II


Analyst III


Manager

MS Vacuum Control   

MS Tune File   

MS CI Control  

Tune MSD  

Edit Tune Parameters  

MS Edit Parameters  

MS Temperatures  

Configure MS Source  

Select MS Tune File  

MS Status Panel

 Apply button  

 Edit button  

 Override button  
CTC/PAL - Instrument 
Menu
Default privileges for access to entries under the CTC/PAL segment of the Instrument 
menu and icons are listed in the following table. See “Change Group Privileges” on page 79 
for details on how to change these settings.

CTC/PAL Instrument 
Menus and Icons


Analyst I


Analyst II


Analyst III


Manager

Change Configuration     

Configuration     

Edit Cycles      

Edit Method      

Import Cycles      

Parameters      
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8. MassHunter Acquisition Windows Security Groups Miscellaneous Instrument Menu
Miscellaneous Instrument 
Menu
Default privileges to miscellaneous entries under the Instrument menu and icons are listed 
in the following table. See “Change Group Privileges” on page 79 for details on how to 
change these settings.

Miscellaneous Items on the 
Instrument Menu and Icons


Analyst I


Analyst II


Analyst III


Manager

Switch Filament     

ALS Parameters    

Backflush Wizard    

HeadSpace Parameters    

Inlet/Injection types    

Edit Monitors    

QTOF MassCal    

HeadSpace Parameters 
View Menu
 

Default privileges to entries under the View menu and icons are listed in the following 
table. See “Change Group Privileges” on page 79 for details on how to change these 
settings.

View Menus and Icons Analyst I Analyst II Analyst III Manager

Data Analysis    

Instrument Control    

Arrange Monitors    

Chromatogram    

Save Layout    

Spectrum    

Tile Horizontal    

Tune and Vacuum Control  
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8. MassHunter Acquisition Windows Security Groups Batch Menu
Batch Menu
 

Default privileges for access to entries under the Batch menu and icons are listed in the 
following table. See “Change Group Privileges” on page 79 for details on how to change 
these settings.

Batch Menu and Icons Analyst I Analyst II Analyst III Manager

Run Batch    

Load and Run Batch    

Load Batch    

Set Up and Run Batch – short menu    

Simulate Batch    

Position and Run Batch   

Print Batch   

Print Batch Log   

Print Post-Batch Sequence Table   

Print Pre-Batch Sequence Table   

View Batch Log   

Save Batch   

Edit Batch   

Select Post Batch Reports  

More Batch  
Checkout Menu
 Default privileges to entries under the Checkout menu and icons are listed in the following 
table. See “Change Group Privileges” on page 79 for details on how to change these 
settings.

Checkout Menu and Icons Analyst I Analyst II Analyst III Manager

Evaluate Tune    

High Mass Check    

Sensitivity Check    

Checkout Tune    

View Previous Tunes…    
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8. MassHunter Acquisition Windows Security Groups Change Group Privileges
Change Group Privileges
 During installation, MassHunter GC/MS Acquisition created four Windows security 
groups. 

• Manager (The highest level of privileges)

• Acquisition Analysts III

• Acquisition Analysts II

• Acquisition Analysts I (The lowest level of privileges)
To change these settings:

1. Login to your workstation with 
Windows Administrator 
privileges.
2. Double-click Configuration 
Editor.
 

3. Provide a valid user name and 
password, and click Login.
4. In the Configuration Editor, select 
Configure > Manage Roles and 
Responsibilities.
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8. MassHunter Acquisition Windows Security Groups Change Group Privileges
5. Click the column heading to sort 
the list by Description, and locate 
the responsibility you want to 
change. 
6. In the Responsibility column, 
select the item you want to 
modify, Method load menu, for 
example.
7. Double click the corresponding 
entry in the Role column to 
display a drop-down selection 
list.
 
8. Select the new Minimum Role 
you want to use for this 
Responsibility. 
For example, you could change the Load Method menu:

• From a minimum role requirement of Analyst I

• To a minimum role requirement of Analyst II
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9
Supported Network Topologies for 
Compliance Security Mode

Single GC/MS Workstation (Acquisition PC)    82

GC/MS Workstation (Acquisition PC) Plus a Data Review Station 
(Review PC)    82

GC/MS Workstation (Acquisition PC) Plus Data Processing (Process PC) 
Plus Data Review (Review PC)    83

Scaled Network Solution Multiple GC/MS Systems    83

Scaled Network Solution Multiple GC/MS Systems + Multiple 
Processing and Review Stations    84

Chapter 9 includes examples of the network configurations supported by 
MassHunter compliance mode.

All supported configurations require an ECM server installation of version 
3.4.1 SP2 or greater.



9. Supported Network Topologies for Compliance Security ModeSingle GC/MS Workstation (Acquisition PC)
Single GC/MS Workstation 
(Acquisition PC)
• Data is acquired, processed, reviewed and approved on a single GC/MS Workstation 
(Acquisition PC).

• Data and Results are secured using OpenLab ECM Server.

GC/MS
Instrument

Acquisition
PC

ECM Server

Secure
Data

Collect
Data

Process
Data

Approve
Results
GC/MS Workstation 
(Acquisition PC) Plus a 
Data Review Station 
(Review PC)
 

• Data is collected and processed on a GC/MS Workstation (Acquisition PC).

• All data is secured using OpenLab ECM Server.

• Results are reprocessed and approved on a second PC (Review PC).

GC/MS
Instrument

Acquisition
PC

ECM Server

Secure
Data

Collect
Data

Process
Data

Review
PC

Reprocess
Data

Approve
Results
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9. Supported Network Topologies for Compliance Security ModeGC/MS Workstation (Acquisition PC) Plus Data 
GC/MS Workstation 
(Acquisition PC) Plus Data 
Processing (Process PC) 
Plus Data Review (Review 
PC)
• Data is collected and processed on a GC/MS Workstation (Acquisition PC).

• All data is secured using OpenLab ECM Server.

• Results can be reprocessed and approved on a separate PC (Process PC).

• Results can also be reviewed on an additional PC (Review PC).

GC/MS
Instrument

Acquisition
PC

ECM Server

Secure
Data

Collect
Data

Process
PC

Process
Data

Review
PC

Review
Data
Scaled Network Solution 
Multiple GC/MS Systems
 

• A Lab acquires, processes, reviews, and approves data from a single instrument on a 
single PC, as illustrated in the brackets below.

• Data and Results from multiple instruments are secured using OpenLab ECM Server. 
Therefore, a lab could have multiple versions of what is in the brackets, all going in to 
the same OpenLab ECM server.

GC/MS
Instrument

n × GC/MS

Acquisition
PC

ECM Server

Secure
Data

Collect
Data

Process
Data

Approve
Results
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9. Supported Network Topologies for Compliance Security Mode Scaled Network Solution Multiple GC/MS 
Scaled Network Solution 
Multiple GC/MS Systems + 
Multiple Processing and 
Review Stations
 

• A lab collects and processes data on one acquisition PC.

• Results from any instrument can be reprocessed and reviewed from alternate PCs.

• All data is secured using OpenLab ECM Server.

n × GC/MS m × Review PCs

GC/MS
Instrument

Acquisition
PC

ECM Server

Secure
Data

Collect
Data

Process
Data

Review
PC

Reprocess
Data

Approve
Results
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