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 Introduction 

 

The purpose of this document is to provide guidance on how to install, configure, 
upgrade, or uninstall WICF 4.X on any instrument controller (LAC/E or Personal 
Workstation) or Client according to the specifications. For more details on ICF or 
the specific driver packages, please review the respective Release Notes on the 
installation media.  

 

Table 1 Terms and abbreviations used in this document 

Terms Description 

CDS Chromatographic Data System 

DSA Data System Adapter 

FR Feature Release 

HF Hotfix 

ICF Instrument Control Framework 

ICF SL Waters ICF Support Layer 

ICL Instrument Control License 

ICS Instrument Component Software 

Instrument controller LAC/E or Personal Workstation 

LAC/E Laboratory Acquisition Control Environment 

SFC Supercritical Fluid Chromatography 

SP Service Pack 

SR Service Release 

SSB Software Status Bulletin 

SVT Software Verification Tool 

U Update 

Waters Waters Corporation 

WICF Agilent ICF Support Layer for Waters CDS 
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Trademarks 

Microsoft, Windows, Windows Server, and Microsoft .NET are trademarks of 
Microsoft Corporation. 

Waters, Empower, MassLynx, and LAC/E are trademarks of Waters Corporation.  

Citrix is a trademark of Citrix Systems, Inc., and/or one or more of its subsidiaries. 

PAL is a trademark of CTC Analytics AG.  

. 
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 Prerequisites 

The following Prerequisites must be met before starting the installation of WICF: 

• Waters CDS must be installed and fully functional. 

• Compatibility and system requirements must be fulfilled as listed in the Release 
Notes. 

• Previous Waters ICF SL installations must be completely uninstalled, including 
the removal of ICF Support, Agilent ICF, Agilent Instrument Drivers, and Agilent 
Software Verification Tool. 

• No sample set must be scheduled or in progress.  

• The installation must be executed with a Windows user account (domain or 
local) having local administrator rights. 

• Only Agilent instruments specified in the Release Notes can be configured. 

• An Empower user account with the appropriate privileges must be used to 
configure an instrument. 

 

NOTE In case ICF SL 3.7.01 project extension (ICF 3.2 Update 3) is installed the GC/HS 
drivers must be uninstalled manually via Windows Programs and Features.  
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COM/DCOM and local security policy settings 

To ensure the functionality of ICF based instrument control in Empower, the 
following COM/DCOM (Distributed Component Object Model) and local security 
policy must be set on each device. Please restart the device after completion of the 
settings.  
Starting with WICF 4.1, the COM settings are set by the WICF installer. The DCOM 
and local security settings are set by the Empower installer. For further details, 
please refer to the appropriate Waters documentation.   

The settings should be checked during troubleshooting, for example, when having 
no instrument dashboard.   

• Component Services > Computers > Properties > COM Security > Access 
Permission 
Select the Allow check boxes for Local Access and Remote Access for 
Authenticated Users and Domain Users (listed in the “Group or user names” 
section). 

• Component Services > Computers > Properties > COM Security > Launch and 
Activation Permissions  
Select the Allow check boxes for Local Launch, Remote Launch, Local 
Activation, and Remote Activation Permissions for Authenticated and Domain 
Users.  

• Local Security Policy > Security Settings > Local Policies > Security Options > 
DCOM: Machine Access Restrictions in Security Descriptor Definition 
Language (SDDL) syntax > Edit Security 
Select the Allow check boxes for Local Access and Remote Access for 
Everyone and Domain Users. 

• Local Security Policy > Security Settings > Local Policies > Security Options > 
DCOM: Machine Launch Restrictions in Security Descriptor Definition 
Language (SDDL) syntax > Edit Security > Launch and Activation 
Permissions  
Select the Allow check boxes for Local Launch, Remote Launch, Local 
Activation, and Remote Activation Permissions for Everyone and Domain Users. 

• Local Security Policy > Local Policies > Security Options > Network Access: 
Let Everyone permissions apply to anonymous users 
Set to Enabled. 
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Firewall settings 

If third-party firewalls or anti-virus software are used on a network with WICF, the 
firewall ports listed in this section must not be in use by other applications to allow 
communication between the instruments and the LC/CE and GC/HS drivers. These 
restrictions apply to both Personal Workstations and Enterprise systems since 
component communications rely on these channels. 

The WICF installer will automatically set up the necessary firewall inbound rules. If 
you encounter communication issues, refer to the following table for an overview of 
the utilized ports.  

Table 2 Instrument Inbound Rules for the instrument controller. 

Protocol Port/Program Description 

TCP 4879 Instrument communication (Headspace) 

TCP 10000-10020 Instrument communication (GC 78xx, 88xx, 9000) 

TCP 58080/PreConfigClient.exe Waters ICF Port 

   

TCP Any/AgilentPlugInServer Default path: 
C:\Empower\Instruments\AgilentLC\AgilentPlugInServer.exe 

TCP Any/PlugInRunner Default path: 
C:\Empower\Instruments\AgilentLC\PlugInRunner.exe 

TCP Any/preconfigservice Default path: 

C:\Empower\Instruments\AgilentLC\preconfigservice.exe 

 

Table 3 Instrument Outbound Rules for the instrument controller in case the firewall setting is not 

“Outbound connections that do not match a rule are allowed”. 

Protocol Port/Program Description 

TCP 23 Instrument communication (LC, CE) 

TCP 53 DNS Server 

TCP 67, 68 DHCP Server (DNS or BootP) 

TCP 9001, 9002, 9100 Instrument communication (GC, LC, 35900) 

TCP 9101, 9110 Instrument communication (GC, LC, 35900) 
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CAUTION 
Since WICF 4.1, executables include a digital signature. In setups without internet 
access and specific firewall rules, the certificate revocation check via the external CA’s 
CRL server can cause timeouts, resulting in an empty instrument dashboard, DHCP 
scan showing "No", and method UI loading times exceeding 30 seconds. To prevent 
the timeouts, the default retrieval timeout settings can be activated and set from 15 

(default) to 1 under Local Security Policy > Security Settings > Public Key Policies > 
Certificate Path Validation Settings > Network Retrieval tab. 

 
Alternatively, the following registry keys can be applied, located on the installation 
media (\Supplementary material\URLRetrievalTimeout):   
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\OID\EncodingType 

0\CertDllCreateCertificateChainEngine\Config] 

"ChainUrlRetrievalTimeoutMilliseconds"=dword:000000c8;200 

milliseconds 

"ChainRevAccumulativeUrlRetrievalTimeoutMilliseconds"=dword:000000c8 

;200 milliseconds 
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 Installation 
 

Installing WICF is a two-step process. First, install the Software Verification Tool 
(SVT). Second, install WICF, which includes ICF and Agilent instrument drivers. The 
WICF installer will prevent installation if specific prerequisites are not met, for 
example, SVT version, Waters CDS version, OS version, as described in Chapter 2. 

In an Empower Enterprise environment, the drivers must be installed on every 
LAC/E and client or Citrix Server that interacts with the Agilent instrument, its 
methods, and results. WICF does not need to be installed on database servers or 
controllers without Agilent instrument connections or interactions. For incremental 
upgrades, interoperability between different WICF and Waters ICF Support Layer 
versions is possible. Refer to the WICF Release Notes for details. 

 

NOTE Before starting the installation of SVT and WICF, ensure that no sample sets are 
running or in the queue, reboot the PC and log in with an account having full local 
Windows administrator privileges. 

 

Interactive Installation of the Agilent Software 
Verification Tool (SVT) 

SVT is required for the installation of WICF. To install the SVT, perform the following 
steps:  

1 Locate the installation file in the subdirectory \Setup\Agilent Software 
Verification Tool. 

2 Double-click the file SFVtool.msi to start the installation of the Software 
Verification Tool. 

3 On the prompted End-User License Agreement, click Next and follow the on-
screen instructions. The default settings should be appropriate in most cases. 

4 If required, adjust the destination folders for the installation. 
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5 Specify the destination of the verification reports. The report of the installation 
verification can be found in this location. 

 



Installation 

WICF Installation & Configuration Guide – Revision 4.2 13 
 

6 Continue with Next and, on the next screen, click Install to start the installation. 

 

7 If the User Account Control Notification is turned on, click Yes to allow the 
installation of SVT. 

 

8 After completion, click Finish to close the installation wizard. 
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9 The Software Verification tool is now available in the Windows Start menu: 

Start > Agilent Technologies > Software Verification Tool. 
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Interactive Installation of the Agilent ICF Support 
Layer for Waters CDS (WICF) 

The Agilent Drivers are delivered as a single Windows Installer file named 
AgilentICFSupportLayerForWatersCDS.msi that includes the supported ICF and 
instrument drivers. To install WICF, perform the following steps: 

1 Ensure that all Prerequisites are fulfilled (see Chapter 2) 

2 Locate the installation file in the subdirectory \Setup\Agilent ICF Support Layer 
for Waters CDS. 

3 Double-click the file AgilentICFSupportLayerForWatersCDS.msi to start the 
installation of WICF. 

4 On the setup dialog, accept the license terms and continue with Install. 

 

5 If the User Account Control Notification is turned on, click Yes to allow the 
installation of WICF. 
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6 Choose if you want to join the Agilent Improvement Program for LC and click 

Continue. 

 

7 Wait until the installation process completes and click Finish. 
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8 To finalize the installation, click Yes to restart the PC. 

 

The location for the files of the default installation is 
C:\Empower\Instruments\AgilentLC. 
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SVT and WICF will be listed in Windows Programs and Features. 
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Silent Installation of SVT and WICF 

It is possible to install the Agilent Software Verification Tool and WICF in silent 
mode by executing the following commands in the command console. Refer to the 
Microsoft documentation for Microsoft installer functionality. Make sure to log on 
to the PC with an account having full local Windows administrator privileges. Start 
the command line with Run as administrator. 

 

Silent SVT Installation via msiexec 

msiexec.exe /i “<path_to_msi>\SFVtool.msi” 

[/quiet][/passive][/q{n|b|r|f}]  

An installation using this syntax will install the msi to the default installation path 
(C:\Program Files (x86)\Agilent Technologies\IQTool) without logging or restart 
instructions. 

Examples 

• Installation with no user interaction and no user interface:  

msiexec.exe /i “C:\Temp\SFVtool.msi” /qn 

• Installation with no user interaction, no user interface, defined installation 
directory, and enabled installation logs: 

msiexec.exe /i “C:\Temp\SFVtool.msi” /qn INSTALLDIR=”C:\Program 

Files (x86)\Agilent Technologies\IQTool” /l*v “C:\Temp\SFV.log”  

 

NOTE The Temp folder in the examples must be created and the msi placed in there 
upfront. 

 

Silent WICF Installation via msiexec 

msiexec.exe /i 

“<path_to_msi>\AgilentICFSupportLayerForWatersCDS.msi”  

[/quiet][/passive][/q{n|b|r|f}] [/norestart][/forcerestart] 
[/L{i|w|e|a|r|u|c|m|o|p|v|x+|!|*}] [“<path_to_log>\install.log”] 

An installation using this syntax will install the msi to the default installation 
path with the defined restart and logging instructions. Unless otherwise stated, 
the WICF installer will restart by default at the end of the installation. 

https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/msiexec
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Examples 

• Installation with no user interaction, no user interface and automatic restart:  

msiexec.exe /i “C:\Temp\AgilentICFSupportLayerForWatersCDS.msi” 

/qn 

• Installation with no user interaction, no user interface, enabled installation logs, 
and no restart: 

msiexec.exe /i “C:\Temp\AgilentICFSupportLayerForWatersCDS.msi” 

/norestart /qn /l*v “C:\Temp\install.log”  

 

NOTE Do not change the default installation location for WICF.   

Push Installations 

To install, upgrade, or remove WICF on multiple Empower clients, LAC/Es, or Citrix 
servers from a host computer, the Microsoft PsExec utility can be used. For further 
information and How-tos, refer to the Microsoft documentation. 

Installing WICF on a Citrix server 

WICF can be deployed and used in a Citrix environment. Refer to the Waters 
Empower documentation for the supported Citrix versions and operating systems. 
For installation, perform the following steps: 

1 Open the command prompt as administrator and put the server in Install mode 

by typing “change user /install”. The message “User session is ready to install 
applications.” Should appear. 

 

https://learn.microsoft.com/en-us/sysinternals/downloads/psexec
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2 Either interactively install WICF or perform a silent installation as described in 
the sections above.  

Put the server back to Execute mode by opening the command prompt as 

administrator and type “change user /execute”. The message “User session is 
ready to execute applications.” Should appear. 

 

Upgrade Installation 

A direct upgrade from previous WICF 4.X versions is supported and is performed by 
following the normal installation steps. Ensure that SVT is upgraded before WICF.  

A direct upgrade from ICF SL to WICF is not supported. All included components of 
ICF SL must be removed completely before installing WICF.  

Uninstallation 

Before starting the uninstallation of SVT and WICF, ensure that no sample sets are 
running or in the queue, reboot the PC and log in with an account having full local 
Windows administrator privileges. 

 

NOTE WICF must be uninstalled before SVT.    

 

To interactively uninstall WICF and SVT: 

1 Go to Windows Programs and Features, highlight the program, and select 

Uninstall. 
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2 Select Yes when asked to uninstall. 

 

3 If the User Account Control Notification is turned on, click Yes to allow the 
uninstallation of WICF. 

 

Wait for the uninstallation to be completed and chose Yes when prompted for 
restart after the uninstallation of WICF. 
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4 The PreConfiguration will remain in the folder 

…\Empower\AgilentLC\PreConfigurations to avoid reconfiguring the 
instruments after re-installation.  

Silent Uninstallation 

To silently uninstall the software, use the proper Microsoft Installer function as 
described in the section above. For example:  

• WICF  

msiexec.exe /x “<path_to_msi>”\ 

AgilentICFSupportLayerForWatersCDS.msi /norestart /qn /l*v 

“<path_to_log>\install.log” 

• SVT  

msiexec.exe /x “<path_to_msi>\SFVTool.msi” /qn 

A restart is necessary to successfully finish the uninstallation. Unless otherwise 
defined, the successful silent WICF uninstallation will automatically restart the PC.   
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 Installation Verification 

The installation and integrity of WICF and its components is verified by the Agilent 
Software Verification Tool (SVT). 

In addition, the WICF files are checked by the Waters Empower Verify Files Utility. 
This utility does not check for the ICF and instrument driver components. 

Perform the installation verification on every instrument controller and every client 
or Citrix server, with WICF installed.  

Agilent Software Verification Tool (SVT) 

The SVT provides documentary evidence that WICF and its included components 
have been installed correctly. To execute the SVT, perform the following steps: 

1 Go to Start > Agilent Technologies > Software Verification Tool. 

 

2 Select the required report type and the components to qualify. 
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3 Select Qualify: The system will run the application and generate a Software 

Verification Report which should give a PASS. Reports are automatically saved 
to C:\SVReports, if not defined differently during SVT installation. 
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4 If the report indicates failure, verify the computer requirements, and try to 
troubleshoot, for example, re-install, or reach out to your support 
representative. 

Silent execution of SVT 

Run the Agilent SVT in silent mode by executing the following command with below 
syntax in the command console: 

Examples 

• Execution of SVT with no UI for Agilent ICF Support Layer for Waters CDS, 
showing progress bar, saving, and opening a pdf report:  

"C:\Program Files (x86)\Agilent 

Technologies\IQTool\Bin\SFVTool.exe" -qt -p:"Agilent ICF Support 

Layer for Waters CDS" -pdf -open 

• Execution of SVT with no UI for all products hiding command window and 
progress bar, showing details of qualified files, saving a html report:  

"C:\Program Files (x86)\Agilent 

Technologies\IQTool\Bin\SFVTool.exe" -silent -ok -p:"all" 

 

NOTE For all available options, use the SVT help function: 
"<path_to_SFVTool.exe>\SFVTool.exe" -h 
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Waters Empower Verify Files Utility 

The Empower Verify Files utility verifies the integrity of the WICF layer together with 
the Empower Installation. To execute the Verify Files utility, perform the following 
steps: 

1 Using your Windows operating system, go to Start > Empower > Verify Files. 

 

2 The Verify Files tool is automatically executed and displayed. The 
Checksum_[DATE]_[TIME].txt file is saved in C:\Empower\Script. 
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Compliance Recommendation 

If the site is in a regulated environment, we recommend following your standard 
operating procedures (SOP). Known and resolved Issues are listed in the Release 
Notes. Together with the Software Verification Tool and the Software Status and 
Release Bulletins, it may help to determine if any qualification tasks are required. If 
required, Agilent offers the (re-) qualification of the hardware or the functional 
verification of the WICF driver installation/upgrade (not Empower) as a service. 
Please contact your Agilent sales representative. 
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 Instrument Configuration 

The configuration of an Agilent Instrumentation in Waters Empower consists of the 
following steps: 

1 PreConfiguration 

2 DHCP Configuration 

3 Chromatographic System Creation 

Whereas steps 1 and 2 slightly differ for LC and GC, step 3 is the same for both. 
The steps are described in detail below.  

 

NOTE  Upgrades from ICF SL 3.3 and earlier need an instrument re-configuration (see 
CRI-1383). 

Agilent LC configuration in Waters Empower 

To configure an Agilent LC in Waters Empower, follow these steps. For configuring 
an Agilent Capillary Electrophoresis system, refer to the technical note Agilent 7100 
Capillary Electrophoresis System in Empower.  

Prerequisites 

1 Ensure proper installation: Verify that Empower and WICF are properly installed 
on the instrument controller and clients that will use the system. 

2 Power on modules: Turn on all modules of the LC system. Ensure that only the 
modules you want to configure are in the CAN bus and one module (preferably 
the detector) is connected to the instrument controller via LAN. 

3 Restart instrument controller: Restart the LAC/E or Personal Workstation that 
will be connected to the instrument. Do not open Run Samples before 
configuring the instrument.     

4 Assign a static IP address: Assign a static IP address to the instrument within 
the subnet of the instrument controller. Use the InfinityLab Assist, the Agilent 
Instant Pilot, or Telnet for this task. Refer to the user manual or Agilent 
community for assistance (How to Check, Configure and Use the IP Address of 

https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_CE.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_CE.pdf
https://community.agilent.com/knowledge/lc-portal/kmp/lc-articles/kp386.how-to-check-configure-and-use-the-ip-address-of-an-agilent-hplc-module
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an Agilent HPLC Module - Articles - LC Portal - Agilent Community). Verify the 
successful network communication (for example, via ping). 

5 Check firmware requirements: Ensure the firmware of the LC modules meets 
the minimum requirements for the WICF version in use (see WICF Release 
Notes). Agilent recommends always using the latest firmware revision to 
provide the highest level of system capability. 

 

NOTE When using an Agilent Instant Pilot (G4208A), enable the 3rd party backward 
compatibility mode to make it invisible to other controllers. Do not hot plug the 
Instant Pilot when the LC stack is powered on. Turn off all HPLC modules before 
plugging or unplugging the Instant Pilot. 

 

PreConfiguration Utility 

1 Log in to Empower from the LAC/E or workstation connected to the instrument 
(recommended) or from any client and open the Configuration Manager.  

 

2 Select Tools > Agilent PreConfiguration. 

https://community.agilent.com/knowledge/lc-portal/kmp/lc-articles/kp386.how-to-check-configure-and-use-the-ip-address-of-an-agilent-hplc-module
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3 Enter the IP address or hostname of the LAC/E or workstation connected to the 
instrument (“localhost” if you are logged in to the instrument controller directly) 

and press Connect. 

 

4 When successfully connected, already configured instruments are shown, and 

the New option at the bottom becomes available. From here, new 
configurations can be created, existing instruments can be re-configured, or the 
existing pre-configurations can be deleted.  
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5 Selecting New opens the Agilent Configuration Editor. Highlight Agilent 
1100/1200/1260/1290 LC (or Agilent 1120/1220 LC Systems) and select Auto 
Configure.  

 

6 In the Auto Config dialog, enter the IP address of the instrument access point 

and press OK. The hostname must not be used.  
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7 With successful connection, all online LC modules are automatically detected 
along with their current configurations and are added to the right panel. 

 

NOTE Do not modify the module configuration at this stage to prevent mismatches 
between the automatically detected hardware configuration and software 
configuration at startup. An exception is when the config parameters are not read 
by RFID tag or cannot be changed via “modify” in the LC Status dashboard (for 
example, G1330A/B Thermostat, loop, or seat capillary for 1100 LCs).  
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8 [Optional] Cluster Configuration 

a In case a potential Cluster is detected during an auto-configuring, possible 
configurations are proposed, and the Cluster can be created by selecting 
the available modules pressing Create Cluster and specifying the required 
cluster settings (press F1 in the cluster dialog box for more information).  

b If clustering is not required, click Close to proceed with the configuration of 
an unclustered system. 

 

9 [Optional] ELSD Configuration 

a Either configure the ELSD before executing the LC Auto Config or use the 
Up button to bring the ELSD on top of the module list. Alternatively, use the 
hostname to configure the ELSD to prevent inheriting the IP address of the 
ELSD by the PreConfiguration utility. 

b Proceed with the next steps.   

10 Press OK and Exit the PreConfiguration and proceed with the Empower DHCP 
Configuration (next section).  
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Empower DHCP Configuration 

After the successful PreConfiguration, the Agilent instrument must be configured in 
the Empower software by performing the following steps: 

1 Log in to Empower from the LAC/E or workstation connected to the instrument 
(recommended) or from any client and open the Configuration Manager. 
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2 Select Nodes from the Empower configuration tree, right-click the desired node 

(LAC/E or workstation) and select Properties.  
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3 Switch to the tab Configure DHCP and click the Configure DHCP button. 

 

4 In the Waters DHCP Server Configuration window, click Add to manually add 
the static IP address of the Agilent LC (same instrument access point as used 
during the PreConfiguration). 
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5 Enter the IP Address, MAC Address (can be arbitrary), and Serial Number or a 

Unique Name. Select the Instrument Type AgilentLC from the drop-down list. 

Confirm with OK. IP and MAC address are checked for duplicates on the same 
instrument controller. Once created editing existing DHCP configurations is not 
possible. The system must be removed and added again. 
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NOTE IP addresses containing invalid character like “.” must not be used in the Unique 
Name field.  

 

6 Press OK to close the Waters DHCP Server Configuration. Browse to the 

Instruments tab and Scan Instruments to check the successful configuration. 

OK? column must indicate Yes. Check the Details column for the read 
instrument configuration.  

 

7 Right-Click > Table Properties and unhide the Manufacturer column. Click OK, 
browse to the manufacturer column and change the name to “Agilent 

Technologies, Inc.”. Close and update the Node Properties by clicking OK. 
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8 You may proceed with the section Chromatographic System Creation.  



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 41 
 

Importing and using Alphanumeric Trays or Wellplates 

Agilent samplers utilize two types of tray/plate schema:  

• The classic schema uses continuous numbering, for example, Vial 1, 2, 3  

• The alphanumeric schema uses alphanumeric positions, for example, P1-A1, 
P1-A2, P2-B1 which translates in Empower to 1:A1, 1:A2, 2:B1 

While the classic schema functions by default, Empower requires imported 
definition files (.txt) to utilize alphanumeric schemas for trays and plates. These 
definition files for the most common trays and plates are included with the 
installation media, located in the \Supplementary 
material\AgilentPlatesForImport directory. Table 4 gives an overview of the files. 
The files are available in English, Japanese, and Chinese (simplified) localized 
format.  
 

NOTE Classic vial drawers for Vialsamplers (50 x 2 mL vials; G7129-60210, G7129-
60220) use continuous numbering and will work by default without importing 
alphanumeric definition files.  

 

To import alphanumeric plate definition files, the following steps must be 
performed: 

1 Browse to Configuration Manager > Plate Types 

2 Check if the desired Plates are already present. If not, right-click inside the table 

and select Import from Text. 
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3 Select Browse, navigate to the plate definition files on the installation media, 

highlight the desired tray/plate and click Open.  
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4 Provide a New Plate Type Name and confirm with OK. 

 

5 After the successful import procedure, the Plate Type Name will appear in the 

Table and can be checked/modified by double-click or right-click > Properties. 

 

6 The tray/plate definition will be available in the Acquisition and vial numbers will 
be displayed in the format 1:A1. 
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7 Assign the same tray/wellplate to the instrument hardware via the instrument 

dashboard: Right-click on the sampler > Assign wellplates. 
For Vialsamplers, no assignment is needed as the tray is automatically 
recognized.   
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NOTE Once successfully imported, the tray/plate is available across the Empower 
Enterprise system and can also be used on other clients and instrument 
controllers.   

 

For detailed instructions and how to create customized trays/plates, see: 

Agilent Infinity Lab LC Series Vialsampler Vial Drawer Configuration in Empower 
Environment Technical Note 

Controlling the Agilent 1260 Infinity/1290 Infinity II Multisampler (G7167A/B) in 
Waters Empower 3 Environment Technical Note 

   

Table 5 Alphanumeric tray/plate definition files delivered with WICF 

File Name (.txt) Part No. Rows Columns Plate 
height 
(mm) 

Volume 
(µL) 

15HRV5mlVialPlate  3 5 42 5000 

15HRV6mlVialPlate 5022-6539  3 5 47 6000 

15VialPlate  3 5 42 5000 

https://www.agilent.com/cs/library/technicaloverviews/public/G7129-Empower-Vialsampler-TecPu-en-D0004805.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G7129-Empower-Vialsampler-TecPu-en-D0004805.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_Multisampler.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_Multisampler.pdf
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Table 5 Alphanumeric tray/plate definition files delivered with WICF 

66VialTray G7129-60010 6 11 43.9 2000 

18VialTray G7129-60110 3 6 43.9 6000 

96DeepAgilent3 5042-6454 8 12 31.5 1000 

96DeepAgilent4 No Agilent PN 8 12 41 1000 

96DeepRitter41 No Agilent PN 8 12 41.2 800 

384Agilent 5042-1388 16 24 14.4 80 

384Corning No Agilent PN 16 24 14.4  

384Greiner No Agilent PN 16 24 14.4  

384Nunc No Agilent PN 16 24 14.4  

Agilent27Eppendorf500uL 5022-6538 3 9 40.5 500 

Agilent27Eppendorf1500uL 5022-6538 3 9 40.5 1500 

Agilent27Eppendorf2000uL 5022-6538 3 9 40.5 2000 

ANSI96Well500uL 5042-1385 
5042-1386 

8 12 14 500 

ANSIAgilent54Vial G2255-68700 6 9 36 2000 

Agilent40Vial 5023-2471 5 8 43 2000 

10Vialbar1 Part of G4226A tray 

(G2258-60011) 
 

10 1 43.9 2000 

5Vialbar1 G7167A/B/C/D Reference 
Vials 

1 5 43.9 2000 

Sampler Thermostat/Cooler Temperature Modes 

The Sample Cooler/Sample Thermostat used in Multisampler and Vialsampler 
offers two control modes that must be defined in the configuration: 

Constant Temperature Mode: This mode is defined as a system (control) setting, 
meaning the temperature setting is independent of the method parameters. The 
temperature remains constant for all methods within a given sequence. This is the 
default option and recommended for most applications. 

Variable Temperature Mode: This mode is defined as a method parameter, 
meaning the temperature setting is part of the method parameters. The 

 
1 The Vialbars must use Plate Layout Position 0 with the position format 0:X. 
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temperature can change from method to method within a given sequence. This 
mode is not recommended for most analytical workflows but might be used for 
some special applications, such as degradation studies. 

To set the mode, the following steps must be performed: 

1 If the Sampler is already configured, start with Step 4 followed by a new auto-
config (Step 2) and a restart of the instrument controller. If not, continue with 
Step 2. 

2 After auto-configuration in the PreConfiguration Utility, open the sampler 
configuration dialog by double-clicking on the sampler. Select the desired 

temperature mode in the Mode dropdown. Do not change any other setting. 
For example, the Thermostat/Cooler installed checkmark must be recognized 
by the auto-config.  
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3 Create a Chromatographic System in Empower as described in the sections 
before.  

4 Open the Acquisition, navigate to the instrument dashboard, right-click on the 

sampler, select Modify > Temperature mode.  

 

5 Select the same Mode as defined in the PreConfig in Step 1.  

6 Restart the instrument controller.  

 

The procedure on how to change the temperature mode is also described by 
Waters in TechNote TECN134945293. 

 

NOTE Changing the temperature mode for an existing configuration requires a method 
resolution for existing methods based on the old configuration with another 
temperature mode setting.  

 

NOTE The G1330A/B Thermostat used for older samplers (G1367X, G1329X) works 
similarly and can also be set to be controlled by method. Please refer to Waters 
TechNote TECN134909208. 
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Technical Notes 

Several technical notes for LC/CE are available from Agilent and Waters describing 
special scenarios and applications. Here is a collection of selected technical notes: 

Technical Notes published by Agilent 

• Agilent InfinityLab LC Series Multicolumn Thermostats and Column Usage in 
Empower 

• Performing Manual Injection (LC) in Empower Environment 

• Agilent 1290 Infinity II Evaporating Light Scattering Detector (ELSD) in 
Empower 

• Using the Fraction Collector in Empower 3 Environment  

• Using ISET in Empower Environment 

 Using High Dynamic Range (HDR) in Empower 

• Agilent 7100 Capillary Electrophoresis System in Empower  

• Controlling the Agilent 1260 Infinity/1290 Infinity II Multisampler (G7167A/B) in 
Waters Empower 

• Agilent Infinity Lab LC Series Vialsampler Vial Drawer Configuration 

 

Application Notes published by Agilent 

• Agilent 1290 Infinity II LC with ISET – Emulation of the Agilent 1100 Series LC 
Through Waters Empower Software 

• Agilent Instrument Control Framework and 1290 Infinity Quaternary LC with 
Waters Empower 

• Using the Agilent Instrument Control Framework to control the Agilent 1290 
Infinity LC through Waters Empower software 

• Using the Agilent Instrument Control Framework to control the Agilent 1220 
Infinity LC system through Waters Empower software 

 

Technical Notes published by Waters 

• Controlling the Agilent 1260/1290 Infinity II Sampler cooler via the Empower 
instrument method TECN134945293 

• Using the Agilent G1330A/B Autosampler Thermostat with Empower 
TECN134909208  

https://www.agilent.com/cs/library/technicaloverviews/public/G7116-MCT-using-Empower-TechPu-en-D0012197.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G7116-MCT-using-Empower-TechPu-en-D0012197.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G1328A-ICF-Empower-ManualInjector-TechPu-en-D0002338.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_ELSD.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_ELSD.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G1364-ICF-EmpowerOE-TechPu-en-D0002925.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G2197_ICF_Empower_ISET_TechPu_en_D0002337.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_HDR.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_CE.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_Multisampler.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_Multisampler.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_Multisampler.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/ICF_Empower_Multisampler.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G7129-Empower-Vialsampler-TecPu-en-D0004805.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G7129-Empower-Vialsampler-TecPu-en-D0004805.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/G7129-Empower-Vialsampler-TecPu-en-D0004805.pdf
https://www.agilent.com/cs/library/applications/5991-6541EN.pdf
https://www.agilent.com/cs/library/applications/5991-6541EN.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/5991-5105EN.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/5991-5105EN.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/5990-9093EN.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/5990-9093EN.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/5990-9399EN.pdf
https://www.agilent.com/cs/library/technicaloverviews/public/5990-9399EN.pdf
https://www.waters.com/webassets/cms/support/docs/TECN134945293_r00.pdf
https://www.waters.com/webassets/cms/support/docs/TECN134945293_r00.pdf
https://www.waters.com/webassets/cms/support/docs/tecn134909208_r01_secure.pdf
https://www.waters.com/webassets/cms/support/docs/tecn134909208_r01_secure.pdf
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• Using the Agilent PreConfiguration Utility with Agilent Instrument Control 
Framework (ICF) Support Version 2.2 TECN134936402 

• Slow Performance when launching Agilent ICF components in Empower 
TECN134962729 

• Mapping ICS-Based GC Methods to Agilent ICF (715007259 Version 00) 

Agilent GC/HS configuration in Waters Empower 

To configure an Agilent GC/HS or GC/CTC PAL3 in Waters Empower, perform the 
following steps. For interoperability scenarios, instrument configuration is only 
supported directly on the LAC/E. 

Prerequisites 

1 Ensure proper installation: Verify that Empower and WICF are properly installed 
on the instrument controller and clients that will use the system. 

2 Power on modules: Turn on the GC (and HS) and ensure that the hardware is 
properly installed. 

3 Restart instrument controller: Restart the LAC/E or Personal Workstation that 
will be connected to the instrument. Do not open Run Samples before 
configuring the instrument.     

4 Assign a static IP address: Assign a static IP address to the instrument within 
the subnet of the instrument controller. Use the GC/HS front panel or Telnet for 
this task. Refer to the user manual or Agilent community for assistance. Verify 
the successful network communication (for example, via ping). 

5 Check firmware requirements: Ensure the GC/HS firmware meets the minimum 
requirements for the WICF version in use (see WICF Release Notes). Agilent 
recommends always using the latest firmware revision to provide the highest 
level of system capability. 

 

NOTE Serial/RS232 connection is not supported with WICF. Ethernet communication is 
required for all GC and HS modules controlled via WICF. For 6890A and 6890 
Plus GCs this may require a hardware update with a LAN Accessory Kit from 
Agilent, part number G2335A.  

 

https://www.waters.com/webassets/cms/support/docs/tecn134936402_r01.pdf
https://www.waters.com/webassets/cms/support/docs/tecn134936402_r01.pdf
https://www.waters.com/waters/support.htm?lid=134962729&lcid=134962728&type=TECN
https://www.waters.com/waters/support.htm?lid=134962729&lcid=134962728&type=TECN
https://www.waters.com/webassets/cms/support/docs/715007259v00.pdf
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PreConfiguration Utility 

GC configuration 

1 Log in to Empower from the LAC/E or workstation connected to the instrument 
(recommended) or from any client and open the Configuration Manager.  

 

2 Select Tools > Agilent PreConfiguration. 

 

3 Enter the IP address or hostname of the LAC/E or workstation connected to the 
instrument (“localhost” if you are logged in to the instrument controller directly) 

and press Connect. 
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4 When successfully connected, already configured instruments are shown and 

New becomes available. From here, new configurations can be created, 
existing instruments can be re-configured, or the existing pre-configurations 
can be deleted.  

 

5 Selecting New opens the Agilent Configuration Editor. Expand Agilent GC 

Systems, select the correct GC type and click the arrow to the right to move 



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 53 
 

the selected GC model to the right window. Auto Configure is not supported for 
GC/HS and greyed out.  

 

6 Double-click the GC on the right pane (or select it and press Configure) to open 
the GC configuration dialog of the selected GC type.  
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7 Enter the IP address of the GC and click Get GC Configuration. GC Name and 
Notes are optional fields.  

 

8 The current GC hardware configuration is uploaded through the active 
connection and displayed in the Configuration tab when successfully finished. 
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9 Review the configuration, specify the Keypad Lock as needed, and confirm with 

OK. 

10 Verify that the correct IP address is shown in the PreConfiguration Utility and 
either select Exit if a GC only is used or proceed with the Headspace 
configuration.  



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 56 
 

 

Headspace configuration 

If a Headspace (HS) is to be configured in addition, follow these steps. If not, skip 
this section and proceed with the next section.  

11 In the Configuration Editor, expand the GC Systems section, select the desired 

Headspace sampler and click the arrow to the right to move it to the right 
pane.  

 

12 Double-click the HS on the right pane (or select it and press Configure) to open 
the HS configuration dialog of the selected HS type.  

13 Enter the IP address of the HS. Instrument Name and Notes are optional fields. 
HS 8697 and 8697 XL Tray are connected to the GC via LAN and the GC IP 
address must be used for configuration.  
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14 Switch to the Configuration tab and click Upload Config from Instrument.  
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a For a 7697A HS, optionally adjust the Resource Conservation and 
Preferences settings. For 8697 (XL Tray), these settings can be reached in 
the Acquisition interface via Advanced Options > Module Options.  
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b For the G1888 HS, an IP address must be entered (hostname is not 
supported). After clicking Upload from Instrument, chose Yes when 
prompted to replace the settings.  
Adjust the Loop Size, Vial EPC, and Carrier Connection.  
Do not change Vial Size, Pressure Units, Oven Stabilization Time, and 
Handshake Mode. These settings must be changed on the G1888 front 
panel and uploaded again.  
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15 Review the configuration and then press OK. Exit the Configuration Editor by 

selecting OK. 
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16 Verify that the correct IP address is shown in the PreConfiguration Utility (GC 

only is displayed) and select Exit. Proceed with the Empower DHCP 
Configuration in the next section.  

  



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 62 
 

CTC PAL3 configuration 

If a CTC PAL3 should be configured, follow these steps. If not, skip this section and 
proceed with the next section.  

 

NOTE The configuration of a CTC is only supported directly on the instrument controller 
and not via a client.  

 

1 Ensure that the compatible CTC PAL3 driver was installed after the installation 
of WICF and that the LAN connection is established.   

2 Open the PreConfiguration Utility directly on the instrument controller, connect 
to localhost or the local IP and create a new instrument.  

3 In the Configuration Editor, expand the CTC Analytics GC tab, select the CTC 
PAL3 GC Sampler and click the arrow to the right to move it to the right pane.  

 

4 Double-click the CTC PAL3 GC Sampler on the right pane (or select it and press 

Configure) to open the CTC configuration dialog.  

5 Enter the IP address of the CTC PAL3 and click Retrieve Configuration.  
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6 Press Tray Configuration and verify the attached tools and tray configurations. 

Click OK and wait until the configuration is retrieved again. Click OK.   
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7 In the Configuration Editor select and configure the Agilent GC in use in 
addition to the CTC PAL3 as described in the GC configuration section. In case 
the GC was already configured, take care that the CTC PAL3 is listed first in the 

right pane by using the Up and Down buttons. Like this the PreConfiguration 

Utility will take the GC IP address for further usage. Press OK. 
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8 Verify that the correct IP address is shown in the PreConfiguration Utility (GC 

only is displayed) and select Exit. Proceed with the Empower DHCP 
Configuration (next section).  

9 [Optional] Modifying the tray and tool configuration is also possible through the 

Soft Configuration via the Empower Run Samples window under Advanced 
Options > Module Options. It may be necessary to close and reopen the Run 
Samples window that the changes are reflected in the dashboard.  
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Empower DHCP Configuration 

After the successful PreConfiguration, the Agilent instrument must be configured in 
the Empower software by performing the following steps: 

1 Log in to Empower from the LAC/E or workstation connected to the instrument 
(recommended) or from any client and open the Configuration Manager. 

 

2 Select Nodes from the Empower configuration tree, right-click the desired node 

(LAC/E or workstation) and select Properties.  
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3 Switch to the tab Configure DHCP and click the Configure DHCP button. 
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4 In the Waters DHCP Server Configuration window, click Add to manually add 
the static IP address of the Agilent GC (same instrument access point as used 
during the PreConfiguration). 

 

5 Enter the IP Address, MAC Address (can be arbitrary), and Serial Number or a 

Unique Name. Select the Instrument Type AgilentGC from the drop-down list. 

Confirm with OK. IP and MAC address are checked for duplicates on the same 
instrument controller. Once created, editing the existing DHCP configurations is 
not possible. The system must be removed and added again.  

 

NOTE IP addresses containing invalid character like “.” must not be used in the Unique 
Name field.  
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6 Press OK to close the Waters DHCP Server Configuration. Browse to the 

Instruments tab and Scan Instruments to check the successful configuration. 

OK? column must indicate Yes, check the Details column for the read 
instrument configuration.  
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7 Right-Click > Table Properties and unhide the Manufacturer column. Click OK, 
browse to the manufacturer column and change the name to “Agilent 

Technologies, Inc.”. Close and update the Node Properties by clicking OK. 
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8 You may proceed with the section Chromatographic System Creation.  

GC dual-simultaneous injection (Dual tower)  

Dual-simultaneous injection or dual tower describe the usage of the GC front and 
back injectors in parallel to inject samples simultaneously applying the same 
method to both samples and recording the signals of both flow paths from front 
and back detectors. This functionality saves time by doubling the sample 
throughput.   

The scripts to enable the dual tower support are applied by default during WICF 
installation. The scripts to disable/enable dual tower support are located on the 
installation media (\Supplementary material\DualTower) and can be used on own 
risk. The scripts must be executed by “Run as administrator” and do modify registry 
entries to add/remove the instrument type A7890 to/from the Waters DHCP Server 
Configuration which enables/disables the use of dual tower.  

 

NOTE The GC Dual Tower functionality is not supported when legacy drivers are 
installed. To make use of dual tower mode, legacy drivers must be uninstalled. 
Vice versa, to use legacy drivers, dual tower must be disabled by using the 
Disable_Dual_Tower script.  
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To configure and use dual tower injections, perform the following steps: 

1 Ensure that the GC hardware has a front and back injection tower correctly 
installed. 

2 Configure the GC using the PreConfiguration Utility as described in the section 
above.  

3 During Empower DHCP Configuration, select Instrument Type A7890 
regardless of the GC model in use (for example, using dual tower with a GC 
8890 needs A7890 selected as instrument type). 

  

4 Create a Chromatographic System in Empower as described in the next 
section.  

5 Open the Run Samples window and select Customize > Defaults.  
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6 Set the checkmark for 7890 is Dual Tower Instrument (does also apply to other 

GC models) and confirm with OK. 

 

7 The Dual/Front/Back tower radio buttons are displayed in the Run Samples 
window. They allow to filter the Sample Set table to display front, back, or both 
injections.  
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8 Create a new instrument method for dual injections. In the method editor, 

navigate to the Options tab and select the injector Dual as Injector Preference.  

 

9 Create a Method Set and a Sample Set based on the instrument method and 
following the rules: 

a The front and back injections lines must specify the same instrument 
method, number of injections and runtime, to perform dual tower 
injections.   

b The vial numbers are alphanumeric (“F” indicates the front tower and “B” 
the back tower whereas the vial position is the numerical number): 

i F:1-F:150 for front injector tower 

ii B:1-B:150 for back injector tower 

c The vial numbers of front and back injectors must be different. 
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10 The simultaneous injections will be marked and the signals assigned according 
to the method.  

 

Chromatographic System Creation 

1 In the Empower Configuration Manager, right-click on Systems and select New 
> Chromatographic System. Alternatively, click File > New > Chromatographic 
System.  
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2 In the New Chromatographic System Wizard, select Create New System and 

click Next.  



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 79 
 

 

3 Select the appropriate LAC/E node and click Next (does not apply for 
workstation). 
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4 Drag and drop the desired instrument from the Available Instruments list to 

New System Instruments list and click Next.  

 

5 Select Share System with Other Network Users and set the appropriate access 
control privileges for the system. 
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6 Enter a System Name and System Comment. Optionally, choose a System 

Location. Select the Online checkbox and click Finish.  
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7 A pop-up window shows that the system is successfully brought online (one 
system license and one instrument connection license are consumed). After 
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successful configuration procedure, the GC/HS system appears in the system 
table and OnLine indicates Yes.  

 

 

 

NOTE If not enough licenses are available during configuration, the system could stay 
offline until further licenses are activated. Alternatively, unused AgilentLC or 
AgilentGC systems can be taken offline to release a license for the desired 
system.   

Configuration report 

There are several ways to view or report the instrument configuration details: 

• After successful configuration, the configuration details are displayed in the 
Details column of the Instruments tab in the Node Properties and can either be 
copied or printed from there.  
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• The configuration details are listed in the System Audit Trail. Please consider 
KPR 783402. 

  

• The configuration details can be reported with the System Information snippet 
of the Report Publisher when a Sample Set was recorded.  
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Modification or deletion of an existing configuration 

Modifying an existing configuration 

When hardware updates/modifications are to be performed such as  

• Adding a module to an already configured LC stack  

• Adding a component (for example, injector, detector, or inlet) to a GC  

• changing the seat capillary, column assignment, loop volume of an LC 

• changing the Sampler Thermostat/Cooler temperature mode 

• changing the vial size of the G1888 HS 



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 86 
 

it is necessary to re-configure the existing system in the PreConfiguration Utility. 
The following steps must be performed:  

1 Perform the hardware modification or configuration change via the Lab 
Advisor/Instant Pilot/Instrument Dashboard for the LC and via the Front Panel 
for the GC.  

2 Restart the instrument controller.  

3 Log in to Empower from the LAC/E or workstation connected to the instrument 
(recommended) or from any client and open the Configuration Manager. Do not 
open Run Samples before updating the configuration.   

 

4 Select Tools > Agilent PreConfiguration. 
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5 Enter the IP address or hostname of the LAC/E or workstation connected to the 
instrument (“localhost” if you are logged in to the instrument controller directly) 

and press Connect. 

 

6 When successfully connected, already configured instruments are shown. 

Select the instrument to be updated and click Configure. 

 

7 Depending on the instrument type (LC or GC), do a new auto-configuration 

(press Clear before to remove the existing configuration) or select Get GC 
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Configuration (GC) or Upload Config from Instrument (HS) as described in the 
sections before.  

8 Open the Run Samples window and check for the configuration changes. 
Consider resolving instrument methods created with the old configuration or 
create new ones.   

Deleting a configuration 

 

To cleanly delete an existing system in Empower and in the PreConfiguration Utility, 
perform the following steps: 

1 Restart the instrument controller where the system is connected to. 

2 [Optional] Open the Configuration Manager, browse to systems, right-click on 
the system to be deleted and select Export to Text to document the system 
before deletion. 
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3 Right-click on the system and select Delete. 

 

4 Confirm the deletion with Yes and select Delete All to remove the system from 
the node and remove it from all user accounts on this database. 
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5 Open the Properties of the node/instrument controller where the system was 
connected.  

 

6 Browse to the Configure DHCP tab, select Configure DHCP, highlight the 

system to be deleted and select Remove. 
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7 Confirm the dialog with Yes and Close the Waters DHCP Server Configuration 

with OK.  

 

8 In the Node Properties, browse to the Instruments tab, highlight the Instrument 

to be deleted and select Remove Instrument.  
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9 Confirm with Yes. Close the Properties with OK.  
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10 In the Configuration Manager, select Tools > Agilent PreConfiguration. 

 

11 Enter the IP address or hostname of the LAC/E or workstation connected to the 
instrument (“localhost” if you are logged in to the instrument controller directly) 

and press Connect. 

 

12 When successfully connected, all configured instruments are shown for this 

instrument controller. Select the instrument to be deleted and click Delete. 



Instrument Configuration 

WICF Installation & Configuration Guide – Revision 4.2 94 
 

 

The following Optional points can be done in case of troubleshooting when deleting 
an instrument is not working properly.  

13 [Optional] On the instrument controller, open the Windows File Explorer and 
navigate to C:\Empower\Instruments\AgilentLC\PreConfigurations. Check if 
the [IP].xml of the deleted instrument is gone. If still present, the xml can be 
deleted manually. 

 

14 [Optional] On the instrument controller, open the Windows File Explorer and 
navigate to C:\Empower\InstrumentServer. Delete the INSTSRV.DAT file and 
restart the instrument controller. The file will be recreated. 
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 Licensing 

Licensing Agilent Instruments in Waters Empower 

To control an Agilent LC, CE, GC, GC-HS instrument with Waters’ Empower CDS, the 
following Waters Empower licenses are required:  

• Empower Licenses (Core, User License, System Control License per 
instrument), sold by Waters. 

• A paper-based Instrument Control License (ICL), sold by Agilent since July 1, 
2022 

To purchase the ICL and/or the driver integration (WICF) Agilent provides the 
following products: 

Table 6 Agilent Drivers for Empower product overview 

Product Description Part Number Content 

Agilent Drivers for Waters 
Empower – GC 

M8407AA One Waters GC ICL to add one GC system to 
Waters Empower CDS  
Authorization code for SubscribeNet with access 

to WICF 

Agilent Drivers for Waters 

Empower – LC/CE 

M8507AA 

(available in packs 
of 1, 5, or 20) 

One Waters LC ICL to add one LC/CE system to 

Waters Empower CDS  
Authorization code for SubscribeNet with access 
to WICF 

Agilent Drivers Upgrade for 

Waters CDS (LC/CE and GC) 

M8509AA Authorization code for SubscribeNet with access 

to WICF 

 

NOTE In case of an upgrade, for example, from ICF SL to WICF, existing Agilent ICL 
licenses can be re-used. ICL´s are vendor specific.  

Activating the ICL for Waters Empower 

1 Unbox the received package and search for the ICL with the license serial 
number inside in the Waters branded envelope.  

2 On any system (Client, LAC/E, Workstation, Server) with Empower installed, and 

connected to the Enterprise system, open the Waters Licensing Wizard.  
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3 Log On with a user having the appropriate privileges. 

 

4 Click on Request software registration. 
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5 Create a registration file, select a File location, and click Next.  
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6 Visit https://www.waters.com/activate/licenseintro.htm and login to the 
Waters account. 

7 Select Empower 3, the appropriate topology (Workstation, Workgroup or 

Enterprise) and Activate License(s) and click Next. 

https://www.waters.com/activate/licenseintro.htm
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8 Enter the serial number of the applicable license(s). Order Number or Base 

Software License are optional. Click Next. 
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9 Load your Software Registration File (.lic) created in step 5 into the web 

interface and click Activate. 

 

10 A License Activation file is generated based on the .lic file and the serial 
number. Save it to a location accessible by the Empower system. 
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11 On your system connected to Empower, go back to the Licensing Wizard and 

select Activate Licenses. 

 

12 Browse to the just created License Activation file and click Next. 
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13 Control the activated licenses and click Finish. 

 

NOTE If this is a new Empower installation with version 3.7 or higher, the instrument 
catalogue must be imported/updated. Otherwise, the instrument cannot be 
brought online. 

 

De-Activating the ICL for Waters Empower 

1 Unbox the received package and search for the ICL with the license serial 
number inside the Waters branded envelope. 

2 On any system (Client, LAC/E, Workstation, Server) with Empower installed, and 

connected to the Enterprise system, open the Waters Licensing Wizard.  
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3 Log On with a user having the appropriate privileges. 

4 Select Deactivate licenses. 
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5 Select the licenses to be deactivated and press Next. 

 

6 Select a location to save the License Deactivation file and press Next. 
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7 Visit https://www.waters.com/activate/licenseintro.htm and login to your 
Waters account. 

8 Select Empower 3, the appropriate topology (Workstation, Workgroup or 

Enterprise) and Deactivate License(s) and click Next. 

 

9 Enter your contact information and click Next. 

https://www.waters.com/activate/licenseintro.htm
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10 Load your License Deactivation file (.lic) created in step 6 into the web 

interface and click Deactivate. 

 

11 The License is now deactivated and can be re-used. Print the Deactivation 
Confirmation page for the records.  
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 Troubleshooting 

Logfiles 

WICF, ICF and instrument driver logs are written by default to 
%ProgramData%\Agilent Technologies\Instrument Control Framework. For WICF, 
each process name can generate up to 30 log files, with each file having a 
maximum size of 20 MB. 

Changing Log Levels 

By default, the basic log level is enabled. To change the log level, open the 
AgilentWicfLogging.dll.config file located at C:\Empower\Instruments\AgilentLC in 
a text editor and modify the LoggerConfigPath value into:  

• Basic \WICFLogger_basic.config - Info, Warning and Error 

• Medium \WICFLogger_medium.config - Info, Warning, Error and Debug 

• Verbose: \WICFLogger_verbose.config – more detailed debug messages 
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Collect the Support Information 

NOTE You must have administrative rights to collect the support information.  

1 On the right-hand side of the dashboard select the Collect Support Info tab. 

 

2 Select the desired check boxes. 

3 Click Collect. 

4 Select file name and location. Click Save. A zip file is created in the designated 
folder.  
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The Installation Guide describes the following: 

 

 Introduction 

 Prerequisites 

 Installation  

 Installation Verification 
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 Licensing 

 Troubleshooting 
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