VR4000

Device Driver User Guide
Notices

© Agilent Technologies, Inc. 2008-2009

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

User Guide Part Number
G5415-90057
July/2007

Contact Information
Agilent Technologies Inc.
Automation Solutions
5301 Stevens Creek Blvd.
Santa Clara, CA 95051
USA

Technical Support: 1.800.979.4811
or +1.408.345.8011
service.automation@agilent.com

Customer Service: 1.866.428.9811
or +1.408.345.8356
orders.automation@agilent.com

European Service: +44 12081443513
euroservice.automation@agilent.com

Documentation feedback:
documentation.automation@agilent.com

Web: http://www.agilent.com

Acknowledgements
Microsoft and Windows are registered trademarks of the Microsoft Corporation in the United States and other countries.

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Safety Notices

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.
Letter to our Customers

Dear Customer,

The Agilent Technologies acquisition of Velocity11 resulted in the following changes:

- Creation of Agilent Technologies Automation Solutions, formerly Velocity11
- Renaming of some Velocity11 products
- New Customer Service and Technical Support contact information
- New website address for product information

Please make a note of the following changes as they impact this user guide.

**Velocity11 product name changes**

<table>
<thead>
<tr>
<th>Velocity11 product name</th>
<th>Changes to ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access2 Automated Microplate Loader</td>
<td>Automated Centrifuge Loader</td>
</tr>
<tr>
<td>Element Automation System</td>
<td>BioCel 900 System</td>
</tr>
<tr>
<td>IWorks Device Driver Programming Interface</td>
<td>VWorks DCL Interface</td>
</tr>
<tr>
<td>PlatePierce Seal Piercing Station</td>
<td>Microplate Seal Piercer</td>
</tr>
<tr>
<td>VCode Barcode Print and Apply Station</td>
<td>Microplate Barcode Labeler</td>
</tr>
<tr>
<td>Velocity11 Robot</td>
<td>3-Axis Robot</td>
</tr>
<tr>
<td>VHooks Integration Interface</td>
<td>VWorks Hooks Interface</td>
</tr>
<tr>
<td>VPrep Pipetting System</td>
<td>Vertical Pipetting Station</td>
</tr>
<tr>
<td>VSpin Microplate Centrifuge</td>
<td>Microplate Centrifuge</td>
</tr>
<tr>
<td>VStack Labware Stacker</td>
<td>Labware Stacker</td>
</tr>
</tbody>
</table>

**New contact information**

Documentation feedback: documentation.automation@agilent.com

Technical Support: 1.800.979.4811 or +1.408.345.8011

service.automation@agilent.com

Customer Service: 1.866.428.9811 or +1.408.345.8356

orders.automation@agilent.com

European Service: +44 12081443513
euroservice.automation@agilent.com

Web: http://www.agilent.com
# Contents

## Chapter 1. Introduction ................................. 1
Who should read this guide .................................. 2
About Velocity11 user guides ................................. 3
What this guide covers ...................................... 5
About devices .............................................. 6
About device drivers ....................................... 7
Installing device drivers .................................... 9
Adding devices ........................................... 10
About diagnostics ......................................... 11
Opening diagnostics ...................................... 12
About profiles ............................................ 15
Setting the properties for a device ....................... 16
Adding and linking Sub Process tasks .................. 19
Using JavaScript to set task parameters ............... 21
About reader output files ................................. 22
About device initialization ............................... 25

## Chapter 2. VR4000 ............................... 27
Workflow for configuring the VR4000 .................. 28
Creating a VR4000 profile ............................... 29
Setting VR4000 task parameters ....................... 31
Managing VR4000 profiles .............................. 35
Operating the VR4000 with diagnostics .............. 37
Introduction

This chapter introduces Velocity11 device drivers and provides some basic procedures that are needed to use them.

A Velocity11 device driver is software that plugs into VWorks or BenchWorks software to allow them to control a specific device.

Before reading this guide, you should be familiar with the VWorks or BenchWorks software user interface. Information about using VWorks or BenchWorks software can be found in the VWorks Version 3 Automation Control User Guide or BenchWorks Automation Control User Guide.

To set up and use Velocity11 device drivers, become familiar with the content in this guide as well as the guides for the devices that use VWorks or BenchWorks software.

This chapter contains the following topics:

- “Who should read this guide” on page 2
- “About Velocity11 user guides” on page 3
- “What this guide covers” on page 5
- “About devices” on page 6
- “About device drivers” on page 7
- “Installing device drivers” on page 9
- “Adding devices” on page 10
- “About diagnostics” on page 11
- “Opening diagnostics” on page 12
- “About profiles” on page 15
- “Setting the properties for a device” on page 16
- “Adding and linking Sub Process tasks” on page 19
- “Using JavaScript to set task parameters” on page 21
- “About reader output files” on page 22
- “About device initialization” on page 25
Who should read this guide

Job roles

This user guide is for people with the following job roles:

<table>
<thead>
<tr>
<th>Job role</th>
<th>Responsibilities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrator</td>
<td>Someone who writes software and configures hardware controlled by device drivers.</td>
</tr>
<tr>
<td>Lab manager, administrator, or technician</td>
<td>Someone who is responsible for:</td>
</tr>
<tr>
<td></td>
<td>- Installing device drivers</td>
</tr>
<tr>
<td></td>
<td>- Managing device drivers</td>
</tr>
<tr>
<td></td>
<td>- Developing the applications that are run using device drivers</td>
</tr>
<tr>
<td></td>
<td>- Solving the more challenging problems that might arise</td>
</tr>
<tr>
<td></td>
<td>- Developing training materials and standard operating procedures for operators</td>
</tr>
<tr>
<td>Operator</td>
<td>Someone who performs the daily production work using the device driver and solves routine problems. Your organization may choose to create its own procedures for operators including the procedures in this guide.</td>
</tr>
</tbody>
</table>

Related topics

For information about... | See...
--- | ---
Contacting Velocity11 | http://www.velocity11.com/contact.html
Accessing online help | “About Velocity11 user guides” on page 3
Device drivers | “About device drivers” on page 7
Chapter 1: Introduction

VR4000 Device Driver User Guide

About Velocity11 user guides

About this topic
This topic describes the different formats of Velocity11 user information and explains how to access the user information.

Formats available
Velocity11 user information is provided to you as:
- Online help
- A PDF file
- A printed book

The information in each format is the same but each format has different benefits.

Where to find user information

Online help
The online help is added to your computer with the Velocity11 lab automation system software installation.

PDF file
The PDF file of the user guide is on the software CD that is supplied with the product.

Velocity11 website
You can search the online help or download the latest version of any PDF file from the Velocity11 website at www.velocity11.com.

Note: All Velocity11 user information can be searched from the website at www.velocity11.com.

Online help
The online help is the best format to use when you are working at the computer and when you want to perform fast or advanced searches for information.

To open the online help:
1. In the Velocity11 lab automation software, press F1. The online help window opens.

Main features
The online help window contains the following:

- **Navigation pane.** Consists of four tabs. The Contents, Index, and Search tabs provide different ways to locate information. The Using tab contains information about using the help system.

- **Content pane.** Displays the online help topics.

- **Navigation buttons.** Enables you to navigate through the pages. The online help includes a navigation pane, content pane, and navigation buttons.
PDF user guides

To open a user guide in PDF format, you need a PDF viewer. You can download a free PDF viewer from the internet.

Printing and searching

The user guides in PDF format are mainly for printing additional copies. You can perform simple searches in the PDF file, although these searches are much slower than online help searches.

More information

For more information about using PDF documents, see the user documentation for the PDF viewer.

Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Who this guide is for</td>
<td>“Who should read this guide” on page 2</td>
</tr>
<tr>
<td>What's in this guide</td>
<td>“What this guide covers” on page 5</td>
</tr>
<tr>
<td>Device driver plug-ins</td>
<td>“About device drivers” on page 7</td>
</tr>
</tbody>
</table>
What this guide covers

<table>
<thead>
<tr>
<th>About this topic</th>
<th>This topic presents an overview of what procedures and information are provided in this user guide. This guide explains how to:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>□ Install the driver for the device</td>
</tr>
<tr>
<td></td>
<td>□ Configure the device in the device manager</td>
</tr>
<tr>
<td></td>
<td>□ Set and use the tasks associated with the device</td>
</tr>
<tr>
<td></td>
<td>□ Use Device Diagnostics</td>
</tr>
</tbody>
</table>

| Also read | Information about device drivers not covered in this guide and about running VWorks or BenchWorks software can be found in the VWorks Version 3 Automation Control User Guide or the BenchWorks Automation Control User Guide. |

<table>
<thead>
<tr>
<th>Driver version</th>
<th>To find version information for a driver in VWorks:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1. Start VWorks.</td>
</tr>
<tr>
<td></td>
<td>2. Click Help and select About VWorks.</td>
</tr>
<tr>
<td></td>
<td>The About VWorks dialog box lists the version numbers of all the current software for all the devices and plug-ins.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Driver version</th>
<th>To find version information for a driver in BenchWorks:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1. Start BenchWorks.</td>
</tr>
<tr>
<td></td>
<td>2. Click Help and select About BenchWorks.</td>
</tr>
<tr>
<td></td>
<td>The About BenchWorks dialog box lists the version numbers of all the current software for all the devices and plug-ins.</td>
</tr>
</tbody>
</table>

| Firmware version | Some devices have firmware installed on them. Because each device is different, the version number may not be the same for all devices. |

<table>
<thead>
<tr>
<th>Firmware version</th>
<th>To find version information for device firmware:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>1. Open Device Diagnostics dialog box.</td>
</tr>
<tr>
<td></td>
<td>2. Click About.</td>
</tr>
<tr>
<td></td>
<td>The About Device Control message box appears displaying the current version of firmware.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>What this guide does not cover</th>
<th>This guide does not cover the following:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>□ The operation of the device</td>
</tr>
<tr>
<td></td>
<td>□ The operation of VWorks or BenchWorks software</td>
</tr>
<tr>
<td></td>
<td>□ Velocity11 devices, such as the PlateLoc Sealer, VCode Microplate Labeler, and VPrep Pipettor when used in stand-alone mode</td>
</tr>
</tbody>
</table>
If you have purchased a device driver plug-in and are installing it yourself, check with the Velocity11 Technical Support to be sure your version of VWorks or BenchWorks software and the device driver plug-in are using the same version of IWorks software.

Device driver plug-ins used with BenchWorks software may not include some newer features that were specifically added for use with VWorks software and that are described in this manual.

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Who this guide is for</td>
<td>“Who should read this guide” on page 2</td>
</tr>
<tr>
<td>User documentation</td>
<td>“About Velocity11 user guides” on page 3</td>
</tr>
<tr>
<td>Device driver plug-ins</td>
<td>“About device drivers” on page 7</td>
</tr>
</tbody>
</table>

### About devices

This topic presents a definition of a Velocity11 device and the device file.

Read this topic if you are unfamiliar with Velocity11 devices and VWorks or BenchWorks software.

A device is an item on your lab automation system that has an entry in the device manager. A device can be a robot, an instrument, or a location on the lab automation system that can hold a piece of labware. Examples of devices:

- Velocity11 robot
- Human robot
- PlateLoc Thermal Plate Sealer
- Labcyte Echo550
- Platepad
- VPrep shelf
- Waste

The data entered into the device manager and saved as a device file contains the configuration information for your devices.
Device file location

Device files have the file name format `file name.dev` and are stored in the folder location that you specify when saving the file.

Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device diagnostics</td>
<td>&quot;About diagnostics&quot; on page 11</td>
</tr>
<tr>
<td>Device profiles</td>
<td>&quot;About profiles&quot; on page 15</td>
</tr>
<tr>
<td>Adding a device to the device manager</td>
<td>&quot;Adding devices&quot; on page 10</td>
</tr>
</tbody>
</table>

About device drivers

About this topic

This topic describes what device drivers are and what they do. Velocity11 device drivers enable mechanical devices or software programs to work with VWorks or BenchWorks software. Read this topic if you are:

- An administrator in charge of installing device drivers and managing Velocity11 devices
- A lab automation system integrator who writes software and configures hardware controlled by VWorks or BenchWorks software

Device driver defined

A Velocity11 device driver enables VWorks or BenchWorks software to control and communicate with the specific type of device. Each type of device that you operate with VWorks or BenchWorks software requires a device driver.

For example, VWorks software uses the:

- VPrep Pipettor device driver to communicate with the Velocity11 VPrep Pipettor device
- Softmax Reader device driver to communicate with Molecular Devices readers

Plug-in defined

A plug-in is a software program that when added to another program extends it.

Plug-in device drivers

Some device drivers are incorporated directly into the VWorks or BenchWorks software application. Other device drivers are distributed as plug-ins. All the device drivers covered in this guide are the plug-in type.
Advantages of distributing device drivers as plug-ins are:

- You only need to install the plug-ins for the devices you use.
- When new plug-ins become available, they can be easily added. There is no need to re-install the VWorks or BenchWorks software application.

### IWorks interface

The device driver plug-ins and VWorks or BenchWorks software use IWorks software as a common interface to communicate with each other. Using a common interface allows the creation of a device driver plug-in without the necessity of changing the software.

**!! IMPORTANT !!** Both VWorks or BenchWorks software and the device driver must be using the same version of IWorks to work properly.

### Writing your own device driver

If you are a lab automation system integrator who writes software and configures hardware controlled by VWorks or BenchWorks software, you can write your own driver plug-in for a new device. Contact the Velocity11 Technical Support for information about how to do this.

### What functions do the device drivers provide? 

Once installed, the following items are enabled:

- Tasks associated with the device.
  
  Device-specific tasks appear in the Protocol Tasks list and are available for use in protocol editor processes.

- Task parameters associated with the device.
  
  Device-specific task parameters appear in the Protocol Task Parameters toolbar. These determine the conditions with which to execute the tasks of the device.

- Diagnostic commands specific to the device.
  
  Device-specific diagnostic commands and options appear in the Device Diagnostics dialog box. These commands enable direct control of the device.

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a device to the device manager</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
<tr>
<td>Installing a device driver</td>
<td>“Installing device drivers” on page 9</td>
</tr>
<tr>
<td>Devices</td>
<td>“About devices” on page 6</td>
</tr>
</tbody>
</table>
Installing device drivers

About this topic
Devices are integrated into VWorks or BenchWorks software using device driver plug-ins. Plug-ins need to be installed before the device can be configured and used.

This topic describes how to install device drivers if they are not already installed on your system. Read this topic if you are an administrator in charge of managing Velocity11 devices.

Procedure

To install device drivers:
1. Insert the device driver installation disc into the CD-ROM of the computer running VWorks or BenchWorks software.
2. Follow the on-screen instructions for installation, selecting the default values when available.
3. When finished, exit VWorks or BenchWorks software.
4. Log off Windows and restart your computer.
5. Start VWorks or BenchWorks software.

<table>
<thead>
<tr>
<th>For this application...</th>
<th>The default location for the device driver is...</th>
</tr>
</thead>
<tbody>
<tr>
<td>VWorks software</td>
<td>C:\VWorks Workspace\bin\plugins</td>
</tr>
<tr>
<td>BenchWorks software</td>
<td>C:\Program Files\Velocity11\BenchWorks\plugins</td>
</tr>
</tbody>
</table>

Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device drivers</td>
<td>&quot;About device drivers” on page 7</td>
</tr>
<tr>
<td>Opening diagnostics</td>
<td>&quot;Opening diagnostics” on page 12</td>
</tr>
</tbody>
</table>
Adding devices

About this topic

To configure your lab automation system to use a device, you need to add it to a device file in VWorks or BenchWorks software. The VWorks or BenchWorks software device manager uses the information in the device file to communicate and operate the device within the automation system.

This topic describes how to:

- Create a new device file (if one does not already exist)
- Add devices
- Save the device file

Read this topic if you are an administrator in charge of managing Velocity11 devices.

Procedure

**To add devices to a device file:**

1. Make sure that the devices are physically networked to the VWorks or BenchWorks software computer and turned on.
2. Start VWorks or BenchWorks software and login as an Administrator.
3. Do one of the following:
   - If you have an existing device file that you want to add to, select File > Device File, click Open, and select your device file.
   - If you are creating a new device file, select File > Device File and click New.
4. Click the Device Manager tab.
5. Click New device in the Device List toolbar and enter a name for the device you are adding.
6. In the device manager, set the Device type.
   The default type is Plate Pad, Standard.
7. Repeat step 5 and step 6 for each device.
8. Select **File > Device File > Save**.

If you are creating a new device file, you are prompted to enter a name for your device file.

Alternatively, you can select **File > Save All**. This saves the device file and the current protocol file at the same time.

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device drivers</td>
<td>“About device drivers” on page 7</td>
</tr>
<tr>
<td>Setting generic device properties</td>
<td>“Setting the properties for a device” on page 16</td>
</tr>
<tr>
<td>Adding a sub-process to a protocol</td>
<td>“Adding and linking Sub Process tasks” on page 19</td>
</tr>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
</tbody>
</table>

### About diagnostics

#### About this topic

This topic presents an overview of diagnostics software.

Read this topic if you need to set up or troubleshoot a device running VWorks or BenchWorks software.

#### Background

Devices can be controlled in real time directly through the VWorks or BenchWorks software Diagnostics using simple commands.

Diagnostics software is used for:

- Troubleshooting
- Setting teachpoints
- Performing manual operations outside a protocol
- Creating and editing profiles

For example, if an error occurs during a run that leaves a plate and the robot where they should not be, you can use robot diagnostics to move the plate and return the robot to its home position.

#### Types of diagnostics software

Devices and robots manufactured by Velocity11 include their own diagnostics software. You can find instructions for using this software in the relevant user guide.
### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
<tr>
<td>Adding a device to the device manager</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>Device drivers</td>
<td>“About device drivers” on page 7</td>
</tr>
<tr>
<td>The definition of devices</td>
<td>“About devices” on page 6</td>
</tr>
</tbody>
</table>

### Opening diagnostics

#### About this topic

Every device has diagnostics software to assist you with troubleshooting and setting up the device. This topic describes how to open a device’s diagnostics in VWorks or BenchWorks software.

Read this topic if you need to access a device’s diagnostics to perform a device setup task or manually operate a device.

#### Procedure 1

**If you are using VWorks4 software**

*To open Diagnostics:*

1. Click **Diagnostics** on the Control toolbar.

2. In the device file’s window, select the device. Expand the general name of the device, if necessary.

3. Click **Device diagnostics** located at the bottom of the window. The device’s diagnostics dialog box opens.

**If you are using VWorks3 or BenchWorks software**

*To open Diagnostics:*

1. Click **Diagnostics** on the Control toolbar.
2. In the **Diagnostics** window, select the device. Expand the general name of the device, if necessary.

3. Click **Device diagnostics**. The device’s diagnostics dialog box opens.

---

**Procedure 2**

If you are using VWorks4 software

To open Diagnostics:
1. Click the **Device File** tab.
2. Select the device from the **Devices** toolbar. Expand the general name of the device, if necessary.

3. Click **Device diagnostics** located at the bottom of the **Devices** toolbar.

The device’s diagnostics dialog box opens.

If you are using VWork3 or BenchWorks software

To open Diagnostics:
1. Click the **Device Manager** tab.
2. Select the device from the **Device List** toolbar. Expand the general name of the device, if necessary.
3. Click **Device diagnostics** located at the bottom of the **Device List** toolbar.

The device’s diagnostics dialog box opens.

---

**Related topics**

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diagnostics</td>
<td>“About diagnostics” on page 11</td>
</tr>
<tr>
<td>About device drivers</td>
<td>“About device drivers” on page 7</td>
</tr>
<tr>
<td>Adding a device to the device manager</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>Setting generic device properties</td>
<td>“Setting the properties for a device” on page 16</td>
</tr>
</tbody>
</table>
## About profiles

### About this topic

This topic describes what profiles are and what they do. Read this topic if you are an administrator in charge of managing Velocity11 devices.

### Profiles defined

A profile contains the initialization settings needed for communication between a device and device driver. The data in a profile is used by VWorks or BenchWorks software to identify each device on the network.

A profile can also contain other basic settings that you are unlikely to change once set up.

Because profiles identify device driver devices on the network, each device driver device must have its own profile.

You can create, modify, and delete profiles as needed.

### Stored settings

Profiles are stored in the Windows registry.

The settings stored in a device driver profile include:

- Whether the device is connected using serial or Ethernet
- If the device is connected using Ethernet, the Device ID of the device on the network
- If the device is connected using serial, the COM port that the controlling computer uses for communication
- Configuration of accessories

### Related topics

<table>
<thead>
<tr>
<th>For information about…</th>
<th>See…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device drivers</td>
<td>&quot;About device drivers” on page 7</td>
</tr>
<tr>
<td>Adding a device to the device manager</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>Opening device diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
</tbody>
</table>
Chapter 1: Introduction
VR4000 Device Driver User Guide

Setting the properties for a device

About this topic
The device properties provide VWorks or BenchWorks software with additional information about the device's current configuration, such as which profile to use, and stores the information in the device file. The device file is automatically loaded when you open a protocol.

The device properties need to be set when configuring the device. Typically, these properties only need to be set once. This topic describes how to set the following device properties:

- General
- Teachpoint
- Barcode
- Location (for devices with multiple teachpoints)
- Device Properties

Read this topic if you are an administrator in charge of managing Velocity11 devices.

Before you start
Make sure that you have installed the device driver plug-in and have added the device to the device manager.

See “Related information” for procedures on how to do these tasks.

Setting general properties

To set the general properties for a device:

1. Click the Device Manager tab.
2. Select the device from the Device List toolbar. (Expand the device name, if necessary.)
   
   Note: For devices with Locations, see “Setting location properties” on page 17. If no Locations, continue with step 3.
3. In the General group, set the following:
   a. Approach height. This is the height to raise the robot gripper above the teachpoint when the robot moves the plate horizontally towards or away from it.
   b. Allowed/prohibited labware. Click the adjacent field to open the dialog box. Move the labware classes by selecting them and clicking one of the arrow buttons.
4. In the Device Properties, select the desired profile if it is not already selected.
5. Select File > Device File > Save to save the changes to the device file.
Setting teachpoints

Teachpoints are the coordinates in space that a robot travels to in order to interact with a device. Only the devices that are accessible by robots are able to have teachpoints.

**To set the teachpoint properties:**

1. Open the **Device Properties** page.
2. In the **Teachpoints** property group, set the following:
   a. **Device is accessible from robot robot’s name.** Choose **Yes** or **No**.
   b. **Teachpoint for robot robot’s name.** Choose a file.

<table>
<thead>
<tr>
<th>Teachpoints</th>
<th>Device is accessible from robot robot’s name</th>
<th>Yes or No</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barcode Readers</td>
<td>Device has south side BCR</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Device has north side BCR</td>
<td>No</td>
</tr>
</tbody>
</table>

Setting barcode location

If your device has a barcode reader, indicate where the reader is located.

**To set the barcode readers property:**

1. In the **Barcode Readers** property group, set the side that has the barcode to **Yes**.
2. Enter the number of the COM port to which the device is connected.

<table>
<thead>
<tr>
<th>Barcode Readers</th>
<th>Device has south side BCR</th>
<th>Yes</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>South side BCR COM port</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Device has north side BCR</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Device has south side BCR</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>Device has north side BCR</td>
<td>No</td>
</tr>
</tbody>
</table>

Setting location properties

**Note:** The options available under Location groups might differ for software and hardware device drivers. Software devices do not have robot-accessible labware positions.

For hardware devices that have more than one robot-accessible labware position, the approach height, allowable/prohibited labware, teachpoint, and barcode properties are located under Location groups.

**To set the Location properties:**

1. **Hardware device drivers only** Set the **Use linked location**. Follow the procedure in “Setting the Use linked location” on page 18.
2. **Hardware device drivers only** Set the **Teachpoints**. Follow the procedure in “Setting teachpoints” on page 17.
3. *Some software device drivers only.* Set the **Approach height** and **Allowed/prohibited Labware.** Follow the procedure in “Setting general properties” on page 16.

4. Set the **Barcode Readers** location. Follow the procedure in “Setting barcode location” on page 17.

5. Assign the **Labware** used by the location by selecting the correct labware type from the list.

6. In the **Device Properties**, select the desired profile if it is not already selected.

7. Select **File > Device File > Save** to save the changes to the device file.

---

### Setting the Use linked location

Currently, this feature is enabled for the special situations in which there is a storage device such as a PlateHub Carousel, StoreX, or Cytomat and a robot, such as the Velocity11 Translator robot that is shuttling plates between systems.

To use this feature, select yes and then select the device location to which you want to link. This tells the software that the current device location is the same physical location as the device selected from the Device to use list.

**Note:** Selecting this option when it is not enabled will have no effect on the system.

---

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device drivers</td>
<td>“About device drivers” on page 7</td>
</tr>
<tr>
<td>Installing a device driver plug-in</td>
<td>“Installing device drivers” on page 9</td>
</tr>
<tr>
<td>Profiles</td>
<td>“About profiles” on page 15</td>
</tr>
<tr>
<td>Adding a device to the device manager</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
</tbody>
</table>
# Adding and linking Sub Process tasks

## About this topic
This topic describes how to add a sub-process to a protocol and configure it. Read this topic if you are an administrator or technician and are responsible for creating protocols in VWorks or BenchWorks software.

## Before you read this
Before you read this topic, become familiar with the topics in the *VWorks Version 3 Automation Control User Guide* or *BenchWorks Automation Control User Guide* describing what a protocol is and how it is created.

## Sub Process task defined
Sub Process tasks indicate the existence of a subroutine within a protocol. Sub-processes typically contain a series of liquid handling tasks used by devices such as the VPrep Pipettor or Multimek dispenser.

## Adding a Sub Process task
The first step in creating a pipette process is to add a Sub Process task to the protocol editor. Drag the Sub Process icon into the process.

![Image of Sub Process task](image)

## Setting Sub Process task parameters
When you add the Sub Process task, a new sub-process is started in the pipette process editor. This process is identified by its sub-process link icon.

![Image of Sub Process link icon](image)

Because you can have more than one sub-process in a protocol, you must link the Sub Process task to the correct sub-process.

**To link the Sub Process task to the correct sub-process:**

1. In the Protocol Editor, add a Sub Process task to the protocol and then select it in the protocol sequence.
2. In the Protocol Task Parameters toolbar, select the sub-process that you want to use for this pipetting task from the Use Sub Process list.
3. If there is only one sub-process and you need to create a second one, click Add New.

**Associating the sub-process to a device**

Because you can have more than one device that uses sub-processes on a lab automation system, you must link each sub-process link icon with one or more devices that you want the sub-process to be able to use. You do this by setting the parameter for the sub-process link icon.

**To link a Sub Process task to a device:**

1. In the Pipette Process Editor, select the Sub Process link icon.

2. In the Available devices list of the Pipette Task Parameters toolbar, select one or more pipettors to link to and click Add.

The selected pipettors move to the lower box and become available for use.
Using JavaScript to set task parameters

About this topic

JavaScript programs (scripts) can be used to change the parameters of a protocol task immediately before it is scheduled. This extends the capability of VWorks or BenchWorks software because the parameters can be changed dynamically during a run, based on the following:

- Information passed from an external source, such as a database
- The number of times the protocol has cycled
- Feedback on changing conditions during the run

This topic describes the use of JavaScript to set task parameters in a protocol.

Read this topic if you are an administrator or technician responsible for creating VWorks or BenchWorks software protocols and want to add functionality to a task using JavaScript.

Where scripts are written

Scripts can be written in two ways:

- Directly into the box in the Advanced Settings tab of the Task Parameters toolbar
- As an external file that is located by clicking Browse in the Advanced Settings tab and navigating to its location on the hard drive

*Note*: You can also call an external file by embedding the “`open()`” function in the box.

The following screenshot displays a short script that prints the parameters of a task to the log toolbar, just before the task runs. In this case, the script is written directly in the Advanced Settings box.
For more information about using JavaScript, refer to the *VWorks Version 3 Automation Control User Guide* or the *BenchWorks Automation Control User Guide*.

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
</table>
| Using JavaScript in protocols | ❑ *VWorks Version 3 Automation Control User Guide*  
❑ *BenchWorks Automation Control User Guide* |
| Adding tasks to protocols | ❑ *VWorks Version 3 Automation Control User Guide*  
❑ *BenchWorks Automation Control User Guide* |

### About reader output files

#### About this topic

Plug-in device drivers that are written for plate readers have a common way of naming their output files. This topic explains the concepts related to output file naming. By reading this topic, you will learn how to prevent data in the reader output files from being overwritten by newer data.

Read this topic if you are an operator who wants to make changes to the task parameters for one of these readers:

❑ VR4000  
❑ Analyst GT  
❑ Fusion  
❑ Viewlux  
❑ Tecan readers

#### Plug-in default output file

When you first install a reader device driver plug-in, all data recorded during a protocol or by a manual read using diagnostics software is written to a single file stored in the C: drive.
The exact name of the file is specific to the device. For example, the RVSI VR4000 device driver creates a file with the name vialreaderresults.txt.

This file can only store data for one read, which means that the set of data for each read overwrites the last set in the file. To avoid this problem you must set up an output file naming convention.

**Profile default output file name**

Some device drivers allow more than one device of that type to be used in the lab automation system. In this case, each device must have its own profile. Even if you have only one device, you can still set up multiple profiles for it, with each storing different settings.

In these cases, you probably want each profile to have a separate default output filename to prevent the data from runs using one profile overwriting those of another.

**Filename suffixes**

To prevent the data from one read overwriting the data from another, you need to append a variable suffix to the file name. You can append a date/time stamp and one or more bar codes on the rack or plate.

**Example**

The example output file folder below shows that a profile default file name of output.txt was created at one time. At another time, a suffix was appended in the profile for the device driver, which added a barcode identifier to the file name (for example output_C100040329.txt).
Overriding output file names with tasks

You can override the default output file name that is set in the profile using the Output filename property of the Read task parameters. This allows you to use different output file names for every task.

The suffix used for the file name that you set in the task parameters is taken from the suffix specified in the device diagnostics profile. So if you select date/time stamp in the profile, the date/time stamp will also be appended during a run in which you have specified a different file name.

Related topics

<table>
<thead>
<tr>
<th>For more information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
<tr>
<td>Profiles</td>
<td>“About profiles” on page 15</td>
</tr>
</tbody>
</table>
### About device initialization

**About this topic**
When working in device diagnostics software, you are often required to initialize the device. This topic explains why device initialization is necessary.

**Opening communications**
Initializing a device opens communications with it. For example, if the device is connected with a serial cable, the COM port is opened, and if the device is connected with an Ethernet cable, the TCP/IP socket is connected.

**Homing motors**
Initializing a device homes motors that do not track their position along their line of travel. Homing a motor moves it until it triggers an event, called a home flag. This tells the motor its location.

The motors on some devices automatically move to their home positions when the device is turned on. The motors on other devices must be initialized to be homed.

**Setting profile parameters**
Initializing a device applies relevant parameters set in the device’s profile.

**Setting state and memory variables**
Most devices store variables in software or firmware. Initializing a device sets these variables to their initial values.

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Diagnostics</td>
<td>❑ “About diagnostics” on page 11</td>
</tr>
<tr>
<td></td>
<td>❑ “Opening diagnostics” on page 12</td>
</tr>
<tr>
<td>Workflow for configuring devices</td>
<td>“Adding devices” on page 10</td>
</tr>
</tbody>
</table>
The RVSI VR4000 is a device that reads data matrix labels on the bottoms of sample tubes. The labels encode sample identification information. The VR4000 can be configured to work in lab automation systems running VWorks.

This chapter contains the following topics:

- “Workflow for configuring the VR4000” on page 28
- “Creating a VR4000 profile” on page 29
- “Setting VR4000 task parameters” on page 31
- “Managing VR4000 profiles” on page 35
- “Operating the VR4000 with diagnostics” on page 37
Workflow for configuring the VR4000

About this topic
This topic presents the workflow for configuring the VR4000 device driver.
Read this topic if you are an administrator responsible for setting up devices in VWorks.

Before you start
Before you can configure the VR4000 device driver, you must have installed it. For installation instructions, see “Setting the properties for a device” on page 16.

Workflow

<table>
<thead>
<tr>
<th>Step</th>
<th>Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>2</td>
<td>“Creating a VR4000 profile” on page 29</td>
</tr>
<tr>
<td>3</td>
<td>“Setting the properties for a device” on page 16</td>
</tr>
</tbody>
</table>

Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device drivers</td>
<td>“About device drivers” on page 7</td>
</tr>
<tr>
<td>Setting VR4000 task parameters</td>
<td>“Setting VR4000 task parameters” on page 31</td>
</tr>
<tr>
<td>Managing RVSI VR4000 profiles</td>
<td>“Managing VR4000 profiles” on page 35</td>
</tr>
<tr>
<td>Using RVSI VR4000 Diagnostics</td>
<td>“Operating the VR4000 with diagnostics” on page 37</td>
</tr>
</tbody>
</table>
Creating a VR4000 profile

About this topic
This topic describes how to create a profile for the VR4000.
You do not need to specify communications settings for the VR4000 because it communicates with the computer directly through a graphics capture card.
Read this topic if you are an administrator responsible for setting up devices in VWorks.

Before you start
Before you create a profile, you must add the VR4000 to the device manager.

Procedure
To create a VR4000 profile:
1. Open RVSI VR4000 Diagnostics.
2. Click the Profiles tab.
3. Click Create a new profile.
4. In the Create Profile dialog box, enter a name for the profile and click OK.
The name appears in the Profile name box.
5. In the Profile Settings area, set the following:
6. Click **OK** to save the profile and exit VR4000 Diagnostics.

### Related topics

<table>
<thead>
<tr>
<th>For information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
<tr>
<td>Adding the RWSI VR4000 to the device manager</td>
<td>“Adding devices” on page 10</td>
</tr>
<tr>
<td>The next step</td>
<td>“Setting the properties for a device” on page 16</td>
</tr>
<tr>
<td>The workflow this procedure belongs to</td>
<td>“Workflow for configuring the VR4000” on page 28</td>
</tr>
<tr>
<td>Managing RWSI VR4000 profiles</td>
<td>“Managing VR4000 profiles” on page 35</td>
</tr>
<tr>
<td>Preventing output file data from being overwritten</td>
<td>“About reader output files” on page 22</td>
</tr>
<tr>
<td>Using VR4000 tasks</td>
<td>“Setting VR4000 task parameters” on page 31</td>
</tr>
<tr>
<td>Profiles</td>
<td>“About profiles” on page 15</td>
</tr>
</tbody>
</table>
Setting VR4000 task parameters

About this topic

When the RSVI VR4000 device is added to the device manager, the tasks associated with the device become available in the protocol editor. When a task is added to a protocol, you need to set the parameters for it. This includes choosing which VR4000 to use and what properties to select for it.

This topic describes the RSVI VR4000 tasks and their parameters.

Read this topic if you are:

- An administrator or technician responsible for creating protocols
- An operator who wants to make changes to the VR4000 task parameters in a protocol

Note: Operators cannot save changes to protocols.

About VR4000 tasks

The RSVI VR4000 device driver adds two tasks to VWorks. These tasks are used to deliver commands to the VR4000 during the execution of a protocol and perform other functions in VWorks.

The RSVI VR4000 tasks are represented by icons in the Protocol Tasks toolbar:

- ![Read tubes (RSVI VR4000)]
- ![Check tubes (RSVI VR4000)]

Read tubes (RSVI VR4000)

This task, available only in the protocol editor, reads data matrix identification labels on tubes in a rack and writes the data to an output text file that you specify. For more information about the output file, see “Related topics” at the end of this topic.

Check tubes (RSVI VR4000)

This task, available only in the protocol editor, reads data matrix identification labels on tubes and compares the data with data in a text file. If there is a mismatch, an error is generated. You can choose whether the error should stop the protocol or quarantine the rack containing the mismatched label.

The text file should be formatted with data in tab-delimited columns like this example below.
The top, left data entry represents the A1 well. The 12 columns and 8 rows represent the 12 columns and 8 rows of a 96-well tube rack.

Empty positions in the rack are represented by empty tabbed space.

If there is a mismatch between a label and an entry in the text file, what happens next depends on your setting for the Report error on mismatch property in the Protocol Task Parameters toolbar for this task.

- If you select No, the protocol will continue as though there has been no mismatch. If you select Yes, what happens depends on your settings in the VWorks general error handling options and the plate icon parameters.

  If in the VWorks general error handling options (Tools > Options) Halt on barcode misreads is selected, the standard error dialog box opens on a mismatch and the protocol is paused until you respond.

  If this option is not selected, the run continues but you have the option of quarantining the rack that contains the mismatched tube.

  Quarantining of racks is set up in the plate icon task parameters.

If you decide to report errors on mismatches, you can output the number of mismatches at the end of the protocol run to a JavaScript variable whose name you specify in the task parameters. You can then write custom JavaScripts that use this variable to perform custom actions.

**JavaScript example: check tube IDs**

In this example, javafilename is defined at an earlier protocol step. The system expects that file will be in the path defined by Checkagainstfilename (for example, c:\RVSI\testfile.txt).

```javascript
    task.Checkagainstfilename = "c:\RVSI\" + javafilename
```

**JavaScript example: number of misses**

After reading the plate the Mismatchesscriptingvariable "numberofmisses" will be zero if the reader matches the specified file
exactly. The script sets a flag for the plate if there are mismatches between the tube map and the values that are read.

```python
if (numberofmisses > 0)
{
    print("the plate did not match the file")
    plate.setUserData("mismatch","true")
}
```

### Setting Read tubes (RVSI VR4000) task parameters:

1. Add the Read tubes (RVSI VR4000) task to the protocol process.
2. In the Protocol Task Parameters toolbar, make sure that the Task Settings tab is displayed.
3. Select the VR4000 or VR4000s and click **Add**.
   - The device name moves to the right of the **Add** and **Remove** buttons.
4. Set the **Read tubes properties**.

<table>
<thead>
<tr>
<th>Property</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use tubes expected parameter</td>
<td>Select Yes to use the Tubes expected property. Select No if you do not know how many tubes there will be in the racks.</td>
</tr>
<tr>
<td>Tubes expected (0-96)</td>
<td>The number of tubes that are expected to be in the rack. If there is a mismatch with this number, the behavior will be the same as with a tube read mismatch described earlier in this topic.</td>
</tr>
<tr>
<td>Output filename</td>
<td>Select the text file that you want to write the label identification data to (you must first create the file).</td>
</tr>
</tbody>
</table>

5. Select **File > Protocol File > Save** to save the changes to the protocol file.

### Setting Check tubes (RVSI VR4000) task parameters:

1. Add the Check tubes (RVSI VR4000) task to the protocol process.
2. In the Protocol Task Parameters toolbar, make sure that the Task Settings tab is displayed.
3. Select the VR4000 or VR4000s and click **Add**.
The device name moves to the right of the **Add** and **Remove** buttons.

![Protocol Task Parameters](image)

4. Set the **Check tubes properties**.

<table>
<thead>
<tr>
<th>Property</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check against filename</td>
<td>Select the text file that contains the data to check against.</td>
</tr>
<tr>
<td>Report error on mismatch</td>
<td>Select Yes if you want to create an error when there is a mismatch. Select No if you do not want to stop the protocol. In this case, you can set up VWorks to quarantine the rack containing the mismatched label. If you do not set up quarantining, the racks with mismatches will be processed in the same way as racks with no mismatches.</td>
</tr>
<tr>
<td>Mismatches scripting variable</td>
<td>Specifies the name of a JavaScript variable that is used to store the number of mismatches in a protocol.</td>
</tr>
</tbody>
</table>

5. Select **File > Protocol File > Save** to save the changes to the protocol file.

**Related topics**

<table>
<thead>
<tr>
<th>For more information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>The workflow that this procedure belongs to</td>
<td>“Workflow for configuring the VR4000” on page 28</td>
</tr>
<tr>
<td>Creating protocols, pre-protocols, post-protocols, and pipette processes</td>
<td><em>VWorks User Guide</em></td>
</tr>
<tr>
<td>Opening RVSI VR4000 device properties page</td>
<td>“Setting the properties for a device” on page 16</td>
</tr>
<tr>
<td>Managing RVSI VR4000 profiles</td>
<td>“Managing VR4000 profiles” on page 35</td>
</tr>
<tr>
<td>Using RVSI VR4000 Diagnostics</td>
<td>“Operating the VR4000 with diagnostics” on page 37</td>
</tr>
<tr>
<td>Output file naming</td>
<td>“About reader output files” on page 22</td>
</tr>
</tbody>
</table>
Managing VR4000 profiles

About this topic
This topic describes how administrators and technicians can manage VR4000 profiles.

Managing profiles
To manage VR4000 profiles:
1. Open RWSI VR4000 Diagnostics.
2. Click the Profiles tab.
3. Select a profile from the Profile name list.
4. Perform the management task.
   Management tasks include the following:
   - Updating the profile. Use this command to save edits to an existing profile.
   - Copying a profile.
   - Renaming a profile.
   - Deleting a profile.

Related topics
For more information about... | See...
--- | ---
Opening diagnostics | “Opening diagnostics” on page 12
Profiles | “About profiles” on page 15
<table>
<thead>
<tr>
<th>For more information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating the VR4000</td>
<td>“Operating the VR4000 with diagnostics” on page 37</td>
</tr>
<tr>
<td>Preventing output file data from being overwritten</td>
<td>“About reader output files” on page 22</td>
</tr>
</tbody>
</table>
Operating the VR4000 with diagnostics

About this topic

This topic describes how to:

- Initialize the VR4000
- Manually read the data matrix labels
- Manually compare the data matrix labels used on a rack of tubes to the data in a text file
- Open the RVS1 Acuity CiMatrix vial reader software

Read this topic if you are an operator who wants to troubleshoot or operate the VR4000 using direct commands.

Before you start

Before you can send commands to the VR4000, or receive status information from the VR4000, you need to initialize it.

To initialize the VR4000:
1. Open VR4000 Diagnostics.
2. Click the Profiles tab.
3. Select a profile from the Profile name list.
4. Click Initialize this profile.

Manually reading vial data matrix labels

Before manually reading a rack of tubes with data matrix labels, you can specify the name of the text file that the data is written to. For general information about how output text files are managed, see “Related topics” at the end of this topic.

To specify a text file to write the data to:
1. Create or locate a text file to write the data to.
2. Open RVS1 VR4000 Diagnostics.
3. Click the Profiles tab.
4. In the Default output filename selector, click the ellipsis button (...) and navigate to the text file that you want to use.

Performing a read

To read a rack of tubes:
1. Open RVS1 VR4000 Diagnostics.
2. Click the Controls tab.
3. Click Read.

The data is displayed in the grid and also written to the specified text file.

To manually check the read data against a text file:

1. Open RVI VR4000 Diagnostics.
2. Click the Controls tab.
3. Select the file that you want to check the read data against and click Check.

If there is a mismatch, an error is returned and the table cells representing the mismatch turn red.
Opening RVSI Acuity CiMatrix software

To open RVSI Acuity CiMatrix software:

1. Open RVSI VR4000 Diagnostics.
2. Click the Controls tab.
3. Click Show RVSI GUI.

The RVSI Acuity CiMatrix software opens in a new window.

Consult the user documentation accompanying the VR4000 for more information about this software.
### Related topics

<table>
<thead>
<tr>
<th>For more information about...</th>
<th>See...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Opening diagnostics</td>
<td>“Opening diagnostics” on page 12</td>
</tr>
<tr>
<td>Profiles</td>
<td>“About profiles” on page 15</td>
</tr>
<tr>
<td>Managing VR4000 profiles</td>
<td>“Managing VR4000 profiles” on page 35</td>
</tr>
<tr>
<td>Preventing output file data from being overwritten</td>
<td>“About reader output files” on page 22</td>
</tr>
<tr>
<td>Initializing a device</td>
<td>“About device initialization” on page 25</td>
</tr>
</tbody>
</table>