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Microscan Barcode Reader
Device Driver Guide
Preface 

This preface contains the following topics:

• “About this guide” on page vi

• “Accessing product user information” on page vii

• “Reporting problems” on page x
v
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About this guide
About this guide

Who should read this guide

This user guide is for people with the following job roles:

 

What this guide covers

This guide describes how to configure the Microscan Laser Barcode Scanner in 
the VWorks software using the Microscan Barcode Reader device- driver plugin. 
Once configured, you can use the tasks and Diagnostics associated with the 
device.

Software version

This guide documents Microscan Barcode Reader Diagnostics version 13.10.

Related guides

Use this guide in connection with the following:

• VWorks Automation Control Setup Guide. Explains how to define labware 
and labware classes, liquid classes, and pipetting techniques, and how to 
track and manage labware in storage.

• VWorks Automation Control User Guide. Explains how to create protocols, 
and set task parameters for each device in the system.

• The workstation installation instructions provided to you by Agilent 
Technologies.

• The specific device user guide for the devices in your workstation.

Job role Responsibilities

Installer Unpacks, installs, and tests the device before it is used.

Integrator Configures hardware and writes software.

Lab manager, 
administrator, 
or technician

• Manages the automation system that contains the 
device

• Develops the applications that are run on the system

• Develops training materials and standard operating 
procedures for operators

Operator Performs the daily production work on the device and 
solves routine problems.
vi Microscan Barcode Reader Device Driver Guide
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Accessing product user information

About this topic

This topic describes the different formats of user information and explains how 
to access it for the Agilent Automation Solutions products.

Where to find user information

The Automation Solutions user information is available in the following 
locations:

• Knowledge base. The help system that contains information about all the 
Automation Solutions products is available from the Help menu within the 
VWorks software. 

• PDF files. The PDF files of the user guides are installed with the VWorks 
software and are on the software CD that is supplied with the product. A 
PDF viewer is required to open a user guide in PDF format. You can 
download a free PDF viewer from the internet. For information about using 
PDF documents, see the user documentation for the PDF viewer.

• Agilent website. You can search the online knowledge base or download the 
latest version of any PDF file from the Agilent website at www.agilent.com/
chem/askb. 

Accessing safety information

Safety information for the Agilent Automation Solutions devices appears in the 
Automation Solutions Products General Safety Guide and in the 
corresponding device safety guide or user guide.

You can also search the knowledge base or the PDF files for safety information.

Using the knowledge base

Knowledge base topics are displayed using web browser software such as 
Microsoft Internet Explorer and Mozilla Firefox.

Note: If you want to use Internet Explorer to display the topics, you might 
have to allow local files to run active content (scripts and ActiveX controls). To 
do this, in Internet Explorer, open the Internet Options dialog box. Click the 
Advanced tab, locate the Security section, and select Allow active content to run in 
files on my computer.

To open the knowledge base, do one of the following:

• From within VWorks software, select Help > Knowledge Base or press F1.

• From the Windows desktop, do one of the following:

– Windows 10. Select Start > All Apps > Agilent Technologies > VWorks 
Knowledge Base.

– Windows 7. Select Start > All Programs > Agilent Technologies > VVWorks > 
User Guides > VWorks Knowledge Base.
viiMicroscan Barcode Reader Device Driver Guide
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Opening the help topic for an area in the VWorks window

To access the context-sensitive help feature:

1 In the main window of the VWorks software, click the help button . 

The pointer changes to . Notice that the different icons or areas are 
highlighted as you move the pointer over them.

2 Click an icon or area of interest. The relevant topic or document opens. 
viii Microscan Barcode Reader Device Driver Guide



Preface
Accessing product user information
Features in the Knowledge Base window

 

Item Feature

1 Navigation area. Consists of four tabs:

• Contents. Lists all the books and the table of contents of the 
books.

• Index. Displays the index entries of all of the books.

• Search. Allows you to search the Knowledge Base (all products) 
using keywords. You can narrow the search by product.

• Favorites. Contains bookmarks you have created.

2 Navigation buttons. Enable you to navigate through the next or 
previous topics listed in the Contents tab.

3 Content area. Displays the selected online help topic.

4 Toolbar buttons. Enable you to print the topic or send documentation 
feedback by email.
ixMicroscan Barcode Reader Device Driver Guide
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Reporting problems

Contacting Automation Solutions Technical Support 

Note: If you find a problem with the Microscan Barcode Reader, contact 
Automation Solutions Technical Support. For contact information, see Notices 
on the back of the title page. 

Note: You can also send a software bug report from within the VWorks 
software.

Reporting hardware problems

When contacting Agilent Technologies, make sure you have the serial number 
of the device or workstation ready.

Reporting software problems

When you contact Automation Solutions Technical Support, make sure you 
provide the following:

• Short description of the problem

• Software version number

• Error message text (or screen capture of the error message dialog box)

• Screen capture of the About VWorks software dialog box

• Relevant software files

To find the VWorks software version number:
In the VWorks software, select Help > About VWorks.

To find the Diagnostics software version number:

1 Open Diagnostics.

2 Read the version number on the title bar of the diagnostics window.

To send compressed protocol and associated files in VZP format:

In the VWorks software, select File > Export to export and compress the 
following files:

• Protocol file

• Device file (includes the device profile and teachpoint file)

• Labware definitions

• Liquid classes

• Pipette techniques

• Hit- picking files

• Plate map files

• Barcode files

• Error library

• Log files

• Form file (*.VWForm)
x Microscan Barcode Reader Device Driver Guide
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Reporting user guide problems

If you find a problem with this user guide or have suggestions for 
improvement, send your comments using one of the following methods:

• Click the feedback button ( ) in the online help.

• Send an email to documentation.automation@agilent.com.
 

xiMicroscan Barcode Reader Device Driver Guide
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Microscan Barcoder Reader
Device Driver Guide
1
Introduction

This chapter provides an overview of setting up a device in the 
VWorks software.

Before reading this guide, you should be familiar with the VWorks 
software user interface. To set up and use the Microscan Barcode 
Reader, become familiar with the content in this guide as well as 
the guides for the other devices in your workstation that use 
VWorks software and interface with the Microscan Barcode Reader.

This chapter contains the following topics:

• “About devices” on page 2

• “Adding and configuring a device in the VWorks software” on 
page 3

• “About Diagnostics” on page 4

• “Opening Diagnostics” on page 5

• “About profiles” on page 6

• “About device intialization” on page 6
1
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About devices
About devices

What is a device?

In the VWorks software, a device is an item in your lab automation 
workstation that can be added to the VWorks device file. A device can be a 
robot, an instrument, or a location in the lab automation workstation that can 
hold a piece of labware. The following are examples of devices:

Examples of devices:

• BenchCel Microplate Handling Workstation

• PlateLoc Sealer

• Microplate Labeler

• Labware Stacker

• Platepad

• A third- party device

What is a device plugin?

A device plugin is software that enables the VWorks software to control and 
communicate with the specific type of device. Each type of device that you 
operate with VWorks software requires a device plugin. When a device plugin 
is installed in the VWorks software, an icon for the device appears in the 
Available devices list. 

Functions of a device plugin 

A device plugin enables the following:

• Tasks associated with the device. Device- specific tasks appear in the 
Protocol Tasks list and are available for use in creating protocols.

• Task parameters associated with the device. Device- specific task 
parameters appear in the Protocol Task Parameters toolbar. These 
determine the conditions with which to execute the tasks of the device.
2 Microscan Barcode Reader Device Driver Guide
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Adding and configuring a device in the VWorks software
• Diagnostic commands specific to the device. Device- specific diagnostic 
commands and options appear in the Device Diagnostics dialog box. These 
commands enable direct control of the device.

About device files

To communicate with and to control the robot and integrated devices, the 
VWorks software uses a device file that contains the following information:

• List of devices the software will communicate with and control

• Type of each device (for example, the robot, PlateLoc Sealer, and any 
integrated device)

• Properties of each device (for example, approach height, allowed or 
prohibited labware, barcode reader access, and so on)

• The communication settings (profile) for communication between the 
devices and the VWorks software

You provide the device information in the VWorks window. The device 
information is stored in a device (.dev) file that is located in a folder you 
specify when saving the file.
 

Adding and configuring a device in the VWorks software

Workflow

To configure your lab automation workstation to use a device, you add the 
device to a device file and then set the properties for the device in the VWorks 
software. The VWorks software uses the information in the device file to 
communicate and operate the device within the workstation. 
3Microscan Barcode Reader Device Driver Guide
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About Diagnostics
The sequence of steps required to add and configure a device to the VWorks 
software are as follows:

About Diagnostics

Using Diagnostics

Diagnostics is the plugin software that you open from within the VWorks 
software. You use Diagnostics to do the following:

• Set up the device. You create a device profile that specifies the 
communication connection (for example, the Ethernet connection) and 
other properties for the specific device

• Troubleshoot problems with the device.

For example, if an error occurs during a run that leaves a plate and the

robot where they should not be, you can use robot diagnostics to move

the plate and return the robot to its home position.
                                                        

Step For this task... Do the following...

1 Create a new device file (if 
one does not exist), or

Open an existing device file.

In the VWorks window, select File > 
New > Device. A Device File tab 
appears.

In the VWorks window, select File > 
Open, make sure All Files or Device 
Files (.dev) type is selected, and 
locate the appropriate device file.

2 Add the device to the device 
file.

In the Available Devices area, 
double- click the device that you 
want to add. Alternatively, you can 
drag a device from the Available 
Devices area into the Device File 
area.

3 Save the device file. Select File > Save to save the device 
file. The file name appears in the 
Device File tab. 

4 Create a profile for the device. From the device file, open 
Diagnostics for the device and click 
Create a profile.

5 Set the device properties Select the device in the Devices 
area of the device file and set the 
properties that appear in the left-
side area of the device file, for the 
device.
4 Microscan Barcode Reader Device Driver Guide
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Opening Diagnostics

About this topic

To establish communication between the host computer and the device, you 
initialize the device. You can initialize the device in the following ways:

• Diagnostics. To control the device using the Diagnostics software. 

• VWorks window. To use VWorks to control the device, for example, to run 
a protocol, you initialize the devices in the VWorks window. 

This topic describes what happens during initialization.

Procedure

To open Diagnostics:

1 In the VWorks software window, ensure the correct device file is open. 

To open a device file, choose File > Open, and then select the appropriate 
device file (*.dev) in the Open dialog box.

2 In the Devices area of the opened device file tab, highlight the device icon, 
and then click Device diagnostics.

Alternatively, you can double- click the device icon.

The device’s diagnostics dialog box opens.
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About profiles

Profiles defined

A profile is a collection of settings, stored in the Windows registry, that 
manages how you connect to a device. A profile:

• Specifies the port or IP address used to establish communication between 
the device and the controlling computer.

• For robots only. References a teachpoint file. For a description of 
teachpoint files, see the specific robot’s user guide.

• Specifies other settings specific for the device. 

Creating a profile

You use the device’s Diagnostics software to create and manage profiles. 

In the VWorks software, each device in the device file requires a unique 
profile. The profile is referenced by a device file. For a detailed description of 
the relationships between the device file, profile, and teachpoint file, see the 
VWorks Automation Control User Guide.
 

About device intialization

About this topic

When working in device diagnostics software, you are often required to 
initialize the device. This topic explains why device initialization is necessary.

Opening communications

Initializing a device opens communications with it. For example, if the device 
is connected with a serial cable, the COM port is opened, and if the device is 
connected with an Ethernet cable, the TCP/IP socket is connected.

Homing motors

Initializing a device homes motors that do not track their position along their 
line of travel. Homing a motor moves it until it triggers an event, called a home 
flag. This tells the motor its location. The motors on some devices 
automatically move to their home positions when the device is turned on. The 
motors on other devices must be initialized to be homed.

Setting profile parameters

Initializing a device applies relevant parameters set in the device’s profile.
6 Microscan Barcode Reader Device Driver Guide
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Setting state and memory variables

Most devices store variables in software or firmware. Initializing a device sets 
these variables to their initial values.
7Microscan Barcode Reader Device Driver Guide
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About device intialization
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2
Setting up a Microscan Barcode Reader

This chapter contains the following topics:

• “Workflow for setting up the Microscan Barcode Reader” on 
page 10

• “Adding a Microscan Barcode Reader to a VWorks device file” 
on page 11

• “Creating Microscan Barcode Reader profiles” on page 15

• “Editing and managing profiles” on page 17

• “Testing the Microscan Barcode Reader” on page 17

• “Using the Scan bar code (Microscan Bar Code Reader) task” 
on page 19

• “Using JavaScript to set task parameters” on page 21
9
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Workflow for setting up the Microscan Barcode Reader
Workflow for setting up the Microscan Barcode Reader

The following table presents the workflow for setting up a Microscan Barcode 
Reader.

Step For this task... See...

1 Turn on the Microscan 
Barcode Reader.

User documentation for the 
Microscan Barcode Reader

2 Add the Microscan Barcode 
Reader to the VWorks software 
device file and set the device 
properties.

“Adding a Microscan Barcode 
Reader to a VWorks device file” on 
page 11

3 Create a profile and set the 
profile properties.

“Creating Microscan Barcode 
Reader profiles” on page 15

4 Verify the scanner can read a 
barcode.

“Testing the Microscan Barcode 
Reader” on page 17

5 Set the Microscan Barcode 
Reader task parameters in a 
VWorks protocol.

“Using the Scan bar code 
(Microscan Bar Code Reader) task” 
on page 19
10 Microscan Barcode Reader Device Driver Guide
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Adding a Microscan Barcode Reader to a VWorks device file

About this topic

This topic describes how to add the Microscan Barcode Reader to a VWorks 
device file. The VWorks software uses the information in a device file to 
communicate with and operate devices within the lab automation system. 

• If your workstation was configured by Agilent Technologies. The correct 
device configuration is already set up for communication with the 
Microscan Barcode Reader. You are not required to create a new device file 
or add the device in the software unless you want to reference different 
profiles, integrate additional devices with the workstation. To establish 
communication, you must initialize the device.

• If you are configuring your workstation. You must add the Microscan 
Barcode Reader device in the VWorks device file. You must also add in the 
software any devices that are physically integrated with the workstation.

For detailed information about device files and associations with profiles, 
teachpoints, and labware definitions, see the VWorks Automation Control User 
Guide.

Creating a device file

If you are setting up a new workstation configuration, you will need to create 
a device file.

To create a device file:

1 Log in to VWorks software as an administrator.

2 In the VWorks window, choose File > New > Device. 

3 A Device File tab appears in the VWorks window.

4 Choose File > Save. In the Save As dialog box, type a file name (*.dev), select 
the following storage location, and click Save:
…\VWorks Workspace\Device Files. The file name appears in the Device 
File tab.
11Microscan Barcode Reader Device Driver Guide
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Adding a Microscan Barcode Reader to a VWorks device file
Adding a device

The following procedure describes how to add the Microscan Barcode Reader 
to a device file. 

To add a Microscan Barcode Reader:

1 Open the device file that contains the other devices in your workstation. 
See “Adding and configuring a device in the VWorks software” on page 3.

2 In the Available Devices area, double- click the Microscan Barcode Reader 
icon. Alternatively, you can drag the icon from the Available Devices area 
into the Device File area.

3 In the Microscan Barcode Reader Properties area, type a Name for the device. In 
the following example, the name shown is the default, Microscan Barcode 
Reader - 1.
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Adding a Microscan Barcode Reader to a VWorks device file
4 Select the Profile.

If the profile you want does not appear in the list, or if no profile appears 
in the list, you need to:

• Create a profile. See “Creating Microscan Barcode Reader profiles” on 
page 15

• Return to this step to select the profile.

Note: Without a profile, you will not be able to establish communication 
with the device.

5 Select File > Save to save the device file.

6 In the Devices area, expand the Microscan Barcode Reader and select Stage.
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Adding a Microscan Barcode Reader to a VWorks device file
7 In the Microscan Barcode Reader Stage Location Properties area, select the 
following:

8 In the Devices area, select the Microscan Barcode Reader, and then click 
Initialize selected devices to establish communication with the device. 

Deleting a Microscan Barcode Reader from the device file

To delete a Microscan Barcode Reader from the device file:

1 In the VWorks window, select the Microscan Barcode Reader you want to 
delete in the Devices area.

2 Click Delete selected devices. 

Property Description

Allowed/prohibited labware Permitted labware class for the selected 
location. Use this field only if you want 
to limit the labware types. For details 
on labware classes, see the VWorks 
Automation Control Setup Guide. 

Teachpoint for robot <robot 
name>

The option for the Microscan Barcode 
Reader stage to be accessed by the 
robot configured in the workstation.

Use for deadlock avoidance The option to use the Microscan 
Barcode Reader stage as a location to 
avoid a deadlock when executing a 
protocol.

Door The option to set up an automated 
pass- through for a device that has a 
gate or door. See theVWorks 
Automation Control User Guide for 
more information.
14 Microscan Barcode Reader Device Driver Guide
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Creating Microscan Barcode Reader profiles

About this topic

This topic explains how to create a new profile for the Microscan Barcode 
Reader. For more information on profiles, see “About profiles” on page 6.

Creating a Microscan Barcode Reader profile

To create a Microscan Barcode Reader profile:

1 In the Devices area, select the Microscan Barcode Reader, and then click 
Device diagnostics.

The Microscan Barcode Reader Diagnostics dialog box opens.
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2 If it is not already displayed, click the Profiles tab.

3 In the Profile Management area, click Create a new profile. The Create Profile 
dialog box opens. 

4 Type a name, and click OK. The name appears in the Profile Management 
area.

5 In the Profile Settings area, set the following parameters:

6 Click Update this profile to save the changes.

7 Click Initialize this profile to establish communication with the Microscan 
Barcode Reader.

Profile parameter Description

Serial Port The controlling computer COM port that is 
connected to the Microscan Barcode Reader.

Note: The Serial Port parameter will be 
automatically defined when a USB- to- serial 
adapter is connected to the computer. You might 
need to lookup the port assigned to this device in 
the Windows Device Manager. 

Occasionally, a port number is reassigned for a 
USB- to- serial connection if you disconnect and 
reconnect the device. If this happens, you must 
verify that the correct Serial Port is set in each 
profile. 

Default barcode side The side of the labware the barcode is on, East, 
West, North, or South. 

Note: This is the side that is used when testing 
the scanner in Diagnostics. When running a 
protocol, you specify the side in the Scan 
Barcode task.
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Editing and managing profiles

Editing a profile

To edit a profile:

1 In the Microscan Barcode Reader Diagnostics Profiles tab, select the profile 
you want to edit in the Profile Management area.

2 Modify the profile information.

3 When you are finished, click Update this profile to save the changes. 

Managing profiles
In the Microscan Barcode Reader Diagnostics Profiles tab, you can select an 
existing profile, and then rename, copy, or delete the profile.

Testing the Microscan Barcode Reader

About this topic

This topic describes how to use Diagnostics to test barcode scanning with the 
Microscan Barcode Reader.

Before you start

Make sure you have a labware that has a barcode label.

Procedure

To test the barcode scanning:

1 Place the labware on the Microscan Barcode Reader platepad and make 
sure the barcode label faces the Microscan Barcode Reader mirror.

2 Open Microscan Barcode Reader Diagnostics.

WARNING  Class II laser hazard. Looking directly at the laser beam can result in 
serious eye injury. Do not look directly at the laser beam.
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3 In the Profiles tab, select the Microscan Barcode Reader profile from the 
Profile list, and click Initialize this profile. 

4 Click the Controls tab.

5 Click Scan. The Microscan Barcode Reader turns on briefly to scan the 
barcode label. One of the following messages appears next to Result:

6 If the No barcode found message appears, click Scan again, and check that 
the barcode scanner laser beam is projected onto the vertical center of the 
barcode label.

Scan result message Description Next step

<barcode text> The barcode was 
successfully scanned

The setup is complete. 
No further adjustment 
is required.

No barcode found Barcode scanning was 
not successful.

Proceed to step 6.
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If the laser beam is not at the vertical center of the label, adjust the scan 
angle of the Microscan Barcode Reader mirror.

7 To optimize the scanner settings, click Calibrate.

Note: During the calibration process, the scanner attempts various 
settings to determine the optimum decode rate for the given conditions.

8 Repeat the scan.

Using the Scan bar code (Microscan Bar Code Reader) task

For information on creating protocols, see the VWorks Automation Control 
User Guide.

Description
The Microscan Barcode Reader device driver adds one task to the VWorks 

software. The Scan bar code task ( ) instructs the 
Microscan Laser Barcode Scanner to scan a barcode.

Adding the Microscan Bar Code Reader task to a protocol

In the Available Tasks area, double- click the Scan bar code task. Alternatively, drag 
a task from the Available Tasks area into the Protocol area. The task icon 
appears in the Protocol area. 

Setting the task parameters

After adding the Scan bar code task at the desired point in the protocol, set 
the following parameters in the Task Parameters area:

Task is available for... Task is available in...

Microscan Laser Barcode Scanner Main Protocol
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Selecting the device 

If you have more than one Microscan Barcode Reader, you must select the 
device you want to perform the task. To do this, click Device Selection, and 
double- click the device you want to use for this task from the Devices available 
to perform this task area. The selected device appears in the Devices involved in 
area.

Parameter Description

Side to scan The side of the labware on which 
the barcode label is attached 
(South, North, East, West).

Task description The option to change the task 
description.

Clear the Use default task 
description check box and type a 
description in the Task description 
area.
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Using JavaScript to set task parameters

About this topic

JavaScript programs (scripts) can be used to change the parameters of a 
protocol task immediately before it is scheduled. This extends the capability of 
VWorks software because the parameters can be changed dynamically during a 
run, based on the following:

• Information passed from an external source, such as a database

• The number of times the protocol has cycled

• Feedback on changing conditions during the run

This topic describes the use of JavaScript to set task parameters in a

protocol.

Where scripts are written

• Directly into the box in the Advanced Settings tab of the Task Parameters 
area

• As an external file that is located by clicking Browse in the Advanced 
Settings tab and navigating to its location on the hard drive

Note: You can also call an external file by embedding the "open()" function in 
the box.

The following screenshot displays a short script that prints the parameters of a 
task to the log toolbar, just before the task runs. In this case, the script is 
written directly in the Advanced Settings box. 

For more information about using JavaScript, see the VWorks Automation 
Control User Guide.
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