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About this guide

• This MassHunter VistaFlux Software workflow guide is part of a series of work-
flow guides developed to help you to analyze your sample data. Other workflow 
guides available in this series include:

Agilent Metabolomics Workflow - Discovery Workflow Guide

Integrated Biology with Agilent Mass Profiler Professional Workflow Guide

Class Prediction with Agilent Mass Profiler Professional Workflow Guide

Agilent Lipidomics Workflow Guide

• This workflow guide presents the steps involved in a qualitative flux analysis:
• Create a target metabolite list using MassHunter Pathways to PCDL and 

MassHunter PCDL Manager
• Extract the target metabolite features and isotopologues from your sample 

data using MassHunter Profinder.
• View the results on pathways network diagrams using Omix Premium.

• Formatting of text that appears in the left-hand margin helps guide you through 
the operations.

• Operations are illustrated with flow charts that show you how the wizards are 
navigated based on your experiment and selections.
4 
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Before you begin Introduction
Introduction Qualitative flux analysis comprises the steps to identify target metabolites of inter-
est for your experiment, create visual pathways networks for your experiment, 
acquire accurate mass data from your samples, extract accurate isotopic metabolite 
information from the sample data, and then view the results on network diagrams of 
the pathways involved in your experiment. The chapters of this workflow guide fol-
low the flow illustrated in Figure 1.

Figure 1 Steps to perform a qualitative flux analysis.

This workflow guide is part of a series of workflow guides developed to help you to 
analyze your sample data. Other workflow guides available in this series include Agi-
lent Metabolomics Workflow - Discovery Workflow Guide (5990-7067EN), Integrated 
Biology with Agilent Mass Profiler Professional Workflow Guide (5991-1909EN), 
Class Prediction with Agilent Mass Profiler Professional Workflow Guide (5991-
1911EN), and Agilent Lipidomics Workflow Guide (5991-1643EN).

To increase your confidence in obtaining reliable and statistically significant results, 
review the chapter “Prepare for an experiment” in the Agilent Metabolomics Work-
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Before you begin Introduction
flow - Discovery Workflow Guide and make sure your analysis includes a carefully 
thought-out experimental design that includes the collection of replicate samples.

What is flux analysis? Metabolomics is a powerful technique for understanding biological systems by mea-
suring the abundance of metabolites; however, data interpretation is often compli-
cated by a lack of dynamic information. For example, an increase in metabolite 
abundance can result from either increased production (pathway is up-regulated) or 
decreased consumption (pathway is down-regulated). Similarly, significant changes 
in flux through a pathway can possibly not result in altered abundance of metabolite 
intermediates at all. For example, the rate of metabolite production and turnover can 
have changed significantly, but the total metabolite pool abundances can have not 
changed due to homeostasis. Stable isotope tracing has tremendous potential to 
help address these situations and drive a deeper understanding of biological sys-
tems through contextualization of the interconversion of metabolites using path-
ways. Qualitative flux analysis highlights the relative rate at which these reactions 
take place.

In qualitative flux analysis, a stable isotope labeled tracer (typically containing 13C, 
15N, or 2H) is introduced into the biological system and results in changes in the nat-
ural isotopic pattern of downstream metabolites. Following analysis by LC/MS, local 
metabolic fluxes can be investigated by mining the data using a target list derived 
from known metabolic pathways. Isotopologues (metabolites differing only in isoto-
pic composition) are measured for each target compound and this information is 
used to track metabolic flux.

Qualitative flux analysis presents multiple analytical challenges such as how to mine 
the target metabolites, account for isotopologues, correct for naturally occurring iso-
topes, and visualize the results in a biological context. MassHunter VistaFlux is 
designed to meet these challenges and is a qualitative flux analysis solution for MS-
only data acquired on Agilent TOF-based high resolution LC/MS systems. 

Metabolomics tells us which investigated pathways are active in your experiment:
• Results from samples are associated with your experimental conditions.
• Metabolite abundance, isotopologue incorporation, and fold change between 

conditions are calculated and visualized.
• Metabolites are often part of more than one pathway.

Qualitative flux analysis identifies active pathways and affected metabolic enzymes 
in your experiment:

• Introduction of an isotopically labeled sugar or amino acid leads to the gradual 
appearance of metabolite isotopologues.

• By monitoring the isotopologues of the metabolites in your experiment, you 
can identify the active pathways in your experiment.

• Isotopologue data that indicates a change in metabolic flux rate can suggest 
that the enzyme activity may have changed due to regulation or mutation in 
the gene product itself.

The Agilent MassHunter VistaFlux Software provides an intuitive workflow to per-
form your qualitative flux analysis and visualize your results on pathways network 
7 



Before you begin Introduction
diagrams. The MassHunter tools necessary to perform a qualitative flux analysis are 
referred to collectively as MassHunter VistaFlux.

The qualitative analysis workflow, see Figure 2, is enabled by isotopologue tracing 
from an experiment employing an isotopically labeled source, such as 13C labeled 
glucose, glutamine, amino acid, or lipid. Data is acquired using a high resolution, 
accurate mass instrument that has good isotopic ratio fidelity, such as a TOF or Q-
TOF mass spectrometer. After you have identified the compounds (metabolites) you 
want to search for, you can mine the data based on the isotope patterns of the most 
important compounds using batch isotopologue feature extraction available in 
Profinder. The results are viewed in Omix Premium (“Visualize on pathways” on 
page 67), a visualization platform used to view your data within the context of bio-
chemical networks.

Figure 2 Illustration of the qualitative flux analysis workflow.

Isotopes, isotopologues, 
and isotopomers

Mass spectrometry is well known to use the presence of naturally occurring 
isotopes to improve feature quality and mass measuring accuracy. In a qualitative 
flux analysis isotopic measurements are important during an experiment employing 
an isotopically enriched compound. Samples are collected and analyzed to assess 
the effects of the experimental conditions on the isotopic enrichment of the 
metabolites. Isotopic enrichment during a qualitative flux analysis experiment leads 
to isotopomers and isotopologues. MassHunter VistaFlux Software mines your 
sample data for target metabolites and isotopologues, corrects the isotopologue 
results for the presence of naturally occurring isotopes, and helps you visualize the 
results in a biological context.

Isotopologues are molecules that contain the same molecular formula and structure 
but differ in their isotopic composition through the substitution of one or more 
atoms with a different isotope. The exact location of the isotope in the molecule, 
8 



Before you begin Introduction
while important chemically, is not important in flux analysis, just the number of iso-
topes in the molecule. Isotopologues can be identified using single-stage MS.

Isotopomers are molecules that contain the same molecular formula, structure, and 
number of isotopes but differ in the specific atomic location of the isotopes in the 
molecular structure. Isotopomers can be identified using advanced MS/MS tech-
niques.

Figure 3 An illustration of how two stable carbon isotopes in a four-carbon mole-
cule relate to isotopomers and isotopologues. Isotopologues are viewed in mass 
spectra during flux analyses. 

A simple four carbon molecule, fumaric acid (C4H4O4), is used to explain the rela-
tionship of isotopes to isotopomers, isotopologues, and mass spectra. The most 
abundant isotope of carbon is 12C. However, 13C, also stable, is not nearly as natu-
rally abundant as 12C; 13C has a natural occurrence of 1.1% of 12C. For simplicity, 
naturally occurring 13C is considered to be negligible; therefore, the mass of the nat-
urally occurring four-12C molecule is m (represented as 12C4), and there are no posi-
tional differences among the isotopes of the carbon atoms.

When a single 13C atom is substituted for one 12C atom, four locations are possible 
where the 13C atom can be placed (isotopomers as shown in Figure 3), and each iso-
topomer has a mass of m + 1 (12C3

13C). When two of the 12C atoms are replaced 
with 13C atoms, six isotopomers are possible, and each of the doubly substituted 
molecules has a mass of m + 2 (12C2

13C2). When three of the 12C atoms are replaced 
with 13C atoms, four isotopomers are possible, and each isotopomer has a mass of 
m + 3 (12C 

13C3). Finally, when all four of the 12C atoms are replaced with 13C atoms, 
only a single arrangement with a mass of m + 4 (13C4) exists. The five different 
9 



Before you begin Introduction
masses m, m + 1, m + 2, m + 3, and m + 4 represent the masses of the five isotopo-
logues visible in the resulting mass spectra.

The isotopologue data contained in the mass spectra from your samples, collected 
over time during your experiment (replicate samples collected for each time period 
constitute a group), can be visualized using Omix Premium within the context of the 
biochemical networks under study. Qualitative flux analysis in-turn helps you iden-
tify pathways whose changes in metabolic activity associate with conditions that 
are controlled in your experiment design.

Overview of the example 
experiment

The example experiment used in this workflow guide is based on a mutation of the 
isocitrate dehydrogenase 2 (IDH2) enzyme associated with chondrosarcoma, a bone 
cancer consisting of a malignant tumor from cartilage-producing cells. IDH2 
catalyzes the conversion of isocitrate to α-ketoglutarate (α-KG). In some tumors, a 
mutant form of this enzyme, a neo-enzyme, gains a function and instead catalyzes a 
reaction consuming α-KG and producing 2-hydroxyglutarate. Three replicate samples 
were acquired for each of five time points within an experiment; therefore, the 
experiment consists of five sample groups with three replicates for a total of fifteen 
sample data files.

IDH2 catalyzes the oxidative decarboxylation of isocitrate to α-ketoglutarate outside 
of the context of the tricarboxylic acid (TCA) cycle (Figure 4 on page 11). IDH2 uses 
the cofactor NADP to achieve its biological activity. During studies of cell lines that 
exhibit chondrosarcoma from the mutation of IDH2, a novel compound, 2-hydroxy-
glutarate, appears as a byproduct of the metabolism. IDH2 enzymes exhibiting the 
mutation produce 2-hydroxyglutarate from α-KG, thereby competing with the conver-
sion of α-KG to succinyl-coenzyme A, and subsequently with succinic acid and addi-
tional downstream metabolites in the TCA cycle. When a chondrosarcoma tumor 
has been established, elevated levels of glutathione can be associated with cancer-
ous activity.

Qualitative flux analysis begins by isotopologue monitoring in an experiment using a 
tracer. In the example experiment the tracer is labeled 13C5-glutamine (U-13C-Gln) 
that directly feeds the formation of α-KG in the TCA cycle. A list of the compounds 
that are part of this example experiment are presented in Table 1 on page 11.
10 



Before you begin Introduction
Figure 4 Illustration of the TCA cycle with the target metabolites listed and high-
lighted in the network diagram

Table 1  Compounds that are part of the example experiment

After administration of the tracer into the cell medium, samples are collected and 
analyzed over time to assess the isotopic enrichment of the metabolites down-
stream from the glutamine. Isotopic enrichment leads to isotopologues of the 
metabolites and are measurable in the acquired mass spectra. Viewing the isotopo-
11 



Before you begin Introduction
logue results in Profinder and Omix Premium helps you identify the isotopic enrich-
ments rates, flux.

More information The MassHunter VistaFlux Software Workflow Guide is part of the collection of 
Agilent manuals, help, application notes, and videos. The current collection of 
manuals and help are valuable to users who understand flux analysis, class 
prediction, and metabolomics workflows and who requires familiarization with the 
Agilent software tools. Video tutorials are also available and provide step-by-step 
instructions to analyze example sample data files. This workflow provides a step-by-
step overview of performing a qualitative flux analysis using MassHunter VistaFlux 
Software.

The following selection of publications provides materials related to MassHunter 
VistaFlux Software used to analyze your sample data:

• Manual: MassHunter Pathways to PCDL Software Quick Start Guide (G6825-
90008, Revision B, May 2016)

• Manual: MassHunter Personal Compound Database and Library Manager 
Quick Start Guide (G3336-90022, Revision A, September 2014)

• Manual: MassHunter PCDL for Qualitative Analysis Familiarization Guide 
(G5883-90002, Revision B, February 2016)

• Manual: MassHunter METLIN Metabolite PCD/PCDL Quick Start Guide 
(G6825-90009, Revision A, October 2014)

• Manual: MassHunter Profinder Software Quick Start Guide
 (G3835-90027, Revision A, April 2016)

• Manual: MassHunter Workstation Software Qualitative Analysis Familiariza-
tion Guide (G3336-90023, Revision A, September 2014)

A complete list of references can be found in “References” on page 143.

In this guide, some references are listed by publication num-
bers while others are listed by document name. You can easily 
download the documents from the Agilent literature library.

Go to the Agilent literature library at www.agilent.com/search 
and type the publication number or the publication title in the 
search box.

Then click the Search  button.

“Definitions” on page 134 contains a list of terms and their 
definitions as used in this workflow.

NOTE
12 



Before you begin Required items
Required items This workflow performs best when using the hardware and software described in 
the “required” sections below. 

Required hardware See the G4992-90005 Site Preparation Checklist for MassHunter VistaFlux Ver 1.0 for 
the required hardware for MassHunter VistaFlux Software.

Required software VistaFlux Software and sample data:
• Agilent MassHunter Pathways to PCDL Software B.07.00
• Agilent MassHunter PCDL Manager B.07.00 SP2
• Agilent MassHunter Profinder B.08.00
• Omix Premium Version 1.9
• “Data” folder containing VistaFlux example data and project files:

> Folder - “CS Gln Flux” data folder containing 15 sample data files
> Folder - “Profinder-Gln-IDH2.m” Profinder method folder
> File - “BioCyc metabolites.cdb” PCDL for the example data
> File - “CS-Gln-IDH2.pfa” Profinder archive file
> File - “CS-Gln-IDH2.Profinder” Profinder project file
> File - “TCA-IDH2.omx” Omix Premium project file
> File - “TCA-BioCyc-IDH2.cdb” metabolite compound database

Optional software Optional MassHunter software you can use with VistaFlux Software:
• Agilent MassHunter METLIN Personal Metabolite Library B.07.00
• Agilent MassHunter Qualitative Analysis B.07.00

Target metabolite discovery for your experiment can benefit from access to online 
pathways databases, such as BioCyc, KEGG, MetaCyc, and WikiPathways.

Next step... You have now completed reviewing background materials for the VistaFlux Software 
workflow. In the next workflow step you create your target list.
13 
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Create target list PCDL overview
PCDL overview Creating a personal compound database (PCD) or a personal compound database 
and library (PCDL) containing one or more compounds that participate in, or are 
associated with, metabolic reactions in selected pathways is the first step in the 
VistaFlux Software workflow. During this step you use the following MassHunter 
products that are part of the MassHunter VistaFlux Software:

MassHunter Pathways to PCDL: Create an Agilent metabolite compound data-
base and library from popular databases such as BioCyc/MetaCyc, KEGG, and 
WikiPathways.

MassHunter PCDL Manager: Search, add, remove, and edit compounds within a 
PCD/PCDL database and create new databases from prior databases. 

Terminology Compound database: MassHunter PCD and PCDL files are also referred to as a com-
pound database. Compound database file names have an extension .cdb.

Compound names: Many compounds are commonly known by their salts. The mass 
spectrometer, however, detects the anion or cation portion of the salt, rather than 
the neutral salt. Compound database entries may contain the familiar compound 
names, but the empirical formulae reflect the detectable cation or anion portion of 
the molecule rather than the formula of the neutral compound salt. For example, the 
full name Mg-ATP (magnesium adenosine 5′-triphosphate salt) and Ca-ATP (calcium 
adenosine 5′-triphosphate salt) may be used for identification in the compound data-
base, even though the mass and formula only includes the ATP anion (adenosine tri-
phosphate).

PCD: An accurate mass compound database. The database may or may not contain 
retention time data.

PCDL: An accurate mass compound database that also contains an MS/MS accu-
rate mass spectral database (spectral library).

Introduction to MassHunter 
Pathways to PCDL

MassHunter Pathways to PCDL (Figure 5) facilitates the creation of custom Agilent 
PCDLs from metabolites present in pathway content culled from popular databases 
such as BioCyc/MetaCyc, KEGG (with the required license you provide), and 
WikiPathways. You can filter and select pathways based on database, organism, 
and/or custom text entries.

Figure 5 MassHunter Pathways to PCDL
16 



Create target list PCDL overview
The databases created with Pathways to PCDL can be modified using MassHunter 
PCDL Manager and used for targeted data acquisition and data analyses. Results 
from targeted analyses can be mapped onto biological pathways maps, as described 
in later steps of this workflow. 

For more information See the MassHunter Pathways to PCDL Software Quick Start Guide for more infor-
mation.

Introduction to MassHunter 
PCDL Manager

The MassHunter PCDL Manager (Figure 6) helps you manage the compounds and 
compound content within PCDs and PCDLs. Some of the actions that can performed 
on a PCD/PCDL include:

• Search for compounds using text, formula, accurate mass, and retention time.
• Search and view MS/MS spectra in PCDLs.
• Create and edit custom PCDs and PCDLs, including adding proprietary com-

pounds, retention times, and MS/MS spectra.
• Import mass lists with retention time in the form of a TXT or CSV file.
• Load spectra from either a CEF file or copy-and-paste of mass spectra from 

MassHunter Qualitative Analysis software.
• Link to websites for more information on compounds.

Figure 6 MassHunter PCDL Manager

For more information See the MassHunter Personal Compound Database and Library Manager Quick Start 
Guide for more information.
17 



Create target list Specify the interesting pathways
Specify the interesting 
pathways

The first step in the VistaFlux Software workflow is to specify the pathways of inter-
est and create a metabolite database using MassHunter Pathways to PCDL. While 
the initial metabolite database created in this section may contain more metabolites 
than really necessary to be targeted, “Generate a target metabolite list” on page 27 
guides you through the steps to manage the metabolites in your database.

Launch Pathways to PCDL A brief overview for Pathways to PCDL is presented in the section “Introduction to 
MassHunter Pathways to PCDL” on page 16.

1. Start Pathways to PCDL 
software.

a Double-click the Pathways to PCDL icon  located on your desktop, or click 
Start > All Programs > Agilent > MassHunter Workstation > Pathways to 
PCDL > Pathways to PCDL.

b Skip to “Create a custom PCDL” on page 20 if you have previously used Pathways 
to PCDL and are familiar with the user interface and workflow.

2. Select the reference 
database (first-time use).

The first time you run Pathways to PCDL on a PC you are prompted to set a refer-
ence METLIN database folder and filename. You are not required to have a METLIN 
database and can skip this step, click Cancel.

a Click Select in the Select Reference METLIN PCD/PCDL dialog box (Figure 7).

Figure 7 Select Reference METLIN PCD/PCDL dialog box

b Navigate to the folder that contains your METLIN database, or any other personal 
compound database, in the Please specify the reference METLIN PCD or PCDL 
(*.cdb) file dialog box (Figure 8).

c Click on the database file name to select your database.

d Click Open.

Figure 8 Please specify the reference METLIN PCD or PCDL (*.cdb) file dialog 
box 
18 



Create target list Specify the interesting pathways
Review the Pathways to 
PCDL user interface

The main functional areas of Pathways to PCDL are shown in Figure 9.

The Pathways to PCDL window consists of two parts: Menu Bar and Display Pane. 
The Display Pane is divided into the Pathways List and the Selected Pathways List 
to help you visualize your progress as you select pathways to create your PCDL. The 
number of pathways and compounds that meet your criteria are shown above each 
table in the Display Pane.

Figure 9 Screen areas of MassHunter Pathways to PCDL

Review the Pathways to 
PCDL workflow

The Pathways to PCDL Workflow shown in Figure 10 presents the order of a typical 
interaction with the Pathways to PCDL software to create a target metabolite data-
base, described in section “Specify the interesting pathways” on page 18, from 
pathways that are interesting to your experiment.

Figure 10 Typical Pathways to PCDL workflow
19 



Create target list Specify the interesting pathways
Create a custom PCDL A custom compound database is created from the metabolites present in pathways 
content following the simple workflow as shown in Figure 10 on page 19. This exam-
ple creates a database of the compounds in the tricarboxylic acid (TCA) cycle.

1. Select your pathway data 
source.

The Pathways to PCDL converter supports pathway content from BioCyc/MetaCyc, 
KEGG, and WikiPathways databases. A user name and password are required in 
order to obtain content from the KEGG database.

a Select BioCyc/MetaCyc for the Source under Pathway Data.

b Review the updated list of pathways in the display pane (Figure 11). If the path-
ways list is long, you may want to select an Organism/Database and/or enter 
Search Text to reduce the list of pathways.

Figure 11 Select pathways source

2. Select an organism to filter 
the pathways from the data 
source.

You can add and remove organisms from the Organism/Database selection list. 
Click  and mark or clear the organism check boxes in the Choose Organ-
isms to Show dialog box.

a Select Homo sapiens from the Organism/Database list.

b Review the updated list of pathways in the display pane (Figure 12).

Figure 12 Select an organism to filter the pathways

3. Choose a selection mode. The Selection Mode provides you with an option to select compounds (metabolites) 
for your personal compound database by association with a pathway name, path-
ways that have a common compound name, and pathway reactions that have a com-
mon compound name. 
20 



Create target list Specify the interesting pathways
Pathway Name: This is a one-step selection process. Select compounds within a 
pathway that you select from the Pathway List in the display pane. The compounds 
associated with the pathway are moved the Selected Pathways List immediately 
after you click Select Highlighted or Select All.

Fellow Pathway Members: This is a two-step selection process. Select compounds 
within a pathway that you select from the Select Interesting Pathways dialog box - 
the list of pathways in this dialog box are related (a fellow) to the compound you 
previously select from the Compound List in the display pane. After you click Select 
Highlighted or Select All, the Fellow Pathways are displayed in the Select Interest-
ing Pathways dialog box. The compounds associated with the pathway are moved 
to the Selected Pathways List immediately after you click Select Highlighted or 
Select All from the Select Interesting Pathways dialog box.

Reaction Partners: This is a one-step selection process. Select compounds associ-
ated with pathway reactions involving the compound you select from the Compound 
List in the display pane. The compounds associated with the associated reactions 
are moved the Selected Pathways List immediately after you click Select High-
lighted or Select All. This selection mode is only available for the BioCyc/MetaCyc 
pathway data source. 

a Click Pathway Names for the Selection Mode.

b Review the updated list of pathways in the display pane (Figure 13).

Figure 13 Pathway Names Selection Mode

4. Enter custom search text. In cases when the number of pathways, or compounds, displayed in the Pathways or 
Compounds List in the display pane is large, you can reduce the number of path-
ways, or compounds, by using search text.

a Type TCA for the Search Text.

b Review the updated list of pathways in the display pane (Figure 14 on page 22). 
The number of pathways in this example is reduced to a single pathway.
21 



Create target list Specify the interesting pathways
Figure 14 Reduction in the number of pathways using TCA for the search text

5. Add one or more pathways 
to your Selected Pathways 
List using Pathways 
Names.

Build your personal compound database by selecting pathways individually (as 
shown in this step) or by clicking Select All from the Compounds List.

a Click the row containing the TCA cycle pathway.

b Click Select Highlighted to move the pathway to the Selected Pathways List.

The compounds associated with the pathway are moved to the Selected Path-
ways List immediately after you click Select Highlighted, or Select All.

c (Optional) Repeat steps a and b to continue adding pathways sources for your 
compound database; the example in this workflow does not require additional 
pathway sources.

d Review the updated list of pathways in the display pane (Figure 15). The number 
of pathways in this example is reduced to a single pathway.

Figure 15 TCA cycle pathway selected for the personal compound database

6. Add one or more pathways 
to your Selected Pathways 
List using Fellow Pathway 
Members.

Build your database from the compounds within pathways that are related to each 
other (fellow pathways) by the compound you previously selected from the Com-
pounds List in the Display Pane. Pathways can be added individually (as shown in 
this step) or by clicking Select All.

a Click Fellow Pathway Members.

 Note: When you change Selection Mode, the Search Text is cleared and the 
Pathways or Compounds List is refreshed.

b Review the updated list of compounds in the Pathways List.
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c Type fu for the Search Text. Nine compounds are available in the Compounds 
List as shown in Figure 16.

 

Figure 16 Fellow Pathway Members Compounds List

d Click Select All. Twenty pathways are shown in the Show Interesting Pathways 
dialog box that involve the nine compounds selected.

e Click TCA cycle pathway as shown in Figure 17.

 

Figure 17 Select Interesting Pathways dialog box

f Click Select Highlighted to move the pathway to the Selected Pathways List. The 
Show Interesting Pathways dialog box closes automatically.

The compounds associated with the pathway are moved to the Selected Path-
ways List immediately after you click Select Highlighted, or Select All.

g (Optional) Repeat steps a through f to continue adding pathways sources for your 
compound database; the example in this workflow does not require additional 
pathway sources.

h Review the updated list of pathways in the display pane (Figure 18 on page 24).

Note: Because a selected pathway is described by the means that it was selected 
“TCA cycle” is not listed twice in the Selected Pathways List. You can tell the 
same pathway was added since the table heading remains unchanged, stating 
“20 Unique Resolved Compounds,” compare Figure 15 on page 22 and Figure 18 
on page 24.
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Figure 18 TCA cycle pathway selected twice for the personal compound database

7. Add one or more pathways 
to your Selected Pathways 
List using Reaction 
Partners.

Build your personal compound database by selecting compounds associated with 
pathway reactions involving the compound you select from the Compounds List in 
the display pane. Pathways can be added individually (as shown in this step) or by 
clicking Select All.

Note: This selection mode is only available for the BioCyc/MetaCyc pathway data 
source. 

a Click Reaction Partners.

b Review the updated list of compounds in the Compounds List.

c Click ATP in the Compounds List - 118 reaction partners are associated with this 
compound.

d Click Select Highlighted.

e (Optional) Repeat steps a through f to continue adding pathways sources for your 
compound database; the example in this workflow does not require additional 
pathway sources.

f Review the updated list of pathways in the display pane (Figure 19).

Note: The number of unique resolved compounds increased significantly to 947 
and there are 10 unresolved compounds.

Figure 19 ATP reaction partner added to the Selected Pathways List
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8. Review unresolved 
compounds in your 
Selected Pathways List.

Pathways to PCDL provides you with an opportunity to manually review the com-
pounds in your Selected Pathways List that may not have a strong association with 
the pathways you have selected (unresolved compounds).

The View Unresolved button is available when you have unresolved compounds in 
your compound list.

a Click View Unresolved. The View Unresolved button is available when you have 
unresolved compounds in your compound list.

b Review the list of unresolved compounds in the Unresolved Compound Viewer 
dialog box (Figure 20).

c Click OK.

Figure 20 Unresolved Compound Viewer dialog box.

9. Remove pathways from 
your Selected Pathways 
List.

For the example experiment remove the pathway that was added using Reaction 
Partners.

a Mark  under the Del. column for the row that corresponds to the ATP pathway 
in the Selected Pathways List. 

Note: When you mark the pathway under the Del. column, it is immediately 
removed from the Selected Pathways List.

b The pathways to create your personal compound database reverted back to just 
the TCA cycle as shown in Figure 18 on page 24.

10. Create your custom PCD/
PCDL.

Create your personal compound database from the compounds within the Selected 
Pathways List.

a Click Create PCD/PCDL.

b Select the folder to save your PCD/PCDL database (Figure 21). The default folder 
is C:\MassHunter\PCDL.

c Type the name for your PCD/PCDL database in File name, Target_01.

d Click Save.
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Figure 21 Save As dialog box

e Click OK after you have reviewed the summary information describing your cus-
tom PCD/PCDL (Figure 22).

Figure 22 Summary information
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Generate a target 
metabolite list

The second step in the VistaFlux Software workflow is to generate a target list of 
metabolites of interest to your experiment using MassHunter PCDL Manager. In this 
step you edit the compound list in the personal compound database you created in 
“Specify the interesting pathways” on page 18.

Launch PCDL Manager A brief overview for PCDL Manager is presented in the section “Introduction to 
MassHunter PCDL Manager” on page 17.

1. Start PCDL Manager and 
open the PCDL created 
using Pathways to PCDL.

a Double-click the Pathways to PCDL icon  located on your desktop, or click 
Start > All Programs > Agilent > MassHunter Workstation > PCDL Manager 
ver, where ver is the version number for the current installation, such as 
“B.07.00”. 

b Select the personal compound database created in “Specify the interesting path-
ways”, step “Create your custom PCD/PCDL.” on page 25, Target_01.cdb. 
The default folder is C:\MassHunter\PCDL (Figure 23).

Note: The PCDL that was last used is displayed as the default PCDL to open.

I

Figure 23 Open PCDL dialog box

2. Make a new copy of your 
TCA cycle personal 
compound database.

This step makes a new copy of your compound database before you begin making 
changes to the original PCDL. Edits made to a personal compound database using 
PCDL Manager are saved in real-time to the open database and cannot be undone.

a Click File > New PCDL. The Create new PCDL dialog box immediately opens and 
has information entered for the open compound database.

b Select General for Select the PCDL type.

c Type Target_02 for Enter the new PCDL name.

d Enter TCA Cycle after removing uninteresting compounds 
for Enter a description of this PCDL.

e Click Create to make a copy of the compound database (Figure 24 on page 28).

Note: When a new PCDL is created, it is automatically opened in PCDL Manager. 
Target_02.cdb is opened for editing and the original TCA cycle compound data-
base, Target_01.cdb, is retained for reference.
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I

Figure 24 Create New PCDL dialog box

3. View the compounds in 
your personal compound 
database.

When a compound database is opened, the compounds can be viewed after you 
Find Compounds based on your search criteria.

a Click the Single Search tab.

b Click  on the toolbar. Twenty compounds, that are part of the 
TCA cycle pathway, are viewed in the Compound Results Table.

Note: If the compound database is large, searching the database without narrow-
ing the search criteria can take a long time.

I

Figure 25 All twenty compounds in the Target_02.cdb PCDL

c Skip to “Review and modify your custom PCDL” on page 30 if you have previous 
experience with PCDL Manager to create a personal compound database.

Review the PCDL Manager 
user interface

The main functional areas of PCDL Manager are shown in Figure 26 on page 29.

The PCDL Manager window consists of five parts: Menu Bar, Toolbar, Action Tabs, 
Action Pane, and Compound Results. The number of compounds that meet your 
search criteria are shown above the table in the compounds results.
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Figure 26 Screen areas of MassHunter PCDL Manager

Review the PCDL Manger 
workflow

The Pathways to PCDL Workflow shown in Figure 27 presents the steps used to cre-
ate the target metabolite compound database for the example experiment.

Figure 27 PCDL Manager workflow for the example experiment
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Review and modify your 
custom PCDL

A custom compound database is created from the metabolites present in pathways 
content extracted using Pathways to PCDL following the workflow as shown in 
Figure 10 on page 19. This example modifies the compound database created from 
the tricarboxylic acid (TCA) cycle pathway.

Note: Edits made to the compound database using PCDL Manager are saved in real-
time to your open database and cannot be undone. It is recommended to make a 
copy of your compound database before editing (see “Make a new copy of your TCA 
cycle personal compound database.” on page 27).

1. Remove uninteresting com-
pounds.

Since the database was created from all of the BioCyc/MetaCyc compounds associ-
ated with the TCA cycle, compounds that are not interesting your experiment can be 
removed; eleven compounds are interesting and nine compounds are removed.

a Click PCDL > Allow Editing to enable editing of the personal compound data-
base. Compounds in the database can be added and removed using the Edit 
actions only when Allowing Editing is marked in the menu.

b Click the Edit Compounds tab.

Hydrogen ion, water, 
and carbon dioxide

c Click Hydrogen Ion in the Compounds Results Table.

d Shift-click Carbon dioxide in the Compounds Results Table to select the com-
pounds between, and including, the selected compounds in the table. Selected 
compounds are highlighted with a background color.

e Click Delete Selected from the Edit actions (Figure 28).

Note: While these compounds are metabolically significant, they are not observ-
able in the mass spectrometer used to acquire this sample data set; therefore, 
hydrogen, water, and carbon dioxide are uninteresting target compounds.

Figure 28 Delete selected compounds
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f Click Yes in the Delete Compound dialog box. This dialog box verifies the action 
to delete the compounds from your open database. The compound database now 
contains 17 compounds.

Note: Edits made to the compound database while Allowing Editing is enabled 
are saved in real-time to your open database and cannot be undone.

g Click the Single Search tab to refresh the search results value above the Com-
pound Results Table.

h Click the Edit Compounds tab to return to editing the compounds.

Oxaloacetate i Click Oxaloacetate in the Compounds Results Table.

j Click Delete Selected from the Edit actions.

k Click Yes in the Delete Compound dialog box. The compound database now con-
tains 16 compounds.

NAD, NADH, Coenzyme A 
(CoA), Acetyl-CoA, and 

Succinyl-CoA

l Click Nicotinamide adenine dinucleotide (NAD) in the Compounds Results Table.

m Shift-click Succinyl-CoA in the Compounds Results Table.

n Click Delete Selected from the Edit actions.

o Click Yes in the Delete Compound dialog box. The compound database now con-
tains 11 compounds.

p Click PCDL > Allow Editing to disable editing of the personal compound data-
base.

2. Make a new copy of your 
edited personal compound 
database.

This step makes a new copy of your edited personal compound database before you 
begin adding new compounds.

a Click File > New PCDL. The Create new PCDL dialog box immediately opens and 
has information completed for the open compound database.

b Select General for Select the PCDL type.

c Type Target_03 for Enter the new PCDL name.

d Enter TCA Cycle after adding additional compounds for Enter 
a description of this PCDL.

e Click Create to make a copy of the compound database.

Note: When a new PCDL is created, it is automatically opened in PCDL Manager. 
Target_03.cdb is opened for editing and the original edited TCA cycle compound 
database, Target_02.cdb, is retained for reference.

3. Add new compounds from 
another PCDL.

While you can manually add new compounds to your compound database, a simple 
method is to append compounds to your compound database from another PCDL. In 
this example, six compounds are added from the Agilent METLIN PCDL.

a Click File > Open PCDL.

b Click the file name for the METLIN PCDL in the Open PCDL dialog box.
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c Click Open.

d Click the Batch Search tab.

e Enter the masses for the new compounds into the Masses table (Figure 29). The 
list of the masses is shown in Table 2.

Figure 29 Masses added to the Batch Search tab
I

Table 2 Six compounds to add from the METLIN PCDL, sorted by mass

f Mark Ignore for Retention times.

g Click  on the toolbar. 

When the search is complete, the results are displayed in the Compound Results 
Table. The compounds results are shown for a single mass at a time; the Com-
pound Results Table is refreshed after you click on a mass in the Masses table in 
the Action Pane. You can view all of the results in the Batch Summary tab.

For each mass you entered, PCDL Manager marks the row for the compound that 
is the best match for your search criteria. Since the search criteria in this example 
is minimal, the compound selected to append to our target compound database is 
selected based on the Compound Name and CAS ID. 

h Right-click the row containing 2-Hydroxyglutarate for mass 148.03717 or, if using 
the Batch Summary tab, highlight one search result for each mass and right-click 
on a highlighted row.

i Click Append to PCDL (Figure 30 on page 33).

j Select Target_03, the compound database containing the interesting compounds 
from the TCA cycle pathway, for Select the PCDL to append to in the Append to 
PCDL dialog box (Figure 30 on page 33).

k Click Append.

l Click No in the Compounds Appended dialog box since there are additional com-
pounds to append to the Target_03 compound database (Figure 31 on page 33). If 
this is the last compound go to step o.
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Figure 30 Append to PCDL from the Compound Results Table and the Append to 
PCDL dialog box.

Figure 31 Compounds Appended dialog box.

m Click the next mass in the Masses table in the Action Pane, if you are adding one 
mass at a time using the Batch Search tab. Otherwise, skip to step 5 on page 34.

n Repeat steps h through m and select the appropriate compound for each mass 
from the compounds listed in Table 2 on page 32.

o Click Yes in the Compounds Appended dialog box after you appended the last of 
the six compounds to the Target_03 compound database (Figure 31).

p Click the Single Search tab.

q Click  on the toolbar. The compound database now contains 17 
target compounds.

4. (Optional) Add new 
compounds manually.

If a compound, or a few compounds, are missing you can add them manually to the 
database. This example adds 2-oxoglutarate to a different compound database.

a Click PCDL > Allow Editing to enable editing of the personal compound data-
base.

b Click Edit > Add New Compound.

c Click Links > PubChem to PubChem Compound search in your browser.

d Type 2-oxoglutarate in the search box in PubChem.

e Click Search.

f Click the first of the results.

g Enter as much compound information as needed for pyruvate.
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h Click Update Selected after you have entered the compound information, and 
before you click on any other compound in the Compound Results Table 
(Figure 32).

Figure 32 Add new compound 2-oxoglutarate

i Click PCDL > Allow Editing to disable editing of the personal compound data-
base.

5. Make a new copy of your 
target personal compound 
database.

This step makes a new copy of your target personal compound database before you 
begin adding additional information, including retention times.

a Click File > New PCDL. The Create new PCDL dialog box immediately opens and 
has information completed for the open compound database.

b Select General for Select the PCDL type.

c Type Target_04 for Enter the new PCDL name.

d Enter Target metabolite list for Enter a description of this PCDL.

e Click Create to make a copy of the compound database.

Note: When a new PCDL is created, it is automatically opened in PCDL Manager. 
Target_04.cdb is opened for editing and the original appended TCA cycle com-
pound database, Target_03.cdb, is retained for reference.

6. Add retention times and 
additional identifiers to 
your target metabolite list.

This step adds retention times, and any additional information, to the target metabo-
lite list. The retention time values are obtained either from sample data acquired 
during your acquisition method development or from the method used to acquire 
your sample data if it has already been acquired. Inclusion of compound identifiers, 
such as CAS, HMP, and KEGG, improves the data matching accuracy when you 
import your Profinder project into Omix Premium.

Note: As an alternative, this step can be done using the Batch Search tab with a 
CSV file from MassHunter Qualitative Analysis or Profinder. When the results are 
displayed in the Batch Summary tab you can click Apply Retention Times.

a Click the Edit Compounds tab.

b Click PCDL > Allow Editing to enable editing of the personal compound data-
base.

c Click on a compound row in the Compound Results Table. This is the compound 
that can be edited in the Action Pane.
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d Add the retention time from Table 3 on page 35 to RT, in addition to and any addi-
tional information to complete the compound data.

Note: You can add retention times using a mass list file. See “Exercise 8. Add 
retention times to a PCDL” in the MassHunter Personal Compound Database and 
Library Manager Quick Start Guide.

e Click Update Selected to write the new information to the compound data and 
before you click on any other compound in the Compound Results Table.

I

Table 3 Target Compound list with retention times, sorted by mass

f Repeat steps c through e to update the retention time for each compound in the 
target metabolite list, as noted in Table 3.

g Click PCDL > Allow Editing to disable editing of the personal compound data-
base. Your target metabolite list may appear as shown in Figure 33.

Figure 33 Final target metabolite list

7. Save your target metabolite 
compound list.

All of the edits made while Allowing Editing is enabled are saved in real-time to 
your open database.

a Click the Single Search tab.
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b Click  on the toolbar to view the 17 compounds that are part of 
the target metabolite list (Figure 33).

c Your target metabolite list (Target_04.cdb) is now ready to be used as the Target 
Source as part of the MassHunter Profinder Batch Isotopologue Extraction 
method (“Create your Batch Isotopologue Extraction method” on page 51).

d Click File > Exit to close PCDL Manager. Alternatively, open a different PCDL or 
perform other actions using PCDL Manager. 
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Select your tracer 
metabolite

Metabolomics studies measure the relative abundance of metabolites to better 
understand biological systems. However, this does not provide insight into the 
dynamics of metabolism since significant changes in flux through a pathway may 
not result in altered abundances of metabolite intermediates. Qualitative flux analy-
sis addresses this issue and allows researchers to obtain information about selected 
pathways and fluxes. In qualitative flux analysis a stable isotope labeled compound, 
referred to as a tracer, is introduced into the biological system. The tracer typically 
contains multiple atoms of 13C, 15N, or 2H. As the tracer is utilized by the organism, 
or metabolized, changes in the natural isotopic pattern occur in downstream metab-
olites. The isotopic composition of the downstream metabolites change over time 
leading to isotopologues whose mass signatures can be measured via a mass spec-
trometry. 

An isotopically labeled source of cellular energy, such as 13C labeled glucose and 
glutamine, was used as the tracer in the example data set for this workflow guide. 
Agilent LC/TOF and LC/Q-TOF MS systems provide the high level of mass accuracy 
and isotopic fidelity required to measure isotopologues of the metabolites down-
stream from the point of origin for this example qualitative flux analysis.

Example data The example data in this workflow guide demonstrates qualitative flux analysis in a 
chondrosarcoma cell line, using 13C5-glutamine (U-13C-Gln) as the tracer. The exam-
ple data was acquired on an Agilent LC/TOF system. The example qualitative flux 
analysis demonstrates the effect of an isocitrate dehydrogenase 2 (IDH2) mutation 
on TCA cycle metabolism; in particular the diversion of glutamine to the production 
of 2-hydroxyglutarate (2-HG) by the mutant IDH2 isoform.

Next step... You have now completed the first step of the VistaFlux Software workflow. In the 
next workflow step you acquire your sample data.
37 



Create target list Select your tracer metabolite
This page intentionally left blank.
38 



Create Target 
List Acquire Data Primary Data 

Analysis
Visualize on 
Pathways Export Results

Acquire data

The quality of your results are influenced by your mass spectrometer, 
acquisition parameters, and sampling approach.
Save your Omix 
Premium project

Select tracer 
metabolite

Create your TOF/
Q-TOF acquisition 

method

Select an accurate 
mass instrument 

TOF/Q-TOF

Mine your sample 
data for the target 

metabolites

Curate your results

Create Batch 
Isotopologue 

Extraction method

Save your Profinder 
project

Specify interesting 
pathways

Generate a target
list of metabolites

Export features as
a Profinder

Archive (PFA) file

Import your Profinder 
features - PFA file

Display isotopologue 
metabolite data and 
highlight pathways

Build your pathways 
network diagram

Generate static 
images of your 

pathways networks

Step through time 
points and network 

activity

Export tables, charts
and images

Acquire your sample 
data
Select an accurate mass instrument    40
Create your acquisition method    41
Acquire your sample data    42



Acquire data Select an accurate mass instrument
Select an accurate mass 
instrument

MassHunter VistaFlux software is designed to help scientists perform qualitative 
flux analysis, and facilitate the processing and visualization of high-resolution accu-
rate mass TOF and Q-TOF LC/MS data. Time-of-flight mass spectrometers are espe-
cially well suited for flux analyses due to the combination of fast scan speed, high 
resolution, and high dynamic range.

Instrument resolution The resolution observed in TOF instruments is a function of the actual resolving 
power of the analyzer, and the ability of the detector circuitry to respond to the sig-
nal and measure the output at the necessary scan speed. Since there is a natural 
spread in the ion arrival times at the detector, improvements in instrument resolu-
tion improve the accuracy of the instrument in measuring the actual time of flight of 
the ions and therefore improve the mass accuracy.

For time-of-flight mass spectrometers (TOF-MS), higher resolution is achieved 
through improvements in the following parameters:

• Ion pulse formation at the inlet to the flight tube
• Energy focus of the pulsed ions
• Flight time
• Vacuum
• Gain and speed of the ion detector
• Digitization rate of the detector electronics

Within limits, higher resolution narrows the mass spectral peak width and in-turn 
produces a more accurate m/z value.

Instrument dynamic range Dynamic range is significant because accurate m/z values are difficult to assign to 
saturated signals and signals with a very low signal to noise. While a single qualita-
tive flux analysis employs many target metabolites that have a wide range of con-
centrations in the biological system under study, it is the tracer and propagation of 
the isotope labeling that places a very high demand on the dynamic range of the 
instrument.

Small molecule tuning
(LC/MS)

Qualitative flux analyses involve the analysis of small molecules, molecules nomi-
nally with a molecular weight from 50 to 6000 Da. Since the best results for flux 
analysis studies involve the identification of the exact mass of the molecular ion, 
LC/MS instrument tunes should be adjusted to (1) improve the sensitivity for intact 
molecular ions and (2) improve the overall sensitivity for small, low-mass, com-
pounds. A typical automated instrument tune optimizes the instrument sensitivity 
across the entire mass range and may result in lower sensitivity for small molecules 
combined with higher fragmentation than desired for metabolomics.
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Create your acquisition 
method

While the samples for your experiment may be considerably different from this 
example, the acquisition method used in the example is presented.

Cell extracts were dried, resuspended, incubated, and centrifuged to remove particu-
lates.100 µL volumes of the final resuspension was transferred to reduced-volume 
autosampler vials.10 µL was removed from every sample to assemble a pooled qual-
ity control vial that was injected six times at the start of the analytical run, then reg-
ularly throughout the analysis to ensure chromatographic stability.

Data were acquired on an Agilent LC/MS system consisting of:
• Agilent 6230 time-of-flight mass spectrometer
• Agilent 1290 Infinity Binary UHPLC pump for the chromatography
• Agilent 1290 Infinity thermostatted column compartment
• Agilent 1290 Infinity HTS autosampler
• Agilent 1260 Infinity isocratic pump with a 100:1 fl ow splitter was used to 

introduce the reference mass solution

The LC was interfaced to the MS with a dual electrospray ionization source, and 
data were acquired in negative ion mode using the 4 GHz high resolution mode at 
1.5 spectra per second. Table 1 shows the analytical method settings.

As with this example, the analytical method must be designed for your target metab-
olites (Table 1 on page 11. Because the TCA cycle is composed of organic acids that 
are poorly retained by reversed-phase chromatography, ion-pair reversed-phase 
chromatography was used. Negative mode electrospray ionization provided the opti-
mal means to introduce the sample for detection of the target compounds using 
time-of-flight mass spectrometry.

Table 4 Example LC/MS analysis parameters
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Acquire your sample 
data

Statistical significance of your qualitative flux analysis depends on understanding 
natural variation and how replicate sampling can influence your results. Acquiring 
an adequate number of samples for each experimental condition, or time observa-
tion, (sample groups) improves the statistical significance of your qualitative flux 
analysis.

Natural variability Not all data analysis requires an assumption that the samples represent a popula-
tion with a normal distribution. In Omix Premium a Welch's t-test does not assume a 
normal distribution. However, the following discussion on natural variability is based 
on a normal distribution.

Before any statistical analysis is begun, it is important to understand how a sample 
represents the population as a whole, and how increasing the sample size improves 
the accuracy of the sample set in describing characteristics of the population.

Under identical conditions, all life systems produce a range of results. Samples from 
the population may show one of the following characteristics:

(1) Results comparable to the mean of the population (i.e., characteristics shown 
by the majority of the population), for example results within ±1 standard devia-
tion (~68%) from the mean.

(2) Results that differ significantly from those shown by the majority of the popu-
lation (i.e., characteristics that are not shown by the majority of the population), 
for example results beyond ±3 standard deviations (~99.7%) from the mean.

(3) Results anywhere in between ±1 to ±3 standard deviations from the mean.

Metabolite abundances in many biological and biochemical systems are found to 
show a probability of variation referred to as a normal distribution. Figure 34 on 
page 43, for instance, shows a normal distribution of a characteristic within a popu-
lation where 68% of the sampled population is shown to have the mean characteris-
tic plus or minus one standard deviation (s). This natural variation of the population 
response to identical conditions is referred to as natural variability. Natural variabil-
ity thus means that any single sample taken from a population is not guaranteed to 
reflect the mean characteristics of the population.

Natural variability is found to occur from inherent randomness and unpredictability 
in the natural world. Natural variability is found in all life and natural sciences and in 
all forms of engineering. For example, a population of plants grown under identical 
conditions of illumination, precipitation, and nutrient availability shows a range in 
growth mass. This range of variable growth mass may be expressed as a mean 
where 95% of the population is expected to show a natural range of variability within 
two standard deviations of the mean (Figure 34 on page 43). 
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Figure 34 Natural variability shown as a Gaussian (normal) distribution. Depend-
ing on the predefined requirement for significance, if the mean of a sample set is 
beyond ±2s from the natural variation there may be a significant effect. Similarly, if a 
particular observation routinely falls beyond ±2s from the natural variability of the 
data the change producing the effect may be considered significant.

In other words, for a set of fixed attributes (independent variables), a representative 
set of samples taken from the population of plants shows a natural variability in the 
dependent variable growth mass. When an experiment is undertaken where plants 
from the same population are subject to variations in one ore more controlled condi-
tions, the plants response shows a change in growth mass in addition to their natu-
ral variability in growth mass. Thus if the entire population is sampled, two adjacent 
normal distributions with means reflecting the plant growth mass under the two 
conditions results (Figure 35).

Likewise, an cell line population subject to controlled exposures shows a natural 
variability of that exposure as expressed through the chemical makeup of samples 
taken from the population. Such unpredictability in the measurable variability of any 
biochemical expression must not be mistakenly correlated with deliberate variations 
of an controlled condition (independent variable).

Figure 35 Natural variability of populations with subject to two different experi-
mental conditions where the means of each data set falls outside of the mean ±3s 
of the other data set.

During your experiment, the natural variability of the data representing a population 
must be understood in order to confidently express any experimental correlation. 
The investment of time and resources in performing a statistical analysis requires 
that the natural variability of the subject specimen be known or reasonably esti-
mated so that the results of the analysis may be conclusively shown to be either 
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within the natural variability (no correlation) or outside of the natural variability and 
therefore provide for a degree of correlation to your controlled condition.

Experimental data collection that does not incorporate a consideration of the natural 
variability of the data does not yield meaningful results. Thus, as with all statistical 
data treatments, an understanding and well planned collection of the data is 
required from your qualitative flux analysis; without an understanding of natural vari-
ability the results follow the adage “garbage in, garbage out.”

Replicate data Replicate sampling and measurement from the population is the only way to esti-
mate the natural variability of your data. No guarantee exists that a single sample 
specimen from a population represents the mean of the population. Any single sam-
ple from a population with a natural variability shown in Figure 34 on page 43 has a 
99.99% chance that it lies within four standard deviations (±4s) of the mean of the 
true population, but in fact that single sample may on a rare occasion fall even fur-
ther from the population mean.

However, if ten samples are taken from the population, the mean of these samples 
produces a statistically more accurate approximation of the true mean of the popula-
tion than fewer samples. The accuracy of the approximation of the true population 
mean proportionally improves with more samples. The true value of the population 
mean is achieved only if the entire population is sampled. However, sampling the 
entire population is not typically feasible because of constraints imposed by time, 
resources, and finances. On the other hand, evaluating fewer samples increases the 
chance of false negative and false positive correlations from the analysis of sample 
data from your experiment.

Too few samples may lead to 
an incorrect conclusion

Figure 36 on page 45 shows that if too few samples are evaluated, and if these sam-
ples just happen to be samples lying far from the mean because of natural variability, 
an incorrect conclusion may be drawn that the change in the independent variable 
produced no significant change in the response. The estimate of the standard devia-
tion of the sample mean estimate of a population mean (standard error) is equal to 
the standard deviation of the samples divided by the square root of the number of 
samples (Equation 1).

(1)

where SE = standard error of the population;   = standard deviation; and N = 
number of samples.

Large sample sizes lead to 
more confident conclusions

As the sample size increases, the likelihood that the data approximates the true 
response of the population increases. The standard deviation of the sample may 
become smaller, and the likelihood of making a correct correlation between cause 
and effect is improved (Equation 2).

SE  N =
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(2)

where   = standard deviation; N = number of samples; xi = the value of an indi-

vidual sample; and X = mean (or average) of all N samples.   

Figure 36 Replicate data are necessary to distinguish whether the represented 
populations actually show significant differences. The three data points in the region 
of overlap of the natural variability may, if too few replicates are selected, lead to a 
result suggesting a less significant difference in the populations.

Successful application of qualitative flux analysis depends on the availability of suf-
ficient replicate samples and specimens. Coupled with an understanding of the sys-
tems under study and a well planned collection of the samples and concomitant 
data, the statistical data treatment of the replicate samples is the backbone of your 
qualitative flux analysis. A sufficient set of replicate data, ten or more replicates, 
may provide a significant answer to the hypothesis and prevent a total loss of time 
and resources invested in performing your analyses.

Next step... You have now completed the second step of the VistaFlux Software workflow. In the 
next workflow step you perform your primary data analysis using MassHunter 
Profinder.

  1
N
---- xi X– 

i 1=

N

=
45 



Acquire data Acquire your sample data
This page intentionally left blank.
46 



Create Target 
List Acquire Data Primary Data 

Analysis
Visualize on 
Pathways Export Results

Primary data analysis

MassHunter Profinder is used to perform batch isotopologue feature 
extraction using the target metabolite compound database.
Save your Omix 
Premium project

Select tracer 
metabolite

Create your TOF/Q-
TOF acquisition 

method

Acquire your sample 
data

Select an accurate 
mass instrument 

TOF/Q-TOF

Mine your sample 
data for the target 

metabolites

Curate your 
results

Create Batch 
Isotopologue 

Extraction method

Specify interesting 
pathways

Generate a target
list of metabolites

Export features as
a Profinder

Archive (PFA) file

Import your Profinder 
features - PFA file

Display isotopologue 
metabolite data and 
highlight pathways

Build your pathways 
network diagram

Generate static 
images of your 

pathways networks

Step through time 
points and network 

activity

Export tables, charts
and images

Save your Profinder 
project
Isotopologue extraction overview    48
Create your Batch Isotopologue Extraction method    51
Mine your sample data for the target metabolites    58
Curate your results    60
Export your results as a Profinder Archive    65
Save your Profinder project    66



Primary data analysis Isotopologue extraction overview
Isotopologue extraction 
overview

Performing a primary data analysis requires a basic understanding of isotopes, isoto-
pomers, and isotopologues, and MassHunter Profinder software. MassHunter 
Profinder is used to perform batch isotopologue feature extraction from your sample 
data files using the target metabolite compound database you created in the chapter 
“Create target list” on page 15.

See “Isotopes, isotopologues, and isotopomers” on page 8 for a brief overview on 
isotopes, isotopomers, and isotopologues.

Introduction to MassHunter 
Profinder

MassHunter Profinder is part of the MassHunter VistaFlux software suite. 
MassHunter Profinder software, optimized for batch feature extraction from TOF, Q-
TOF, and MSD data files, is the primary data analysis software for your qualitative 
flux analysis sample data acquired using Agilent LC/TOF and LC/Q-TOF.

Profinder is optimized to extract features from large data sets and provides you with 
an intuitive user interface to inspect and review each feature across the files associ-
ated with your data set. With Profinder, you can review and compare extracted ion 
chromatograms, mass spectral data, and isotopologues associated with each fea-
ture. You can also save your feature extraction progress to a project to review, 
adjust, and reprocess at a later time. Profinder archive (PFA) files contain extracted 
compound features and sample group information. PFA files are imported into Omix 
Premium to view your data in the context of biochemical networks, including isoto-
pologue results, as part of a qualitative metabolic flux analysis described in this 
workflow.

Review the Profinder user 
interface

The main functional areas of Profinder are shown in Figure 37 on page 49. The main 
Profinder window consists of three parts: (1) the Menu Bar, (2) the Toolbar, and (3) 
the Main Window.

The main window is further divided into up to five windows — (3a) Compound 
Groups, (3b) Compound Details, (3c) Chromatogram Results, (3d) MS Spectrum 
Results, and (3e) Isotopologue Results that are used to review the results from 
applying a feature extraction method to your data set. Each window can be floated 
independently to any location and size on your computer display or arranged to your 
preference within the main window. 
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Figure 37 Screen areas of MassHunter Profinder

Review the Profinder batch 
isotopologue extraction

Batch isotopologue extraction, one of five feature extraction wizards within 
Profinder, uses an input CSV file or personal compound database file, PCD/PCDL, 
containing the target feature molecular formulas, mass, and retention time informa-
tion. Batch isotopologue extraction anticipates that the target compounds may have 
undergone some degree of isotope labeling, to extract features from your data using 
a process referred to as Find Compounds by Formula. After feature extraction is per-
formed, the extraction algorithm determines which of the possible isotopologues are 
actually present, measures the raw abundances of the isotopologues, and corrects 
the isotopologues abundances for the natural occurrence of the unlabeled ions. 

Batch isotopologue extraction supports only LC/MS acquired data. Unlike the other 
batch feature extraction wizards, target retention times are required for this work-
flow. Profinder performs isotopologue mining in two stages, an initial screening fol-
lowed by refinement. The initial screening stage extracts isotopologue EICs around 
the target retention time range and then evaluates peak mass spectral data to find 
ions that match the predicted list of possible isotopologues. The refinement stage 
uses a self-optimizing peak finder to refine the m/z assignment from the profile 
data. During refinement, Profinder re-extracts the EICs using the new isotopologue 
m/z values, refines the start and end retention time bounds on the newly extracted 
EICs, and then reports both EIC peak area and summed isotopologue peak heights 
as the compound abundances.
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Note: Profinder finds and extracts isotopologues in your sample data; it does not 
find or extract isotopomers. 

The batch isotopologue extraction wizard is shown in Figure 38.

Figure 38 One step is presented in the Batch Isotopologue Extraction wizard

Retention times As a reminder, batch isotopologue extraction requires that your Target Source con-
tain accurate retention times for each target in your sample data files.See “Add 
retention times and additional identifiers to your target metabolite list.” on page 34 

Note: If your Target Source database does not have retention times, or requires 
retention times to be updated, you can use Profinder to generate the new retention 
times.   Run the Batch Targeted Extraction on one group, or other subset of your 
sample data, to find the features in your sample data. Then export the features as a 
CSV file using File > Export as CSV. The CSV output from Profinder can then be 
used as a mass list file in the Batch Search tab of PCDL Manager as described in the 
note in “Add retention times and additional identifiers to your target metabolite 
list.” on page 34.

For more information See the MassHunter Profinder Software Quick Start Guide for more information.
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Create your Batch 
Isotopologue Extraction 
method

In this task, you launch Profinder, select your sample files, add the sample files to 
your Profinder project and create your Batch Isotopologue Extraction method.

Launch Profinder A brief overview of Profinder is presented in “Introduction to MassHunter 
Profinder” on page 48.

Start the Profinder software. Double-click the Profinder icon  located on your desktop, or click Start > All 
Programs > Agilent > MassHunter Workstation > Profinder B.08.00.

Create your Profinder 
project

When Profinder opens, you can begin a new project or open a saved project. This 
section guides you through the steps to create a new project.

1. Add sample files to your 
new project.

a Click File > Add/Remove Sample Files, click  on the 
toolbar, click File > New Project, or click New Project  on the toolbar.

b Click Add files in the Add/Remove Sample Files dialog box.

c Navigate to the folder containing your sample data in the Open file dialog box.

d Click on your first sample data file. The selected sample data file is highlighted in 
a background color.

e Shift-click on the last sample data file to select the entire set of sample data. All 
of the selected sample data files are highlighted in a background color.

f Click Open in the Open file dialog box (Figure 39).

 

Figure 39 Select sample data files in the Open file dialog box

2. Enter sample group values. When entering Sample Group values, the entries must use identical letters, num-
bers, punctuation, and case in order for the grouping functions to perform properly.
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a Click the data entry cell under the Sample Group column, next to the sample file 
name.

b Enter the sample group identification text.

c Right-click the last replicate sample to open the entry shortcut menu.

d Click Fill Down (Figure 40).

The operations available in the shortcut menu help you ensure that replicate sam-
ples have identical group values. 

e Repeat these steps for each sample file.

 

Figure 40 Use Fill Down to add Sample Group values in the Add/Remove Sample 
Files dialog box

3. Re-order your samples into 
a logical order.

The order of the appearance of the samples and sample groups you set in the Add/
Remove Sample Files dialog box determines the order of the results viewed in the 
Isotopologues Results area of the Main Window (Figure 37 on page 49).

a Click the first sample row you want to re-order.

b Shift-click the last sample row that contains two or more samples that you want 
to re-order.

c Click the Move Up  and Move Down  arrows, along the sight side of the 
Add/Remove Sample Files dialog box, to sort your samples in a logical order and 
to place replicate samples in sequential rows (Figure 41).

Figure 41 Use the Move Up arrow re-order samples in the Add/Remove Sample 
Files dialog box
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d Repeat these steps until your samples and sample groups are in the order you 
want them to appear in Isotopologues Results (Figure 42).

e Click OK in the Add/Remove Sample Files dialog box.

Figure 42 Sample group values and order for the example Profinder project

Create your Batch 
Isotopologue Extraction 
method.

After you add your sample data files to your Profinder project, you select a feature 
extraction workflow to set up your primary data analysis method.

When you make a change to a parameter in Profinder, the software automatically 
places a change icon  (a blue triangle shape) in the wizard tab and next to the 
value containing the parameter where you made a change. This icon indicates that 
you have unsaved parameters changes and serves as a reminder to save the 
changes you have made to the method. The original parameter value may be viewed 
by placing your pointer over the change icon. After you save your method, the 
change icon(s) disappear.

1. Select your feature 
extraction workflow.

a Select Batch Isotopologue Extraction.

b Click Next to select and enter the isotopologue extraction method parameters.

 

Figure 43 Feature Extraction Workflow selection dialog box
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2. Enter the extraction 
parameters in Ion Species 
tab.

a Click the Ion Species tab.

b Click the Select  button to select your target source.

c Navigate to the folder that contains your target metabolite database in the Open 
database file dialog box (Figure 45).

d Select the target metabolite database, Target_04.cdb, you created in chapter 
“Create target list” on page 15 in the Open database file dialog box.

The final target metabolite database, after adding additional compound identifi-
ers, appears as shown in Figure 44. By adding compound identifiers to your target 
metabolite database the compound matching performed during visualization in 
Omix Premium is less sensitive to precise compound spelling; compound identifi-
ers are matched with higher priority, when present, than compound names.

Figure 44 Final target metabolite list with additional compound identifiers

e Click Open.

Figure 45 Use the Move Up arrow re-order samples in the Add/Remove Sample 
Files dialog box

f Select +H under the Default ion species, Positive group headings.

g Select -H under the Default ion species, Negative group headings.

h Enter 1 for Charge state under the Charge state group heading.

i Select 13C under the Labeling group heading.

j Enter 99 for Isotope purity under the Labeling group heading.
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Figure 46 Extraction Parameters - Ion Species tab

3. Enter the extraction 
parameters in Extraction 
tab.

a Click the Extraction tab.

b Clear Smooth EIC before integration under the Chromatogram smoothing group 
heading.

c Select Gaussian for the Smoothing function under the Chromatogram smoothing 
group heading.

d Enter 5 points for Function width under the Chromatogram smoothing group 
heading.

e Enter 5 points for Gaussian width under the Chromatogram smoothing group 
heading.

f Select Use peak core area under the Ion abundance criterion group heading.

g Enter 20 for % Peak height under the Ion abundance criterion group heading.

h Mark Prefer profile data under the Extraction data format group heading.

i Select Display isotopologue spectrum plots under the Extraction data format 
group heading.

Figure 47 Extraction Parameters - Extraction tab
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4. Enter the extraction 
parameters in Ion Qualifi-
cation tab.

a Click the Ion Qualification tab.

b Enter 40.00 ppm for Masses +/- under the Match tolerance group heading.

c Enter 0.00 mDa for Masses + under the Match tolerance group heading.

d Enter 0.05 minutes for Retention times under the Match tolerance group head-
ing.

e Enter 250 counts for Anchor ion height >= under the Isotopologue ion thresh-
olds group heading.

f Enter 1000 counts for Sum of ion heights >= under the Isotopologue ion thresh-
olds group heading.

g Enter 0.50 for Correlation coefficient under the Coelution threshold group 
heading.

Figure 48 Extraction Parameters - Ion Qualification tab

Run your Batch 
Isotopologue Extraction 
method.

Click Finish. Isotopologue feature extraction, target metabolite mining, begins imme-
diately and an operation progress dialog box is displayed (Figure 49).

Figure 49 Operation in progress dialog box

Save your Batch 
Isotopologue Extraction 
method.

a Click the Method > Save As.

b Navigate to the folder to save your method in the Save Method dialog box.

c Enter VistaFlux_WFG for the File name.
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Figure 50 Save Method dialog box used to save your Profinder method

d Click Save.
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Mine your sample data 
for the target 
metabolites

After you have created a Profinder project (“Create your Profinder project” on 
page 51), mining your target metabolites can be performed in two ways: (1) create a 
new Batch Isotopologue Extraction method as described in “Create your Batch Iso-
topologue Extraction method” on page 51, or (2) create a new project, load a previ-
ously saved method, and run Batch Isotopologue Extraction as described in this 
section.

Launch Profinder Double-click the Profinder icon  located on your desktop, or click Start > All 
Programs > Agilent > MassHunter Workstation > Profinder B.08.00.

Create your Profinder 
project

When Profinder opens you can begin a new project or open a saved project. Go to 
“Create your Profinder project” on page 51 to begin a new project. This section 
guides you through the steps to open and process a previously saved project.

1. Open a Profinder project. a Click File > Open Project, or click Open Project  on the toolbar.

b Adjust the main window layout and display options as necessary.

2. Review your sample data 
files and grouping.

a Click File > Add/Remove Sample Files, click  on the 
toolbar to review the sample data files and sample group assignments.

b Add and remove samples files and/or designate specific files to include in this 
mining session using the Show/Hide column.

c Click OK in the Add/Remove Sample Files dialog box.

Load your Batch 
Isotopologue Extraction 
method.

After you open your Profinder project, open your previously saved Batch Isotopo-
logue Extraction method.

a Click Method > Open.

b Navigate to the folder that contains your method in the Open Method dialog box 
(Figure 51 on page 59).

c Select your previously saved method.

d Click Open.

e Click the appropriate response, Yes, No, or Cancel, in the Save dialog box to con-
tinue.
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Figure 51 Open Method dialog box

Run your Batch 
Isotopologue Extraction 
method.

a Click Wizards > Batch Isotopologue Extraction.

b Review your isotopologue extraction parameters. See “Create your Batch Isoto-
pologue Extraction method.” on page 53 for an overview of the parameters.

c Click Finish. 

d Click Yes in the Warning dialog box (Figure 52). Isotopologue feature extraction, 
target metabolite mining, begins immediately and an operation progress dialog 
box is displayed (Figure 49 on page 56)

Figure 52 Warning dialog box indicating that continuing the operation clears cur-
rent results from Profinder memory
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Curate your results The data mining results are displayed in the views available the main window. The 
main window, see Figure 37 on page 49, is divided into up to five windows - (a) Com-
pound Groups, (b) Compound Details, (c) Chromatogram Results, (d) MS Spectrum 
Results, and (e) Isotopologue Results that are used to review the results from apply-
ing the Batch Isotopologue Extraction method to your data set. Each window can be 
floated independently to any location and size on your computer display or arranged 
to your preference within the main window.

Compound Groups The data presented in the Compound Groups window (Figure 53) is organized as a 
list of all of your target compounds averaged across all of the data files in your proj-
ect - averaged feature information.

The Compound Groups window shows a table of compound-level information for all 
of the targeted features. Semi-quantitative information is shown as the average 
value for the feature across all of the files where the feature was found. A Group 
row contains summary information for a single compound target as feature-
extracted across your data set.

Information regarding the available columns are found in the online Help in the topic 
“Compound Groups Columns.” A list of the available columns is displayed when you 
right-click within the Compound Groups table, and then click Add/Remove Columns.

Figure 53 Compound Groups window and shortcut menus
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Compound Details The data presented in Compound Details window (Figure 54) is organized as a list of 
the appearance of a selected compound in all of the data files in your project - fea-
ture information by data file.

The Compound Details window shows a table of compound-level information for a 
single feature selected in the Compound Groups window. The quantitative informa-
tion is shown for the selected feature as it is found in each data file in your project.

Information regarding the available columns are found in the online Help “Com-
pound Details Columns.” A list of the available columns is displayed when you right-
click within the Compound Details table, and then click Add/Remove Columns.

Figure 54 Compound Details window and shortcut menus

The Flags (Tgt) column, highlighted, provides a feature extraction summary for each 
isotopologue for the selected compound, for each sample data, file based on warn-
ing, or error flags, reported from the Find by Formula algorithm.

○ = no errors (qualified)
The isotopologue qualified and was used in the calculation.

M =  m/z tolerance (disqualified)
The isotopologue was disqualified for not meeting the m/z tolerance.

T = time correlation (disqualified)
The isotopologue was disqualified for not coeluting.
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_ =  no peak (disqualified)
The isotopologue was disqualified because its EIC did not have enough con-
tiguous non-zero points.

Chromatogram Results Chromatogram Results (Figure 55) presents the extracted ion chromatograms (EIC), 
or extracted compound chromatograms (ECC), for each feature. For isotopologue 
extraction results, the sum of the EICs for all of the qualified isotopologues are used 
to create ECCs for the for the target feature of the feature selected in the Compound 
Groups window. An ECC is displayed for each data file. 

The Chromatogram Results windows provides an opportunity to quickly review the 
chromatograms to determine if you want to remove the compound, extract a com-
pound manually, and adjust your Batch Isotopologue Extraction method.

The Results Modes buttons  on the toolbar allow you to 
set the display mode, display options, and the maximum number of chromatograms 
to display in the window. By default the chromatograms are displayed in an alternat-
ing cycle of ten colors to help you review the data for a particular data file as you 
select different features. Color by Sample Group displays the samples in an alter-
nating cycle of colors based on the sample group assignment, time sequence for 
qualitative flux analyses. The order of the appearance of the samples and sample 
groups are set in the Add/Remove Sample Files dialog box.

Figure 55 Chromatogram Results window and shortcut menu
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MS Spectrum Results MS Spectrum Results (Figure 56) presents the averaged mass spectrum (MS) across 
the integrated ECC for the feature selected in the Compound Groups window for 
each data file. For isotopologue extraction results the mass spectra are presented 
across the isotopologue extraction region. 

The MS Spectrum Results windows provides an opportunity to quickly review the 
mass spectra to determine if you want to remove the compound or adjust your 
Batch Isotopologue Extraction method.

The Results Modes buttons  on the toolbar allow you to 
set the display mode, display options, and the maximum number of mass spectra to 
display in the window. By default the spectra are displayed in an alternating cycle of 
ten colors, matched with the Chromatogram Results, to help you review the MS data 
for a particular data file as you select different features. Color by Sample Group dis-
plays the samples in an alternating cycle of colors based on the sample group 
assignment, time sequence for qualitative flux analyses. The order of the appear-
ance of the samples and sample groups are set in the Add/Remove Sample Files 
dialog box.

Figure 56 MS Spectrum Results window and shortcut menu

Isotopologue Results Isotopologue Results presents a sequence of charts, or a single chart for the feature 
selected in the Compound Groups window. The display of the isotopologue results 
depends on the results mode  selected from the toolbar. 
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This view provides you with an opportunity to quickly review the flux results to 
determine if you want to adjust your Batch Isotopologue Extraction method.

List mode displays the isotopologue results for each sample file. The isotopologue 
charts are arranged in the order of your sample groups with each sample replicate 
displayed in an alternating cycle of ten colors, matched with the Chromatogram 
Results and MS Spectrum Results. The coloring can be changed to represent the 
sample groups by selecting Color by Sample Group from the toolbar.

Sample group mode (Figure 56)displays the isotopologue results for each sample 
group. Each sample replicate is displayed within each group chart in an alternating 
cycle of ten colors, matched with the Chromatogram Results and MS Spectrum 
Results. The coloring can be changed to represent the sample groups by selecting 
Color by Sample Group from the toolbar.

Overlaid mode displays a single summary chart of the isotopologue results. The 
summary chart contains the average and standard error for each isotopologue per 
sample group presented in gray scale. The sample groups can be viewed in color by 
selecting Color by Sample Group from the toolbar.

Figure 57 Isotopologue Results window and shortcut menu

The chart y-axes can be scaled to raw abundances (Raw), raw abundances normal-
ized to 100% (Raw (%)), natural isotope abundance corrected abundances (Cor-
rected), and natural isotope abundance corrected and normalized to 100% 
(Corrected (%)).
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Export your results as a 
Profinder Archive

Save your Profinder results as a Profinder Archive (PFA) file to visualize your results 
in the context of biochemical networks in Omix Premium in chapter “Visualize on 
pathways” on page 67. 

a Click the File > Export as Profinder Archive.

b Select All compounds under the Export contents heading in the Export to 
Profinder Archive (.PFA) dialog box.

c Click the Select  button to select your export destination folder, and enter 
your file name.

d Navigate to the folder to save your project in the Save Export File to dialog box 
(Figure 58).

e Enter VistaFlux_WFG for the File name.

f Click Save to return to the Export to Profinder Archive (.PFA) dialog box. The 
Profinder Archive is not saved at this time; it is saved from the Export to 
Profinder Archive (.PFA) dialog box.

Figure 58 Save Export File to dialog box used to save your Profinder Archive

g Click OK to save your Profinder Archive file (Figure 59).

Figure 59 Export to Profinder Archive dialog box
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Save your Profinder 
project

Save your Profinder project, method, and the current sample data file extraction 
results so that you can review your results and extraction method at a later time. 

a Click the File > Save Project as.

b Navigate to the folder to save your project in the Save As dialog box.

c Enter VistaFlux_WFG for the File name.

d Click Save.

Figure 60 Save As dialog box used to save your Profinder project

Next step... You have now completed the third step of the VistaFlux Software workflow. In the 
next workflow step you visualize your results on pathways.
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Network diagrams and 
Omix Premium overview

A pathways network diagram is created using Omix Premium to facilitate the visual 
relationship of the target compounds in the experiment. Isotopologue compositions 
of the target compounds, superimposed on the pathways network diagram, help you 
visualize the metabolic flux of the pathways and possible association with experi-
mental conditions. The pathways network diagram in the example experiment 
includes target compounds from each of the following elements:

• Pathways
• Tracer compounds
• Novel metabolites
• Indirect metabolites
• Nucleosides

Example experiment The example experiment used in this workflow guide is based on a mutation of the 
isocitrate dehydrogenase 2 (IDH2) enzyme associated with chondrosarcoma, a bone 
cancer consisting of a malignant tumor from cartilage-producing cells. IDH2 partici-
pates in the regulation of the metabolites D-threo-isocitrate and α-ketoglutarate in 
the TCA cycle. Mutation of the IDH2 results in the formation of a novel metabolite 
from α-ketoglutarate and perturbs energy production in the cell. To study the effect 
of the IDH2 mutation, the experiment monitors a set of target compounds that are 
directly and indirectly associated with pathways that are part of the central carbon 
metabolism, the primary energy producing mechanism for all aerobic biology. The 
following biological pathways are part of the network created for the example exper-
iment:

• Tricarboxylic acid cycle
• Lactate fermentation
• Aspartate biosynthesis
• Glutamate biosynthesis/degradation

Description of the elements 
in the network diagram

Create a network diagram for each of the elements involved in the experiment with 
particular emphasis on the appearance of each of the seventeen (17) target com-
pounds. The first appearance of each target metabolite in the LC/MS sample data is 
emphasized in the following overview of the diagram elements.

Pathways Four BioCyc pathways are part of the example network diagram.

Lactate fermentation pathway: Pyruvate, a three carbon molecule formed from the 
glycolysis of glucose, is metabolized aerobically or anaerobically. The aerobic path-
way leads to the TCA cycle. The anaerobic pathway leads to lactate (L-lactic acid) 
known for accumulating during intense muscle use.

TCA cycle: The TCA cycle is a high-output energy cycle. Entry into the TCA cycle 
from glycolysis is via the dehydrogenation of pyruvate to acetyl coenzyme A (acetyl-
CoA). Travel around the TCA cycle leads to the following metabolite order: 

START with acetyl coenzyme A (acetyl-CoA) > citrate (citric acid) > cis-aconitate 
(aconitic acid) > D-threo-isocitrate (D-threo-isocitric acid) > 2-oxoglutarate or α-
ketoglutarate (oxoglutaric acid or α-KG) > succinyl coenzyme A (succinyl-CoA) > 
succinate (succinic acid) > fumarate (fumaric acid) > (S)-malate (L-malic acid) > 
oxaloacetate (oxalacetic acid) > RETURN to citrate.
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Aspartate biosynthesis: The non-essential amino acid L-aspartic acid is formed from 
oxaloacetate, a metabolite that is part of the TCA cycle.

Glutamate biosynthesis/degradation: α-ketoglutaric acid is formed through the 
deamination of glutamate, a tracer in this study.

Tracers The tracer is labeled glutamate, 13C5- glutamate (U-13C-Glu), that directly feeds the 
formation of 2-oxoglutarate in the TCA cycle. 2-oxoglutarate is in-turn acted on by 
the mutated enzyme IDH2 in the experimental cell line.

Novel metabolites Novel metabolites are metabolites that form as a result of pathway perturbation, 
such as an enzyme mutation, and are sometimes referred to as an oncometabolite if 
observed in cancer cells. IDH2 normally catalyzes the oxidative decarboxylation of 
isocitrate to 2-oxoglutarate. During studies of cell lines that exhibit chondrosarcoma 
from the mutation of IDH2 a novel compound, 2-hydroxyglutarate, appears as a 
byproduct of metabolism. IDH2 exhibiting the mutation produce 2-hydroxyglutarate 
from 2-oxoglutarate, thereby competing with the conversion of 2-oxoglutarate to 
succinyl-coenzyme A, succinic acid and additional downstream metabolites in the 
TCA cycle.

Indirect metabolites Indirect metabolites show a commensurate increase, or decrease, in abundance as a 
result of the perturbation of a pathway. When a chondrosarcoma tumor has been 
established, elevated levels of glutathione may appear in samples.

Nucleosides Nucleosides participate in general cellular metabolism and can be used for a variety 
of reasons in a flux analysis experiment. The nucleosides in this study include ade-
nosine triphosphate (ATP), adenosine diphosphate (ADP), guanosine triphosphate 
(GTP), and guanosine diphosphate (GDP).

Introduction to Omix 
Premium

Omix Premium is a customizable visualization and modeling tool for biochemical net-
work diagrams. Omix Premium brings together systems biology and metabolic engi-
neering, two scientific disciplines that are involved with the understanding of 
complex biochemical networks, to produce high quality visualizations for qualitative 
flux analyses. Vector graphics generated with Omix Premium are ideally suited for 
scientific presentations and publications. 

Based on human systems analysis activities, network diagrams generated with 
Omix Premium are structured using concepts such as metabolic pathways, regula-
tory motifs, genetic operons/regulons, signal transduction sequences, hierarchical 
organization, and spatial compartmentalization. Omix Premium has addressed the 
challenge of designing information-rich visual representations of biological network 
diagrams. Network diagrams created using Omix Premium are capable of displaying 
quantitative data from simulation runs or experimental data associated with the net-
work nodes and edges. Omix Premium is therefore ideally suited to display your 
qualitative flux analysis data processed using MassHunter Profinder.
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Review the Omix Premium 
user interface

The main functional areas of Omix Premium are shown in Figure 61. The Omix Pre-
mium window consists of four parts: (1) the Menu Bar, (2) the Toolbar, (3) the Docu-
ment Area, and (4) the Status bar.

The document area can be further divided into up to five windows — (3a) Drawing 
Area, (3b) Component View window, (3c) Property Editor window, (3d) Data Man-
ager window, and (3e) Log Messages window. Your visualization, and most of your 
interaction with Omix Premium, takes place in the Drawing Area. Each window can 
be floated independently to any location and size on your computer display or 
arranged to your preference within the Document Area, as shown in Figure 61. 

Figure 61 Screen areas of Omix Premium with the MassVisualizer toolbar
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Review the workflow
for creating a network
diagram

The workflow to create your initial pathways network diagram is shown in Figure 62. 
The objective is to become familiar with several basic steps to create a new network 
pathways document.

Note: No specific sequence of steps must be followed to create your pathways net-
work diagram. As you are learning, follow this workflow to become familiar with 
more than one approach to add pathways, add metabolites, and arrange elements 
using Omix Premium.

Figure 62 Workflow to create a pathways network diagram for the data contained 
in your Profinder Archive

Step 1. Create a new document using pathways content available on the BioCyc 
database. See section “1. Launch Omix Premium” on page 73.

Step 2. Use the Omix Premium interface to search, review, and select reactions 
from pathways for a specified organism. Once you have selected the target reac-
tions for your project, import the target reactions into your new document. See 
section “2. Search, review, and select pathways reactions” on page 73.

Step 3. Arrange and position the components of the pathways reactions you 
selected into a basic order within your new pathways network diagram. During 
this initial exercise to arrange the imported pathways reactions you develop a 
familiarization with the various toolbars and working in the Drawing Area. See 
section “3. Arrange and position your pathways reactions” on page 75.

Step 4. Add the compounds from your Profinder Archive file to your pathways 
network diagram. Some compounds in the PFA file, generated in “Export your 
results as a Profinder Archive” on page 65, are not part of the initial pathways 
network diagram; you can create the new compounds automatically within Omix 
Premium. See section “4. Add compounds from your Profinder Archive file” on 
page 78.

Step 5. Enable the Agilent MassVisualizer plug-in for your new document. Mass-
Visualizer enables the MassVisualizer Toolbar that is necessary to add the quali-
tative flux analysis visual elements to your network diagram. See section “5. 
Enable Agilent MassVisualizer” on page 80.

Step 6. Find and add additional BioCyc pathway reactions to connect and com-
plete your pathways network diagram. Duplicate compounds created as a result 
of adding new pathway content can help you to become familiar with merging 
duplicates and linking pathways together. For compounds that are unique to your 
experiment, such as novel and indirect metabolites, reactions are created to link 
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them to the pathways network diagram. See section “6. Link new compounds and 
add new pathway” on page 80.

Step 7. Adjust your complete pathways network diagram using pattern tools, 
geometry tools for edge segments, and general visual placement in preparation 
for viewing your Profinder data within the Drawing Area. See section “7. Adjust 
your network diagram using pattern and geometry tools” on page 88.

Step 8. Save your pathways network diagram as an Omix Premium (OMX) docu-
ment. See section “8. Save your network diagram” on page 98.

Omix Premium Plug-ins In this workflow guide the plug-ins Agilent MassVisualizer, Atomic Layer, and Chem-
ical Structures are enabled. 

Click Extras > Manage Plug-Ins to launch the Plug-in Manager dialog box 
(Figure 63) to install or update plug-ins for your Omix Premium Installation. 

You can also update your Omix Premium and Plug-ins using Help > Check for 
Update or Help > Update Plug-ins; the Check for Update menu is replaced with 
Update Plug-ins when the software is aware of an available plug-in update.

Figure 63 Plug-in Manager dialog box
72 



Visualize on pathways Build your pathways network diagrams
Build your pathways 
network diagrams

Create your initial pathways network diagram using the basic steps described in 
“Review the workflow for creating a network diagram” on page 71. Similar to the 
creation of your target metabolite list, the pathways network diagram is based on 
the reactions and metabolites associated with the TCA cycle shown in Figure 4 on 
page 11.

1. Launch Omix Premium A brief overview of Omix Premium is presented in “Introduction to Omix 
Premium” on page 69. This is Step 1 of “Review the workflow for creating a network 
diagram” on page 71.

a Double-click the Omix Premium icon  located on your desktop, or click Start 
> All Programs > Omix Premium > Omix Premium. When Omix Premium opens 
the document area is arranged to facilitate a quick means to review the software 
features, create a new document, and open a recent document.

Create a new document b Click New in the Document Area (Figure 64).

c Click Load Network from BioCyc. The Select BioCyc Database dialog box is 
immediately opened.

Figure 64 Create a new document in Omix Premium

2. Search, review, and 
select pathways reactions

Use the Omix Premium interface to search, review, and select reactions from path-
ways for a specified organism. Once you have selected the target reactions for your 
project, import the target reactions into your new document. This is Step 2 of 
“Review the workflow for creating a network diagram” on page 71.

Select organism using 
Select BioCyc Database 

dialog box

a Click Homo sapiens for your search organism in the Select BioCyc Database dia-
log box (Figure 65 on page 74). The upper pane lists your favorite organisms and 
the lower pane lists all BioCyc organisms; you can mark and clear your favorite 
organisms from the lower pane.
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b Click OK.

Figure 65 Select BioCyc Database dialog box

Select pathways using 
Load from BioCyc 

dialog box

a Type TCA in Quick Search to reduce the number of pathways listed in the 
Browse Pathways section of the Database Content in the Load from BioCyc dia-
log box (Figure 66).

b Click TCA cycle in the Database Content area.

c Click the Show pathway on BioCyc website  button to view the pathway in 
your default browser.

d Click the Add all Reactions of the selected Pathway(s) into your selected net-
work  button to copy all of the reactions in the TCA cycle pathway to the 
Selected Network area.

Note: Double-click TCA cycle to view all of the TCA cycle pathway reactions.

Figure 66 Load from BioCyc dialog box
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e Type lactate in Quick Search.

f Click lactate fermentation (reoxidation of cytosolic NADH) in the Database Con-
tent.

g Click the Show pathway on BioCyc website  button to view the pathway in 
your default browser.

h Click the Add all Reactions of the selected Pathway(s) into your selected net-
work  button to copy all of the reactions in the lactate fermentation pathway 
to the Selected Network area.

i Review the Selected Network table; you can remove and restore reactions.

Select one or more reactions that are not interesting. Use click, Shift-click, and 
Ctrl-click to select more than one reaction. Selected reactions are highlighted 
using a background color.

Click the Remove all selected Reactions out of your selected network  but-
ton to remove the highlighted reactions from the Selected Network. If you remove 
a reaction you want to retain, click the source pathway in the Database Content 
and then click  to restore the reactions in the selected network. Duplicate 
reactions are not created, Omix Premium restores the missing reaction to the 
Selected Network area.

j Click OK to create your new document. The two pathways are placed in the Draw-
ing Area. The lactate fermentation (reoxidation of cytosolic NADH) pathway was 
moved from its initial position produce the view shown in Figure 67.

Figure 67 Drawing Area showing an initial view of two BioCyc pathways. During 
this workflow you will move, edit, and align elements to improve the view.

3. Arrange and position
your pathways reactions

Use the Omix Premium Drawing Area interface to arrange and position the pathways 
reactions you selected into a basic order within your new pathways network dia-
gram. This is Step 3 of “Review the workflow for creating a network diagram” on 
page 71.
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Edit pathway name a Double-click the text lactate fermentation (reoxidation of cytosolic NADH) to 
edit the pathway name.

b Select the text lactate fermentation (reoxidation of cytosolic NADH). Selected 
text is highlighted in a background color.

c Type Lactate fermentation for the pathway name, and then press Enter.

Move and arrange the pathway a Click the pathway line associated with the Lactate fermentation pathway. The 
pathway line changes to a lighter shade of the same color indicating that the 
pathway is selected.

b Drag the entire pathway so that pyruvate (Lactate fermentation) is positioned 
near and above acetyl-CoA (TCA cycle).

c Right-click on the L-LACTATE-DEHYDROGENASE-RXN node, and then click Auto-
matically arrange single neighbors to organize the nodes as shown in Figure 68.

Figure 68 Automatically arrange single neighbors to arrange cofactors

Insert a new reaction This set of steps creates a pathway to link the lactate fermentation pathway to the 
TCA cycle pathway.

a Click and drag the Lactate fermentation pathway so the pyruvate metabolite is 
above the acetyl-CoA metabolite (Figure 69 on page 77).

b Click Insert Reaction  > Insert Reaction on the toolbar (or type Ctrl+Shift+R) 
to insert the new pyruvate decarboxylation reaction that links pyruvate to acetyl-
CoA.
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c Drag the new reaction to a location between the pyruvate to acetyl-CoA metabo-
lites as shown in Figure 69.

d Type PYR-DEC-RXN for the name of the new reaction, and then press Enter.

Note: You must enter a reaction name when a new reaction is inserted into your 
pathways network diagram. Your new reaction is immediately added to the list of 
Reactions in the Component View window, Each reaction must have a unique 
name.

Insert flux edges a Click Insert Flux Edge  on the toolbar to insert a flux edge from pyruvate to 
the pyruvate decarboxylation reaction.

b Click on one of the nine control points around the pyruvate metabolite. The center 
control point provides the smoothest network appearance.

c Drag the flux edge to one of the nine control points around the pyruvate dehydro-
genase reaction and release the flux edge. The center control point provides the 
smoothest network appearance.

d Click on one of the nine control points around the pyruvate decarboxylation reac-
tion to insert a second flux edge from the pyruvate decarboxylation reaction to 
the acetyl-CoA metabolite. Since the Insert Flux Edge is still active, it is not nec-
essary to click Insert Flux Edge  a second time. The center control point pro-
vides the smoothest network appearance.

e Drag the flux edge to one of the nine control points around the acetyl-CoA metab-
olite and release the flux edge. The center control point provides the smoothest 
network appearance.

f Click Select  on the toolbar, or press Esc, to exit the process of inserting flux 
edges.

Note: The pyruvate decarboxylation reaction joins the lactate fermentation reac-
tion to the TCA cycle. The Drawing Area view in Figure 69 illustrates changes 
made to the lactate fermentation pathway name and movement of the relative 
positions of the metabolites and reactions to improve the pathway clarity. 

Figure 69 Drawing Area showing the inserted pyruvate decarboxylation reaction
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4. Add compounds from 
your Profinder Archive file

Add the compounds from the PFA file you saved in “Export your results as a 
Profinder Archive” on page 65. This is Step 4 of “Review the workflow for creating a 
network diagram” on page 71.

Note: You can import your isotopologue results into an Omix Premium document 
without a pathway (“Import Profinder results without a pathway” on page 100). 
When you import a PFA file from Profinder, you are notified when one or more 
compound in your PFA file does not match any compounds in your Omix Premium 
document; when you choose to insert the unmatched compounds from your PFA 
you can use all of the MassVisualizer tools (see “Display isotopologue metabolite 
data and highlight pathways” on page 103) to review any PFA file without first 
creating a pathways network diagram.

Open Profinder data a Click Data > Open Data Table.

b Navigate to the folder and select file VistaFlux_WFG.pfa (Figure 70) in the Open 
Data Source dialog box.

c Click Open. The Data Manager window is automatically opened.

Figure 70 Open Data Source dialog box

Activate Agilent 
MassVisualizer plug-in

d Click Yes in the new Open Data Source dialog box to activate Agilent MassVisu-
alizer (Figure 71). You can chose to activate the Agilent MassVisualizer plug-in 
later; however, MassVisualizer must be activated at this time in this workflow.

Note: If you do not activate the MassVisualizer plug-in you cannot add missing 
compounds in the next step. Click Extras > Document Extensions > Agilent 
MassVisualizer to manually enable MassVisualizer and continue to the next step.

Figure 71 Open Data Source dialog box

e Click Data > Show Data Manager to close the Data Manager window. The pur-
pose for opening your Profinder project is to obtain the compounds that are not 
present in the TCA cycle and lactate fermentation pathways; the Data Manager 
window is not necessary to import the missing compounds.
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Add compounds to the net-
work diagram

a Click Visualization > Agilent MassVisualizer > Check for missing compounds. If 
you have not previously checked for missing compounds, when you next click the 
Show Abundance Changes  button Omix Premium will automatically check 
for missing compounds.

Note: When there are compounds in the PFA file that do not match compounds in 
the open document, the Compound Availability dialog box is opened after you 
click the Show Abundance Changes  button. This provides an opportunity to 
import metabolites that have mass spectral data to a pathway diagram that does 
not yet contain nodes for them. Otherwise the Abundance Change Visualization 
dialog box is opened.

b Review the list of metabolites in the Profinder Archive file that do not match to a 
compound in the open document in the Compound Availability dialog box. Four 
compounds are not available in the network diagram (Figure 72).

Figure 72 Compound Availability dialog box

c Click Yes to add the four missing compounds to the network document: Glutathi-
one, oxidized, 2-Hydroxyglutarate, L-Glutamate, and L-Aspartic acid.

Note: Even though compound names in the Profinder Archive are not the same as 
the names used on by the imported BioCyc pathways, the compounds are suc-
cessfully matched. Inclusion of compound identifiers, such as CAS, HMP, and 
KEGG (see “Add retention times and additional identifiers to your target metabo-
lite list.” on page 34) improved the data matching accuracy when you imported 
your Profinder project into Omix Premium.

d Drag the group of four metabolites to a position next to the TCA cycle.

e Click on the Drawing Area to place the four metabolites. Exact placement is not 
important; the metabolites are moved to new locations as they are linked to your 
network diagram (Figure 73).

Figure 73 Drawing Area showing the four missing metabolites
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5. Enable Agilent 
MassVisualizer

Choose the plug-ins to enable for your document. This is Step 5 of “Review the 
workflow for creating a network diagram” on page 71.

a Click Extras > Document Extensions > Agilent MassVisualizer (Figure 74).

Note: You must enable the Agilent MassVisualizer plug-in to enable visualization 
of your isotopologue results from Profinder. If the Agilent MassVisualizer plug-in 
is not enabled when you open a PFA file Omix Premium will automatically prompt 
you (Figure 71).

b Click Extras > Document Extensions > Atomic Layer.

c Click Extras > Document Extensions > Chemical Structures.

Figure 74 Enable Document Extensions from the menu bar

Enable the Agilent Mass 
Visualizer toolbar

a Right-click anywhere on the toolbar to view the status of the available toolbars.

b Click MassVisualizer Toolbar (Figure 75).

c Drag the MassVisualizer Toolbar group to a convenient location among the open 
toolbars.

Figure 75 Initial MassVisualizer toolbar

6. Link new compounds and 
add new pathway

Find and add BioCyc pathway reactions to complete your pathways network dia-
gram. For compounds that are unique to your experiment, such as novel and indirect 
metabolites, reactions are created to link them to the pathways network diagram. 
This is Step 6 of “Review the workflow for creating a network diagram” on page 71.

1. Link the novel metabolite 
2-hydroxyglutarate to the 
TCA cycle.

The novel metabolite 2-hydroxyglutarate is linked to 2-oxoglutarate via a new reac-
tion labeled IDH2.

a Drag the 2-hydroxyglutarate metabolite to a position near and to the right of 2-
oxoglutarate on the TCA cycle.

Insert a new reaction b Click Insert Reaction  > Insert Reaction on the toolbar (or type Ctrl+Shift+R) 
to insert the new IDH2 reaction that links 2-hydroxyglutarate to 2-oxoglutarate.

c Drag the new reaction to a location between the 2-hydroxyglutarate and 2-oxoglu-
tarate metabolites.
80 



Visualize on pathways Build your pathways network diagrams
d Type IDH2 for the name of the new reaction, and then press Enter (Figure 76).

Note: You must enter a reaction name when a new reaction is inserted into your 
pathways network diagram. Your new reaction is immediately added to the list of 
Reactions in the Component View window. Each reaction must have a unique 
name.

Figure 76 Drawing Area showing the inserted IDH2 reaction

Insert flux edges e Click Insert Flux Edge  on the toolbar to insert a flux edge from 2-hydroxyglu-
tarate to the IDH2 reaction.

f Click on one of the nine control points around the 2-oxoglutarate metabolite. The 
center control point provides the smoothest network appearance.

g Drag the flux edge to one of the nine control points around the IDH2 reaction and 
release the flux edge. The center control point provides the smoothest network 
appearance.

h Click on one of the nine control points around the IDH2 reaction to insert a sec-
ond flux edge from the IDH2 reaction to the 2-hydroxyglutarate metabolite. Since 
the Insert Flux Edge is still active you do not need to click Insert Flux Edge  a 
second time. The center control point provides the smoothest network appear-
ance.

i Drag the flux edge to one of the nine control points around the 2-hydroxyglutarate 
metabolite and release the flux edge. The center control point provides the 
smoothest network appearance.

j Click Select  on the toolbar, or press Esc, to exit the process of inserting flux 
edges. Your network diagram should look similar to Figure 77 on page 82.
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Figure 77 Drawing Area showing the inserted IDH2 and flux edges

2. Move the indirect 
metabolite glutathion near 
2-hydroxyglutarate.

Since the glutathione metabolite is an indirect metabolite, position the glutathione 
metabolite near the 2-hydroxyglutarate metabolite.

• Drag the glutathione, oxidized metabolite to a position near the 2-hydroxygluta-
rate metabolite. Flux edges are not necessary to connect this metabolite to the 
network diagram (Figure 78).

Figure 78 Drawing Area showing the repositioned glutathion, oxidized metabolite

3. Insert a new pathway 
containing L-aspartic acid.

Insert the aspartate biosynthesis pathway to show the relationship of the metabolite 
L-aspartic acid to the TCA cycle.

Delete metabolites a Right-click the L-aspartic acid metabolite in the Component View, and then click 
Delete to delete the L-aspartic acid metabolite that was imported with the PFA 
file (Figure 79 on page 83).

b Right-click the L-glutamate metabolite in the Component View, and then click 
Delete.

Note: Because L-aspartic acid and L-glutamate are also part of the new pathway 
imported later in this step, deleting these metabolites before inserting the new 
pathway assures that the BioCyc database information is included in the network 
model (for example, chemical structure, database identifiers, and synonyms). The 
database information available in Insert Pathway from BioCyc in this case con-
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tains more information, including the structural information, than the database 
used to create the PCDL used in Profinder.

Figure 79 Delete a metabolite from the Component View

Insert a new pathway c Click Insert Pathway  > Insert Pathway from BioCyc on the toolbar, or click 
Insert > Insert Pathway > Insert Pathway from BioCyc on the menu bar, to 
insert the aspartate biosynthesis pathway.

d Type aspartate for by name search in the Select Pathway dialog box.

e Click the Search  button (Figure 80).

f Click aspartate biosynthesis in the list of pathways that match your search text.

g Clear import regulatory effects (inhibition and activation). Regulatory effects are 
only relevant for kinetic modeling and are not necessary for qualitative flux analy-
sis.

h Click OK.

Figure 80 Select Pathway dialog box

i Drag the aspartate biosynthesis pathway near to and above the oxaloacetate 
metabolite on the TCA cycle, then click on the Drawing Area.

j Drag the pathway name aspartate biosynthesis to a position above the pathway 
so you can access the individual metabolites and reactions.
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k Right-click on the ASPAMINOTRANS-RXN node, and then click Automatically 
arrange single neighbors to organize the nodes. Your network diagram should 
look similar to Figure 81.

Figure 81 Drawing Area showing the aspartate biosynthesis pathway next to the 
TCA cycle pathway

Mirror a pathway l Drag a selection box around the aspartate biosynthesis reaction (Figure 82).

Figure 82 Drawing Area showing the aspartate biosynthesis pathway next to the 
TCA cycle pathway

m Right-click on an element of the selected the aspartate biosynthesis reaction.

n Click Mirror horizontally, or click the Mirror horizontally  button, this places 
the oxaloacetate metabolites in each of the pathways near each other (Figure 83 
on page 85).
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Figure 83 Mirror a pathway to align the oxaloacetate metabolites near each other

Unify a duplicate metabolite o Click one oxaloacetate metabolite.

p Shift-click the other oxaloacetate metabolite to select both metabolites. A dashed 
rectangle encompassing both metabolites confirms that the metabolites are 
selected.

q Right-click the oxaloacetate metabolite that is part of the TCA cycle pathway.

Note: When you move, scale, or rotate a multi-node selection, any nodes that are 
assigned to an underlying pattern are ignored and remain unchanged on their 
position.

r Click Unify selected duplicates into this metabolite. The two pathways are now 
joined together (Figure 84 on page 86).
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Figure 84 Drawing Area showing the final arrangement of the aspartate biosyn-
thesis pathway

s Drag the metabolites, reactions, and descriptors to improve the pathway clarity 
similar to Figure 85.

Note: The aspartate biosynthesis reaction also includes the tracer metabolite, L-
glutamate, that is the last metabolite from the target metabolite list imported 
from the PFA file. However, the tracer metabolite is part of another reaction path-
way more directly associated with the mutant IDH2 reaction added in the next 
step. 

Figure 85 Drawing Area showing the final arrangement of the aspartate biosyn-
thesis pathway

4. Insert a new pathway 
containing L-glutamate.

Insert the glutamate biosynthesis/degradation pathway to show the relationship of 
the metabolite L-glutamate to the TCA cycle near the IDH2 reaction.

Note: Because the L-glutamate metabolite imported from the PFA was previously 
deleted, the L-glutamate already present in the network model was created from 
the BioCyc database and therefore contains the most detailed information. L-Glu-
tamate is not deleted before adding the new pathway in this step.
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Insert a new pathway a Click Insert Pathway  > Insert Pathway from BioCyc on the toolbar, or click 
Insert > Insert Pathway > Insert Pathway from BioCyc on the menu bar to 
insert the glutamate biosynthesis/degradation pathway.

b Type glutamate for the by name search in the Select Pathway dialog box.

c Click the Search  button (Figure 86 on page 87).

d Click glutamate biosynthesis/degradation in the list of pathways that match 
your search text.

e Clear import regulatory effects (inhibition and activation). Regulatory effects are 
only relevant for kinetic modeling and are not necessary for qualitative flux analy-
sis.

f Click OK.

Figure 86 Select Pathway dialog box

g Drag the aspartate biosynthesis pathway near the 2-oxoglutarate metabolite on 
the TCA cycle, then click on the Drawing Area.

h Drag the pathway name glutamate biosynthesis/degradation to a position below 
the pathway so you can access the individual metabolites and reactions associ-
ated with the pathway (Figure 87).

Figure 87 Drawing Area with the glutamate biosynthesis/degradation pathway
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Unify a duplicate metabolite i Click on one 2-oxoglutarate metabolite.

j Shift-click on the other 2-oxoglutarate metabolite to select both metabolites. A 
dashed rectangle encompassing both metabolites confirms that the metabolites 
are selected.

k Right-click on the 2-oxoglutarate metabolite that is part of the TCA cycle pathway.

l Click Unify selected duplicates into this metabolite. The two pathways are now 
joined together.

m Right-click on the GLUTAMATE-DEHYDROGENASE-NADP+-RXN reaction, and 
then click Automatically arrange single neighbors to improve the pathway clar-
ity.

n Move the pathway nodes to create a layout that is similar to Figure 88.

Figure 88 Drawing Area showing the final arrangement of the glutamate biosyn-
thesis/degradation pathway

7. Adjust your network 
diagram using pattern and 
geometry tools

Adjust your pathways network diagram using pattern tools, geometry tools for edge 
segments, new pathways, and general visual placement in preparation for viewing 
your Profinder data within the Drawing Area. This is Step 7 of “Review the workflow 
for creating a network diagram” on page 71.

Add a circle path a Click the Edit Layout Patterns  button on the toolbar. The Drawing Area 
changes; the network diagram is moved to the background and toolbars not 
related to the Pattern Editor are removed.

b Click the Zoom Diagram  button on the toolbar so the entire pathway is visible 
in the Drawing Area.

c Click the Insert Circle Pattern Path  button on the toolbar (Figure 89 A on 
page 89).

d Click in the Drawing Area over the CITCYN-RXN node to start the circle at the 
entry to the TCA cycle (Figure 89 B on page 89).
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e Drag the dynamic circle view so that is aligned with and slightly larger than the 
general TCA cycle in the Drawing Area (Figure 89 C).

f Click on the Drawing Area to place the circle path. The beginning and end of the 
arc are indicated with red squares (Figure 89 D).

Figure 89 Sequence of actions to draw a circle pattern in the Pattern Editor

Note: When the circle is started and position properly over the TCA cycle, Omix 
Premium automatically guides you through alignment of the TCA cycle pathway 
to the pattern starting with the CITCYN-RXN node as shown in Figure 90 on 
page 90. Animated arrows on the circle shows that the alignment is proceeding in 
a clockwise direction. You direct the automatic layout using the Add Nodes to 
Pattern dialog box.

If the circle pattern is not properly inserted over the reaction the Add Nodes to 
Pattern dialog box does not appear. After you close the Pattern Editor, you can 
launch the Add Nodes to Pattern dialog box by dragging the CITCYN-RXN node 
onto the red square of the circle pattern that now appears in the background of 
the Drawing Area.
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Figure 90 Pattern editor and Add Nodes to Pattern dialog box

Add nodes to the circle pattern a Click on each successive metabolite and reaction to confirm the nodes you want 
to align to the circle pattern. When a node, a metabolite, or reaction is clicked the 
pathway is highlighted to provide a visual confirmation of the pattern alignment 
you selected (Figure 91 on page 91).

The beginning of the path is labeled Pathway: 'TCA cycle’ and each successive 
node of the pathway is cascaded below and to the right. The starting node, CIT-
CYN-RXN, is determined by where the circle was initially placed with respect to 
the pathway. When a pathway has a branch, an alternate cascaded sequence of 
nodes is presented further down the list of nodes. Move the Add Nodes to Pat-
tern dialog box away from the Drawing Area so you can preview the layout path 
highlighted in yellow on the pathway diagram as shown in Figure 91 on page 91.

Mark Arrange in opposite direction if you want to arrange nodes in a counter-
clockwise order.

b Click the second CITSYN-RXN node (highlighted in green) to select the nodes in a 
clockwise order as shown in Figure 92 on page 91. A green-highlighted node rep-
resents a complete and valid path through the network. You must select a green 
node to proceed with the layout process.

c Click OK to complete the node order. The network diagram is automatically fitted 
to the circle pattern and the edges are converted from lines to smooth curves that 
are fit onto the circle path (Figure 93 on page 92).
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Figure 91 Adding nodes to the circle path

Figure 92 Selecting the nodes to add to the path when there is a split in the path-
way
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Figure 93 The TCA cycle pathway fitted to a circle path

Add a curve path a Zoom the Drawing Area into the split path of the TCA cycle containing the SUC-
CCOASYN-RXN node.

b Click the Insert Curve Pattern Path  button on the toolbar.

c Click on the succinyl-CoA node, but not on the circle path, to start the curve path. 
It is not recommended to have the curve path connect to the circle path; this can 
lead to a confusion regarding which path a node and its edges follow. This is the 
first control point for the curve.

d Click on the Drawing Area near, but to the lower-right of the SUCCINATE-COA-
LISAGE-GDP-FORMING-RXN node. This is the second control point for the curve.

e Click again on the Drawing Area near, but to the upper left of the SUCCINATE-
COA-LISAGE-GDP-FORMING-RXN node. This is the third control point for the 
curve.

f Click on SUCCINATE-COA-LISAGE-GDP-FORMING-RXN node, but not on the cir-
cle path, to complete the line path. This is the fourth, and final, control point for 
the curve. A curve path is completed when you place four control points 
(Figure 94 on page 93).

g Click Close Pattern Editor  on the toolbar. The circle and curve 
paths are visible behind your pathways network diagram.
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Figure 94 Curve path in the pattern editor

Add a node to a path a Drag the SUCCCOASYN-RXN node to the curve path. By moving the reaction node 
to a position close to the underlying path, Omix Premium automatically snaps the 
node to the path.

b Drag the metabolites connected to the SUCCCOASYN-RXN node to view the reac-
tion edges.

Align an edge to a path a Click the edge between the succinyl-CoA and SUCCCOASYN-RXN nodes. The 
edge is surrounded by a dashed rectangle.

b Click the edge between the succinyl-CoA and SUCCCOASYN-RXN nodes a sec-
ond time to enable changing the edge geometry. A red circle appears on the edge 
(Figure 95).
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Figure 95 Select a line edge to convert to curve edge

c Right-click the red circle (control point) on the edge, then click Curve Shape > 
Curve (One Control Point) to change the edge line into a curve (Figure 95 on 
page 94).

d Drag the edge control point, now a black circle, to match the edge to the arc path 
(Figure 96).

Figure 96 Adjust a curve edge to follow the background curve pattern

e Repeat the edge conversion to a curve and alignment for the edge between the 
SUCCCOASYN-RXN and succinate nodes (Figure 97).

Figure 97 Split in the TCA cycle pathway aligned to a background curve path

f Click the Zoom Diagram  button on the toolbar so the entire pathway is visible 
in the Drawing Area (Figure 98 on page 95).
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Figure 98 Network diagram after repositioning nodes and aligning to patterns 
using the Pattern Editor

Create a new pathway You can define a new pathway and add reaction, edge, and metabolite nodes to the 
pathway using the Component View window. The new pathway can be formatted 
and adjusted in a manner identical to imported pathways. 

a Click the Insert Pathway  button > Insert Pathway on the toolbar.

b Type 2-Hydroxyglutarate formation for the Name in the New Path-
way dialog box (Figure 99).

c Mark the IDH2 reaction on the list of Available Reactions. The list of available 
reactions contains reactions that are not already associated with a pathway.

d Click OK. The new pathway appears in the Pathways tree in the Component View 
window.

Note: Since the IDH2 reaction node already has reaction edges that connect it 
with the metabolites 2-hydroxyglutarate and 2-oxoglutarate, the entire pathway is 
created from this operation (Figure 102 on page 96).

Figure 99 New Pathway dialog box
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Create and fill an 
empty pathway

If you click OK in the New Pathway dialog box (Figure 99 on page 95), but did not 
select a reaction to assign to the new pathway, a notice is displayed. You can click 
Yes to create an empty pathway or Click No to assign a reaction to the new pathway 
(Figure 100).

Figure 100 New Pathway created without a reaction notice

a Click the IDH2 reaction node in the Component Viewer window.

b Drag the IDH2 reaction node to the 2-Hydroxyglutarate formation pathway in the 
Component Viewer window (Figure 101).

Note: Since the IDH2 reaction node already has reaction edges that connect it 
with the metabolites 2-hydroxyglutarate and 2-oxoglutarate, the entire pathway is 
created with a single drag and drop operation (Figure 102).

Figure 101 Drag a reaction to a pathway in the Component View dialog box

Figure 102 2-Hydroxyglutarate formation pathway after smoothing the edges
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Add a new pathway a Click the Insert Pathway  button > Insert Pathway on the toolbar.

b  Type Pyruvate to TCA cycle for the Name in the New Pathway dialog 
box (Figure 103).

c Mark the PYR-DEC-RXN reaction on the list of Available Reactions. The list of 
available reactions contains reactions that are not already associated with a 
pathway.

Figure 103 New Pathway dialog box

d Click OK. The new pathway appears in the Pathways tree in the Component View 
window.

Note: Since the PYR-DEC-RXN reaction node already has reaction edges that con-
nect it with the Lactate fermentation pathway, the entire pathway is created from 
this operation (Figure 104).

Figure 104 Complete network diagram with line smoothing
97 



Visualize on pathways Build your pathways network diagrams
8. Save your network 
diagram

Save your pathways network diagram as an Omix Premium (OMX) document. This is 
Step 8 of “Review the workflow for creating a network diagram” on page 71.

Note: When your Omix Premium document has unsaved changes an asterisk 
appears at the end of the file name in the title bar (Figure 105).

Figure 105 Unsaved changes in your document are indicated by an asterisk in the 
title bar

a Click File > Save or click the Save  button on the toolbar.

If this is the first time you are saving your project, you are prompted for the folder 
and file name as described in the following steps. The first time you save your 
project is the same as when you click File > Save As.

b Navigate to the folder to save your Omix Premium network in the Save Omix Net-
work Model dialog box.

c Enter VistaFlux_Network_Diagram for the File name (Figure 106).

d Click Save.

Figure 106 Save Omix Network Model dialog box
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Import your Profinder 
Project

Import compounds and isotopologue extraction results from your Profinder project 
using the PFA file you saved in “Export your results as a Profinder Archive” on 
page 65. See “4. Add compounds from your Profinder Archive file” on page 78 for 
steps to use the PFA file to add the target compounds to your network diagram.

a Click Data > Open Data Table. If the Data Manager window is already open you 
can click the Open Data Table  button, a small button located at the bottom-
left of the Data Manager window.

b Navigate to the folder and select file VistaFlux_WFG.pfa (Figure 107).

c Click Open. Profinder compounds and isotopologue results are imported into the 
Data Manager window. The Data Manager window is automatically opened and 
your Profinder data is added to your document.

Figure 107 Open Data Source dialog box

d Review the information contained in the Data Manager window (Figure 108).

Figure 108 Example view of the Data Manager window

e Click Data > Show Data Manager, or click the Data Manager  button on the 
toolbar, to close the Data Manager window. The Profinder data is retained by the 
Omix Premium document when the Data Manager window is closed. 

Click Data > Show Data Manager, or click the Data Manager  button, again 
to re-open the Data Manager window.
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Import Profinder results 
without a pathway

Import your target metabolites and isotopologue results into an Omix Premium doc-
ument without a pathway and visualize the data as a collection of compounds.

When you import a PFA file from Profinder, you are notified when one or more com-
pounds in your PFA file do not match any compounds in your Omix Premium docu-
ment; when you choose to insert the unmatched compounds from your PFA you can 
use all of the MassVisualizer tools to review your Profinder results without first cre-
ating a pathways network diagram.

1. Launch Omix Premium. Double-click the Omix Premium icon  located on your desktop, or click Start > 
All Programs > Omix Premium > Omix Premium. When Omix Premium opens the 
document area is arranged to facilitate a quick means to review the software fea-
tures, open a new document, and open a recent document.

2. Create a new document. a Click New in the Document Area (Figure 109).

b Click New Omix Network.

Figure 109 Create a new document in Omix Premium

3. Import your Profinder 
results

a Click Data > Open Data Table.

b Navigate to the folder and select your PFA file (Figure 110).

Figure 110 Open Data Source dialog box

c Click Open.
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Activate Agilent 
MassVisualizer plug-in

d Click Yes in the new Open Data Source dialog box to activate Agilent MassVisu-
alizer (Figure 111). You can chose to activate the Agilent MassVisualizer plug-in 
later; however, MassVisualizer must be activated at this time in this workflow.

Note: If you do not activate the MassVisualizer plug-in you cannot add missing 
compounds in the next step. Click Extras > Document Extensions > Agilent 
MassVisualizer to manually enable MassVisualizer and continue to the next step.

Figure 111 Open Data Source dialog box

e Click Data > Show Data Manager to close the Data Manager window. The pur-
pose for opening your Profinder project is to obtain the compounds that are not 
present in the TCA cycle and lactate fermentation pathways; the Data Manager 
window is not necessary to import the missing compounds.

4. Insert the compounds from 
your Profinder results into 
the new document.

a Click Visualization > Agilent MassVisualizer > Check for missing compounds. If 
you have not previously checked for missing compounds, when you next click the 
Show Abundance Changes  button Omix Premium will automatically check 
for missing compounds.

Note: When there are compounds in the PFA file that do not match compounds in 
the open document, the Compound Availability dialog box is opened after you 
click the Show Abundance Changes  button. This gives you the opportunity to 
import metabolites that have mass spectral data to a pathway diagram that does 
not yet contain nodes for them. Otherwise the Abundance Change Visualization 
dialog box is opened.

b Review the list of metabolites in the Profinder Archive file that are not matched to 
a compound in the open document in the Compound Availability dialog box. In 
this case all of the target compounds in the PFA file are not available in the net-
work diagram (Figure 112).

Figure 112 Compound Availability dialog box

c Click Yes to add the compounds from the PFA file.
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d Click any where on the Drawing Area to visualize the compounds in Omix Pre-
mium. The compounds are added to your new document as separate, uncon-
nected nodes arranged in a vertical column (Figure 113).

Figure 113 Target metabolites added to a new Omix Premium document
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Display isotopologue 
metabolite data and 
highlight pathways

The MassVisualizer plug-in for Omix Premium provides you with the ability to visual-
ize isotopologue data from Profinder; you can view absolute and relative abun-
dances, labeling incorporation, and statistics within the context of your network 
diagram.

 MassVisualizer overview After you import your isotopologue results into Omix Premium, you can use the 
MassVisualizer toolbar and menu (Figure 114) to add new views to your network dia-
gram. MassVisualizer provides you with four classes of visualization tools: Abun-
dance Changes, Quilt Plots, Bar Charts, and Background Information with 
Visualization on Demand.

Figure 114 Views of the MassVisualizer toolbar (top) and menu (bottom) when you 
visualize your results by “all sample groups.” When you visualize your results by 
“individual sample group,” sample group control buttons are visible in the toolbar 
and the menu (Figure 141 on page 125) for you to use to view your results by each 
individual group.

 Abundance Change Visualize up to three different summary statistics within the metabolite node: (1) 
metabolite change per group versus the control group, (2) labeling incorporation per 
group, and (3) fractional labeling percent per group. This visualization mode cannot 
be used with Draw structures on the metabolites. Abundance change parameters 
are viewed in the Abundance Change Visualization dialog box (Figure 115 on 
page 104) and are represented on the metabolite node as shown in Figure 116 on 
page 104. See “Edit Color Coding and Color” on page 106 for editing the colors.
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Figure 115 Abundance Change Visualization dialog box

Figure 116 Metabolite fold change visualization

 Quilt Plots Visualize the isotopologue abundances, by individual or all sample groups, in quilt 
plots next to the metabolite nodes. Indications of statistical significance of the isoto-
pologue abundances among the groups can be enabled and adjusted by either a 
pairwise Welch’s t-test versus control, or a one-way ANOVA of each group against 
every other group. Quilt plot parameters are viewed in the Quilt Plots dialog box 
(Figure 117 on page 105). See “Edit Color Coding and Color” on page 106 for editing 
the colors.
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Figure 117 Quilt Plots dialog box

 Bar Charts Visualize various isotopologue summaries in bar charts displayed next to the metab-
olite nodes. You can view bar charts containing metabolite abundance, label incorpo-
ration, fractional labeling, and isotopologue histograms. Bar chart parameters are 
viewed in the Bar Charts dialog box (Figure 118). The parameters in the Bar Charts 
dialog box change based on the Preferences selection. See “Edit Color Coding and 
Color” on page 106 for editing the colors.

Figure 118 Bar Charts dialog box variations based on the preferences selection 
(the dialog box when Fractional labeling is selected is identical to when Metabolite 
abundance is selected)
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Edit Color Coding and Color Each of the MassVisualizer tools (Abundance Changes, Quilt Plots, and Bar Charts) 
offers you the ability to edit the colors used to display your data. Omix Premium pro-
vides you with parameters to edit sequential color coding, diverging color coding, 
and single colors.

Sequential color coding uses a value range of 0 to 1 (or 100%) to compute the cor-
responding color. Percentage values are not directly related to fold change values; 
the colors for the percentages are used to represent relative changes. For example, 
label incorporation is represented by a value between zero (no incorporation) and a 
maximum incorporation; therefore, sequential color coding uses 0% to encode zero 
label incorporation and 100% to encode the maximum amount of label incorporation.

Diverging color coding uses a value range of minimum-zero-maximum to compute 
the corresponding color. For fold change visualization, a diverging color coding is 
used because fold change can be positive (increasing change) or negative (decreas-
ing change). The color coding value of 50% encodes no fold change. 0% encodes the 
negative fold change (minimum) and 100% encodes the positive fold change (maxi-
mum).

A single color is used to color a metabolite node when the metabolite is untargeted 
or unmeasurable, as well as the color of the bars in a bar chart.

a Click the  button next to any Color coding gradient scale to launch the 
Edit Color Coding dialog box. This allows you to create a custom gradient 
(Figure 119).

b Click the  button in the Edit Color Coding dialog box, or click the 
 button in the Abundance Change Visualization and Bar Charts dialog 

boxes, to launch the Choose Color dialog box. This allows you to select your pre-
ferred color (Figure 119).

c Select your preferred color using any of the Color Triangle, Color Circle, Color 
Area, Color Palette tabs in the Choose Color dialog box.

d Click OK in the respective dialog boxes to save your color selection.

Figure 119 Edit Color Coding and Choose Color dialog boxes
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Select a control group Various statistical views in the MassVisualizer toolbar are “versus the control.” You 
can change the control group at any time in the Data Manager window.

a Click Data > Show Data Manager, or click the Data Manager  button on the 
toolbar.

b Mark the Control column for Group 1 (Figure 120). To mark, or clear a mark, in the 
data table; double-click on your selection under the Control column.

Figure 120 Select a control group in the Data Manger window

Enable visualization of 
abundance changes on your 
network diagram

Visualization of abundance changes is illustrated using the lower-right section of 
the example network diagram, where the 2-hydroxyglutarate formation and gluta-
mate biosynthesis/degradation pathways join the TCA cycle pathway.

Zoom the Drawing Area so you can see the section of the network diagram similar 
to Figure 121.

Figure 121 Zoom of the Drawing Area before adding abundance change visualiza-
tion
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Metabolite change When you view metabolite change, the metabolite abundance change can be 
viewed as a percent change or log2 scaled, referred to as a fold change. When you 
clear Auto-scale color range to largest change custom values can be entered for 
the lower and upper bounds of the metabolite abundance change.

a Click the Show Abundance Changes  button from the toolbar, or click Visual-
ization > Agilent MassVisualizer > Show Abundance Changes.

b Mark Show metabolite change (vs. control) in the Abundance Change Visual-
ization dialog box (Figure 115 on page 104).

c Click Individual sample group.

When your results are visualized by individual sample group, control buttons are 
visible in the toolbar and the menu (Figure 141 on page 125) for you to view your 
results by stepping through each individual group. The color of the target metabo-
lite nodes change to reflect the maximum percent or fold change of the metabo-
lite abundance for the current group (selected using the slider in the 
MassVisualizer toolbar) relative to the control group: the color gradient varies 
from up, increasing abundance (red), to down, decreasing abundance (blue).

d Click All sample groups.

When your results are visualized by all sample groups, the control buttons are 
not displayed, and the toolbar and the menu appear as shown in Figure 114 on 
page 103. The color of the target metabolite nodes change to reflect the maxi-
mum percent, or fold change, across all of the groups in your experiment relative 
to the control group: the color gradient varies from up, increasing abundance 
(red), to down, decreasing abundance (blue) (Figure 122).

e Click OK.

Figure 122 Zoom Drawing Area with all sample groups abundance change visual-
ization
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Labeling incorporation change When you view labeling incorporation you can select automatic scaling of the range 
(0 to the maximum value) or you can specify an upper bound of the incorporation. 
When you clear Auto-scale color range to largest incorporation you can enter a 
custom value for the upper bound of the labeling incorporation.

a Click the Show Abundance Changes  button from the toolbar, or click Visual-
ization > Agilent MassVisualizer > Show Abundance Changes.

b Mark Show labeling incorporation (ratio of labeled/unlabeled isotopologue 
abundances) in the Abundance Change Visualization dialog box (Figure 115 on 
page 104).

c Click Individual sample group.

When your results are visualized by individual sample group, control buttons are 
visible in the toolbar and the menu (Figure 141 on page 125) for you to view your 
results by stepping through each individual group. The color of the target metabo-
lite nodes change to reflect the largest change in label incorporation for the cur-
rent group (selected using the slider in the MassVisualizer toolbar): the color 
gradient varies from low label incorporation (white) to high label incorporation 
(green). 

d Click All sample groups.

When you visualize your results by all sample groups, the control buttons are not 
displayed, and the toolbar and the menu appear as shown in Figure 114 on 
page 103. The color of the target metabolite nodes change to reflect the largest 
change in label incorporation across all of the groups in your experiment: the 
color gradient varies from low label incorporation (white) to high label incorpora-
tion (green), see Figure 123.

e Click OK.

Figure 123 Zoom Drawing Area with two abundance change visualizations
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Fractional labeling % a Click the Show Abundance Changes  button from the toolbar, or click Visual-
ization > Agilent MassVisualizer > Show Abundance Changes.

b Mark Show fractional labeling % in the Abundance Change Visualization dialog 
box (Figure 115 on page 104).

c Click Individual sample group.

When your results are visualized by individual sample group, control buttons are 
visible in the toolbar and the menu (Figure 141 on page 125) for you to view your 
results by stepping through each individual group. The color of the target metabo-
lite nodes change to reflect the largest change in fractional labeling for the cur-
rent group (selected using the slider in the MassVisualizer toolbar) relative to the 
control group: the color gradient varies from low fractional labeling (white) Click 
All sample groups.

When your results are visualized by all sample groups, the control buttons are 
not displayed, and the toolbar and the menu appear as shown in Figure 114 on 
page 103. The color of the target metabolite nodes change to reflect the largest 
change in fractional labeling across all of the groups in your experiment relative 
to the control group: the color gradient varies from low fractional labeling (white) 
to high fractional labeling (violet), see Figure 124.

d Click OK.

Figure 124 Zoom Drawing Area with three abundance change visualizations
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Enable visualization of quilt 
plots on your network 
diagram

Visualization of quilt plots is illustrated using the lower-right section of the example 
network diagram, where the 2-hydroxyglutarate and glutamate biosynthesis/degra-
dation pathways join the TCA cycle.

Zoom the Drawing Area so you can see the section of the network diagram similar 
to Figure 121 on page 107.

Quilt plots a Click the Show Quilt Plots  button from the toolbar, or click Visualization > 
Agilent MassVisualizer > Show Quilt Plots.

b Mark Show quilt plots of isotopologue abundances in the Quilt Plots dialog box 
(Figure 117 on page 105).

c Click Individual sample group.

When your results are visualized by individual sample group, control buttons are 
visible in the toolbar and the menu (Figure 141 on page 125) for you to view your 
results by stepping through each individual group. Quilt plots are shown next to 
the metabolite node. The color of the columns in the single isotopologue data row 
change to reflect the maximum isotopologue abundance for the current group 
(selected using the slider in the MassVisualizer toolbar): the color gradient varies 
from low isotopologue abundance (white) to high isotopologue abundance (red). 

d Click All sample groups.

When your results are visualized by all sample groups, the control buttons are 
not displayed, and the toolbar and the menu appear as shown in Figure 114 on 
page 103. Quilt plots are shown next to the metabolite node and there is a row of 
data for each group. The color of the columns in the isotopologue data rows 
change to reflect the maximum isotopologue abundance for each group: the color 
gradient varies from low isotopologue abundance (white) to high isotopologue 
abundance (red), see Figure 123 on page 109.

Statistical visualization e Mark Pairwise Welch’s t-test (vs. Control).

The Welch’s t-test is a version of the Student’s t-test. Unlike the Student’s t-test 
that assumes a normal distribution, the Welch’s t-test does not, and is more reli-
able when the test is performed on sample groups with unequal sample sizes and 
variance. Welch’s t-test results are indicated symbolically, the symbols are 
defined by a threshold p-value and a symbol, within the quilt chart. The Welch's t-
test is applied in a pairwise manner, where each experimental group is tested 
against the control group (specified in the Data Manager - see Figure 120 on 
page 107).

p-value A p-value of 0.05 is similar to stating that, if the mean values for each group are 
identical, then a 5% chance or less exists of observing a difference in the mean of 
the group values as large as you observed. In other words, statistical treatment of 
random sampling from identical populations with a p-value set at 0.05 leads to a 
difference smaller than you observed in 95% of the experiments, and larger than 
you observed in 5% of the experiments. Another way to express a p-value of 0.05 
is that there is a 5% chance or less of the observed difference being due to mere 
random chance. 
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Note: At times a really large change may have low significance (small p-value). 
This can occur when there are small absolute differences in the abundances of 
the isotopomers (see the quilt plot for 2-oxoglutarate with two thresholds).

f Mark ANOVA.

Analysis of variance (in the case of Omix Premium, a one-way ANOVA) compares 
the means and variance of each group versus all other groups in a "round-robin" 
fashion. This test is similar to a Student's t-test. A one-way ANOVA produces an 
F statistic, which in turn is expressed as a p-value from the F distribution. The 
results are shown symbolically below the quilt plots.

Note: Multiple testing correction is not applied to ANOVA results in Omix Pre-
mium. This may increase the false positive error rate slightly, depending on the 
experimental design.

g Mark the second threshold so that the quilt plots can show up to two thresholds 
of statistical significance for each test.

h Click OK.

Figure 125 Zoom Drawing Area with three abundance changes and quilt plots visu-
alization
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Enable visualization of bar 
charts on your network 
diagram

Visualization of bar charts is illustrated using the lower-right section of the example 
network diagram, where the 2-hydroxyglutarate and glutamate biosynthesis/degra-
dation pathways join the TCA cycle. The bar charts visualization options are similar 
to the Isotopologue Results in MassHunter Profinder, with the difference being that 
in Omix Premium you can view the results for all of the metabolites at the same 
time, and in the context of your biochemical network.

Zoom the Drawing Area so you can see the section of the network diagram similar 
to Figure 121 on page 107.

Bar charts, label incorporation a Click the Show Bar Charts  button from the toolbar, or click Visualization > 
Agilent MassVisualizer > Show Bar Charts.

b Mark Show bar charts in the Bar Charts dialog box.

c Click label incorporation under the Preferences group heading. The parameters 
in the Bar Charts dialog box change based on the Preferences selection as illus-
trated in Figure 118 on page 105.

d Click Individual sample group in the Bar Charts dialog box.

When your results are visualized by individual sample group, control buttons are 
visible in the toolbar and the menu (Figure 141 on page 125) for you to view your 
results by stepping through each individual group. Bar charts are shown next to 
the metabolite node. The color of the bars on the chart in the individual sample 
group reflect the labeled and unlabeled isotopologue abundance or percentage 
for the current group (selected using the slider in the MassVisualizer toolbar): the 
color for the unlabeled isotopologue is blue and the labeled isotopologue is red. 

e Click All sample groups in the Bar Charts dialog box.

When your results are visualized by all sample groups, the control buttons are 
not displayed, and the toolbar and the menu appear as shown in Figure 114 on 
page 103. Bar charts are shown next to the metabolite node. The color of bars on 
the chart rows for the all sample groups reflect the labeled and unlabeled isoto-
pologue abundance or percentage for each group: the color for the unlabeled iso-
topologue is blue and the labeled isotopologue is red, see Figure 126 on page 114.

f Click OK.
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Figure 126 Zoom Drawing Area with three abundance changes and bar charts visu-
alization with label incorporation

Bar charts, isotopologue 
histograms

a Click the Show Bar Charts  button from the toolbar, or click Visualization > 
Agilent MassVisualizer > Show Bar Charts.

b Click isotopologue histograms under the Preferences group heading. The param-
eters in the Bar Charts dialog box change based on the Preferences selection as 
illustrated in Figure 118 on page 105.

c Click Individual sample group in the Bar Charts dialog box.

When your results are visualized by individual sample group, control buttons are 
visible in the toolbar and the menu (Figure 141 on page 125) for you to view your 
results by stepping through each individual group. Bar charts are shown next to 
the metabolite node. The bars on the chart in the individual sample group reflect 
the isotopologue abundance or percentage for the current group (selected using 
the slider in the MassVisualizer toolbar). 

d Click All sample groups in the Bar Charts dialog box.

When your results are visualized by all sample groups, the control buttons are 
not displayed, and the toolbar and the menu appear as shown in Figure 114 on 
page 103. Bar charts are shown next to the metabolite node. The color of the bars 
on the chart rows for the all sample groups reflect the isotopologue abundance or 
percentage for each group, see Figure 127 on page 115.

e Click OK.
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Figure 127 Zoom Drawing Area with three abundance changes and bar charts visu-
alization with isotopologue histograms

Visualize chemical 
structures your network 
diagram

Metabolites created from curated databases include structural information. You can 
display the chemical structures of the metabolites next to the metabolite nodes or 
replace the metabolite nodes with the structures.

Note: You must have the Chemical Structures plug-in enabled to visualize chemical 
structures. When pathways are loading from BioCyc you must mark import chemi-
cal structures in the Select Pathway dialog box, or when you click Options in the 
Load from BioCyc dialog box when you are creating a new document from BioCyc.

Zoom the Drawing Area so you can see the section of the network diagram similar 
to Figure 121 on page 107.

a Click the Visualize chemical structures  button > Draw structures next to 
metabolites from the toolbar, or click Visualization > Visualize chemical struc-
tures > Draw structures next to metabolites.

b Review and adjust the positions of the elements of your network diagram in the 
Drawing Area (Figure 128 on page 116).
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Figure 128 Zoom Drawing Area with three abundance changes and chemical struc-
tures visualization

Node anchor When charts and chemical structures are added to your network diagram, these 
accessories are positioned relative to the small anchor that is shown next to each 
node. The anchor (Figure 129) is movable, and you can be place the anchor any-
where relative to the node (top, bottom left, and right). 

Figure 129 Anchor used to position accessories in your network diagram

The anchor has a layout property for aligning the accessories as shown in Figure 130 
on page 117. The accessories can be aligned freehand, horizontally, vertically, or 
according to the diagram standard. Freehand is shown in the Property Editor win-
dow, when the accessories are placed manually (relative to the anchor).

You can also edit many other parameters associated with your metabolite, and other 
features of your network diagram, using the Property Editor window.
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Figure 130 Layout properties for the Anchor

View all of your Profinder 
results using Visualization 
on Demand

Visualization on Demand allows you view all of the background information on your 
target metabolites.

a Click the Show Background Information  button from the toolbar, or click 
Visualization > Agilent MassVisualizer > Show Background Information. This 
loads your Profinder results into an active state in your Omix Premium session.

Figure 131 Load Background Information dialog box
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The Load Background Information dialog box shows you the steps to enable 
visualization on demand.

b Click the Network View Mode  button from the toolbar.

c Click the Visualize Properties on Demand  button from the toolbar, or click 
View > Visualize Properties on Demand.

d Move your mouse slowly over a metabolite and then click on branches of the 
information tree to lock the information in view on your Drawing Area. Click a 
branch again to unlock (hide) the information (

Figure 132 Sample visualization on demand for L-glutamate
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Generate static images 
of your pathways 
network

When you have created your network diagram, imported your isotopologue results 
from Profinder, and developed an understanding of your experiment in the context of 
the biological network, you can generate static images of your qualitative flux analy-
sis. With Omix Premium you can arrange, scale, highlight, and enable/disable nearly 
every feature of the network diagram and results visualization. Omix Premium pro-
vides you with powerful tools to help you present your qualitative flux analysis in 
reports, publications, and presentations.

Click the Network View Mode  button from the toolbar to disable editing mode 
and enable pan, zoom, and many other view controls of your network diagram.

Show only the pathway 
metabolites

a Click the Hide Cofactors  button from the toolbar to hide the cofactors to the 
reaction nodes.

Note: If you are in editing mode, the cofactors in the Drawing Area remain visible 
but take on a lighter shade (ghosted) to indicate they do not appear in the view 
mode and during print, export, and image save operations.

b Click the Hide Reactions  button from the toolbar to hide the reaction nodes. 
The diamond shapes are removed from the pathways. 

c Click the Appearance of Reaction Labels  button > Hidden from the toolbar 
to hide the text description of the reaction nodes. The reaction node descriptions 
are removed from the pathways (Figure 133). 

d Click File > Save Image to save a sample image of the network diagram. The 
saved image is identical to the Drawing Area in view mode.

Figure 133 View of the network diagram in view mode
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Show chemical structures 
on metabolite nodes

The chemical structures tend to be initially drawn small with respect to the network 
diagram. This example makes the chemical structures more prominent.

a Click the Visualize chemical structures  button > Draw structure on metab-
olites from the toolbar to replace the metabolite rectangles with the chemical 
structures.

b Click the Select  button from the toolbar to enter the editing mode 

c Zoom the Drawing Area to view a chemical structure of (S)-lactate in detail.

d Click on a chemical structure to enable the control nodes.

e Drag a corner control node on the chemical structure to make the chemical struc-
ture larger (Figure 134).

Figure 134 Change the size of a chemical structure on the network diagram, note 
that the cofactors are lighter indicating they do not appear in the view mode

f Click the Network View Mode  button from the toolbar to disable editing 
mode (Figure 135).

Figure 135 Resized chemical structure
120 



Visualize on pathways Generate static images of your pathways network
Emphasize the target 
metabolites

a Click the Visualize chemical structures  button > Draw structure on metab-
olites from the toolbar to remove the chemical structures and return the names of 
the metabolites to the nodes.

b Click the Select  button from the toolbar to enter the editing mode 

c Click the Show Property Editor  button from the toolbar.

Change a metabolite font d Click the (S)-lactate metabolite.

e Click the cell for the Font value under Common Style, Text in the Property Editor 
window to edit properties of the font for this metabolite (Figure 136).

f Select 72 for Size in the Select Font dialog box.

g Click OK.

Figure 136 Edit the font properties of a metabolite in the property editor

Hide a metabolite label h Click the acetyl-CoA metabolite.

i Click the cell for the Placement value under Label, Base in the Property Editor 
window to change the value of the label for this metabolite (Figure 137 on 
page 122).

j Click Hidden.
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Figure 137 Edit the font properties of a metabolite in the property editor

k Repeat “Change a metabolite font” and “Hide a metabolite label” to increase the 
font size for the target metabolites and hide the labels of the non-target metabo-
lites. You can perform the font adjustments on more than one metabolite at a 
time.

l Click the Hide Metabolites  button from the toolbar to hide non-target metab-
olite nodes.

m Click the Hide Reactions  button from the toolbar to hide reactions nodes.

n Click the Hide Cofactors  button from the toolbar to hide cofactors.

o Click the Hide Effector edges  button from the toolbar to hide effector edges.

p Click the Hide Flux edges  button from the toolbar to hide the flux edges.

q Click the Network View Mode  button from the toolbar to disable editing 
mode and view your network (Figure 138 on page 123).
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Figure 138 Network diagram after adjusting the metabolite labels

r Click the Visualize chemical structures  button > Draw structure next to 
metabolites to add chemical structures.

s Click the Select  button from the toolbar to enter the editing mode 

t Resize the chemical structures of the target metabolites.

u Click the Network View Mode  button from the toolbar to disable editing 
mode and view your network diagram (Figure 139).
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Figure 139 Network diagram after adjusting the metabolite labels and adding 
chemical structures

Add plots and charts to your 
network diagram

With the network diagram cleaned up to the essential elements from your flux anal-
ysis, you can add quilt plots and/or bar charts to your network diagram.

Figure 140 Network diagram with charts
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Step through time points 
and network activity

In “Display isotopologue metabolite data and highlight pathways” on page 103 each 
of the fold change, quilt plot, and bar chart results can be displayed with a visualiza-
tion preference of Individual sample group in the respective dialog boxes. When 
Individual sample group is selected, the fold change, quilt plot, and bar chart data is 
presented for the current group as selected using the slider in the MassVisualizer 
toolbar. 

Click any of the control buttons available on the MassVisualizer toolbar or Visualiza-
tion menu to step through the time points (sample groups). Figure 141 shows the 
control buttons available with MassVisualizer; Stop, Back, Play, Next, Slider, and 
Record.

Figure 141 MassVisualizer toolbar (top) and menu (bottom) when you visualize 
your results by “individual sample group.” You use the control buttons to step 
through the time points (sample groups). When you visualize your results by “all 
sample groups,” the sample group control buttons are not displayed, and the toolbar 
and the menu appear as shown in Figure 114 on page 103.
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Save your Omix 
Premium project

At any time during your session with Omix Premium, you can save your pathways 
network diagram as an Omix Premium (OMX) document. Saving your session with a 
descriptive name and a sequential number for the file name saves you time if you 
want to return to prior network diagrams after you have adjusted and customized 
various elements.

Note: When your Omix Premium document has unsaved changes an asterisk 
appears at the end of the file name in the title bar (Figure 142).

Figure 142 Unsaved changes in your document are indicated by an asterisk in the 
title bar. This example uses a descriptive name and a sequential number for the file 
name.

a Click File > Save or click the Save the network document to file  button on 
the toolbar. 

b Navigate to the folder to save your Omix Premium network in the Save Omix Net-
work Model dialog box.

c Enter a descriptive name and a sequential number for the File name (Figure 143).

d Click Save.

Figure 143 Save Omix Network Model dialog box

Next step... You have now completed the fourth step of the VistaFlux Software workflow. In the 
next workflow step you export your results.
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Export tables, charts 
and images

When you have created your network diagram, imported your isotopologue results 
from Profinder, developed an understanding of your experiment in the context of the 
biological network, and generated static images, you can export your network dia-
gram for presentations and publications.

Your options to export images of your qualitative flux analysis include:
• Print to system printers, see “Print to system printer using clippings”
• Export to biochemical formats, see “Export to biochemical formats” on 

page 130
• Save to graphics file formats, see “Save to graphics file formats” on page 130
• Copy PFA data file tables from Data Manager to other programs, such as pre-

sentation and spreadsheet software.

Print to system printer 
using clippings

a Click the Network View Mode  button from the toolbar to disable editing 
mode and view your network diagram.

b Click File > Edit Diagram Clippings to enter the Diagram Clipping Editor mode.

c Click the Insert Diagram Clipping  button from the toolbar.

d Drag the clipping selection frame to encompass the area you want to assign to a 
clipping.

e Type in a name for the clipping region you have defined in the New Diagram Clip-
ping dialog box (Figure 144).

Figure 144 Diagram Clipping Editor

f Click OK.

g Click Close Diagram Clipping Editor.
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h Click File > Print, or type Ctrl-P, to print your network diagram to any system 
printer installed on your personal computer.

i Select the system printer to use in the Print dialog box.

j Click Print. This action does not start a printing; the next dialog box allows you to 
set your clipping, print options, and generate a preview.

k Select your clipping, or <Print All>, in the Print Metabolic Network dialog box.

l Select Fit to Page Width and other parameters to use in the Print Metabolic Net-
work dialog box (Figure 145).

Figure 145 Print Metabolic Network dialog box

m Click Preview to review the output before sending it to your system printer 
(Figure 146). The clipping is fit to the page, and if there is room on the page addi-
tional elements from your network diagram are also added to the clipping.

Figure 146 Preview view of your network diagram

n Click Close to return to the Print Metabolic Network dialog box.

o Click OK to print your network diagram (Figure 145).
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Export to biochemical 
formats

a Click File > Export > Export Network File, or type Ctrl-E, to export your network 
diagram to standard flux, systems biology, and stoichiometry file formats.

b Navigate to the folder to save your network model in the Export Omix Network 
Model dialog box.

c Type the File name.

d Select the file type to export your file (Figure 147).

Figure 147 File types in the Export Omix Network Model dialog box

e Click Save to export your network diagram.

Save to graphics file 
formats

a Click File > Save Image to save your entire network diagram, not just the current 
view in the Drawing Area, to a graphics or presentation file format.

b Navigate to the folder to save your network diagram in the Export Omix Network 
Diagram dialog box.

c Type the File name.

d Select the file type to export your file (Figure 148).

Figure 148 File types in the Print Metabolic Diagram dialog box

e Click Save to export your network diagram image.
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Copy tables a Click the top left header cell of any table in the Data Manager window to select 
the table.

b Click the Copy icon in the top of the Data Manager window (Figure 149).

Figure 149 Copy a table in the Data Manager window

c Paste the table into a spreadsheet or other office software product.

p
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Conclusion You have now completed the VistaFlux Software workflow.
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Reference information Definitions
Definitions This section contains a list of terms and their definitions as used in this workflow. 
Review of the terms and definitions presented in this section helps you understand 
the software wizards and the class prediction workflow.

Abundance profile Relative or absolute signal intensities of the extracted compounds identified in your 
sample derived from the chromatographic/mass spectral data.

Algorithm Mathematical calculations and related parameters that are applied to sample data to 
produce a result that may be used to represent or classify a sample.

Alignment Adjustment of the chromatographic retention time of eluting components to improve 
the correlation among data sets, based on the elution of specific component(s) that 
are (1) naturally present in each sample or (2) deliberately added to the sample 
through spiking the sample with a known compound or set of compounds that does 
not interfere with the sample.

ANOVA Abbreviation for analysis of variance which is a statistical method that simultane-
ously compares the means between two or more attributes, parameters, or groups 
of a sample data set. ANOVA is used to determine if a statistical difference exists 
between the means of two or more data sets (groups) and thereby prove or disprove 
the hypothesis. See also Student’s t-test and Welch’s t-test.

Bar chart A two-dimensional representation of data that uses rectangles that originate from 
one axis, an axis that represents a non-numerical value, to represent a numerical 
value defined by the second axis.

Baselining A technique used to view and compare data, that involves converting the original 
data values to values that are expressed as changes relative to a calculated statisti-
cal value, derived from the data. The calculated statistical value is referred to as the 
baseline.

Bioinformatics The use of computers, statistics, and informational techniques to increase the 
understanding of biological processes. 

Biomarker An organic molecule whose presence and concentration in a biological sample indi-
cates a normal or altered function of higher level biological activity.

Carbohydrate An organic molecule consisting entirely of carbon, hydrogen, and oxygen that is 
important to living organisms.

CEF file A file format called a compound exchange file (CEF) that is used to exchange data 
between Agilent software. CEF files are used to share molecular features between 
MassHunter software.
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Cell The fundamental unit of an organism consisting of several sets of biochemical func-
tions within an enclosing membrane. Animals and plants are made of one or more 
cells that combine to form tissues and perform living functions.

Class A grouping of samples organized for a study based on having a similar or identical 
likeness such as origin, condition (age, disease, treatment, extraction procedure), or 
another trait that is relevant to an experiment.

Co-elution When ion signals elute from a chromatographic column at nominally the same time. 
This can be due to the ion signals belonging to adducts of the same compound, 
alternative charge states of the same compound, or two or more compounds sharing 
similar chemical properties, causing them to be unresolvable by the chosen chroma-
tography.

Complex Class of compounds consisting of two or more proteins that physically bind each 
other. Their combined form is biologically active and stable.

Composite spectrum A compound spectrum generated to represent the molecular feature that includes 
more than one ion, isotope, or adduct (not just M + H) and is used by Mass Profiler 
Professional for recursive analysis and ID Browser.

Compound A metabolite that may be individually referred to as a compound, descriptor, ele-
ment, entity, feature, or metabolite during the various steps presented during various 
workflows.

Compound group A single compound that is targeted, or found, in any of the sample data files in a 
project. For example, if 20 compounds are found in the first data file in the project, 
then there are at least 20 compound groups in the project. If additional unique com-
pounds are found in the remaining data files for your project, then additional com-
pound groups are created.

Control During analyses of your sample data, replicate samples are averaged together in 
groups representing the independent variable in your experiment. When one group 
is used as a reference against which statistical variation of the other groups is com-
pared, the one group is referred to as a control.

Data Information that represents, in a form suitable for storing and processing by a com-
puter, the qualitative or quantitative attributes of a subject. Examples include LC/MS 
data consisting fundamentally of time, ion m/z, and ion abundance from a chemical 
sample.

Data processing Conversion of data into meaningful information. Computers are employed to enable 
rapid recording and handling of large amounts of data, i.e., MassHunter Workstation 
and Mass Profiler Professional.
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Data reduction See reduction.

Deconvolution An algorithmic feature extraction of compound ion signals by coelution and in some 
cases, grouping of isotope clusters by m/z, charge state, and adduct/deduct ion 
species.

Dependent variable An element in a data set that can only be observed as a result of the influence from 
the variation of an independent variable. For example, a pharmaceutical compound 
structure and quantity may be controlled as two independent variables while the 
metabolite profile presents a host of small-molecule products that make up the 
dependent variables of a study.

Document A network diagram created in Omix Premium. Also referred to as a network model.

Edge A visual representation of the connection between a reaction and a metabolite when 
creating a network diagram.

Effector A small molecule that regulates biological activity in a pathway.

Element A metabolite that may be individually referred to as a compound, molecular feature, 
element, or entity during the various steps of data analysis. An element can also 
refer to one of many pieces of graphical information used to create a network dia-
gram.

Environment The natural and/or controlled conditions that surround an organism as it lives and 
operates.

Enzyme Proteins acting as biocatalysts in a metabolomic reaction. These entities are particu-
larly important in depicting a biochemical network.

Experiment Data acquired in an attempt to understand causality where tests or analyses are 
defined and performed on an organism to discover something that is not yet known, 
to demonstrate as proof of something that is known, or to find out whether some-
thing is effective.

Extraction The process of retrieving a deliberate subset of data from a larger data set whereby 
the subset of the data preserves the meaningful information, not the redundant and 
less meaningful information. Also known as data extraction or feature extraction.

F statistic A value used with a one-way ANOVA test to determine if the difference between the 
mean values of two sample groups are significant.

Feature Independent, distinct characteristic of a phenomena and data under observation. 
Features are an important part of the identification of patterns - pattern recognition - 
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within data whether processed by a human or by artificial intelligence, such as 
MassHunter Profinder. During the various workflows a feature may be individually 
referred to as a compound, descriptor, element, entity, or metabolite.

Feature extraction The extraction of compound signals from complex, multidimensional data and its 
background noise. This results in a reduction of data size and complexity through 
the removal of redundant and non-specific data. Careful feature extraction yields a 
smaller data set that is more easily processed without any compromise in the infor-
mation quality.

Feature selection The identification of important, or non-important, variables and the variable relation-
ships in a data set using both analytical and a priori knowledge about the data.

Filter The process of establishing criteria by which entities are removed (filtered) from fur-
ther analysis during data analysis.

Flux A representation of the magnitude and direction of chemical flow through a path-
way.

Filter by flag A flag is a term used to denote a quality of an entity within a sample. A flag indi-
cates if the entity was detected in each sample as follows: Present means the entity 
was detected, Absent means the entity was not detected, and Marginal means the 
signal for the entity was saturated.

Fold change A measure of the amount of change expressed in the ratio of the amount of change 
from the original value versus the original value. A fold change can be positive 
(increasing) or negative (decreasing)

Hypothesis A proposition made to explain certain facts and tentatively accepted to provide a 
basis for further investigation. A proposed explanation for observable phenomena 
may or may not be supported by the analytical data. Statistical data analysis is per-
formed to quantify the probability that the hypothesis is true. Also known as the sci-
entific hypothesis.

Hypothetical A statement based on, involving, or having the nature of a hypothesis for the pur-
poses of serving as an example and not necessarily based on an actuality.

Identified compound Chromatographic components that have an assigned, exact identity, such as com-
pound name and molecular formula, based on prior assessment or comparison with 
a database. See also Unidentified Compound.

Independent variable An essential element, constituent, attribute, or quality in a data set that is deliber-
ately controlled in an experiment. An independent variable may be referred to as a 
parameter and is assigned a parameter name during the various steps of data analy-
sis.
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Isotope An element that has a different number of neutrons from another element with the 
same number of protons. Examples include 12C versus 13C,14N versus 15N, and1H 
versus 2H, each of these elements represent different isotopes of carbon, nitrogen, 
and hydrogen, respectively.

Isotopologue Molecules that contain the same molecular formula and structure but differ in their 
isotopic composition through the substitution of one or more atoms with a different 
isotope. The exact location of the isotope in the molecule, while important chemi-
cally, is not important in flux analysis, just the number of isotopes in the molecule.

Isotopomer Molecules that contain the same molecular formula, structure, and number of iso-
topes but differ in the specific atomic location of the isotopes in the molecular struc-
ture.

Label The isotope that is used to enrich a compound used for flux analyses.

Labeling When an isotope of an atom is substituted for the naturally occurring atom, the 
resulting compound is referred to as being labeled. Metabolites in a cell can become 
labeled when a isotopically enriched compound is introduced to the cellular metabo-
lism. An experiment that studies the rate that metabolites become labeled through 
metabolism are referred to as metabolic flux analysis or qualitative flux analysis.

Lipidomics Identification and quantification of cellular lipids from an organism in a specified bio-
logical situation. The study of lipids is a subset of metabolomics.

Mass variation Using the mass to charge (m/z) resolution to improve compound identification. 
Compounds with nearly identical and identical chromatographic behavior are decon-
voluted by adjusting the m/z range for extracting ion chromatograms.

Mean The numerical result of dividing the sum of the data values by the number of individ-
ual data observations.

Metabolism The chemical reactions and physical processes whereby living organisms convert 
ingested compounds into other compounds, structures, energy and waste.

Metabolite Small organic molecules that are intermediate compounds and products produced 
as part of metabolism. Metabolites are important modulators, substrates, byprod-
ucts, and building blocks of many different biological processes. A metabolite may 
be individually referred to as a compound, molecular feature, element, or entity 
during the various steps of data analysis.

Metabolome The complete set of small-molecule metabolites that may be found within a biologi-
cal sample. Small molecules are typically in the range of 50 to 600 Da.
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Metabolomics The process of identification and quantification of all metabolites of an organism in 
a specified biological situation. See Metabonomics for the study of the change in the 
metabolites in response to externalities.

Metabonomics The metabolic response to externalities such as drugs, environmental factors, and 
disease. See Metabolomics for the identification and quantitation of metabolites.

Model Another name to refer to a network diagram.

Network A set of metabolite and reaction nodes that can be assembled with additional infor-
mation to represent the operation biochemical system.

Network diagram A graphical visualization of metabolite and reaction nodes, effectors, and flux edges 
that together represent the operation biochemical system.

Node A representation of a metabolite or reaction when you create a network diagram.

Normalization A technique used to adjust the ion intensity of mass spectral data from an absolute 
value based on the signal measured at the detector to a relative intensity of 0 to 100 
percent based on the signal of either (1) the ion of the greatest intensity or (2) a spe-
cific ion in the mass spectrum.

Null hypothesis The default position taken by the hypothesis that no effect or correlation of the inde-
pendent variables exists with respect to the measurements taken from the samples. 
An example null hypothesis: “No effect or correlation exits between a change in the 
independent variables (e.g., treatment) and a change in the dependent variables 
(e.g., metabolic profile).”

Observation Data acquired in an attempt to understand causality where no ability exists to (1) 
control how subjects are sampled and/or (2) control the exposure each sample 
group receives.

Organism A group of biochemical systems that function together as a whole thereby creating 
an individual living entity, such as an animal, plant, or microorganism. Individual liv-
ing entities may be multicellular or unicellular. See also specimen.

Pathway A sequence of reactions and metabolites that represent the chemical reactions that 
occur in a cell.

p-value The probability of obtaining a statistical result that is comparable to or greater in 
magnitude than the result that was actually observed, assuming that the null 
hypothesis is true. The null hypothesis is stated that no correlation exists between 
the independent variables and the measurements taken from the samples. Rejection 
of the null hypothesis is typically made when the p-value is less than 0.05 or 0.01. A 
139 



Reference information Definitions
p-value of 0.05 or 0.01 may be restated as a 5% or 1% chance of rejecting the null 
hypothesis when it is true. When the null hypothesis is rejected, the result is said to 
be statistically significant meaning that a correlation exists between the indepen-
dent variables and the measurements as specified in the hypothesis.

Peptide Linear chain of amino acids that is shorter than a protein. The length of a peptide is 
sufficiently short that it is easily made synthetically from the constituent amino 
acids.

Peptide bond The covalent bond formed by the reaction of a carboxyl group with an amine group 
between two molecules, e.g., between amino acids.

PFA file A file format called a Profinder Archive (CEF) that is used to exchange data between 
Profinder and Omix premium.

Quilt plot A graphical representation of data using a two-dimensional grid and where each grid 
employs a color used to indicate magnitude instead of numerical text.

Proteomics The study of the structure and function of proteins occurring in living organisms.

Recursive Reapplying the same algorithm to a subset of a previous result in order to generate 
an improved result.

Recursive feature finding A multi-step process that improves the accuracy of finding statistically significant 
features in sample data files. This is employed by MassHunter Profinder.

Reduction The process whereby the number of variables in a data set is decreased to improve 
computation time and information quality, such as an extracted ion chromatogram 
obtained from LC/MS data files. Reduction provides smaller, viewable and interpre-
table data sets by employing feature selection and feature extraction. Also known as 
dimension reduction and data reduction. This is part of most of the advanced pro-
cesses employed by Mass Profiler Professional.

Regression analysis Mathematical techniques for analyzing data to identify the relationship between 
dependent and independent variables present in the data. Information is gained from 
the estimation, regression, or the sign and proportionality of the effects of the inde-
pendent variables on the dependent variables. 

Replicate Multiple identical samples collected from a population so that the sample evaluation 
results in a value that more closely approximates the true value.

Sample A part, piece, or item that is taken from a specimen and understood as being repre-
sentative of the larger specimen (e.g., blood sample, cell culture, body fluid, aliquot) 
or population. An analysis may be derived from samples taken at a particular geo-
graphical location, taken at a specific period of time during an experiment, or taken 
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before or after a specific treatment. A small number of specimens used to represent 
a whole class or group.

Sample group An experimental condition, such as the time a sample was acquired after an experi-
ment was started, assigned to replicate samples. Larger number of samples in a 
sample group improve the statistical significance of your qualitative flux analysis.

Sampling The process of taking samples that have a statistical representation of the popula-
tion under evaluation.

Spline curve A smooth curve representation to connect nodes in a network diagram. The degree 
of curve applied to a spline is controlled by spline points.

Spline point The degree of curve applied to a spline curve is controlled by moving points that are 
referred to as spline points.

Standard A chemical or mixture of chemicals used to compare the quality of analytical results 
or to measure and compensate the precise offset or drift incurred over a set of anal-
yses.

Statistics The mathematical process employed in manipulating numerical data from scientific 
experiments to derive meaningful information. This is part of the principal compo-
nent analysis, t-test, and ANOVA processes employed by Mass Profiler Professional.

Student’s t-Test A statistical test to determine whether the mean of the data differs significantly 
from that expected if the samples followed a normal distribution in the population. 
The test may also be used to assess statistical significance between the means of 
two normally distributed data sets (groups). See also ANOVA.

Subject A chemical or biological sample taken from a specimen, or a whole specimen, that 
undergoes a treatment, experiment, or an analysis for the purposes of further under-
standing.

Tracer A stable isotope labeled compound, referred to as a tracer, is introduced into the bio-
logical system for flux analysis. The tracer typically contains multiple atoms of 13C, 
15N, or 2H.

Unidentified compound Chromatographic components that are only uniquely denoted by their mass and 
retention times and which have not been assigned an exact identity, such as com-
pound name and molecular formula. Unidentified compounds are typically produced 
by feature finding and deconvolution algorithms. See also Identified Compound.
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Variable An element in a data set that assumes changing values, e.g., values that are not 
constant over the entire data set. The two types of variables are independent and 
dependent.

Volume The area of the extracted compound chromatogram (ECC). The ECC is formed from 
the sum of the individual ion abundances within the compound spectrum at each 
retention time in the specified time window. The compound volume generated by 
MFE is used by Mass Profiler Professional to make quantitative comparisons.

Welch’s t-test A version of the Student’s t-test. Unlike the Student’s t-test that assumes a normal 
distribution, the Welch’s t-test does not assume normal variance and is more reli-
able when the test is performed on sample groups with unequal sample sizes and 
unequal variance. See also Student’s t-test.

Wizard A sequence of dialog boxes presented by Mass Profiler Professional that guides you 
through well-defined steps to enter information, organize data, and perform analy-
ses.
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References This section consists of citations to Agilent manuals, primers, application notes, pre-
sentations, product brochures, technical overviews, videos, and software that help 
you use Agilent products and perform your qualitative flux analyses.

Manuals Check www.agilent.com for the most current version of these manuals. Check the 
installation media or the online Help of your installed software for the manuals that 
apply to your version software.
• MassHunter Pathways to PCDL Software Quick Start Guide (G6825-90008, Revi-

sion A, November 2012)
• MassHunter Personal Compound Database and Library Manager Quick Start 

Guide (G3336-90022, Revision A, September 2014)
• MassHunter PCDL for Qualitative Analysis Familiarization Guide (G5883-90002, 

Revision B, February 2016)
• MassHunter METLIN Metabolite PCD/PCDL Quick Start Guide (G6825-90009, 

Revision A, October 2014)
• MassHunter Profinder Software Quick Start Guide (G3835-90027, Revision A, 

April 2016)

Application Notes • 13C-Glutamine Qualitative Flux Analysis of a Chondrosarcoma Cell Line Using Agi-
lent VistaFlux (5991-6810EN, May 2016)

Technical Overviews • Agilent MassHunter Profinder: Solving the Challenge of Isotopologue Extraction 
for Qualitative Flux Analysis (5991-6817EN, April 2016)

• Agilent MassHunter VistaFlux for Qualitative Flux Analysis (5991-6756EN, April 
2016)

Presentations • Introducing VistaFlux Software for High Performance Qualitative Flux Analysis 
(http://www.agilent.com/en-us/promotions/flux, April 2016)

• Advances in Instrumentation and Software for Metabolomics Research
 (Advances in Instrumentation and Software for
 Metabolomics.pdf, September 18, 2012)

•  Workflows to Support Automated Class Prediction with Complex Samples
 (WP20_405__Workflows_Support_Automated_Class_Prediction.pdf, June 25, 
2012)

• Multi-omics Analysis Software for Targeted Identification of Key Biological
 Pathways (May 3, 2012)

• Predictive Classification of Contaminants Encountered During the Distillation of
 Shochu, a Distilled Beverage Native to Japan
 (ASMS_2011_ThP_316.pdf, June 23, 2011)

• Metabolomics LCMS Approach to: Identifying Red Wines according to their
 variety and Investigating Malaria infected red blood cells (November 3, 2010)
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• Small Molecule Metabolomics (November 3, 2010)
• Presentation: Metabolome Analysis from Sample Prep through Data Analysis

 (November 3, 2010)
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Acknowledgments and 
Citations

This section contains acknowledgments and citations for the BioCyc and KEGG 
pathways databases.

BioCyc Pathway/Genome 
Databases

Includes BioCyc Pathway/Genome databases from 
the Bioinformatics Research Group at SRI Interna-
tional®, used under license.

http://www.biocyc.org/

Citation based on use of BioCyc databases or the Pathway Tools software

If you use BioCyc databases or the Pathway Tools software in your research, cite rel-
evant publications as described on the BioCyc website:

http://biocyc.org/publications.shtml

For example, users who publish research results in scientific journals based on use 
of data from the EcoCyc Pathway/Genome database should cite:

Keseler et al., Nucleic Acids Research 39:D583-90, 2011. 

Users who publish research results in scientific journals based on use of data from 
most other BioCyc Pathway/Genome databases should cite:

Caspi et al., Nucleic Acids Research 40:D742-53, 2012.

KEGG Database Includes KEGG (Kyoto Encyclopedia of Genes and 
Genomes) databases developed by Kanehisa Laboratories.

http://www.genome.jp/kegg/

Citation based on use of KEGG Database

If you use the KEGG database in your research, cite relevant publications as 
described on the KEGG website:

http://www.genome.jp/kegg/kegg1.html

Omix Premium Omix is a registered trademark of Omix Visualization GmbH & Co. KG.
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