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This Quick Start Guide provides an overview of how to use the Feature 
Extraction 10.10 software, with step- by- step instructions on how to start 
the program and run an extraction. Exercises are also provided to help 
you, through the use of example images provided with the software.

This guide assumes you have already installed Feature Extraction 10.10 
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Agilent Genomic Workbench Standard Edition.

For a complete description of the Feature Extraction main window and its 
components, see the Feature Extraction 10.10 Users Guide.
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Starting Feature Extraction on PCs with Agilent Scanners
Starting Feature Extraction on PCs with Agilent Scanners

Agilent Genomic Workbench software (including Feature Extraction) is 
pre- installed on PCs that are shipped with Agilent scanners. When you 
start the Feature Extraction or Agilent Genomic Workbench software for 
the first time on the PC that was shipped with your Agilent scanner, you 
will receive an error indicating that the software cannot find the database. 
Before you can use the software, you must set the database host name to 
the name of the PC.

Figure 1 Database connection error for Agilent Genomic Workbench

Figure 2 Database connection error for Feature Extraction

Use the following procedure to set the database host computer name.

To set the database host name for Agilent Genomic Workbench and Feature 
Extraction

1 Start the Agilent Genomic Workbench software.

2 When the Database connection error message appears, click Yes.
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To set the database host name for Agilent Genomic Workbench and Feature Extraction
The Enter the database parameters dialog box appears.

Figure 3 Enter the database parameters dialog box

3 In the box next to Host, type the name of your PC. You can find the 
name of the computer by opening the Windows Control Panel, and 
selecting System. Leave the Port set to 3306.

4 Click OK to close the dialog box.

5 You can now log into Agilent Genomic Workbench, or close it and start 
the Feature Extraction software.
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What is Agilent Feature Extraction software?
What is Agilent Feature Extraction software?

Agilent Feature Extraction 10.10 software automatically reads and 
processes up to 100 raw microarray image files in the batch mode, or 
real- time extraction as soon as the .tif image is produced by the Agilent 
scanner. It finds and adjusts microarray grids, rejects outlier pixels, 
accurately calculates feature intensities and ratios, flags outlier features, 
and calculates statistical confidences. Application- specific QC reports 
summarize multiple analyses. 

Feature Extraction is a key component of Agilent Genomics Workbench, a 
comprehensive informatics platform that integrates complementary 
technologies to provide a complete genomic solution, from design of 
microarray and target enrichment libraries through analysis and reporting.

Agilent Feature Extraction software extracts data from microarray images 
produced in two different situations:

• Agilent microarrays scanned on an Agilent scanner

• Non- Agilent microarrays scanned on an Agilent scanner

Feature Extraction handles each of these images differently. These 
differences are described throughout the documentation.

If you are a new user
Read “Getting Help” on page 6.

“Starting the program and setting up eArray” on page 13.

If you intend to analyze...

• Saved Agilent images, read the “Instructional overview” on page 21, and 
go to “Example Exercise 1: Set up and run batch extractions on Agilent 
images” on page 31.

• Saved non- Agilent images, read the “Instructional overview” on page 21, 
and go to “Example Exercise 2: Set up and run batch extractions on 
non- Agilent images” on page 43.

NOTE Feature Extraction versions 10.7 and higher do not support microarray images generated by 
the GenePix/Axon scanner.
4 Agilent Feature Extraction 10.10 Quick Start Guide



 
If you are an experienced user
Agilent images in real time, read the “Instructional overview” on 
page 47, and go to “General Instructions” on page 48.

If you are an experienced user
Read “What’s new in version 10.10?” on page 9.

Do the exercises again if you want to sharpen your skills.

To manually download updates
When Feature Extraction is installed, Feature Extraction protocols and QC 
metric sets are also installed. Grid templates are not included with the 
installation. But if you set up an eArray login in Feature Extraction, the 
software will automatically download and update the necessary grid 
templates and Feature Extraction protocols from the eArray server. You 
can also go to the following web sites to download updates manually.

Listed below are some useful Agilent Web sites:

www.agilent.com/chem/earray -  To register for eArray account

www.agilent.com/chem/feprotocols -  To download Feature Extraction 
protocols

www.agilent.com/chem/designfile -  To download grid templates

www.agilent.com/chem/feqcmetrics -  To download QC metrics

www.agilent.com/chem/registration -  To subscribe to E- Notes for monthly 
updates on Agilent products
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Getting Help
Getting Help

To get help for Feature Extraction
The following tables list the resources available for getting help. Guides 
and manuals are opened using Adobe® Reader® software. 

Help Resource Description/Instructions

Feature Extraction Quick Start 
Guide

This guide, which you are reading, gives you an overview of the 
Feature Extraction software, including tutorial exercises. To open 
this guide from within Feature Extraction, click Help > Quick Start 
Guide.

Feature Extraction User Guide A comprehensive guide for using the Feature Extraction software, 
that includes the following chapters:

• Chapter 1– Working with Feature Extraction
• Chapter 2– Extracting Microarrays Automatically
• Chapter 3– Creating Grid Files and Templates
• Chapter 4– Changing Protocol Settings
• Chapter 5– Changing Image Displays
To open this guide from within Feature Extraction, click Help > 
User Guide.

Feature Extraction Reference 
Guide

A reference guide that contains information about protocols, QC 
reports, results, and algorithms, that includes the following 
chapters:

• Chapter 1 – Default Protocol Settings
• Chapter 2 – QC Report Results
• Chapter 3 – Text File Parameters and Results
• Chapter 4 – MAGE-ML Results
• Chapter 5 – How Algorithms Calculate Results
• Chapter 6 – Command Line Feature Extraction
To open this guide from within Feature Extraction, click Help > 
Reference Guide.

Technical Support Opens a link to the Agilent Technical Support Web site where you 
can find literature and manuals, view Frequently Asked Questions, 
and download updates and revision information. There is also a 
Contact Us link where you can locate the technical support phone 
number or send an e-mail to technical support for your country.
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To get help within Agilent Genomic Workbench
To get help within Agilent Genomic Workbench

Feature Extraction Training Opens a link to the Feature Extraction Tutorials Web Site, where 
you can view a number of self-paced instructional tutorials.

To open this Web site from within Feature Extraction, click Help > 
Feature Extraction Training.

Feature Extraction on the Web Opens a menu that provides links to the following:

• Array annotation – Find available design files by barcode
• Feature Extraction Software – Feature Extraction software 

downloads and information
• Feature Extraction Protocols – Download current and previous 

versions of Feature Extraction protocols

Agilent License Opens the Agilent software license redemption Web site, where 
you use your entitlement certificate to redeem your software 
license.

Memory Status Opens an information window that shows how much computer 
memory is currently available and how much memory is in use.

About Opens an information window that shows your Feature Extraction 
version, license, and database information. This window also 
displays your computer Host ID, which you need in order to redeem 
your license.

Help Resource Description/Instructions

Help Resource Description/Instructions

Feature Extraction Guides From the Help tab in Agilent Genomic Workbench, a Feature 
Extraction button appears if the selected application can use 
Feature Extraction. Click Feature Extraction to open a menu that 
lets you open the following guides:

• Feature Extraction Quick Start Guide
• Feature Extraction User Guide
• Feature Extraction Reference Guide
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To learn about Agilent products and services
To learn about Agilent products and services
To view information about the Life Sciences and Chemical Analysis 
products and services that are available from Agilent, go to 
www.chem.agilent.com.

Other User Guides The Help tab in Agilent Genomic Workbench lets you view any of 
the available user guides that apply to the currently selected 
application type.

1 Set the desired application type from the Switch Application 
menu. 

2 In the Agilent Genomic Workbench tab bar, click Help. 
The names of the available user guides appear in the command 
ribbon.

3 Click the desired user guide. 
The selected user guide opens in Adobe Reader.

Help Resource Description/Instructions
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What’s new in version 10.10?
What’s new in version 10.10? 

Feature Extraction 10.10 includes the following new and changed 
functions:

• Perform Feature Extraction on CGH+SNP (Comparative Genomic 
Hybridization with Single Nucleotide Polymorphism) microarrays 
containing new SNP control probes.

• Import Dye Normalization lists from eArray and store them in the 
database.

• For manual gridding, associate Dye Normalization list (if present) 
automatically to grid file from the corresponding grid template.

• Use a Dye Normalization list associated with a grid template (if 
present) instead of the method specified in the protocol.

• Details of the Dye Normalization list used during extraction are 
included in the XML, QC Report, and Batch Summary output, and in 
the Run Monitor Window.

• External Dye Normalization lists are only used for non- Agilent arrays.

• Automatically create zip file of text output package.

• Changes to the Array Format in the Place Grid protocol step.

• Addition of two parameters to all array formats for the Place Grid 
protocol step.

• Ability to report population outliers as Failed in MAGEML file.

• The CGH report has been updated and renamed CGH_ChIP. It is now 
the default report for the ChIP protocol.

• New QC Report for Agilent test slides.

• Parameters (params) are now included in the output XML.

• New Corner Pattern Detection (CPD) protocol (available by request) for 
fully automatic grid placement of dim arrays. 

See the Release Notes installed with the Feature Extraction software for 
more information about Feature Extraction 10.10 (Start > Programs > 
Agilent > Agilent Genomic Workbench <version>\FeatureExtraction > 
Release Notes).
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What’s new in version 10.10?
Perform Feature Extraction on CGH+SNP (Comparative Genomic Hybridization 
with Single Nucleotide Polymorphism) microarrays containing new SNP control 
probes

The SurePrint G3 Human Comparative Genomic Hybridization (CGH) 
platform has been extended to include a set of Single Nucleotide 
Polymorphism (SNP) probes on the same microarray. This allows for the 
simultaneous detection of high resolution copy number and copy neutral 
variations and eliminates the need to run two separate microarrays. 
Agilent Feature Extraction software now supports feature extraction of 
new CGH+SNP microarrays that contain SNP control probes.

Import Dye Normalization lists from eArray and store them in the database

When you download a grid template from eArray.com Feature Extraction 
also downloads the corresponding DyeNormList file, if present. Feature 
Extraction automatically imports and stores the DyeNormList in the 
database and associates it with the grid template.

Associate Dye Normalization list automatically to grid file from the 
corresponding grid template

Grid files, used to help locate the spot centroids (geometric centers) on 
the microarrays, now are automatically associated with the dye 
normalization list (if present) from the grid template on which the grid 
file is based.

Use a Dye Normalization list associated with a grid template (if present) instead 
of the method specified in the protocol

You now have the option to use a dye normalization list associated with 
the grid template instead of the using the Dye Norm List setting from the 
protocol

Details of the Dye Normalization list used during extraction are included in the 
XML, QC Report, Batch Summary output, and in the Run Monitor Window

The name of the dye normalization list and the number of probes it 
contains are now displayed in the QC report header, Batch Summary 
Report, the XML output file, and in the Run Monitor Window.
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What’s new in version 10.10?
External Dye Normalization lists are only used for non-Agilent arrays

External dye normalization lists are no longer used for Agilent arrays, 
which use the dye normalization lists associated with the array designs. 
You can specify an external dye normalization list for non- Agilent arrays, 
however.

Automatically create .zip file of text output package

You can now select to automatically create a .zip file containing the text 
output from an extraction set. This option is turned on or off in the 
Project Properties.

Changes to the Place Grid>Array Format choices

The 30 micron feature size choice was removed. Two new choices, 30 
micron single pack, and 30 micron multi- pack are now available.

New options in the Place Grid step for all array formats

“Use central part of pack for peak and skew calculation” and “Use the 
correlation method to obtain origin x of subgrids” options are now 
available in the Place Grid step for all array formats. These options are 
useful particularly in cases where pack edges have dim spots and are 
failing to grid.

Report Population outliers as Failed in MAGEML file

With this new option turned on, any feature that is flagged as a 
population outlier is reported as Failed in the MAGE- ML output file.

The CGH report has been updated and renamed CGH_ChIP

The CGH report now includes a plot of the log ratio distributions, and has 
been renamed CGH_ChIP. This report is now the default report for the 
ChIP protocol.

New QC Report for Agilent test slides 

A new QC Report, “Test Chip” is now available that is designed for use 
with Agilent test slides. This report is used by Agilent service personnel 
for scanner performance verification.
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What’s new in version 10.10?
Parameters (params) are included in the output XML

The XML output file now contains Feature Extraction parameters.

New Corner Pattern Detection (CPD) protocol (available by request) for fully 
automatic grid placement of dim arrays

The Corner Pattern Detection (CPD) is a technique for fully automatic grid 
placement using a special pattern placed at the four corners of each array 
on a slide. 

A template is formed by a unique arrangement of control probes. The 
template is printed and hybridized at four corners of each array along 
with other experimental probes. The grid placement step searches for 
these templates using image correlation technique. The locations obtained 
are used to calculate the origin, slope and skew. The grid geometry 
information is further used to place the grid on the scan.

Since the grid estimation is based on the locations obtained for the 
templates and the templates are placed at the corners of arrays, the 
irregularity in the spot grid due to missing rows/columns and the dust 
particles spread over image do not affect the grid placement. Further, the 
template size (10X10 spots) and the particular arrangement of spots 
within the template help to obtain correct locations even in the presence 
of noise and presence/absence of few probes and dust particles in the 
template area. Thus the technique is very robust to all common types of 
artifacts present in the slide image. In addition, the templates aid in 
accurate calculation of rotation and skew even if they are large in values. 
Above all, the technique has delivered very good grid irrespective of 
number of bright spots present on the array.

The prerequisite of the technique is presence of the corner patterns in the 
assays. For further information on this please contact Agilent Technical 
Support.
12 Agilent Feature Extraction 10.10 Quick Start Guide



 
Starting the program and setting up eArray
Starting the program and setting up eArray

The Feature Extraction program can be started in one of two ways:

• From Microsoft® Windows® 

• From the Agilent Genomic Workbench Open Application tab

To start the program from Windows
• Double- click the Feature Extraction shortcut on your desktop. 

This shortcut was created when the Feature Extraction program was 
installed.

OR

• From Windows, click Start > All Programs > Agilent Genomic 
Workbench Standard Edition<revision> AGW Feature Extraction 
<revision>.

To start the program from Agilent Genomic Workbench
1 Open Agilent Genomic Workbench, if you have not already done so.

2 In the Agilent Genomic Workbench main window, click the Open 
Application tab.

3 In the Open Application tab, click the Feature Extraction icon .

NOTE You must have a valid license installed in order to use Feature Extraction. If you do not have 
a license installed, you will see an error message.
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To set up a Feature Extraction license
To set up a Feature Extraction license

Redeem your software licenses

To obtain your Feature Extraction license:

1 Start the Feature Extraction program and select Help > Agilent 
License.

Have the following items available:

• Software Entitlement Certificate (SEC) -  This PDF contains the 
Order Number and Certificate Number that you need to provide in 
order to redeem your purchased license.

• Host ID -  This can be found under the menu Help > About. You need 
to provide the host ID to redeem your purchased license.

2 Follow the instructions on the Agilent Software License Redemption 
Web site to redeem your purchased license.

After redeeming the license online, you will receive an e- mail with the 
license attached.

3 Save the unzipped license file to the folder on the drive where you 
installed the software. By default, Feature Extraction is installed in the 
Agilent Genomic Workbench installation folder:

C:\Program Files\Agilent\Agilent Genomic Workbench Standard 
Edition <version>\FeatureExtraction\

Set up the license from Agilent Genomic Workbench

1 Locate your license file and double- click it to open the file in Notepad. 

2 Highlight the license text, and copy it to the Clipboard.

3 Start the Agilent Genomic Workbench software. See “To start the 
program from Agilent Genomic Workbench” on page 13.

4 In the Open Application tab in Agilent Genomic Workbench, next to 
Feature Extraction, click License. 

5 Click License and then paste the license in the blank license field. (To 
paste the text, press Ctrl V on your keyboard.)
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To set up eArray login
Set up the license from Feature Extraction

1 Start the Feature Extraction software, if it is not already running.

If the Feature Extraction program is already running (unlicensed), click 
the New Project icon .

2 A message appears that informs you that you do not have a valid 
license installed. Click Retry.

The Select Agilent Feature Extraction License File dialog box opens.

3 Find the folder that contains the license file.

4 Select the license file (.lic), and click Open.

To set up eArray login
When you first open Feature Extraction, the eArray Login Setting window 
appears on top of the Feature Extraction main window. If you do not see 
the eArray Login Setting window, you can access it using Tools > eArray 
settings.

Figure 4 eArray Login Setting dialog box
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To set up eArray login
Feature Extraction connects to the Agilent eArray server to automatically 
download, install, and use the required grid templates, Feature Extraction 
protocols, and QC metric sets during extraction.

For information on the eArray server and how to use the eArrayXD 
module in Agilent Genomic Workbench to create and manage custom 
microarray content for CGH, ChIP, methylation, gene expression, and 
microRNA applications, see the eArrayXD User Guide.

It is highly recommended that you set up an eArray login to take 
advantage of this feature before you run the extraction project. 

1 Type your eArray User Name and Password in the eArray Login 
Setting window, if you already have an existing eArray account. Hint: 
The user name is the e- mail address you provided when you created an 
eArray account.

If you do not have an eArray account, you must first register for one. 
To start the registration process, click Register. This will take you to 
the Agilent eArray registration Web site where you can request a free 
eArray account. Follow the instructions provided on the eArray Web 
site to complete the registration.

2 Click Test Connection. The message “Login Successful!!!” is displayed if 
the connection to the eArray server is successful. If you get the message 
“Login denied”, check that the user name and password you typed are 
correct.

3 Under Advanced Options, select the appropriate boxes:

• Use eArray server during extraction

Select this check box to log into eArray server to automatically 
download, install, and use grid templates (design files), Feature 
Extraction protocols, and QC metric sets during extraction.

NOTE An internet connection is required in order to log into eArray.
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To set up eArray login
• Check for updates of grid template

Select this check box to download updates to existing grid templates 
already in the Grid Template Browser. Updated grid templates are 
added to the database, leaving existing grid templates, unless you mark 
Replace old grid template. When this is marked, the newest grid 
template in the database will be used for feature extraction.

If several versions of a design are in the database and you want to do 
an extraction using an older design, clear this box. Otherwise, the 
extraction will automatically use the most recent version of the design 
(whether or not you are using the eArray server during extraction.)

• Replace old grid template

When you select this check box, Feature Extraction will replace old grid 
templates in the Grid Template Browser with the latest ones from the 
eArray server.

• On starting Feature Extraction check for protocol update from 
eArray server

Select this box to download updates from the eArray server for existing 
default protocols and QC metric sets in the FE Protocol Browser. 

4 To save the eArray login settings, click Save. You will get a message 
“Setting updated successfully”. Click OK to close the message, and click 
Close to exit the eArray Login Setting window.

Now you see the Feature Extraction main window.
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To set up eArray login
Figure 5 Feature Extraction Main Window
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To open an image file
To open an image file
1 With the Feature Extraction main window open, click File > Open > 

Image, and browse to the folder that contains the image file. 
Double- click the image file (.tif) that you want to open. 

If the Feature Extraction program is running, you can also “drag and 
drop” the image from your folder to the open Feature Application 
window.

If you do not have the Feature Extraction program running, you can 
also open an image file by dragging and dropping an image file to the 
Feature Extraction shortcut on your desktop.

Figure 6 Feature Extraction main window with open image

Image Toolbar

IMAGE WORK WINDOW
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To open an image file
To learn more about interactively finding spots and creating grid files for 
non- Agilent images, see Chapter 3, “Creating Grid Files”, in the Feature 
Extraction 10.10 User Guide.

To learn more about changing the image display, see Chapter 5, “Changing 
Image Displays”, in the Feature Extraction 10.10 User Guide.

NOTE For high resolution images (2 or 3 micron or 20-bit), you see a low-resolution preview image 
until you crop to roughly 1/10 of the preview image size. Then you see the original 
high-resolution image. [The Crop Cursor turns red when you are outside the high-resolution 
(High Fidelity) region.]
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Setting up a Standard Project to extract Agilent and non-Agilent image files
Setting up a Standard Project to extract Agilent and non-Agilent image 
files

Instructional overview
Follow the road map below and the instructions on the next pages to get 
started.

See Chapter 2 in the Feature Extraction 10.10 User Guide for details on 
this task.

The Agilent Feature Extraction program works with Agilent or non- Agilent 
microarray images produced on Agilent scanners using projects, extraction 
sets, grid templates or files, and protocols. The images are organized into 
extraction sets that contain the grid and protocol information to run the 
extraction. The extraction sets, in turn, are organized into projects.

Start 
Here!

Set up and 
run saved 
image files

3 Add image files 
(extraction 
sets)

1 Create a 
“Standard 
Project”

2 Enter 
project 
properties

4 Check 
extraction 
configuration 
and save 
project

5 Add/change 
grid files/ 
templates 
(optional)

7 Run the 
extraction 
sets in the 
project

6 Add/change 
protocols 
(optional)
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Instructional overview
Figure 7 Project Explorer with expanded extraction sets

project A grouping of information that contains one or more extraction sets that 
define the files to use in the extraction.

extraction set Each group that contains a microarray image file, grid template (or grid 
file) and protocol within a project. This term is used both before and after 
extraction.

grid template Grid information from Agilent design files or grid files stored in the 
database. A grid template includes feature annotation and general 
geometry about the microarray (number of rows, columns, subgrids, 
feature spacings), which is used to find spots before data analysis takes 
place. Although not specific to any microarray image, grid template 
information is usually applied to the image for which the template was 
designed.

grid file Grid files are required in order to do feature extraction for non- Agilent 
images. Rarely, the automatic grid placement of Agilent images using a 
grid template may produce an incorrect grid, which will also require the 
use of a user- generated grid file. When using a grid file, extraction uses 
the nominal and “found” spot locations specific to the image from which 
the grid file was created. Grid files are created in the Feature Extraction 
program using a microarray image file and a microarray layout file (such 
as an Agilent Design file or a .GAL [GenePix Array List] file). The grid file 
contains the locations of the “found” spots if the “Calculate spot size and 
centroids” option is run before the file is saved. You can create grid 
templates from grid files, although the templates have only geometry 
information, no found spots.

protocol A list of steps and parameter values that define the data analysis 
algorithms and calculations used for feature extraction of a microarray 
image or images.

Extraction Set

Image File

Grid Template (design)

Protocol

Grid File
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General Instructions
General Instructions

Step 1. Create a Standard Project

• If the Feature Extraction program is not already running, double- click 
the Feature Extraction shortcut on your desktop to start, or click the 
Feature Extraction icon in the Open Application tab of Agilent 
Genomic Workbench.

Feature Extraction automatically creates a standard project 
(FE_Project1) every time you start the program. The Feature Extraction 
main window appears with the Project1 work window and an empty 
Extraction Set Configuration tab window. 

Figure 8 Feature Extraction main window 

Standard Toolbar

Grid Template 
Browser Pane

FE Protocol 
Browser Pane

Project Explorer 
Pane

QC Metric Set 
Browser Pane

PROJECT WORK WINDOW

FE Project Tools
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General Instructions
You can change where and how the project work window and the 
browser panes dock when you start the program. To learn more about 
working with this interface, see the Feature Extraction 10.10 User 
Guide. 

Step 2. Enter the project properties

1 Click the Project Properties tab to view the default project properties.

2 To change a default setting, select a property and click the down arrow 
that appears on the right column. Choose from the available options.

Figure 9 Default project properties for a standard project

You can run Feature Extraction for one or more Agilent images generated 
by the Agilent scanner with these default project properties. You can also 
set up and run multiple extractions with a combination of Agilent and 
non- Agilent images.

To learn more about setting up and running batch extractions with the 
Project Work Window, see the exercises in this guide:
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General Instructions
• “Example Exercise 1: Set up and run batch extractions on Agilent 
images” on page 31.

• “Example Exercise 2: Set up and run batch extractions on non- Agilent 
images” on page 43.

Step 3. Add image files (extraction sets) to the project

1 In the Project Explorer, right- click FE_Project1, and click Add 
Extraction.

2 Select one or more images, and click Open. 

• To select multiple images at a time, hold down the Ctrl key and select 
the images.

• You can also add one or more image files by dragging and dropping 
them from the folder to the open project in the Feature Extraction 
window.

Any extraction set that is missing the required components, such as grid 
template or protocol, shows a lightning bolt in Project Explorer and a “?” 
in the icon of the missing component. (Provided eArray is enabled and the 
image is an Agilent image.) In versions prior to 10.5, if any of the 
required components were not attached to the tiff image, then the 
extraction set would not be extracted. This changed beginning with version 
10.5. 

You do not need to assign a grid template/grid file and a protocol to an 
image file in order to run the extraction. Extraction sets without a grid 
template and/or a protocol attached to the project can be extracted, by 
setting the program to automatically determine the correct template and 
protocol to use. For this functionality to work, one of the following must 
be true:

• Prior to running the extraction, you set up to use the eArray server 
during extraction, as discussed in the section “To set up eArray login” 
on page 15.

• Prior to running the extraction, the required grid templates and 
protocols already exists in the database and are shown in the Grid 
Template Browser and FE Protocol Browser.

For custom grid templates and protocols that cannot be found on the 
eArray server, you must add them manually to the database before you 
run the extraction. See the Feature Extraction 10.10 User Guide.
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General Instructions
If grid templates are not loaded automatically, or you want to use a 
different grid template or protocol, you can assign them manually. See 
Step 4 “Assign grid template/grid file to the extraction set (depending on 
type of images)” on page 26 and Step 5 “Assign a protocol to the 
extraction set (optional)” on page 27.

Step 3. Assign grid template/grid file to the extraction set (depending on type of 
images)

Agilent images By default, if the required grid templates are in the 
database, when you add Agilent tiff images to the project, Feature 
Extraction will automatically associate the appropriate grid templates to 
the extraction sets. You can also assign a grid template or grid file to the 
Agilent image.

To assign a grid template for Agilent images:

1 Expand the extraction set.

2 Select a grid template from the Grid Template Browser, hold down the 
mouse button and drag it to the second position of the extraction set in 
Project Explorer. 

3 Let go of the mouse button to drop it at this position.

To assign a grid file for Agilent images:

1 Right- click the second position of the expanded extraction set and click 
Select Grid File.

2 Select the grid file, and click Open.

The grid file name will appear in the extraction set, along with the grid 
template on which it is based.

Non-Agilent images You must assign a grid file to non- Agilent images in 
the project. The extraction automation feature is not supported for 
non- Agilent images. Feature Extraction will not extract non- Agilent images 
that are missing grid files or protocols.

To assign a grid file for non- Agilent images:

1 Right- click the second position of the expanded extraction set and click 
Select Grid File.

2 Select the grid file, and click Open.
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AMADID is the 
Agilent MicroArray 

Design IDentifier.

Agilent microarray images scanned with an Agilent scanner For Agilent 
microarray images with barcode information included in the image, the 
program selects a grid template from the database using the AMADID 
portion of the barcode associated with the image file. If there are grid 
templates for that AMADID that come from multiple design files, the 
program selects the grid template from the most recently created Agilent 
design file. To add a barcode if the image has none, see the Feature 
Extraction 10.10 User Guide. 

For this automated assignment to work, the grid template must exist in 
the database. If it does not, you can let the Feature Extraction try to 
automatically download the required grid template from the eArray server 
or you can interactively associate a grid template or grid file with the 
extraction set. See page 26 for details on how to assign a grid template or 
grid file.

Agilent uses barcode information for many workflow automation and data 
tracking steps. Inclusion of the Agilent barcode information in the TIFF 
file helps ensure that the data is quickly, easily and accurately processed 
and that informatics programs know how to analyze the results.

Non-Agilent images scanned with an Agilent scanner Non- Agilent image files 
from an Agilent scanner do not point to grid information that the Agilent 
Feature Extraction program can read. Therefore, when you load the 
non- Agilent image file, you must add a grid file that you have already 
created. 

See Chapter 3 in the Feature Extraction 10.10 User Guide to learn how 
to create grid files.

Step 3. Assign a protocol to the extraction set (optional)

Automatically assigned protocols come from two sources: a default 
protocol associated with the grid template, or a project level default 
protocol. You select which of these options has the higher priority. (See 
Chapter 2 of the Feature Extraction 10.10 User Guide to learn how to 
associate a protocol with a grid template and where to enter the project 
level default protocol.) You can also add a protocol to the extraction set 
manually.
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To add a protocol manually:

1 From the Protocol Browser select a protocol, hold down the mouse 
button and drag it to the third position of the extraction set.

2 Release the mouse button to drop the protocol onto the third position 
of the set.

Feature Extraction can run analyses on Agilent 1- color gene expression 
(GE1), 2- color gene expression (GE2), CGH, CGH+SNP, ChIP, miRNA, and 
non- Agilent 2- color GE (GE2- nonAT) microarray images scanned on the 
Agilent scanner. Agilent includes Feature Extraction protocols for 
extracting each of these image types. 

Step 3. Add or change grid templates from design files (optional)

For the Agilent images you intend to extract, you add grid templates 
based on the images’ design files to the Grid Template Browser.

1 Right- click the Grid Template Browser pane, and click Add.

2 Select a design file or files, and click Open.

Every extraction set must have an image file, assigned grid template/grid 
file and protocol. Grid templates and protocols for Agilent images are 
loaded to the extraction set automatically by the program, if the grid 
template associated with the loaded image’s design file is available in the 
database. If a grid template is in the database, it is displayed 
automatically in the Grid Template Browser. If a grid is not in the 
database, the program will automatically get the grid template from eArray 
when the extraction starts. For details on how to update or add grid 
templates using Agilent eArray, see the Feature Extraction 10.10 User 
Guide. 

CAUTION These Feature Extraction Protocols were optimized using data from Agilent catalog 
arrays, which have many replicated probes and validated Negative Control probes. If 
custom arrays without enough replicated probes are used, or arrays with custom 
probes designated as Negative Control probes, the default Feature Extraction Protocols 
may not be optimal. The Feature Extraction Protocol optimization also uses Agilent's 
default lab protocols; that is, label, hybridization, wash, and scanner procedures.
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Step 3. Change QC metric set associated with the protocol to monitor QC metrics 

At times the Feature Extraction program is used in a production 
environment, where the microarray processing protocols are similar and 
monitoring run- to- run consistency is an important goal. Feature 
Extraction can help monitor this consistency with the QC metric sets. 

In earlier versions of Feature Extraction, you choose one QC metric set in 
the Project Properties tab that was used for all extractions in a project.

In version 10.5 and higher, the QC metric sets and protocols are linked. 
The Feature Extraction protocol defines which metric set is used with it. 

To change the QC metric set associated to the Feature Extraction protocol:

1 In the FE Protocol Browser, double- click a protocol to open the FE 
Protocol Editor.

2 Select Protocol Properties to see the protocol properties.

3 Under General, click the cell next to Metricset.

4 Click the down arrow, and select the QC metric set appropriate for your 
microarray application.

If a metric set you want to use is not available in the metric set list, 
you must first import it to the database. 

To import a QC metric set into the database:

1 Select View > QC Metric Set Browser from Feature Extraction main 
window, if it is not already visible.

2 The QC Metric Set Browser displays all of the default metric sets and 
custom metric sets in the database. Custom metric sets are created 
using the Quality module in Agilent Genomic Workbench. Right- click 
in the QC Metric Set Browser and select Import to import metric 
sets that are not shown in the QC Metric Set Browser.

The default QC metric sets installed with the Feature Extraction 
software are read- only and cannot be removed from the database. 
However, you can remove or change a QC metric set associated with the 
protocol and then save it as a new protocol with a different name. 

To remove a QC metric set from the protocol:

• Select <Set empty> from the metric set list in the Protocol 
Properties.

5 Click Save As to save the new protocol.
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QC metric sets Metric sets are loaded into the database when you install 
the Feature Extraction software. If you set up the eArray login as 
discussed in the section “To set up eArray login” on page 15, then Feature 
Extraction will automatically download and install the latest QC metric 
sets from the eArray server. 

If you remove a QC metric set, updates of QC metric sets are also 
available at www.agilent.com/chem/feqcmetrics, if you need to manually 
download and install them in Feature Extraction. 

When you create QC metric sets using the Agilent Genomic Workbench 
Quality tools, you can associate them to protocols in Feature Extraction. 
When that project is run, the Feature Extraction program summarizes the 
metric statistics on each microarray’s QC report and shows how the 
results compare to the thresholds (if any) defined in the metric set. It also 
reports this information in the output files in the statistics table. For 
more information on using the Quality module in Agilent Genomic 
Workbench, see the Agilent Genomic Workbench Quality Tools User Guide.

Step 6. Save the project 

1 Select File > Save As.

By default, your projects are saved in C:\Program Files\Agilent\Agilent 
Genomic Workbench Standard Edition <version>\FeatureExtraction\FEProjects.

2 To save in a different location, go to or create the folder for your 
projects.

3 Type a project name, and click Save.

Step 4. Run Feature Extraction

1 Click the Project Run mode On/Off button on the Feature Extraction 
Project toolbar , or select Project > Start Extracting. 

CAUTION Agilent-supplied QC metric sets are intended to assist users in monitoring microarray 
processing issues. They were not developed to detect microarray manufacturing 
issues.
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Example Exercise 1: Set up and run batch extractions on Agilent images 

The following exercise takes you through the setup, analysis, and reporting 
steps of Feature Extraction with example images provided by Agilent. 
These images are provided on the Agilent Genomic Workbench installation 
disk.

With this exercise you learn how to:

• Set up and extract a 2- color GE microarray image and produce a 
2- color GE QC report with spike- ins.

• Set up and extract four 1- color GE images on a 4- multiplex (multi 
pack) microarray and produce a 1- color GE QC report. 

Try the Steps on the left before reading the Detailed Instructions. 

Task 1: Add an extraction set for a 2-color Gene Expression microarray image file 

Steps Detailed Instructions Comments

1 Add the 2-color gene expression 
image file that was installed with 
the Feature Extraction software to 
Project 1.

a Start the Feature Extraction program.
b Click the Add Extraction Set(s) button 

on the toolbar, or right-click Project 
Explorer, and select Add Extraction.

c The example images are located in the 
installation folder for the Agilent 
Genomic Workbench client. By default, 
this is C:\Program 
Files\Agilent\Agilent Genomic 
Workbench Standard Edition 
<version>\FeatureExtraction\ 
ExampleImages. Select the 
Hu22K_GE2_251209710036.tif file, and 
click Open.

d Expand the extraction set that appears 
in Project Explorer.

• There may be times when you need 
to manually assign a grid template 
and/or a protocol to the extraction 
set. Task 1 is intended to show you 
how to do this.

• The grid template associated to this 
image is automatically assigned to 
the extraction set when the grid 
template is available in the Grid 
Template Browser.
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2 Add a grid template to the 
extraction set, if one has not been 
automatically assigned.

Note: The grid template for this 
image is a design file that begins 
with 012097_D...

a Right-click the Grid Template Browser, 
and click Add.

b Go to the ExampleImages folder, or the 
folder where the image file is stored.

c Select the design file 
(012097_D_20070820.xml), and click 
Open.

d When the message appears that tells 
you the grid template was successfully 
added, click OK.

e Drag and drop the new grid template to 
the second row, after the image name.

• The program will automatically 
assign the appropriate grid template 
and protocol for the image if 
<Automatically Determine> is 
displayed in the extraction set, and 
you have selected in the eArray 
settings to use the eArray server 
during extraction.

3 Assign the gene expression 2-color 
protocol to the extraction set.

Note: The 2-color GE protocol for 
this extraction set has spike-ins 
turned on as the default setting. 
The QC report will show all the 
spike-in results.

• From the FE Protocol Browser, drag 
and drop the GE2_1010_Sep10 Feature 
Extraction protocol to the third row of 
the gene expression extraction set.

• You can add a GE2_105 (version 
10.5) Feature Extraction protocol to 
the Grid Template Browser if you 
want to compare data run on v10.5 
vs. v10.10. The extraction set using 
v10.5 Feature Extraction protocol is 
analyzed using v10.5 data 
processing, but with v10.10 for 
image processing.

• The latest protocols can be 
automatically downloaded from 
eArray server and installed on 
Feature Extraction, if you select this 
in the eArray settings.

Task 1: Add an extraction set for a 2-color Gene Expression microarray image file (continued)

Steps Detailed Instructions Comments
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Task 2: Add an extraction set for a 1-color Gene Expression image file of 4-multiplex microarray 

Steps Detailed Instructions Comments

1 Add a grid template from the 
design file.

Note: The design file for this image 
is 014850_D_20070207.xml.

a Right-click the Grid Template Browser, 
and click Add.

b Go to the directory where the image 
file is stored.

c Select the design file 
(014850_D_20070820.xml), and click 
Open. 

d When the message appears that tells 
you the design was added 
successfully, click OK.

• Task 2 shows you how to associate 
a default Feature Extraction 
protocol with a grid template. When 
the image and grid template are 
loaded in the project, Feature 
Extraction automatically attaches 
the default protocol to the 
extraction set.

2 Assign a default 1-color GE 
protocol to the grid template to use 
for the microarray image with 
barcode 25148503446.

a Right-click grid template 
14850_D_20070820 in the Grid 
Template Browser and select 
Properties.

b In the Grid Template Properties page, 
click the Default OneColor protocol 
row.

c From the Default OneColor protocol list 
select GE1_11010_Jun10, and click 
OK.

• The software recognizes to use the 
default 1-color protocol when the 
1-color scan file is loaded.
Agilent Feature Extraction 10.10 Quick Start Guide 33



 
Example Exercise 1: Set up and run batch extractions on Agilent images
3 Add the 1-color GE example image 
file installed with the Feature 
Extraction software to Project 1.

Note: This image has been 
renamed from the original scan 
name. The “14850” in the name 
corresponds to the AMADID.

a Right-click Project Explorer, and select 
Add Extraction.

b Select the 
Hu4x44K_GE1_251485034336_H.tif 
file, and click Open.

c Expand the extraction set that appears 
in Project Explorer.

• Feature Extraction lets you extract 
the multiplex images as one image 
file and produces one .shp shape 
file for the four microarrays in the 
multiplex.

• This is an XDR image scanned at 
high and low PMTs. Adding a high 
PMT scan (_H) automatically loads 
the corresponding low PMT scan 
(_L) that is in the same directory.

• Feature Extraction automatically 
loads the grid template which has 
the default 1-color GE protocol 
assigned to it. As a result, the 
protocol is also loaded to the 
extraction set.

Task 2: Add an extraction set for a 1-color Gene Expression image file of 4-multiplex microarray (continued)

Steps Detailed Instructions Comments
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Task 3: Add an extraction set for a CGH microarray image file 

Steps Detailed Instructions Comments

1 Add the 20-bit CGH image file 
installed with the Feature 
Extraction software to Project 1.

Note: The grid template for this 
image is not provided as part of the 
Example Images installation.

a Click the Add Extraction Set(s) button 
on the toolbar, or right-click Project 
Explorer, and select Add Extraction.

b Select the file 
Hu244K_CGH_251469312458.tif, and 
click Open.

c Expand the extraction set that appears 
in Project Explorer.

• Task 3 shows you how to extract a 
tiff image without a grid template 
and protocol attached in the project 
when you set up the eArray login.

2 Check the Extraction Set 
Configuration tab to make sure that 
the assignments are OK for the GE 
1-color and 2-color extraction sets.

a Expand the columns in the Extraction 
Set Configuration tab to see all the 
entries for the three extraction sets.

• Note: The output file name is the 
name of the extraction set plus the 
protocol name.

• Note: The CGH extraction set does 
not have a protocol assigned to it.
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3 Enter eArray login settings, if you 
have not yet done so. You must 
select the Use eArray server 
during extraction in order for this 
exercise to work.

Note: You must have an eArray 
account before you can set up the 
login settings in Feature Extraction. 

a Select Tools > eArray Settings.
b In the eArray Login Setting window, if 

you do not have an eArray account, 
click the Register button to sign up for 
one.

c Enter your eArray login information, 
and click the Test Connection button. 
You should get a message indicating 
successful login.

d In Advanced Options, select Use 
eArray server during extraction. Click 
Save and then close the eArray 
Settings dialog box.

• The settings let Feature Extraction 
automatically log into the eArray 
server to check for updates of grid 
templates, protocols, and QC metric 
sets.

Task 4: Save the project and start the Feature Extraction batch run  

Steps Detailed Instructions Comments

1 Save the project with a new name. a Select File > Save As.
b Go to or create the folder for your 

projects, if you want to save in a 
location different from the default 
FEProjects directory.

c Enter AgilentExampleImages (or 
anything you want) in the File Name 
box, and click Save.

• You must save the project before 
the program will start extracting.

• After you save the project, the 
project name changes in both the 
title bar and Project Explorer.

Task 3: Add an extraction set for a CGH microarray image file (continued)

Steps Detailed Instructions Comments
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2 Run Feature Extraction on 
AgilentExampleImages project.

Note: The Running Monitor 
window shows the progress of 
each extraction set.

a Click the Project Run mode On/Off 
button, or select Project > Start 
Extracting.

The project extraction starts to run.

• In Feature Extraction 10.10 only one 
extraction set is extracted at a time. 

Task 5: View project run summary and QC report 

Steps Detailed Instructions Comments

1 View the Summary Report tab for 
the project run summary.

• The Summary Report tab appears next 
to the Extraction Set Configuration tab 
when the project run starts.

• See Figure 10 on page 39 for details.

• Once extraction is done, the Project 
Run Summary shows information, 
warnings, errors, and QC reports 
associated to each extraction set.

• For multiplex microarray images, a 
QC report is generated for each 
microarray.

• Note: The 4-multiplex 1-color GE 
microarray image will have four QC 
reports, one for each microarray.

Task 4: Save the project and start the Feature Extraction batch run  (continued)

Steps Detailed Instructions Comments
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2 Open the QC report for the 2-color 
GE extraction set, and see whether 
the results seem reasonable or not.

See Chapter 2 in the Feature 
Extraction 10.10 Reference Guide 
for information on how to interpret 
the QC Report.

a In the Project Run Summary on-screen 
report, double-click the link to the QC 
report for Hu22K_GE2.

Or do the following:

• Go to the folder where the .tif image 
file is saved.

• Double-click the .pdf file for the QC 
report.

b Display the grid, spatial distribution 
plot and plot of median % CV to see 
any anomalies.

• The QC report (.pdf file) by default is 
put in the same folder as the image 
file. You can change the default 
folder setting by selecting 
Tools>Preferences from the 
toolbar, and then opening the 
Output & Data Transfer folder. The 
default results folder is defined in 
the Local File Folder setting.

• If you are running Feature 
Extraction with a 30-day demo 
license, the QC report is an .html 
file. See Chapter 2 of the Feature 
Extraction User Guide to learn to 
how print this .html file.

Task 5: View project run summary and QC report (continued)

Steps Detailed Instructions Comments
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Figure 10 Summary report for AgilentExampleImages project

Task 5: View project run summary and QC report (continued)

Steps Detailed Instructions Comments
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Figure 11 Grid placement at four corners and spatial distribution plots for Hu22K_GE2 QC report

Task 5: View project run summary and QC report (continued)

Steps Detailed Instructions Comments
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Figure 12 Background corrected signals and log ratio vs. processed signals plots for Hu22K_GE2 QC report

3 Print the latest Project Run 
Summary report for the project.

a Go to the results folder where the 
AgilentExampleImages project is 
saved.

b Open and print the 
_LastBatchReport.rtf with Microsoft 
Word.

• All Summary Reports are saved to 
the folder containing the project 
associated with the report.

• Note that there are two reports with 
the .rtf extension. One is always a 
specifically-named rtf 
(ProjectName_Date). The Computer 
Name_LastBatch file is used for the 
last extraction run and is 
overwritten by the next project, if 
same folder is used.

• If an image was extracted 
previously, the previous .rtf files are 
named as Project Name_Date and 
Time.rtf.

Task 5: View project run summary and QC report (continued)

Steps Detailed Instructions Comments
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CAUTION Agilent-supplied QC metric sets are intended to assist users in monitoring microarray 
processing issues. They were not developed to detect microarray manufacturing 
issues.
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Example Exercise 2: Set up and run batch extractions on non-Agilent images

This exercise shows you how to create a new project, change project 
properties and run Feature Extraction for the non- Agilent image shipped 
with the software.

Repeat these instructions to add non- Agilent images of your own to create 
a batch. You can also set up and run a combination of Agilent and 
non- Agilent images in one project.

Scans must be from Agilent scanner. Other scanners are not supported.

Try the Steps on the left before reading the Detailed Instructions.

Steps Detailed Instructions Comments

1 Create a new standard project.

Note: After FE_Project1, the next 
project you open is FE_Project2. 
The name of every project that you 
open after that follows in 
numerical order, whether you save 
FE Project N or not or close FE 
Project N or not.

• Select File > New > Standard Project, 
OR

• Click the New Project icon, 

• A standard project is one where 
extraction sets are set up from 
existing scan files to run 
automatically as a batch.

• Each time you restart the software, 
the first new project is FE_Project1.

2 Change the following Project 
Properties:
• Highest Priority Default Protocol: 

Project Default
• Project Default Protocol: 

GE2-nonAT_105_Sep09
• Use Grid file if available: True

a Click the Project Properties tab.
b Click the cell next to Highest Priority 

Default Protocol, and select Project 
Default.

c Click the cell next to Project Default 
Protocol, and select 
GE2-nonAT_1010_Sep10.

d Click the cell next to Use Grid file if 
available, and select True.

• In the Project Properties tab screen, 
you can select a number of 
variables that pertain to the project 
as a whole, rather than to individual 
extraction sets.

• Because some of these properties, 
such as Project Default Protocol, 
affect how the extraction set is 
constructed, you may want to set 
these before you add the image files 
(extraction sets).
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• See Chapter 2 in the Feature 
Extraction 10.10 User Guide for 
instructions on how to change other 
project properties

• Note that any changes from the 
default settings are shown in 
orange.

3 Add the non-Agilent image shipped 
with the software to Project 2.
• Add any other of your 

non-Agilent images that you 
want in the batch.

a Click the Add Extraction Set(s) 
button, or right-click anywhere in 
Project Explorer, and select Add 
Extraction.

b Go to the directory containing the 
non-Agilent image, and click Open.

c Expand this extraction set.
d Right-click grid icon (below the tif file), 

and click Select Grid file.
e Browse to the folder containing the 

grid file. For this example, it is located 
in the same folder as the image.

f Select the grid file (_grid.csv) and click 
Open.

• The grid is automatically assigned, 
if its name is the same as the image 
name and you set the Project 
Properties parameter “Use Grid File 
if available” to “True.

• Note: In this example, because the 
the image file name 
“Non_Agilent_expression” is NOT 
the same as the grid file name 
“Non-Agilent”, the grid will not be 
automatically assigned to this 
image. You must manually select a 
grid file to use.

• The protocol was automatically 
assigned to the extraction set 
because you set the highest priority 
default protocol to be the one for 
the project and then selected the 
non-Agilent protocol as the default 
project protocol.

Steps Detailed Instructions Comments
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4 Save the project with a new name. a Select File > Save As.
b Go to or create the directory for your 

projects.
a Enter nonAgilentExampleImage, and 

click Save.

• For non-Agilent images you must 
create a grid file (grid.csv) for use in 
the extraction set. For more 
information see Chapter 3 in the 
Feature Extraction User Guide.

5 Run Feature Extraction on 
nonAgilentExampleImage project.

Note: The Running Monitor 
window shows the progress of 
each extraction set.

a Click the Project Run mode On/Off 
button, or select Project > Start 
Extracting.

The project extraction starts to run.

• In Feature Extraction 10.10 only one 
extraction set is extracted at a time. 

Steps Detailed Instructions Comments
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6 View the Summary Report tab for 
the project run summary.

• Summary Report tab appears next to 
the Extraction Set Configuration tab 
when the project run starts.

The Project Run Summary report 
shows a red Error message that there 
were a large percentage of 
background non-uniform outliers. User 
should check the QC Report and may 
need to make a grid file to re-extract 
this image. See the Feature Extraction 
User Guide for information on how to 
create a grid file.

7 View the QC Report b Double-click the blue line containing 
the link to the QC report.

On the QC report, note the red 
Evaluate Grid message under Spot 
Finding of the Four Corners of the 
Array.

Steps Detailed Instructions Comments
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Setting up an On-Time project to extract Agilent image files in real time

Instructional overview
An On- Time project lets you set up the Feature Extraction software to 
automatically extract Agilent microarray image files as they are 
transferred from the Agilent scanner to a folder of your choosing. 

Follow the workflow below and the instructions on the next pages to get 
started.

Start 
Here!

Set up and 
run Agilent 
files in real 
time

3 Set the 
results path 
and formats

1 Create an 
“On-Time” 
project

2 Set the 
incoming 
image path

4 Set the 
Feature 
Extraction 
termination 
criteria

5 Set other 
properties 
and save the 
project

6 Run Feature 
Extraction

NOTE
 On-Time projects work only with Agilent microarrays scanned on the Agilent scanner.
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General Instructions

These instructions help you set up the program to run a batch of Agilent 
microarray images in real time as they arrive from the Agilent scanner to 
a folder of your choosing. These instructions do not include running 
Feature Extraction.

Step 1. Create an on-time project

• Select File > New > On- Time Project.

Note that you do not add extraction sets to on- time projects.

Figure 13 On-Time Project Properties window
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Step 2. Enter the incoming image path

1 Click the cell next to Incoming Image Folder, and select the path for 
your scanned images.

2 Click OK.

The software assigns the appropriate grid template to each of the 
Agilent microarrays and the appropriate protocol included in the Grid 
Template Properties sheet.

If you want the On- Time project to process microarrays whose grid 
templates are missing from the database, you must set up the software 
to use the eArray server during extraction. The required grid templates, 
protocols, and QC metric sets are automatically downloaded and 
installed in the database. See “To set up eArray login” on page 15 for 
more details.

Step 3. Enter termination criteria

1 Click the cell next to Use Run Duration Time Out, and select True.

2 If not expanded, expand the Duration Time folder.

3 Use the sliders to enter 0 for Days, 2 for Hours and 30 for Minutes.
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Figure 14 On-Time Project run terminating

Step 4. Change QC metric set associated with a protocol to monitor QC metrics 

To change the QC metric set associated to the Feature Extraction protocol:

1 In the FE Protocol Browser, double- click a protocol to open the FE 
Protocol Editor.

2 Select the Protocol Properties tab to see the protocol properties.

3 Under General, click the cell next to Metricset.

4 Click the down arrow, and select the QC metric set appropriate for your 
microarray application.

If a metric set you want to use is not available in the metric set list, 
you must first import it to the database. 

To import a QC metric set into the database:

1 Select View > QC Metric Set Browser from Feature Extraction main 
window, if it is not already visible.
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2 Right- click in the QC Metric Set Browser and select Import to import 
either Agilent metric sets or metric sets created with the QC Chart 
Tool.

The default QC metric sets installed with the Feature Extraction 
software are read- only and can not be removed from the database. But 
you can remove a QC metric set from the protocol. 

To remove a QC metric set associated with the protocol:

1 Select <Set empty> from the metric set list in the Protocol 
Properties.

5 Click Save As to save the new protocol.

Step 6. Save the project 

1 Select File > Save As.

By default, your projects are saved in C:\Program Files\Agilent\Agilent 
Genomic Workbench Standard Edition <version>\FeatureExtraction\FEProjects.

2 To save in a different location, go to or create the folder for your 
projects.

3 Type a project name, and click Save.

Step 4. Run Feature Extraction

1 Make sure that the scanner is ready.

2 Click the Project Run mode On/Off icon in the Feature Extraction 
Project Tools, or select Project > Start Extracting.

The image files are saved to the Incoming Image Folder as they 
complete scanning and are then extracted automatically.

You can display the progress of the extractions, the Summary Report, 
and the QC Report as you did for the Standard Project extractions.

The Summary Report notes how many metrics are within range for 
each extraction. The QC report for each image contains the values for 
the metrics and an evaluation of whether they were within or exceeded 
the threshold limits.
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In this book

This book contains brief 
instructions to help you get 
started with your Agilent 
Feature Extraction 10.10 
software. This book shows 
you:

• What is new for
version 10.10

• How to set up and run
batch extractions of
existing Agilent and
non- Agilent image files

• How to set up and run
batch extractions of Agilent
image files in real time
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