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What is MassHunter Profinder?

Agilent MassHunter Profinder software is a stand-alone 
program, optimized for batch feature extraction from TOF and 
Q-TOF based profiling data files and MSD data files. Profinder 
is also part of the MassHunter VistaFlux software. Feature 
extraction, combined with chromatographic alignment across 
multiple data files, is a critical step in the peak finding and data 
reduction workflow that minimizes the appearance of both false 
positive and false negative features by “binning” the features in 
the chromatographic time domain. Profinder reduces your 
acquired data size and complexity through the removal of 
redundant and non-specific information by identifying the 



What’s new in B.08.00?
important variables (features) associated with the data. Careful 
feature extraction yields a smaller data set that is more easily 
processed without any compromise in the information quality.

Profinder is optimized to not only extract features from large 
data sets but also provides you with an intuitive user interface 
to inspect and review each feature across the files associated 
with your data set. With Profinder you can review and compare 
extracted ion chromatograms, mass spectral data, and 
isotopologues associated with each feature. You can save your 
feature extraction progress to a project to review, adjust, and 
reprocess at a later time.

The feature files generated by Profinder (CEF files) can be 
imported into Agilent Mass Profiler Professional (MPP), a 
chemometrics platform used in any MS-based differential 
analysis to determine relationships among two or more sample 
groups and variables. Profinder Archive files (PFA files) 
containing extracted compound features and sample group 
information are imported into Omix Premium, a visualization 
platform, to view your data in combination with biochemical 
networks, including isotopologue results as part of a metabolic 
flux analysis.

What’s new in B.08.00?

• Isotopologue feature extraction support is added for 
metabolic flux analysis in MassHunter VistaFlux Software.

• Profinder Archive export provides a single-file transfer of 
project data to Omix Premium.

• Untargeted and recursive feature extraction is supported for 
GC/Q-TOF and GC/MSD.

• Targeted All Ions fragment confirmation is supported for 
LC/TOF, LC/Q-TOF and GC/Q-TOF data files.

• Additional feature extraction algorithms are multithreaded 
and memory optimized to support large projects and 
datasets.
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Features of Profinder
Features of Profinder

• Open all of the files associated with your Agilent TOF and 
Q-TOF MS data set (sample files) in a single selection 
process.

• Create methods for your feature extraction and 
chromatographic alignment by following a guided 
step-by-step wizard for the selected algorithm.

• Choose from five feature extraction algorithms: 

• Batch Molecular Feature Extraction

• Batch Recursive Feature Extraction (small 
molecules/peptides)

• Batch Recursive Feature Extraction (large molecules)

• Batch Targeted Feature Extraction

• Batch Isotopologue Extraction

• Extract the features from all of the data files in your data set 
by running a single algorithm.

• Automatically generate an extracted ion chromatogram (EIC) 
and extracted compound chromatogram (ECC) for each 
feature found in each data file.

• Review the chromatographic integration/alignment, mass 
spectra, and isotopologues using an intuitive graphical 
interface.

• Curate the features in your data post-analysis.

• Export your extracted features via three file formats:

• Compound exchange format (CEF) is a file format that is 
used to exchange data between Agilent MassHunter 
software. CEF files, for example, are imported into 
MassHunter Mass Profiler Professional for statistical 
analysis.

• Comma separated values (CSV) is an ASCII text file that is 
readily imported into text editors and spreadsheets.

• Profinder Archive (PFA) is a binary file format used to 
transfer your features to Omix Premium for metabolic flux 
analysis and visualization within the context of 
biochemical networks.
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Where is Profinder used in your experiment?
• Save your feature extraction parameters as Profinder 
methods.

• Save your feature extraction progress as a Profinder project 
file and open the project at a later time to review, adjust, and 
reprocess your data files.

Where is Profinder used in your experiment?

Profinder is used to extract the features from LC/TOF, 
LC/Q-TOF, GC/Q-TOF, and GC/MSD data files you acquired 
from your experimental samples. An untargeted differential 
analysis experiment may include the steps shown below.

1 Prepare for your experiment

2 Acquire your data - Data Acquisition

3 Extract the spectral features - Profinder

4 Perform a differential analysis - Mass Profiler Professional

5 Identify features in your data - ID Browser

6 Perform advanced analysis operations - Mass Profiler 
Professional

7 Visualize your Profinder results within biochemical 
networks - Omix Premium

Figure 1 shows the steps and Agilent tools that are used in an 
untargeted differential analysis and visualization in 
biochemical networks. Some of the feature finding steps 
performed by Profinder can alternatively be accomplished using 
a sequence of steps involving MassHunter Qualitative Analysis, 
DA Reprocessor, and MPP as described in the Agilent 
Metabolomics Workflow - Discovery Workflow Guide. 
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Where is Profinder used in your experiment?
Figure 1 MassHunter Profinder is an optimized feature extraction 

tool.
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Where to Find More Information
Where to Find More Information

Online Help

Press F1 To get more information about a window or dialog 
box, place the cursor on the window or dialog box of interest 
and press F1.

Help Menu Click Help > Contents to access the contents of the 
Profinder Help including wizards, basic tasks, user interface, 
and reference information.

  Click Help for information specific to wizards.

Documents

Mass Profiler Professional 

• Agilent G3835AA MassHunter Mass Profiler Professional 
Software - Quick Start Guide

• Agilent G3835AA MassHunter Mass Profiler Professional 
Software - Familiarization Guide

• Agilent G3835AA MassHunter Mass Profiler Professional 
Software - Application Guide

• Agilent MassHunter Mass Profiler Professional User Manual

Workflow Guides and Overviews 

• MassHunter VistaFlux Software - Workflow Guide

• Agilent Metabolomics Workflow - Discovery Workflow Guide

• Agilent Metabolomics Workflow - Discovery Workflow 

• Integrated Biology with Agilent Mass Profiler Professional - 
Workflow Guide

• Integrated Biology with Agilent Mass Profiler Professional - 
Workflow Guide Overview

• Class Prediction with Agilent Mass Profiler Professional 
Workflow Guide
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Where to Find More Information
• Class Prediction with Agilent Mass Profiler Professional 
Workflow Overview

MassHunter Qualitative and Quantitative Analysis 

• MassHunter Qualitative Analysis Familiarization Guide for 
LC/MS 

• MassHunter Quantitative Analysis Familiarization Guide

Training

Road Show Slide Presentation Metabolome Analysis - From 
Sample Prep Through Data Analysis (Metabolomics Road Show, 
March 2011)

Training Courses  Visit www.chem.agilent.com to view a listing 
of training courses for MPP.
Profinder Quick Start Guide 7
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Getting Started

How do I get started?
Getting Started

How do I get started?

This Quick Start Guide helps you install Profinder, review the 
Profinder user interface, and perform feature extraction using 
your data.

1 Install Profinder. Follow the instructions in “Profinder 
Installation” on page 39.

2 Launch Profinder. Double-click the Profinder icon  
located on your desktop, or click Start > All Programs > 
Agilent > MassHunter Workstation > Profinder B.08.00.

3 Review the following three sections in this Quick Start 
Guide:

“User Interface” on page 9

“Basic Profinder Workflow” on page 19

“Feature Extraction Workflow Algorithms” on page 31

4 Review the Agilent Metabolomics Workflow - Discovery 
Workflow Guide. This guide helps you improve your results 
by covering topics that help you:

• Prepare for an experiment

• Explain the parameters related to finding features

• Perform an initial differential analysis using MPP

5 Extract the features in your samples following the example 
Basic Profinder Workflow (see “Basic Profinder 
Workflow” on page 19).
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User Interface

Main Functional Areas
User Interface

A feature may be referred to as a compound, molecular feature, 
element, or entity during the various steps of analysis using 
Agilent MassHunter software.

Help and detailed information regarding the various 
parameters and statistical treatments are available when you 
press F1 or click Help > Contents from the menu bar.

Main Functional Areas

The main Profinder window consists of three parts: (1) the 
Menu Bar, (2) the Toolbar, and (3) the Main Window. The main 
functional areas are shown in Figure 2.

Figure 2 The main functional areas of Profinder as viewed before you begin a project.
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User Interface

Main Functional Areas
1. Menu Bar

The menu bar (Figure 3) provides actions that are used for 
managing your projects, methods, display, and extracting 
features.

Figure 3 Menu bar

2. Toolbar

The toolbar is located below the menu bar and contains five 
groups of buttons for commonly performed tasks:

Project New project, Open project, and Save project

Samples Add sample files to your new or current project.

Button Equivalent Command

File > New Project

File > Open Project

File > Save Project

Button Equivalent Command

File > Add/Remove Sample Files
10 Profinder Quick Start Guide



User Interface

Main Functional Areas
Main Window Display or hide the various tables and results generated by 
Profinder, so you can increase the available display area for 
your review.

Feature Coloring Toggle the feature coloring by sample group.

Extraction Select the feature selection algorithm you want to review, edit, 
and apply to your data set.

Button Equivalent Command

View > Compound Groups

View > Compound Details

View > Chromatogram Results

View > MS Spectrum Results

View > Isotopologue Results

Button Equivalent Command

Edit > Color by Sample Group

Button Equivalent Command

Wizards > Batch Molecular Feature Extraction

Wizards > Batch Recursive Feature Extraction

---------------- (small molecules / peptides)

Wizards > Batch Recursive Feature Extraction

-------------- (large molecules)

Wizards > Batch Target Feature Extraction

Wizards > Batch Isotopologue Extraction
Profinder Quick Start Guide 11



User Interface

Main Functional Areas
Results Modes Select the display mode and display options to use in your 
results windows.

3. Main Window

The main window, see Figure 2 on page 9, is further divided into 
up to five windows — (3a) Compound Groups, (3b) Compound 
Details, (3c) Chromatogram Results, (3d) MS Spectrum Results, 
and (3e) Isotopologue Results that are used to review the results 
from applying the feature extraction method to your data set. 
Each window can be floated independently to any location and 
size on your computer display or arranged to your preference 
within the main window. The various windows are described in 
the following pages.

Button Equivalent Command

List mode, no equivalent command

Sample group mode, no equivalent command

Overlaid mode, no equivalent command

Maximum number of chromatograms or 

spectra to display, no equivalent command

Configuration > Plot Display Options
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User Interface

Main Functional Areas
Compound Groups The data presented in Compound Groups is 
organized as a list of all of your extracted feature data averaged 
and summarized across all of the data files in your project.

The Compound Groups window shows a table of 
compound-level information for each feature extracted from at 
least one data file, if the data was extracted using Batch 
Molecular Feature Extraction, or for all targeted features, if the 
data was extracted using Batch Targeted Feature Extraction or 
Batch Isotopologue Extraction. Semi-quantitative information is 
shown as the average value for the feature across all of the files 
where the feature was found.

A compound group is a single compound (feature) found in any 
one or more of the data files in a project. For example, if the 
first data file in the project yields 35 compounds, then at least 
35 compound groups are in the project. If additional unique 
compounds are found in the other data files, then additional 
compound groups are created. 

Information regarding the available columns are found in the 
online Help in the topic “Compound Groups Columns.” A list of 
the available columns is displayed when you right-click within 
the Compound Groups table, and then click Add/Remove 
Columns (see Figure 4 on page 17).

Compound Details The data presented in Compound Details is 
organized as a list of the appearance of a selected feature 
(compound) in all of the data files in your project - feature 
information by data file.

The Compound Details window shows a table of compound-level 
information for a single feature selected in the Compound 
Groups window. The quantitative information is shown for the 
selected feature as it is found in each data file in your project.

Information regarding the available columns are found in the 
online Help “Compound Details Columns.” A list of the available 
columns is displayed when you right-click within the Compound 
Details table, and then click Add/Remove Columns (see 
Figure 4 on page 17).
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User Interface

Main Functional Areas
The Flags (Tgt) column, highlighted, provides a feature 
extraction summary for each isotopologue for the selected 
compound, for each sample data, file based on warning, or error 
flags, reported from the Find by Formula algorithm.

? = no errors (qualified)

The isotopologue qualified and was used in the 
calculation.

M =  m/z tolerance (disqualified)

The isotopologue was disqualified for not meeting the m/z 
tolerance.

T = time correlation (disqualified)

The isotopologue was disqualified for not coeluting.

_ =  no peak (disqualified)

The isotopologue was disqualified because its EIC did not 
have enough contiguous non-zero points.

Chromatogram Results Chromatogram Results presents the 
extracted ion chromatogram (EIC) for each feature and, for 
isotopologue extraction results, the sum of the EICs for all of 
the isotopologues. For non-targeted feature extraction, the 
extracted compound chromatogram (ECC) is displayed for the 
ions contained in the molecular feature of the feature selected 
in the Compound Groups window. An EIC/ECC set is displayed 
for each data file. By default the chromatograms are displayed 
in an alternating cycle of ten colors to help you review the data 
for a particular data file as you select different features. Color 
by Sample Group displays the samples in an alternating cycle 
of colors based on the sample group assignment.
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User Interface

Main Functional Areas
MS Spectrum Results MS Spectrum Results presents the 
averaged mass spectrum (MS) across the integrated ECC for the 
feature selected in the Compound Groups window for each data 
file. For isotopologue extraction results the mass spectra re 
presented across the isotopologue extraction region. By default 
the MS is displayed in an alternating cycle of ten colors, 
matched with the Chromatogram Results, to help you review 
the MS data for a particular data file as you select different 
features. Color by Sample Group displays the samples in an 
alternating cycle of colors based on the sample group 
assignment.

Isotopologue Results Isotopologue Results presents a sequence 
of charts, or a single chart, depending on the results mode 
selected from the toolbar (see “Results Modes” on page 12).

List mode displays the isotopologue results for each sample 
file. The isotopologue charts are arranged in the order of 
your sample groups with each sample replicate displayed in 
an alternating cycle of ten colors, matched with the 
Chromatogram Results and MS Spectrum Results. The 
coloring can be changed to represent the sample groups by 
selecting Color by Sample Group from the toolbar.

Sample group mode displays the isotopologue results for 
each sample group. Each sample replicate is displayed within 
each group chart in an alternating cycle of ten colors, 
matched with the Chromatogram Results and MS Spectrum 
Results. The coloring can be changed to represent the sample 
groups by selecting Color by Sample Group from the toolbar.

Overlaid mode displays a single summary chart of the 
isotopologue results. The summary chart contains the 
average and standard error for each isotopologue per sample 
group presented in gray scale. The sample groups can be 
viewed in color by selecting Color by Sample Group from the 
toolbar.

The order of the appearance of the samples and sample 
groups is set in the Add/Remove Sample Files dialog box. 
The compound containing the isotopologues is selected in the 
Compound Groups window.
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User Interface

Shortcut menu commands
The chart y-axes can be scaled to raw abundances (Raw), raw 
abundances normalized to 100% (Raw (%)), natural isotope 
abundance corrected abundances (Corrected), and natural 
isotope abundance corrected and normalized to 100% 
(Corrected (%)).

Raw: The actual abundances of each isotopologue by sample 
data file, or average abundance of each isotopologue when 
the data is viewed in the summary chart.

Corrected: The abundance for each isotopologue is corrected 
to remove the natural isotopic contributions so that the 
abundance is due to the isotopic enrichment from the 
qualitative flux analysis.

Raw (%): The actual relative abundances of each 
isotopologue by sample data file, or average of each 
isotopologue when the data is viewed in the summary chart.

Corrected (%): The relative abundance for each isotopologue 
after the abundance for each isotopologue is corrected to 
remove the natural isotopic contributions so that the 
abundance is due to the isotopic enrichment from the 
qualitative flux analysis.

Shortcut menu commands

A right-click in any of the main window shows you a menu of 
options (Figure 4 on page 17) applicable to where you click and 
to your current selection. Options available include customize 
the columns in the table views, copy to the system clipboard, 
and delete compound groups or individual compounds.
16 Profinder Quick Start Guide



User Interface

Definitions
Figure 4 The shortcut menu commands available within the main 

window automatically adjust based on the active window.

Definitions

Algorithm An algorithm is a set of automated, sequential mathematical 
tasks performed to find, filter, align, and extract features from 
your chromatographic/mass spectral data sets.

Feature A feature is synonymous with compound. A feature is referred 
to interchangeably with compound, molecular feature, element, 
or entity during the various steps of analysis using Agilent 
MassHunter software.

Isotopologue Molecules that contain the same molecular formula and 
structure but differ in their isotopic composition through the 
substitution of one or more atoms with a different isotope.

Isotopomer Molecules that contain the same molecular formula, structure, 
and number of isotopes but differ in the location of the isotopes 
in the molecular structure.

Method A method is a set of parameters that are associated with the 
feature extraction algorithms used by Profinder. Methods 
containing the parameters for the algorithms can be saved using 
unique file names.

Chromatogram Results

Compound Groups &
Compound Details

MS Spectrum Results

Isotopologue Results
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User Interface

Help
Wizard A wizard is a sequence of interactive steps used by Agilent 
MassHunter software to guide you through the steps necessary 
to complete an analytical task. Profinder uses a set of wizards to 
guide you through the parameters associated with each feature 
extraction algorithm.

Workflow A workflow is an Agilent document or a graphical overview that 
captures a sequence of steps to guide you through an analytical 
task. A workflow may cover more than one wizard and may 
include steps performed by more than one Agilent MassHunter 
software program.

Help

Online Help and detailed information regarding the various 
fields and statistical treatments are available by pressing F1, 
clicking , or clicking Help > Contents from the menu 
bar.

Unsaved parameter changes

When you make a change to a parameter in Profinder, the 
software automatically places a change icon  (a blue triangle 
shape) in the wizard tab and next to the value containing the 
parameter where you made a change. This icon indicates that 
you have unsaved parameters changes and helps you remember 
to save the changes you have made to the method. The original 
parameter value may be viewed by placing your pointer over the 
change icon. When you save your method, the change icon(s) 
disappear.
18 Profinder Quick Start Guide



Basic Profinder Workflow

Unsaved parameter changes
Basic Profinder Workflow

The basic Profinder workflow guides you through the steps 
necessary to extract features from your sample files. The steps 
shown in Figure 5 are described in the following sections:

• “Add sample files to your project” on page 20

• “Edit and run your feature extraction algorithm method” on 
page 24

• “Export your Profinder features” on page 26

• “Save your Profinder method” on page 29

• “Save your Profinder project” on page 30

Figure 5 The basic Profinder workflow (see the MassHunter VistaFlux Software - Workflow Guide for the 

Profinder Batch Isotopologue Extraction workflow)
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Basic Profinder Workflow

Add sample files to your project
Add sample files to your project

In this task, you launch Profinder, select your sample files, and 
add the sample files to your Profinder project.

Steps Detailed Instructions Comments

1 Start Profinder. • Click the Profinder icon  on your 

desktop, or click Start > All Programs 

> Agilent > MassHunter Workstation 

> Profinder B.08.00.

• The first time you start Profinder it 

displays in full screen. Subsequent 

program launches remember the 

screen size from your prior session.

2 Begin your Profinder project by 

adding sample files.

• Click File > Add/Remove Sample 

Files, or click 

 on the 

toolbar.

• If you click File > New Project 

after starting Profinder, you are 

automatically prompted to add 

sample files.

• When you click Add/Remove 

Sample Files after launching 

Profinder, Profinder starts a new 

project as if you clicked File > New 

Project.

3 Add files to the Add Sample Files 

dialog box.

• Click Add file(s) to display the Open 

file dialog box.
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Basic Profinder Workflow

Add sample files to your project
4 Select all of the sample data files 

in the Open file dialog box.

a Browse to the folder containing your 

sample files.

b Select all of the sample data files for 

your Profinder project.

c Click Open.

• Selected sample data files are 

highlighted in the Open file dialog 

box.

• A Profinder project contains all of 

the sample data files from your 

experiment - replicates samples for 

each condition (group) in your 

experiment.

• You can click Add Sample Files, to 

add additional sample data files to 

your project and rerun feature 

extraction.

Steps Detailed Instructions Comments
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Basic Profinder Workflow

Add sample files to your project
5 Enter Sample Group values to the 

sample files in the Add Sample 

Files dialog box.

a Click the data entry cell under the 

Sample Group column, next to the 

sample file name.

b Enter the sample group identification 

text.

c Repeat for each sample file.

• When a data entry cell is selected it 

is highlighted using a background 

color.

• When entering Sample Group 

values, the entries must use 

identical letters, numbers, 

punctuation, and case in order for 

the grouping functions to perform 

properly. 

• Use the Copy, Paste, and Fill Down 

shortcuts (click the right mouse 

button) to help assign Sample 

Group values to each sample.

6 Mark the samples to add to your 

project.

a Mark the samples to add to your 

project in the Show/Hide column.

b Click OK.

• All of the Samples in the same 

project must have the same 

polarity. If some of the Samples 

have a Positive Polarity and some 

have a Negative Polarity an error 

message is shown when you click 

OK.

Steps Detailed Instructions Comments
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Basic Profinder Workflow

Add sample files to your project
Your new Profinder project is now begun.

The Feature Extraction Workflow immediately prompts you to 
select a feature extraction algorithm and then guides you 
through the steps to edit and run the feature extraction method.
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Basic Profinder Workflow

Edit and run your feature extraction algorithm method
Edit and run your feature extraction algorithm method

Batch feature extraction performed by Profinder is part of a 
workflow for statistical data analysis, qualitative flux analysis, 
and data visualization in biochemical networks.

• Batch Molecular Feature Extraction

• Batch Recursive Feature Extraction [default selection]

• for small molecules / peptides [default selection]

• for large molecules (intact proteins)

• Batch Targeted Feature Extraction

• Batch Isotopologue Extraction

An overview of each extraction algorithm is found in the section 
“Feature Extraction Workflow Algorithms” on page 31. Batch 
Isotopologue Extraction is optimized to extract isotopologues 
for targeted features for qualitative flux analysis.

Steps Detailed Instructions Comments

1 Select the feature extraction 

algorithm to apply to your samples.

a Click one of the batch extraction 

algorithms.

b Click Next.

• MFE performs chromatographic 

deconvolution and aligns the 

features across the selected 

sample files using mass and RT. 

See “Batch Molecular Feature 

Extraction” on page 31 for the 

wizard steps.

• RFE performs MFE and then uses 

the mass and RT of each feature to 

automatically perform a targeted 

feature extraction. See “Batch 

Recursive Feature Extraction” on 

page 32 for the wizard steps.

• TFE uses an input formula source to 

extract features. See “Batch 

Targeted Feature Extraction” on 

page 34 for the wizard steps.

• IE locates possible isotopologues of 

target compounds. See “Batch 

Isotopologue Extraction” on 

page 35 for the wizard steps.
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Basic Profinder Workflow

Edit and run your feature extraction algorithm method
2 Review and edit the parameters for 

the feature extraction algorithm.

a Make changes to the parameters on 

each wizard tab for each step.

b Click Next to go to the next step of the 

wizard.

c Click Previous to return to an earlier 

step.

• Click Help to activate online Help 

specific for the current tab in the 

wizard.

• Click Cancel to stop editing the 

algorithm parameters. Any changes 

made to the algorithm parameters 

are not saved.

3 Run the feature extraction 

algorithm.

a Click Finish to run the extraction 

algorithm on your sample data.

b An Operation in Progress dialog box 

is displayed while the extraction 

process is running.

• The feature extraction process can 

take a long time. To significantly 

improve performance, increase the 

amount of memory and use a faster 

processor.

4 Review your results. • Review your results and then export 

the results and save your method.

• Using the Compound Groups, 

Compound Details, Chromatogram 

Results, and MS Spectrum Results 

windows, you can edit your results: 

delete a compound group, delete 

abundance from compound details 

window or chromatogram results 

window, and integrate a peak 

manually. More information is 

available in the online Help.

• The next steps in this Quick Start 
Guide help you export your results 

and save your method.

Steps Detailed Instructions Comments
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Basic Profinder Workflow

Export your Profinder features
Export your Profinder features

You save the features in your sample data files to a file format 
called a compound exchange file (CEF) that is used to exchange 
data between Agilent software. CEF files are used to import 
your molecular features into Mass Profiler Professional.

Steps Detailed Instructions Comments

1 Select Export as CEF from the File 

menu.

• Click File > Export as CEF. • Alternate export options include:

• Export as CSV - average Mass 

and RT with actual feature 

abundance for each sample

• Export as Detailed CSV - 

average Mass and RT with all 

actual feature values for each 

sample

• Export as Profinder Archive - 

binary file format used to 

transfer data to Omix Premium

2 Export your features (compounds) 

to CEF files.

a Under Export contents, click All 

compounds.

b Under Exported value override, mark 

the Export median RT/mass instead 

of measured RT/mass check box.

c Under Exported value override, click 

Export missing values as zero 

abundance.

d Under Export destination, click 

At the location of data file. All 

of the CEF files are placed in 

the same folder containing the 

sample data files.

e Click OK.

• The features extracted from your 

sample data files are saved as CEF 

files. A separate CEF file is created 

for each sample data file.

• Export median RT/mass instead of 

measured RT/mass replaces the 

individual mass and RT valves for 

each feature as it appears in each 

sample data file with the median 

values. This aligns the features 

across the sample data files and 

removes the need to perform a 

compound alignment in MPP - the 

MPP compound alignment values 

can be set to as small as 0.001 ppm 

and 0.001 min.

• The export option for missing 

values that you select affects 

downstream statistics, such as 

calculation of means.

• The number of CEF files created is 

identical to the number of sample 

data files in your Profinder project.
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Export your Profinder results for visualization
Export your Profinder results for visualization

You save your Profinder results as a Profinder Archive (PFA) 
file to visualize your results in the context of biochemical 
networks in Omix Premium.

Steps Detailed Instructions Comments

1 Select Export as Profinder Archive 

from the File menu.

• Click File > Export as Profinder 

Archive.

• Alternate export options include:

• Export as CEF - features saved to 

a file format used to exchange 

data between Agilent software.

• Export as CSV - average Mass 

and RT with actual feature 

abundance for each sample

• Export as Detailed CSV - 

average Mass and RT with all 

actual feature values for each 

sample

2 Select your export contents and 

destination.

a Select All compounds under the 

Export contents heading in the Export 

to Profinder Archive (.PFA) dialog 

box.

b Click the Select  button to select 

your export destination folder, and 

enter your file name.
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Basic Profinder Workflow

Export your Profinder results for visualization
3 Navigate to the folder and enter 

your file name.

a Navigate to the folder to save your 

project in the Save Export File to 

dialog box.

b Type a name for File name.

c Click Save to the Export to Profinder 

Archive (.PFA) dialog box.

• The Profinder Archive is not saved 

at this time; it is saved from the 

Export to Profinder Archive (.PFA) 

dialog box.

4 Save your Profinder archive file. a Review your selection, path and file 

name in the Export to Profinder 

Archive (.PFA) dialog box.

b Click OK to save you Profinder archive.

• Your Profinder Archive (PFA) file is 

imported into Omix Premium where 

you can visualize your results in the 

context of biochemical networks.

Steps Detailed Instructions Comments
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Save your Profinder method

You save your Profinder feature algorithm method using a 
unique name.

Steps Detailed Instructions Comments

1 Select Save from the menu bar. • Click Method > Save. • If you have not previously saved 

your method, Save is the same as 

Save As and prompts you for a 

name to save your method.

2 Type the file name and save your 

method.

a Type the name to use for your method 

file in the Save Method dialog box.

b Click Save.

• The Save Method dialog box does 

not appear when you click Save for 

your method if you previously saved 

your method.

• Click Method > Save As if you 

want to save your method using a 

new file name.

• If acquisition parameters exist in 

the current method, you can select 

whether to also save the 

acquisition method parameters to 

the new method.
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Save your Profinder project

This is an optional step. You can save your Profinder project, 
method, and the current sample data file extraction results so 
that you can continue reviewing your results and the extraction 
method at a later time.

Steps Detailed Instructions Comments

1 Select Save Project from the menu 

bar.

• Click File > Save Project. • If you have not previously saved 

your project, Save Project is the 

same as Save Project as and 

prompts you for a name to save 

your project.

2 Type the file name and save your 

project.

a Type the name to use for your project 

file in the Save as dialog box.

b Click Save.

• The Save As dialog box does not 

appear when you click Save Project 

if you previously saved your project.

• Click File > Save Project as if you 

want to save your project using a 

new file name.

• Note: Profinder project files can be 

one GB or more in file size.

• Note: Remember to include the 

original sample data when you 

share a Profinder project.
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Feature Extraction Workflow Algorithms

Five feature extraction algorithms are available in Profinder. 
Each extraction algorithm is designed to efficiently extract the 
features (compounds) in your sample data files. The resulting 
compound groups are imported into your MPP experiment or 
Omix Premium as part of your qualitative flux analysis.

When you begin a new analysis, start with permissive feature 
extraction algorithm parameters and review the results for false 
positive and false negative features. Then adjust the algorithm 
parameters to reduce the appearance of false positive features 
without increasing the loss of actual features - false negative 
features.

Batch Molecular Feature Extraction

Molecular feature extraction (MFE) performs chromatographic 
deconvolution to find the features in your samples. After 
finding the features, the features (compounds) are aligned 
across all of the selected sample files using mass and retention 
time (RT). After performing MFE, Profinder employs an 
algorithm to re-assign ion species using cross-file analysis to 
generate compound groups.

The wizard workflow is shown in Figure 6.

Figure 6 Four steps are presented in the Batch Molecular Feature Ex-

traction wizard.
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Batch Recursive Feature Extraction

Recursive Feature Extraction (RFE) performs MFE, as 
described above, and then uses mass and retention time of the 
results to perform a targeted feature extraction referred to as 
Find by Ion (FbI). Using the untargeted MFE results for a 
targeted FbI feature extraction is referred to as recursive 
feature extraction.

After calculating the median mass, median RT, and composite 
spectrum from the aligned features found using MFE, FbI uses 
the median values to perform a targeted extraction to improve 
the reliability in finding the features in your data. This 
recursive feature finding, combined with replicate samples for 
each of your experiment conditions, improves the statistical 
accuracy of your analysis and reduces the potential for 
obtaining a false positive or false negative answer to your 
hypothesis.

The recursive feature extraction workflow performed by 
Profinder is similar to that outlined in the Agilent 
Metabolomics Workflow - Discovery Workflow Guide. The 
difference is that the feature extraction process happens in a 
single step, in the same application, without moving CEF files 
back and forth between MassHunter Qualitative Analysis, DA 
Reprocessor, and Mass Profiler Professional as illustrated in 
Figure 1 on page 5. For a comparison of feature finding between 
Profinder and MassHunter Qualitative Analysis, refer to Class 
Prediction with Agilent Mass Profiler Professional Workflow 
Guide.

The wizard workflow for small molecules is shown in Figure 7 
on page 33.

The wizard workflow for large molecules is shown in Figure 8 
on page 33.
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Figure 7 Eight steps are presented in the Batch Recursive Feature Extraction for small molecules/peptides 

wizard.

Figure 8 Seven steps are presented in the Batch Recursive Feature Extraction for large molecules (intact 

peptides) wizard.
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Batch Targeted Feature Extraction

Targeted feature extraction (TFE) uses an input formula source, 
CEF file, or database containing molecular formulas, mass, 
and/or retention time information to extract features from your 
data using a process referred to as Find Compounds by 
Formula. After feature extraction is performed, compound 
alignment produces a result such that one compound target can 
only have one compound extracted per data file.

Find Compounds by Formula typically uses molecular formula 
information, like a PCDL, to calculate the ions and isotope 
patterns derived from the formula as the basis to find features 
in the sample data file. When the input molecular features 
contain mass and retention time, as found in CEF file, instead 
of just the molecular formula, TFE calculates reasonable isotope 
patterns and uses these patterns with retention time tolerances 
to find the target features in the sample data files. When the 
input molecular features are filtered from a find process that 
was previously untargeted, the molecular features found using 
Find Compounds by Formula is also referred to as recursive 
finding.

The wizard workflow is shown in Figure 9.

Figure 9 Five steps are presented in the Batch Targeted Feature Extraction wizard.
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Batch Isotopologue Extraction

Batch isotopologue extraction supports only LC/MS acquired 
data.Unlike the other batch feature extraction wizards, target 
retention times are required for this workflow. 

Isotopologue extraction (IE) uses an input CSV file or 
compound database file, PCD/PCDL, containing the target 
feature molecular formulas, mass, and/or retention time 
information, and anticipates that the target compound may 
have undergone some degree of isotope labeling, to extract 
features from your data using a process referred to as Find 
Compounds by Formula. After feature extraction is performed, 
the extraction algorithm determines which of the possible 
isotopologues are actually present, measures the raw 
abundances of the isotopologues, and corrects the 
isotopologues abundances for the natural occurrence of the 
unlabeled ions. 

See the MassHunter VistaFlux Software - Quick Start Guide 
and the MassHunter VistaFlux Software - Workflow Guide for 
additional information.

Isotopes, Isotopomers, Isotopologues, and Mass Spectra

Isotopologues are molecules that contain the same molecular 
formula and structure but differ in their isotopic composition 
through the substitution of one or more atoms with a different 
isotope. The exact location of the isotope in the molecule, while 
important chemically, is not important in flux analysis, just the 
number of isotopes in the molecule. Isotopologues can be 
identified using single-stage MS.

Isotopomers are molecules that contain the same molecular 
formula, structure, and number of isotopes but differ in the 
location of the isotopes in the molecular structure. Isotopomers 
can be identified using advanced MS/MS techniques.

Note: Profinder finds and extracts isotopologues in your sample 
data; it does not find or extract isotopomers. 
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Figure 10 An illustration of how two stable carbon isotopes in a 

four-carbon molecule relate to isotopomers and isotopo-

logues. Isotopologues are viewed in mass spectra during flux 

analyses. 

A simple four carbon molecule, fumaric acid (C4H4O4), is used 
to explain the relationship of isotopes to isotopomers, 
isotopologues, and mass spectra. The most abundant isotope of 
carbon is 12C. However, 13C, also stable, is not nearly as 
naturally abundant as 12C; 13C has a natural occurrence of 1.1% 
of 12C. For simplicity, naturally occurring 13C is considered to 
be negligible; therefore, the mass of the naturally occurring 
four-12C molecule is m (represented as 12C4), and there are no 
positional differences among the isotopes of the carbon atoms.

When a single 13C atom is substituted for one 12C atom, four 
locations are possible where the 13C atom can be placed 
(isotopomers as shown in Figure 10), and each isotopomer has a 
mass of m + 1 (12C3

13C). When two of the 12C atoms are 
replaced with 13C atoms, six isotopomers are possible, and each 
of the doubly substituted molecules has a mass of m + 2 
(12C2

13C2). When three of the 12C atoms are replaced with 13C 
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atoms, four isotopomers are possible, and each isotopomer has 
a mass of m + 3 (12C 

13C3). Finally, when all four of the 12C 
atoms are replaced with 13C atoms, only a single arrangement 
with a mass of m + 4 (13C4) exists. The five different masses m, 
m + 1, m + 2, m + 3, and m + 4 represent the masses of the five 
isotopologues visible in the resulting mass spectra.

Isotopologue mining

Profinder performs isotopologue mining in two stages, an initial 
screening followed by refinement. The initial screening stage 
extracts isotopologue EICs around the target retention time 
range and then evaluates peak mass spectral data to find ions 
that match the predicted list of possible isotopologues. The 
refinement stage uses a self-optimizing peak finder to refine the 
m/z assignment from the profile data and then re-extracts the 
EICs using the new isotopologue m/z values, refines the start 
and end retention time bounds on the newly extracted EICs, 
and then reports both EIC peak area and summed isotopologue 
peak heights as the compound abundances.

The wizard workflow is shown in Figure 11.

Figure 11 One step is presented in the Batch Isotopologue Extraction 

wizard.
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Monitoring your computer while running Profinder

You can monitor your computer’s resources, especially memory, 
while running Profinder. Right-click on the computer taskbar 
and then click Start Task Manager to launch the Windows Task 
Manager. Select the Performance tab to monitor your CPU and 
memory usage.

For additional details regarding your computer’s memory usage 
click Resource Monitor and select the Memory tab. See 
Figure 12. If your memory usage approaches the amount of 
physical RAM, adding additional RAM increases performance.

Figure 12 Monitoring the system and memory resources on your com-

puter.
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Profinder Installation

Standalone MassHunter Profinder Profinder is installed from a 
Setup Wizard, which you run from the main installation 
program. If you have a prior version, uninstall Profinder before 
installing this newer version (see “Uninstall a prior version” on 
page 39).

Right-click ProfinderSetup.exe, and then click Run as 
administrator.

Install Profinder on the highest performing PC you have 
available to reduce the time it takes to extract the features from 
your sample files. Profinder requires a PC running Windows 7 
(64-bit) with at least 8GB of RAM and at least 30GB of available 
disk space.

Note: A PC with 16GB or more of RAM and a solid-state drive 
will see significantly improved Profinder performance and 
reduction in the time it takes to extract features from large data 
sets.

As part of MassHunter VistaFlux Software Profinder is also part 
of the MassHunter VistaFlux Software suite; for Profinder 
installation instructions refer to the software installation 
instructions found in the MassHunter VistaFlux Software - 
Quick Start Guide.

Uninstall a prior version If you have a prior version of Profinder 
installed, you must delete the prior version before installing this 
new version.

1 Click Start > Control Panel.

2 Click Programs and Features.

3 Click Agilent MassHunter Workstation Profinder 
Software.

4 Click Uninstall/Change to uninstall Profinder.
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In this book

The MassHunter Profinder 
Software Quick Start Guide 
presents the first steps to use 
the MassHunter Profinder 
Software. Profinder is part of 
the MassHunter VistaFlux 
software.

This Quick Start Guide 
applies to MassHunter 
Profinder B.08.00 and later 
until superseded, as part of 
the MassHunter VistaFlux 
Software.

For Research Use Only. Not 
for use in diagnostic 
procedures.
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