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The Quantitative Analysis Report Builder Familiarization Guide presents 
step-by-step exercises to help you learn to use the Report Builder program. You 
can do these exercises with the demo batches DrugsofAbuse and LC-QTOF 
Pesticide, shipped with the system in the Data folder of your installation disk, or 
with data you acquire.
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Access the Report Builder
The MassHunter Quantitative Analysis Report Builder software is installed with 
MassHunter Quantitative Analysis.

To access the Report Builder, go to Start > Agilent MassHunter > Report Builder. 
To create a shortcut icon on your desktop, right-click Report Builder in the Start 
menu and select Send to > Desktop.

Report Builder menu
The Report Builder menu contains six sections: Edit, Font, Alignment, Colors, 
Insert, and Preview.

• Use the Edit section to Delete an element.

• Use the Font, Alignment, and Colors sections to set the font styles, results 
alignment, and the fore color and back color in the report template.

• Use the Insert section to insert Page, Textbox, Image, List, Table, and 
Scriptbox elements into a report template.

• Use the Preview section to Setup the Quantitative Analysis batch file that can 
then be used to Preview the report output.
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Access Report Builder PDF Templates
Report Builder PDF Templates are located at: D:\MassHunter\Report Templates\
Quant\PDF-ReportBuilder.

In this directory there are PDF templates for Quant analysis and Unknowns 
analysis. Each of these templates can be opened and edited in the Report 
Builder.

Example report outputs are provided on the MassHunter Quantitative Analysis 
Shipping DVD at \Supplemental\MassHunter\Report Templates\Quant\ Index.
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Before You Begin
Either back up the PDF templates before you modify them, or immediately save 
the PDF template as a new template. Modified or damaged PDF templates can 
only be restored by re-installing the MassHunter Quantitative Analysis software.
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2 Report Template Workflows

Quantitative Analysis - Calibration Report Template 9

Unknowns Analysis - Area Percent Report Template 50

In this section, you will create example report templates from scratch to give you 
a better understanding of how to use the MassHunter Quantitative Analysis 
Report Builder. 
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Quantitative Analysis - Calibration Report 
Template

For this example, you will create a Calibration Report by completing the 
following procedures.

1 Create a new Quantitative Analysis report template on page 9

2 Edit the Batch information table on page 14

3 Add a Calibration Curve table with a graph on page 17

4 Add a Calibration Results table on page 30

5 Add a report title on page 46

6 Preview the report template on page 48

Create a new Quantitative Analysis report 
template 
To create a new Quantitative Analysis report template, select File > New, and 
then select Quantitative Analysis. 

Each template type links to a different dataset. A dataset is an in-memory 
relational database that stores all of the information on and the relationships 
between samples, compounds, qualifiers, and calibration levels. 

In a Quantitative Analysis dataset, a one-to-many (1:n) relationship exists 
between the following tables: 

• Each Batch (sample) has one or more TargetCompounds. 
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• Each TargetCompound (method) has one or more TargetQualifiers 
(method). 

• Each TargetCompound (method) has one or more Peaks (result). 

• Each Qualifier (method) has one or more QualifierPeaks (result). 

• Each TargetCompound has one Calibration with many levels.

As a general rule, Target tables hold the method, and Peak tables hold the 
results:

• TargetCompound table - contains the method information for compounds

• TargetQualifier table - contains the method information for their qualifiers

• Peak table - contains the result information for compounds

• PeakQualifier table - contains the result information for their qualifiers

Insert a list
1 From the Insert pane, click List.

2 Select Compound list, and click OK.
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3 Edit the Data Binding filters. Click the Data Binding field in the Properties 
pane, then click the ellipsis.

a Under Data bindings, select Compound. 



2 Report Template Workflows
Insert a list

Report Builder Familiarization Guide 12

b Under Filters, click New. 

NOTE
An ID is a unique identifier for a table row in a Dataset. IDs such as BatchID, 
SampleID, CompoundID, etc. have system-assigned numbers. The combination 
of IDs can rapidly locate and link to the unique table row in a Quantitative 
Analysis dataset.

c Select ISTDFlag from the Field list, and select != from the Operator list.
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d Enter True in the Fixed value field, and click OK.

e Click OK to close the Data Binding window.
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4 In the Properties pane, under General, click Page Break, then select Between 
from the list.

Edit the Batch information table
1 Select TableBatch from the drop-down menu at the top of the Properties 

pane. This highlights the table filled with batch information in your report. 
Each cell contains a caption, value, or expression.

A table contains a header row, rows, and cells. Table cells can include the 
following:

• (C) - Caption (same term that is displayed in the Quantitative Analysis 
software)

• (L) - Localized text

• (V) - Value (same number that is displayed in the Quantitative Analysis 
software)

• (E) - Expressions (can be used to format numbers and data as desired)
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2 The caption {C:CalibrationLastUpdatedTimeStamp} is too long to fit in its 
cell. Select it, click Content Type in the Properties pane, and select 
LocalizedText from the drop-down menu. 

3 Click Localized Text, then click the ellipsis. 

4 On the bottom row, enter CalibrationLastUpdate in the Key column, and 
Calibration Last Update in the Default Value column. 
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5 Click OK. The caption has been updated in the table.
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Add a Calibration Curve table with a graph
1 Select List-Compound from the drop-down menu at the top of the Properties 

pane. 

2 Click Table. A new table (Table1) appears at the bottom of the report.

In the properties pane, make the following changes:

• Change the Relative Column Width to 1,1,2 to resize the columns in 
relation to the table width

• Enter CalCurve in the ID field to update the table name
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• Enter 100 in the Width Percentage field to resize the table width 

3 To add binding data to the table, click Data Binding in the Properties pane, 
then click the ellipsis. 
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4 Under Data Bindings, click Add. 

5 Enter Calibration for the Binding name and select Calibration from the Data 
name list. In the Filters section, click New. 



2 Report Template Workflows
Add a Calibration Curve table with a graph

Report Builder Familiarization Guide 20

6 Select SampleID from the Field list and = from the Operator list. Select 
Compound from the Binding name list, and select SampleID from the Field 
Name list. Click OK.

7 Add a data binding filter for each of the following configurations:

a Select CompoundID from the Field list, select = from the Operator list, 
select AND from the Concatenation type list, select Compound from the 
Binding name list, and select CompoundID from the Field name list.

b Select CalibrationType from the Field list, select != from the Operator list, 
select AND from the Concatenation type list, and select Method from the 
Fixed value list.
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c Select LevelConcentration from the Field list, select Top from the 
Operator list, select AND from the Concatenation type list, and enter 1 for 
the Fixed value.

8 In the Orders section, click New. 
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9 Select LevelConcentration from the Field name list, and select Ascending 
from the Ascending/Descending list. Click OK. 

10 Click OK to close the Data Binding window.
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11 Select the empty cell to the left of the Header, and click Textbox.

12 Right-click the cell and select Textbox Properties. 
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13 Select Field value, select Compound from the Binding name list, and then 
select CompoundName from the Field list.
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14 On the Font tab, select Bold, and click OK.

15 Right-click the Header cell and select Textbox Properties. 
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16 Select Field Caption, select Compound from the Binding name list, and select 
RelativeStandandError from the Field list. 

17 On the Font tab, select Bold, and click OK. 
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18 Select the cell to the right of {C:RelativeStandardError} and click Textbox. 

19 Right-click the cell and click Textbox Properties. 
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20 Select Field Value, select Compound from the Binding name list, and 
RelativeStandardError from the Field list. Click OK.

21 To use the same format in the current cell as is found in the Quantitative 
Analysis software, double-click Field Format in the Properties pane, and 
select Compound from the Binding Name list, and RelativeStandardError 
from the Field Name list. 
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22 To add a graphic, select the empty cell below {V:CompoundName}, click 
Graphics, and select Calibration Curve. 

23 To resize the graphic, in the Properties pane, enter 3 for Column Span and 
180pt for Height.

ID fields like BatchID, SampleID, and CompoundID have system-assigned 
numbers which help to rapidly locate and link to unique table rows in a 
Quantitative Analysis dataset. To edit the ID fields, expand the ID section in the 
Properties pane. Enter the values for each ID:

• BatchID

• Field Value: Compound-BatchID

• Binding Name: Compound

• Field Name: BatchID

• CompoundID

• Field Value: Compound-CompoundID

• Binding Name: Compound

• Field Name: CompoundID

• SampleID

• Field Value: Compound-SampleID
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• Binding Name: Compound

• Field Name: SampleID 

Add a Calibration Results table
1 Select List-Compound from the list at the top of the Properties pane, and 

click Table. 
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2 In the Properties pane, adjust the number of columns by changing the 
Column Count to 8, and adjust the widths of the columns by changing 
Relative Column Widths to 3,1,1,1,1,1,1,1. Enter CalResults for ID, and 100 for 
Width Percentage.

3 To add a border to the table, select Solid from the Line Style list and select a 
Color for each of the cell borders. 

4 Repeat steps 3-10 from the section Add a Calibration Curve table with a 
graph on page 17 to add binding data to the table.
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5 Select the first cell in the first row of the table, and click Textbox. 
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6 Right-click the cell and select Textbox Properties. Select Field Caption, select 
Calibration from the Binding name list, and CalibrationSTDPathName from 
the Field list. 

7 On the Font tab, select Bold. Click OK.
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8 Select the first cell in the second row of the table, and click Textbox. 
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9 Right-click the cell and select Textbox Properties. 

10 Select Field Value, select Calibration from the Binding name list, and select 
CalibrationSTDPathName from the Field list. Click OK. 
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11 Select the cell labeled Header, and click Textbox. 



2 Report Template Workflows
Add a Calibration Results table

37 Report Builder Familiarization Guide

12 Right-click the textbox, and select Textbox Properties. 

13 Select Field Caption, select Calibration from the Binding name list, and 
CalibrationType from the Field list. 
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14 On the Alignment tab, select Left from the Horizontal list. 

15 On the Font tab, select Bold. Click OK.
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16 Select the cell labeled Data, and click Textbox. 

17 Right-click the cell, and select Textbox Properties. 
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18 Select Field Value, select Calibration from the Binding name list, and select 
CalibrationType from the Field list. 

19 On the Alignment tab, select Left from the Horizontal list. Click OK.
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20 For the cells in the third column, use the instructions in the previous steps to 
select Calibration and LevelName for the Field Caption of the cell in the first 
row, and Calibration and LevelName for the Field Value of the cell below it. 
Bold the text of the cell in the first row, and change the horizontal alignment 
of both cells to Center. Click OK.

21 For the cells in the fourth column, select Calibration and LevelEnable for the 
Field Caption of the cell in the first row, and Calibration and LevelEnable for 
the Field Value of the cell below it. Bold the text of the cell in the first row, and 
set the horizontal alignment of both cells to Center. Click OK.
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22 For the cells in the fifth column, select Calibration and LevelConcentration for 
the Field Caption of the cell in the first row, and Calibration and 
LevelConcentration for the Field Value of the cell below it. Bold the text of the 
cell in the first row, and set the horizontal alignment of both cells to Right. 
Click OK.

23 To use the same format in the {V:LevelConcentration} cell as is found in the 
Quantitative Analysis software, double-click Field Format in the properties 
pane, and select Calibration from the Binding Name list, and select 
LevelConcentration from the Field Name list. 
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24 For the cells in the sixth column, select Calibration and LevelResponse for 
the Field Caption of the cell in the first row, and Calibration and 
LevelResponse for the Field Value of the cell below it. Bold the text of the cell 
in the first row, and set the horizontal alignment of both cells to Right. 

25 Select the {V:LevelResponse} cell, double-click Field Format in the Properties 
pane, and select Calibration from the Binding Name list and LevelResponse 
from the Field Name list. 
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26 For the cells in the seventh column, select Calibration and 
LevelResponseFactor for the Field Caption of the cell in the first row, and 
Calibration and LevelResponseFactor for the Field Value of the cell below it. 
Bold the text of the cell in the first row, and set the horizontal alignment of 
both cells to Right. 

27 Select the {V:LevelResponseFactor} cell, double-click Field Format in the 
Properties pane, and select Calibration from the Binding Name list and 
LevelResponseFactor from the Field Name list. 
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28 For the cells in the eighth column, select Calibration and LevelRSD for the 
Field Caption of the cell in the first row, and Calibration and LevelRSD for the 
Field Value of the cell below it. Bold the text of the cell in the first row, and set 
the horizontal alignment of both cells to Right. 

29 Select the {V:LevelRSD} cell, and enter F1 in the Format field in the Properties 
pane. 
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Add a report title 
1 Select the {L:Report Title} cell in the page header. Click Localized Text in the 

Properties pane, then click the ellipsis. 

2 Enter Quant Calibration Report in the Default Value column for Header 
Center. Click OK.

3 In the Properties pane, change the font size to 16.
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4 Click File > Save As, and save the template as CalCalibration.template.xml.
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Preview the report template
1 Click Setup. 

2 Click browse in the Setup Preview window, navigate to the DrugsOfAbuse 
folder, and select DOA_Demo.batch.bin. Select QQQ for Instrument type.
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3 Click Preview. A PDF report is generated using the selected batch file.
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Unknowns Analysis - Area Percent Report 
Template

For this example, you will create a Calibration Report by completing the following 
procedures.

1 Create a new Unknowns Analysis report template on page 50

2 Insert a list on page 51

3 Add a Sample Information table with a graph on page 53

4 Add a Compound Results table on page 61

5 Add a report title on page 91

6 Generate a report on page 93

Create a new Unknowns Analysis report 
template 
To create a new Unknowns Analysis report template, select File > New, and 
select Unknowns Analysis.
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Insert a list
1 Click List.

2 Under Data bindings, click Add. Enter Sample in the Binding name field, and 
select SelectedSample from the Data name list. 

3 In the Orders section, click New. Select AcqDateTime from the Field name 
list, and select Ascending under the Ascending/Descending list. Click OK.
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4 Click OK to close the Data Binding window. 

5 Select Page Break in the Properties pane, and select Between from the list.
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Add a Sample Information table with a graph
1 Select List1 from the drop-down menu at the top of the Properties pane. Click 

Table. A new table (Table1) appears in the report.

2 In the Properties pane, make the following changes:

• Change the Column Count to 2 

• Change the Relative Column Widths to 1,3 to resize the columns in 
relation to the table width

• Enter SampleInfo in the ID field to update the table name

• Enter 100 in the Width Percentage field to resize the table width.
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3 To edit a table cell, select the empty cell to the left of the Header cell, and 
click Textbox.

4 Right-click the cell and select Textbox Properties.

5 Select Field caption, then select Sample from the Binding name list, and 
select DataPathName from the Field list.
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6 On the Font tab, select Bold. Click OK. 

7 Right-click the Header cell, and select Textbox Properties. 

8 Select Field Value, select Sample from the Binding name list, and 
DataPathName from the Field list. 
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9 On the Alignment tab, select Left from the Horizontal list. Click OK. 

 

10 For the cells in the second row, use the instructions in the previous steps to 
select Sample and DataFileName for the Field Caption of the cell in the first 
column, and Sample and DataFileName for the Field Value of the cell in the 
second column. Bold the text of the cell in the first column, and set the 
horizontal alignment of both cells to Left. Click OK.
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11 To add rows to the table, select SampleInfo from the list at the top of the 
Properties pane, and click Table Row. Click Table Row 3 more times to add a 
total of 4 rows. 

12 For the cells in the third row, select Sample and SampleName for the Field 
Caption of the cell in the first column, and Sample and SampleName for the 
Field Value of the cell in the second column. Bold the text of the cell in the 
first column, and set the horizontal alignment of both cells to Left.
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13 For the cells in the fourth row, select Sample and AcqMethodFileName for 
the Field Caption of the cell in the first column, and Sample and 
AcqMethodFileName for the Field Value of the cell in the second column. 
Bold the text of the cell in the first column, and set the horizontal alignment of 
both cells to Left.

14 For the cells in the fifth row, select Sample and AcqDateTime for the Field 
Caption of the cell in the first column, and Sample and AcqDateTime for the 
Field Value of the cell in the second column. Bold the text of the cell in the 
first column, and set the horizontal alignment of both cells to Left.

15 To add a graphic, select the empty cell below {C:AcqDateTime}, click 
Graphics, and select Sample Chromatogram.



2 Report Template Workflows
Add a Sample Information table with a graph

59 Report Builder Familiarization Guide

16 To resize the graphic, in the Properties pane, enter 2 for Column Span and 
150pt for Height.

17 ID fields like BatchID and SampleID have system-assigned numbers which 
help to rapidly locate and link to unique table rows in a Quantitative Analysis 
dataset. To edit the ID fields, expand the ID section in the Properties pane. 
Enter the values for each ID:

• BatchID

• Field Value: Sample-BatchID

• Binding Name: Sample

• Field Name: BatchID

• SampleID

• Field Value: Sample-SampleID

• Binding Name: Sample
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• Field Name: SampleID
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Add a Compound Results table
1 Select List1 from the list at the top of the Properties pane. 

2 Click Table. A new table appears at the bottom of the report. 

3 In the properties pane, 

• change the Column Count to 9

• change the Relative Column Width to 1,1,4,1,1,1,1,1,1 to resize the 
columns in relation to the table width
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• enter CompoundResults in the ID field to update the table name

• select False for Keep Together

• enter 100 in the Width Percentage field to resize the table width 

4 To add binding data to the table, click Data Binding in the Properties pane, 
then click the ellipsis.
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5 Under Data Bindings, click Add. 
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6 Enter Component for the Binding name and select Component from the Data 
name list. 
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7 In the Filters section, click New. 

8 Select BatchID from the Field list, and = from the Operator list. Select Sample 
from the Binding name list, and select BatchID from the Field name list. Click 
OK.
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9 In the filters section, click New. 

10 Select SampleID from the Field list, Sample from the Binding Name list, and 
SampleID from the Field Name list. 
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11 In the Orders section, click New. 
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12 Select RetentionTime from the Field name list, and select Ascending from 
the Ascending/Descending list. Click OK. 
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13 Under Data Bindings, click Add. 
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14 Enter Hit in the Binding name field, and select Hit from the Data name list. 

15 Add a data binding filter for each of the following configurations:

a Select BatchID from the Field list,
select = from the Operator list, 
select Sample from the Binding name list, 
and select BatchID from the Field name list. 
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b Select SampleID from the Field list, 
select = from the Operator list,
select AND from the Concatenation type list,
select Sample from the Binding name list, 
and select SampleID from the Field name list. 

c Select ComponentID from the Field list,
select = from the Operator list,
select AND from the Concatenation type list,
select Component from the Binding name list, 
and select ComponentID from the Field name list. 
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d Select HitID from the Field list,
select = from the Operator list,
select AND from the Concatenation type list,
select Component from the Binding name list,
and select PrimaryHitID from the Field name list. 

e Select Visible from the Field list,
select = from the Operator list,
select AND from the Concatenation type list,
and enter True in the Fixed value field. 
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16 Under Data Bindings, select Component, and select Left outer join. 
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17 Under Data Bindings, select Hit, and select Left outer join. All components 
and matching hits are now included in the result table. 
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18 Click OK to close the Data Binding window. 

19 Select the first cell in the first row, and click Textbox. 
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20 Right-click the cell, and select Textbox Properties. 

21 Enter Peak# in the Text field. 



2 Report Template Workflows
Add a Compound Results table

77 Report Builder Familiarization Guide

22 On the Alignment tab, select Center from the Horizontal list. 

23 On the Font tab, select Bold. Click OK. 
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24 Select the first cell in the second row and click Textbox. 

25 Right-click the cell, and select Textbox Properties. 
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26 Select Expression, and enter BoundItems["Component"].ComponentID + 1. 

27 On the Alignment tab, select Center from the Horizontal list. 
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28 For the cells in the second column, enter RT in the Text field for the cell in the 
first row and set the font to Bold. For the cell in the second row, select Field 
value, select Component from the Binding name list, and select 
RetentionTime from the Field list. Set the horizontal alignment of both cells 
to Center.

29 To use the same format in the {V:RetentionTime} cell as is found in the 
Quantitative Analysis software, double-click Field Format in the Properties 
pane, and select Component from the Binding Name list, and RetentionTime 
from the Field Name list.
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30 For the cells in the third column, use the instructions in the previous steps to 
select Hit and CompoundName for the Field Caption of the cell in the first 
row, and Hit and CompoundName for the Field Value of the cell below it. Bold 
the text of the cell in the first row, and change the horizontal alignment of 
both cells to Left.

31 Select the cell in the first row of the fourth column, and click Textbox. 
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32 Click Localized Text in the Properties pane, then click the ellipsis. 

33 On the fourth row, enter StartMin in the Key column, and Start Min in the 
Default Value column. Click OK.
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34 In Textbox Properties, bold the text, and set the horizontal alignment to Right.

35 For the cell in the second row of the fourth column, select Component and 
StartX for Field Value, set the horizontal alignment to Right, and click OK. 
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36 Select the {V:StartX} cell, double-click Field Format in the Properties pane, 
and select Component from the Binding Name list and StartX from the Field 
Name list. 

37 For the cell in the first row of the fifth column, in the Localized Text window, 
enter EndMin in the Key column, and End Min in the Default Value column, 
and click OK. 
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38 For the cell below it, select Component and EndX for Field Value. Bold the text 
of the cell in the first row, and change the horizontal alignment of both cells 
to Right. 

39 Select the cell containing {V:EndX}, double-click Field Format in the 
Properties pane, and select Component from the Binding Name menu, and 
EndX from the Field Name menu. 
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40 For the cells in the sixth column, enter PeakArea for Key, and Peak Area for 
Default Value in the Localized Text window for the cell in the first row, and 
select Component and Area for the Field Value of the cell in the second row. 
Bold the text of the cell in the first row, and change the horizontal alignment 
of both cells to Right. 

41 Select the {V:Area} cell, and select Component and Area in the Field format 
of the Properties pane.
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42 For the cells in the seventh column, enter PeakHeight for Key, and Peak 
Height for Default Value in the Localized Text window for the cell in the first 
row, and select Component and Height for the Field Value of the cell in the 
second row. Bold the text of the cell in the first row, and change the horizontal 
alignment of both cells to Right. 

43 Select the {V:Height} cell, and select Component and Height in the Field 
format section of the Properties pane. 
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44 For the cells in the eighth column, enter Peak%Max for Key, and Peak % Max 
for Default Value in the Localized Text window for the cell in the first row, and 
select Component and AreaPercentMax for the Field Value of the cell in the 
second row. Bold the text of the cell in the first row, and change the horizontal 
alignment of both cells to Right. 

45 Select the {V:AreaPercentMax} cell, and select Component and 
AreaPercentMax in the Field format section of the Properties pane. 
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46 For the cells in the ninth column, enter Peak%Total for Key, and Peak % Total 
for Default Value in the Localized Text window for the cell in the first row, and 
select Component and AreaPercent for the Field Value of the cell in the 
second row. Bold the text of the cell in the first row, and change the horizontal 
alignment of both cells to Right. 

47 Select the {V:AreaPercent} cell, and select Component and AreaPercent in 
the Field format section of the Properties pane. 
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48 Select CompoundResults from the list at the top of the Properties pane. Click 
Columns, then click the ellipsis. 

49 In the Columns window, select Height, and click Move Up. Click OK.
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Add a report title 
1 Select the {L:Report Title} cell in the page header. Click Localized Text in the 

Properties pane, then click the ellipsis. 

2 Enter UA Area Percent Report in the Default Value column for Report Title. 
Click OK.
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3 In the Properties pane, change the font size to 16.

4 Click File > Save As, and save the template as UAAreaPercent.template.xml.
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Generate a report 
1 Open a TIC analysis in MassHunter Unknowns Analysis. 

2 Click Home > Generate Report. 
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3 Under Report method, click Choose, navigate to the relevant folder, and load 
your method.

4 Under Report method, click Edit. 

5 Click Add Template.

6 Search for and select your report template, and click Open.
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7 Click Save & Exit.
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8 Click OK at the bottom of the Report window. A PDF report is generated using 
the selected batch files.
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3 Modify a Report Template

Replace the Agilent Logo with Your Own 98

Replace a Column in the Report 99

Replace a column using the Textbox Properties window 101

Remove a Column From the Report 103

Adjust the Width of a Column 104

Filter Results Using Special Conditions 105

Adjust the Size of a Graphic 107

Add a New Column to an Existing Report 108

Edit an Expression 112

Preview the Report 113

In this section you will modify a report template by completing a series of tasks, 
such as replacing the logo, modifying tables, filtering results, adjusting graphic 
sizes, and adding an expression.
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Replace the Agilent Logo with Your Own
1 Open the Report Builder.

2 Select File > Open.

3 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\
Quant, and open Gen_Samples_ISTD.template.xml.

4 The Agilent logo is in the upper right corner of the report template. This is the 
header section of the report page.

Select the logo graphic. The filename AgilentLogo.tif appears in the right 
panel.

5 If the logo you want to use is in the same file location as the report template, 
enter the file name in the File field, and press Enter.

If the logo you want to use is in a different location than the report template, 
enter the full path of the file in the File field, and press Enter.

6 Save the template.
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Replace a Column in the Report
You can replace a column in a table through either the Columns window or the 
Textbox Properties window.

Replace a column using the Columns window
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Samples_ISTD.template.xml.

2 Right-click the ResponseRatio column header, and select Select > Table 
(Results).

3 In the Columns field in the Properties pane, click the ellipsis.
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4 In the Columns window, select ResponseRatio, and click Remove.

5 Select TargetPeak from the Select columns from: list, select 
SignalToNoiseRatio in the Available columns pane, and click Add.

6 Click Move Up or Move Down to move the column to the desired location.

7 Click OK. The ResponseRatio column is replaced by the SignalToNoiseRatio 
column.
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Replace a column using the Textbox 
Properties window

1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\
Quant, and open Gen_Samples_ISTD.template.xml.

2 Right-click the ResponseRatio column header, and select Textbox Properties.

3 Select SignalToNoiseRatio from the Field Caption > Field list, and click OK.
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4 Right-click the RepsonseRatio value, and select Textbox Properties.

5 Select SignalToNoiseRatio from the Field Value > Field list, and click OK

6 The ResponseRatio column is replaced by the SignalToNoiseRatio column. 
Save the template.
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Remove a Column From the Report
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Samples_ISTD.template.xml.

2 Select the table that contains the QualifierResponseRatio column (Results).

3 In the Column Count field in the Properties pane, change the column count 
from 9 to 8.

The last column in the table, QualifierResponseRatio, is removed.

4 Save the template.

To remove a column that is not the last column in the table:

1 Right-click the column to remove, and select Move Right.

Repeat this step until the column is the last column in the table.

2 In the Column Count field in the Properties pane, reduce the column count by 
1 to remove the last column.

3 Save the template.
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Adjust the Width of a Column
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Samples_ISTD.template.xml.

2 Select a table.

3 In the Relative Column Widths field in the Properties pane, change the values 
to adjust the widths of the columns in the table.

4 Save the template.



3 Modify a Report Template
Filter Results Using Special Conditions

Report Builder Familiarization Guide 105

Filter Results Using Special Conditions
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Sample_AboveLOQ.template.xml.

This report filters results lower than the LOQ. Use this procedure to modify 
the data binding to filter results lower than the LOD.

2 Select the Results table in the Properties pane, and click the ellipsis in the 
Data Binding field.

3 In the Data Binding window, select Target Peak, and then select AND 
<CalculatedConcentration> >= <TargetCompound:LimitOfQuantitation>.
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4 Click Edit.

5 Select LimitOfDetection from the Field name list, and click OK.

6 Click OK.

7 Save the template.
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Adjust the Size of a Graphic
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Samples_ISTD.template.xml.

2 Select the graphic to resize.

3 In the Height and Width Percentage fields in the Properties pane, change the 
values to adjust the size of the graphic.

4 Save the template.
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Add a New Column to an Existing Report
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Samples_ESTD.template.xml.

2 Select the Results table from the Properties pane, and change the Column 
Count value from 8 to 9.

A new empty column is added to the end of the table.
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3 Add a textbox to the empty column header and value. Separately select the 
empty cells in the table, and click Textbox.

4 Right-click the column header textbox and select Textbox Properties.
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5 Select Field caption, select TargetPeak from the Binding name list, and then 
select SignalToNoiseRatio from the Field list.

6 Click OK.

7 Right-click the column value textbox and select Textbox Properties.
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8 Select Field value, select TargetPeak from the Binding name list, and then 
select SignalToNoiseRatio from the Field list.

9 Select True for the Bold field in the Properties pane for the field caption and 
field value.

10 Save the template.
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Edit an Expression
1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\

Quant, and open Gen_Samples_ISTD.template.xml.

2 Select the expression in the FinalConc column in Table 2, and click the 
ellipsis for the Expression field in the Properties pane.

3 Modify the expression as needed in the ExpressionWindow window, and click 
OK.

4 Save the template.
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Preview the Report
After changes have been made to the report template, you can preview the report 
by setting up the Report Builder with your dataset.

1 Navigate to D:\MassHunter\Report Templates\Quant\PDF-ReportBuilder\
Quant, and open Gen_Samples_ISTD.template.xml.

2 Click Preview.

3 In the Setup Preview window, click Browse, then navigate to and select your 
batch file.

4 Select the Instrument type to match your dataset.

5 Click Preview. A PDF report is generated using the batch file selected.
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Navigate the report page by page. Below is an example of page 4 using the 
DrugsofAbuse dataset.
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