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Where to find 

more information

Use the online Help for in-depth information not given in this Quick Start Guide. 
Display online Help in one of two ways:

• Select Contents, Index, or Search from the MassHunter PCDL Manager Help 
menu.

• Press the F1 key to get more information about a window, tab, or dialog box.
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What is MassHunter Personal Compound Database and Library 

Manager?

The MassHunter Personal Compound Database and Library Manager lets you 
manage content in personal compound databases (PCDs) and personal compound 
databases and libraries (PCDLs).

You can use the Agilent Personal Compound Database and Library Manager to 
add, remove and edit the compounds in your PCD/PCDL to meet the specific needs 
of your laboratory and your analyses. You can add retention times to your 
customized PCD/PCDL based on standards and/or retention times for compounds 
you analyze. You can also add your own spectra to your customized PCDL, in 
addition to those provided in the master PCDL.

With MassHunter Qualitative Analysis B.07.00, you can run a database search to 
identify compounds, and then send the MS/MS spectra to your customized PCDL. 
You can also filter spectral noise and correct the product ions to their theoretical 
accurate mass.

You will use the MassHunter Qualitative Analysis program to do automated or 
manual searches of a PCD or PCDL to identify compounds and spectrum peaks in 
your data files, as described in “Searching a PCDL in Qualitative Analysis” on 
page 24.

MassHunter PCDL Manager lets you

• Search for compounds in both PCDs and PCDLs, using text, formula, accurate 
mass, and retention time (optional or required). The use of retention time 
increases the compound identification specificity.

• Search or browse MS/MS spectra in PCDLs.

• Create and edit custom PCDs and PCDLs, including adding proprietary 
compounds, retention times, and theoretically corrected MS/MS and GC/MS 
spectra. 

• Import mass lists with retention time in the form of a .txt or .csv file.

• Send spectra to your customized PCDL directly from the Qualitative Analysis 
program to create your own custom library. Choose from options to filter 
spectral noise and/or to correct the product ions to their theoretical accurate 
mass.

• Load spectra from either a .CEF file or by copy-and-pasting mass spectra from 
MassHunter Qualitative Analysis software and search for those spectra in the 
current PCDL. 
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What is MassHunter Personal Compound Database and Library Manager? 
• Do private, on-site searches, which keep intellectual property safe. 

• Link to websites for more information on compounds. 

Terminology Note A PCD is an accurate mass compound database with or without retention times. 

A PCDL is an accurate mass compound database with optional retention time, 
which also contains one or more MS/MS accurate mass spectra, also referred to as 
a spectral library.

Compound names Many compounds are commonly known as their salts. The mass spectrometer, 
however, detects the anion or cation portion of the salt, rather than the neutral 
salt. PCD and PCDL entries may contain the familiar compound names, but the 
empirical formulae reflect the detectable cation or anion portion of the molecule, 
rather than the formula of the neutral compound salt. For example, the full name 
Vecuronium bromide may be used for identification in the PCDL, even though the 
mass/formula only includes the Vecuronium cation.
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Startup
Installation

If the MassHunter Personal Compound Database and Library Manager is not 
already installed on your system, install it as follows.

1 Insert the MassHunter Personal Compound Database and Library Manager disk 
into the disk drive.

2 From the installation disk, double-click PCDLSetup.exe.

3 Follow the instructions on the screen.

The MassHunter PCDL Manager is installed, along with the following .cdb files:

• PCDL\Sulfas_AM_PCDL.cdb - a small example master PCDL, which can be used 
to create a custom PCDL for importing compounds.

• PCDL\Empty.cdb - an empty master PCDL.

To create a PCDL and import compounds, see “To create a custom PCDL” on 
page 16 and “To import compounds to a custom PCDL” on page 17.

To remove MassHunter PCDL Manager

Use the Add/Remove window of the Control Panel.

Doing this removes the PCDL Manager and master PCDs and PCDLs that have 
been installed, but does not remove custom PCDs and PCDLs you have created.

Startup

1 Select Programs > Agilent > MassHunter Workstation > PCDL Manager from 
the Windows Start menu to start the MassHunter PCDL Manager.

The PCDL that was last used is displayed as the default PCDL to open when you 
start the MassHunter PCDL Manager.

2 To open a different PCDL, see “To open a PCDL” on page 13.
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Toolbar
Main Window

The PCDL Manager main window has the following areas and controls.

• “Toolbar”(below)

• “Menus” on page 6

• “Compound Tabs” on page 8

• “Spectral Tabs” on page 10

Toolbar

The following items are available on the MassHunter PCDL Manager toolbar:

Button Equivalent Menu Item Comments

PCDL > Find Compounds Available only when the Single Search or 
Batch Search tabs are displayed.  
Same as pressing the F5 key. 

PCDL > Find Spectra Available only when the Spectral Search 
or Browse Spectra tabs are displayed.  
Same as pressing the F5 key.

File > Print Results

File > Export Results For use with Batch Summary Results only.

File > New PCDL

File > Open PCDL

View > Autosize Columns

View > Hide Empty Columns

Help > Contents
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Main Window  

Menus
Menus

The following menus are available in MassHunter PCDL Manager:

File menu

New PCDL Lets you create a custom PCDL that can be edited and personalized 
for your lab. This is done by creating a copy of an existing PCDL with a new name 
that can be edited. See “To create a custom PCDL” on page 16.

Open PCDL Lets you open a different PCDL.

Backup PCDL Lets you copy the PCDL for archive purposes.

Create Subset PCDL Lets you create a new PCDL from an input file, which is a 
subset of the currently loaded PCDL.

Import Compounds  Lets you select a file that contains compounds to add to a 
custom PCDL if editing is enabled. If you start with an empty PCDL, then you are 
essentially creating a custom PCDL from the imported compounds.

Export Results Lets you export batch summary results for use with other 
programs, such as spreadsheets and word processors.

Print Results  Lets you print search results and structures.

Exit Closes the MassHunter PCDL Manager window.

Edit menu 

These menu items are for use with custom PCDs and PCDLs with editing enabled 
only and are only available when the Edit Compounds tab is displayed.

Add New Compound Creates a new compound in the PCDL. It has a mass of 0 
and is named “New Compound”. The new compound is displayed at the end of the 
Results table. Enter information such as RT, Formula, Name, and Structure for the 
new compound in the Edit Compounds tab.

Save As New Compound Creates a new compound in the PCDL using the current 
values of the edit fields on the Edit Compounds tab. The new compound is 
displayed at the end of the Results table.
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Menus
Update Selected Compound Updates the information for the selected compound 
in the PCDL. The updated information is reflected in the Results table.

Delete Selected Compound Removes the selected lines of the Results table, which 
removes the selected compounds from the PCDL. Use Ctrl+click or Shift+click to 
select multiple lines.

View menu

Add/Remove Compound Columns Opens the Add/Remove Columns dialog box, 
which lets you specify what information is displayed in the Compound Results 
table.

Restore Default Compound Columns Displays the columns in the Compound 
Results table as they were originally set in the software.

Autosize Columns Changes the width of each column in the compound and 
spectra tables so that the data is visible within its column. All columns in the table 
are resized except for Compound Name, IUPAC Name, and Notes. Columns are 
automatically resized if necessary, when you edit content on the Edit Compounds 
tab or the Edit Spectra tab. You may still need to scroll after using this command.

Hide Empty Columns Automatically hides columns in compound and spectra 
tables that do not have any content. You can display that column again when you 
click Add/Remove Compound Columns.

Structure Details Opens the Structure Details dialog box, which displays the 
current structure in a larger size for easier viewing.

PCDL menu 

Find Compounds Searches the PCDL for compounds that match criteria specified 
on the Single Search tab or Batch Search tab. Only available when either the Single 
Search tab or Batch Search tab is displayed. You can also press the F5 key.

Find Spectra Searches the PCDL for spectra that match criteria specified on the 
Spectral Search tab or Browse Spectra tab. Only available when either the Spectral 
Search tab or Browse Spectra tab is displayed. You can also press the F5 key.

Allow Editing A toggle that enables or disables editing operations to a custom 
PCDL. A master PCDL cannot be edited.
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Main Window  

Compound Tabs
Convert PCDL Opens the Convert PCDL dialog box. You need to convert a PCDL 
which was developed with an older version of PCDL to the format which is used 
with PCDL version B.07.00. Once you convert a PCDL to version B.07.00, you 
cannot use that PCDL in a version of Qualitative Analysis that is before B.07.00.

PCDL Information Opens the PCDL Information dialog box. You can view 
information about the current PCDL and edit the description for custom PCDs or 
PCDLs with editing enabled.

Links menu 

Lets you access websites such as PubChem and ChemSpider for additional 
information on compounds or metabolites. The links displayed depend on the type 
of the current PCDL.

Help menu

Contents, Index, and Search Opens the online Help window for MassHunter 
PCDL Manager, with the appropriate tab displayed.

View EULA Displays the license agreement for MassHunter PCDL Manager in a 
Notepad window.

About Displays the version and build number of the MassHunter PCDL Manager.

Compound Tabs

The following tabs are available for searching, viewing, and editing compounds:

Single Search tab

Lets you search for compounds in the PCDL. Search results are displayed in the 
Compound Results table. See “To find compounds” on page 27.

NOTE
If you open an older PCDL, the program will automatically ask if you want to update to the 
newer format now. A copy of the original PCDL is archived in the 
\MassHunter\PCDL\Archive folder.
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Compound Tabs
Batch Search tab

Lets you search for compounds in the PCDL by specifying a mass list and optional 
retention times. Search results are displayed in the Compound Results table. See 
“To find compounds from a mass list” on page 34.

Batch Summary tab

Shows a summary view of all Best fit hits from a Batch Search. Results can be 
exported for use with other applications. You can also add comments and update 
retention times for custom PCDs or PCDLs with editing enabled. See “To view 
batch summary results” on page 37.

Edit Compounds tab

For custom PCDs or PCDLs that allow editing, you can use this tab to edit 
information for compounds and to add new compounds. Before editing existing 
compounds, do a Single or Batch search, so that the compounds to be modified are 
present in the Compound Results table. See “To edit compounds in a custom 
PCDL” on page 42.

Compound Results

Compound search results are displayed in the lower part of several tabs in the 
MassHunter PCDL Manager window. See “To change how data is displayed in 
results tables” on page 29 for more information on displaying search results.

Clicking on a row of the table displays structure information about that compound 
in the Structures area, if the structure is available in the PCDL.

You can also select compounds in the results table for editing on the Edit 
Compounds and Edit Spectra tabs (custom PCDs or PCDLs with editing enabled 
only). See “To edit compounds in a custom PCDL” on page 42.

Structures 

Structure tab  This area on the right side of compound-related tabs displays 
structure information for the compound currently selected in the Compound 
Results table, if it is available in the PCDL. Clicking the  button opens the 
Structure Details dialog box and displays a larger image of the structure. Both 
MOL structures and glycan structures are supported.
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Spectral Tabs
If the structure attached to the currently selected compound is a glycan format, 
then the glycan cartoon is displayed in the Structures tab. Right-clicking on a 
glycan drawing lets you change the display settings, such as Show Linkage and 
Switch Direction.

MOL Text tab  Displays the text version of the structure. If the current PCDL is a 
custom PCDL with editing enabled, you can copy text from a molecular drawing 
tool that is capable of generating MOL file text or a glycan structure and paste it 
into this area to update the structure of the selected compound. Or you can use the 

 button in the Structure area to load a structure from a .MOL, .kcf, .linucs, or 
.glycoct_condensed file.

Spectral Tabs

The following tabs are available for searching, viewing, and editing spectra:

Spectral Search Tab

Lets you load spectra from a .CEF file or copy-and-paste spectra from Qualitative 
Analysis and search for the spectra in the current PCDL. 

Browse Spectra Tab

Lets you search the current PCDL for spectra that match certain parameters, such 
as mass, collision energy, ion polarity, and ionization mode. Use the default search 
parameters to view all spectra in the PCDL. 

You can also view spectral information for compounds retrieved from the Single 
Search tab or Batch Search tab by clicking on the compound of interest in the 
compound results table in the lower part of the tab.

Spectral results are displayed in the Spectral Information Table in the middle part 
of the tab.

Edit Spectra Tab

You can use this tab to add, delete, and edit spectra in a custom PCDL, if editing is 
enabled for the PCDL. Before editing, you must do a Single or Batch search, so that 
some compounds are present in the compound results table in the lower part of 
the tab.
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Spectral Tabs
Clicking the Precursor Ion or Ion Species column for a particular spectrum brings 
up the Edit Species menu. 

Graphic tab

This area of the spectra-related tabs lets you view selected spectra in graphic 
format. You can see the Acquired spectrum and the Library spectrum.

Mass List tab

This tab shows you the mass list for the current spectra that is displayed in the 
Graphic tab. The mass list consists of a list of masses and relative abundances

NOTE
It is strongly recommended to use the Send Spectra to PCDL feature in MassHunter 
Qualitative Analysis to import spectra to a PCDL when creating your own custom library. 
This feature allows you to filter spectral noise, set a pass/fail base peak height filter, and 
correct the product ions to their theoretical accurate mass.
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Getting Started  
Getting Started

The following topics will help you get started with Agilent MassHunter PCDL 
Manager. This guide and the online Help explain these activities.

• “PCDL operations” on page 13

• “Searching a PCDL in Qualitative Analysis” on page 24

• “Searching a PCDL in MassHunter PCDL Manager” on page 27

• “Doing a batch search” on page 34

• “Editing a custom PCDL” on page 40

• “Spectral searching and editing” on page 44
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To open a PCDL
PCDL operations

The following PCDL operations are described in the following pages:

• “To open a PCDL” on page 13

• “To convert a PCDL” on page 14

• “To back up a PCDL” on page 14

• “To view PCDL information” on page 15

• “To view more information” on page 15

• “To create a custom PCDL” on page 16

• “To import compounds to a custom PCDL” on page 17

• “To create a subset PCDL from an input file” on page 18

• “To send spectra from Qualitative Analysis” on page 19

• “To extract spectra in Qualitative Analysis to send to PCDL” on page 21

To open a PCDL

The PCDL that was last used is displayed as the default PCDL to open when you 
start MassHunter PCDL Manager. Do this step to open a different PCDL.

1 Open the Open PCDL dialog box in either of the following ways:

• Click Open PCDL from the File menu, or

• Click  on the toolbar.

2 Select the file of interest (.cdb extension) and click Open.

3 If the PCDL that you selected is from a previous version of PCDL Manager, then 
you are prompted to update the database to the new format. Click Yes to 
continue. If you click No, then you won’t be able to edit, append or create 
subsets of the database in the older format.

NOTE
Master PCDs and PCDLs cannot be edited, but they can be used to create custom PCDs or 
PCDLs that can be edited. See “To create a custom PCDL” on page 16.
MassHunter PCDL Manager Quick Start Guide 13
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To convert a PCDL
To convert a PCDL

PCDLs from previous versions of MassHunter PCDL can be converted for use in 
MassHunter PCDL B.07.00 and later.

1 Click Convert PCDL from the PCDL menu to open the Convert PCDL dialog 
box.

2 Select the PCDL database that you want to convert (.CDB file extension) and 
click the Convert Button. The database is converted to the latest schema, and 
the name of the converted library is the same name. An archive of the PCDL is 
saved in the Archive folder before it is converted.

To back up a PCDL

1 Click Backup PCDL from the File menu. 

2 Select a folder for the backup file or accept the default folder, which is: 

MassHunter\PCDL\Archive 

3 Type in a file name for the backup file or accept the default file name, which is 
in the form: 

<name>.<yyyy.mm.dd>.cdb 

where name is the name of the current PCDL, yyyy is the current year, mm is the 
current month, and dd is the current day of the month. 

4 Click Save.  
A backup copy of the PCDL is created using the specified file name and 
location.
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To view PCDL information
To view PCDL information

1 Click PCDL Information from the PCDL menu. 

2 View the following information about the PCDL: 

• File name

• # Compounds (entries)

• Master or User

• Type: General, Metabolomics, Pesticides, Forensics, or Glycans

• Edit allowed: Yes or No

• Last modified timestamp

• Version number 

• Description: the description can be edited if the current PCDL is a custom 
PCDL with editing enabled.

3 If you modified the Description or changed the database Type, click Apply.

4 Click Close to close the PCDL Information dialog box.

To view more information

1 Open the Links menu.

2 Click the web link of interest. The available links will vary depending on the 
type of the current PCDL: General, Metabolomics, Pesticides, Forensics, or 
Glycans.

The selected web page will open in your Internet browser window.
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To create a custom PCDL
To create a custom PCDL

1 Click New PCDL from the File menu or click  on the toolbar.

Tip You can also create a custom PCDL by creating a subset of an existing PCDL in 
either of the following ways:

• “To create a subset PCDL from an input file” on page 18

• “To create a subset PCDL from selected compounds” on page 32

2 Do the following steps on the New PCDL dialog box: 

a Select a starting file for the new PCDL. The default path is 
\MassHunter\PCDL. The following files are supplied with the software and 
can be used to create custom PCDLs that you can edit and customize:

• PCDL\Empty.cdb - an empty master PCDL

• PCDL\Sulfas_AM_PCDL.cdb - a small example master PCDL. If you start with 
this PCDL, you will need to remove the example entries in this PCDL before 
using it.

b Select the PCDL type for the new PCDL from the following choices: 
General, Metabolomics, Pesticides, Forensics, or Glycans.

c Type a name for the new PCDL.

d Enter a description for the new PCDL. 

e Click Create to create the new PCDL. 

The new PCDL becomes the current working PCDL and is automatically 
enabled for editing. 

3 You can add compounds to the new PCDL in either of the following ways:

• “To import compounds to a custom PCDL” on page 17 

• “To append compounds to a PCDL” on page 33

• “To send spectra from Qualitative Analysis” on page 19
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To import compounds to a custom PCDL
To import compounds to a custom PCDL

Use the following procedure to import compounds into a custom PCDL or to create 
a custom PCDL from a compound list created by another application. If you start 
with an empty PCDL, then you are essentially creating a custom PCDL from the 
imported compounds.

1 Prepare the import file. The format required for the import file is described in 
the online Help. The .CSV or .TXT file can be created in any of the following ways:

• Exported from MassHunter PCDL Manager as described in “To export batch 
summary results” on page 38.

• Exported from another application such as Agilent Qualitative Analysis, 
Mass Profiler, or GeneSpring MS software.

• Manually in Excel.

2 Open the custom PCDL of interest or create a new PCDL as described in “To 
create a custom PCDL” on page 16.

3 Enable editing on this PCDL by clicking Allow Editing on the PCDL menu. If it 
has a check mark next to this command, you can edit this PCDL.

4 Click Import Compounds from the File menu.

5 Select the .CSV or .TXT file prepared in Step 1 that contains the compounds of 
interest, and then click Open.

6 To view the new compounds in the PCDL, do a search on the Single Search tab 
with no criteria or criteria that you know will find the compounds of interest. 
The compounds will be listed in the Compound Results table. 

7 Compounds that were not imported due to problems with the input file are 
saved in the file <ImportFileName>-ImportLog.csv, where <ImportFileName> is the 
name of the import file selected in Step 5. Examine this log file to determine 
how to fix the problems, and then import the corrected file. 

8 (Optional) See “To edit compounds in a custom PCDL” on page 42 if you want 
to change information for the imported compounds. 

NOTE
During import, the mass is calculated from the formula and that value is used for the 
PCDL. If the difference between the calculated value and the mass contained in the import 
file is > 0.0001 Da, then that compound is added to the log file. Common problems that 
result in mass errors are 1) the mass value is the mass from the spectrum and not a 
neutral mass, and 2) the formula contains the adduct (such as Cl). The information in the 
log file can be used to determine the correct Formula or Mass. 
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To create a subset PCDL from an input file
To create a subset PCDL from an input file

You use the following procedure to create a custom subset PCDL starting from the 
PCDL currently open in PCDL Manager. You can use a Master PCDL or a Custom 
PCDL as the starting template. You can use this procedure to create a small 
customizable subset of one of the Agilent Master PCDLs.

1 Prepare the input file in the proper format, as described in online Help.

2 Open the desired starting PCDL from which you want to create the subset 
PCDL.

3 Click File > Create Subset PCDL to open the Create Subset PCDL dialog box.

4 Select the input file prepared in Step 1.

5 Select the PCDL type (General, Metabolomics, Pesticides, Forensics, or 
Glycans).

6 Type in a name for the subset PCDL.

7 Select whether or not to include mass spectra.

8 Type in a description for the subset PCDL.

9 Click Create.

The subset PCDL is created and a message is displayed that tells the number of 
compounds that were copied into the new subset PCDL.

A log file is created that has a list of the compounds that were not found. The 
log file is created in the same directory as the subset PCDL and with the same 
name, i.e. <name>.log.

10 When a message is displayed to ask if you want to load the new subset PCDL, 
click Yes to load it or No to continue working with the current PCDL.
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To send spectra from Qualitative Analysis
To send spectra from Qualitative Analysis

You use this procedure to send spectra, that have been identified in MassHunter 
Qualitative Analysis, for use in PCDL Manager. These actions are performed in the 
Qualitative Analysis program.

1 Open the MassHunter Qualitative Analysis program.

2 Create the spectrum that you want to send to a PCDL library. See “To extract 
spectra in Qualitative Analysis to send to PCDL” on page 21.

3 Open the Send Spectra to PCDL dialog box.

• Right-click the spectrum in the MS Spectrum Results window and click Send 
Spectra to PCDL.

• Select the spectrum. Then, click Spectra > Send Spectra to PCDL.

4 Select the Library path. The spectra are added to the selected PCDL.

5 (optional) Mark the Minimum base peak height check box. If you mark this 
check box, you can enter the minimum base peak counts that are needed to add 
the spectrum to the library. A default value of 1000 counts has been used and is 
recommended. You can change this value if necessary to achieve desired 
results. This option allows you to set a pass/fail criteria based on base peak 
height to ensure good ion statistics in the spectral library.

6 Click one of the Annotation filter options. You can click either Formula 
annotated peaks (excludes unknowns) if present else all peaks or All peaks. 
When Formula annotated peaks (excludes unknowns) if present else all 
peaks is selected, the program checks that the m/z fragment ions observed are 

NOTE
We strongly recommend that only the lowest monoisotopic ion is 
selected as the precursor ion for use in MS/MS library creation. The 
quadrupole resolution during acquisition must be set to narrow for 
this purpose. Doing this ensures the best possible match to the MS/MS 
fragmentation library when dealing with complex mixtures.

NOTE
Using a large PCDL such as METLIN as a Formula source for 
identification when extracting spectra will result in multiple hits for 
each compound which will need to be manually sorted to identify the 
correct compound.
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To send spectra from Qualitative Analysis
consistent with the assigned precursor ion species and assigns the fragment ion 
species as an annotation above each fragment ion peak.

7 Click one of the m/z selection options. You can click either Calculated m/z if 
present else observed m/z or Observed m/z.

8 Click one of the Conflict resolution options. If the spectrum already exists in 
the library, you can either Send and replace the spectrum in library or Skip 
sending this spectrum. 

If profile or LC/MS spectra are contained in the file, a message is displayed 
saying that they have been skipped. Only identified, centroided MS/MS and 
GC/MS spectra are loaded for use in PCDL Manager.

The spectra appear in the library spectra table. 

To send theoretically mass corrected spectra to a PCDL

The following options have been set as defaults in the Send Spectra to PCDL tab in 
the LibrarySearch-Default.m method. These options need to be re-selected if 
another method file is used.

• Minimum base peak height

• Formula annotated peaks (excludes unknowns) if present, else all data

• Calculated m/z if present else observed m/z

Before sending the spectra to the PCDL, manually inspect each spectrum and 
ensure that all peaks have been annotated. Annotated peaks are green and have 
the formula annotated above each peak. You may need to expand the x-axis to view 
the annotation. In the case that the spectrum itself is green, please click Edit > 
Choose Defined Color and choose a different color.

Any un-annotated peaks indicate the following:

1 An impurity ion which cannot be present according to the assigned precursor 
ion species empirical formula

2 A higher m/z isotope which can be seen when the quadrupole resolution has 
not been set to narrow during data acquisition.

When pure single compound standards have been used along with a quadrupole 
resolution set to narrow during acquisition but un-annotated peaks are still seen, 
please retune and calibrate the instrument before reacquiring data.
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To extract spectra in Qualitative Analysis to send to PCDL
To extract spectra in Qualitative Analysis to send to PCDL

This topic describes how to extract the spectra. To send the spectra to PCDL, see 
“To send spectra from Qualitative Analysis” on page 19.

1 Open the LibrarySearching-Default.m method. 

a Click Method > Open. 

b Select this method

c Click Open.

2 Set up Find Compounds by Formula parameters.

To extract MS/MS spectra and identify compounds, use Find Compounds by 

Formula and extract MS/MS spectra

a In the Method Explorer window, click the Find Compounds by Formula 
> Options tab.

b Click the Results tab.

c Mark the Extract MS/MS spectrum check box.

d Click the Separate MS/MS spectrum per CE button.

e Click the Formula Source tab and select a PCDL database/library that 
contains the compounds of interest.

To extract GC/MS spectra and identify compounds, use Find Compounds by 

Formula

a In the Method Explorer window, click the Find Compounds by Formula 
> Options section.

b Click the Formula Source tab and select a PCDL Database/Library 
containing the compounds of interest.

NOTE
Using a large PCDL such as METLIN as a Formula source will result 
in multiple hits for each compound which will need to be manually 
sorted to identify the correct compound.

NOTE
Using a large PCDL such as METLIN as a Formula source will result 
in multiple hits for each compound which will need to be manually 
sorted to identify the correct compound.
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3 Setup Generate Formulas parameters. 

To Assign correct possible ion species

a In the Method Explorer, click the Identify Compounds > Generate 
Formulas section.

b Click the Allowed Species tab.

c Mark all desired ion species under Charge carrier to be assumed if not 
known.

d Verify that appropriate elements and limits are set under Elements and 
Limits. 

Add fragment annotation.

a Click the Fragment Formulas tab.

b Mark Annotate fragment spectrum peaks with formulas.

Set spectral noise filters.

a Click the Fragment Formulas tab.

b Mark Absolute height and type 10 for the counts.

c Mark Relative height and type 1 for the % of largest peak.

NOTE
For general LC and GC/MS spectrometry, the default value of MS ion 
electron state should be set to Allow both even and odd.

NOTE
The following defaults are set in the LibrarySearching-Default.m 
method. Please verify these options if you are using another method.

NOTE
When Formula annotate peaks with formulas is marked, the program 
checks that the m/z fragment ions observed are consistent with the 
assigned precursor ion species and assigns the fragmented ion species 
as an annotation above each fragment ion peak.

NOTE
The above filters can be adjusted to achieve desired results.
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To extract spectra in Qualitative Analysis to send to PCDL
4 Run the Find Compounds by Formula algorithm. Click Find > Find Compounds 
by Formula.

5 Verify that the compounds are identified properly, and inspect the degree of 
spectral annotation.

Annotated peaks are green and have the formula annotated above each peak. You 
may need to expand the x-axis to view the annotation. In the case that the 
spectrum itself is green, please click Edit > Choose Defined Color and choose a 
different color.

Any un-annotated peaks indicate the following:

1 An impurity ion which cannot be present according to the assigned precursor 
ion species empirical formula

2 A higher m/z isotope which can be seen when the quadrupole resolution has 
not been set to narrow during data acquisition.

NOTE
For large molecules and/or molecules which have a high degree of fragmentation, you 
may need to set the Maximum number of peaks to a value that is higher than 250. This 
value is set on the Fragment Formulas tab.

NOTE
Spectra acquired for library creation must have the quadrupole resolution set to narrow 
during acquisition. However, spectra acquired for library matching purposes can be 
routinely acquired with a lower resolution with the consequence that higher m/z isotopes 
will appear in the sample spectrum but not the library spectrum and will lower the forward 
score.

NOTE
When acquiring spectra for library creation and pure single compound standards have 
been used along with a quadrupole resolution set to narrow during acquisition but 
un-annotated peaks are still seen, please tune and calibrate the instrument again before 
re-acquiring data.
MassHunter PCDL Manager Quick Start Guide 23



Searching a PCDL in Qualitative Analysis  

To use a PCDL to identify ions in a spectrum in Qualitative Analysis
Searching a PCDL in Qualitative Analysis

A mass-only search can be done on an ion in a spectrum or a compound. AMRT 
search can only be done on a compound. MS/MS library search can be done on an 
MS/MS spectra or a compound with MS/MS spectra. GC/MS library search can be 
done on GC/MS spectra or a compound with GC/MS spectra.

Use the following procedures to search a PCDL with MassHunter Workstation 
Software Qualitative Analysis program. These steps apply to version B.07.00 of 
Qualitative Analysis and may be slightly different in later revisions.

To use a PCDL to identify ions in a spectrum in Qualitative Analysis

Do this step to identify ions in a spectrum with a PCDL:

1 Open the data file of interest in Qualitative Analysis.

2 Extract a mass spectrum or extract a peak spectrum as described in Qualitative 
Analysis online Help.

3 Set the search criteria in the Identify Compounds > Search Database section 
of Method Editor:

a On the Search Criteria tab, select Mass as the Values to match option.

b On the Database tab, click the Browse […] button to open the Open 
Database File dialog box.

c Select PCDL Files (.cdb) as the file type to see a list of PCDLs.

d Select the PCDL of interest and click Open.

4 Initiate the search by right-clicking on the spectrum and selecting Search 
Database for Spectrum Peaks from the shortcut menu (or in other ways 
described in Qualitative Analysis online Help).

The PCDL is searched for the masses in the spectrum. If hits are found, 
information such as masses, formulas, and compound names is displayed in the 
DB Search Results window. 

5 Review the results in the Spectrum Identification Results window.
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To use a PCDL to identify compounds by mass or mass and 

retention time in Qualitative Analysis

Do this step to identify compounds with a PCDL:

1 Open the data file of interest in Qualitative Analysis.

2 Find compounds as described in Qualitative Analysis online Help.

3 Select the compounds to search in the Compound List window or Data 
Navigator.

4 Set the search criteria in the Identify Compounds > Search Database section 
of Method Editor:

a On the Search Criteria tab, select Mass as the Values to match option.

b On the Database tab, click the Browse […] button to open the Open 
Database File dialog box.

c Select PCDL Files (.cdb) as the file type to see a list of PCDLs.

d Select the PCDL of interest and click Open.

5 Initiate the search and review the results in the Compound Identification 
Results window.

To search an accurate mass library for spectra in Qualitative Analysis

Do this step to identify spectrum peaks with a PCDL:

1 Open the data file of interest in Qualitative Analysis.

2 Extract a mass spectrum or extract a peak spectrum as described in Qualitative 
Analysis online Help.

3 Set the search criteria in the Identify Compounds > Search Library section of 
Method Editor:

4 On the Libraries tab, click the Add Library button to open the Open Library 
File dialog box. Select ,cdb as the Files of type to see a list of PCDLs. Select a 
library and then click Open to select the PCDL of interest.

5 Initiate the search in one of the following ways:

• Click Identify > Search Library for Spectra

• Click Search Library for Spectra on the Data Navigator Spectra shortcut 
menu

• Click Search Library for Spectra in the MS Spectrum Results shortcut menu

• Click Search Library for Spectra in the Actions menu
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To search an accurate mass library for compounds in Qualitative Analysis
6 Review the results in the Spectrum Identification Results window, the Structure 
Viewer window, and the Spectral Difference Results window. 

To search an accurate mass library for compounds in Qualitative 

Analysis

Do this task to identify compounds with a PCDL.

1 Open the data file of interest in Qualitative Analysis.

2 Find compounds using one of the Find Compounds with MS/MS extraction 
algorithms as described in Qualitative Analysis online Help. 

3 Select the compounds to search in the Compound List window or Data 
Navigator.

4 Set the search criteria in the Identify Compounds > Search Library section of 
Method Editor.

5 On the Libraries tab, click the Add Library button to open the Open Library 
File dialog box. Select ,cdb as the Files of type to see a list of PCDLs. Select a 
library and then click Open to select the PCDL of interest.

6 Initiate the search in one of the following ways:

• Click Identify > Search Library for Compounds

• Click Search Library for Compounds in the Data Navigator Compounds 
shortcut menu

• Click Search Library for Compounds in the Compound List shortcut menu

• Click Search Library for Compounds in the Actions menu

7 Review the results in the Compound Identification Results window.
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To find compounds
Searching a PCDL in MassHunter PCDL Manager

Searching a compound PCDL for compounds matching certain criteria can be 
broken into the following activities, which are described in the following pages:

• “To find compounds” (below)

• “To view compound search results” on page 29

• “To change how data is displayed in results tables” on page 29

• “To print compound results” on page 31

• “To create a subset PCDL from selected compounds” on page 32

• “To append compounds to a PCDL” on page 33

To find compounds

1 If the PCDL you want to search is not already open, click Open PCDL from the 
File menu or click  on the toolbar to open it.

2 Click the Single Search tab.

3 To return the contents of the entire PCDL, leave the search parameters blank 
and skip to Step 6. Otherwise, set the desired mass search criteria:

a Mass and Mass tolerance in ppm or mDa

b Type of mass ([M+H]+, Neutral, or [M-H]-)

• Select [M+H]+ mass type if you are searching for an observed positive ion in 
the compound database. The neutral mass value will be automatically 
calculated, assuming the ion was a positive protonated ion. If Include 
cations is selected in Step 3c, the neutral mass of a cation is calculated.

• Select Neutral mass type if the mass is the calculated neutral mass value, 
usually a value that was calculated by Molecular Feature Extraction (MFE). 
Do not select this value for a mass observed in a spectrum. Ions observed in 
a spectrum have a charge and need to be converted to neutral to work with 
the PCDL. For observed ions use either the [M+H]+ or [M-H]- selection.

• Select [M-H]- mass type if you are searching for an observed negative ion in 
the compound database. The neutral mass value will be automatically 
calculated, assuming the ion was a negative deprotonated ion. If Include 
anions is selected in Step 3c, the neutral mass of an anion is calculated.
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To find compounds
c Mark the options under Ion search mode:

• Include neutrals is typically marked. Clear it if you want to search anions 
and cations only.

• Mark Include anions or Include cations if you also want to consider those 
chemicals that don't pick up or lose a proton to ionize. Searching both modes 
may return false matches. 

• Mark Include anions if the data was acquired in negative ion mode.

• Mark Include cations if the data was acquired in positive ion mode. 

4 Enter Retention time parameters, keeping the following guidelines in mind:

• When searching a PCDL without retention time data, be sure to clear the 
Require checkbox for Retention time. 

• When searching a PCDL that contains retention time information for 
compounds, enter a retention time and RT tolerance if you want to consider 
retention times in the search.

5 If desired, enter a Formula, Name, IUPAC, CAS, or ChemSpider ID to find 
compounds based on these fields. You can also enter text in the Notes field to 
search for a text string, such as “antidiabetic”. The following additional search 
fields are available for Metabolomics PCDs or PCDLs only: METLIN, KEGG, 
HMP, and LMP IDs.

6 Start the search in any of the following ways: 

• Click Find Compounds on the toolbar, 

• Click Find Compounds on the PCDL menu, or 

• Press the F5 key. 

7 View search results in the Compound Results table at the bottom of the window. 
For more information, see “To view compound search results” on page 29 and 
“To change how data is displayed in results tables” on page 29.
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To view compound search results
To view compound search results

1 Do a search on the Single Search tab as described in “To find compounds” on 
page 27.

2 View search results in the Compound Results table at the bottom of the window. 
You can change how compound results are displayed as described in “To change 
how data is displayed in results tables” on page 29.

3 Click on a compound in the Results table to view its structure information in 
the Structures area on the right side of the window, if the structure is available 
in the PCDL.

4 To edit information for custom PCDs or PCDLs that allow editing, click the Edit 
Compounds tab, as described in “To edit compounds in a custom PCDL” on 
page 42.

5 If any of the compound results contain mass spectra, you can view them as 
described in “To view spectra for a compound” on page 47.

See Also If desired, the following additional actions can be performed on the current 
compound results.

• “To print compound results” on page 31.

• “To create a subset PCDL from selected compounds” on page 32.

• “To append compounds to a PCDL” on page 33.

To change how data is displayed in results tables

1 To sort the table by the entries in a column, click the heading for the column of 
interest.

2 To change the order of the columns of information in the table, drag a column 
heading to a different position. Repeat this until the desired order is achieved.

3 To resize a column to fit the information contained in it, double-click on the 
right column divider in the heading of the column of interest.

4 To resize a column to a specific width, drag the separator between the column 
headings to the right or left until the column is the desired width.

5 Click View > Autosize Columns to resize the widths of columns to the width of 
the widest content in any cell of the column. All columns in the table are resized 
except for Compound Name, IUPAC Name, and Notes.
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To change how data is displayed in results tables
6 To change which columns of information are displayed in the table:

a Right-click the table and click Add/Remove Columns from the shortcut 
menu to open the Add/Remove Columns dialog box.

b Move the items of information that you want to display from the 
Available columns list to the Show these columns list by clicking Add -> 
or by double-clicking on them.

c Remove any unwanted items of information from the Show these 
columns list by clicking <- Remove or by double-clicking on them.

d Click OK.

e Click View > Hide Empty Columns to automatically hide columns that 
do not have any content.

The results table will be updated to reflect the selected columns of information.

NOTE
Autosizing large CDBs can take a very long time. For example, any of the master METLIN 
cdb files can take 30 to 90 minutes to complete the procedure, depending on cdb size and 
computer model.
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To print compound results
To print compound results

The Print/Copy in Summary Format check box changes the format and number of 
compounds printed. The Print/Copy in Summary Format check box is located 
above the compound results table.

If you clear the Print/Copy in Summary Format check box, then up to the first 30 
compound entities selected are printed with all of the columns displayed in the 
Results table.

If you mark the Print/Copy in Summary check box, then all compounds selected 
or all compounds are printed. They are printed in the following summary format:

• Compound Name

• Formula

• Mass

• RT (min)

• One External ID

• Agilent ID and METLIN ID

1 If you want to print only certain compounds, highlight those rows in the 
Compound Results table using Ctrl+click or Shift+click.

2 (optional) Mark the Print/Copy in Summary Format check box above the 
compound results table.

3 Open the Print Results dialog box in any of the following ways:

• Select Print Results from the File menu.

• Click  on the toolbar.

• Right-click the results table and click Print Results from the shortcut menu.

4 Select desired report options from the following:

• Printer (destination)

• Print Preview if you want to view the report on the screen first.

• Fit to page to size the report to fit the width of the page.

• Orientation (Landscape or Portrait). The default is Landscape, as it allows 
more columns of information.

5 Select the desired report content options from the following: 

• All rows or Only highlighted rows of the results table 

• Include search parameters 

• Include unmatched masses 

• Print structures and the size (240 x 160, 360 x 240, or 540 x 360)

6 Click OK to generate the report. 
MassHunter PCDL Manager Quick Start Guide 31



Searching a PCDL in MassHunter PCDL Manager  

To create a subset PCDL from selected compounds
If you selected Print Preview in Step 3, review the report in the Print preview 
dialog box. Click  on the toolbar to print the report. 

To create a subset PCDL from selected compounds

1 Do either of the following searches to display compound information in the 
Results table:

• “To find compounds” on page 27

• “To find compounds from a mass list” on page 34

2 To select the compounds of interest, highlight those rows in the table.

3 To open the Create Subset PCDL dialog box, right-click the table, and then click 
Create Subset PCDL from the shortcut menu.

4 Enter the following information on the Create Subset PCDL dialog box:

• Select the type: General, Metabolomics, Pesticides, Forensics, or Glycans. 
The type affects which user interface options are available when the PCDL is 
opened in PCDL Manager.

• Type in a name for the subset PCDL.

• Mark whether or not to include spectra for compounds if present in the 
PCDL.

• Enter a description for the subset PCDL.

5 Click Create.  
The subset PCDL is created and a message is displayed that tells the number of 
compounds that were copied into the new subset PCDL.

6 When a message is displayed to ask if you want to load the new subset PCDL, 
click Yes to load it or No to continue working with the current PCDL.

7 You can append additional compounds to the subset database as described in 
“To append compounds to a PCDL” on page 33.

NOTE
For Single Search results, only the first 30 compound results will be printed as displayed in 
the results table. To print all compounds selected in summary format, mark the Print/Copy 

in Summary Format check box.
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To append compounds to a PCDL

1 Do either of the following searches to display compound information in the 
Results table:

• “To find compounds” on page 27

• “To find compounds from a mass list” on page 34

2 To select the compounds of interest, highlight those rows in the table.

3 To open the Append to PCDL dialog box, right-click the table, and then click 
Append to PCDL from the shortcut menu.

4 Enter the following information on the Append to PCDL dialog box:

• Select the path for the PCDL you want to append to or accept the default 
path displayed.

• Select the PCDL to append the compounds to.

• Mark whether or not to include spectra for compounds if present in the 
PCDL.

5 Click Append.

The compounds are appended to the selected PCDL and a message is displayed 
that tells the number of compounds that were added.

6 When a message is displayed to ask if you want to load the PCDL, click Yes to 
load it or No to continue working with the current PCDL.
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Doing a batch search

Searching a PCDL for compounds based on a mass list can be broken into the 
following activities, which are described in the following pages:

• “To find compounds from a mass list” (below)

• “To view batch search results” on page 36

• “To view batch summary results” on page 37

• “To export batch summary results” on page 38

To find compounds from a mass list

1 If the PCDL you want to search is not already open, open it in either of the 
following ways:

• Select Open PCDL from the File menu.

• Click  on the toolbar.

2 Click the Batch Search tab.

3 Enter a mass list in one of the following ways: 

• Click the File button to the left of the mass list table to open a mass list file 
output by MassHunter Qualitative Analysis (.csv or .txt file), Mass Profiler 
(.xls file), or GeneSpring MS (.txt file).

• Copy and paste a compound list from MassHunter Qualitative Analysis.

• Type masses and retention times directly into the table.

4 Select or enter the Type of mass (typically Neutral for Batch Search) and Mass 
tolerance, in ppm or mDa. 

5 Mark the Ion search mode check boxes as follows: 

• Include neutrals is typically marked.

• Mark Include anions and/or Include cations if you also want to consider 
those few chemicals that don't pick up or lose a proton to ionize. 

6 Click one of the following options for Retention times:

Option Meaning Application

Ignore Don’t consider retention time even 
if it is present in the list

When searching the sample master PCDL 
or any custom PCDL without retention time 
data.
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To find compounds from a mass list
7 Initiate the search in any of the following ways: 

• Click Find Compounds on the toolbar.

• Click Find Compounds from the PCDL menu.

• Press the F5 key. 

8 When the search is complete, the number of hits for each mass appears in the 
Hits column of the mass list, and the list is automatically sorted to show the 
masses with the most hits at the top of the list. To sort the list by a different 
criterion, click the heading for the column of interest (Mass or RT). 

Masses with conflicting hits are shown in red text in the Mass List table.

9 Click a row in the Mass List table to display the compounds found for that mass 
in the Compound Results table in the lower part of the window. For more 
information on viewing batch search results, see “To view batch search 
results” on page 36. 

10 Select and view the best compound hit for each mass as described in “To view 
batch summary results” on page 37.

Optional Use retention time information to 
rank a compound higher if its 
retention time matches with the 
observed retention time.

When searching a PCDL that contains 
retention time information for some 
compounds.

Required Consider only compounds that 
match the specified retention time 
range.

When searching a PCDL that contains 
retention times for some compounds and 
both mass and RT criteria must be met.
MassHunter PCDL Manager Quick Start Guide 35



Doing a batch search  

To view batch search results
To view batch search results

1 Do a search on the Batch Search tab as described in “To find compounds from a 
mass list” on page 34.

2 When the search is complete, the number of hits for each mass appears in the 
Hits column of the mass list, and the list is automatically sorted to show the 
masses with the most hits at the top of the list. To sort the list by a different 
criterion, click the heading for the column of interest (Mass or RT). Masses with 
conflicting hits are shown in red text in the Mass List table.

3 Click a row in the Mass List table to display the compounds found for that mass 
in the Search Results table in the lower part of the window. 

 Tip For ease of reviewing results, use the F4 key to scroll down the Mass List and the 
Shift+F4 keys to scroll back up. The information in the Results table will be updated 
as you scroll through the mass list. 

4 (Optional) Change how the batch search results are displayed as described in 
“To change how data is displayed in results tables” on page 29. 

5 See “To view batch summary results” on page 37 for information on selecting 
and viewing the best compound hit for each mass.

6 Click a compound in the Compound Results table to view its structure 
information in the Structures area on the right side of the window, if the 
structure is available in the PCDL. 

7 Click the Edit Compounds tab to edit information for custom PCDs or PCDLs 
that allow editing, as described in “To edit compounds in a custom PCDL” on 
page 42.

8 If any of the compound results contain mass spectra, you can view them as 
described in “To view spectra for a compound” on page 47.

See Also If desired, the following additional actions can be performed on the current 
compound results.

• “To print compound results” on page 31.

• “To create a subset PCDL from selected compounds” on page 32.

• “To append compounds to a PCDL” on page 33.
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To view batch summary results
To view batch summary results

1 Do a search on the Batch Search tab as described in “To find compounds from a 
mass list” on page 34.

2 Click a row in the Mass List table to display the compounds found for that mass 
in the Batch Search Results table in the lower part of the window. Masses with 
conflicting hits are shown in red text in the Mass List table.

3 Review the entries marked in the Best column for each mass and if necessary, 
edit the Batch Search Results table to select the best compound hit by marking 
the desired row (compound). You can also clear the box for the selected hit to 
ignore all the results for that compound.

4 Click the Batch Summary tab to view only the best hits from the Batch Search 
Results table. Compounds with conflicting mass hits are shown in red text in 
the results table.

5 (Optional) Change how the batch summary results are displayed as described 
in “To change how data is displayed in results tables” on page 29. 

6 Click a compound in the results table to view its structure information in the 
Structures area on the right side of the window, if the structure is available in 
the PCDL. 

7 Click the Edit Compounds tab to edit information for custom PCDs or PCDLs 
that allow editing, as described in “To edit compounds in a custom PCDL” on 
page 42.

8 To export batch summary results, see “To export batch summary results” on 
page 38.

9 To print batch summary results, see “To print compound results” on page 31.

10 (Optional) For a custom PCDL with editing enabled, you can update retention 
times in the PCDL for the compounds shown in the Batch Summary Results 
table. See “To update retention time data” on page 40.
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To export batch summary results

1 Do a batch search as described in “To find compounds from a mass list” on 
page 34.

2 Select and view the best compound hit for each mass as described in “To view 
batch summary results” on page 37, or clear the box for the selected hit to 
ignore all the results for that compound.

3 (Optional) Change the display of data in the Batch Summary tab as described 
in “To change how data is displayed in results tables” on page 29. 

4 Open the Export Results dialog box in any of the following ways: 

• Click Export Results from the File menu.

• Click  on the toolbar.

• Right-click the results table and click Export Results from the shortcut 
menu in the Batch Summary results table.

5 Click Select if you wish to specify a different file name, location, or file type for 
the export file. Otherwise the following default file name, location, and format 
are used: 

• If the mass list was opened from a file, the export file name is: 
<massListFileName>-<TimeStampInSecs>.txt

• If you entered the mass list manually, the export file name is:  
MassList-<TimeStampInSecs>.txt

• The default location for the export file is MassHunter\PCDL\Results. 

• The default output file format is .TXT (tab-separated values), but you can 
select .CSV (comma-separated values) instead.

6 Select one or more of the following types of information to include in the report: 
Search parameters, Results, and Unmatched masses (available only if the 
Results checkbox is marked).

7 Mark the Open results file after exporting option to open the batch summary 
results file automatically in the associated application. 

8 Click OK to output the results. 

9 The results will open in the associated application such as Excel if you selected 
the Open results file option in Step 7. Otherwise open the exported results file 
in your application of choice at a later time.
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To export batch summary results
NOTE
When a .csv file is opened in Excel, the Text Import Wizard may be displayed 
automatically. If so, follow the prompts to specify the proper delimiter for your file, e.g. 
comma or tab. 
If the wizard is not displayed automatically, all the values for each row may appear in the 
first column. To split the text into columns, select the first column (A), then start the 
wizard by selecting Text to Columns on the Data tab, in the Data Tools group.
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To update retention time data
Editing a custom PCDL

Compound information in a custom PCDL can be edited in the following ways:

• “To update retention time data” on page 40

• “To edit compounds in a custom PCDL” on page 42

To update retention time data

This procedure applies to custom PCDs or PCDLs only.

1 Open the custom PCDL of interest. Be sure that editing is enabled by marking 
Allow Editing on the PCDL menu.

2 Click the Batch Search tab.

3 Enter a mass list in one of the following ways: 

• Click the File button to the left of the mass list table to open a mass list file 
output by MassHunter Workstation Qualitative Analysis (.csv or .txt file), 
Mass Profiler (.xls file), or GeneSpring MS (.txt file).

• Copy and paste a compound list from Qualitative Analysis.

• Type in masses and retention times directly into the table.

4 Select one of the following options for Retention times:

• Ignore - Use this option to search a PCDL with no retention time 
information or retention times that may be outside the tolerance window.

• Optional - Use this option to search a PCDL that either has no retention time 
information or has retention times missing for some compounds that you 
now want to update. 

• Required - Use this option if you only want to identify and update those 
compounds that already have retention time information in the PCDL. 
Specify an RT tolerance value in minutes as well.

5 Set other search criteria if desired as described in “To find compounds from a 
mass list” on page 34.

6 Initiate the search in any of the following ways: 

• Click Find Compounds on the toolbar.

NOTE
Every mass in the mass list must have a retention time value for this procedure.
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• Click Find Compounds from the PCDL menu.

• Press the F5 key.

7 When the search is complete, the number of hits for each mass appears in the 
Hits column of the mass list, and the list is automatically sorted to show the 
masses with the most hits at the top of the list. To sort the list by a different 
criterion, click the heading for the column of interest (Mass or RT). 

Masses with conflicting hits are shown in red text in the Mass List table. 

8 Click a row in the Mass List table to display the compounds found for that mass 
in the Search Results table in the lower part of the window. For more 
information on viewing batch search results, see “To view batch search 
results” on page 36. 

9 Select and view the best compound hit for each mass as described in “To view 
batch summary results” on page 37 or clear the box for the selected hit to ignore 
that compound.

10 Click Apply Retention Times to apply retention times from the Mass List in the 
Batch Search tab for each of the compounds listed in the Batch Summary table.

NOTE
All conflicting results must be resolved before retention time data can be updated.
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To edit compounds in a custom PCDL

Do this step to edit information for compounds, to add a new compound, or to 
remove a compound.

1 Open the custom PCDL of interest. 

2 Enable editing by marking Allow Editing on the PCDL menu.

3 Do a search using either of the following:

• “To find compounds” on page 27.

• “To find compounds from a mass list” on page 34.

4 When the search is complete, click the Edit Compounds tab.

5 To update information for a particular compound:

a Select the compound of interest by clicking it in the Search Results table. 
Information for the selected compound is displayed in the Edit 
Compounds tab.

b Update information on the left side of the Edit Compounds tab, such as 
Name, Mass, RT, Formula, CAS or ChemSpider ID, and Ion type.

c Update structure information if desired in either of the following ways:

• Click the MOL Text tab and paste in MOL file text that you have copied from 
a molecular drawing tool (Ctrl+V), or 

• Click  in the Structures area to open a .MOL file.

d Click Update Selected. The information for the compound is updated in 
the PCDL and the information you entered in Step 5b is reflected in the 
Results table.

NOTE
If the mol file does not contain a structure with the same molecular formula as in the 
Formula box, a warning appears stating that the structure’s formula and thus Mass differs 
from that in the Formula box. You can click Yes to apply the structure’s formula, and the 
current information in the Formula and Mass boxes is automatically edited.
If you click No, the mol file is updated, but the compound information is not 
changed.
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6 To add a new compound to the PCDL:

a Click Add New. A new compound is created in the PCDL with a mass of 0 
named “New Compound” and the new compound is displayed at the end 
of the Results table.

b Enter or change information for the new compound as described in Step 
5 above.

c Click Update Selected. The information you entered for the new 
compound is updated in the PCDL and the information is reflected in the 
Results table.

Alternate method 

to add a new 

compound

Enter information for a new compound on the left side of the Edit Compounds 
tab, such as Name, Mass, RT, Formula, CAS ID, and Ion type, then click Save As 
New. A new compound is created in the PCDL using the specified values. The 
new compound is displayed at the end of the Results table.

7 To remove a compound from the PCDL:

a Select the compound of interest by clicking it in the Search Results table. 
Press Ctrl+click or Shift+click to select multiple compounds for deletion.

b Click Delete Selected.

NOTE
If you select another compound entry before clicking Update Selected, all entered 
information is lost.
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Spectral searching and editing

Searching and editing mass spectra in a PCDL is broken down into the following 
tasks:

• “To import spectra from a .CEF file” - below

• “To copy spectra from MassHunter Qualitative Analysis” - below

• “To paste spectra into MassHunter PCDL Manager” on page 46

• “To search spectra in a PCDL” on page 46

• “To browse spectra in the PCDL” on page 47

• “To view spectra for a compound” on page 47

• “To add, move, or remove spectra in a custom PCDL” on page 48

• “To clean up noisy spectra” on page 50

To import spectra from a .CEF file

Do this step to load spectra into MassHunter PCDL Manager that have been output 
to a .CEF file from another program such as MassHunter Qualitative Analysis 
software. 

1 Click to display the Spectral Search or Edit Spectra tab.

2 Click Load Spectra .

3 Select the .CEF file of interest and click Open.

If profile spectra or non-MS/MS spectra are contained in the file, a message is 
displayed saying that they have been skipped. Only centroided MS/MS spectra 
are loaded for use in MassHunter PCDL Manager.

The spectra appear in the Acquired spectra table. See the following topics for 
further use of imported spectra:

• “To search spectra in a PCDL” on page 46

• “To add, move, or remove spectra in a custom PCDL” on page 48

• “To clean up noisy spectra” on page 50
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To copy spectra from MassHunter Qualitative Analysis

1 Open the data file of interest in MassHunter Qualitative Analysis software.

2 Find compounds. You can use one of the following algorithms:

• Find by Targeted MS/MS, depending on how the data was acquired.

• Find by Auto MS/MS, depending on how the data was acquired.

• Find by Formula, as long as the Extract MS/MS spectra check box is 
marked

• Find by Molecular Feature, as long as the Extract MS/MS spectra check 
box is marked.

3 Expand the compounds of interest in Data Navigator to see the spectral results.

4 Select the product ion spectra of interest.

5 If the data was acquired in Profile mode, right-click and click Convert Profile 
to Centroid and Replace from the shortcut menu.

6 Right-click the MS Spectrum Results window and select Copy to Clipboard. 

All spectra displayed in the MS Spectrum Results window are copied, not just 
the highlighted ones. It may be simpler to only display one spectra at a time.

NOTE
It is also possible to copy spectra from one compound or from one PCDL to another. 
Multiple windows of PCDL Manager, including multiple windows of the same PCDL file, 
can be open at the same time.
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To paste spectra into MassHunter PCDL Manager

1 Copy spectra from MassHunter Qualitative Analysis as described in “To copy 
spectra from MassHunter Qualitative Analysis” on page 45.

2 Click to display the Spectral Search or Edit Spectra tab as appropriate.

3 Right-click the Acquired spectra table and click Paste Spectra. 

If profile spectra or LC/MS spectra were copied from MassHunter Qualitative 
Analysis, a message is displayed saying that they have been skipped. Only 
centroided MS/MS and GC/MS spectra are pasted into MassHunter PCDL 
Manager. The spectra are listed in the Acquired spectra table.

To search spectra in a PCDL

1 If the PCDL you want to search is not already open, open it by clicking Open 
PCDL from the File menu or  on the toolbar.

2 Import spectra as described in “To import spectra from a .CEF file” or “To copy 
spectra from MassHunter Qualitative Analysis” on the previous page.

3 Click to select the spectrum to search from the Acquired spectra table on the 
Spectral Search tab.

4 Use the default search parameters or set any of the following search 
parameters: Search type, Filters, or Tolerances. These parameters are 
described in online Help.

5 Click to start the search.

The search results are displayed in the Spectral Results table in the lower part 
of the tab. If desired, the spectral results display can be changed as described in 
To change how data is displayed in results tables.

6 Click a row of the results table to view the mass spectrum plot for the selected 
compound in the Spectral Plot window to the right of the table.

7 Click the Mass Lists tab in the Spectral Plot window to view a list of masses and 
relative abundance values for the selected spectrum.

NOTE
Spectra cannot be pasted into the Library spectra table.
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To browse spectra in the PCDL

Use the following procedure to search the current PCDL for spectra that match 
certain parameters, such as mass, collision energy, ion polarity, and ionization 
mode.

1 Click the Browse Spectra tab.

2 Use the default search parameters to return the contents of the entire PCDL 
and skip to Step 3. Otherwise, set the desired search criteria: Mass, Collision 
energy, Ion polarity, and Ionization mode. These parameters are described in 
online Help.

3 Click to start the search.

The PCDL search results are displayed in the Spectral Results table in the 
middle of the tab. If desired, the spectral results display can be changed as 
described in “To change how data is displayed in results tables” on page 29.

4 Click on a row of the results table to view the mass spectrum plot for the 
selected spectrum in the Spectral Plot window to the right of the table.

5 Click the Mass Lists tab in the Spectral Plot window to view a list of masses and 
abundance values for the selected spectrum.

To view spectra for a compound

1 Do a compound search using either of the following:

• “To find compounds” on page 27.

• “To find compounds from a mass list” on page 34.

2 When the compound search is complete, click the Browse Spectra tab.

The compound search results are displayed in the Compound Results table in 
the lower part of the tab.

3 Click a compound of interest in the Compound Results table. The PCDL spectra 
associated with the selected compound are displayed in the Spectral Results 
table in the middle of the tab. In this case, the search parameters set in the top 
of the tab are ignored.

4 Click a row of the Spectral Results table to view the mass spectrum plot for the 
selected spectrum in the Spectral Plot window to the right of the table.

5 Click the Mass Lists tab in the Spectral Plot window to view a list of masses and 
relative abundance values for the selected spectrum.

6 Repeat step 3 through step 5 for other compounds of interest.
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To change ion species for a compound

1 View spectral information for compounds in the spectral tables on the Edit 
Spectra tab.

2 Double-click the Ion Species cell in the row for the compound of interest to 
open the Edit Species dialog box.

3 The following information is displayed but cannot be edited: Compound Name, 
Compound Mass, and Ionization Mode.

4 If desired, change the value for the Precursor Ion.

5 Select an Ion Species for the compound.

6 Click OK to close the Ion Species dialog box.

7 Repeat steps 2 to step 6 for other compounds of interest.

To add, move, or remove spectra in a custom PCDL

1 Enable editing of the current PCDL by marking Allow Editing on the PCDL 
menu.

2 Do a compound search using either of the following:

• “To find compounds” on page 27.

• “To find compounds from a mass list” on page 34.

3 When the compound search is complete, click the Edit Spectra tab.

NOTE
The information about the spectra such as collision energy, ion polarity, ionization mode, 
and instrument type cannot be edited. The acquisition parameters used for data 
acquisition are stored with the spectra in the PCDL. The Ion species and Precursor Ion 
values can be edited and allow you to choose the correct ion species from a pull down 
context sensitive menu or directly type in the ion species.

NOTE
Agilent strongly recommends to use the Send Spectra to PCDL feature in MassHunter 
Qualitative Analysis to import spectra to a PCDL when you create a custom library. The 
spectra are loaded directly into the library table. This function allows you to filter spectral 
noise, set a pass/fail base peak height filter and correct the product ions to their 
theoretical accurate mass.
48 MassHunter PCDL Manager Quick Start Guide



Spectral searching and editing 

To add, move, or remove spectra in a custom PCDL
The compound search results are displayed in the Compound Results table in 
the lower part of the tab.

4 Click a compound you want to view or modify in the Compound Results table. 
The spectra associated with the selected compound are displayed in the Library 
spectra table in the middle of the tab.

5 To view more of the table, drag the vertical blue line that divides the screen.

6 Load spectra into the Acquired spectra table at the top of the tab in either of 
the following ways:

• From a .CEF file as described in “To import spectra from a .CEF file” on 
page 44, or

• From Qualitative Analysis, as described in “To copy spectra from 
MassHunter Qualitative Analysis” and “To paste spectra into MassHunter 
PCDL Manager” on page 46.

7 To add spectra to the compound selected in Step 4:

a Click to select the spectrum of interest in the Acquired Spectra table. 
Multiple spectra can be selected using Ctrl+click or Shift+click.

b Click Add Spectra. The Library spectra table will be updated to show the 
new list of spectra for the compound. 

c Click each spectrum to edit the Ion Species.

8 To delete spectra from the compound selected in Step 4:

a Click to select the spectrum of interest in the Library spectra table. 
Multiple spectra can be selected using Ctrl+click or Shift+click.

b Click Delete Spectra. The Library spectra table will be updated to show 
the revised list of spectra for the compound.

9 To move spectra between compounds:

a Click to select the compound to copy spectra from in the Compound 
Results table in the lower part of the tab. 

The spectra for that compound are displayed in the Library spectra table in the 
middle of the tab.

b Click to select the spectra of interest in the Library spectra table, then 
right-click in the table and select Copy Spectra from the shortcut menu. 
Use Ctrl-click or Shift-click before copying if you want to select multiple 
spectra.

c Right-click in the Acquired spectra table in the upper part of the tab and 
select Paste Spectra from the shortcut menu. 
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The spectra are added to the Acquired spectra table.

d Click to select the compound to copy the spectra to in the Compound 
Results table in the lower part of the tab.

e Click Add Spectra.

The Library spectra table will be updated to show the revised list of spectra for 
the compound.

To clean up noisy spectra

Do this step to remove small noise peaks from spectra before or after you add 
them to a custom PCDL, if you used the import from cef file or copied spectra from 
MassHunter Qualitative Analysis. Using the Send Spectra to PCDL feature in 
MassHunter Qualitative Analysis eliminates the need for this step.

1 Select the spectrum of interest in either the Acquired spectra or Library 
spectra table on the Edit Spectra tab.

2 Click the Mass Lists tab in the Spectral Plot window. By default, the masses are 
sorted in descending order by relative abundance value. Click the Rel Abund 
column header if you want the lowest relative abundance values (likely noise 
peaks) to appear at the top of the table.

3 Select the masses to delete by clicking on them in the Acquired masses or 
Library masses list. Use Ctrl-click or Shift-click to select multiple masses.

4 Right-click in the Acquired masses or Library masses list and select Delete 
Masses from the shortcut menu.

5 Update the PCDL as follows, depending on whether the spectrum modified in 
Step 4 was an Acquired or Library spectrum.

• Click Add Spectra to add an Acquired spectrum to the selected library 
compound.

• Click Update Spectra to update the selected library compound with a 
modified Library spectrum.
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Familiarization Exercises

These exercises will help you learn to use the MassHunter Personal Compound 
Database and Library Manager:

•  “Exercise 1. Search for compounds” on page 51

•  “Exercise 2. View spectra for compounds” on page 55

•  “Exercise 3. Batch search from a mass list” on page 57

•  “Exercise 4. Search a spectral library” on page 60

•  “Exercise 5. Browse spectra in the PCDL” on page 62

Custom PCDL operations:

•  “Exercise 6. Create a custom PCDL” on page 64

•  “Exercise 7. Edit compounds” on page 65

•  “Exercise 8. Add retention times to a PCDL” on page 67

Exercise 1. Search for compounds

In this exercise, you will search for compounds in an example PCDL and review 
the search results.

Steps Detailed Instructions Comments

1 Open the example PCDL. a Click Open PCDL from the File menu, 
or click the  button on the toolbar.

b Select the Sulfas_AM_PCDL.cdb file, 
and click the Open button.

Skip this step if the Sulfas PCDL is 
already open.

2 Click the Single Search tab.

3 Leave the search parameters 
blank.

• Verify that the Require checkbox for 
Retention time is cleared, since the 
example Sulfas PCDL does not contain 
retention time information.

This will return all compounds in the 
PCDL. See “To find compounds” on 
page 27 for a discussion of search 
parameters to narrow your search.

4 Begin searching. • Click the Find Compounds button on 
the toolbar.

Alternate methods:
• Click Find Compounds from the 

PCDL menu.
• Press the F5 key.
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5 Review the search results in the 
table in the lower half of the tab.

• See Figure 1 on page 54. The results are sorted from low mass 
to high mass.

6 View structure information for a 
selected compound.

• Click a compound in the Compound 
Results table. Its structure is displayed 
in the Structure area on the right side 
of the window.

• Clicking the  button displays a 
larger image of the structure.

• Clicking the MOL Text tab displays 
the text version of the structure. 

7 Sort the table by name. • Click the heading of the Compound 

Name column. Click it again to sort by 
name in the opposite order.

Clicking on any column heading will 
sort the table according to the values 
in that column.

8 Reorder the columns in the table. a Drag a column heading to a different 
position. 

b Repeat until the desired order is 
achieved. 

9 Resize a column. • Double-click the right column divider in 
the heading of the column of interest 
to resize the column to fit the 
information contained in it.

Alternate Method:
• Drag the separator between column 

headings to the right or left until 
the column of interest is the 
desired width.

• Click View > Autosize Columns.

10 Change which columns of 
information are displayed in the 
table.

a Right-click the table and click 
Add/Remove Columns from the 
shortcut menu. 

b Move the items of information that 
you want to display from the Available 

columns list into the Show these 

columns list using the Add-> button.
c Move the items of information that 

you don’t want to display out of the 
Show these columns list into the 
Available columns list by clicking the 
<-Remove button.

d Click OK. 

Alternate Methods:
• You can also open the Add/Remove 

Columns dialog box by selecting 
Add/Remove Compound Columns 
from the View menu.

• You can move individual items 
between the two lists by 
double-clicking them.

Note that the original column layout 
can be restored at anytime by clicking 
Restore Default Compound Columns 
from the View menu.

Steps Detailed Instructions Comments
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11 Create a subset PCDL from 
selected compounds.

a  To select the compounds of interest, 
highlight those rows in the table.

b Right-click the table, and then click 
Create Subset PCDL.

c Enter the information on the Create 

Subset PCDL dialog box.
d Click Create.
e Click No when asked whether or not 

to load the new PCDL.

• For more information, see “To 
create a subset PCDL from selected 
compounds” on page 32.

• You can also append selected 
results to an existing PCDL as 
described in “To append 
compounds to a PCDL” on page 33.

12 Print results. a Mark or clear the Print/Copy in 

Summary Format check box.
b Click the  button on the toolbar to 

open the Print Results dialog box.
c Select print options. For a discussion 

of print options, see “To print 
compound results” on page 31.

d Click OK. If you selected the Print 
Preview option, review the report in 
the Print Preview window, then click 
the  button to print it.

• If you mark the Print/Copy in 

Summary Format check box, then 
all compounds with only certain 
columns are printed. See “To print 
compound results” on page 31.

• If you clear this check box, then all 
columns shown in the results table 
are printed for the first 30 selected 
compounds.

• To print only selected results, 
highlight those rows in the 
Compound Results table using 
Ctrl+click or Shift+click; then, 
select Only highlighted rows as 
one of the print options in Step c.

Steps Detailed Instructions Comments
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Figure 1 Results of Single Search for Compounds
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Exercise 2. View spectra for compounds

In this exercise, you will view mass spectra for the compounds retrieved in the 
Single Search done in Exercise 1.

 

Steps Detailed Instructions Comments

1 Display the Browse Spectra tab. Click to display the Browse Spectra tab. This procedure can also be performed 
from the Edit Spectra tab.

2 Select Sulfamethizole from the 
Single Search Results table.

Click on the Sulfamethizole row of the 
Single Search Results table.

The Single Search Results table is in 
the lower part of the tab and should 
contain the compound results from 
Exercise 1.

3 View the spectral information for 
Sulfamethizole.

View Compound Name, Ion Species, 
Precursor Ion, CE (V), Polarity, 
Ionization, and Instrument in the spectral 
information table.

The spectral information table is in the 
middle of the tab.

4 View the mass spectrum plot for 
Sulfamethizole.

Click the Graphic tab in the spectral plot 
window.
See Figure 2 on page 56.

The spectral plot window is on the 
right side of the tab.

5 View the mass list for 
Sulfamethizole.

Click the Mass List tab in the spectral 
plot window.

6 View information for another 
Sulfamethizole spectrum.

a Click on a different row of the spectral 
information table.

b View the mass spectrum and mass list 
for this spectrum in the Spectral Plot 
Window as described in Steps 4 and 5.

Different mass spectra were obtained 
for Sulfamethizole by acquiring data 
with three different Collision Energy 
values: 10, 20, and 40.

7 View spectral information for a 
different compound.

Click on the Sulfamethazine row of the 
Single Search Results table in the lower 
part of the tab.

View the spectral information for this 
compound as described in Step 3.
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Figure 2 Viewing Browse Spectra tab
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Exercise 3. Batch search from a mass list

In this exercise, you will search an example PCDL using an imported mass list.

Steps Detailed Instructions Comments

1 Open the example PCDL. a Select Open PCDL from the File menu, 
or click the  button on the toolbar.

b Select the Sulfas_AM_PCDL.cdb file, 
and click the Open button.

Skip this step if the Sulfas PCDL is 
already open, as it is after Exercise 2.

2 Click the Batch Search tab.

3 Open a mass list. a Click the File button to the left of the 
mass list table.

b Select the sulfa_compounds.txt mass 
list file in the 
MassHunter\PCDL\Mass List Files 
folder. 

c Click the Open button.

• Mass lists can also be 
copy-and-pasted into PCDL Manager 
from MassHunter Qualitative 
Analysis.

• See online help in MassHunter 
Qualitative Analysis for instructions 
on how to output a mass list.

4 Set the batch search parameters. a In this case the following default 
search parameters can be used for the 
search:

• Neutral Masses option marked.
• Mass tolerance 10 ppm.
• Optional for Retention times clicked.
• Only the Include neutrals option 

marked for Ion search mode.

The example PCDL does not include 
retention times.

5 Begin searching. Click the Find Compounds button on the 
toolbar.

Alternate methods:
• Select Find Compounds from the 

PCDL menu.
• Press the F5 key.

6 Review search results. • When the search is complete, the 
number of hits for each mass appears in 
the Hits column of the mass list.

• The list is automatically sorted to show 
the masses with the most hits at the 
top of the list. See Figure 3 on page 59. 

• To sort the mass list by a different 
criterion, click the heading for the 
column of interest.

• Masses with conflicting hits are 
shown in red text in the Mass List 
table. 

7 (Optional) Create a subset PCDL 
from selected compounds or 
append selected compounds to an 
existing PCDL.

• See “To create a subset PCDL from 
selected compounds” on page 32.

• See “To append compounds to a 
PCDL” on page 33.
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8 View hits for selected masses. Click a row in the Mass List table to 
display the compounds found for that 
mass in the Batch Search Results table in 
the lower part of the window. 

For ease of reviewing results, use the 
F4 key to scroll down the Mass List and 
the Shift+F4 keys to scroll back up. The 
information in the results table will be 
updated as you scroll through the mass 
list.
The batch search results table can be 
resorted as described in “To change 
how data is displayed in results 
tables” on page 29.

9 Select the best compound hit for 
each mass.

Mark the Best column for the row 
(compound) you believe is the best 
compound hit for each mass. In many 
cases, this will be the one already selected 
by the software.

You can also clear the box for the 
selected hit to ignore that mass.

10 View the best hit results. Click the Batch Summary tab. The Best hit 
for each mass is shown in the Batch 
Summary table in the lower part of the 
window. See Figure 4 on page 59.

Compounds with conflicting mass hits 
are shown in red text in the results 
table.
The batch summary results table can 
be resorted as described in “To change 
how data is displayed in results 
tables” on page 29.

11 Export batch summary results. a Click the  button on the toolbar to 
open the Export Results dialog box.

b Select the following options: Search 

parameters, Results, and Unmatched 

masses.
c Mark the Open results file after 

exporting option.
d Click OK to output the results. 

The results will open in the associated 
application such as Excel.  
The following export file is created in 
the MassHunter\PCDL\Results folder: 
sulfa_compounds-<timestamp>.txt

You can also open the Export Results 
dialog box in either of the following 
ways: 
• Select Export Results from the File 

menu.
• Right-click in the Batch Summary 

results table and select Export 

Results from the shortcut menu.

You can select a different file name, 
location or type as described in “To 
export batch summary results” on 
page 38.

Steps Detailed Instructions Comments
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Figure 3 Results of Batch Search - Mass List

Figure 4 Batch Summary Results
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Exercise 4. Search a spectral library

In this exercise, you will load spectra from a .CEF file and search for spectra in an 
example PCDL.

 

Steps Detailed Instructions Comments

1 Open the example PCDL. a Select Open PCDL from the File menu, 
or click the  button on the toolbar.

b Select the Sulfas_AM_PCDL.cdb file, 
and click the Open button.

Skip this step if the Sulfas PCDL is 
already open, as it will be after 
Exercise 3.

2 Import spectra. a Click the  button on the 
Spectral Search tab.

b Select the Sulfas.CEF file in the 
Example Data folder on the PCDL 
installation disk.

c Click the Open button.

• See online help in MassHunter 
Qualitative Analysis for instructions 
on how to output spectra to a .CEF 

file.
• When MS spectra are loaded into 

the Spectral Search tab, the 
Precursor Ion value is empty.

The imported spectra appear in the 
Acquired spectra table in the upper part 
of the tab.

Often the Compound Name field will 
be blank. Compound Name is shown 
only if the compound was identified in 
MassHunter Qualitative Analysis 
before the cef file is exported.

3 Select the spectrum to search. Click on the Sulfamethizole row in the 
Acquired spectra table that has Collision 

Energy value of 12. 

4 Set search parameters. Clear the check mark for the Collision 

energy Filter.
Use default values for the other 
search parameters.

5 Start searching. Click the Find Spectra button on the 
toolbar.

You can also start the search in either 
of the following ways:
• Select Find Spectra from the PCDL 

menu.
• Press the F5 key.

6 View search results. The search results are displayed in the 
Library spectra table in the lower part of 
the tab.  
See Figure 5 on page 61.

If desired, the spectral results display 
can be changed as described in “To 
change how data is displayed in 
results tables” on page 29.

7 View the mass list. • Click the Mass Lists tab in the 
Spectral Plot window.
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Figure 5 Spectral Search results
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Exercise 5. Browse spectra in the PCDL

In this exercise, you will search an example PCDL for spectra that match certain 
parameters, such as mass, collision energy, ion polarity, and ionization mode.

 

Steps Detailed Instructions Comments

1 Open the example PCDL. a Select Open PCDL from the File menu, 
or click the  button on the toolbar.

b Select the Sulfas_AM_PCDL.cdb file, 
and click the Open button.

Skip this step if the Sulfas PCDL is 
already open, as it will be after 
Exercise 4.

2 Display the Browse Spectra tab. Click to display the Browse Spectra tab.

3 View all compounds in the PCDL. a Use the default search parameters:
• Precursor Ion Mass and Collision 

energy blank
• Ion polarity (Any)
• Ionization mode (Any)

b Click the Find Spectra button on the 
toolbar to start the search.

4 View spectral information. View Compound Name, Ion Species, 
Precursor Ion, CE(V), Polarity, 
Ionization, and Instrument in the 
Spectral Search Results table in the 
middle of the tab. See Figure 6 on 
page 63.

5 View the mass spectrum plot for 
one of the spectra.

a Click a row of the results table to 
select a spectrum.

b Click the Graphic tab in the spectral 
plot window to the right of the table.

6 View the mass list for the selected 
spectra.

• Click the Mass List tab in the spectral 
plot window.

7 Filter spectra by Precursor ion 
mass.

a Set the Precursor ion mass to 279.09.
b Click the Find Spectra button on the 

toolbar to start the search.

Note that only the three 
Sulfamethazine spectra are returned.
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8 Reset the default search 
parameters.

a Right click in the upper part of the 
Browse Spectra tab and select Reset 

Search Fields from the shortcut 
menu.

9 Filter spectra by Collision energy 
voltage.

a Set the Collision energy to 40.
b Click the Find Spectra button on the 

toolbar to start the search.

Note that the four spectra are 
returned by the search that have 
Collision Energy values of 40,

Figure 6 Browsing Spectra Results

Steps Detailed Instructions Comments
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Exercise 6. Create a custom PCDL

In this exercise, you will create a custom PCDL from the example Sulfas PCDL.

 

Steps Detailed Instructions Comments

1 Open the New PCDL dialog box. • Click New PCDL from the File menu or 
click the  button on the toolbar.

Alternate method: You can also create 
custom PCDLs as described in the 
following topics:
• “To create a subset PCDL from an 

input file” on page 18
• “To create a subset PCDL from 

selected compounds” on page 32

2 Create the new PCDL. a Select Sulfas_AM_PCDL as the 
starting PCDL.

b Select General as the PCDL type.
c Type in a name for the new PCDL, 

such as Sulfas_AM_Custom.
d Enter a description for the new PCDL. 
e Click the Create button to create the 

new PCDL. 

• The new PCDL becomes the current 
working PCDL and is automatically 
enabled for editing. 

• The new custom PCDL will contain 
all compounds and spectra from the 
starting PCDL.

3 Edit the PCDL. See “Exercise 7. Edit compounds”.
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Exercise 7. Edit compounds

In this exercise, you will edit the custom PCDL that you created in Exercise 6.

 

Steps Detailed Instructions Comments

1 Open the custom PCDL you 
created in Exercise 6, if it is not 
already open.

a Select Open PCDL from the File menu, 
or click the  button on the toolbar.

b Select the Sulfas_AM_Custom.cdb 
file, and click the Open button.

Skip this step if the custom PCDL is 
already open, as it will be if you just 
completed Exercise 6.

2 Enable editing for this PCDL. a Open the PCDL menu.
b Mark Allow Editing if it is not 

currently marked.

A new PCDL is automatically enabled 
for editing when it is created.

3 Do a search. a Click the Single Search tab.
b Click the Find Compounds button on 

the toolbar to start the search. The 
search results appear in the table in 
the lower half of the window.

This search returns all neutral mass 
compounds in the PCDL.

4 Click the Edit Compounds tab.

5 Update information for a particular 
compound.

a Select the compound of interest by 
clicking on it in the Compound Results 
table. 

b Update information on the left side of 
the Edit Compounds tab, such as 
Mass, RT, Formula, Name, CAS ID, and 
Ion type.

c Click the Update Selected button to 
apply the changes to the PCDL. 

Information for the selected 
compound is displayed in the Edit 
Compounds tab.

The updated information will be 
changed in the PCDL and reflected in 
the results table. 

6 Update structure information for a 
particular compound.

a Select the compound of interest by 
clicking on it in the Compound Results 
table. 

b Click the  button in the 
Structures area to open a .MOL file. 

c Click the Update Selected button. The 
information you entered will be 
changed in the PCDL.

You can also update structure 
information for a selected compound 
by clicking on the MOL Text tab and 
pasting in MOL file text that you 
copied from a molecular drawing tool 
(Ctrl+V).
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7 Add a new compound to the PCDL. a Click the Add New button.  
A new compound is created in the 
PCDL with a mass of 0 named “New 
Compound”, and the new compound 
is displayed at the end of the 
Compound Results table.

b Enter or change information for the 
new compound as described in Step 5 
above.

c Click the Update Selected button.  
The information you entered for the 
new compound is updated in the PCDL 
and the information is reflected in the 
results table.

Alternate method: 

a Enter information for a new 
compound on the left side of the 
Edit Compounds tab, such as 
Mass, RT, Formula, Name, and Ion 
type.

b Click the Save As New button.  
A new compound is created in the 
PCDL using the specified values. 
The new compound is displayed at 
the end of the results table.

8 Remove a compound from the 
PCDL.

a Select the compound of interest by 
clicking on it in the Compound Results 
table. 

b Click the Delete Selected button. 

The selected compound is removed 
from the PCDL.

9 Add retention times to the PCDL 
as described in Exercise 8.

Steps Detailed Instructions Comments
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Exercise 8. Add retention times to a PCDL

In this exercise, you will add retention times to the custom PCDL created in 
Exercise 6.

 

Steps Detailed Instructions Comments

1 Open the custom PCDL you 
created in Exercise 6 and edited in 
Exercise 7, if it is not already open.

a Select Open PCDL from the File menu, 
or click the  toolbar button.

b Select the Sulfas_AM_Custom.cdb 
file, and click the Open button.

None of the compounds in this 
example PCDL have retention times.

2 Enable editing for this PCDL. a Open the PCDL menu.
b Mark Allow Editing if it is not 

currently marked.

A new PCDL is automatically enabled 
for editing when it is created.

3 Click the Batch Search tab.

4 Open a mass list file that contains 
retention time information for the 
masses.

a Click the File button to the left of the 
mass list table.

b Select sulfa_compounds.txt in the 
MassHunter\PCDL\Mass List Files 
folder.

c Click the Open button.

Each mass in the mass list must have 
an associated retention time value.

5 Set the search parameters. a Set the Mass tolerance to 100 ppm.
b Mark Retention times Optional.
c Set the RT tolerance to 1 minute as 

shown below:

6 Start the search. Click the Find Compounds toolbar button.
The number of hits for each mass 
appears in the Hits column of the mass 
list.  
In this example, hits were found for four 
masses, which appear at the top of the 
mass list. See Figure 7.

To sort the list by a different criterion, 
click the heading for the column of 
interest.
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7 Resolve conflicting hits. Masses with conflicting hits are shown 
in red text in the Mass List table. 

This example has no conflicting hits 
so you can skip this step.

8 Click the Batch Summary tab. See Figure 8.

9 Update retention times in the 
PCDL from the current mass list.

Click the Apply Retention Times button.
Note that this button is unavailable until 
all conflicting hits are resolved as 
described in Step 7.

Retention time information is updated 
in the PCDL for each of the 
compounds listed in the Batch 
Summary table. See Figure 9.

Figure 7 Batch Search Results with Retention Time Optional

Steps Detailed Instructions Comments
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Figure 8 Batch Summary Results with Retention Time Optional (before updating)
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Figure 9 Batch Summary Results with Retention Times Updated
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