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No part of this manual may be reproduced 
in any form or by any means (including 
electronic storage and retrieval or transla-
tion into a foreign language) without prior 
agreement and written consent from Agi-
lent Technologies, Inc. as governed by 
United States and international copyright 
laws.

Warranty

The material contained in this docu-
ment is provided “as is,” and is sub-
ject to being changed, without notice, 
in future editions. Further, to the max-
imum extent permitted by applicable 
law, Agilent disclaims all warranties, 
either express or implied, with regard 
to this manual and any information 
contained herein, including but not 
limited to the implied warranties of 
merchantability and fitness for a par-
ticular purpose. Agilent shall not be 
liable for errors or for incidental or 
consequential damages in connection 
with the furnishing, use, or perfor-
mance of this document or of any 
information contained herein. Should 
Agilent and the user have a separate 
written agreement with warranty 
terms covering the material in this 
document that conflict with these 
terms, the warranty terms in the sep-
arate agreement shall control.

Technology Licenses 

The hardware and/or software described in 
this document are furnished under a 
license and may be used or copied only in 
accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of 
a U.S. Government prime contract or sub-
contract, Software is delivered and 
licensed as “Commercial computer soft-
ware” as defined in DFAR 252.227-7014 
(June 1995), or as a “commercial item” as 
defined in FAR 2.101(a) or as “Restricted 
computer software” as defined in FAR 
52.227-19 (June 1987) or any equivalent 
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52.227-19(c)(1-2) (June 1987). U.S. Govern-
ment users will receive no greater than 
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(June 1987) or DFAR 252.227-7015 (b)(2) 
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Safety Notices

CAUTION

A CAUTION notice denotes a haz-
ard. It calls attention to an operat-
ing procedure, practice, or the like 
that, if not correctly performed or 
adhered to, could result in damage 
to the product or loss of important 
data. Do not proceed beyond a 
CAUTION notice until the indicated 
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operating procedure, practice, or 
the like that, if not correctly per-
formed or adhered to, could result 
in personal injury or death. Do not 
proceed beyond a WARNING 
notice until the indicated condi-
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Introduction

Install the Quant-My-Way Flavors Setup Program    6

Open the Quant-My-Way Flavors Setup Program    8

The Agilent MassHunter Workstation Quantitative Analysis B.09.00 
software provides tools to customize, save, and share a Quantitative 
Analysis flavor.

A MassHunter Quantitative Analysis flavor is a user interface with a 
specific set of tools and options. The Quantitative Analysis software 
provides a preset number of system flavors designed for several 
instruments and applications.

Use the Quant-My-Way Flavors Setup program to create customized 
Quantitative Analysis flavors that display the tools and menu options you 
need for your laboratory or function. Your custom flavors can then be 
saved, updated, and shared with others in your organization.
5Agilent Technologies



1 Introduction
Install the Quant-My-Way Flavors Setup Program
6

The Quant-My-Way Flavors Setup program can be installed alone or with any 
other Quantitative Analysis feature during the MassHunter Workstation 
Quantitative Analysis B.09.00 installation. The Quant-My-Way Flavors Setup 
program should be installed on the workstation where a user will be creating 
and editing custom flavors.

You can install the Quant-My-Way Flavors Setup program during the 
MassHunter Workstation Quantitative Analysis installation (“Install 
Quant-My-Way Flavors Setup during installation), or it can be installed after 
Quantitative Analysis has already been installed (“Install Quant-My-Way 
Flavors Setup after installation" on page 7).
Install Quant-My-Way Flavors Setup during installation
1 During the MassHunter Workstation Quantitative Analysis B.09.00 
installation, on the Features screen, select Quant-My-Way Flavors Setup Tool.

2 Click Next, and continue to complete the installation.
Quant-My-Way Flavors Setup Familiarization Guide
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Install Quant-My-Way Flavors Setup after installation
Quant-My-Way Flavo
1 If the MassHunter Workstation Quantitative Analysis B.09.00 software has 
already been installed, from the Windows Control Panel, open Programs and 
Features.

2 Select Agilent MassHunter Workstation Quantitative Analysis B.09.00, and click 
Change.

3 On the Agilent MassHunter Workstation Installer Maintenance screen, click 
Change.

4 On the Features screen, select Quant-My-Way Flavors Setup Tool.

5 Click Next, and continue to complete the installation.
rs Setup Familiarization Guide 7
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Open the Quant-My-Way Flavors Setup Program
8

Windows 7: Select Windows Start > All Programs > Agilent MassHunter 
Quantitative Analysis Tools > Quant-My-Way Flavors Setup.

Windows 10: Select Windows Start > All Programs > Agilent MassHunter 
Quantitative Analysis Tools, and open the Quant-My-Way-Flavors Setup program.
Quant-My-Way Flavors Setup Familiarization Guide
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Create and Manage Flavors

Create a Root Folder Location to Store Custom Flavors    10

Create a Flavor    12

Use the Quant-My-Way Flavors Setup program to create a custom flavor 
and manage your existing custom flavors and folders.
9Agilent Technologies



2 Create and Manage Flavors
Create a Root Folder Location to Store Custom Flavors
10
The root folder is the directory folder where you will store your flavors. You 
can use any convenient location in your directory.

1 On the Flavor Root screen, click Open Root Folder.

2 Navigate to an existing folder, or create a New Folder, and click Select Folder.
Quant-My-Way Flavors Setup Familiarization Guide



Create and Manage Flavors 2

Quant-My-Way Flavo
The Flavor root folder path is displayed, and the existing Flavors are listed.
rs Setup Familiarization Guide 11



2 Create and Manage Flavors
Create a Flavor
12
Create a flavor based on a standard system flavor, and then modify it as 
needed for display name, Batch Table, ribbon options, sample types, outliers, 
or by adding your own custom ribbon buttons and menus.

In this example, we will create a QQQ flavor that simplifies the user interface 
to include only the functions needed to perform routine data analysis. The 
method development functionality will be removed, as well as other 
non-essential data analysis tools.

1 On the Flavor Root screen, click New.

2 Enter a Folder name. This name will be used as the flavor name in the root 
folder. It will also be used as the default display name of the desktop icon 
and user interface of your flavor unless the display name is changed in the 
general settings. For this example, enter Data Analysis.

3 Select a standard system flavor Instrument on which to base your flavor.

4 Click New. 
Quant-My-Way Flavors Setup Familiarization Guide



Create and Manage Flavors 2

Quant-My-Way Flavo
A folder is created in your root folder containing the configuration file 
(startup.xml) for your flavor.

Continue your customization by updating the Batch Table, ribbon options, 
sample types, outliers, or by adding your own custom ribbon buttons and 
menus. See “Customize a Flavor" on page 15.
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Customize a Flavor

Remove Batch Table Columns    16

Customize the Quant-My-Way Ribbon    19

Create a Custom Ribbon Button    21

Update your flavor with a new display name, Batch Table, ribbon, sample 
type, outliers, or with your own custom ribbon buttons and menus.
15Agilent Technologies



3 Customize a Flavor
Remove Batch Table Columns
16
1 On the Flavor Settings > Batch Table Settings screen, select Flat Table (Multiple 
Compounds) from the Default Batch Table Layout list.

2 Select Flat Table (Multiple Compounds) from the Batch Table Layout list.
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Customize a Flavor 3

Quant-My-Way Flavo
3 Remove the following Default Visible Columns:

• Quantitation Message Summary

• Outlier Summary

• Data File

• Type

• Level

• Acq. Date-Time

4 Select Compound Results from the Table list.
rs Setup Familiarization Guide 17
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3 Customize a Flavor
5 Remove the following Default Visible Columns:

• RT

• Accuracy

6 Click Save Settings.
Quant-My-Way Flavors Setup Familiarization Guide
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Customize the Quant-My-Way Ribbon
Quant-My-Way Flavo
1 On the Flavor Settings > Ribbon Settings screen, remove the following:

• Method tab

• Calibration menu (Home > Analyze)

• Integrate menu (Home > Analyze)

• Clear Results button (Home > Analyze)
rs Setup Familiarization Guide 19
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3 Customize a Flavor
• Open Report Folder button (Home > Report)

• Queue Viewer button (Home > Report)

• Edit Report Method button (Home > Report)

• Library Search Results button (Home > Report)

• Library Search Reports menu (Home > Report)

2 Click Save Settings.
Quant-My-Way Flavors Setup Familiarization Guide



Customize a Flavor 3
Create a Custom Ribbon Button
Quant-My-Way Flavo
To create a custom ribbon button in the Quant-My-Way Flavors Setup program, 
you must create Python script for the button functionality. The script file (.py) 
must be saved in a Tools folder within your custom flavor folder. In this 
example, the script ZeroExceptionPeaks.py would be saved in D:\My Root Folder\
Data Analysis\Tools.

1 Select the Analyze menu in the right pane (Home > Analyze).

2 In the left pane, select Zero Peak, and click Add to add it to the Analyze menu.
rs Setup Familiarization Guide 21
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3 Customize a Flavor
3 Select the Zero Peak button in the right pane, and click Properties.

4 Select Image only from the Minimum size list.

5 Select Image and text (Large) from the Maximum size list.

6 In the Custom script module field, enter ZeroExceptionPeaks.

7 In the Custom script execute field, enter ZeroExceptionPeaks.Execute(ToolState, 
UIState).

8 In the Custom script set state field, enter ZeroExceptionPeaks.SetState(ToolState, 
UIState).

9 Click OK.
Quant-My-Way Flavors Setup Familiarization Guide
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Quant-My-Way Flavo
10 Click Save Settings.
rs Setup Familiarization Guide 23
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3 Customize a Flavor
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Share and Install a Flavor

Make a Flavor Available for Use    26

Install a Flavor    29

You can make custom flavors available to others in your organization to 
install and use in Quantitative Analysis.
25Agilent Technologies



4 Share and Install a Flavor
Make a Flavor Available for Use
26
After you have created a custom flavor, you can make it available to others in 
your organization to use for data analysis by deploying it in the Quant-My-Way 
program.

1 Open the root folder of the flavor you would like to make available for use.

2 Click Deploy.

3 Use the default Destination, or enter the folder path where you want to save 
your deployment file. 

4 Use the default installation file name, or enter a new name. The date is used 
for the default name.
Quant-My-Way Flavors Setup Familiarization Guide



Share and Install a Flavor 4

Quant-My-Way Flavo
5 Embed or Link the flavor configuration to the installation file that will be 
created for this deployment.

• In an embedded deployment, a flavor will remain as it was configured 
when it was installed on a workstation. 

• In a linked deployment, a flavor will update whenever it is updated in 
the Quant-My-Way Flavors Setup program.

6 Select the Configurations to deploy. Multiple flavors in a root folder may be 
deployed as a group. Installing this deployment file will install all the 
flavors selected.
rs Setup Familiarization Guide 27
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4 Share and Install a Flavor
7 Click OK. A deployment file (QUANTSTUPS File) is created. The deployment 
file is used to install the flavors included in this deployment onto the 
workstation where you want to use them for data analysis.
Quant-My-Way Flavors Setup Familiarization Guide



Share and Install a Flavor 4
Install a Flavor
Quant-My-Way Flavo
After the custom flavor is deployed, it is available to you or others in your 
organization to install on a workstation for quantitative analysis.

1 Install MassHunter Workstation Quantitative Analysis B.09.00 on the 
workstation where you want to install the custom flavor. The 
Quant-My-Way Flavors Setup program is not required to install a flavor.

2 From the Windows directory on the workstation where you want to install 
the flavor, navigate to and open the deployment file (QUANTSTUPS file) 
containing the flavor you want to install.

3 Use the selected Deployment file, or browse to the QUANTSTUPS file you 
want to install.

4 Use the default Destination folder, or enter the folder path where you want to 
save your flavor files.

5 Click OK. The flavor is installed on the workstation, and a shortcut icon to 
the flavor is added to the desktop.

When the flavor is launched for use, the Quantitative Analysis user interface 
will be displayed in the Windows operating system language of the workstation 
where it is launched.
rs Setup Familiarization Guide 29
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4 Share and Install a Flavor
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