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Process Data
Terminology
Process Data
Refer to the Quick Start Guide for an overview of the MassHunter Mass 
Profiler Software.

Processing data in Mass Profiler begins with creating a project that contains 
sample files that are arranged in one or two groups. A method is then created 
to set feature finding, alignment, normalization, and filtering parameters. You 
can create and save multiple methods and projects to widen and narrow the 
set of features to consider for further analysis or for emphasizing during the 
acquisition of new data.

The following tasks are presented in this section:

• “Create a project” on page 3

• “Edit a method” on page 6

• “Perform a PCA analysis” on page 13

• “Apply a different method” on page 18

• “Edit a project” on page 18

Terminology
Algorithm An algorithm is a set of automated, sequential mathematical tasks performed 

to find, filter, align, extract, compare, and identify features from your 
chromatographic/mass spectral data sets.

Feature A feature is synonymous with compound. A feature is referred to 
interchangeably with compound, descriptor, element, entity, metabolite, or 
molecular feature during the various steps of analysis using MassHunter 
software. A feature can consist of one or multiple related ions, including 
isotopes, and different ion species (charge carrier, multimers) and charge 
states. For LC/IM-MS data, ions representing different ion species and charge 
state are not combined because these ions are typically separated by drift time 
in the ion mobility stage.

Group Samples that have a common relationship within the definition of the 
experiment design, for example, samples from a group of healthy versus 
diseased specimen. Related samples are grouped together for analysis. For a 
project with two groups, Mass Profiler initially assigns “Experiment” and 
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“Control” for the group names. Because the these default names can be 
changed this guide may refer to the Experiment group as <Group 1> and the 
Control group as <Group 2>.

IMFE Refers to the algorithm that operates on LC/IM-MS data to group all of the 
isotopes from the same adducted neutral molecule into a single, reported 
feature. IMFE is short for IM-MS feature extractor or IM-MS feature extraction.

Method A method is a set of all the parameters used for processing sample files in a 
Mass Profiler project, including feature finding, aligning, normalizing, and 
filtering. Methods can be saved using unique file names.

MFE Refers to the algorithm that operates on GC/MS and LC/MS data to group all 
of the isotopes from all of the ion species derived from the same neutral 
molecule into a single, reported composite compound. MFE is short for 
molecular feature extractor or molecular feature extraction.

Project Two samples, or one or two sample groups, and the associated method that 
form your feature analysis and investigation. A project can be saved and 
opened at a later time to continue your analysis.

Sample GC/MS and LC/MS data acquired from a specimen and understood to be 
representative of the larger specimen or population. Individual samples are 
imported into Mass Profiler in the form of raw data files, CEF files, or CSV 
files.

Workflow A workflow is a sequence of steps executed for an analytical task, the type and 
sequence of which can be documented via a graphical overview. A workflow 
may cover more than one wizard and may include steps performed by more 
than one MassHunter software program.

Create a project
1 Click File > Create Project, or click the Create Project button  on the 

toolbar.

2 Enter general project information in the Create Project dialog box 
(Figure 1 on page 4):

a Select 1 or 2 sample groups for the Number of groups.

b Type a Project name. This project name is automatically used as the 
project file name when you save your project.
Mass Profiler Familiarization Guide 3
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c Select the Input data type.

Figure 1 Create Project dialog boxes for one and two group projects.

Input data types *.d (MFE) - MassHunter data file - A raw data file from MassHunter Data 
Acquisition software. For this data type Mass Profiler finds the 
compounds (using MFE or IMFE, depending on the instrument used to 
acquire the data) and analyzes the results using all of the available 
method parameters. If more than one sample is part of a project, feature 
extraction automatically runs the recursive grouping of ions.

*.cef (MFE, FbF) - CEF file - A compound exchange format file from 
another MassHunter software program. For this data type the features 
have already been found in the original data file using Find by Molecular 
Formula (MFE) or Find by Formula (FbF); Mass Profiler analyzes the 
results using the method parameters except those related to finding 
features (Input filters and Sample chemistry and ionization). If the CEF 
files contain identifications for features (name and/or formula), the 
features are forced to align. Otherwise alignment is based on mass and 
RT values.

*.csv (RT, Mass, Abund.) - CSV file - A generic data file in which the 
features have already been found. The file must begin with a header row 
that contains the text RT, Mass, Abundance (in any order). 
4 Mass Profiler Familiarization Guide
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Subsequent rows contain the numerical information in the same order, 
separated by commas, for each feature and with one feature per row. 
Because of the limited feature information available, Mass Profiler 
analyzes the results using only the parameters available in the 
Alignment & Normalization tab and a portion of the parameters 
available in the Statistics & Filters tab.

3 Set up the first, or only, group of samples as follows:

a Type a name for the Group name, or accept the default name 
Experiment.

b Click Add to open the Folder Selector dialog box (for .d files) or the 
Select Files dialog box (for .cef and .csv files).

c Select the sample files to add to the group. Press and hold SHIFT or CTRL 
and click the mouse button to select multiple files.

d Click OK or Open. The files you selected are listed under the first group 
in the Create Project dialog box.

e Repeat steps b through d to add additional samples if desired, but each 
file can be added to the project only once.

NOTE: To remove a sample from a group, click in the leftmost column of 
the sample row, the column without header text, to select the row, then 
click Delete.

4 Set up the second group of samples, if applicable, as follows:

a Type a name for the Group name, or accept the default name Control.

b Repeat steps b through e in step 3 to add samples to the group.

5 Mark Open method on OK to immediately open and edit the method 
parameters after you click OK in the Create Project dialog box (default 
setting).

6 (Optional) Enter a value in the Scalar column for any sample to multiply 
the feature abundance values in that sample by the value entered.

7 Click OK. If Open method on OK is marked the Method Parameters dialog 
box is opened, otherwise you are returned to the Mass Profiler main 
window. The Mass Profiler main window only displays results after you run 
a method. 

NOTE: A warning  is displayed after you click OK if a file appears in the 
project more than once or one group does not contain any data files.
Mass Profiler Familiarization Guide 5
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Edit a method
1 Click Method > Edit Method, or click the Edit Method  button on the 

toolbar.

2 Enter parameters in the Method Parameters dialog box.

Edit the parameters in the Method Parameters dialog box by selecting one 
of two editing modes at the bottom of the dialog box as shown in Figure 2. 
The default editing mode, Commonly changed parameters, presents the 
method parameters in a simplified view within the dialog box.

Figure 2 Method parameter editing modes

The method parameters for the Commonly changed parameters mode for 
two different two-group projects is shown in Figure 3.

Figure 3 Method Parameters dialog box when you have a two group project: (left) two 
or more samples per group and (right) one sample per group.
6 Mass Profiler Familiarization Guide
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Figure 4 Method Parameters dialog box with default values for All parameters mode

Method Parameters dialog 
box “All parameters” tabs 
for a two group project 
containing two or more 
samples per group.

Note: Parameters within the 
dashed box of the Feature 
Finding/Loading tab (upper 
image) are not available for 
IM-MS data. Parameters 
within the dashed box of 
the Statistics & Filters tab 
(lower right image) are only 
available for IM-MS data.
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The method parameters for the All parameters mode, shown in Figure 4 on 
page 7, are edited using a sequence of three tabs according the workflow:

• Feature Finding/Loading: see “Find features” on page 10

• Alignment & Normalization: see “Align features” on page 11 and 
“Normalize abundance and correct RT of features” on page 11

• Statistics & Filters: see “Report statistics and feature filters” on page 12

3 Exit the method editor when you have reviewed the method parameters:

a Click OK to save the method changes in memory and exit the method 
editor.

b Click Cancel to discard the method changes and exit the method editor.

c Click Run to save the method changes in memory, exit the method editor, 
and process the samples in the current project using the current method 
parameters. The results are displayed in the Feature Plot and Feature 
Table in the Mass Profiler main window as shown in Figure 5 on page 9.

To quickly obtain results using a different method, click Method > Load 
Method and Run.
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Figure 5 The main functional areas of Mass Profiler after a method is run on a project. If selected in the View 
menu, the Feature Plot can be replaced with a Features Details pane shown in Figure 6 on page 10.
Mass Profiler Familiarization Guide 9
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Save your method 4 Save your method to disk as an .mpm file using one of the following options:

a Click Method > Save Method, or click the Save Method  button on 
the toolbar to save the method using the current name.

b Click Method > Save Method As, to save the method using a new name 
using the Save Method As dialog box. 

Save your project 5 Save your project using one of the following options (a copy of the method 
parameters used to create the results is embedded with the project):

a Click File > Save Project, or click the Save Project  button on the 
toolbar to save the changes to the current project.

b Click File > Save Project As to save the changes to the current project 
using a new name using the Save Project As dialog box. 

Find features

The find feature parameters are only available for MassHunter sample data 
files described in “Input data types” on page 4. Figure 7 on page 11 shows the 
available feature finding parameters for the two editing modes.

Figure 6 When you click View > Switch to Feature-Details Mode from the menu, the Feature Details pane 
replaces the Feature Plot pane in the main window shown in Figure 5 on page 9.
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Figure 7 Default feature finding parameters in the Method Parameters dialog box for 
LC/MS data files using both editing modes

Align features 
The alignment parameters are available for all of the sample data files 
described in “Input data types” on page 4. Features are aligned based on 
tolerance values entered for the retention time and mass.

Figure 8 Default feature alignment parameters in the Method Parameters dialog box 
are identical for both editing modes

Normalize abundance and correct RT of features 
The normalization and retention time correction parameters are available for 
all of the sample data files described in “Input data types” on page 4. By 
default samples are not abundance normalized or retention time corrected 
and these parameters are only available for editing in the All parameters 
mode.

Commonly changed parameters All parameters
Mass Profiler Familiarization Guide 11
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Figure 9 Example feature abundance normalization and RT correction parameters with 
an example internal standard in the Method Parameters dialog box in the All 
parameters mode

Abundance normalization and RT correction are applied to the samples in the 
project by marking Apply and selecting the mode Without standards or With 
standards, respectively.

Without standards mode: Mass Profiler applies a maximum RT correction 
using the RT tolerance. This value should be higher than the RT tolerance for 
alignment, and be set based on the RT shifts expected between the data files. 
This alignment is used for a preliminary alignment during feature finding so 
that the Mass Profiler can statistically determine and correct the time shifts 
between the samples.

With standards mode: Mass Profiler uses the internal standards as defined 
under the Internal standard definitions heading. The number of internals 
standards is entered and the RT and neutral mass for each internal standard 
is specified. Mark the respective internal standards to define whether to use 
the internal standard for abundance normalization (Norm.), RT correction 
(Corr.), or both.

Report statistics and feature filters
Reporting statistics and feature filtering parameters are available for all of the 
sample data files described in “Input data types” on page 4. Group statistics 
are only available for projects that contain two groups.
12 Mass Profiler Familiarization Guide
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Figure 10 Example statistics reporting and feature filter parameters in the Method Pa-
rameters dialog box for both editing modes. The Sample occurrence filter is 
only enabled for projects with two groups where each group contains two or 
more samples.

Perform a PCA analysis
Mass Profiler includes a statistical tool referred to as Principal Component 
Analysis (PCA) that employs a mathematical process by which the features 
found within your data are transformed into a new set of data in relation to 
variables called principal components. Each principle component is optimized 
to account for the maximum variability in the features among the samples 
with your project. For a project with a single group the PCA can help you 
identify samples that are more closely related. For a project with two groups 
the PCA helps you identify whether variations among the features separate 
the samples by group.

Using PCA you can easily identify and mark the features that account for 
greatest similarity, or difference, among your samples and return the marks to 
your Feature Table summary.

Commonly changed parameters All parameters
Mass Profiler Familiarization Guide 13
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Figure 11 Principal Component Analysis dialog box for a project that contains two 
groups and 10 samples per group

Shortcut menus within the PCA plots provide options applicable to the 
context where you click and to your current view (Figure 12). 

Figure 12 The shortcut menu commands available within the Principal Component 
Analysis dialog box

1 Click View > Principal Component Analysis > For All Features in Table to 
become familiar with the capabilities of PCA. Other options for starting 

C-C Plot2D Score Plot
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PCA are noted in “Principal Component Analysis menu” in the Quick Start 
Guide.

2 Mark Using log2 abundance to transform the abundance values of the 
features to log base 2 for the PCA calculations. This is marked by default.

3 Mark Normalizing by feature deviation to normalize the abundance values 
of the features by their standard deviation for the PCA calculations. This is 
marked by default.

4 Review the Variance(%) and Cumulative Variance (%) in the Principal 
Components table in the top-left of the Principal Component Analysis 
dialog box (Figure 11 on page 14). If the variance of the first principal 
component is large (a value that is closer to 100%), a clear separation 
between sample groups is possible and is usually reflected by a visual 
separation on the 2D Score Plot. If the variance of the first principal 
component is small (a value that is closer to zero), there is a degree of 
visual overlap between sample groups on the 2D Score Plot.

(Row Number) The leftmost column, without a column heading, contains the 
row number for the principal components. The row number order does not 
change when the principal components are sorted by any of the data 
columns.

Component Each principal component is labeled with a number 
corresponding to the component’s share of the PCA variance. The lower 
number principal components account for more of the variance in the 
group or feature difference. The Principal Component Table is initially 
sorted by the component Variance(%) value, but the sort order can be 
changed by clicking on any column heading.

Variance (%) The amount of variance that a single principal component is 
able to account for out of the total possible group or feature variance.

Cumulative Variance (%) The sum of the variance that successive principal 
components are able to account for out of the total possible group or 
feature variance.

5 Review the separation, or similarity, of your samples in the 2D Score Plot 
in the lower-left of the Principal Component Analysis dialog box (Figure 11 
on page 14). You can select any of the principal components to plot against 
each other to view how each principal component separates your samples. 
Available shortcut menu options are shown in Figure 12 on page 14.

6 Review the features and their principal component attributes Features 
table in the top-right of the Principal Component Analysis dialog box 
(Figure 11 on page 14). You can view the attributes for any of the principal 
Mass Profiler Familiarization Guide 15
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components using the drop-down list box above the table. When you select a 
different principal component the table and the C-C Plot automatically 
update.

(Row Number) The leftmost column, without a column heading, contains the 
row number for the features. The row number order does not change when 
the features are sorted by any of the data columns.

 ID An identification (ID) number is assigned to each feature based in 
descending order of the feature abundance. The table is initially sorted by 
the ID value, but the sort order can be changed by clicking on the heading of 
any other column.

Mark The check boxes in this column are used to Mark one or more features 
of special interest to your project. You can mark the features manually or 
based on features that appear in the C-C Plot. The mark annotations are 
transferred to the Feature Table when you click OK. If you select a feature 
in error, click the check box again or use the C-C Plot to clear the mark.

Formula If you have identified features with ID Browser this additional 
column appears and shows the molecular formula for identified features 
(see “Identify Features” on page 29).

Name If you have identified features with ID Browser this additional 
column appears and shows the name for the identified features (see 
“Identify Features” on page 29).

CAS If you have identified features with ID Browser and the compound ID 
includes CAS numbers, this additional column appears.

RT Average retention time of the feature.

DT Average drift time of the feature. (LC/IM-MS data)

Mass Average neutral mass of the feature.

Diff. Score The differential score is a value between 0 and 100 that 
represents whether the data groups are significantly different. The score is 
calculated using the Student’s t-test. A larger value indicates a higher 
confidence that the data sets in the two groups are different. The project 
must have more than one sample per group to display this attribute.

RMS The calculated root mean square (RMS) error computed for each 
feature during the PCA modeling.

Loading A calculated value during the PCA modeling that can help identify 
which features account for the greatest variation in the PCA. Entities with a 
larger loading are more significant to the sample differentiation. The sum of 
16 Mass Profiler Familiarization Guide
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the squared loadings of all the features of a given principal component is 
equal to one. The positive or negative sign of a particular principal 
component is arbitrary.

Correlation A reliability value for the feature. Numerical values closer to ±1 
are more reliable and more significant to the sample differentiation.

7 Review the correlation and covariance relationship of the features in the 
C-C Plot in the lower-right of the Principal Component Analysis dialog box 
(Figure 11 on page 14). The C-C Plot automatically updates when you select 
a different principal component and when you change the abundance 
transformation.

The C-C Plot shows the covariance and correlation coefficients resulting 
from the PCA model in a scatter plot. In this plot both magnitude 
(covariance) and reliability (correlation) are visualized. 

The covariance (Cov) and correlation coefficient (Cor) are calculated by the 
following equations:

Cov = Sum(ps* fs)/(N-1)

Cor = Sum(ps* fs)/Sqrt(Sum(ps*ps)*Sum(fs*fs));

where,
ps is the principal component value measured by sample s,
fs is the feature value measured by sample s,
Sum are value summations over all of the samples, and
N is the number of samples.

Available shortcut menu options are shown in Figure 12 on page 14. In 
particular, using the zoom functionality and the shortcut menu you can 
easily mark and clear feature that meet your analysis objectives.

8 Click OK when you have completed your review and selection (marking) of 
the features that meet your analysis objectives and you want to return to 
the main Mass Profiler window. The marked features appear with a mark in 
the new column PCA Mark in the Feature Table.

9 Save your project using one of the following options (a copy of your method 
is embedded with the project):

a Click File > Save Project, or click the Save Project  button on the 
toolbar to save the changes to the current project.

b Click File > Save Project As to save the changes to the current project 
using a new name using the Save Project As dialog box. 
Mass Profiler Familiarization Guide 17
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Apply a different method
This procedure helps you quickly process a project using different methods.

1 Click Method > Load Method and Run to open the Open dialog box.

2 Select a method in the Open dialog box.

3 Click Open to load and automatically apply the method to your current 
project. The parameters in the selected method are applied to the current 
project and the results are immediately displayed in the Feature Table and 
Feature Plot.

4 Save your project using one of the following options (a copy of your method 
is embedded with the project):

a Click File > Save Project, or click the Save Project  button on the 
toolbar to save the changes to the current project.

b Click File > Save Project As to save the changes to the current project 
using a new name in the Save Project As dialog box. 

Edit a project
This procedure helps you change the properties of an existing project, such as 
project name, group names, sample composition, and sample scalar values. To 
change the Number of groups or the Input data type you must create a new 
project.

1 Click File > Edit Project to open the Edit Project dialog box.

2 Make the desired changes to the project, in the same fashion described in 
“Create a project” on page 3.

3 Exit the Edit Project dialog box by:

a Click OK on the Create Project dialog box to open the Method 
Parameters dialog box, if Open method on OK is marked. If Open 
method on OK is cleared your changes to the project are retained and 
the Create Project dialog box is closed.

b Click Cancel to return to disregard any changes you have made to the 
current project and return to the main window.

c Click Run to automatically process the project samples using the current 
method and update the results displayed in the Feature Table and 
Feature Plot in the main window.
18 Mass Profiler Familiarization Guide



Process Data
Edit a project
4 Save your project using one of the following options (a copy of your method 
is embedded with the project):

a Click File > Save Project, or click the Save Project  button on the 
toolbar to save the changes to the current project.

b Click File > Save Project As to save the changes to the current project 
using a new name using the Save Project As dialog box. 
Mass Profiler Familiarization Guide 19
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View Results
When a project is processed with the current method parameters the results 
are shown automatically in the Feature Table and Feature Plot areas of the 
Mass Profiler main window. Processing is performed and the main window is 
updated after the following actions:

• Click Run in the Method Parameters dialog box

• Click Method > Load Method and Run

• Click Method > Run Current Method

• Click the Run Current Method  button

Results are also shown when you open a project, although no new processing 
is done unless you do one of the above actions.

The following view tasks are presented:

• “View results in the Feature Table”

• “View results in the Feature Plot” on page 21

• “View results in the Feature Details” on page 22

• “View the feature in IM-MS Browser (LC/IM-MS data)” on page 24

• “Print, save, or copy the Feature Plot image” on page 25

• “Find more feature information from database websites” on page 25

• “View the feature abundance distribution” on page 26

• “View the global occurrence histograms” on page 27

View results in the Feature Table
The Feature Table (see Figure 5 on page 9) shows the results of processing the 
sample files selected in your project with the current method. The table can be 
sorted by the values in any column by clicking on the corresponding column 
heading. See “Feature Table” in the Quick Start Guide for an overview of the 
information you can view in the Feature Table.

Other columns are added to the table to show the results of performing a PCA 
(“Perform a PCA analysis” on page 13) and identifying features using the ID 
Browser program (“Identify Features” on page 29).
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For a project with two groups, the results of the comparison of the groups is 
viewed as follows:

1 Scroll horizontally to view the feature details under the Comparison 
heading located on the right of the table.

2 Click the Expression heading to sort the features by up-regulation and 
down-regulation. Regulation indicates features that have an increased (up) 
or decreased (down) average abundance in <Group 1> relative to <Group 
2>.

3 Right-click on any row number cell on the left side of the Feature Table to 
access the shortcut menu options: View Feature Details in IM-MS Browser 
(for LC/IM-MS data files only), Feature Details, Abundance Distribution 
(only for projects with 2 sample groups and at least 3 sample files), 
Identification Lookup, and Web mass search.

4 To copy the contents of the table for use in another program, drag the 
mouse to select the cells of interest (or click on any one or more row 
number) then press CTRL-C to copy the data to the clipboard. The copied 
contents can then be pasted into other applications, such as a text editor or 
a spreadsheet.

View results in the Feature Plot
The Feature Plot shows a graphical result of processing the project with the 
current method. By adjusting the parameters you can adjust any plot to 
visualize the feature differences by sample and group. The relative size of the 
plot markers representing a feature is an indication of the average abundance 
of the feature. See “Feature Plot” in the Quick Start Guide for an overview of 
the information you can view in the Feature Plot.

Inspection of the features in the Mass vs. RT plot is as follows:

1 Move the pointer over a data point (feature) on the plot to display a brief 
description of that feature (Figure 13 on page 22). The size of a marker 
indicates the abundance of a feature: the larger the marker, the more 
abundant the feature.
Mass Profiler Familiarization Guide 21
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Figure 13 Feature information in the Feature Plot

2 Click and drag the pointer within the graph to define an area to enlarge. 
The area expands when you release the mouse button.

3 Change how and which features are displayed in the Feature Plot as 
described in “Feature Plot” in the Quick Start Guide.

4 Right-click in any Feature Plot graph plot to access the shortcut menu 
options described on “Plot shortcut commands” in the Quick Start Guide.

View results in the Feature Details
The Feature Details (see Figure 6 on page 10) shows the details of the feature 
selected when you double click on the row number of a feature in Feature 
Table. The data presented in Feature Details is organized in four panes: a table 
with the Feature Details by Sample, a table with the Feature Details by Ion, 
and, if available for the imported data type, extracted ion chromatograms (for 
LC/MS data), drift spectra (for LC/IM-MS data), and mass spectra of the 
feature for each sample data file. See “Feature Details” in the Quick Start 
Guide for an overview of the information you can view in the Feature Details.

Two data view modes, Feature-Details mode and Feature-Plot mode, are 
available to help you view your results. You can switch between the two modes 
using the menu item View - Switch to Feature-Details Mode, which then 
changes to View - Switch to Feature-Plot Mode allowing you to switch back.

• If Feature Details are requested in the Feature-Plot mode, the details 
show in the Feature Detail View dialog box. 
22 Mass Profiler Familiarization Guide
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• If Feature Details are requested in Feature-Details mode the details 
show in the lower half of the main window by updating the Feature 
Details pane.

Use this procedure to view more information about a selected feature. The 
available information is limited for CEF and CSV file types.

1 Open the Feature Details for a selected feature in any of the following ways:

From the Feature 
Table

• Click the row number of the feature of interest in the Feature Table, then 
click View > Feature Details for Selected Feature to view the Feature 
details.

• Right-click the row number for the feature in the Feature Table, and 
select Feature Details from the shortcut menu.

• Double-click the row number of the feature of interest in the Feature 
Table to view the Feature details.

From the Feature 
Plot

• Right-click on the feature of interest in the Feature Plot, and select 
Feature Details from the shortcut menu. 

2 Review the information for the feature in all the samples in the Feature 
Details by Sample table in the top left pane as described in “Feature details 
by sample” in the Quick Start Guide. Note the selected feature may not be 
present in every sample in the project.

3 Double-click a row (sample) in the Feature Details by Sample table to view 
the information for the feature in the Feature ions pane as described in 
“Feature details by ion” in the Quick Start Guide. The information 
displayed depends on the input data type of the sample.

4 Double-click a row (ion species) in the Feature Details by Ion table to view 
a pane that contains the extracted ion chromatogram (for LC/MS data) or 
the drift spectra (for LC/IM-MS data). These panes are described in 
“Extracted Ion Chromatograms (LC/MS data)” in the Quick Start Guide 
and “Drift Spectra (LC/IM-MS data)” in the Quick Start Guide.

5 Experiment with the shortcut menu options are described in “Feature 
Details shortcut menu” in the Quick Start Guide.
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View the feature in IM-MS Browser (LC/IM-MS data)
The MassHunter IM-MS Browser is an application that supports interactive 
browsing and visualization of data from single LC/IM-MS data files, extraction 
of various 2D and 3D subsets of that data, finding of features, exporting of 
extracted data in a variety of formats, and collision cross section calculations.

Launching IM-MS Browser

If your project contains only one or two samples, a feature can be viewed in 
the IM-MS Browser. Select the row of the desired feature and click View > 
Selected Feature in IM-MS Browser or View feature in IM-MS Browser from 
the context sensitive shortcut menu. One or two IM-MS Browser windows 
open, automatically extract frames across the elution time of the feature, and 
zoom the frame viewer into the feature using reasonable drift time and m/z 
ranges, whether the feature is present in both data files or only one.

When you select another row (feature) and view the feature in IM-MS Browser, 
when IM-MS Browser is already open, the two open IM-MS browser windows 
refresh accordingly. The previous feature(s) stay in the feature list in the 
respective IM-MS Browser window so you can easily adjust the view among 
recently viewed features. 

Maximum number of M-MS Browser windows
A maximum of four (4) IM-MS Browser windows can be open at the same time. 
If your project contains more than two samples, a feature can be viewed from 
up to four samples (IM-MS Browser windows) by selecting one sample at a 
time from the feature details by sample pane in Feature Details. Click the 
right mouse button and select View feature in IM-MS Browser. If you attempt 
to view the feature detail from a fifth sample a message dialog box prompts 
you to close one or more IM-MS Browser windows first. When the Mass 
Profiler software is closed, all IM-MS Browser windows launched from Mass 
Profiler are automatically closed.

For information on using IM-MS Browser see the MassHunter IM-MS Browser 
Software - Quick Start Guide, available on the Agilent Literature Library at 
www.chem.agilent.com. 
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Print, save, or copy the Feature Plot image
Print, save, or copy the Feature Plot image
The following options are available in many graphics in Mass Profiler.

Print Image Prints the current plot image based on your current printer 
settings.

Copy Image to Clipboard Copies the current plot image to the Clipboard to 
paste into other applications as either an Enhanced Meta file (a group of 
objects that form the image) or a Bitmap format (a single image object).

Save Image to File Saves the current plot image as either an Enhanced Meta 
file (.emf) or Bitmap (.bmp) format.

Find more feature information from database websites
Use this procedure to conduct a search by neutral mass and access more 
information about selected features in any of the following online databases: 
ChemIDplus, HMP, NIST, PubChem, or Web METLIN.

From the Feature 
Table

Method 1:

1 Click the row number to select the feature of interest in the Feature Table.

2 Click Web Mass Search and the database to search from the menu bar.

Method 2:

1 Right-click on the row number for the feature of interest in the Feature 
Table to display the shortcut menu.

2 Select Web Mass Search and the database to search from the menu.

From the Feature 
Plot

Method 3:

1 Right-click on or near the feature of interest in the Feature Plot to display 
the shortcut menu.

2 Select Web Mass Search and the database to search from the menu.

In each case above, your default Internet browser is opened to perform the 
selected mass search as described in “Web Mass Search menu” in the Quick 
Start Guide.
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View the feature abundance distribution
This feature is only available if the project contains two sample groups and at 
least three samples.

1 Open the Abundance Distribution window for a selected feature in any of 
the following ways:

From the Feature 
Table

• Click the row number of the feature of interest in the Feature Table, then 
click View > Abundance Distribution for Selected Feature.

• Right-click the row number for the feature in the Feature Table, and 
select Abundance Distribution from the shortcut menu.

From the Feature 
Plot

• Right-click on the feature of interest in the Feature Plot, and select 
Abundance Distribution from the shortcut menu. 

2 Review the abundance distribution of the samples for the selected feature 
in the Abundance Distribution of Feature # window. The abundance 
distribution consists of a histogram and a curve color-coded by group (red 
for <Group 1> and blue for <Group 2>), as shown in Figure 14.

Figure 14 Abundance Distribution of Feature window

The lower plot is a histogram with abundance values on the x-axis. The 
height of the bars are determined by the number of samples whose 
abundance falls into that abundance bin. 
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View the global occurrence histograms
The upper plot has the same abundance x-axis. The distribution curves are 
calculated using the least-squared fit to a Gaussian shape of the data in the 
lower plot.

View the global occurrence histograms
1 Click View > Global Occurrence Histogram.

2 Review the information presented in the Global Occurrence Histograms 
window. Each histogram shows the frequency of feature occurrence in the 
samples within each group and or within both groups in your project. The 
x-axis is the number of samples that a particular feature occurs in, from 
zero up to the number of samples in the group. The y-axis is the number of 
features that occur in that number of samples from zero up to the number 
of features in the project. 

Figure 15 Global Occurrence Histogram window

Global Occurrence Histogram shortcut menu
The menu commands available when you right-click in the Global Occurrence 
Histogram are shown in Figure 16 on page 28.
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Copy Copies the histograms in the window graphic to the Clipboard to paste 
into other applications.

Save Image As Saves the histograms in the window graphic as one of five 
image file formats: .png, .gif, .jpg, .tif, or .bmp.

Show Point Values  Annotate the number of features found in each sample 
when the pointer is moved over each bar graph.

Unzoom Restores the previous zoom level of the histogram.

Set Scale to default Resets the axes of the histogram to show the full data.

Figure 16 The shortcut menu commands available within the Global Occurrence Histo-
gram window
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Identify Features
The following procedures help you to identify features using MassHunter ID 
Browser. Identify features is not available for the CSV file type.

• “Lookup the identity of a single feature” on page 29

• “Identify multiple features” on page 30

• “Review identification results” on page 31

Lookup the identity of a single feature
Results of an identification lookup for a single feature are not returned back to 
Mass Profiler. The lookup functionality is designed to help you identify 
features of interest without committing to adding the results to your project. 
To return feature identification to your project use “Identify multiple features” 
on page 30.

1 Select the feature of interest and initiate identification in any of the 
following ways:

From the Feature 
Table

• Click the row number of the feature of interest in the Feature Table, then 
click Identify Features > Identification Lookup for Selected Feature.

• Right-click the row number for the feature in the Feature Table, and 
select Identification Lookup from the shortcut menu.

From the Feature 
Plot

• Right-click on the feature of interest in the Feature Plot, and select 
Identification Lookup from the shortcut menu. 

2 Review and adjust the identification method parameters in the Compound 
Identification Wizard.

3 Click Next and Back to review all of the method parameters.

4 Click Finish to exit the wizard and automatically run the method on the 
feature.

5 Review results in the Compound List Window as described in “Review 
identification results” on page 31.

6 Click Save and Return in the toolbar to close the ID Browser window and 
return to Mass Profiler. Your ID Browser results are not returned to Mass 
Profiler.
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Identify multiple features
Results of identifying multiple features are returned back to Mass Profiler.

1 Click Identify Features and select one of the following options:

• For All Features in Table: All of the features in the Feature Table are 
passed to ID Browser for identification. 

• For Marked Features in Table: The features marked in the Mark column 
in the Feature Table are passed to ID Browser for identification. 

• For Unmarked Features in Table: The features that are not marked in 
the Mark column in the Feature Table are passed to ID Browser for 
identification. 

• For Highlighted Features on Graph: The features that meet the 
parameters you select and specify in the Plot mode are displayed in the 
Feature Plot and are passed to ID Browser for identification. 

• For PCA Marked Features in Table: The features marked in the PCA 
Mark column in the Feature Table are passed to ID Browser for 
identification.

• For PCA Unmarked Features in Table: The features that are not marked 
in the PCA Mark column in the Feature Table are passed to ID Browser 
for identification. 

2 Review and adjust the identification method parameters in the Compound 
Identification Wizard.

3 Click Next and Back to review all of the method parameters.

4 Click Finish to exit the wizard and automatically run identification on the 
selected features.

5 Review results in the Compound List Window as described in “Review 
identification results” on page 31.

6 Click Save and Return in the toolbar to close the ID Browser window and 
return to Mass Profiler. Your ID Browser results are returned to Mass 
Profiler.
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Review identification results
This section helps you view compound identification results in the Compound 
List Window of the ID Browser as shown in Figure 17 on page 32.

1 View the compounds in the table in the Compound List Window. 

• Each row in the table shows the best compound identification match for 
each feature. 

• Each column contains additional information about each compound. For 
a list of the information that can be displayed for a compound, see the ID 
Browser online help for more information.

2 Click the + button to the left of a compound to display the second level of 
the compound table - the list of compounds that were matched to the 
original feature based on the formula generation and database and library 
search. 

• Second level rows have a green background.

3 Click the + button next to a second level search result to display the third 
level of the compound table - species information, if the second level has a 
formula assigned from either generate formulas or database search. 

• Third level rows have a light blue background.

4 Click the + button next to an entry in the third level of the table to display 
the fourth level of the compound table - the m/z peak list.

• Fourth level rows have a light red background.

5 Click the - button to close a level that is open. Closing a compound row 
automatically closes the 2nd, 3rd and 4th level rows for that compound. 

Any number of feature levels can be open for as many compounds as you 
want at the same time.
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Review identification results
Figure 17 ID Browser after identifying features as compounds
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Mark features for Export
Export Mass Profiler Data
This section describes how to export data from Mass Profiler for use with 
other programs, such as text editors, spreadsheet, and MassHunter programs 
Qualitative Analysis, Acquisition, and Mass Profiler Professional. You can 
export features in the formats described in “Exporting data” in the Quick 
Start Guide:

• “Mark features for Export” below

• “Export data from the Feature Table” below

• “Export data from the Feature Plot” on page 36

Mark features for Export
Use this procedure to mark any features of special interest. These marks are 
included when you export data from the Feature Table or the Feature Plot as a 
Feature Summary. The mark notation is not included in the other export 
formats.

• Mark a feature in the column labeled Mark in the rows for the features of 
interest in the Feature Table.

• Clear a feature that is marked, click again in the column labeled Mark in the 
row for the feature.

• Click View > Principal Component Analysis to add PCA Mark features. See 
“Perform a PCA analysis” on page 13.

Export data from the Feature Table
1 (Optional) Mark any features that are of special interest as described in 

“Mark features for Export” above.

2 Click one of the following items in the File menu, depending on the format 
you want to use to export the data:
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Export data from the Feature Table
• Export Feature Summary > From Table...: Export the feature summary 
information from the Feature Table for use in a spreadsheet such as 
Excel. The export file format is a tab-delimited text file and can be 
opened in a text editor, but it is saved with an .XLS extension so that 
Excel opens the file automatically when you double-click on the file in 
Windows Explorer. You can export from the Feature Table using one of 
three options:

From Table - All Features
From Table - Marked Features
From Table - Unmarked Features
If you have marked features from a principal component analysis two 
additional options are available:
From Table - PCA Marked Features
From Table - PCA Unmarked Features

• Export Target MS/MS Inclusion List > From Table...: Export the 
averaged ion data (m/z, z, RT, delta RT) for each feature in the Feature 
Table for use in data acquisition in targeted MS/MS experiments. The 
export file format is a comma-separated value text file with a .CSV 
extension. You can export from the Feature Table using one of three 
options:

From Table - All Features
From Table - Marked Features
From Table - Unmarked Features
If you have marked features from a principal component analysis two 
additional options are available:
From Table - PCA Marked Features
From Table - PCA Unmarked Features

• Export MPP Input File > From Table...: Export the feature summary 
information from the Feature Table for use with Mass Profiler 
Professional. The export file format is a tab-delimited text file. You have 
a choice to export with a .txt extension for opening in a text editor, or an 
.xls extension for direct opening in Excel. You can export from the 
Feature Table using one of three options:

From Table - All Features
From Table - Marked Features
From Table - Unmarked Features
If you have marked features from a principal component analysis two 
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Export data from the Feature Table
additional options are available:
From Table - PCA Marked Features
From Table - PCA Unmarked Features

• Export Composite-Compounds CEF > From Table...: Export the list of 
features for import into Mass Profiler Professional for advanced 
statistical analysis. The export file format is a compound exchange file 
with a .CEF extension. The features within a group are summed to form a 
composite compound. This export feature is not available for LC/IM-MS 
data files. You can export from the Feature Table using one of three 
options:

From Table - All Features
From Table - Marked Features
From Table - Unmarked Features
If you have marked features from a principal component analysis two 
additional options are available:
From Table - PCA Marked Features
From Table - PCA Unmarked Features

3 If you selected Export Targeted MS/MS Inclusion List > From Table... in 
Step 2, the Export Inclusion List Options dialog box (Figure 18) appears. 
Set the following parameters for selecting representative ions for each 
feature.

Figure 18 Export Inclusion List Options dialog box
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Export data from the Feature Plot
a Mark Most abundant to use the most abundant ion for each feature.

b Select the parameters for Charge state.

c Select the parameters for Adduct selection.

d Enter a RT tolerance in minutes or accept the default value of 0.10 
minutes.

e Click OK.

4 Enter a folder and name for the output file and click Save.

Export data from the Feature Plot
1 Display the features of interest in the Feature Plot as described in “Feature 

Plot” in the Quick Start Guide. Keep the following caveats in mind:

• When you export graphed features, only the features shown as solid dots 
are exported. Circles are filled or not based on the current Highlighting 
criterion. If the Highlighting criterion is set to None, then the result is 
equivalent to the table-based reports.

• The ratio and comparison plots can only include features that are 
present in both groups. You may get a different list of features depending 
on which graph you are exporting. The generated files include 
annotations to document what graph and highlighting criterion were 
used to generate the export.

• The supported export formats are based on data averaged over one or 
more groups. Even if you choose a Plot style that displays individual per 
sample features, the exported data report the averaged feature data.

2 Click one of the following items on the File menu, depending on the format 
you want to use to export the data:

• Export Feature Summary > From Graphed Features: Export the 
features in the current Feature Plot for use in a spreadsheet. The export 
file format is a tab-separated text file with an .XLS extension for direct 
opening in Excel.

• Export Target MS/MS Inclusion List > From Graphed Features: 
Export the averaged ion data (m/z, z, RT, delta RT) for each feature in the 
Feature Table for use in data acquisition in targeted MS/MS experiments. 
The export file format is a comma-separated value text file with a .CSV 
extension. 
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Export data from the Feature Plot
• Export MPP Input File > From Graphed Features: Export the features 
in the current Feature Plot for use in MPP. The export file format is a 
tab-delimited text file. You have a choice to export with a .TXT extension 
for opening in a text editor, or an .XLS extension for direct opening in 
Excel. 

• Export Composite-Compounds CEF > From Graphed Features: Export 
the features in the current Feature Plot for import into Mass Profiler 
Professional for advanced statistical analysis. The export file format is a 
compound exchange file with a .CEF extension. The features within a 
group are summed to form a composite compound. This export feature is 
not available for LC/IM-MS data files.

3 If you selected Export Targeted MS/MS Inclusion List > From Table... in 
Step 2, the Export Inclusion List Options dialog box (Figure 18 on page 35) 
appears. Set the following parameters for selecting representative ions for 
each feature.

a Mark Most abundant to use the most abundant ion for each feature.

b Select the parameters for Charge state.

c Select the parameters for Adduct selection.

d Enter a RT tolerance in minutes or accept the default value of 0.10 
minutes.

e Click OK.

4 Enter a folder and name for the output file and click Save.
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Familiarization Exercises
The Mass Profiler installation disc contains files for three sets of data files 
which you can use to become familiar with the main workflows of Mass 
Profiler: 2-Sample-Comparison, 2-Sample-Comparison with LC/IM-MS data, 
and 2-Sample-Group-Comparison.

Example A: 2-Sample-Comparison
The goal of this exercise is to use untargeted feature finding for the 
comparison of two samples and find and identify the compound differences 
between the samples. Four exercises are in this example:

• “Exercise 1. Create a project and run method” on page 38

• “Exercise 2. Edit post-alignment filtering parameters” on page 41

• “Exercise 3. Identify features” on page 43

• “Exercise 4. View feature details” on page 45

The folder 2-Sample-Comparison contains the following files for this example:

• Method file 2-Sample_Comparison.mpm
• Fruit_Tea.d (a raw data file from a fruit tea extract)

• Fruit_Tea_1_10000.d (a raw data file from the fruit tea extract spiked with
a low concentration of four sulfa drugs)

Exercise 1. Create a project and run method

In this exercise you create a new project to view the example 
2-Sample-Comparison data files.

1 Copy the example files and folders to the appropriate MassHunter folders 
on your computer. By default, the \MassHunter folder is on the D: drive on 
acquisition systems, and on the C: drive on offline systems.

a Copy the method file 2-Sample_Comparison.mpm in the 
2-Sample-Comparison folder to \MassHunter\MassProfiler\Methods.

b Create a folder named 2-Sample-Comparison within the folder 
\MassHunter\MassProfiler\Input Data.
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c Copy the Fruit_Tea.d and Fruit_Tea_1_10000.d data folders in the 
2-Sample-Comparison folder to \MassHunter\MassProfiler\Input 
Data\2-Sample-Comparison.

2 Double-click the Mass Profiler icon  located on your desktop.

3 Create the example project.

a Click File > Create Project or the Create Project  button. The Create 
Project dialog box is opened. The next steps populate the dialog box as 
shown in Figure 19.

b Verify that the Number of groups is set to 2.

c Type 2-Sample-Comparison for the Project Name.

d Select *.d (MFE) for the Input data type

e Click Add in the Experiment group section on the left.

f Navigate to the folder \MassHunter\MassProfiler\Input 
Data\2-Sample-Comparison in the Folder Selector dialog box.

g Select the data file Fruit_Tea_1_10000.d in the Folder Selector dialog 
box.

h Click OK to load the data file into the project.

i Click Add in the Control group section on the right.

j Select the data file Fruit_Tea.d in the Folder Selector dialog box.

k Click OK to load the data file into the project.

Figure 19 Create Project dialog box for the 2-Sample-Comparison project

l Clear Open method on OK.

m Click OK in the Create Project dialog box.
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4 Click Method > Load and Open Method or the Load and Open Method  
button.

5 Select 2-Sample_Comparison.mpm in the Open dialog box.

6 Click Open. The method is immediately loaded and opened for editing in 
the Method Parameters - <method file name> dialog box. The parameters 
are set as shown in Figure 20.

Figure 20 Method Parameters dialog box for 2-Sample_Comparison.mpm

7 Click All parameters and verify the following parameter settings in the 
Feature Finding/Loading tab:

a Measure of abundance is set for Max ion intensity

b Feature finding input filters, Restrict RT to is marked and set to 
0.0-10.0 min. and Ion intensity >= is set to 600 counts.

c Sample chemistry and ionization Isotope model is “Common organic 
molecules” and Limit charge states to a range of is marked and set to 
1-1.

8 Click Run.
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Mass Profiler processes the project with the method parameters and 
updates the Feature Table and Feature Plot in the main window. The 
method finds 5,991 features, a large number of features, since no 
post-alignment filtering is applied.

Figure 21 Adjusted view of the 2-Sample-Comparison project - 5,991 features are identi-
fied in the Feature Table. Since the features are not necessarily present in 
both groups, the Feature Plot shows a total of 11,850 features.

9 Adjust the parameters of the Feature Plot to obtain the view shown in 
Figure 21 and to become familiar with the Feature Plot parameters.

a Select All samples for Sample Selection.

b Select Mass vs RT for X-Y selection.

c Select Group for Colored by.

d Select Q score for Highlighting criterion.

e Type 80 for Highlighting threshold.

Exercise 2. Edit post-alignment filtering parameters
In this exercise you adjust the post-alignment filtering parameters.

1 Click the Edit Method  button or click Method > Edit Method.
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2 Select the Statistics & Filters tab.

3 Mark Q-Score >=. 

4 Type 100 for Q-Score >= in order to require the highest quality features.

5 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 5,991 to 1,561.

6 Click the Edit Method  button or click Method > Edit Method.

7 Select the Statistics & Filters tab.

8 Mark Apply under the Expression section.

9 Click Both under the Expression section.

10 Type 4.0 for Fold change >= in the Group difference section.

11 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 1,561 to 4.

Figure 22 Reprocessed view of the 2-Sample-Comparison project - 4 features
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Exercise 3. Identify features
In this exercise you identify the four features from Exercise 2 using ID 
Browser.

1 Click the Identify Features > For All Features in Table.

2 Clear Molecular formula generator (MFG) in the Compound 
Identification Wizard dialog box.

Figure 23 Compound Identification Wizard dialog box

3 Click Next.

4 Verify that the database path on the Database tab is set to 
\MassHunter\PCDL\default.csv.

5 Click Finish.

6 Verify that 4 out of the 4 compounds are identified as Sulfamethazine, 
Sulfadimethoxine, Sulfamethizole, and Sulfochloropyridazine with match 
scores from 77-95 (see Figure 24 on page 44)

7 Click Save and Return to return the identified feature information to Mass 
Profiler. Two new columns, Name and Formula, are created in the Feature 
Table and contain the compound names and formulas (see Figure 25 on 
page 44).
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Figure 24 ID Browser results for the four differentially expressed features

Figure 25 Identified features of the 2-Sample-Comparison project
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Exercise 4. View feature details
In this exercise you review the feature details in the main window.

1 Click View > Switch to Feature-Details Mode to replace the Feature Plot 
with Feature Details. 

2 Double-click on the row number of the first sulfa drug in the Feature Table. 
The Feature Details associated with this feature populate the lower half of 
the main window (see Figure 26).

The upper of the two new tables is titled Feature 1 - All Samples, and 
contains entries for the Fruit_Tea_1_10000 data in red and Fruit_Tea data 
in blue. The lower table is titled Fruit_Tea_1_10000 and shows three ions 
and the neutral mass of the feature calculated at 278.0837.

Figure 26 Feature Details view of the 2-Sample-Comparison project

3 Verify that on the right side of the Feature Details view two sets of 
chromatograms and mass spectra are shown. The chromatogram for 
Fruit_Tea_1_10000 is on top and shows a chromatographic peak, which is 
not visible in the chromatogram of the Fruit_Tea sample. The average mass 
spectrum on the top has the four ions associated with the feature marked 
with red dots, while the lower spectrum does not.
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4 Double-click on the row number of the first ion in the ion table. Observe 
how the chromatograms change when extracting the ion species 
individually (in this example “M+H,” “M+H,1,” “M+H,2,” and “M+Na”).

5 Repeat steps 2, 3, and 4 for the remaining three sulfa drugs. Explore the 
graphics using zoom and unzoom to compare the chromatogram and mass 
spectrum for each feature in detail.

6 Double-click the row number 2 in the Feature Details by Sample table to 
update the Feature Details by Ion table with the ions from the Fruit_Tea.d 
(control) sample.

7 Double-click on the row numbers in the ion table and observe how the 
chromatograms change when extracting the ion species individually.

8 Click File > Save Project. A copy of the most recent method parameters 
used to create the results is embedded with the project.

9 Review the project, Feature Table, Feature Plot, and Feature Details as 
described earlier in this guide in the sections: “View results in the Feature 
Table” on page 20, “View results in the Feature Plot” on page 21, and “View 
results in the Feature Details” on page 22.

Exercise B: 2-Sample-Group-Comparison
The goal of this exercise is to use untargeted feature finding for the 
comparison of two groups of samples and see if the experiment can 
differentiate the samples by grouping. Three exercises are in this example:

• “Exercise 1. Create 2-Sample-Group-Comparison project and run the 
method” on page 47

• “Exercise 2. Edit post-alignment filtering parameters” on page 49

• “Exercise 3. Analyze your groups using PCA” on page 51

The folder 2-Sample-Group-Comparison contains the following:

• Folder Control that contains ten control data files and folder Experiment 
that contains ten experiment data files

• Method file 2-Sample-Group-Comparison.mpm
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Exercise 1. Create 2-Sample-Group-Comparison project and run the method

In this exercise you set up and process the example 2-Sample-Group-Comparison 
project.

1 Copy the example files and folders to the appropriate MassHunter folders 
on your computer. By default, the \MassHunter folder is on the D: drive on 
acquisition systems, and on the C: drive on offline systems.

a Copy the method file 2-Sample-Group-Comparison.mpm to 
\MassHunter\MassProfiler\Methods.

b Create a folder named 2-Sample-Group-Comparison within the folder 
\MassHunter\MassProfiler\Input Data.

Figure 27 The basic Mass Profiler workflow for the 2-Sample-Group-Comparison project
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c Copy the folders Control and Experiment and their contents to 
\MassHunter\MassProfiler\Input Data\2-Sample-Group-Comparison.

2 Double-click the Mass Profiler icon  located on your desktop.

3 Create the example project.

a Click File > Create Project or the Create Project  button. The Create 
Project dialog box is opened.

b Verify that the Number of groups is set to 2.

c Type 2-Sample-Group-Comparison for the Project Name.

d Select *.d (MFE) for the Input data type

e Click Add in the Experiment group section on the left.

f Navigate to the folder \MassHunter\MassProfiler\Input 
Data\2-Sample-Group-Comparison\Experiment in the Folder Selector 
dialog box.

g Select all ten data files in the Folder Selector dialog box.

h Click OK to load the data files into the project.

i Click Add in the Control group section on the right.

j Navigate to the folder \MassHunter\MassProfiler\Input 
Data\2-Sample-Group-Comparison\Control in the Folder Selector 
dialog box.

k Select all ten data files in the Folder Selector dialog box.

l Click OK to load the data files into the project.

m Clear Open method on OK. For this exercise a previously created 
example method is used to process the data files.

n Click OK.

4 Load and edit the example method.

a Click the Load and Open Method  button or click Method > Load and 
Open Method.

b Select 2-Sample-Group-Comparison.mpm.

c Click Open.

d Verify Commonly changed parameters is selected at the bottom of the 
dialog box.

e Verify that Feature filter Q-Score >= is cleared.

f Verify that Sample occurrence Frequency >= is cleared.
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5 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features found is 14,057 (see Figure 28). This is a large number 
of features because no post-alignment filtering is set.

Figure 28 Initial view of the 2-Sample-Group-Comparison project - 14,057 features

Exercise 2. Edit post-alignment filtering parameters
In this exercise you adjust the post-alignment filtering parameters.

1 Click the Edit Method  button or click Method > Edit Method.

2 Mark Feature filter Q-Score >=.

3 Type 80 for Q-Score >=.

4 Click Run. 

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 14,057 to 7,005.

5 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.
Mass Profiler Familiarization Guide 49



Familiarization Exercises
Exercise B: 2-Sample-Group-Comparison
6 Mark Sample occurrence Frequency >=.

7 Type 80 for Frequency >=.

8 Click in at least one group, this requires that a feature is present in at least 
80% of the samples in at least one group.

9 Click Run. 

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 7,005 to 4,658.

10 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.

11 Mark Apply under the Expression section.

12 Click Both under the Expression section.

13 Type 2.0 for Fold change >= in the Abundance difference, Group 
abundance section.

14 Click Run. 

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 4,658 to 2,941.

15 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.

16 Click Up under the Expression section.

17 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 2,941 to 2,227.

18 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.

19 Click Down under the Expression section.

20 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 2,227 to 714.

21 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.
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22 Click Both under the Expression section.

23 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features increases from 714 back to 2,941 as shown in Figure 29.

Figure 29 2-Sample-Group-Comparison project with 2,941 features

Exercise 3. Analyze your groups using PCA
In this exercise you perform a principal component analysis on the 2,941 
features from “Exercise 2. Edit post-alignment filtering parameters”. The goal 
of the PCA analysis in this exercise is to see whether the features allow the 
sample groups to be differentiated and then identify a subset of abundant 
features that account for the differentiation.

1 Click View > Principal Component Analysis > For All Features in Table. 
Since the method applied to the project has been optimized to reduce the 
occurrence of features that are less significant, as illustrated by the Feature 
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Plot shown in Figure 29, all of the features in the Feature Table are 
analyzed using PCA.

2 Review the PCA results (Figure 30) to become familiar with the panes and 
actions available in the Principal Component Analysis dialog box. See 
“Perform a PCA analysis” on page 13 for more information.

Figure 30 Initial PCA for the project after filtering the features in Exercise 2

3 Clear Normalizing by feature deviation in the Principal Component 
Analysis dialog box.

4 Clear Using log2 abundance in the Principal Component Analysis dialog 
box.

The choice of whether to use Normalizing by feature deviation or Using 
log2 abundance depends on where you publish your results.

In the initial PCA analysis (Figure 30) the cumulative variance accounted 
for by the first four principal components is 84.18%, 87.39%, 88.95%, and 
90.27%.

By removing the abundance normalization options (Figure 31 on page 53) 
the variance accounted for by the first principal component increases and 
the cumulative variance improves to 91.27%, 94.43%, 96.95%, and 97.86%.
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Figure 31 PCA for the project after clearing Using log2 abundance and Normalizing by 
feature deviation

5 Click the Diff. Score column heading two times to sort the Feature: 
Principal Component 1 feature table by decreasing score. Note that 2,922 
of the 2,941 features have a Diff. Score greater than or equal to 90.

6 Mark the features that have the greatest correlation and covariance in the 
C-C Plot:

a Right-click and select Unzoom in the C-C Plot.

b Right-click and select Mark Features in Zoomed Area (Figure 33 on 
page 54, left). Notice that all of the features are marked in the feature 
table above the C-C- Plot.

c Click and drag the pointer from approximately (-0.5, -1) to (0.5, 1) in the 
C-C Plot as shown in Figure 32 on page 54. Since drawing the zoom 
window to exact values is not very accurate your numbers in the next 
step can be different.
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Figure 32 Zoom in on the C-C Plot

d Right-click and select Clear Marks for Features in Zoomed Area 
(Figure 33, right). 

Figure 33 Using the C-C Plot to mark all features (left) and then clear the features that have less correlation 
and covariance (right).

7 Click the Mark column heading to sort the Feature: Principal Component 
1 feature table by mark. Note that about 20 of the 2,941 features are marked 
and account for a covariance greater than ~0.5 and a correlation greater 
than ~1.0, and note that these feature are not necessarily just the features 
with the greatest Diff. Score.

8 Click OK to return the PCA Mark information to the Feature Table in the 
main window.
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9 Click View > Principal Component Analysis > For PCA Marked Features 
in Table. The principal component analysis is rerun on the features 
selected from the initial PCA analysis with results that show improved 
group separation.

By removing the abundance normalization (Figure 34) and the use of the 
log2 abundance, the variance accounted for by the first principal 
component increases and the cumulative variances for the four Principal 
Components increase to 96.00%, 98.27%, 99.29%, and 99.67% compared to 
the variances in step 4 on page 52.

Figure 34 PCA for the PCA Marked features after clearing Using log2 abundance and 
Normalizing by feature deviation

10 Click OK to return to the main window.

11 Review the project, Feature Table, Feature Plot, and Feature Details as 
described earlier in this guide in the sections: “View results in the Feature 
Table” on page 20, “View results in the Feature Plot” on page 21, and “View 
results in the Feature Details” on page 22.
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12 Click File > Export Composite-Compounds CEF > From Table - PCA 
Marked Features to save the features you marked in the PCA as a CEF file. 
See “Export Mass Profiler Data” on page 33 for additional information.

Figure 35 Export PCA marked features from the Feature Table

Example C: 2-Sample-Comparison_IM of IM-MS data
The goal of this exercise is to use untargeted feature finding for the 
comparison of two samples acquired using an LC/IM-MS and find and identify 
the compound differences between the samples. The sample data files are 
similar to that used in Example A. Four exercises are in this example:

• “Exercise 1. Create a project and run method” on page 57

• “Exercise 2. Edit post-alignment filtering parameters” on page 60

• “Exercise 3. Identify features” on page 61

• “Exercise 4. View feature details” on page 63

The folder 2-Sample-Comparison_IM contains the following files for this 
example:

• Method file 2-Sample_Comparison_IM.mpm
• Fruit_Tea_IM.d (a raw data file from a fruit tea extract)

• Fruit_Tea_1_1000_IM.d (a raw data file from the fruit tea extract spiked 
with a low concentration of four sulfa drugs)
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Exercise 1. Create a project and run method
In this exercise you create a new project to view the example 
2-Sample-Comparison_IM data files that were acquired using an LC/IM-MS.

1 Copy the example files and folders to the appropriate MassHunter folders 
on your computer. By default, the \MassHunter folder is on the D: drive on 
acquisition systems, and on the C: drive on offline systems.

a Copy the method file 2-Sample_Comparison_IM.mpm in the 
2-Sample-Comparison folder to \MassHunter\MassProfiler\Methods.

b Create a folder named 2-Sample-Comparison_IM within the folder 
\MassHunter\MassProfiler\Input Data.

c Copy the Fruit_Tea_IM.d and Fruit_Tea_1_1000_IM.d data folders in the 
2-Sample-Comparison folder to \MassHunter\MassProfiler\Input 
Data\2-Sample-Comparison_IM.

2 Double-click the Mass Profiler icon  located on your desktop.

3 Create the example project.

a Click File > Create Project or the Create Project  button. The Create 
Project dialog box is opened.

b Verify that the Number of groups is set to 2.

c Type 2-Sample-Comparison_IM for the Project Name.

d Select *.d (MFE) for the Input data type

e Click Add in the Experiment group section on the left.

f Navigate to the folder \MassHunter\MassProfiler\Input 
Data\2-Sample-Comparison_IM in the Folder Selector dialog box.

g Select Fruit_Tea_1_1000_IM.d in the Folder Selector dialog box.
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Figure 36 Create Project dialog box for the 2-Sample-Comparison_IM project

h Click OK to load the data file into the project.

i Click Add in the Control group section on the right.

j Select Fruit_Tea_IM.d in the Folder Selector dialog box.

k Click OK to load the data file into the project.

l Clear Open method on OK. For this exercise a previously created 
example method is used to process the data files.

m Click OK.

4 Load and edit the example method.

a Click the Load and Open Method  button or click Method > Load and 
Open Method.

b Select 2-Sample_Comparison_IM.mpm.

c Click Open.

d Verify Commonly changed parameters is selected at the bottom of the 
dialog box.
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Figure 37 Method Parameters dialog box for 2-Sample_Comparison_IM.mpm

e Verify that Input filters Restrict RT to is marked and set to 1.5 to 17.5 to 
exclude the regions before the injection peak and when the column is 
flushed with high organic mobile phase. 

f Verify that Input filters Ion Intensity >= is set to 100. For LC/IM-MS data 
the minimum ion intensity is set to a lower value (100 is the default).

g Click All parameters at the bottom of the dialog box.

h Verify that Max ion volume is selected for the Measure of abundance on 
the Feature Finding/Loading tab. Maximum ion volume is the preferred 
measure of abundance for LC/IM-MS data and the default setting. 
Summing the ion intensities across m/z, DT, and RT improves the 
dynamic range of feature finding.

i Click Commonly changed parameters at the bottom of the dialog box.

5 Click Run.

Mass Profiler processes the project with the method parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features found is 41,919 (see Figure 38 on page 60). This is a 
large number of features because no post-alignment filtering is set.
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Figure 38 Initial view of the 2-Sample-Comparison_IM project - 41,919 features are 
identified in the Feature Table.

Exercise 2. Edit post-alignment filtering parameters
In this exercise you adjust the post-alignment filtering parameters.

1 Click the Edit Method  button or click Method > Edit Method.

2 Mark Feature filter Q-Score >=.

3 Type 100 for Q-Score >=.

4 Click Run.

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 41,919 to 1,733.

5 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.

6 Mark Apply under the Expression section.

7 Click Both under the Expression section.

8 Type 4 for Fold change >=.

9 Click Run.
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Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 1,733 to 22.

10 Click the Edit Method  button or click Method > Edit Method to 
re-open the Method Editor window.

11 Click Up in the Expression section.

12 Click Run. 

Mass Profiler reprocesses the project with the changed parameters and 
updates the Feature Table and Feature Plot in the main window. The 
number of features decreases from 22 to 12 (see Figure 39).

Figure 39 Reprocessed view of the 2-Sample-Comparison_IM project - 12 features

Exercise 3. Identify features

In this exercise you identify the twelve features from Exercise 2 using ID 
Browser. IMFE features from LC/IM-MS data files can be identified via 
Accurate Mass Database Search and/or Molecular Formula Generator in ID 
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Browser. In this example, identification is done via accurate mass and 
optional retention time, but without drift time or collisional cross section 
(CCS) consideration.

1 Click the Identify Features > For All Features in Table.

2 Clear the Molecular formula generator (MFG) mark in the Compound 
Identification Wizard dialog box.

Figure 40 Compound Identification Wizard dialog box

3 Click Next.

4 Type 15 for the mass Match tolerance in ppm on the Search Criteria tab.

5 Verify that the database path on the Database tab is set to 
\MassHunter\PCDL\default.csv.

6 Click Finish.

7 Verify that 4 out of the 12 compounds are identified as Sulfamethazine, 
Sulfadimethoxine, Sulfamethizole, and Sulfochloropyridazine (see 
Figure 41 on page 63)

8 Click Save and Return to return the identified feature information to Mass 
Profiler. Two new columns, Name and Formula, are created in the Feature 
Table and contain the compound names and formulas (see Figure 42 on 
page 63).
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Figure 41 ID Browser results for the 2-Sample-Comparison_IM project

Figure 42 Identified features of the 2-Sample-Comparison_IM project
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Exercise 4. View feature details
In this exercise you review the feature details in the main window.

1 Click View > Switch to Feature-Details Mode to replace the Feature Plot 
with Feature Details. 

2 Double-click on the row number of the sulfochloropyridazine feature in the 
Feature Table. The Feature Details associated with this feature populate the 
lower half of the main window (see Figure 43).

The upper of the two new tables is titled Feature 1 - All Samples, and 
contains entries for the Fruit_Tea_1_1000_IM data in red and 
Fruit_Tea_IM data in blue. The lower table is titled Fruit_Tea_1_1000_IM 
and shows five ions. For LC/IM-MS data a neutral mass is not calculated, 
since differently adducted or charged ion clusters are not combined. The 
ions are presented with both the drift time and retention time.

Figure 43 Feature Details view of the 2-Sample-Comparison_IM project

3 Verify that on the right side of the Feature Details view two sets of drift 
spectra and mass spectra are shown. The drift spectra for 
Fruit_Tea_1_1000_IM is on top.

4 Click File > Save Project. A copy of the most recent method parameters 
used to create the results is embedded with the project.
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