Agilent ChemStation Security Pack for UV-visible Spectroscopy

User’s Guide

Agilent Technologies
Notices


No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number
G1813-90010
Edition
04/07
Printed in Germany
Agilent Technologies
Hewlett-Packard-Strasse 8
76337 Waldbronn, Germany

Warranty
The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Safety Notices

CAUTION
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING
A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

Technology Licenses
The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend
If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.
Effective August 20, 1997, the U.S. Food and Drug Administration (FDA) released and published a new rule to enable pharmaceutical companies to approve their results with electronic signatures and to transfer paper-trail documentation into electronic records. This rule is known as 21 Code of Federal Regulations, Part 11 (referred to as 21 CFR Part 11) and applies to all industry segments regulated by the FDA. 21 CFR Part 11 places high emphasis on the implementation of all measures to protect and secure electronic records. In addition to this rule on electronic records, other general requirements for computerized systems are brought to the auditor’s attention. These rules cover the basic requirements of validation, limiting data access, and ensuring data integrity and data traceability.

This book describes how the Agilent Security Pack for UV-visible ChemStation in combination with the advanced or dissolution mode fulfills all demands of CFR 21 Part 11 on access security, data integrity, audit-trail and electronic signature. However, the ChemStation solution for compliance with 21 CFR Part 11 is designed for and supported in closed systems only.

Moreover, this manual will guide you through the installation and configuration of the security pack software. This manual is organized in four chapters which lead you from the installation and configuration of the software through the general concepts behind Security Pack to detailed information about security aspects of the advanced and dissolution testing software.

Local Installation and Configuration

This chapter describes how to install and configure the Agilent ChemStation Security Pack for UV-visible spectroscopy on PCs running Windows XP as operating system.

Server/Workstation Installation

This chapter describes how to install and configure the Agilent ChemStation Security Pack for UV-visible spectroscopy on a network with a Server share for data storage and multiple Workstations for instrument control.
Updating and Uninstalling the Security Pack

This chapter describes how to update and uninstall Agilent UV-Visible ChemStation that has been protected by the Security Pack for UV-visible spectroscopy.

Introduction

This chapter describes the concepts behind the Agilent Security Pack for UV-Visible ChemStation. The user will be introduced to the different aspects of CFR 21 Part 11 and how they are implemented in software.

Advanced Software

Advanced result concepts and active menus for managers and operators using the Agilent ChemStation advanced software.

Dissolution Testing Software

This chapter describes the security aspects of the dissolution testing software.
## Contents

1  Local Installation and Configuration  9  
   Installing Security Pack  10  
   Installing the ChemStation Software  11  
   Adding the Security Pack to an installed ChemStation  18  
   Configuring Security Pack  24  
   Configuring Security Policies  25  
   Creating and Managing New ChemStation Users  30  
   Configuring the Agilent Security Service  33  
   Saving the UV-visible ChemStation Configuration  36  

2  Server/Workstation Installation  37  
   Prerequisites for the Server/Workstation Installation  38  
   Domain Requirements  39  
   Installing the Security Pack on the Server  40  
   Configuring the Security Pack on the Server  41  
   Configuring the Agilent Security Service on the Server  41  
   Configuring Security Policies  44  
   Adding ChemStation Users  49
Contents

Installing the Security Pack on the Workstation 54
  Installing the ChemStation Software 55
  Adding the Security Pack to an installed ChemStation 62
  Configuring Security Pack 68
  Configuring Security Policies 69
  Mapping the Shared Server Directory 70
  Adding and Managing ChemStation Users 70
  Configuring the Agilent Security Service 79
  Saving the UV-visible ChemStation Configuration 81

3 Updating and Uninstalling the Security Pack 83
  Updating the ChemStation with Security Pack 84
  Uninstalling the ChemStation with Security Pack 85

4 Introduction 89
  Access Security 90
    ChemStation Access Control 90
    Logging Security Violations 95
    Session Lock for Unattended Operation 96
    Changing Operator and Password 97
    Restricted File Access 98
  Data Integrity 101
    Changing Methods 102
    Deleting Spectra 103
    Result Files 104
Audit Traceability 105
  The Method Changed Logbook 105
  The Run Logbook 105
  Retrieving the Original Result 106

Electronic Signatures 107
  ChemStation Modes and Support of 21 CFR Part 11 108

5 Advanced Software 111
  The Advanced Software Result Concept 112
  The Dynamic Menu Structure/ User Interface 114
    The Main Menu Bar 114
    The File Menu 115
    The Edit Menu 117
    The Method Menu 118
    The Measure Menu 119
    The Instrument Menu 120
    The Automat Menu 121
    The View Menu 121
    The Mode Menu 122
    The Config Menu 122
    The Help Menu 123
  Advanced Software Automation and Result Concept 123
  Restricted Data Path 124
Contents

6 Dissolution Testing Software 125

The Dissolution Testing Result Concept 126
The Dissolution Testing User Interface 127

The Dissolution Testing Menus 130

The Main Menu Bar 130
The File Menu 131
The Method Menu 132
The Instrument Menu 133
The Dissolution Menu 134

Index 135
This chapter describes how to install and configure the Agilent ChemStation Security Pack for UV-visible spectroscopy on PCs running Windows XP as operating system.

Security Pack is an add-on software module that modifies the advanced software G1116AA and dissolution testing software G1118AA to support the requirements for electronic records and signatures (21 CFR Part 11).

**NOTE**

The general purpose software G1115AA does not offer all features to be compliant with 21 CFR Part 11 since it does not support electronic signatures. But the access to the general purpose software can be configured by a user with manager rights. Furthermore, the biochemical analysis software G1117AA is not supported in combination with the Security Pack.
1 Local Installation and Configuration

Installing Security Pack

To install the Security Pack you need checking the **G1813AA Security-Pack Add-on** and you should have the license keys available for all software modules to be installed or added.

Local administrator rights are required to perform the installation. If no ChemStation software is currently installed on the target PC please follow the “Installing the ChemStation Software” below, otherwise please go to “Adding the Security Pack to an installed ChemStation” on page 18

**NOTE**

The description for the Windows XP setup is described for **Classic Start menu** and the **Windows classic** appearance. The Windows XP user interface can be changed by adjusting the properties for the **Start menu** and the desktop by means of a right mouse click.
Installing the ChemStation Software

ChemStation software and the Security Pack can be installed at the same time. For details about the installation and configuration of the ChemStation software and the Agilent 8453 spectrophotometer please refer to the *Installing Your UV-visible Spectroscopy System* manual.

1. Log on as local administrator to your PC and make sure the drive you intent to install your ChemStation software is using the NTFS file system.

Start Windows Explorer and right-click the drive where the ChemStation software shall be installed.

By default the ChemStation software is installed on the C: drive under C:\Chem32. Select Properties, choose the General tab and check for the string File System: NTFS.

![Disk file system property.](image)

*Figure 1*  Disk file system property.
1 Local Installation and Configuration

If the file system is not NTFS, it must be converted. Select Start > Programs > Accessories > Command Prompt, then type

```
convert <drive>: /fs:ntfs /v
```

where <drive> is the drive where the ChemStation software is installed, and press Enter.

![Figure 2](image)

**Figure 2** DOS command window.

At the end of the file conversion the message **Conversion complete** appears in the Command Prompt window. Type **Exit** and press **Enter** to close the window.

2 Insert the Agilent UV-Visible ChemStation CD-ROM and start Setup.exe.

3 On the InstallShield Wizard press the **Next** button.

![Figure 3](image)

**Figure 3** Installation welcome dialog.
4 Please read the license terms and press the Yes button to accept.

![License Agreement dialog.](image)

**Figure 4** License Agreement dialog.

5 Use the Browse button to enter or select your own Destination Folder or use the default installation folder C:\Chem32. Press Next to continue.

![Destination folder setup.](image)

**Figure 5** Destination folder setup.
Local Installation and Configuration

6. Select all software packages you want to install.

![Software Components Selection](Image)

**Figure 6** UV-visible ChemStation software components selection.

**NOTE**
All Add-on software must be selected in the above setup dialog. No more modification is possible after a Security Pack installation.

7. Select *Local - local UV-Vis Security pack configuration* and press *Next*.

![Installation Type Selection](Image)

**Figure 7** Installation type selection.
8 Enter a licence key and press *Add License*.
    Repeat the license key entry until all licenses are added for your selected products then press *Next*.

![License key entry dialog.](image)

**Figure 8** License key entry dialog.

9 The Configuration Editor is automatically launched to configure your installation. Please see your *Agilent 8453 UV-visible Spectroscopy System Installation Guide* for details.
    Exit the Configuration Editor.
Wait until the InstallShield Wizard’s completion dialog is displayed and press Finish.
By default the system will reboot.

![Figure 9](image.png)  
**Figure 9**  
Installation completed dialog.

**NOTE**
Rebooting your system is required before you proceed.
It may be delayed by selecting the *No, I want to restart my computer later* option.
11 From the Start menu run the UV-visible ChemStation’s Installation Qualification and check for successful completion.

![Installation Qualification Result](image)

**Figure 10** Installation Qualification Result.

12 Continue with “Configuring Security Pack” on page 24
1 Local Installation and Configuration

Adding the Security Pack to an installed ChemStation

**NOTE** If you are adding the Security Pack to an Agilent UV-visible Spectroscopy System that has already been in use before, you might have already saved a customized configuration, that is incompatible with the Security Pack. **Delete** the files `configon.reg` and `configof.reg` under `C:\Chem32\n\` (n: instrument number 1 to 4, default installation path), if they exist.

1 Log on as local administrator to your PC and make sure the drive you intent to install your Security Pack software is using the NTFS file system. Start Windows Explorer and right-click the drive where the ChemStation software is installed. By default the ChemStation software is installed on the C: drive under `C:\Chem32`. Select Properties, choose the General tab and check for the string File System: NTFS.

![Disk file system property](image)

If the file system is not NTFS, it must be converted. Select **Start > Programs > Accessories > Command Prompt**, then type

```bash

```
convert <drive>: /fs:ntfs /v

where <drive> is the drive where the ChemStation software is installed, and press Enter.

![DOS command window.](image)

At the end of the file conversion the message **Conversion complete** appears in the Command Prompt window. Type **Exit** and press **Enter** to close the window.

1. Insert the Agilent UV-Visible ChemStation CD-ROM and start setup.exe.

2. If you are adding the Security Pack on a previous revision of the ChemStation software, the dialog below is displayed. The installation will perform the required update automatically if you continue with pressing Next and step 4 below.

![Revision mismatch warning dialog.](image)

**NOTE**
1 Local Installation and Configuration

3 In the Welcome dialog of the InstallShield Wizard select the *Modify* option and press the *Next* button.

![Install Shield Wizard Entry Dialog](image1)

Figure 14  Install shield wizard entry dialog.

4 In the Select Components dialog of the InstallShield Wizard check the *G1813AA Security Pack Add-on* and press the *Next* button.

![Select Components Dialog](image2)

Figure 15  UV-visible ChemStation software components selection.
5  In the Security Pack dialog select the *Local* configuration and press the *Next* button.

![Security Pack installation type selection.](image16.png)

**Figure 16** Security Pack installation type selection.

6  Enter your license key in the entry line of the Enter License Information dialog, press the *Add License* button and then the *Next* button.

![License key entry.](image17.png)

**Figure 17** License key entry.
1  Local Installation and Configuration

7  Now the software installation starts and finally the completion dialog is displayed. Press the Finish button to exit the installation program and close the Add or Remove Programs dialog.

Figure 18  Installation Completion dialog.
After the installation is completed, run the Installation Verification by selecting **Start > Programs > UV-Visible ChemStations > Installation Qualification**.

The Security Pack has been installed without errors when the message line *Installation Verification completed successfully* is displayed at the bottom of the ChemStation Installation Verification dialog.

![ChemStation Installation Verification](image)

**Figure 19**  Installation Qualification Result.

Continue with “Configuring Security Pack” on page 24
Configuring Security Pack

After installation of Security Pack the Chemstation software can only be accessed by members of following local Windows user groups, which are subsequently called ChemStation user groups:

- ChemStationManagers
- ChemStationOperators

The SharedChemManagers and SharedChemOperators groups are local Windows user groups only. Members of these groups must also be in the ChemStationManagers or ChemStationOperators group in order to obtain access to the UV-Visible ChemStation.

For more information about the ChemStation user groups refer to “Access Security” on page 90. A detailed description of the permissions of ChemStation Managers and Operators is given in Chapter 5, “Advanced Software” and Chapter 6, “Dissolution Testing Software”.

Configuration of Security Pack comprises following steps.

1. Windows XP security policies have to be configured.
2. New ChemStation users have to be created and/or managed.
3. The Agilent Security Service has to be configured and activated.
4. Saving the UV-visible ChemStation configuration.

A detailed description how to perform these three tasks is given in the following sections.

The example screens shown in this chapter were created on a computer with the name WADC2115. On the corresponding screens of your computer WADC2115 will be replaced by your computer name. There is no need to change the name of your computer to WADC2115.
Configuring Security Policies

Configuring the Account Policy

The account policy dialog is used to control how passwords must be used by all user accounts, and whether user accounts are automatically locked out after a series of incorrect logon attempts. To manage the account policy following configuration is necessary:

1. Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.
2. In the Administrative Tools menu select Local Security Policy and open the Account Policies folder.
3. Open the Password Policy folder. Specify all password policies in accordance with your local policies. Contact your IT department if necessary. In order to change a password policy double click on the item in the right list, e.g. Maximum Password Age. In the upcoming dialog box specify the account policy setting and click OK.
4. Open the Account Lockout Policy folder. Specify all account lockout policies in accordance with your local policies. Contact your IT department if necessary. In order to change a account lockout policy double click on the item in the right list, e.g. Lockout duration. In the upcoming dialog box specify the account lockout policy setting and click OK.
5. Close the all windows and leave the Windows Control Panel.
Local Installation and Configuration

Configuring the User Rights Policy
—Act As Part of Operating System
—Take Ownership of files or other objects

Following configuration is necessary to grant the user right, *Act as part of the operating system*, to the ChemStation user groups and to grant the ChemStationAdmins group the right, *Take ownership of files or other objects*:

1. Logon as local Administrator and select *Start > Settings > Control Panel > Administrative Tools*.
2. In the Administrative Tools menu select *Local Security Policy* and open the *Local Policies* folder.
3. Select *User Rights Assignment* and double click on the item *Act as part of the operating system* in the right list.
4. Click on the *Add User or Group...* button.
5. In the Select Users and Groups dialog press the *Advanced* button.

![Select Users and Groups dialog](image)

**Figure 21** Selection Dialog for Users and Groups.

6. Press the *Object Types...* button, check *Groups* and press *OK*.
7. Press the *Locations...* button and select your computer from the list and press *OK*.
8. Press the *Find Now* button and select groups *ChemStationManagers, ChemStationOperators, SharedChemManagers* and *SharedChemOperators*, and click *OK*.
9 Click OK again.

![Selection of ChemStation groups.](image1)

**Figure 22** Selection of ChemStation groups.

![Selected groups for Act as part of the operating system right.](image2)

**Figure 23** Selected groups for *Act as part of the operating system* right.
10 Click OK and check if all ChemStation groups show up in the Security Setting list of the user right Act as part of the operating system.

11 Click OK to leave the Act as part of the operating system Properties dialog box.

12 In the Local Security Settings double click on the item Take ownership of files or other objects in the Policy column of the right list.

13 Click on the Add User or Group... button

14 In the Select Users and Groups dialog press the Advanced button.

15 Press the Object Types... button, check Groups and press OK.

16 Press the Locations... button and select your computer from the list and press OK.

17 Press the Find Now button and select the group ChemStationAdmins and click OK.

18 Click OK again.

19 Check if the ChemStationAdmins group shows up in the “Security Setting” list of the user right Take ownership of files or other objects.

20 Click OK and close the all windows and leave the Windows Control Panel.
Configuring the Audit Policy

Selected activities of users can be tracked by auditing security events and then placing entries in a computer's security log. The Audit policy dialog can be used to determine the types of security events that will be logged for the computer. Following configuration is necessary to track all security violations during logon and logoff to the system:

1. Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.

2. In the Administrative Tools menu select Local Security Policy and open the Local Policies folder.

3. Open the Audit Policy subfolder and double click on Audit account logon events. Check both Success and Failure for the Logon Events and Click OK. Specify further types of security events in accordance with your local policies. Contact your IT department if necessary.

4. Close the all windows and leave the Windows Control Panel.

To view entries in the security log select Start > Settings > Control Panel > Administrative Tools > Event Viewer and choose the Security Log. To specify maximum size of the security log select Action > Properties and adjust the settings according to your IT policies. See also “Logging Security Violations” on page 95.
Creating and Managing New ChemStation Users

The ChemStation software can be used by members of the ChemStationManagers and ChemStationOperators groups only. Table 1 shows the ChemStation user groups and the default users, which are automatically created during installation of Security Pack.

Table 1  Default Members of ChemStation User Groups

<table>
<thead>
<tr>
<th>ChemStation User Group</th>
<th>Default Members</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChemStationAdmins</td>
<td>ChemStationAdmin</td>
</tr>
<tr>
<td>ChemStationManagers</td>
<td>ChemStationManager, ChemStationAdmin</td>
</tr>
<tr>
<td>ChemStationOperators</td>
<td>ChemStationOperator</td>
</tr>
<tr>
<td>SharedChemManagers</td>
<td>none</td>
</tr>
<tr>
<td>SharedChemOperators</td>
<td>none</td>
</tr>
</tbody>
</table>

NOTE

The SharedChemManagers and SharedChemOperators groups are Windows user groups only. Members of these groups must also be in the ChemStationManagers or ChemStationOperators group in order to obtain access to the UV-Visible ChemStation.

This section describes how you can use the Windows XP Control Panel to
• create new local ChemStation user accounts
• add existing local user accounts to a ChemStation user group
• add existing domain accounts to a ChemStation user group.

Creating New Local ChemStation User Accounts

The following procedure describes how to create new ChemStation user accounts on your local computer.

1 Logon as Administrator and select Start > Settings > Control Panel > Administrative Tools.
2 In the Administrative Tools select Computer Management.
3 Open the Local Users and Groups folder and select the Users folder.
4 From the Action menu select New User...
5 In the New User dialog enter the User Name, the Full Name and a Description.

6 Specify a Password and Confirm Password.

7 Make sure the option is checked and the account is enabled.

8 Press Create to add the new user.

9 Repeat steps 4 through 8 to create further ChemStation users (ChemStationManagers, ChemStationOperators, SharedChemManagers or SharedChemOperators, respectively).

10 Click Close to leave the New User dialog box.

11 Open the Groups folder and double click on one of the ChemStation user groups to add new users to the respective group.

12 In the upcoming dialog box click on Add....

13 In the next upcoming dialog box click on Advanced....

14 Press the Object Types... button, check only Users and press OK.

15 Press the Locations... button, select your computer and press OK.

16 Press the Find Now button and select the new users, press OK and OK again.

17 Repeat steps 11 to 16 other affected ChemStation groups.

18 Close all windows and leave the Windows Control panel.

NOTE After the first Windows XP login of a new user a profile will be generated in the Windows Profiles directory (C: \Documents and Settings).
1 Local Installation and Configuration

Adding Existing Local Accounts to ChemStation User Groups

1 Logon as Administrator and select Start > Settings > Control Panel > Computer Management.
2 Open the Local Users and Groups folder.
3 Open the Groups folder and double click on the respective ChemStation user group to add an existing user account.
4 In the upcoming dialog box click on Add....
5 In the next upcoming dialog box click on Advanced....
6 Press the Object Types... button, check only Users and press OK.
7 Press the Locations... button, select your computer and press OK.
8 Press the Find Now button and select the users, press OK and OK again.
9 Check that all selected users appear in the Members list of the Local Group and press OK.
10 Close all windows and leave the Windows Control Panel.

Adding Domain Accounts to ChemStation User Groups

1 Logon as Administrator and select Start > Settings > Control Panel > Computer Management.
2 Open the Local Users and Groups folder.
3 Open the Groups folder and double click on the ChemStation user group where you want to add an existing user account.
4 In the upcoming dialog box click on Add....
5 In the next upcoming dialog box click on Advanced....
6 Press the Object Types... button, check only Users and press OK.
7 Press the Locations... button, select the domain and press OK.
8 Press the Find Now button and select the users, press OK and OK again.
9 Check that all selected users appear in the Members list of the Local Group and press OK.
10 Close all windows and leave the Windows Control Panel.
Configuring the Agilent Security Service

The Agilent Security Service ensures that all ChemStation files are owned by the account ChemStationAdmin. That is, whenever a ChemStation user generates a new result file the ChemStationAdmin takes automatically the ownership of this file. This data access security feature is necessary to prevent that, for instance, a ChemStationOperator takes the ownership of a file and hence the permission to delete this file.

Changing the ChemStationAdmin Password

Before starting the Agilent Security Service the password for the ChemStationAdmin account has to be changed.

1 Logon as Administrator and select Start > Settings > Control Panel > Administrative Tools > Computer Management.

2 Open the Local Users and Groups folder and then open the Users folder.

3 In the name list of the Users select ChemStationAdmin and from the Action menu run Set Password…

4 In the Set Password for ChemStationAdmin warning dialog press the Proceed button. Enter and confirm a new password for the ChemStationAdmin in Set Password dialog box.

5 Click OK to activate the new password and OK again to leave the New Password dialog box.

6 Close all windows and leave the Windows Control Panel.
Local Installation and Configuration

Configuring and Starting the Agilent Security Service

After changing the password of the ChemStationAdmin the security service must be configured and started.

1. Logon as Administrator and select Start > Settings > Control Panel > Administrative Tools.
2. Double-click Services.

3. Double click on Agilent Security Service to open the Agilent Security Service Properties (Local Computer) dialog box.
4. Choose Automatic as Startup Type.
5. Select the Log On tab and select Log on as: This account:
6. Click the Browse button.
7. In the next upcoming dialog box click on Advanced....
8. Press the Object Types... button, check only Users and press OK.
9. Press the Locations... button, select your computer and press OK.
10. Press the Find Now button and select ChemStationAdmin, press OK and OK again.
11 In the Agilent Security Service Properties (Local Computer) dialog box enter and confirm the ChemStationAdmin password you have specified in “Changing the ChemStationAdmin Password” on page 33 and click Apply.

12 Select the General tab.

13 In the General tab of the Agilent Security Service Properties (Local Computer) dialog box click on Start.

14 Click on OK and check that the Agilent Security Status is started.
1 **Local Installation and Configuration**

15 Close all dialogs and exit the Windows *Control Panel*.

16 Reboot your computer.

17 After rebooting your computer please proceed with “Saving the UV-visible ChemStation Configuration.” on page 36.

**NOTE**

In order to start the secured UV-Visible ChemStation you have to be member of the ChemStationManagers(Operators) group. If you are logged on as Windows XP Administrator you are not allowed to start the ChemStation unless the Administrator account is added the ChemStation user groups.

**Saving the UV-visible ChemStation Configuration.**

The installed configuration of the UV-visible ChemStation must be saved once by a ChemStation user with manager rights. This configuration becomes mandatory for users with operator rights.

1 Logon as a user of the ChemStationManagers group and select *Start > Programs > UV-Visible ChemStations > Instrument 1 online*.

2 Logon again to the UV-Visible ChemStation using the above account.

3 Exit the ChemStation session using the *Exit ChemStation* command form the *File* menu.

4 In the closing dialog displayed check *Save Configuration* and press *OK*.

5 Repeat steps 1 to 4 for the offline ChemStation *Instrument 1 offline*.

6 If multiple instruments are connected repeat steps 1 to 5 for all additional instruments.

**NOTE**

Your UV-visible ChemStation is now readily configured and setup for all ChemStation users.

**WARNING**

This configuration must not be changed by means of the ChemStation’s *Config* menu or by means of the *Configuration Editor*. Due to the specific user rights assigned to the data folders a change obscures the system integrity.
This chapter describes how to install and configure the Agilent ChemStation Security Pack for UV-visible spectroscopy on a network with a Server share for data storage and multiple Workstations for instrument control.
Prerequisites for the Server/Workstation Installation

**NOTE**
In order to perform the following tasks you need local administrator rights for the Server and for the Workstation computer.
The Domain to be used in this installation must exist and the global groups to handle ChemStation users with manager and operator rights must be available. In addition a global account for the ChemStation administration is required. The target computers for the installation must be members of the Domain.

**NOTE**
The description for the Windows XP setup is described for “classic Start Menu” and the “Windows classic” appearance. The Windows XP user interface can be changed by adjusting the properties for the “Start” menu and the desktop by means of a right mouse click.

**NOTE**
The supported operating systems on the server are Windows Server 2000 or Windows Server 2003.

In the following sections the terms Server and Workstation are used. A typical system contains one common Server with a share where the data are stored and multiple Workstations. The Workstation is the computer, where the UV-Visible ChemStation software is installed. This Workstation will control the Agilent 8453 UV-Visible Spectrophotometer and accessories.

The Server/Workstation Installation of the Security Pack is only supported with UV-Visible ChemStation A.10.01 or higher. If the UV-Visible ChemStation Software is already installed locally, start the ChemStation software, choose About from the Help menu and check that the revision is A.10.01 or higher.

If the revision is A.10.0x, the ChemStation software needs to be updated first.

For revisions less than A.10.0x a new installation on the Windows XP operating system is required for the Workstation.

No change is necessary on an existing UV-visible ChemStation server share.
Domain Requirements

Make sure that at least two global groups are available on the domain to contain the ChemStation users with manager rights and ChemStation users with operator rights.

For the user management a tool to assign members to these groups should be available. This tool should allow to add and remove members to the above global groups.

User accounts must exist in the domain for all UV-visible ChemStation users. A special global account for the administration of the ChemStation must be available.

NOTE

The Server used for the UV-Visible ChemStation data shares and the domain controller must be different computer systems.
Installing the Security Pack on the Server

The installation of the UV-visible ChemStation Security Pack on the Server will create the UV-visible instruments data structure for four instruments on the shared ChemStation directory, as specified in step 6. Four subdirectories named 1, 2, 3, and 4, are created as up to four instruments can be connected to a single workstation.

On the next level you will find the directories for methods, data etc., where the ChemStation data will be saved.

1 Logon to the Server as local Administrator.
2 Use an existing drive or create a directory on the server to be shared for storing the UV-Visible ChemStation files.
3 Share the drive or directory, where the UV-Visible ChemStation data will be stored.
4 Insert the Agilent UV-Visible ChemStation CD-ROM, open the G1813 Server folder and start setup.exe.
5 Follow the instructions on the screen and click Next.
6 Specify the path of the shared ChemStation drive or directory.
7 Enter your G1813AA license key.
8 After the installation is completed click on Finish.

If you want to add another independent share to your Server/Workstation systems, you have to start over at step 2 and use a different drive or create a new directory for an additional share.

NOTE

During the installation the subdirectories with the required special permissions for the ChemStationAdmins, ChemStation Managers and ChemStationOperators will be created.
Configuring the Security Pack on the Server

After the installation of the UV-visible ChemStation Security Pack on the Server the following tasks have to be performed:

1. the Agilent Security Service has to be configured and activated
2. the local security policies have to be configured
3. the ChemStation users have to be added.

Configuring the Agilent Security Service on the Server

The Agilent Security Service ensures that all ChemStation files are owned by the account of the ChemStation administrator. That is, whenever a ChemStation user generates a new result file the ChemStation administrator takes automatically ownership of this file. This data access security feature is necessary to prevent that, for instance, a ChemStationOperator takes the ownership of a file and hence the permission to delete this file.

For a Server/Workstation System the ChemStation administrator must be a global user account. If a local ChemStationAdmin account exists on the Server, it has to be removed.

NOTE

In the following examples the ChemStation administrator “ChemStationAdmin” is setup in the Domain named “AGILENT”. In general the Security Pack can be installed in any domain.
Configuring and Starting the Agilent Security Service on Windows 2000/2003 Server

1. Logon as Administrator and select Start > Settings > Control Panel > Administrative Tools.

2. Double-click Services.

3. Double click on Agilent Security Service to open the Agilent Security Service Properties (Local Computer) dialog box.

4. Choose Automatic as Startup Type.

5. Select the Log On tab and select Log on as: This account.

6. Click the Browse button.

7. In the upcoming Select User dialog box select the domain name from the drop-down list box Look In container.

8. In the upcoming Enter Network Password dialog, enter the ChemStation administrator account along with the respective password to access the domain.

NOTE: The Agilent Security Service has to be started only for the first share created on a server. If the “Services” dialog displays the “Status” already as “Started” with the “Startup Type” “Automatic” and the “Log On as” displays the ChemStation administrator account, no configuration is required. Restart the service by selecting the Agilent Security Service and choosing Restart from the Action menu. Close the “Services” dialog and skip all following configuration steps.
9 From the names list select ChemStation Administrator account or enter the account name and click OK.

10 In the Agilent Security Service Properties (Local Computer) dialog box enter and confirm the password of the global ChemStation administrator and click Apply.

11 Select the General tab.

12 In the General tab of the Agilent Security Service Properties (Local Computer) dialog box click on Start.

13 Click on OK and check that the Agilent Security Service is started.

14 Close all dialogs and exit the Windows Control Panel.
Server/Workstation Installation

Configuring Security Policies

Configuring the User Rights Policies

—Act As Part of Operating System
—Take Ownership of files or other objects

Following configuration is necessary to grant the user right *Act as part of the operating system* to the ChemStation user groups and to grant the *ChemStationAdmins* group the right *Take ownership of files or other objects*.

**NOTE**

In the following examples the computer name is “WADC2240”. In a specific installation the name of the server in the domain is indicated.

Configuring the User Rights Policies on Windows 2000 Server

1. Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.
2. In the Administrative Tools menu select Local Security Policy and open the Local Policies folder.
3. Select User Rights Assignment and double click on the policy Act as part of the operating system on the list.
4. Click on the Add... button and select your computer name from the drop-down list box Look In container.
5. From the Names: list select the groups ChemStationAdmins, ChemStationManagers, ChemStationOperators and click Add.
6. Click OK and check if all ChemStation groups show up in the Assigned To list.

![User rights policy - Act as part of the operating System.](image)

Figure 29  User rights policy - Act as part of the operating System.
7 Click OK to leave the Local Security Policy Setting dialog box.
8 In the Local Security Settings double click on the policy *Take ownership of files or other objects* on the list.
9 Click on the *Add*... button and select your computer name from the drop-down list box *Look In* container.
10 From the *Names:* list select the group *ChemStationAdmins* and click *Add*.
11 Click OK and check if the *ChemStationAdmins* group shows up in the *Assigned To* list.
12 Continue with “Adding ChemStation Users” on page 49.

![Local Security Policy Setting](image)

**Figure 30** User rights policy - Take ownership of files or other objects.
Configuring the User Rights Policies on Windows 2003 Server

1. Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.

2. In the Administrative Tools menu select Local Security Policy and open the Local Policies folder.

3. Select User Rights Assignment and double click on the policy Act as part of the operating system on the list.

4. Click on the Add User or Group... button.

5. Press the Locations... button and quit the eventually displayed Enter Network Password dialog with Cancel. Select the server PC name from the Location: list and press OK.

6. Press the Object Type... button and select Groups. Use the Find Now... button to get a list with all local group names. Select the groups ChemStationAdmins, ChemStationManagers, ChemStationOperators and click OK and OK again.

7. Press Apply and OK and check if all ChemStation groups show up in the list.

8. Click OK to leave the Local Security Policy Setting dialog box.

Figure 31  User rights policy - Act as part of the operating System.
9 In the Local Security Settings double click on the policy *Take ownership of files or other objects* on the list.

10 Click on the *Add User or Group*... button.

11 Press the *Locations*... button and quit the eventually displayed *Enter Network Password* dialog with *Cancel*. Select the server PC name from the *Location: list* and press *OK*.

12 Press the *Object Type*... button and select *Groups*. Use the *Find Now*... button to get a list with all local group names. Select the group *ChemStationAdmins* and click *OK* and *OK* again.

13 From the *Names: list* select the group *ChemStationAdmins* and click *Add*.

14 Click *OK* and check if the *ChemStationAdmins* group shows up in the *Assigned To* list.

15 Click *OK*, close the all windows and leave the Windows Control Panel.

16 Continue with “Adding ChemStation Users” on page 49.

---

**Figure 32** User rights policy - Take ownership of files or other objects.
Adding ChemStation Users

The global groups in the domain for ChemStation managers and operators are added to the local ChemStation groups.

The local groups shown in ‘Table 2’ are created during the installation. For the first setup no members are assigned.

Table 2  Local ChemStation User Groups on Server

<table>
<thead>
<tr>
<th>ChemStation User Group</th>
<th>Default Members</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChemStationAdmins</td>
<td>none</td>
</tr>
<tr>
<td>ChemStationManagers</td>
<td>none</td>
</tr>
<tr>
<td>ChemStationOperators</td>
<td>none</td>
</tr>
</tbody>
</table>

NOTE

If one or more UV-visible ChemStation shares for the Security Pack already exist, members may already exist for the groups.
2 Server/Workstation Installation

Add the Domain ChemStation Administrator account

1. Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.
2. In the Administrative Tools menu select Computer Management and open the Local Users and Groups folder.
3. Select the Groups folder and double click on the ChemStationAdmins name on the list.

Figure 33 Computer management - Groups.
4 Click on the Add... button and select the domain name from the drop-down list box Look In container.

![Groups - Add member(s) image]

**Figure 34** Groups - Add member(s).

5 Logon to the domain by use of the ChemStation administrator account.

![Logon to Domain image]

**Figure 35** Logon to Domain.
6 From the Name list select the account name with the ChemStation administrator and click Add.

7 Click OK for the selection, click Apply to add the member and close the dialog.

8 Add the domain ChemStation administrator account also to the local ChemStationManagers group. (Repeat steps 3 to 7 with the local ChemStationManagers group instead of the local ChemStationAdmins group).

9 Close all windows and leave the Windows Control Panel.
Add the Domain User Groups

1 Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.

2 In the Administrative Tools menu select Computer Management and open the Local Users and Groups folder.

3 Select the Groups folder and double click on the ChemStationManagers name on the list.

4 Click on the Add... button and select the domain name from the drop-down list box Look In container.

5 If required, login to the domain by use of the ChemStation administrator account.

6 From the Name list select the global group name with the ChemStation managers and click Add.

7 Click OK for the selection, click Apply to add the member and close the dialog.

8 To add the ChemStation operators repeat steps 3 to 7 with the ChemStationOperators group and add the respective global ChemStation operators group name.

9 Close all windows and leave the Windows Control Panel.
2 Server/Workstation Installation

Installing the Security Pack on the Workstation

To install the Security Pack you need checking the G1813AA Security-Pack Add-on and you should have the license keys available for all software modules to be installed or added.

Local administrator rights are required to perform the installation. If no ChemStation software is currently installed on the target PC please follow the “Installing the ChemStation Software” below, otherwise please go to “Adding the Security Pack to an installed ChemStation” on page 62.

Access to the domain is required to configure the workstation setup.

NOTE

The description for the Windows XP setup is described for Classic Start menu and the Windows classic appearance.
The Windows XP user interface can be changed by adjusting the properties for the Start menu and the desktop by means of a right mouse click.

Installation of Security Pack on a Workstation comprises steps.

1 “Installing the ChemStation Software” or “Adding the Security Pack to an installed ChemStation” on page 62.
2 “Configuring Security Pack”
3 “Configuring the Agilent Security Service”

A detailed description how to perform these three tasks is given in the following sections.
Installing the ChemStation Software

ChemStation software and the Security Pack can be installed at the same time. For details about the installation and configuration of the ChemStation software and the Agilent 8453 spectrophotometer please refer to the *Installing Your UV-visible Spectroscopy System* manual.

1. Log on as local administrator to your PC and make sure the drive you intend to install your ChemStation software is using the NTFS file system.

   Start Windows Explorer and right-click the drive where the ChemStation software shall be installed.

   By default the ChemStation software is installed on the C: drive under C:\Chem32. Select Properties, choose the General tab and check for the string File System: NTFS.

   ![Figure 37 Disk file system property.](image)

   If the file system is not NTFS, it must be converted. Select *Start > Programs > Accessories > Command Prompt*, then type

   `convert <drive>: /fs:ntfs /v`
where <drive> is the drive where the ChemStation software is installed, and press Enter.

At the end of the file conversion the message Conversion complete appears in the Command Prompt window. Type Exit and press Enter to close the window.

2 Insert the Agilent UV-Visible ChemStation CD-ROM and start setup.exe.

3 On the InstallShield Wizard press the Next button.

4 Please read the license terms and press the Yes button to accept.
5 Use the **Browse** button to enter or select your own Destination Folder or use the default installation folder C:\Chem32. Press **Next** to continue.

![License Agreement dialog.](image)

**Figure 40**  License Agreement dialog.

![Destination folder setup.](image)

**Figure 41**  Destination folder setup.
Server/Workstation Installation

Select all software packages you want to install.

![Software Component Selection](image)

**Figure 42**  Software component selection for installation.

**NOTE**  All Add-on software must be selected in the above setup dialog. No more modification is possible after a Security Pack installation.
7 Select Workstation - workstation part of the Server UV-Vis Security pack configuration and press Next.

![Figure 43 Installation type selection.](image)

8 Enter a licence key and press Add License. Repeat the license key entry until all licenses are added for your selected products then press Next.

![Figure 44 License key entry dialog.](image)
2 Server/Workstation Installation

9 The Configuration Editor is automatically launched to configure your installation. Please see your *Agilent 8453 UV-visible Spectroscopy System Installation Guide* for details. Exit the Configuration Editor.

10 Wait until the InstallShield Wizard’s completion dialog is displayed and press *Finish*. By default the system will reboot.

![Figure 45](image.png) 

**Figure 45** Installation completed dialog.

**NOTE**

Rebooting your system is required before you proceed. It may be delayed by selecting the *No, I want to restart my computer later* option.
11 From the Start menu run the UV-visible ChemStation's Installation Qualification and check for successful completion.

![Installation Qualification Result](image)

**Figure 46** Installation Qualification Result.

12 Continue with “Configuring Security Pack” on page 68.
Adding the Security Pack to an installed ChemStation

If you are adding the Security Pack to an Agilent UV-visible Spectroscopy System that has already been in use before, you might have already saved a customized configuration, that is incompatible with the Security Pack. Delete the files `configon.reg` and `configof.reg` under `C:\Chem32\n\` (n: instrument number 1 to 4, default installation path), if they exist.

1. Log on as local administrator to your PC and make sure the drive you intent to install your Security Pack software is using the NTFS file system. Start Windows Explorer and right-click the drive where the ChemStation software is installed. By default the ChemStation software is installed on the C: drive under `C:\Chem32`. Select Properties, choose the General tab and check for the string File System: NTFS.

![Figure 47](image) Disk file system property.

If the file system is not NTFS, it must be converted. Select `Start` > `Programs` > `Accessories` > `Command Prompt`, then type
convert <drive>: /fs:ntfs /v

where <drive> is the drive where the ChemStation software is installed, and press Enter.

At the end of the file conversion the message Conversion complete appears in the Command Prompt window. Type Exit and press Enter to close the window.

2 Insert the Agilent UV-Visible ChemStation CD-ROM and start setup.exe.

If you are adding the Security Pack on a previous revision of the ChemStation software, the dialog below is displayed. The installation will perform the required update automatically if you continue with pressing Next and step 4 below.
2 Server/Workstation Installation

3 In the Welcome dialog of the InstallShield Wizard select the Modify option and press the Next button.

![Install Shield Wizard Entry Dialog](image1)

Figure 50 Install shield wizard entry dialog.

4 In the Select Components dialog of the InstallShield Wizard check the G1813AA Security Pack Add-on and press the Next button.

![UV-visible ChemStation Software Components Selection](image2)

Figure 51 UV-visible ChemStation software components selection
5 In the Security Pack dialog select the *Workstation* configuration and press the *Next* button.

![Security Pack installation type selection](image)

**Figure 52** Security Pack installation type selection

6 Enter your license key in the entry line of the Enter License Information dialog, press the *Add License* button and then the *Next* button.

![License key entry](image)

**Figure 53** License key entry.
7 Now the software installation starts and finally the completion dialog is displayed. Press the Finish button to exit the installation program and close the Add or Remove Programs dialog.

Figure 54  Installation Completion dialog.
After the installation is completed, run the Installation Verification by selecting Start > Programs > UV-Visible ChemStations > Installation Qualification.

The Security Pack has been installed without errors when the message line Installation Verification completed successfully is displayed at the bottom of the ChemStation Installation Verification dialog.

Figure 55  Installation Qualification Result.

Continue with “Configuring Security Pack” on page 68.
Configuring Security Pack

After installation of Security Pack the Chemstation software can only be accessed by members of the global ChemStation user groups for ChemStation managers and ChemStation operators.

For more information about the ChemStation user groups refer to “Access Security” on page 90. A detailed description of the permissions of ChemStation Managers and Operators is given in Chapter 5, “Advanced Software” and Chapter 6, “Dissolution Testing Software”.

Configuration of Security Pack comprises the following steps.

1. Windows XP security policies have to be configured.
2. The network share has to be mapped to a local drive letter.
3. ChemStation users have to be added and/or managed.
4. The Agilent Security Service has to be configured and activated.
5. The UV-visible ChemStation configuration has to be stored to disk.

A detailed description of how to perform these three tasks is given in the following sections.

**NOTE**

In the workstation environment a server with the Security pack installed and configured must be accessible through a network connection.
Configuring Security Policies

After the installation of the workstation software the Windows XP operating system has to be configured to support the necessary security features. This configuration is identical to the configuration of the local Security Pack installation. Therefore only links to the respective manual sections are provided.

Configuring the Account Policy

For the configuration of the account policies please follow the instructions given for the local installation “Configuring the Account Policy” on page 25.

Configuring the User Rights Policies

—Act As Part of Operating System
—Take Ownership of files or other objects

For the configuration of the user rights policies please follow the instructions given for the local installation “Configuring the User Rights Policy —Act As Part of Operating System —Take Ownership of files or other objects” on page 26.

Configuring the Audit Policy

For the configuration of the audit policy please follow the instructions given for the local installation “Configuring the Audit Policy” on page 29.
2 Server/Workstation Installation

Mapping the Shared Server Directory

The UV-Visible ChemStation share created by the Security Pack installation on the server is linked to the workstation.

1. Open Windows Explorer and select Map Network Drive... from the Tools menu.

2. In the upcoming Map Network Drive dialog box select an unused Drive: letter.

3. In the Folder: entry field specify the Server name and the name of the shared drive/directory or use the Browse... button to select the share.

4. Check Reconnect at Logon and click OK.

NOTE

Make sure that the above mapping of the shared server directory is available to all UV-visible Security Pack users with the same drive letter for the UV-visible ChemStation server share.

Adding and Managing ChemStation Users

The global ChemStation administrator account and the global groups in the domain for ChemStation managers and operators are added to the respective local ChemStation groups.

The local groups shown in table 4, ‘Local ChemStation User Groups on Workstation’ are created during the installation. For the first setup no members are assigned.

Table 3 Local ChemStation User Groups on Workstation

<table>
<thead>
<tr>
<th>ChemStation User Group</th>
<th>Default Members</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChemStationAdmins</td>
<td>none</td>
</tr>
<tr>
<td>ChemStationManagers</td>
<td>none</td>
</tr>
<tr>
<td>ChemStationOperators</td>
<td>none</td>
</tr>
<tr>
<td>SharedChemManagers</td>
<td>none</td>
</tr>
<tr>
<td>SharedChemOperators</td>
<td>none</td>
</tr>
</tbody>
</table>
Add the Domain ChemStation Administrator account

The account of the domain ChemStation administrator has to be added to the local ChemStationAdmins and the local ChemStationManagers group.

1. Logon as local Administrator and select Start > Settings > Control Panel > Administrative Tools.
2. In the Administrative Tools menu select Computer Management and open the Local Users and Groups folder.
3. Select the Groups folder and double click on the ChemStationAdmins item in the list.

![Computer Management dialog.](image)
Server/Workstation Installation

4 Click on the *Add...* button.

![Group Members list](image1)

*Figure 57*  Group Members list.

5 Press the *Advanced...* button.

![Select Users or Groups dialog](image2)

*Figure 58*  Select Users or Groups dialog.
6 Press the *Object Types...* button.

![Advanced Select Users or Groups dialog.](image)

**Figure 59** Advanced Select Users or Groups dialog.
2 Server/Workstation Installation

7 Check Users and press OK.

![Object Types selection dialog.](image)

**Figure 60** Object Types selection dialog.

8 Press Locations..., select your domain and press OK.

![Location selection dialog.](image)

**Figure 61** Location selection dialog.
9 Press *Find Now* to get a list of accounts, chose the ChemStation account for administration and press *OK* and *OK* again.

**NOTE**

In larger domains you can use *Name* field to reduce the number of accounts listed.

![Global account selection for ChemStation administration.](image)

**Figure 62**

Global account selection for ChemStation administration.
2  Server/Workstation Installation

10 Press OK to quit the ChemStationAdmins property dialog.

![Figure 63](image)

Figure 63  Global account added to the local ChemStationAdmins group.

11 Add the domain ChemStation administrator account also to the local ChemStationManagers group. (Repeat steps 3 to 11 with the local ChemStationManagers group instead of the local ChemStationAdmins group).

12 Close all windows and leave the Windows Control Panel.
Add the Domain ChemStation Groups to the Local ChemStation Groups

For the access rights to the local PC the members of the global ChemStation user groups must be made available on the target workstation. This is done by adding only the global user groups to the respective local groups.

**NOTE**
No users must be created locally. The accounts and the membership of ChemStation users is managed only on the domain level.

**NOTE**
Make sure that no membership of the same account to both the local ChemStationManagers and the local ChemStationOperators occurs.

Perform the steps below for the local ChemStationManagers and the local ChemStationOperators groups: in the following steps referred to as ChemStation user group.

**NOTE**
The procedure below follows the same approach as the addition of the ChemStation admin account described before in “Add the Domain ChemStation Administrator account” on page 50. The difference is that the objects now are global groups rather than an account and the affected local groups are the ChemStationManagers and the ChemStationOperators group.

1. Logon as Administrator and select Start > Settings > Control Panel > Administrative Tools > Computer Management.
2. Open the Local Users and Groups folder.
3. Open the Groups folder and double click on the local ChemStation user group.
4. In the upcoming dialog box click on Add....
5. In the next upcoming dialog box click on Advanced.....
6. Press the Object Types... button, check only Groups and press OK.
7. Press the Locations... button, select the domain and press OK.
8. Press the Find Now button and select the global group(s), press OK and OK again.
9 Check that all selected groups appear in the Members list of the Local Group and press OK.

10 Close all windows and leave the Windows Control Panel.

After performing the user setup the local groups should contain the members as indicated in Table 4.

### Table 4  Local ChemStation User Groups on Workstation after configuration

<table>
<thead>
<tr>
<th>ChemStation User Group</th>
<th>Default Members</th>
</tr>
</thead>
<tbody>
<tr>
<td>ChemStationAdmins</td>
<td>&lt;Domain name&gt;&lt;ChemStation administrator account name&gt;</td>
</tr>
<tr>
<td>ChemStationManagers</td>
<td>&lt;Domain name&gt;&lt;ChemStation managers group name&gt;</td>
</tr>
<tr>
<td>ChemStationOperators</td>
<td>&lt;Domain name&gt;&lt;ChemStation operators group name&gt;</td>
</tr>
<tr>
<td>SharedChemManagers</td>
<td>none</td>
</tr>
<tr>
<td>SharedChemOperators</td>
<td>none</td>
</tr>
</tbody>
</table>

**NOTE**

The user management for ChemStation managers and ChemStation operators is done in the domain groups by adding or removing members to these groups. By this means it can be assured that the members are always present at the same time for the server as well as for the workstation.

The membership management should be performed by the IT administrator for the domain.
Configuring the Agilent Security Service

The Agilent Security Service ensures that all ChemStation files are owned by the global ChemStation administrator account. That is, whenever a ChemStation user generates a new result file the ChemStation administrator account takes automatically the ownership of this file. This data access security feature is necessary to prevent that, for instance, a ChemStation user with operator privileges can take ownership of a file and hence the permission to delete this file.

Configuring and Starting the Agilent Security Service

The security service must be configured and started. You need the global ChemStation administrator account name and the account password to perform the setup.

1. Logon as Administrator and select Start > Settings > Control Panel > Administrative Tools.
2. Double-click Services.
3. Double click on Agilent Security Service to open the Agilent Security Service Properties dialog box.
4. Choose Automatic as Startup Type.
5. Select the Log On tab and select Log on as: This account.
6. Enter the global ChemStation Administrator account name and the respective password twice and click Apply.
7. Select the General tab.
2 Server/Workstation Installation

8 In the General tab of the Agilent Security Service Properties dialog box click on Start.

9 Click on OK and check that the Agilent Security Status is Started.

![Services status (Standard view)](image)

Figure 65 Services status (Standard view).

10 Close all dialogs and exit the Windows Control Panel.

11 Reboot your computer.

12 Continue with “Saving the UV-visible ChemStation Configuration.” on page 81.
Saving the UV-visible ChemStation Configuration.

In order to start the secured UV-Visible ChemStation you have to be a member of one of the global groups for ChemStation managers or ChemStation operators.
If you are logged on as Administrator you are not allowed to start the ChemStation.

Before the first use of the ChemStation for operators, a manager has to configure the path pointing to a secure share as installed by the Server installation and save this configuration on exit.
The default values for the share access are invalid and cannot be changed by a user with operator rights only.

The installed configuration of the UV-visible ChemStation must be saved once by a ChemStation user with manager rights. This configuration becomes mandatory for users with operator rights.

1 Logon as a user of the ChemStationManagers group and select Start > Programs > UV-Visible ChemStations > Instrument 1 online.
2 Logon again to the UV-Visible ChemStation using the above account.
3 Exit the ChemStation session using the Exit ChemStation command form the File menu.
4 In the closing dialog displayed check Save Configuration and press OK.
5 Repeat steps 1 to 4 for the offline ChemStation Instrument 1 offline.
6 If multiple instruments are connected repeated steps 1 to 5 for all additional instruments.

Your UV-visible ChemStation with Security Pack is now readily configured and setup for all ChemStation users.
2 Server/Workstation Installation
This chapter describes how to update and uninstall Agilent UV-Visible ChemStation that has been protected by the Security Pack for UV-visible spectroscopy.
3 Updating and Uninstalling the Security Pack

Updating the ChemStation with Security Pack

The Update of an existing ChemStation with Security Pack to a higher revision is performed automatically by means of the setup program.

During the setup, the installation wizard displays the dialog below to inform you about the update.

![Revision mismatch warning dialog.](image)

**Figure 66** Revision mismatch warning dialog.

For details, please see the respective installation procedures for a local setup “Adding the Security Pack to an installed ChemStation” on page 18 or the workstation setup “Adding the Security Pack to an installed ChemStation” on page 62.
Uninstalling the ChemStation with Security Pack

The setup program supports the removal of the software.

**WARNING**

Make sure that you really want to remove the software.
We strongly recommend to archive all data files of a local system.

**NOTE**

For the installation on a different system make sure you have your license keys available.
The Modify option of the setup program can be used to read the license keys of the current installation.

To remove the software please follow the steps below.

1. Reboot the PC and log on as Administrator.
2. Insert the Agilent UV-Visible ChemStation CD-ROM and start Setup.exe.
3. On the InstallShield Wizard dialog select Remove and press Next.

![ChemStation software removal](image)

**Figure 67** ChemStation software removal.
3 Updating and Uninstalling the Security Pack

4 During the software removal the progress is indicated by the dialog below.

![Software removal progress indication.](image)

Figure 68  Software removal progress indication.
5 Please wait until completion of the operation is indicated by the dialog below and press Next to quit the setup program.

![Software removal completion dialog](image)

**Figure 69** Software removal completion dialog.

6 Reboot the PC.

**NOTE**

The local groups installed (ChemStationAdmins, ChemStationmanagers, ChemStationOperators, SharedChemManagers and SharedChemOperators) are not automatically removed. If they are no longer required, they can be removed using the Computer Management for groups.
3 Updating and Uninstalling the Security Pack
This chapter describes the concepts behind the Agilent Security Pack for UV-Visible ChemStation. The user will be introduced to the different aspects of CFR 21 Part 11 and how they are implemented in software.
Access Security

Security Pack provides access security to fulfill the FDA rules and guidelines for limited system access.

The example windows in this chapter refer to a system running Windows 2000. Some of the corresponding example windows appear different on Windows XP systems.

ChemStation Access Control

The ChemStation access control is based on the Windows user administration. To be allowed to logon to the ChemStation and to perform specific actions a user has to be added to one of the local ChemStation user groups by the Windows Administrator as described in “Creating and Managing New ChemStation Users” on page 30 (“Local Installation and Configuration”) or by an IT professional as described in “Server/Workstation Installation”, “Adding and Managing ChemStation Users” on page 70.

Members of the ChemStationManagers and SharedChemManagers group have access to the Manager Mode of the ChemStation software, while members of the ChemStationOperators and SharedChemOperators group can access the Operator Mode. Following table gives a short overview about the major permissions in Manager and Operator mode. For detailed information refer to Chapter 5, “Advanced Software” and Chapter 6, “Dissolution Testing Software”.

Table 5 Permissions of ChemStation Managers and Operators

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load Method</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Change Method Parameters / Meta Data</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Save Method</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Perform Measurements</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Save Result</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
In a local setup of the system all groups and users may exist local and can be managed by the local administrator. In a distributed environment with a workstation setup and server setup, all users and the respective ChemStation user groups should be global. This has a lot of advantages for the user and account administration. No more user and group management is required on the target workstation and server system after the installation. All user management and administration work can be performed in the user domain by IT professionals.

The groups SharedChemManagers and SharedChemOperators can be used, for example, in the following situation:

- A ChemStation is used by multiple users,
- these ChemStation users are using the ChemStation software sequentially without shutting down the computer in between, and
- the Windows security lockout CTRL + ALT + DELETE (Lock Workstation) is used to prevent the computer from unauthorized access during unattended operation.

If the Windows security lockout is used, only the user who locked the session or a Windows administrator can unlock the computer. In this case a different ChemStation Manager or ChemStation Operator would not be able to unlock the computer and finalize the analysis, e.g. the postrun tasks after an automated 12-hour dissolution run.

In order to avoid such a situation a SharedChemManager/Operator account can be setup by the administrator and used as shared Windows login account. If the Windows session started by logon to SharedChemManager/Operator account, all users will know the password of the shared user. They will be able to unlock the Windows Workstation.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load Result</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Sign Dissolution Result</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Change Report Setup</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
4 Introduction

**NOTE**

In the distributed environment of the server/workstation setup global accounts should be used for the shared Manager and Operator accounts.

But in addition each Manager/Operator must use their personal account to log on to the UV-visible ChemStation. This is required in order to assign all actions (measurements) to the correct ChemStation User. Members of the SharedChemManagers/Operator group cannot start the UV-visible ChemStation. They must be members of the ChemStationManager/Operator group as well.

**NOTE**

The configuration of the SharedChemManager/Operator accounts is not required, if the ChemStation users are using the ChemStation lockout (Config > Lock Session).

All aspects of password handling like aging, length, session lockout or uniqueness are controlled by the Windows Account Policy. The Account Policy is specified by the administrator during installation of the security pack, see “Configuring the Account Policy” on page 25 (“Local Installation and Configuration”).

![Local Security Settings](image)

*Figure 70*  Local Windows Account Password Policy for all users
Furthermore, the administrator defines the password settings for the individual user when assigning a new account, refer to "Creating and Managing New ChemStation Users" on page 30 ("Local Installation and Configuration") for details.
During logon to the ChemStation software the system checks whether the user is member of one of the local ChemStation user groups and whether the given password is valid and in accordance with the defined account policies and password settings.

![ChemStation Logon](image)

**Figure 73** ChemStation Logon
Logging Security Violations

In accordance to the Audit Policies defined by the administrator during configuration of the security pack, Windows automatically maintains a logbook tracking all security violations such as failed attempts to logon to the ChemStation or the computer. To check the security log of the Windows Event Viewer select Start > Settings > Control Panel > Administrative Tools > Event Viewer and choose Security from the Log menu.

![Figure 74](image)

Log of Security Violations using Windows Event Viewer

When double clicking an event the Event Detail dialog pops up showing a detailed description of the event.
Session Lock for Unattended Operation

The Security Pack offers the possibility to lock the ChemStation even during the execution of a sequence. This is to prevent the system from unauthorized access during unattended operation. The ChemStation session lock is activated by selecting Lock Session from the Config menu.

An automatic lock of the system after a specified time period can be enabled by ChemStation managers by selecting Inactivity Lockout from the Config menu. In any case the operator has to enter his user name and password to unlock the system again.
Changing Operator and Password

The operator can either be changed by choosing Change Operator from the Config menu, which brings up the ChemStation Logon dialog as shown in Figure 73 on page 94, or by entering the new user name and password while the ChemStation is locked, see Figure 75 on page 96.

Operator passwords can be changed by

- using built-in Windows Security dialog (Ctrl+Alt+Delete > Change Password)
- clicking Change Password during logon to the ChemStation (Figure 73 on page 94).
- clicking Change Password while the ChemStation is locked (Figure 75 on page 96).

NOTE

When checking Autostart as NT User from the Config menu, the user name and password of the current Windows user will be used during the next start of the ChemStation. In this case no password is required to start the ChemStation. Autostart as NT User can only be configured by ChemStation managers.
4 Introduction

Restricted File Access

ChemStation files are protected against manipulations using Windows file access permissions. For example, ChemStation operators must not be able to delete result files and, to ensure audit traceability, even ChemStation managers must not be allowed to delete methods.

To check the permissions do a right-click on the directory, select the Security tab and press the Advanced button from the Security tab.

Figure 76 shows the permissions that are applied to the data and method directory during installation of the Security Pack software. In the Permission Entries table for each user or group the associated permissions and their usage are shown.
As an example, Figure 77 shows the file access permissions for ChemStation Operators in the data directory.

![Permission Entry for data](image)

**Figure 77** File Access Permission of the ChemStationOperators Group in the Data Directory

For detailed informations about Windows file access permission refer to Windows 2000 or the Windows XP documentation.
Table 6 gives an overview of the directory and file access permissions for all subdirectories of a configured instrument, e.g. \Chem32\1.

**Table 6** Directory and File Permissions of ChemStation

<table>
<thead>
<tr>
<th>User Group</th>
<th>Instrument Directory</th>
<th>ChemStationOperators</th>
<th>ChemStationManagers</th>
<th>ChemStationAdmins</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automat</td>
<td>Read,Write &amp; Execute</td>
<td>Read &amp; Execute</td>
<td>Read,Write &amp; Execute</td>
<td>Read &amp; Execute</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data</td>
<td>Read,Write &amp; Execute</td>
<td>Read &amp; Execute</td>
<td>Full Control</td>
<td>Modify</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Diagnose</td>
<td>Full Control</td>
<td>Full Control</td>
<td>Full Control</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Method</td>
<td>Read,Write &amp; Execute</td>
<td>Read &amp; Execute</td>
<td>Read,Write &amp; Execute</td>
<td>Read &amp; Execute</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reports</td>
<td>Read,Write &amp; Execute</td>
<td>Read &amp; Execute</td>
<td>Full Control</td>
<td>Modify</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stds</td>
<td>Full Control</td>
<td>Full Control</td>
<td>Full Control</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Temp</td>
<td>Write &amp; Execute</td>
<td>Full Control</td>
<td>Full Control</td>
<td>Modify</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Data Integrity

This section describes how the Security Pack follows the FDA rules and guidelines for data integrity. The major aspects of data integrity that have been implemented in the ChemStation software are as follows.

- Operators can load predefined methods and run a sequence of measurements but are not allowed to change any meta data.
- If spectra are deleted during a measurement sequence they are not deleted from the set of raw data but stored in a separated data block that is part of the results and can be retrieved at any time.
- The measurement sequence takes place in a closed loop and requires the storage of the results on exit.
- It is possible to retrieve the original data and results at any time. Raw and meta data are linked by storing both to a single result file. The result file includes logbooks documenting who did what during a sequence.
- Raw and meta data are protected from unauthorized modification. An operator is not allowed to modify, move, delete or rename a result.
Introduction

Changing Methods

Within a sequence operators are able to measure blanks, samples, standards and auxiliaries and to check all results through the View menu. However, operators are not allowed to change any acquisition or evaluation parameters. For this reason all method setup dialog boxes and the spectrophotometer setup dialog are de-activated for ChemStation operators.

Figure 78  Advanced and Dissolution Method Setup Menus in Operator Mode

Chapter 5, “Advanced Software” and Chapter 6, “Dissolution Testing Software” are giving a detailed overview of the active menus in Operator mode.
Deleting Spectra

If a user deletes an acquired spectrum from the sample or standard table it is mandatory to enter a reason in the Delete Spectra dialog box, see Figure 79.

**NOTE**

To delete a spectrum it has to be selected first by clicking the spectrum in the Sample/Standard Spectra window or by clicking left to the number of the spectrum (# column) in the Sample/Standard Spectra Table. You can select several spectra at the same time by holding the Ctrl key while selecting.

After a spectrum has been deleted an entry in the Run Logbook is generated, documenting that the original result has been changed, see “The Run Logbook” on page 105. Deleted spectra are not removed from the raw data but moved into the Deleted Spectra register. The content of the deleted spectra register can be checked at any time by selecting Deleted Spectra from the View menu.
To be able to recalculate the original results all deleted spectra can be restored by selecting the spectra and clicking Restore, see Figure 80. Restoring deleted spectra again generates an entry in the Run Logbook.

Result Files

After finishing a sequence the result file is saved by selecting Save Advanced/Dissolution Result As from the File menu. The result file (*.ar/dr) comprises all raw spectra, deleted spectra a run logbook and a signature logbook. For details refer to “The Advanced Software Result Concept” on page 112 and “The Dissolution Testing Result Concept” on page 126. By saving all information to a single file it is ensured that the original results can be reproduced during an audit. Result files are protected against manipulation by a checksum and against deletion by the Windows file access permissions, see “Restricted File Access” on page 98 for details.
Audit Traceability

The Method Changed Logbook

To ensure audit traceability it is not possible to overwrite an existing method. If a manager wants to save a changed method to disk he has to save it to a new file. Each method includes a Method Change Logbook with the history of the method as well as a comment explaining the changes.

The Method Change Logbook is automatically attached to the method and allows a tracing of all predecessors of a method by the name and location on the filing system.

To display the Method Change Logbook on screen select View > Logbooks > Method Change Logbook and click Display.

The Run Logbook

A versioning based on the logbook is implemented for result files. Changing raw and meta data by deleting a sample or changing a method parameter, for instance, will automatically generate an entry in the Run Logbook.

Reprocessing the results with changed parameters by selecting Dissolution Result > Calculate from the View menu will append the logbook with information on the actions done during reprocessing.

If the result is signed and stored again, the result file now includes the changed method and a copy of the actual Run Logbook.
To display the Run Logbook select View > Logbooks > Run Logbook and click Display. Figure 82 shows an example of a dissolution result run logbook where the result has been recalculated and signed by the manager after method and run parameters have been changed.

Retrieving the Original Result

In case the manager has signed a result after changing raw and meta data, the original result can be retrieved by applying following procedure:

- Load the result file.
- Load the original method by selecting File > Load Method and, if available, restore deleted spectra, see “Deleting Spectra” on page 103 for details.
- Select View > Dissolution Result > Calculate to recalculate the result using the original method parameters and raw data.
Electronic Signatures

After finishing a sequence the operator must sign and save the result file by selecting File/Save Advanced(Dissolution) Result As. In the upcoming Sign Result dialog box the operator has to enter his user name and password before the result is saved.

![Figure 83 Saving Results](image1)

Existing results can be reviewed and signed off by the manager. Selecting File/Sign Advanced (Dissolution) Result opens the Sign Result dialog box where the Manager has to specify the reason for the signature, his user name and password.

![Figure 84 Signing Results](image2)
4 Introduction

All signatures are saved with the result file and documented in the signature logbook with date, time, reason and full name of the user who signed the result. To review the signature logbook select View > Logbooks > Signatures and click Display.

![Signature Logbook](image)

**Figure 85** Signature Logbook

### ChemStation Modes and Support of 21 CFR Part 11

The different ChemStation modes offer different levels of support of CFR 21 Part 11. For full compliance with CFR 21 Part 11 the advanced or dissolution testing mode are required. Table 7 gives an overview on the available features of Security Pack for UV-visible ChemStation in dependence of the selected mode.

**Table 7** Security Features of ChemStation Software Modes

<table>
<thead>
<tr>
<th>Feature</th>
<th>Standard</th>
<th>Advanced</th>
<th>Dissolution</th>
<th>Kinetics/Thermal Denaturation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Raw data protection</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Storage of raw and meta data</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Mandatory log-in</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Electronic sign-off</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Application lock†</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Audit trail for methods</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Audit trail for raw/meta data</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
</tbody>
</table>
Introduction

Table 7  Security Features of ChemStation Software Modes (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Standard</th>
<th>Advanced</th>
<th>Dissolution</th>
<th>Kinetics/Thermal Denaturation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password policy part 11</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>-</td>
</tr>
<tr>
<td>Archiving built-in†</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>-</td>
</tr>
<tr>
<td>Data recovery tools</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>-</td>
</tr>
</tbody>
</table>

* Not supported

† Not mandatory for Part 11 compliance, but important to ensure access security during unattended operation.

‡ Not mandatory for Part 11 compliance, but recommended for data security and long-term data storage. Interface to NuGenesis data base provided.
4 Introduction
Advanced result concepts and active menus for managers and operators using the Agilent ChemStation advanced software.

To fulfill the requirements of 21 CFR Part 11 a new result concept and a dynamic menu structure have been implemented in the advanced software.

The dynamic menu structure prevents an operator from certain actions during an analysis. For instance, an operator must not be allowed to clear any measured spectra before the result has been saved.

In this chapter the advanced result concept and the accessible menu items at different states of an analysis are described.
The Advanced Software Result Concept

The result concept of the advanced software, for instance, doesn’t allow an operator to clear spectra or to change the software mode before the results are saved to disk. Such restrictions are implemented by means of a dynamic menu structure, which guides the operator through an analysis, i.e. the actual analysis state defines which menus are accessible and which are deactivated.

Table 8 on page 113 shows the analysis states, the possible actions at this state and which state is reached next after a certain action. All these actions will be added in the Run Logbook, which is saved with the result file. The section “The Dynamic Menu Structure/ User Interface” on page 114, describes the active menus in Manager and Operator mode, depending on the analysis state.

The advanced result file (*.ar) comprises all information that is necessary to recover state 2 (Result Saved) when reloading the result. The following list gives an overview of the information that is saved with a result file:

- Sample Spectra
- Method Parameters
- Run Logbook
- Signatures Logbook
- Standard Spectra (if available)
- Auxiliary Spectra (if available)
- Deleted Spectra (if available)
- Automation Table (if available)
- Method Change Logbook (if available)
### Table 8  Advanced Result Concept—Analysis States

<table>
<thead>
<tr>
<th>State #</th>
<th>Analysis State</th>
<th>Possible Actions / Active Menus</th>
<th>Next State</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Initial State</td>
<td>Load Method...</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Load Samples/Standards/Auxiliary...</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Load Automation...</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Measure Blank/Sample/Standard/Auxiliary</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Run Automation</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Load Advanced Result</td>
<td>4</td>
</tr>
<tr>
<td>1</td>
<td>Spectra Measured</td>
<td>Measure Blank/Sample/Standard/Auxiliary</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Save Advanced Result As...</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>Result Saved</td>
<td>Print Report</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clear Standards/Auxiliary</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clear Samples</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>Automation Finished</td>
<td>Save Advanced Result As...</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Advanced Result saved during automation</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Spectra cleared during automation</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>Result Loaded</td>
<td>Print Reports</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Sign Advanced Result...</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clear Standards/Auxiliary</td>
<td>4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clear Samples</td>
<td>0</td>
</tr>
</tbody>
</table>
The Dynamic Menu Structure/ User Interface

The following sections give a tabular overview of all menu items of the advanced software and whether they are available in a certain analysis state in Manager and Operator modes (compare Table 8 on page 113).

NOTE

The column State 3 Automation Finished of Table 9 on page 115 through Table 16 on page 122 reflects state 3 under the assumption that the advanced result file has not been saved during the automation (switch to state 2) and that the samples have not been cleared (switch to state 0).

The Main Menu Bar

Figure 86 shows the accessible main menus in the Manager and Operator mode. The main menu bar is independent from the analysis state.

<table>
<thead>
<tr>
<th>Manager Mode</th>
<th>File</th>
<th>Edit</th>
<th>Method</th>
<th>Measure</th>
<th>Instrument</th>
<th>Automat</th>
<th>Math</th>
<th>Optimize</th>
<th>View</th>
<th>Mode</th>
<th>Config</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator Mode</td>
<td>File</td>
<td>Edit</td>
<td>Method</td>
<td>Measure</td>
<td>Instrument</td>
<td>Automat</td>
<td>View</td>
<td>Mode</td>
<td>Config</td>
<td>Help</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 86 Menu Bar in Manager and Operator Mode

The Math and Optimize menus are used in Manager mode during method development. For instance, it can be used to check for the wavelength of best sensitivity or selectivity or to optimize the robustness of an analytical method. However, in the Operator mode the Math and Optimize menu are not accessible because operators are not supposed to perform any interactive manipulation of acquired spectra.
The File Menu

By means of the dynamic file menu the ChemStation software ensures that, for instance, an operator cannot load an existing result file or a new method before the actual result has been saved to disk (File > Save Advanced Result As) and the results are cleared (Edit > Clear > Samples).

Table 9 gives an overview about all items of the File menu and whether they are available in a certain analysis state in Manager and Operator modes.

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish.</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
</tr>
<tr>
<td>Load Samples</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Load Standards</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Load Auxiliary</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Save Samples</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Save Standards</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Save selec. Spectra</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Import Samples</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Import Standards</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Import Auxiliary</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Export selec. Data</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>New Method</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Load Method</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Save Method As</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Set Method Passw.</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
</tbody>
</table>
## Advanced Software

### Table 9 The File Menu—Active Menus in Dependence of the Analysis State (continued)

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish.</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
</tr>
<tr>
<td>Load Automation</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Save Automation</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Load Sample Table</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Save Sample Table</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Load Advanced Res.</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Save Advanced Res.</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Sign Advanced Res.</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Print Results</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Report Setup</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
</tbody>
</table>
The Edit Menu

The Edit menu ensures that, for instance, an operator cannot clear any spectra before the advanced result is saved to disk.

Table 10 gives an overview about all items of the Edit menu and whether they are available in a certain analysis state in Manager and Operator modes.

Table 10  The Edit Menu—Active Menus in Dependence of the Analysis State

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
</tr>
<tr>
<td>Cut</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Copy</td>
<td>no</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Paste</td>
<td>no</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Paste Append</td>
<td>no</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Select All</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Copy to Clipboard</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Clear Samples</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Clear Standards</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Clear Auxiliary</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Clear Op./Math Res.</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Annotate</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>
The Method Menu

According to CFR 21 Part 11 operators must acquire data in a controlled mode, where it is not possible to change any method parameter. This requirement is fulfilled by means of the method menu, which does not allow the operator to access any method setup dialog box in any analysis state.

Table 11 shows that for both managers and operators the Method menu is independent from the analysis state.

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Analysis</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Report Setup</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
<tr>
<td>Analyze</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Calibrate</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Options &amp; Info</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
</tbody>
</table>

Table 11 The Method Menu
The Measure Menu

The measure menu ensures that, for instance, an operator cannot measure further spectra after a result has been saved.

Table 12 gives an overview about all items of the Measure menu and whether they are available in a certain analysis state in Manager and Operator modes. In Manager mode the Measure menu is independent from the analysis state.

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>Manager</th>
<th>Operator</th>
<th>Manager</th>
<th>Operator</th>
<th>Manager</th>
<th>Operator</th>
<th>Manager</th>
<th>Operator</th>
<th>Manager</th>
<th>Operator</th>
<th>Manager</th>
<th>Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blank</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Sample</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Standard</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Auxiliary</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
</tr>
</tbody>
</table>
5 Advanced Software

The Instrument Menu

The Instrument menu prevents that an operator can change any spectrophotometer or pump setup parameter since both belong to the set of method parameters.

Table 13 gives an overview about all items of the Instrument menu. For both Manager and Operator mode the Instrument menu is independent from the analysis state.

Table 13 The Instrument Menu

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manager Operator</td>
<td>Manager Operator</td>
<td>Manager Operator</td>
<td>Manager Operator</td>
<td>Manager Operator</td>
</tr>
<tr>
<td>Select Sampl. Syst.</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Setup Sampl. Syst.</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Setup Spectroph.</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Lamps</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Spectroph. Status</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>

When selected:

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>Manager Operator</th>
<th>Manager Operator</th>
<th>Manager Operator</th>
<th>Manager Operator</th>
<th>Manager Operator</th>
<th>Manager Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>MCT Control</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Pump Control</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Setup Pump Param.</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>
The Automat Menu

Table 14 gives an overview about all items of the Automat menu and whether they are available in a certain analysis state in Manager and Operator modes. For Manager mode the Automat menu is independent from the analysis state.

Table 14  The Automat Menu—Active Menus in Dependence of the Analysis State

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0</th>
<th>State 1</th>
<th>State 2</th>
<th>State 3</th>
<th>State 4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
<td>Operator</td>
<td>Manager</td>
</tr>
<tr>
<td>Run Automation</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Information</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Setup Autom. Table</td>
<td>yes (read)</td>
<td>yes (read)</td>
<td>yes (read)</td>
<td>yes (read)</td>
<td>yes (read)</td>
</tr>
<tr>
<td>Setup Sample Table</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>

The View Menu

The View menu gives a convenient access to spectra, logbooks and results. However, in the view menu you cannot execute any action or change any parameters such as method or instrument parameters. Hence, all items of the View menu can be accessed in Manager and Operator modes at any analysis state.
5 Advanced Software

The Mode Menu

Table 15 shows whether a mode switch is possible in a certain analysis state in Manager and Operator modes.

Table 15 The Mode Menu—Active Menus in Dependence of the Analysis State

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode menu active</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
</tr>
</tbody>
</table>

The Config Menu

Table 16 gives an overview about all items of the Config menu. For both Manager and Operator modes the Config menu is independent from the analysis state.

Table 16 The Config Menu

<table>
<thead>
<tr>
<th>Mode Menu Item</th>
<th>State 0 Initial State</th>
<th>State 1 Spectra Measured</th>
<th>State 2 Result Saved</th>
<th>State 3 Automation Finish</th>
<th>State 4 Result Loaded</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Path</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Graphic Attributes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Show Graphical UI</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Show Sidebar</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Lamp Time Table</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Change Operator</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Lock Session</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>
The Help Menu

All items of the Help menu can be accessed in Manager and Operator modes at any analysis state.

Advanced Software Automation and Result Concept

To make the advanced software automation compliant with the result concept of Security Pack the following changes have been implemented compared to the non-security advanced software:

- The actions Save Samples, Save Standards and Save Auxiliary are removed.
- Save Result is added to the list of actions.
- For the action Save Result a mechanism has been implemented that automatically creates a new filename. The auto-filename creation allows specifying the beginning of the filename. The system then replaces the remaining characters—up to eight—with digits representing the next free number.

Example: In the automation table the string “ar1_” is defined as parameter for Save Result. When Save Result is executed the system searches the data folder for all files starting with “ar1_”, e.g. ar1_0000.ar, ar1_0001.ar and ar1_0002.ar. In this example the result filename will be bt1_0003.ar, since “3” is the next available number.
5  Advanced Software

• The consistency check makes sure that no spectrum is cleared before it is saved with the result. Following rules have been implemented:
  • Clear spectra can be in the first row in the automation table.
  • Clear spectra can follow another clear.
  • Clear spectra is allowed after Save Result.
  • Clear spectra can follow Result Report only if Result Report directly follows Save Result. The figure below shows an example of an illicit sequence. Exchanging lines 4 and 5 would lead to a valid sequence.

![Automation Table](image)

**Restricted Data Path**

To restrict the path where the result is saved to a protected area is essential for data security. Paths can be changed with the Config/Path menu items. The data path can be changed also when saving samples or results, the standards path when saving standards, the method path when saving methods and the automation path when saving the automation table. An operator is not allowed to change to a folder that is closer to the root than the predefined settings. These settings can be saved with the configuration at the end of a ChemStation session.
This chapter describes the security aspects of the dissolution testing software.

- “The Dissolution Testing Result Concept” on page 126 explains the dissolution result concept.
- “The Dissolution Testing User Interface” on page 127 gives an overview about the major changes of the dissolution user interface compared to the standard dissolution testing software.
- “The Dissolution Testing Menus” on page 130 describes the security aspects of the dissolution menus.
Data integrity is one of the basic aspects, which has to be addressed to fulfill FDA rules of secure data handling.

To ensure data integrity it must be possible to reproduce the original results at any time. In the ChemStation dissolution testing software this is achieved by saving all raw and meta data in one result file (*.dr) and by preventing this file from unauthorized modification using Windows file access permission. After Installation of the Security Pack the action “Save dissolution result” must be added to the PostRun sequence in order to ensure data integrity. If this action is missing, the automated consistency check will indicate an error and impede the start of the dissolution run.

If the dissolution run is aborted, the operator has to enter a reason. The ChemStation will stop the dissolution run and move on to the PostRun sequence to ensure that the dissolution result file is saved.

Following list gives an overview about the raw and meta data saved with a dissolution result file:

- Sample Spectra
- Method Parameters
- Actual Dissolution Parameters (from Edit Run Parameter and Edit Control Parameter dialog box, see “The Dissolution Testing User Interface” on page 127)
- Run Logbook
- Signatures Logbook
- Standard Spectra (if available)
- Auxiliary Spectra (if available)
- Deleted Spectra (if available)
- Automation Table (if available)
- Method Change Logbook (if available)

NOTE

No calculated results are saved with the dissolution result file.
The Dissolution Testing User Interface

To make the Dissolution Testing ChemStation software compliant with CFR 21 Part 11 three major changes have been implemented in the user interface:

- The item Sign Dissolution Result has been added to the File menu.
- Operators have no permission to change any method parameter via the Method and Instrument menu.
- Operators are no longer able to specify the actual dissolution parameters like vessel volume, tablet weights or control concentration after the run has finished (via the Dissolution menu). To be able to enter the actual values, the check box Prompt for information before run must be selected by the manager during method development in the Product, Bath and Info Method Parameters dialog box (select Method/Edit Product Info and Bath Parameter/Options & Info).
When Prompt for information before run has been selected the operator is automatically prompted to enter the actual dissolution parameters during the dissolution run. After the PreRun Sequence has finished the Edit Run Parameter dialog pops up first. In this dialog the operator can enter the Lot#, the Bath serial number, the actual conditions of the dissolution bath and the weight of each tablet.
Second, the Edit Control Parameter dialog box pops up, if a Control has been defined as one step of the measurement cycle in the Measure Cycle Definition dialog box (Method/Define Measurement Cycle). In this dialog the operator can specify the actual value of the control.
The Dissolution Testing Menus

The following sections are giving a detailed overview about the menu items of the dissolution testing software and whether they are available in Manager and Operator modes.

The Main Menu Bar

Figure 87 shows the accessible main menus in Manager and Operator mode.

- **Manager Mode**: File → Edit → Method → Measure → Instrument → Dissolution → Math → View → Mode → Config → Help
- **Operator Mode**: File → Edit → Method → Measure → Instrument → Dissolution → View → Mode → Config → Help

Figure 87  Menu Bar in Manager and Operator Mode

The Math menu can be used by managers for interactive spectral processing during method development. However, in the Operator mode the Math menu is not accessible since operators are not supposed to perform any interactive manipulation of acquired spectra.
The File Menu

Operators are not allowed to develop new methods, save methods, sign dissolution results or change the format of reports (Report Setup). These restrictions are reflected in Table 17, which gives an overview about all items of the File menu and whether they are available in manager and operator mode.

Table 17  The File Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load Samples, Standards, Auxiliary</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Save Samples, Standards, Selected Spectra</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Import Samples, Standards, Auxiliary</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Export Selected Data as</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>New Method</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Load Method</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Save Method As</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Set Method Password</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Load Dissolution Result</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Save Dissolution Result As</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Sign Dissolution Result</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Print Results, Methods, Calibration</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Report Setup</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
The Method Menu

Table 18 gives an overview about all items of the Method menu and whether they are available in manager and operator mode. In Operator mode all method setup dialog boxes are deactivated, because Operators must not be allowed to change any method parameter.

However, the items Analyze and Calibrate are accessible in Operator mode since they are only used for recalculating the Dissolution result and calibration curve.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Product Info and Bath Parameter</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Edit Evaluation Parameter</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Edit Dissolution Run Parameter</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Define Measurement Cycle</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Define Control for Measurement Cycle</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Analyze</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Calibrate</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
The Instrument Menu

Operators are allowed to work interactively with the selected sampling system. For instance, they can control the position of multicell transports, valves and autosamplers and they can interactively start and stop the pump, if connected.

However, operators have no permission to change the spectrophotometer parameters (wavelength range, integration time, interval) and pump parameters (pump time, wait time, etc.). These acquisition parameters are meta data and therefore saved with result and method files. Meta data can be changed in Manager mode, only.

The limited access to the instrument menu for operators is summarized in Table 19.

Table 19  The Instrument Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Sampling System</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Setup Sampling System</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Setup Pump Parameters (submenu of Setup Sampling System if Online Multicell, Sipper, or Autosampler has been selected)</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Setup Spectrophotometer</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Lamps</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Spectrophotometer Status</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Dissolution Bath Status</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Depending on the selected sampling system:

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pump</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Multicell Transport Position</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Autosampler</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Valve Position</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Setup Cycle Time</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
The Dissolution Menu

In manager mode the Dissolution menu can be used to
• start a dissolution run
• specify the actual dissolution parameters after the run has finished (Edit Run Parameter and Edit Control Parameter dialog box)
• define which vessels will be used to calculate the dissolution result, e.g. when two different batches have been measured in one run (Vessel Usage dialog box).

Operators, however, are not allowed to change the actual dissolution parameters after the dissolution run has finished, since these parameters are meta data and therefore saved with the dissolution result file (see “The Dissolution Testing User Interface” on page 127). Furthermore, operators are not able to exclude any vessel from the calculation of the dissolution result.

The restricted access to the dissolution menu for operators is reflected in Table 18 on page 132.

Table 20  The Dissolution Menu

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Manager Mode</th>
<th>Operator Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run Dissolution</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Stop</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Edit Run Parameter</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Edit Control Parameter</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Setup Vessel Usage</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
Index

Numerics
21 CFR Part 11 3, 108

A
access security 90
account policy 92
Windows XP 25
workstation 69
accounts, adding
workstation 77
act as part of the operating system
Windows 2000 (server) 44
Windows XP 26
advanced result concept 113
Agilent security service
Windows 2000 (server) 41
Windows XP 33
workstation 79
analysis states 112, 113
analyze 132
audit 104
audit policy
Windows XP 29
audit policy, configuring
Windows XP 29
workstation 69
audit traceability 98, 105
auto-filename creation 123
automat menu 121
automation 123
autosamplers 133
autostart as NT user 97

B
biochemical analysis software (G1117AA) 9

C
calibrate 132
changing methods 102
changing operator 97
changing password 97
changing raw and meta data 105
ChemStation access control 90
ChemStation logon 94
ChemStation software modes 108
ChemStation user groups
Windows XP 24, 32
ChemStation users, adding
Windows 2000 (server) 49
ChemStationAdmin 33, 41
ChemStationManagers 30, 49, 70, 78, 90
ChemStationOperators 30, 49, 70, 78, 90
clear spectra 117, 124
closed loop 101
config menu 122
configuring security pack
Windows XP 24
workstation 68
Configuring the Agilent Security Service
workstation 79
configuring the Agilent security service
Windows 2000 (server) 41, 44
Windows XP 33, 36, 81
consistency check 124
control 129
collection concentration 127
control panel
Windows XP 30
controlled mode 118

data and method directory 98
data integrity 101, 126
deleted spectra register 103
deleting spectra 103
dissolution menu 134
dissolution run 134
dissolution testing menus 130
domain accounts, adding
Windows XP 32
dynamic menu structure 114
edit control parameter 129
edit menu 117
edit run parameter 128
electronic records 3
electronic signatures 3, 107
event viewer 95
Windows XP 29

F
FDA 3, 90
file access permissions 98
file menu 115, 131
Food and Drug Administration 3

G
G1115AA software 9
G1117AA software 9
general purpose software (G1115AA) 9
Index

I
inactivity lockout 96
installing security pack
  Windows XP 18, 62
installing the ChemStation software
  Windows XP (local) 11
  workstation 55
instrument menu 120, 133

L
local accounts
  Windows XP 32
local policies
  Windows XP 25, 29
logbook 95, 101
logon 94

M
main menu bar 114, 130
manager mode 90, 114, 130
Managing ChemStation users
  workstation 70
math menu 114, 130
measure menu 119
member 94
meta data 101, 126, 133
method change logbook 126
method changed logbook 105
method menu 118, 132
method parameter 132
method parameters 126
mode menu 122
mode switch 122
multicell transport 133

O
operator mode 90, 114, 130
optimize menu 114
original results 104
ownership 79
  Windows 2000 (server) 41
  Windows XP 33

P
password handling 92
password restrictions
  Windows XP 25
password settings 93
permissions of ChemStation managers and
  operators 90
predefined methods 101
prompt for information before run 128
pump setup 120

R
raw data 101, 126
recalculate 104
reprocessing 105
restricted data path 124
restricted file access 98
result concept 112
result file 101, 126
result files 104
results 101
retrieving the original result 106
reviewed 107
run logbook 105, 112, 126

S
saving results 107
security policies
  Windows XP 25
workstation 69
security service
  Windows 2000 (server) 41, 44
  Windows XP 33
security violations 95
sequence 96
service
  Windows XP 33
session lock 96
SharedChemManagers 30, 91
SharedChemOperators 30, 91
sign 107
sign dissolution result 127
sign dissolution results 131
signatures logbook 126
signed 105
signed off 107
signing results 107
software
  biochemical analysis 9
  G1115AA 9
  G1117AA 9
  general purpose 9
spectral processing 130
spectrophotometer parameters 133
spectrophotometer setup 102, 120

tablet weights 127
take ownership of files or other objects
  Windows 2000 (server) 44
  Windows XP 26
unattended operation 96
unauthorized modification 101
uninstall ChemStation 85
uninstall Security Pack 85
updating ChemStation 84
updating Security Pack 84
user accounts, creating
  Windows XP 30
user rights policy
  Windows 2000 (server) 44
  Windows 2000 Server 45
  Windows XP (local) 28
workstation 69
users, creating and managing
  Windows XP 30
valves 133
vessel volume 127
view menu 121
wavelength range 133
Windows profile
  Windows XP 31
Windows user groups
  Windows XP 24
  Windows XP 9
In This Book

This book describes the Agilent ChemStation Security Pack for UV-visible spectroscopy. The Security Pack is an add-on module for the Agilent ChemStation and helps you meet the requirements of the U.S. Food and Drug Administration's (FDA) ruling on electronic records and signatures, CFR 21 Part 11.