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1 Preparation of RapidFire data for MassHunter 
quantitative analysis
This section describes how to prepare RapidFire data for analysis by 
MassHunter. It contains the following topics:
About analyzing RapidFire data 2
About data analysis with MassHunter quantitative analysis 2
To convert data for use with MassHunter quantitative analysis 3
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1 Preparation of RapidFire data for MassHunter quantitative analysis
About analyzing RapidFire data
About analyzing RapidFire data

RapidFire data can be acquired from triple-quadrapole (TQ) or time-of-flight 
(TOF/Q-TOF) LC/MS instruments controlled by the Agilent MassHunter Data 
Acquisition program.

After data acquisition is completed (see the RapidFire 400 System User Guide), 
you can process the data using RapidFire Integrator as described in this guide.
• The Agilent RapidFire Integrator data analysis program can be used to 

integrate all of the data points collected in a single RapidFire run.
• Each sequence of a RapidFire batch is processed individually. There is no limit 

on the number of plates.

RapidFire data can also be processed using MassHunter Workstation 
Quantitative Analysis. For more information see:
• “About data analysis with MassHunter quantitative analysis” below, and
• Agilent MassHunter Workstation Quantitative Analysis Familiarization Guide.

About data analysis with MassHunter quantitative 
analysis

During the RapidFire-MassHunter data acquisition, data files (.D) are generated 
for each sequence.

The total ion chromatogram (TIC) can be viewed in real time in MassHunter Data 
Acquisition, and can be inspected further in MassHunter Qualitative Analysis.

After a run is completed, the original data files (long sequenceX.d files that are 
generated by MassHunter Data Acquisition and RFDataBase.xml files that are 
generated by RapidFire software) must be split into individual injection files for 
the standard data analysis by MassHunter Quantitative Analysis program.
2 Agilent RapidFire Data Analysis Guide



1 Preparation of RapidFire data for MassHunter quantitative analysis
To convert data for use with MassHunter quantitative analysis
To convert data for use with MassHunter quantitative 
analysis

To convert data:
1 In the RapidFire software window, click File > Convert MS Data.

2 In the Convert MS Data dialog box:
a Select the whole-experiment data directory (Data Path) you want to 

convert.
b Select where to save the resulting single-injection data files (Save To).

The data path of the latest run is displayed as a default selection.
c If needed, select options to indicate what you do not want to be converted.
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1 Preparation of RapidFire data for MassHunter quantitative analysis
To convert data for use with MassHunter quantitative analysis
d Select Convert automatically if you want data to be converted 
automatically.

While this option is selected and the dialog box opened, data is 
automatically converted. Data Path and Save To are automatically 
populated with the data folder that contains data most recently imported 
or generated by a run. Conversion begins on the data in that directory 
immediately. When you clear the check box, the automatic conversion in 
progress is canceled, and Data Path and Save To are no longer 
automatically populated.

e Click Convert.
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1 Preparation of RapidFire data for MassHunter quantitative analysis
To convert data for use with MassHunter quantitative analysis
3 View the list of converted files as shown in the following example. The 
single-peak data files are automatically named InjXXXXX-barcode-well.d, 
where:
• XXXXX is the injection order in the RapidFire batch.
• barcode is the plate name.
• well is the plate position of the sample on the RapidFire plate map.

4 Proceed with viewing and processing the single-injection data files, as 
described in the MassHunter Quantitative Analysis online Help and User 
Guide.
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2 Data analysis using RapidFire Integrator
This section describes how RapidFire 400 data is stored, prepared, and analyzed 
by RapidFire Integrator software.

Location, format, and preparation of data for RapidFire Integrator 8
Location of data 8
Data files 9
Exact mass plate map 11

Loading RapidFire TQ LC/MS data in RapidFire Integrator 12
To prepare MassHunter data 12
To open RapidFire TQ LC/MS data 13

Loading RapidFire TOF or Q-TOF LC/MS data in RapidFire Integrator 14
To open RapidFire TOF or Q-TOF LC/MS data 14

Analyzing Data in RapidFire Integrator 17
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2 Data analysis using RapidFire Integrator
Location, format, and preparation of data for RapidFire Integrator
Location, format, and preparation of data for 
RapidFire Integrator

Location of data

RapidFire data is stored in the folder D:\MassHunter\Data\RapidFire on the MS 
controlling computer.
• A new data folder is created each day with the date as the folder name.
• A new folder is created when a new experiment (in Plates mode) or a new 

batch (in Sequences mode) is started in RapidFire Acquisition program.

Example The first run performed on April 5, 2021 is saved in the following folder on the 
computer running the MS:

D:\MassHunter\Data\RapidFire\2021\April\5\1

NOTE
The data file folders that are created by the MS computer settings may be 
different than the scheme described above. Refer to the BASE_DATA_DIR 
variable in RFMassHunterS.cfg on your MS computer, which is located in 
C:\Agilent\RapidFire Communicator\cfgs.
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2 Data analysis using RapidFire Integrator
Data files
Data files

A data set for analysis with the RapidFire Integrator program includes the 
following types of files. 

NOTE
The following files must be present in the same folder.

• batch.rftime
• sequenceX.d mass spectrometer (MS) data files
• platemap.tofmap.txt tab-delimited text file (for TOF or Q-TOF LC/MS)

The original platemap.tofmap.txt file is empty. Change it as described on 
page 11.

The following example data folder for a RapidFire Q-TOF system shows the three 
required file types:

If the data is acquired within a single experiment in Plates mode, then multiple 
96-well or 384-well plates are analyzed within a single folder.
Agilent RapidFire Data Analysis Guide 9



2 Data analysis using RapidFire Integrator
Data files
The following columns of data are saved in the batch.rftime text file:
• Plate identity
• Injection number
• Sequence number
• Row
• Column
• Sip Time

The Sip Time is the time stamp for the actuation of valve 2 from inject to load 
position, as well as the start of elution to MS.
• Sip sensor value

The displayed value is 1 if the optical sip sensor detected the presence of liquid, 
or 0 if it did not.

Example

NOTE
• The aqueous and organic wash stations, WASH1 and WASH2, have (row, 

column) addresses of (2001, 2) and (2001, 3), respectively.
• The matrix vials MAT1, MAT2, MAT3, and MAT4 hve (row, column) addresses 

of (1001, 2), (1001, 3), (1001, 4), and (1001, 5), respectively.
• If data were acquired in Plates mode, make sure to name or rename the MS 

data files to sequence1.d.
10 Agilent RapidFire Data Analysis Guide



2 Data analysis using RapidFire Integrator
Exact mass plate map
Exact mass plate map

For data that were acquired via RapidFire Q-TOF LC/MS in MS/MS mode, you do 
not need to modify the platemap.tofmap.txt file.

For RapidFire-TOF/Q-TOF experiments in MS mode, modify platemap.tofmap.txt 
to specify the exact masses of the compounds of interest for each well that was 
injected. RapidFire Integrator uses these values to extract the appropriate ion 
chromatograms from the TOF data of each well. For data that are acquired in MS 
mode, the columns of data in the platemap.tofmap.txt file are:
• Sequence number
• Row
• Column
• Exact mass 1 (or chemical formula 1)
• Exact mass 2 (or chemical formula 2), and so on

More columns can be appended as needed.

Example
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2 Data analysis using RapidFire Integrator
Loading RapidFire TQ LC/MS data in RapidFire Integrator
Loading RapidFire TQ LC/MS data in RapidFire 
Integrator

A run in Plates mode is defined as the data that are collected without setting up a 
batch. Unlike Sequences mode, data acquired in Plates mode are named and 
saved in folders possibly with different names and locations on the controlling 
computers. 

If the data are collected in Plates mode, then prepare the data as described in this 
section before you analyze it with RapidFire Integrator.

If the data are collected in Sequences mode, proceed with “To open RapidFire 
TQ LC/MS data” on page 13.

To prepare MassHunter data

Repeat this process for each RapidFire-MS run:
1 Rename the MS data files to sequence1.d.
2 Copy the following files to a unique folder, such as \data sequenceX\

• sequence1.d
• batch.rftime (from the RapidFire computer, see “Data files” on page 9).
12 Agilent RapidFire Data Analysis Guide



2 Data analysis using RapidFire Integrator
To open RapidFire TQ LC/MS data
To open RapidFire TQ LC/MS data

1 Start the Agilent RapidFire Integrator program by double-clicking the desktop 
icon.

2 Click File > Load QQQ Data.

3 When the Browse for folder window appears:
a Select the folder that contains the .D and .RFTIME files.
b Click OK.

4 Continue with “Analyzing Data in RapidFire Integrator” on page 17.
Agilent RapidFire Data Analysis Guide 13



2 Data analysis using RapidFire Integrator
Loading RapidFire TOF or Q-TOF LC/MS data in RapidFire Integrator
Loading RapidFire TOF or Q-TOF LC/MS data in 
RapidFire Integrator

To open RapidFire TOF or Q-TOF LC/MS data

1 Start the Agilent RapidFire Integrator program by double-clicking the desktop 
icon.

2 Click File > Load TOF-QTOF Data.

3 When the Browse For Folder window appears:
a Select the folder that contains the .D, .RFTIME and 

platemap.TOFMAP.TXT files.
b Click OK.

4 Click Data > Extract TOF_QTOF XICS.
5 For data that were acquired with a TOF or Q-TOF LC/MS in MS mode:

a Set the following parameters in the TOF Options dialog box:
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2 Data analysis using RapidFire Integrator
To open RapidFire TOF or Q-TOF LC/MS data
• Display Time Range (set to all by default)
• Polarity
• Error (ppm), which determines the accuracy
• Internal Standard

If Use Internal Standard is selected, enter the mass of the internal 
standard. To extract multiple internal standards in every well of the 
RapidFire-TOF run, use a comma to separate each mass.

b Click OK to close the dialog box.
6 For data that were acquired with a Q-TOF LC/MS in MS/MS mode:

a Click Add in the QTOF Options dialog box.
b In the Add Product dialog box:
• Select Sequence and Precursor Ion.
• Type the mass or chemical formula of one Product Ion of interest and the 

Error (ppm).
• Click OK.
c Repeat for all Precursor Ions and all Product Ions of interest.
Agilent RapidFire Data Analysis Guide 15



2 Data analysis using RapidFire Integrator
To open RapidFire TOF or Q-TOF LC/MS data
d When you are finished, click OK to close the QTOF Options dialog box.
7 Select Minutes for the MS data files time units and click OK.
16 Agilent RapidFire Data Analysis Guide



2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
Analyzing Data in RapidFire Integrator

To analyze the data in RapidFire Integrator:
1 Click the sequence of interest in the left pane (1), as shown for Sequence 1 in 

the following example.

2 Review the data using the following features:
• To display the list of m/z, click the + sign next to the sequence (2).
• To display the following menu options, right-click in the left pane (2).

• Select the number of graphs to display in the upper-right area of the 
window (3).

• To select an area of graph to expand, drag the mouse. Repeat to expand 
the area further.

To zoom out each successive level, right-click on the graph and select 
Un-zoom. (1)
Agilent RapidFire Data Analysis Guide 17



2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
3 Integrate the peaks as follows:
a Zoom in on a known landmark peak within the sequence.
• Any peak within the experiment can be selected as a landmark.
• Data analyses can be based on any mass.
• The title of the plot identifies monitored analytes by their m/z.

To navigate from one m/z to another, use the scroll bar on the right side of 
the window.

b Select the identity of the peak from the Sample list (1).
18 Agilent RapidFire Data Analysis Guide



2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
c Define the peak to integrate for area-under-the-curve (AUC) calculations in 
either of the following ways:

• Drag the mouse in a thin slab rectangle from the front edge of the peak to 
its tail end.

• Use the keyboard to type in the T1 and T2 times (1).

The defined time range is displayed in the T1 and T2 boxes above the 
graph. The peak area is also emphasized by teal coloring as shown in the 
following example (2).
Agilent RapidFire Data Analysis Guide 19



2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
d To process the data for the current sequence, click the summation button.

All masses within the same sequence are processed together. AUCs of 
injections turn blue, but background signals remain red.

e Repeat step a through step d for each sequence of the run.

4 To save partial progress in data analysis before all of the sequences of the run 
are analyzed, click File > Save As and enter a name for the file.

The results are saved in the specified .RFD file.
5 Click File > Open to reopen experiment files that have been partially 

processed.
6 To export data that were acquired with a triple-quad LC/MS, click File > Export 

Peak Data List.

An .rfpks text file is created, which contains a list of injections.

You can analyze this file with a spreadsheet program. The following is an 
example file opened in Microsoft Excel.
20 Agilent RapidFire Data Analysis Guide



2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
7 To export data that were acquired with a TOF or Q-TOF LC/MS in MS mode, 
click File > Export Peak Data TOF.

An .rfpks text file is created, which contains a list of injections.

Only the masses of interest are reported for each well.

You can further analyze the results with a spreadsheet program. The following 
is an example file opened in Microsoft Excel.
Agilent RapidFire Data Analysis Guide 21



2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
8 To export data that were acquired with a Q-TOF LC/MS in MS/MS mode, click 
File > Export Peak Data List.

An .rfpks text file is created, which contains a list of injections.

Only the precursor Ion : product ion pairs of interest are reported for each 
sequence.

You can further analyze the results using a spreadsheet program. The 
following is an example file opened in Microsoft Excel.

9 To export RapidFire TQ LC/MS data by plates, click File > Export Peak Data 
Plate-wise.

NOTE
• Data for MAT# and WASH# injections are not displayed.
• This option is only offered if each sample well within a plate is visited only 

once.
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2 Data analysis using RapidFire Integrator
Analyzing Data in RapidFire Integrator
You can analyze this file with a spreadsheet program, such as Microsoft 
Excel. An example is shown below.

10 To export RapidFire TOF/Q-TOF data acquired in MS mode, click File > Export 
Peak Data TOF.

An .rfpks text file is created, which contains a list of injections.

Only the masses of interest are reported for each well.

You can further analyze the results using a spreadsheet program, such as 
Microsoft Excel. An example is shown below.
Agilent RapidFire Data Analysis Guide 23
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