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Preface 
This preface contains the following topics:
• “About this guide” on page vi
• “Accessing user guides” on page viii



Preface
About this guide

vi BioTek Liquid Handler Device Driver Guide

About this guide

Who should read this guide

This user guide is for people with the following job roles:

 

What this guide covers

This guide describes how to set up BioTek microplate washers and dispensers in the 
VWorks software. The VWorks software supports the following models of BioTek 
liquid handling devices:
• EL406 Washer Dispenser 
• MultiFlo FX Multi-Mode Dispenser
• ELx405DW - Elx405 Select Deep Well Washer
• 405 TS/LS Washer

What is new in this edition

This edition contains updates to the device and profile descriptions and procedures to 
reflect changes introduced in VWorks software 14.1.

Software version

This guide is applicable for the following versions of VWorks software and BioTek 
Liquid Handler Diagnostics:
• 13.1.7 — 13.1.x
• 14.1.0 and later
The VWorks software runs on Microsoft Windows 10 64-bit operating system.
The VWorks BioTek Liquid Handler Device is compatible with BioTek Liquid Handling 
Control (LHC) software version 2.22 or later versions.
                                                        

Job role Responsibilities

Installer Unpacks, installs, and tests the device before it is used.

Integrator Configures hardware and writes software.

Lab manager, 
administrator, or 
technician

• Manages the automation system that contains the device
• Develops the applications that are run on the system
• Develops training materials and standard operating 

procedures for operators

Operator Performs the daily production work on the device and solves 
routine problems.
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Related guides

Use this guide in conjunction with the relevant BioTek user documentation and the 
following guides:
• VWorks Automation Control Setup Guide. Explains how to define labware and 

labware classes, liquid classes, and pipetting techniques, and how to track and 
manage labware in storage.

• VWorks Automation Control User Guide. Explains how to create protocols, and set 
task parameters for each device in the system.

Related topics

For information about... See...

Accessing the Agilent automation product 
user guides

“Accessing user guides” on page viii

BioTek user documentation https://btresource.force.com/CRC/s/

Setting up a BioTek Liquid Handler device “Setup workflow” on page 2

https://btresource.force.com/CRC/s/


Preface
Accessing user guides

viii BioTek Liquid Handler Device Driver Guide

Accessing user guides

About this topic

This topic describes the different formats of user information and explains how to 
access it for the Agilent Automation Solutions products.

Where to find user information

The user information is available in the following locations:
• Knowledge base. The help system for the Automation Solutions products is 

available from:
– Help menu within the VWorks software: Select Help > Knowledge Base or press 

F1.

– From the Windows desktop: Select Start ( ) > All Apps > Agilent 
Technologies > VWorks Knowledge Base.

For guidelines on using the VWorks context-sensitive help and knowledge base 
features, see Using the knowledge base, below.

• PDF files. The PDF files of the user guides are installed with the VWorks software 
(C:\Program Files (x86)\Agilent Technologies\VWorks\UserGuides) and are 
available in the VWorks Knowledge Base.

• Website. You can search the online VWorks Knowledge Base or download the latest 
version of any PDF file from the Agilent website at www.agilent.com/chem/askb. 

Accessing safety information

Safety information for the Agilent Automation Solutions devices appears in the 
Automation Solutions Products General Safety Guide and in the corresponding device 
safety guide or user guide.
You can also search the knowledge base or the PDF files for safety information.

Using the knowledge base

Knowledge base topics are displayed using web browser software such as Microsoft 
Edge.
Note: If you want to use Microsoft Internet Explorer to display the topics, you might 
have to allow local files to run active content (scripts and ActiveX controls). For 
instructions, see the Microsoft user documentation.

https://www.agilent.com/chem/askb
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Opening the help topic for an area in the VWorks window

To access the context-sensitive help feature:

1 In the main window of the VWorks software, click the help button . The pointer 

changes to . Notice that the different icons or areas are highlighted as you 
move the pointer over them.

2 Click an icon or area of interest. The relevant topic or document opens. 
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Features in the Knowledge Base window

 

Step For this task...

1 Contents pane. Lists all the books and the table of contents of the books.

2 Search. Allows you to search the Knowledge Base (all products or selected products) using 
keywords.

3 Topic area. Displays the selected online help topic.

4 Navigation buttons. Enable you to navigate through the next or previous topics listed in the Contents 
tab.

5 Toolbar buttons: Enable you to:
• Expand or collapse all the sections in a topic that has drop-down headings.
• Print the topic.
• Send feedback by email for a given topic.
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Setting up a BioTek Liquid Handler 
device
This chapter describes how to set up a BioTek Liquid Handler device in the VWorks 
software. 
You must have VWorks administrator or technician privileges to set up devices in 
the VWorks software. 
The topics in this chapter are:
• “Setup workflow” on page 2
• “Configuring a BioTek Liquid Handler XmlRpc Server” on page 3
• “Adding a VWorks BioTek Liquid Handler device” on page 5
• “Creating a profile” on page 10
• “Testing a BioTek Liquid Handler” on page 13
• “Run BioTek Liquid Handler task” on page 16
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Setup workflow

You must have VWorks administrator or technician privileges to set up devices in the 
VWorks software. 
The following table presents the workflow for setting up a BioTek Liquid Handler device.

Related topics

Step For this task... See...

1 Ensure that the BioTek Liquid 
Handling Control (LHC) software 
is installed on the computer that 
you are using to control the 
BioTek liquid-handling 
instrument.

BioTek documentation for the device

2 Turn on the BioTek instrument. User documentation for the BioTek 
device

3 Configure the BioTek Liquid 
Handler XmlRpc Server for your 
instrument.

“Configuring a BioTek Liquid Handler 
XmlRpc Server” on page 3

4 Add a BioTek Liquid Handler 
device to the VWorks device file 
and set the device properties.

“Adding a VWorks BioTek Liquid 
Handler device” on page 5

5 Create a device profile and set 
the profile properties.

“Creating a profile” on page 10

6 Verify the device control. “Testing a BioTek Liquid Handler” on 
page 13

7 Create a VWorks protocol. VWorks Automation Control User Guide

8 Add the BioTek Liquid Handler 
task to the VWorks protocol and 
set the task properties for the 
device.

“Run BioTek Liquid Handler task” on 
page 16

For more information about… See…

BioTek user documentation  https://btresource.force.com/CRC/s/

Using JavaScript to set task 
parameters

VWorks Automation Control User Guide
See “Accessing user guides” on page viii.

https://btresource.force.com/CRC/s/
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Configuring a BioTek Liquid Handler XmlRpc Server

About this topic

This topic describes how to configure a BioTek Liquid Handler XmlRpc Server, which is 
required to control a BioTek Liquid Handler.
A BioTekLiquidHandlerXmlRpcServer.exe is required for each instrument of a given 
type that you want to control, for example, BioTekLiquidHandlerXmlRpcServer1.exe, 
BioTekLiquidHandlerXmlRpcServer2.exe, BioTekEL406.exe, and so forth. 
Note: You will need to make a copy of the BioTekLiquidHandlerXmlRpcServer.exe file 
for each instance of an instrument that you want to control.

Before you start 

Ensure that you have the installed the BioTek Liquid Handling Control software 
version 2.22 or later version on the computer that will be used to control the 
instrument.

Procedure

To install the server:
1 Copy the following files from the following servers folder:

C:\Program Files (x86)\Agilent 
Technologies\VWorks\XmlRpcServers\BioTekLiquidHandler\ 
• BioTekLiquidHandlerXmlRpcServer.exe
• BTILHCRunnerWrapper.dll
Paste the copied files in the BioTek LHC installation folder. By default, the 
installation folder is C:\Program Files (x86)\BioTek\Liquid Handling Control 2.22\. 
Your installation folder might be different depending on the version of the Liquid 
Handling Control software.

2 Open a Command Prompt window (Run as Administrator) as follows:
a In the C:\Windows\System32 folder, right-click cmd.exe, and then select 

Run as administrator.
b Click Yes in the User Account Control dialog box that opens.
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c Execute the following two lines in the Command Prompt window:
cd C:\Program Files (x86)\BioTek\Liquid Handling 
Control 2.22\ <enter>
Note: Your software installation folder might be different.
C:\Windows\Microsoft.NET\Framework\v4.0.30319\regasm /
codebase /tlb BTILHCRunnerWrapper.dll <enter>

3 In Windows, create a shortcut on the Desktop for each XmlRpc Server (each 
instrument) that you configure.

4 Use the shortcut to start the XmlRpc Server.

Related topics

For more information about… See…

BioTek user documentation https://btresource.force.com/CRC/s/

Adding a BioTek Liquid Handler to a 
VWorks device file

“Adding a VWorks BioTek Liquid Handler 
device” on page 5

Creating a VWorks device profile for 
BioTek liquid handlers

“Creating a profile” on page 10

Testing the device in diagnostics “Testing a BioTek Liquid Handler” on 
page 13

Create a VWorks protocol. VWorks Automation Control User Guide

https://btresource.force.com/CRC/s/
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Adding a VWorks BioTek Liquid Handler device 

About this topic

This topic describes how to add the BioTek Liquid Handler device ( ) 
in the VWorks software and set the device properties. 
The device properties provides the VWorks software with information about the 
device’s current configuration. The device properties settings are stored in the device 
file. The VWorks software uses the information in a device file to communicate with 
and operate the device. You must have VWorks administrator privileges to create and 
edit device files.
For detailed information about device files and associations with profiles, teachpoints, 
and labware definitions, see the VWorks Automation Control User Guide.

Devices and device files defined

A device is an item in your lab automation system that has an entry in a VWorks 
software device file. A device can be a robot, an instrument, or a location in a lab 
automation system that can hold a piece of labware.
The device file (*.dev) stores information for all the devices in an integrated system, 
including:
• Type of device 
• Device configuration information (for example, approach height, allowed or 

prohibited labware, and so on)
• Profile to use

Creating a device file

If you are setting up a new workstation configuration, you need to create a VWorks 
device file. 
To add a new device to an existing device file, see “Adding the BioTek device to a device 
file” on page 6.

To create a device file:
1 Log in to the VWorks software as an Administrator.
2 In the VWorks window, choose File > New > Device. A Device File tab appears in the 

VWorks window.



Setting up a BioTek Liquid Handler device
Adding a VWorks BioTek Liquid Handler device

6 BioTek Liquid Handler Device Driver Guide

3 Click File > Save. 
4 In the Save As or Save File As dialog box, select the storage location, type the file 

name, and then click Save. 

Adding the BioTek device to a device file

Before you start:
• Ensure that any devices are physically networked to the computer.
• Turn on the devices.
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To add devices to a device file:
1 In the VWorks window, verify that the correct device file is open.
2 In the Available Devices area, double-click the BioTek Liquid Handler icon. 

Alternatively, you can drag the icon to the Device File tab.
Note: To show or hide the list of available devices, choose View > Available 
Devices.

3 In the Device File tab, select the BioTek Liquid Handler-n icon.
4 Under BioTek Liquid Handler Properties, type a Name for the device. By default, the 

software assigns BioTek Liquid Handler-n, and increments the number for each 
device that you add.
To identify the specific device, you might want to include the device serial number 
in the name.

5 In the Profile list, select a profile for the device.
If the Profile list is empty:
a Create a profile. For instructions, see “Creating a profile” on page 10.
b Return to this step to select the new profile.
A profile is required to establish communication with the device.
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6 On the Device File tab, expand the BioTek Liquid Handler device icon, and then click 
the Location icon. The corresponding location properties appear. 

7 Set the following properties.

8 Click File > Save to save the changes.

Property Description
 
Allowed/prohibited 
labware

Optional. Click  if you want to specify labware 
restrictions for this location. The Allowed/prohibited 
labware dialog box appears. For details on the labware 
classes, see the VWorks Automation Control Setup 
Guide.

Note: If the  button is not visible, click the empty 
field. 

BCR on south/west/
north/east side

The location of the barcode reader and the desired 
barcode reader device.
Use this field only if a barcode reader is installed on the 
device.

Use for deadlock 
avoidance

Option to permit the location to be used for deadlock 
avoidance.
Select Yes (default) to permit labware to be moved to 
this location to avoid a deadlock in the system.
Select No if you do not want to move random labware 
to this location to avoid a deadlock.

Door This property is not applicable for the BioTek Liquid 
Handler device.
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If you are creating a new device file, the Save As or Save File As dialog box appears 
so that you can specify a name and location for your device file. Ensure the file type 
is *.dev.
Alternatively, you can select File > Save All to save the device file and the current 
protocol file at the same time.

Related topics

For more information about… See…

Creating a VWorks device profile for 
BioTek liquid handlers

“Creating a profile” on page 10

Testing the device in diagnostics “Testing a BioTek Liquid Handler” on 
page 13

Create a VWorks protocol. VWorks Automation Control User Guide

Configuring the BioTek Liquid Handler 
task in a VWorks protocol

“Run BioTek Liquid Handler task” on page 16
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Creating a profile

Before you start

The profile is referenced by a VWorks device file. The device file must be open before 
you can create or modify a profile.

Procedure

To create a new profile:
1 In the VWorks software window, ensure the correct device file is open. 
2 In the Devices area of the opened device file tab, highlight the device icon, and then 

click Device diagnostics. 

The BioTek Liquid Handler Diagnostics dialog box opens. This dialog box is the same in 
VWorks 14.1 and 13.1.x, except that the 13.1.x versions do not include the log areas at 
the bottom of the window. The following figure shows the dialog box for VWorks 14.1.
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Figure BioTek Liquid Handler Diagnostics v14.1

VWorks 14.1 only. A log of profile activity appears in the box at the bottom of the 
window. The VWorks software records these events and stores the information in 
the Main log.

3 In the Profiles tab, click Create a new profile. The Create Profile dialog box opens.
4 Type a name, and click OK. The name appears in the Profile Management area.
5 In the Profile Settings area, set the following parameters:

Profile parameter Description
Server IP The IP address of the computer on which the VWorks 

BioTek LiquidHandler XmlRpc Server will be running.
Typically, this is the IP address of the local computer, in 
which case you can use the local host address: 
127.0.0.1

Server port (1-65535) The “listening” port of the BioTek LiquidHandler 
XmlRpc Server. 
Typically, you use the default setting of 6000. You may 
need to change the default port if 6000 is already in 
use.
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6 Click Update this profile to save the changes.
VWorks 14.1 only. In the Diagnostics dialog box, the Modified Variables area clears, 
and the update is logged in the box at the bottom of the window.

7 Click Initialize this profile to establish communication with the device.

Related topics

Serial port The COM port on the computer to which this BioTek 
device is connected.
Note: The Serial Port parameter will be automatically 
defined when a USB-to-serial adapter is connected to 
the computer. You might need to lookup the port 
assigned to this device in the Windows Device 
Manager. Occasionally, a port number is reassigned for 
a USB-to-serial connection if you disconnect and 
reconnect the device. If this happens, you must verify 
that the correct Serial Port is set in each profile.

Product type The model of this BioTek instrument.
Select the product type from the list.

LHC Protocol folder The folder that contains the protocols for this BioTek 
liquid-handling device.

Profile parameter Description

For more information about… See…

BioTek user documentation https://btresource.force.com/CRC/s/

Installing a BioTek Liquid Handler 
XmlRpc Server

“Configuring a BioTek Liquid Handler 
XmlRpc Server” on page 3

Creating a VWorks device file that 
includes the BioTek Liquid Handler 
device

“Adding a VWorks BioTek Liquid Handler 
device” on page 5

Testing the device in diagnostics “Testing a BioTek Liquid Handler” on 
page 13

Create a VWorks protocol. VWorks Automation Control User Guide

Configuring the BioTek Liquid Handler 
task in a VWorks protocol

“Run BioTek Liquid Handler task” on page 16

https://btresource.force.com/CRC/s/
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Testing a BioTek Liquid Handler

About this topic

This topic describes how to use Diagnostics to test a BioTek Liquid Handler.

Before you start

Ensure the following:
• The BioTek instrument is turned on.
• The BioTek Liquid Handling Control software is running.
• You have a BioTek protocol to reference for the BioTek device that you are testing.
• You have labware that is suitable for the protocol file to be run.
Note: For more information on your BioTek instrument and software, refer to the 
BioTek user documentation for the specific instrument. 

Using Diagnostics to test a BioTek Liquid Handler

To test a BioTek Liquid Handler:
1 Place an appropriate labware on the instrument plate stage. 
2 Open BioTek Liquid Handler Diagnostics.

In the Devices area of the opened device file tab, highlight the device icon, and then 
click Device diagnostics.

3 In the BioTek Liquid Handler Diagnostics window, select the correct Profile name, 
and then click Initialize this profile.
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4 Click the Controls tab, and ensure that the Status readout displays IDLE.

5 In the Run Protocol area, select the Protocol to Run. 
The protocols are located in the folder specified in the Profiles tab. 

6 In the Timeout (s) box, specify the maximum duration (seconds) of the protocol run 
on this BioTek device.
Note: VWorks displays an error message if the run duration exceeds the 
specified timeout.
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7 Click Run Protocol. The Status readout displays RUNNING PROTOCOL.

After the run completes, the Status readout displays IDLE.

Aborting a run in progress

To abort a run in progress in diagnostics:
In the Controls tab, click Abort. The Status readout displays IDLE.

Related topics

For more information about… See…

BioTek user documentation https://btresource.force.com/CRC/s/

Installing a BioTek Liquid Handler 
XmlRpc Server

“Configuring a BioTek Liquid Handler 
XmlRpc Server” on page 3

Creating a VWorks device file that 
includes the BioTek Liquid Handler 
device

“Adding a VWorks BioTek Liquid Handler 
device” on page 5

Creating a VWorks device profile for 
BioTek liquid handlers

“Creating a profile” on page 10

Create a VWorks protocol. VWorks Automation Control User Guide

Configuring the BioTek Liquid Handler 
task in a VWorks protocol

“Run BioTek Liquid Handler task” on page 16

https://btresource.force.com/CRC/s/
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Run BioTek Liquid Handler task 

About this topic

This topic describes how to specify the parameters for the Run BioTek Liquid Handler 

task ( ). 

For details on how to create a VWorks protocol that includes this task, see the VWorks 
Automation Control User Guide.

Run BioTek Liquid Handler task defined

The Run BioTek Liquid Handler task runs the specified BioTek liquid-handler protocol on 
a BioTek liquid-handling device.

Setting task parameters

To set the Run BioTek Liquid Handler task parameters:
1 Add a Run BioTek Liquid Handler task to a protocol.
2 Select the task icon in the protocol, and then set the following task parameters.

Parameter Description
Protocol File The BioTek liquid-handler protocol that you want to 

run.
Timeout (5–36000 s) The maximum duration (seconds) of the protocol 

run on this BioTek device.
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3 Click File > Save.

Related topics

For more information about… See…

BioTek user documentation https://btresource.force.com/CRC/s/

Installing a BioTek Liquid Handler 
XmlRpc Server

“Configuring a BioTek Liquid Handler 
XmlRpc Server” on page 3

Setting up the device in the VWorks 
software

“Setup workflow” on page 2

Creating a VWorks device profile for 
BioTek liquid handlers

“Creating a profile” on page 10

Testing the device in diagnostics “Testing a BioTek Liquid Handler” on 
page 13

https://btresource.force.com/CRC/s/
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In This Guide
This guide describes how to configure the 
VWorks software to control a BioTek Liquid 
Handler. 
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