Agilent OpenLab CDS Workstation

Installation and Configuration
Notices

Manual Part Number
M8413-90002 Rev. C
EDITION 02/2019

Copyright
© Agilent Technologies, Inc. 2016-2019
No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.
Agilent Technologies
Hewlett-Packard-Strasse 8
76337 Waldbronn

Software Revision
This guide is valid for revision 2.4 of Agilent OpenLab CDS.

Warranty
The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses
The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend
U.S. Government Restricted Rights. Software and technical data rights granted to the federal government include only those rights customarily provided to end user customers. Agilent provides this customary commercial license in Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212 (Computer Software) and, for the Department of Defense, DFARS 252.227-7015 (Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial Computer Software or Computer Software Documentation).

Safety Notices

CAUTION
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING
A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

OpenLab CDS Workstation Installation and Configuration
In this Guide ...

This document provides instructions for installation, configuration, administration, and maintenance of an OpenLab CDS Workstation. It includes information on the license generation with SubscribeNet and operating system configuration.

Table 1  Terms and abbreviations used in this document

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Panel</td>
<td>Control Panel for Agilent OpenLab software</td>
</tr>
<tr>
<td>Microsoft Control Panel</td>
<td>Part of the Microsoft Windows operating system</td>
</tr>
<tr>
<td>Shared Services</td>
<td>Set of administrative services that control, for example, the security policy and the central configuration of OpenLab CDS. Shared services are accessed via the Control Panel.</td>
</tr>
</tbody>
</table>

1 **Introduction**
This chapter describes the installation workflow and the preparatory steps.

2 **Set Up the Windows Operating System**
This chapter describes the operating system configuration.

3 **Install OpenLab CDS Workstation**
This chapter describes the installation of the software.

4 **Post Installation Tasks**
This chapter describes tasks that are relevant after finishing the installation.

5 **Licensing**
This chapter provides basic information on OpenLab licensing. It describes how you generate a license file with SubscribeNet and install the license in the Control Panel.
6 Configure OpenLab CDS Workstation
This chapter describes the initial configuration steps after installing the OpenLab CDS software. All configuration tasks are performed in the Control Panel. For more details, refer to the Control Panel section in OpenLab Help & Learning.

7 Optional Procedures
This chapter describes the installation or upgrade of additional software. It also contains information on the installation of OpenLab Help and Learning only, and on performance improvement on offline machines.

8 About the OpenLab CDS Software
This chapter contains an overview of the software architecture and customization options.

9 System Setup and Maintenance
This chapter contains information on the Control Panel and Shared Services Maintenance. In addition, it describes various maintenance procedures.

10 Upgrade OpenLab CDS
This chapter describes the upgrade from OpenLab CDS 2.0 or higher to the current version of OpenLab CDS.

11 Uninstall OpenLab CDS With All of its Components
This chapter describes the uninstallation of the software.

12 Repair the Software
This chapter contains information on repairing your OpenLab CDS system using the OpenLab Installer.
Contents

1 Introduction  7
   Installation Workflow Overview  8
   Before you Begin  9

2 Set Up the Windows Operating System  10
   Configure Windows 10  11
   Configure Windows 7  16

3 Install OpenLab CDS Workstation  21
   Run the OpenLab Installer  22
   Silent Installation  33
   Install or Upgrade Driver Software  36

4 Post Installation Tasks  38
   Create Account to Access Network Share  39
   Configure the Antivirus Program  42
   Configure Internet Explorer for OpenLab Help and Learning  44
   Local Windows Group for Secure Projects Root Folder  45
   Disable Windows 10 Updates  46

5 Licensing  47
   About OpenLab CDS Licensing  48
   Get a License  50
   Install Your License  54

6 Configure OpenLab CDS Workstation  55
   Configure Authentication  56
   Configure Security Policy  57
   Configure users, roles, and privileges  58
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure the Storage Location</td>
<td>62</td>
</tr>
<tr>
<td>Enable File System Security</td>
<td>63</td>
</tr>
<tr>
<td>Configure Initial Project</td>
<td>63</td>
</tr>
<tr>
<td>Configure Initial Instrument</td>
<td>64</td>
</tr>
<tr>
<td>Other settings in the Control Panel</td>
<td>64</td>
</tr>
<tr>
<td>7 Optional Procedures</td>
<td>65</td>
</tr>
<tr>
<td>Install OpenLab Help and Learning Only</td>
<td>66</td>
</tr>
<tr>
<td>Improve Performance on Offline Machines</td>
<td>67</td>
</tr>
<tr>
<td>Install or Uninstall Add-ons</td>
<td>68</td>
</tr>
<tr>
<td>8 About the OpenLab CDS Software</td>
<td>69</td>
</tr>
<tr>
<td>Software Architecture</td>
<td>70</td>
</tr>
<tr>
<td>Customization</td>
<td>73</td>
</tr>
<tr>
<td>9 System Setup and Maintenance</td>
<td>75</td>
</tr>
<tr>
<td>Control Panel</td>
<td>76</td>
</tr>
<tr>
<td>Shared Services Maintenance</td>
<td>81</td>
</tr>
<tr>
<td>Maintenance Procedures</td>
<td>83</td>
</tr>
<tr>
<td>10 Upgrade OpenLab CDS</td>
<td>99</td>
</tr>
<tr>
<td>License Upgrade</td>
<td>100</td>
</tr>
<tr>
<td>Upgrade OpenLab CDS Workstation to Latest Version</td>
<td>102</td>
</tr>
<tr>
<td>11 Uninstall OpenLab CDS With All of its Components</td>
<td>103</td>
</tr>
<tr>
<td>Uninstall OpenLab CDS</td>
<td>104</td>
</tr>
<tr>
<td>Uninstall OpenLab Help and Learning Only</td>
<td>105</td>
</tr>
<tr>
<td>12 Repair the Software</td>
<td>110</td>
</tr>
<tr>
<td>13 Appendix</td>
<td>114</td>
</tr>
<tr>
<td>Privileges in the Control Panel</td>
<td>115</td>
</tr>
<tr>
<td>Migration guides</td>
<td>123</td>
</tr>
<tr>
<td>Sales and Support Assistance</td>
<td>123</td>
</tr>
</tbody>
</table>
1 Introduction

Installation Workflow Overview  8
Before you Begin  9

This chapter describes the installation workflow and the preparatory steps.
Introduction
Installation Workflow Overview

Installation Workflow Overview

Prepare
• Check OpenLab CDS Requirements
  Guide for details
• Set Up Windows
• Run System Configuration Checker
  from the OpenLab CDS Installer
to ensure that all requirements are met

Install
1. Run Installation wizard,
   incl. software verification
2. Post Installation:
   Set Account to Enable Automatic Printing
3. Optional:
   Improve performance on offline machines

Get Licenses
1. Obtain licenses via SubscribeNet
2. Install your license

Configure
• Authentication
• Projects, incl. audit trail settings
• Instruments

See "Set Up the Windows Operating System" on page 10
If you plan scripted installations, see "Silent Installation" on page 33.

See "Install OpenLab CDS Workstation" on page 21
See "Post Installation Tasks" on page 38
See "Optional Procedures" on page 65

See "Licensing" on page 47

See "Configure OpenLab CDS Workstation" on page 55.
All configuration tasks are performed in the administrative and management center of OpenLab, the Control Panel.
For more details, refer to the Control Panel section in OpenLab Help & Learning.
1 Decide on a computer name. Do not use underscores. Installation is not possible if the computer name contains an underscore.

2 Install all required hardware, including any cables, instrument detectors, and communication cables. GPIB interfaces may be required for some non-Agilent instruments.

3 Run the **System Configuration Checker** from the OpenLab CDS Installer to make sure that the PC matches all requirements.

   For details, refer to the *OpenLab CDS Workstation Requirements and Supported Instruments Guide*.

4 Update Adobe Reader DC to the most recent version.

   The OpenLab CDS installation medium contains version 2018 of Adobe Reader DC. To benefit from the latest software improvements, especially related to the software stability, Adobe Reader 2018 must be updated to the most recent version (2018.x.x).

5 Switch off the Adobe Updater.

   a In Adobe Reader, click *Edit > Preferences*.

   b On the **Updater** page, select *Do not download or install updates automatically*.

   If you need to update Adobe Reader, update it manually when the machine is not busy.

6 If .NET 4.7.2 or higher is not installed on your system, its installation will automatically be triggered by the installation wizard. However, this may require a system reboot. To avoid the system reboot during installation, install .NET in advance.

7 Prepare an account with administrative privileges to run the installation.

8 If you use Trend Micro™ as an antivirus software, turn off **Web Reputation** to allow the installation of all components.

9 If you plan to upgrade from a previous version of OpenLab CDS please refer to "Upgrade OpenLab CDS" on page 99.
2 Set Up the Windows Operating System

Configure Windows 10  11
Configure Windows 7  16

This chapter describes the operating system configuration.
Set Up the Windows Operating System
Configure Windows 10

Configure Windows 10

The following descriptions apply to Windows 10 Build 1703. The settings for higher builds may differ slightly.

In the Microsoft Control Panel (View the items by icon to see a list of all items):

1. **System**: Under *Windows activation*, click **Change product key**. Enter a valid value to activate Windows.

2. **File Explorer Options**: In the *View* tab:
   - Select **Always show menus**.
   - Select **Display the full path in the title bar**.
   - Clear **Hide extensions for known file types**.
   - Clear **Use Sharing Wizard**.

3. **Indexing Options**: Disable indexing.
   - Click the **Modify** button. Select **Show all locations**, and clear all drives and locations.

4. **Power Options**:
   a. As preferred plan select **High performance**.
   b. Click **Change Plan settings**.
   c. Set the option **Put the computer to sleep** to **Never**.
   d. Click **Change advanced power settings**.
   e. Open the nodes for **Hard disk > Turn off hard disk after**.
   f. Set the Minutes to 0 (=Never).

5. **Administrative Tools**: Configure security options:
   a. Double-click **Local Security Policy**.
   b. Navigate to **Security Settings > Local Policies > Security Options**.
   c. Double-click the following policy listed in the right hand panel: **Network Access: Sharing and security model for local accounts**.
   d. In the displayed dialog select the following item from the drop-down list: **Classic - local users authenticate as themselves**.
Set Up the Windows Operating System

Configure Windows 10

[MUST] 6 Date and Time: Choose the time zone of your regional location.

[MUST] 7 Network and Sharing Center:
   b. On the Power Management tab, clear all check boxes.

[MUST] 8 Programs and Features:
   a. Click Turn Windows features on or off.
   b. Enable .NET 3.5 by selecting the .NET Framework 3.5 (includes .NET 2.0 and 3.0) check box.
      This option requires an internet connection.
   c. To make sure that all the net.tcp components are properly initialized, Non-HTTP activation must be enabled. Expand the .NET Framework 3.5 (includes .NET 2.0 and 3.0) node and select the Windows Communication Foundation Non-HTTP Activation check box.
   d. Select the .NET Framework 4.7 Advanced Services check box. Use the default values for sub items.
   e. Select the Internet Explorer 11 check box.
   f. Select the Telnet Client check box.
   g. Select the TFTP Client check box.
   h. Reboot the PC if necessary.

[PERFORMANCE] 9 System (Microsoft Control Panel): Change performance options:
   a. Click Advanced system settings.
   b. On the Advanced tab > Performance click Settings.
   c. On the Visual Effects tab, select Custom.
   d. Under Custom, select the following check boxes for better usability:
      • Smooth edges of screen fonts
      • Show shadows under mouse pointer
      • Show shadows under windows

NOTE If this procedure does not work as expected, or the computer has no internet access, install .NET 3.5 from the Windows installation media (see details for Windows 10 under https://support.microsoft.com/en-us/kb/2734782). If you do not have installation media, create them as described under https://www.microsoft.com/en-us/software-download/windows10.
2 Set Up the Windows Operating System
Configure Windows 10

e  On the Advanced tab, select Virtual Memory.
   For optimum performance use the Change button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible, locate the paging file on a drive different from the system installation drive.

f  On the Data Execution Prevention tab, select Turn on DEP for essential Windows programs and services only.

PERFORMANCE 10 System (Microsoft Control Panel): Change system properties.
   a  Click Advanced system settings.
   b  On the Advanced tab > Startup and Recovery, click Settings.
      In the System startup section: Change both Time to display ... fields from 30 to 3 sec.
      In the System failure section: Select Automatically restart.
      In the Write debugging information section: Select Kernel memory dump from the drop-down list
   c  On the System Protection tab, in the Protection Settings section:
      Make sure that Protection is turned off for all drives. If required, click Configure and select Disable system protection.
   d  On the Remote tab, in the Remote Assistance section:
      Clear the Allow Remote Assistance connections to this computer check box.

OPTIONAL 11 Region: Language for non-Unicode programs:
   On the Administrative tab, click Change system locale... From the drop down list, select English (United States).

NOTE Do not change system locale if you are using an English, Portuguese, Japanese or Chinese Operating System.

In the Windows Settings:

MUST 1 Start > Settings > Update & security:
   Click Check for updates to check for updates and apply all patches. Before proceeding, ensure that all updates are downloaded and installed. Ensure that there is no reboot pending.

MUST 2 Start > Settings > Update & security > Windows Defender:
   a  Click Turn on Windows Defender Antivirus.
   b  Click App & browser control.
      Turn off SmartScreen under Check apps and files, SmartScreen for Microsoft Edge, and SmartScreen for Windows Store apps.
2 Set Up the Windows Operating System
Configure Windows 10

[MUST] 3 Start > Settings > System > Tablet Mode:
   a For When I sign in, select Use desktop mode.
   b For When this device automatically switches tablet on or off, select Don't ask me and don't switch.

[MUST] 4 Start > Settings > Apps > Offline Maps: Turn Metered connections and Map updates off.

[MUST] 5 Start > Settings > Apps > Default apps: For best user experience in OpenLab Help and Learning, select Internet Explorer or Google Chrome as default Web browser.


[OPTIONAL] 7 Start > Settings > Personalization: Disable advertising info:
   a On the Lock screen page:
      • Under Background, select Picture or Slideshow.
      • Turn off Get fun facts, tips, tricks, and more on your lock screen.
      • Turn off Show lock screen background picture on the sign-in screen.
   b On the Start page:
      Turn off Occasionally show suggestions in Start.

[OPTIONAL] 8 Start > Settings > Personalization: In the Taskbar tab, under Taskbar buttons select Combine when taskbar is full.
   This will simplify switching between open CDS instances.

[MUST] 9 Start > Settings > Privacy:
   a On the General page, turn off the following:
      • Let apps use advertising ID to make ads more interesting to you based on your app usage (turning this off will reset your ID)
      • Let website provide locally relevant content by assessing my language list
      • Let Windows track app launches to improve Start and search results
   b On the Location page, make sure Location for this device is off. If not, click Change to turn it off.
Set Up the Windows Operating System

Configure Windows 10

Other Windows settings:

[MUST] 1 Disable Windows Update service.
   a In the Windows Start menu, enter Windows Administrative Tools in the Type here to search field, then choose the Administrative Tools Control panel. Click Component Services.
   b Select Console Root > Services (Local).
   c Double click Windows Update.
   d On the General tab, set the Startup type to Disabled. Confirm your settings.

[MUST] 2 Disable Compatibility View in Internet Explorer.
   a Open Internet Explorer.
   b Click the Tools icon, and then click Compatibility View Settings.
   c Clear the Display intranet sites in Compatibility View check box.

[MUST] 3 Enable the navigation pane:
   Open Windows Explorer, then select View > Navigation pane from the ribbon and make sure that Navigation pane is selected.

[OPTIONAL] 4 Right-click Start, select Run from the context menu, then type gpedit.msc in the Run field.
   a Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.

[OPTIONAL] b Set Don't display the Getting Started welcome screen at logon to Enabled.
   c Set Hide entry points for Fast User Switching to Enabled.

[OPTIONAL] 5 Recycle Bin Properties: (right-click on desktop icon Recycle Bin, then select Properties) Select the following options:
   • Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
   • Select Display delete confirmation dialog.

Repeat these steps for all drives of your computer.
Configure Windows 7

In the Microsoft Control Panel (View the items by icon to see a list of all items):

1. **System** (Microsoft Control Panel): Under **Windows activation**, click **Change product key**. Enter a valid value to activate Windows.

2. **Folder Options**: In the **View** tab,
   - Select **Always show menus**.
   - Select **Display the full path in the title bar**.
   - Clear **Hide extensions for known file types**.
   - Clear **Use Sharing Wizard**.

3. **Windows Update** (Microsoft Control Panel): Click **Check for updates** to check for updates and apply all critical security patches.

   **NOTE**
   Install Windows update 401990 if your system does not contain .NET 4.7 yet. You need this update to install .NET 4.7 from the CDS installer.

4. **Windows Update** (Microsoft Control Panel): Change the settings for updates:
   - Click **Change settings**. In the **Important updates** section, select **Never check for updates**. Clear the other update options.

   **NOTE**
   This setting is required during installation of OpenLab CDS.

   On clients in a client/server system, you may activate automatic updates again after finishing the installation.

   On Agilent Instrument Controllers (AIC) or standalone workstations, keep the **Never check for updates** setting. This setting is important to avoid data loss due to system reboot during data acquisition.

5. **Indexing Options**: Disable indexing.
   - Click the **Modify** button. Select **Show all locations**, and clear all drives and locations.

6. **Power Options**:
   - **a** As preferred plan select **High performance**.
   - **b** Click **Change Plan settings**.
2 Set Up the Windows Operating System
Configure Windows 7

Set the option Put the computer to sleep to Never.

Click Change advanced power settings.

Open the nodes for Hard disk > Turn off hard disk after.

Set the Minutes to 0 (=Never).

[MUST] 7 Administrative Tools: Configure security options:
   a Double-click Local Security Policy.
   b Navigate to Security Settings > Local Policies > Security Options.
   c Double-click the following policy listed in the right hand panel: Network Access: Sharing and security model for local accounts.
   d In the displayed dialog select the following item from the drop-down list: Classic - local users authenticate as themselves.

[MUST] 8 Date and Time: Choose the time zone of your regional location.

[MUST] 9 Network and Sharing Center:
   a Select Change adapter settings. Right-click your Ethernet Adapter, then select Properties. On the General tab, click Configure.
   b On the Power Management tab, clear all check boxes.

[MUST] 10 Programs and Features:
   a Click Turn Windows features on or off.
   b Expand the Microsoft .NET Framework 3.5.1 node and select the Windows Communication Foundation Non-HTTP Activation check box.
   c Select the Internet Explorer 11 check box.
   d Select the Telnet Client check box.
   e Select the TFTP Client check box.
   f Reboot the PC if necessary.

[PERFORMANCE] 11 System (Microsoft Control Panel): Change performance options:
   a Click Advanced system settings.
   b On the Advanced tab > Performance click Settings.
   d Under Custom, select the following check boxes for better usability:
      • Smooth edges of screen fonts
      • Show shadows under mouse pointer
      • Show shadows under windows

OpenLab CDS Workstation Installation and Configuration 17
2 Set Up the Windows Operating System
Configure Windows 7

**e** On the **Advanced** tab, select **Virtual Memory**.
For optimum performance use the **Change** button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible, locate the paging file on a drive different from the system installation drive.

**f** On the **Data Execution Prevention** tab, select **Turn on DEP for essential Windows programs and services only**.

**[PERFORMANCE]**

12 System (Microsoft Control Panel): Change system properties:

**a** Click **Advanced system settings**.

**b** On the **Advanced** tab under **Performance**, click **Settings**.
- **Visual Effects** tab: Select **Adjust for best performance**, then click **Apply**.
  
  Select **Custom**, then select the following check boxes for better usability:
  - Show shadows under mouse pointer
  - Show shadows under windows
  - Smooth edges of screen fonts

- **Advanced** tab > **Virtual Memory**: For optimum performance use the **Change** button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible locate the paging file on a drive different from the system installation drive.

- **Data Execution Prevention** tab: Select **Turn on DEP for essential Windows programs and services only**.

  Click **OK** to close the **Performance Options** dialog.

**c** On the **Advanced** tab under **Startup and Recovery**, click **Settings**.
- **System startup** section:
  Change both **Time to display ...** fields from 30 to 3 sec.

- **System failure** section:
  Select **Automatically restart**.
  In the **Write debugging information** subsection, select **Kernel memory dump** from the drop-down list.

  Click **OK** to close the **Startup and Recovery** dialog.

**[OPTIONAL]**

13 Region and Language (Microsoft Control Panel): Set the language for non-Unicode programs.

On the **Administrative** tab, click **Change system locale**... From the drop down list, select **English (United States)**.

**NOTE**
Do not change the system locale if you are using an English, Portuguese, Japanese or Chinese Operating System.
Set Up the Windows Operating System

Configure Windows 7

Other Windows settings:

[MUST] 1 Windows logon options: Right-click Start, select Run from the context menu, then type gedit.msc in the Run field
   a Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.

[MUST] 2 Set Hide entry points for Fast User Switching and Always use classic logon to Enabled.

[OPTIONAL] 3 Set Don't display the Getting Started welcome screen at logon to Enabled.

[MUST] 2 Disable Compatibility View in Internet Explorer.
   a Open Internet Explorer.
   b Click the Tools icon, and then click Compatibility View Settings.
   c Clear the Display intranet sites in Compatibility View check box.

[OPTIONAL] 3 General Layout: (right-click Start > Properties)
   a Start Menu Tab: In the Privacy section select both items
   b Start Menu Tab > Customize button: In Customize Start Menu dialog:
      • Clear the following option:
         • Favorites menu
      • Select the following options:
         • Computer Display as a link
         • Connect To
         • Control Panel: Display as a menu
         • Default Programs
         • Devices and Printers
         • Documents: Display as a link
         • Enable context menus and dragging and dropping
         • Games: Don't display this item
         • Help
         • Highlight newly installed programs
         • Music: Don't display this item
         • Network
         • Open submenus when I pause on them with the mouse pointer
         • Personal folder: Display as a link
         • Pictures: Display as a link
Configure Windows 7

- Run command
- Search other files and libraries Search with public folders
- Search programs and Control Panel
- Sort All Programs menu by name
- System administrative tools: Display on the All Programs menu and in the Start menu
- Use large icons

[OPTIONAL] 4 Right-click Start, select Run from the context menu, then type `gpedit.msc` in the Run field.
  a Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.
  b Set Don't display the Getting Started welcome screen at logon to Enabled.
  c Set Hide entry points for Fast User Switching to Enabled.

[OPTIONAL] 5 Recycle Bin Properties: (right-click on desktop icon Recycle Bin, then select Properties) Select the following options:
  - Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
  - Select Display delete confirmation dialog.
Repeat these steps for all drives of your computer.

[OPTIONAL] 6 If HTTPS is set up, you must enable TLS 1.2 in order to log in to the OpenLab software.
To enable TLS 1.2, set the following registry keys:
- [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2]
- [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
  "Enabled"=dword:00000001
  "DisabledByDefault"=dword:00000000
- [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Server]
  "Enabled"=dword:00000001
  "DisabledByDefault"=dword:00000000
3 Install OpenLab CDS Workstation

Run the OpenLab Installer  22
Silent Installation  33
Export Properties File  33
Run Installation  34
Parameters and Return Codes  35
Logging and Tracing  35
Install or Upgrade Driver Software  36
Register driver software with OpenLab CDS  37

This chapter describes the installation of the software.
3   **Install OpenLab CDS Workstation**

Run the OpenLab Installer

### Run the OpenLab Installer

1. Copy the entire content of the USB media to a local drive, then remove the USB media from the PC. Right-click the setup.exe file, and run it as administrator.

   ![Organize, Open, New folder]

   ![Favorites, Libraries, Computer, Network]

   ![Name]

   - ja-JP
   - pt-ER
   - Setup
   - zh-Hans
   - setup.exe

   **NOTE** If User Account Control (UAC) is switched on, this step requires active confirmation to continue.

2. The OpenLab Installer checks if the Microsoft .NET Framework 3.5 SP1 is present and enabled. If it is not, the installer automatically tries to install and activate it.

   **NOTE** If .NET 3.5 cannot be enabled, for example, because the computer has no internet access, install .NET 3.5 from the Windows installation media (see Method 3 under [https://support.microsoft.com/en-us/kb/2734782](https://support.microsoft.com/en-us/kb/2734782)). If you do not have installation media, create them as described under [https://www.microsoft.com/en-us/software-download/windows10](https://www.microsoft.com/en-us/software-download/windows10).
3 Install OpenLab CDS Workstation
   Run the OpenLab Installer

3 On the start screen, select OpenLab CDS, and click OK.

4 Click Install/Upgrade.
3 Install OpenLab CDS Workstation

Run the OpenLab Installer

5 The OpenLab Installer checks if correct version of Microsoft .NET Framework is available. If it is not, you will be prompted to install it.

6 License Agreement: Read and confirm Agilent terms and conditions.
3 Install OpenLab CDS Workstation
Run the OpenLab Installer

7 Installation Type: Select Standalone Workstation.

8 Installation Folder: Provide an installation folder for OpenLab CDS. Do not use the root folder of any drive.
3 Install OpenLab CDS Workstation
   Run the OpenLab Installer

9 Select Storage Type: Choose Local File System.
3 Install OpenLab CDS Workstation
Run the OpenLab Installer

10 Storage Configuration. Provide a folder for storing the project data. Do not use the root folder of any drive.

NOTE
The maximum file path length is 256 characters. The characters of project folder names and file names (for example, sequences files or report templates) will also contribute to the maximum numbers of characters.

If you want allow access to the projects root path only from within OpenLab CDS, select Secure 'Projects Root Path'.
11 Migration Settings:

The Migration tool helps you to migrate data from ChemStation or EZChrom. If you want to import data prepared by the Migration tool, select **Migrate Database**, and provide the required paths. For details, refer to *Agilent Migration Tools for OpenLab - OpenLab CDS ChemStation and EZChrom Edition to OpenLab CDS Workstation* (OpenLabMigrationTool.pdf, located in the Migration folder Setup\Tools\Migration) on the installation media.
3 Install OpenLab CDS Workstation

Run the OpenLab Installer

12 Prerequisite Check: Mandatory settings in the operating system are checked. The report is located in C:\ProgramData\Agilent\InstallLogs\<date and time>. Note that ProgramData is a hidden folder.

In case of errors, see the following hints:

- Is the name of the installation folder still applicable?
- Is there enough space available on the hard disk? For details, refer to the OpenLab CDS Requirements Guide (OpenLabCDSRequirements.pdf).

---

1 To run the site preparation tool separately before installing: Start the OpenLab Installer, select the Planning page, and click System Configuration Checker.
13 **Review.** All components that will be installed are listed with their version numbers.

- To save a properties file for a future silent installation (see "Silent Installation" on page 33), click **Save to config File**.
- To start the installation, click **Install**.
Install OpenLab CDS Workstation
Run the OpenLab Installer

14 **Install**: After the installation has completed, click **Next**.

15 **Configure**: Configuration tools run in the background to configure the local file system. This takes about 10 min. When finished, click **Next**.
3 Install OpenLab CDS Workstation
Run the OpenLab Installer

16 Finish:
• To confirm everything has been installed correctly, click Run Software Verification.
• To complete the installation, select the Reboot the computer now check box, and click Finish.

In case of errors during the installation: Check the installation log files under C:\ProgramData\Agilent\InstallLogs\[date and time]. Note that ProgramData is a hidden folder.

The installation includes a set of standard instrument drivers. If you need other instrument driver software, install it in a separate step. See "Install or Upgrade Driver Software" on page 36.

1 To start the tool separately at a later point in time, select Start > Agilent Technologies > Software Verification Tool.
Silent Installation

OpenLab CDS supports a command-line mode for installation, also referred to as *silent installation*. This mode supports installation, upgrade, repair, and uninstallation. You can execute silent installations either manually or as part of software management systems such as LANDesk or HP CM.

**Export Properties File**

The OpenLab Installer supports a feature to export the installation parameters into a properties file which you can then use for the silent installation.

1. Launch the OpenLab Installer.
2. Follow the instructions of the wizard.
   - If an error is shown about missing redistributable packages, install the required packages from the installation medium (Setup\redist folder), and reboot.
3. When you have reached the **Review** screen, click **Save to config file**.
   - Save the file to a suitable location. The file will automatically be saved as a .properties file.

You can now use the properties file for the silent installation.
3 Install OpenLab CDS Workstation

Silent Installation

Run Installation

Prerequisites

- You have prepared a properties file for silent installation. See "Export Properties File" on page 33.
- .Net Framework is present on your system.
  
  If it is not present, it will automatically be installed. You must then manually select Accept to agree with the license agreement.
- All required redistributable packages are installed.
  
  An error on missing packages is shown when running the wizard, but it is hidden in the silent mode. Therefore, if packages are missing, the silent installation will fail without notice. Redistributable packages are available on the installation medium in the Setup\redist folder.

1 Copy the content of the USB media to a centralized folder.

2 Copy the properties file to the same directory as the CDSInstaller.exe.

3 Right-click the executable of the command prompt or Power shell prompt, and run it as administrator.

4 Navigate to the location where you have saved the installation files.
   
   For example: C:\CDS

5 To start the installation, call CDSInstaller.exe with the following syntax:

   CDSInstaller.exe -s -c <PropertiesFile>

   For example:

   CDSInstaller.exe -s -c Silent.Properties

   With this command, you start the OpenLab Installer without a user interface.

6 Wait about 5 minutes while the installation takes place. To check the process of installation, look at the log files under \%ProgramData\Agilent\InstallLogs.

   If a required installable is missing, the OpenLab Installer will create an entry in a log file, and, depending on the component type, will continue or roll back the installation. An error code will be returned in such scenarios.

7 After the installation has finished, reboot the PC.
Install OpenLab CDS Workstation
Silent Installation

Parameters and Return Codes

Parameters

Use the following parameters when calling CDSInstaller.exe in command-line
mode:

- `-s`
  Silent mode - no user interface will be shown.
- `-c`
  Configuration file - a properties file contains all parameters.
- `<PropertiesFile>`
  The properties file contains all required inputs for the installer. Replace
  `<PropertiesFile>` with the correct file path and file name. The file must be
  located in the same directory as the CDSInstaller.exe.

Return Codes

After installation, uninstallation, upgrade, or repair in the command-line mode, the
system will return a number code which is explained below.

<table>
<thead>
<tr>
<th>Error/return code</th>
<th>Return value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Success. You can see all of the information in the log file.</td>
<td>0</td>
</tr>
<tr>
<td>Failure. Verify against the log file to see what failed.</td>
<td>any other number</td>
</tr>
</tbody>
</table>

Logging and Tracing

All exceptions, errors and information messages are logged under C:\ProgramData\Agilent\InstallLogs\<date and time>. Note that ProgramData is a hidden folder.
Install OpenLab CDS Workstation
Install or Upgrade Driver Software

Install or Upgrade Driver Software

The following driver software packages are automatically installed and configured with OpenLab CDS. For details, refer to the OpenLab CDS Workstation Requirements and Supported Instruments guide.

- Agilent GC & GC/MS
- Agilent LC & LC/MS
- Agilent 35900 A/D
- Agilent SS420x
- Agilent Data Player (Virtual Instruments)

Other instrument driver software, add-on software, or upgrades to existing driver software, must be installed and configured manually. Instrument driver software and add-on software can be found on the installation media under Setup\Packages\Add-Ons.

The latest Agilent drivers are available in SubscribeNet. In the Product List, select OpenLab Software > OpenLab Agilent Instrument Drivers.

Install or upgrade driver software

1. Run the installer package, and follow the installation wizard.
   
   For details on the installation or upgrade procedures, refer to the respective driver documentation.

2. Register driver software with OpenLab CDS.
   
   See “Register driver software with OpenLab CDS” on page 37.

The OpenLab Configuration will find all newly installed or updated instrument drivers and register them with the Shared Services. New instrument types will be available in the Control Panel.
Register driver software with OpenLab CDS

The following procedure must be carried out after installing drivers other than the ones listed above, and after upgrading any driver. With these steps you make the new drivers available in OpenLab CDS.

1. In Windows, select **Start > All Programs > Agilent Technologies > OpenLab Configuration**.

2. In the **OpenLab Configuration** tool, enter one of the following strings as a server hostname:
   - The IP address of the workstation, for example 192.x.x.x
     To look up your IP address, open the Windows Command Prompt and enter `ipconfig`. This returns an IPv4 address.
   - The IP address of the localhost, 127.0.0.1
   - The computer name

3. Click **Connect** to enable the input boxes for the user credentials.

4. Under **Step 2 - Authentication**, enter your user credentials.

5. Make sure the **Register as Instrument Controller** check box is cleared.

6. Click **Register**.
4 Post Installation Tasks

Create Account to Access Network Share  39
Set up the domain user account  39
Enable automatic printing  41
Configure the Antivirus Program  42
Configure Internet Explorer for OpenLab Help and Learning  44
Local Windows Group for Secure Projects Root Folder  45
Disable Windows 10 Updates  46

This chapter describes tasks that are relevant after finishing the installation.
Create Account to Access Network Share

OpenLab CDS allows you to automatically process your data during acquisition, without opening Data Analysis. During this processing specific domain user privileges to access a network share/network printer and log on as a service are required:

- You can generate reports and print them to printer or save them as files. Exporting the reports to a network share is a typical way how they are sent to an external system (for example, LIMS).
- You can export raw data or results during a run, and save the files to a network share.

Set up the domain user account

1. Log in as Windows domain user who has local administrative privileges.
2. Go to Control Panel > All Control Panel Items > Administrative Tools and double-click Services. Make sure the status of Agilent OpenLab Instrument Service is Started. If not, right-click and select Start.
3. Right-click Agilent OpenLab Instrument Service and select Properties.
4 Post Installation Tasks
Create Account to Access Network Share

4 Click the **Log On** tab, select **This account** and enter the login credentials of a domain user who has network printing privileges. Click **OK**.

![Image of Log On tab settings]

5 The **Services** window confirms that the account has been granted the **Log On As A Service** right. Click **OK**.

![Image of Services window with confirmation]

6 Click **OK** in the Services window to acknowledge that **The new logon name will not take effect until you stop and restart the service**.
Post Installation Tasks
Create Account to Access Network Share

7 Restart the PC. This will enable the Log On user specified in Instrument Service to automatically print reports in Data Acquisition.

8 After the PC reboots, log in using the same domain user account (for example, agilent\ppadmin) specified in the Log On tab of Agilent OpenLab Instrument Service Properties window.

Enable automatic printing

If you plan to acquire a single sample or a sequence that specifies a processing method that has Printer report destination, add a default printer to the PC to enable automatic printing of reports.

Prerequisites
You have set up a domain user account (see “Set up the domain user account” on page 39).

1 Go to Control Panel > All Control Panel Items > Devices and Printers and click Add a printer.

2 Select Add a network, wireless or Bluetooth printer and browse or type a shared printer name that you want to add. Once the printer is added, print a test page and set it as a default printer.
Configure the Antivirus Program

1. Be sure to open the firewall ports listed in the Firewall Settings in the OpenLab CDS Requirements guide.

2. For best performance, consider the following folder exclusions. These folders should only be scanned while the instruments are idle, and no data acquisition or data analysis takes place.
   - [C:\]CDSProjects
   - [C:\]Program Files (x86)\Agilent Technologies
   - [C:\]ProgramData\Agilent
   - [C:\]ProgramData\Agilent IPB Files
   - [C:\]ProgramData\Agilent Technologies
   - [C:\]ProgramData\ChromatographySystem
   - [C:\]ProgramData\Firebird
   - [C:\]ProgramData\IsolatedStorage
   Refer to your specific antivirus software documentation on how to configure folder exclusions.

Settings for Trend Micro™ antivirus software

OpenLab CDS can be used with other antivirus programs as well. If you use Trend Micro™, the following settings are recommended to optimize system performance.

1. **Web Reputation**: Turn off to maximize performance.
   
   The risk of turning off Web Reputation is that web traffic through browsing from the machine will not be checked.
   
   Ensure that there is another URL/web scanner on the gateway level to protect the endpoint, or ensure that the endpoints have limited access to Internet. These production machines should not have access to Internet websites where most of the infections are coming from.

2. **Real time scan**: Add exclusions, and modify scan direction from Created/Modified/Retrieved to Created/Modified.
   
   Exclusions ensure that the working directory of Agilent Technologies will not be scanned, thus improving performance.
4 Post Installation Tasks
Configure the Antivirus Program

The risk is that only files that are created and changed on this machine are scanned. Files that are just accessed will be bypassed. Dormant Files that got infected without being noticed at the time they were created or written to the machine will not be scanned.

Increase scheduled scan to daily to ensure all files on the machine are being checked for infections that are dormant or not moving.

3 Behavior Monitoring: Add below list of programs to Approved programs.
C:\Program Files (x86)\Agilent Technologies\...

- OpenLab Acquisition\Agilent.OpenLab.Acquisition.AcqInstrumentService.exe
- OpenLab Acquisition\Agilent.OpenLab.AcquisitionClient.exe
- OpenLab Data Analysis\Bin\Agilent.Chromatography.DataAnalysis.Processing.ProcessingServer.exe
- OpenLab Data Analysis\Bin\Agilent.Chromatography.DataAnalysis.Ui.CustomCalculationDesigner.exe
- OpenLab Data Analysis\Bin\Agilent.OpenLab.DataAnalysis.exe
- OpenLab Data Analysis\Bin\Reporting\Agilent.OpenLab.Reporting.RdlDescriptor.exe
- OpenLab Data Analysis\Bin\Reporting\Agilent.OpenLab.Reporting.RdlDescriptorContextMenu.exe
- OpenLab Data Analysis\Bin\Reporting\IntelligentReporting.RenderServiceHost.exe
- OpenLab Data Analysis\Bin\Reporting\TemplateDocumentation.exe
- OpenLab Services\Automation\AutomationServerHost.exe
- OpenLab Services\Diagnostics\DiagnosticsToolsServiceHost.exe
- OpenLab Services\Licensing\Flexera\lmadmin.exe
- OpenLab Services\Licensing\Licensing.Service.Host.exe
- OpenLab Services\Server\SharedServicesHost.exe
- OpenLab Services\UI\Agilent.OpenLab.ControlPanel.exe

The risk is that if any of the excluded files get infected, it will not be detected. For example, trigger a schedule on a daily basis to cover these files.

4 Realtime monitoring: Add below folder to the exclusion list of Realtime Monitoring setting:
C:\Program Files (x86)\Agilent Technologies\...
4 Post Installation Tasks
Configure Internet Explorer for OpenLab Help and Learning

Configure Internet Explorer for OpenLab Help and Learning

If you use Google Chrome or Edge, no further settings are required.

If you use Internet Explorer as your default browser: Make the following settings to ensure that OpenLab Help and Learning is opened without showing a confirmation prompt.

1. In Internet Explorer, click Tools > Internet Options.
2. Select the Advanced tab.
4. Confirm your settings.
5. Reboot the computer to make the settings effective.
Local Windows Group for Secure Projects Root Folder

If you installed OpenLab CDS using the Secure 'Projects Root Path' option, your projects folder (by default, C:\CDSProjects) and anything within this folder is locked. Only the local Windows system user and the local Windows group \AgtsFsGroup are able to browse this folders. The \AgtsFsGroup group is created during installation.

To ensure that the system is working properly do not delete the \AgtsFsGroup group.

**CAUTION**

The application may become unusable

If you change file access privileges, Windows 10 removes the default ownership. As a result, OpenLab CDS will be unable to access your data.

 ✓ Request Agilent's support if you need to change privileges on file system level.
Post Installation Tasks
Disable Windows 10 Updates

Disable Windows 10 Updates

Your company's security policy may require that Windows updates are not applied automatically.

With Windows 10, automatic updates cannot be turned off in the Windows settings as in earlier Windows versions. Instead, you must disable the Windows Update service. As this service is required during installation, you can only disable it after finishing the installation.

1. In the Start menu, search for services.msc and press Enter to open the Services window.
2. Double-click the Windows Update service.
3. Set the startup type to Disabled.

NOTE
The computer is no longer automatically updated. Make sure you keep the computer up to date by other means.
5 Licensing

About OpenLab CDS Licensing  48
Software subscriptions and Software Maintenance Agreement (SMA)  48
License Types  48
License File  49

Get a License  50
Obtain a License with SubscribeNet  50
Other Ways to Obtain a License  52

Install Your License  54

This chapter provides basic information on OpenLab licensing. It describes how you generate a license file with SubscribeNet and install the license in the Control Panel.
About OpenLab CDS Licensing

Software subscriptions and Software Maintenance Agreement (SMA)

Bundled into OpenLab CDS is a one-year software subscription which provides access via SubscribeNet to new software updates, product upgrades, familiarization and media.

As a best practice, we recommend customers renew subscriptions annually so as to maintain their licenses and have full access to the newest updates, upgrades, media and familiarization. To manage software entitlements and download software, log in to SubscribeNet by pasting this link in your browser: http://agilent.subscribe.net/

Software subscriptions do not include installation services. Installation or upgrade services must be purchased by contacting your sales representative in your region.

License Types

The license file is a collection of Product, Instruments and Add-on licenses (or activation keys), and is installed to your OpenLab CDS System.

The licenses or activation keys in the license file can either be Shared or Counted:

- Shared licenses — system computers and other components can have shared, or add-on, licenses — because they share a core license.
- Counted licenses — these licenses are part of the OpenLab CDS floating licensing strategy. They are not permanently assigned to any one component. Instead they are automatically assigned to components, such as AICs and instruments, while the components are starting up. The licenses are automatically returned when the component is closed. The license management program controls license issuance and retrieval.

In this case, the only requirement is that a component is licensed while running. You only need enough licenses for all components running concurrently, rather than for each installed component.

A startup license for the system allows you to run OpenLab CDS for 60 days after the installation. In order to run the data system software after the 60-day period, you must install your license file.
Licensing
About OpenLab CDS Licensing

License File

A license file will contain your software license. This file is installed on the workstation. The license file is bound to this computer, and cannot be moved to another workstation without regenerating the license in SubscribeNet.

Information in the license file defines the number of instruments and other options that may be used concurrently with your system.

The most efficient way to manage and maintain your licensing is through the Internet.
Get a License

Obtain a License with SubscribeNet

Use the following procedure to generate and download your license. In case you do not have internet access, skip to the section "Other Ways to Obtain a License" on page 52.

If you are a new user who has not registered with SubscribeNet, continue with the section New Users.

If you have registered with SubscribeNet, skip to the section Users registered with SubscribeNet.

Prerequisites

To generate, download, and install a final license for your product, you will need:

• The authorization code label provided in the lavender envelope containing your Software Entitlement Certificate.
  If you have not received a lavender envelope for your product, contact your vendor or internal support.
• The URL for SubscribeNet from the Software Entitlement Certificate.
• The host name of the computer where the Control Panel is running.
• The MAC address.
  To retrieve your MAC address from a computer where OpenLab CDS is already installed, open the Control Panel and browse to the Administration > Licenses section. Use the Copy MAC Address or Save MAC Address function to obtain the MAC address for license generation.
  During this process you will have to enter the MAC address of your license server. For workstations, this is the local computer. For client/server systems, this is the server.

NOTE

If any changes are made to the computer name or domain reference after the license is installed, remove the license. A new license will need to be created in SubscribeNet, downloaded, and installed.

NOTE

If the network adapter that provides the MAC address used during license creation is removed from the machine, your license will no longer be valid. A new license will need to be generated with a currently available MAC on the license server.
Licensing
Get a License

New Users
1. Go to https://agilent.subscribenet.com/control/agil/AgilRegisterToAccount to register the product with SubscribeNet.
2. On the registration page, enter the authorization code from the label and complete the profile information (required fields are marked with an asterisk *).
   The email address you enter will become your login ID.
3. Click Submit. The system will generate and display an account name for you.
   SubscribeNet will send a welcome email with your login ID and password.
4. Log in to SubscribeNet using your login ID and password.
   Once you log in, you can use the online user manual link for help with any questions you have.
5. Select Generate or View licenses from the left navigation bar.
6. Follow the prompts to generate your new license.
   You will be prompted for the HOST NAME of the computer. The host name you enter must match with the network name of the computer where the Control Panel is running. Do not include any DNS suffix (domain.com) references in the entered machine name.
7. When the system generated the license, view its details, then click Download License File. Save the license file to your computer and to a backup location (such as a portable storage device).
   Use your login ID and password when you revisit the Agilent SubscribeNet site to regenerate a license file, add new authorization codes, or further configure the license for your system.

Users registered with SubscribeNet
1. If you already have a SubscribeNet account, use https://agilent.subscribenet.com/.
   Lost your SubscribeNet password? Use https://agilent.subscribenet.com/control/agil/password to have it emailed to you.
2. Select the SubscribeNet account associated with this authorization code, if you have more than one account.
   This will allow you to enter your new authorization code and make available the new license entitlements.
4. Follow steps 5 through 7 in the previous procedure, New Users, to generate or view your new licenses.
Licensing
Get a License

Other Ways to Obtain a License

If you are unable to generate a license, contact your nearest Agilent technical support office. A representative will tell you how to submit an OpenLab CDS License Generation Form in your location.

Offline Licensing

If an internet connection is not available in your laboratory:

You or your local on-site service engineer will collect the necessary information from you to allow Agilent to create a license account on your behalf. For phone support in your region, call the sales and service number for your region. See the Appendix for a list of numbers for various countries.

Required Customer Information for Agilent License Support:

The following information must be provided to Agilent in order to enable us to create a licensing account on your behalf.

1. Collect Account Information:
   Your account name will be your company name and Lab name separated by a comma. Employee information provided here will be used to define the first administrator of your account for future access to the system as required. Please prepare the following pieces of information prior to contacting your local Agilent sales and service center in order to expedite service:
   - Company Name
   - Lab/Department Name
   - First Name
   - Last Name
   - E-mail address
   - Job Title
   - Phone #
   - Address, City, State/Province, Postal Code, Country

2. Collect Authorization Code(s):
   The authorization code is an alpha-numeric code provided on a label which is enclosed in a lavender envelope. If you have received more than one code you must provide all codes to ensure that all ordered licenses are granted to your account.
5 Licensing
Get a License

3 Receiving your license:
Once the above information is provided Agilent will then work on your behalf to generate a license file through SubscribeNet. The license file will either be sent to your shipping address (on a CD), or your local FSE will deliver it in person (usually on USB media). Once your license is received follow the below section on "Install your License" to finish installing your license on your CDS system(s).
Install Your License

The license must be added to your system using the Control Panel.

1. Start the Control Panel shortcut on the desktop or go to Start > All Programs > Agilent Technologies > OpenLab Shared Services > Control Panel.
2. Navigate to Administration > Licenses.
3. In the ribbon, click Add License +.

4. Choose to install the license by:
   - Using the license file option to browse to and open the license file (.lic) saved from the license generation process in SubscribeNet.
   - Selecting the License Text option and copying the license text from a text file received into the provided field.
5. Click OK.

The Administration interface in the Control Panel will now display the status of installed licenses.
Configure OpenLab CDS Workstation

Configure Authentication 56
Configure Security Policy 57
Configure users, roles, and privileges 58
Create or import users 58
Groups 59
Roles and Privileges 59
Add users or groups to a role 61
Specific Roles for Individual Instruments or Projects 61
Configure the Storage Location 62
Enable File System Security 63
Configure Initial Project 63
Configure Initial Instrument 64
Other settings in the Control Panel 64

This chapter describes the initial configuration steps after installing the OpenLab CDS software. All configuration tasks are performed in the Control Panel. For more details, refer to the Control Panel section in OpenLab Help & Learning.

**CAUTION**

This chapter is not applicable if you are migrating from OpenLab CDS ChemStation Edition or OpenLab CDS EZChrom Edition.

- If you are upgrading from OpenLab CDS ChemStation Edition or EZChrom Edition, be sure to refer to the corresponding migration guide (see Appendix) prior to configuring OpenLab CDS ("Migration guides" on page 123).
Configure OpenLab CDS Workstation
Configure Authentication

Configure Authentication

OpenLab CDS supports the following authentication providers:

- **None** (default setting after installation)
  In this mode, no login screen is shown when you access the Control Panel. The user is automatically logged in to the application with security disabled. All log entries record the user as “Anonymous”. With the authentication provider **None**, the Security Policy and User Management nodes are unavailable in the Control Panel.

- **Internal**
  In this mode, the user’s credentials are stored in the OpenLab CDS system. You are asked to create an administrator account for OpenLab CDS before setting up other users. This is the only mode in which you can create new users within the system; in all other modes you can only map to users that exist in a different system.

- **Windows Domain**
  You import existing Windows users into OpenLab CDS system. The authentication is done either by Windows Active Directory domain or NT 4.0 Domain within the Enterprise. OpenLab CDS only uses the identity and password of the mapped users; roles and privileges for OpenLab CDS are still configured in the Control Panel.

1. Launch the Control Panel.
2. Navigate to **Administration**.
3. In the navigation pane, select **System Configuration**.
4. In the ribbon, click **Edit System Settings**.
5. Select the required authentication provider from the drop-down list, then click **Next**.

**NOTE**
Do not change the storage type.

With the authentication provider **None**, any activity logs will display a generic **System** operator with no additional identification. This is not recommended for compliant setups.
Configure OpenLab CDS Workstation

Configure Security Policy

6 Provide user credentials:
   a For Windows Domain: Select the check box to use a domain user, and provide user credentials with the rights to obtain user and group information. Then click Select Account to open the Search Users dialog and select an administrator account.
   b For Internal. Click Create Account to create a new administrator account for OpenLab CDS.

7 Confirm your settings. When complete, the Control Panel will restart.

Configure Security Policy

If you need to comply with specific standards, adjust the security policy as required.

With the authentication provider Internal, you can set all parameters in the Control Panel. With an external authentication provider (Windows Domain), you can only set the inactivity time in the Control Panel; all other parameters are defined by the external system.

1 Launch the Control Panel and navigate to Administration.
2 In the navigation pane, select Security Policy.
3 In the ribbon, click Edit Security Policy.
Configure users, roles, and privileges

With internal authentication, you create the required users in the Control Panel. With Windows domain as an external authentication system, you import the Windows domain users.

To define what users are allowed to view or do, OpenLab CDS offers predefined roles and allows you to define your own specific roles. Roles are equipped with numerous specific privileges.

Each user can be member of multiple groups. You must assign one or more specific roles to each group. You can also assign roles to single users; however, for the sake of clarity, it is strongly recommended to assign roles only on the group level. Every member of a group automatically has all roles of this group.

1. Launch the Control Panel and navigate to Administration.
2. In the navigation pane, select Users, Groups, or Roles.
3. Create new items, or edit the existing ones.

Create or import users

Use the Control Panel to manage the roles and privileges. You can create custom roles, or assign one or more of the predefined roles to give users varying degrees of access.

Add users (Internal Authentication only)

1. From the navigation pane, click Administration > Users.
2. In the ribbon, click Create User.
3. In the Create User dialog, provide the relevant parameters:
   - Enter the name and password for the new user.
   - By default, the new user will need to change the password at next logon. If this is not required, clear the User must change password at next logon check box.
   - In the Role Membership tab, assign the user to an appropriate role. You can use the default roles, or prepare your own roles in the Control Panel under Administration > Roles.
4. Click OK.
Configure OpenLab CDS Workstation
Configure users, roles, and privileges

Import users (Windows Domain Authentication only)

To add users to your system, you must have privileges to obtain user and group information from the domain.

1. From the navigation pane, click Administration > Users.
2. In the ribbon, click Import.
3. In the Search Users dialog box, enter search string for the Windows domain username.
4. From the Search Results list, select the user you want to import, and click Add. The user is added to the Selected Users list.
5. Repeat steps 2 through 4 until you have added all the user names that you want to import to the Selected Users list, then click OK.

Groups

If you use an external authentication provider, you can either import the names of groups that exist in the external system, or create new internal groups. There is no limit on the number of groups that can be mapped or created.

Assign users to groups either in the external system or in the Control Panel. If you need additional user assignments that are relevant only for OpenLab CDS, create them in the Control Panel. Otherwise it is sufficient to only import the groups and assign the required roles to the groups.

If you delete or unmap a group, the users who were members in this group remain unchanged.

Roles and Privileges

Roles are used to assign privileges to a user or a user group globally or for a specific instrument, project, project group or location. The system contains a list of predefined roles which are installed as part of the system installation (for example, Instrument Administrator, Instrument User, or Everything). Each role has certain privileges assigned.
Configure OpenLab CDS Workstation
Configure users, roles, and privileges

Privileges are grouped according to the three main role types (Project role, Instrument role, and Administrative role). When you assign privileges to a role, you first select the required role type and then select the privileges related to this role type. Each role can only have privileges of one specific role type; the only exception is the predefined role *Everything*, which has all privileges of all role types. Users or groups may require multiple roles to perform system functions. For example, a user with the role *Chemist* may need another role such as *Instrument User* with the privilege to run an instrument.

You can create a tree of different locations in the Control Panel, and add instruments to the relevant locations. For each instrument or instrument group, you can assign different Instrument roles (see also “Specific Roles for Individual Instruments or Projects” on page 61). For example, a user can have the role *Instrument Administrator* for one instrument, and *Instrument User* for another instrument.

You can also create a tree of different projects or project groups in the Control Panel, and assign different Project roles for different projects (see also “Specific Roles for Individual Instruments or Projects” on page 61). For example, a user can have the role *Project Administrator* in one project, so that he can manage the settings in the Control Panel. In a second project, he may have a role that allows him to edit the content of a project, but not to change the project settings.

For more information on privileges, see the Appendix.

**Table 3 Description of role types**

<table>
<thead>
<tr>
<th>Role Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrative privileges</td>
<td>These privileges are globally assigned to a user or group and cannot be changed on the instrument/location level. They are the typical administration privileges such as <em>Backup and restore</em>, <em>Manage security</em>, <em>Manage printers</em>, etc.</td>
</tr>
<tr>
<td>Instrument privileges</td>
<td>These privileges can be assigned globally or on the instrument/location level. Privileges for instruments are, for example, <em>View instrument or location</em> and <em>Run instrument</em>. Users need the <em>View instrument or location</em> privilege on the global level to see the locations and instruments tree in the Control Panel.</td>
</tr>
<tr>
<td>Project privileges</td>
<td>Privileges for accessing or modifying different levels of data. You can assign these privileges globally or on project or project group level.</td>
</tr>
</tbody>
</table>

OpenLab CDS Workstation Installation and Configuration
Configure OpenLab CDS Workstation
Configure users, roles, and privileges

Add users or groups to a role

1. From the navigation pane, click Administration > Roles.
2. In the Roles window, select the role you want to assign to users or groups.
3. In the ribbon, click Edit Role.
4. In the Edit Role dialog box, click the Members tab.
5. Click Add user or group.
6. In the Search Users and Groups dialog box, enter the name of a user or group, and click Search to view a list of all users and groups that meet the search criteria.
7. Under Search Results, select a user or group, and click Add.
8. Click OK.

Specific Roles for Individual Instruments or Projects

By default, the roles of users or groups are globally set for all locations, instruments, project groups, or projects. The role settings are inherited from the root node Instruments or Projects, respectively. In order to assign a different role to a user or group for one specific node, you can deselect the Inherit privileges from parent check box in the Edit Privileges dialog for the required node. Afterwards, you can assign a different role that will be valid only for the specific node.

You can assign Instrument roles to individual locations or instruments.

If you use projects, you can assign Project roles to individual project groups or projects.

Administrative roles are always set globally.
Configure OpenLab CDS Workstation

Configure the Storage Location

All project data is stored on the local file system. Each project has its own project folder, but all project folders are located in the Projects Root Path. The following procedure explains how to change Projects Root Path.

Prerequisites
To be able to change the Projects Root Path, the directory must be empty. You have not yet created any projects.

NOTE
If you already created projects, move the data away temporarily, then delete the project. After you have set the correct path, create the projects again and move the data back.

1. Launch the Control Panel.
2. Navigate to Administration.
3. In the navigation pane, select System Configuration.
4. In the ribbon, click Edit System Settings.
5. Select the storage location File System from the drop-down list, then click Next.
6. Provide the new Projects Root Path.
7. Confirm your settings. When complete, the Control Panel will restart.
Enable File System Security

With File System Security, you prevent users from modifying OpenLab files outside OpenLab CDS. File System Security may have been enabled already during installation, but you can enable it at any time. File System Security is optional.

1. Launch the Control Panel.
2. Navigate to Administration.
3. In the navigation pane, select System Configuration.
4. In the ribbon, click Edit System Settings.
5. Select the storage location File System from the drop-down list, then click Next.
6. Select the Secure project folder check box, then click Next.
7. Confirm your settings.

Configure Initial Project

1. Launch the Control Panel and navigate to Projects.
2. Create and configure a project:
   - On the CDS Settings tab:
     - Enter the locations for Methods, Sequences, Results, Sequence Templates and Report Templates.
     - Consider the required audit trail settings for this project.

For more details, refer to the Control Panel section in OpenLab Help & Learning.
Configure Initial Instrument

1. Launch the Control Panel and navigate to **Instruments**.
2. Click **Create** in the ribbon to create a new instrument.
3. Select the new instrument, and click **Configure Instrument** in the ribbon.
4. It is recommended that you use Auto Configuration (if available) to configure your instruments: Select a module, click **Auto Configuration**, and provide the instrument's IP address or hostname.

For more details, refer to the Control Panel section in OpenLab Help & Learning.

Other settings in the Control Panel

Consider also other settings in the Control Panel, such as:
- Changing the instrument status reporting frequency
- Changing audit trail settings for a project
- Editing signature levels for a project (only accessible from an OpenLab CDS Workstation or Client)

For more details, refer to the Control Panel section in OpenLab Help & Learning.
7 Optional Procedures

Install OpenLab Help and Learning Only 66
Improve Performance on Offline Machines 67
Install or Uninstall Add-ons 68
ADF Export Plug-in 68

This chapter describes the installation or upgrade of additional software. It also contains information on the installation of OpenLab Help and Learning only, and on performance improvement on offline machines.
Optional Procedures
Install OpenLab Help and Learning Only

Install OpenLab Help and Learning Only

Use this option to install OpenLab Help and Learning content without installing OpenLab CDS applications.

Do not use this option on a machine where OpenLab CDS is, or will be, installed.

1. Insert the USB media, right-click the setup.exe file, and run it as administrator.
2. On the start screen, select OpenLab CDS, and click OK.
3. Click Install OpenLab Help and Learning Only.
4. Select your language, and click Next.
5. On the welcome screen, click Next.
6. Confirm Agilent terms and conditions, and click Next.
7. Review the installation directory. If desired, click Change... to specify a different directory.
8. Click Install.
9. When the installation is complete, click Finish.
10. If you plan to use Internet Explorer to view the content, set the Internet Options as described under Configure Internet Explorer for OpenLab Help and Learning on page 44.

Without these settings, you will need to click Allow blocked content when opening the help.

No settings are required for Google Chrome or Edge.

You can uninstall or repair OpenLab Help and Learning from the same link in the installer (see Uninstall OpenLab Help and Learning Only on page 105).
Optional Procedures

Improve Performance on Offline Machines

Improve Performance on Offline Machines

Computers running OpenLab CDS may exhibit slow performance when they are not connected to the Internet.

The windows operating system has routines built into its operation that causes it to continuously search for an online connection in order to update to all the latest Windows security certificates when using secure software.

Use the following system settings on all workstations to remedy this problem.

1. Open Internet Explorer and select Tools > Internet Options. In the Advanced tab, clear the following check boxes:
   - Security > Check for publisher's certificate revocation
   - Security > Check for server certificate revocation

2. Change the following registry keys:
   - [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SystemCertificates\AuthRoot]
     "DisableRootAutoUpdate"=dword:00000001
   - [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\SystemCertificates\AuthRoot]
     "DisableRootAutoUpdate"=dword:00000001

3. Document that you turned off the Root Certificates, as this can prevent users from installing other applications.
Optional Procedures
Install or Uninstall Add-ons

Install or Uninstall Add-ons

ADF Export Plug-In

Prerequisites

- The Allotrope Data Format (ADF) plug-in is not delivered with the OpenLab CDS installation medium. Download Data Export Add-on for OpenLab CDS from SubscribeNet.
- You have installed OpenLab CDS.

1. To install the plug-in:
   a. Run the installer MSI file as administrator.
   b. Follow the wizard.
   c. Install the required license.

2. To uninstall the plug-in, run the installer MSI file again as an administrator; click Remove and follow the wizard.
This chapter contains an overview of the software architecture and customization options.
OpenLab CDS is a data system solution for analytical workflows that controls a wide variety of instruments including the industry-leading GC and GC/MS-SQ instruments, along with best-in-class LC and LC/MS-SQ. By combining chromatography and single-quad mass spectrometry into a single scalable solution with centralized system administration, you can streamline your laboratory workflows and maximize productivity. A tailored and simplified user interface with a new state-of-the-art user experience, along with e-learning tools, to help you to get up to speed and productive as fast as possible.

The Agilent OpenLab CDS software is provided on read-only USB media that contains all required executable files and documents. This includes:

- Acquisition
- Data Analysis and Reporting
- Shared Services
- Content Management
- Custom Calculation Editor
- Help and Learning Platform
- User documentation
- Instrument driver software for Agilent LC, GC, LC/MS, GC/MS, or A/D
- Instrument driver software for virtual instruments (Data Player)
- Agilent Parts Finder
- Third party tools
About the OpenLab CDS Software

Software Architecture

**Workstation**: All components on a single PC; results are stored in the local file system; the system supports up to four instrument connections.

![OpenLab CDS Workstation and Workstation Plus](image)

**Figure 1** OpenLab CDS Workstation and Workstation Plus
About the OpenLab CDS Software
Software Architecture

Workstation Plus (with Content Management): All components on a single PC; results are stored in a database provided by the Content Management component; Users have no access to the data via the local file system; supports up to four instrument connections.

![Diagram of Workstation Plus Components](image)

**Data Analysis Client** | **Control Panel**
---|---
**Acquisition Client** | **Shared Services**
**Instrument Server** | **Content Management Database**

1 to 4 Instruments

**Figure 2** Components on a Workstation Plus

Local File System

All project data such as methods, raw data, results, templates, or reports are stored in the local file system. Each project has its own folder. All project folders are located in one specific Projects Root Folder.

By default, the content of the Projects Root Folder is not protected against modification or deletion from local file browsers. To ensure data integrity, select **Secure project folder** during installation, or select **Secure project folder** in the system settings of a ready installed Workstation.

When the project folder is secured, normal windows file operations are restricted to only members of the AgtSfsGroup user group. For more information, see “Local Windows Group for Secure Projects Root Folder” on page 45.
Customization

OpenLab CDS can be customized to support various workflows and applications. Customizing capabilities are available via different approaches.

For more information on how to use the different tools, refer to OpenLab Help & Learning.

Customization via custom calculations

Data Analysis can be enriched by calculating additional values. The calculations are done with the Custom Calculator Designer and referenced by or embedded in a processing method.

These calculations can be quite complex. The calculation results are directly visible in Data Analysis, no report generation is needed.

Custom calculations are processed on result set level. They are only computed if all injections of the result set are processed together.

Customization via report templates

In a report template you can call calculation results from a method-specific custom calculation, or define additional, template-specific calculation expressions. The template-specific values are only visible in the report preview or the final report.

Reports are generated on either injection level, result set level, or across multiple result sets. Reports can be used for automated result evaluation on all the mentioned levels.

Example report templates for typical petrochemical or pharmaceutical applications are provided with the application and can be imported in Data Analysis (see Import default templates in OpenLab Help & Learning).
Customize application to start external programs

The customization capabilities allow to add ribbon groups and icons in the Data Selection and Data Processing views of OpenLab Data Analysis.

It is possible to start an external program via an icon and to hand over the project data path and the path of the current injection as parameters to the program.

The customization is based on a file CustomToolsConfiguration.xml at C:\ProgramData\AgilentTechnologies\OpenLab DataAnalysis\ that needs to be created by the user. An example CustomToolsConfiguration.xml file is included on the media at Setup > Tools > Support > UCL > Customization folder.

For more information, refer to OpenLab Help & Learning.

Export raw data and results

Data Analysis offers the possibility to execute post processing plug-ins as part of the processing method. These post processing plug-ins allow to export raw data or results as part of the processing routine of single runs as well as sequence runs, also in unattended mode. Scripts are available for the export in the following formats:

- ChemStation Export (.D/.ch format)
- AIA Export (OpenLab CDS v2 raw data and peak results as netCDF format (revision 3.4) according to AIA Chromatography Data Standard Specification V1.0)
- OpenLab CDS 2 raw data export (native .dx files for ACE)

Other plug-ins such as the Allotrope Data Format (ADF) plug-in are available via SubscribeNet.
System Setup and Maintenance

Control Panel  76
Instrument Management / Lab Status at a Glance  76
License Management  77
System Activity Log  78
Diagnostics  79
Administrative Reports  79
Authentication Provider  80
Security Policy  80
User Management  80

Shared Services Maintenance  81

Maintenance Procedures  83
Introduction  83
Software backup procedure  85
Data Backup Procedure  91
Software Restore Procedure  94
Data Recovery Procedure  95

This chapter contains information on the Control Panel and Shared Services Maintenance. In addition, it describes various maintenance procedures.
Control Panel

Using the Control Panel, you can access Shared Services control features such as security policy, central configuration, or lab status at a glance.

**Instrument Management / Lab Status at a Glance**

The **Instruments** view in the Control Panel offers an overview of all instruments in the network or on the workstation. You can see the following information for all instruments, summarized on one page:

- Status of the instrument with related color code
- Instrument name
- Instrument location
- Instrument type
- Last change of configuration

Depending on the configuration, this information may be accessed from a single workstation PC or from multiple clients in a network.

You can create a tree of different locations in the Control Panel, and add instruments to these locations. Using locations, you can organize your instruments for example by department, by laboratory, or by lab bench. For each instrument, you can provide basic information such as the name, description, and instrument type.
System Setup and Maintenance
Control Panel

Depending on your privileges in OpenLab CDS, you can perform several operations on the instruments:

- View instrument information (instrument status, instrument details, activity log)
- View the locations and instruments tree
- Edit the instrument information
- Configure the instrument

The instrument configuration is stored in the Shared Services database. You access the configuration tool from the Control Panel.

- Launch the instrument

On a Workstation, you can only launch instruments that are configured on this PC.

With a Client/Server system, you can launch instruments remotely from any OpenLab CDS client in the network.

Your privileges can differ for the different locations and instruments (see “Specific Roles for Individual Instruments or Projects” on page 61).

License Management

This service includes the administration of all licenses that are required for your system.

Before adding a license file, you must first purchase the license and generate the license file using SubscribeNet. For more information on generating new license files, see “Obtain a License with SubscribeNet” on page 50.

License Management in the Control Panel provides the following functions:

- You can add license files to the license server.
- You can navigate to the license monitor and view the properties of all licenses installed on a given license server.
- You can remove license files from the license server. This may be useful if an invalid license file has been added.
- You can view or change the license server.
- You can view, copy, or save the MAC Address of the license server.
- You can navigate to the Agilent Electronic Software and License Delivery web page to obtain a license.
The following properties are shown for installed licenses:

- **Feature**: This indicates the type of license used.
- **Version**: If a license is versioned, you can see the version number. For licenses that are not versioned, the version is always shown as 1.0.
- **In Use (Available)**: This indicates the number of licenses that are currently in use and, in brackets, the total number of licenses. With the OpenLab CDS licensing strategy, a license is only in use as long as a software instance is running (see “License Types” on page 48).
- **Expiration**: If the license is only valid for a certain period of time, the expiration date is displayed.

In the **Alerts** pane, you are informed if the number of available licenses has gone down to zero for a specific feature, or if you have started a software instance which requires a license that is unavailable.

For more information on adding license files and viewing the license properties, refer to the Control Panel section in OpenLab Help & Learning.

**System Activity Log**

The System Activity Log allows you to centrally access all system activities. It contains information on the various events associated with Shared Services or with specific instruments. You can filter the list in order to view only events of a specific type, in a specific time range, created by a specific user, or containing a specific description.

The following types of events are recorded:

- System
- Instrument Management
- Instrument
- Project Management
- Instrument Controller
- User
- Group
- Security
- Printer
- License
The messages can come from other components, such as the user management, or from an instrument module. Instrument messages include error messages, system messages, or event messages. The System Activity Log records these events irrespective of whether you have been alerted to them or not. To get more information on an event, expand the line of interest in the activity logbook viewer.

Diagnostics
The **Diagnostics** view allows you to access several reports and tools for diagnostic purposes:

- Ping the server.
- Create a report, either for the local system or for the server, with information on the operation system, processors, disk drives, processes, network, and connections.
- Centrally access and download all the log files, trace files, etc. that are created by the registered modules.

Administrative Reports
In the **Administrative Reports** view, you can additionally create and export various XML or PDF reports related to the system configuration:

**Instrument Controllers Report**
Detailed information of all Instrument Controllers. When this report is generated on a Workstation, the information presented relates to the local system. When this report is generated on a client-server system, all Instrument Controllers are included.

**Instruments Report**
Provides detailed information about configuration and access privileges for all instruments on the system. On client-server systems, this report includes all instruments on all Instrument Controllers.
9 System Setup and Maintenance

Control Panel

Projects Report
Provides detailed information about configuration and access privileges for all projects on the system.

Roles and Privileges Report
Describes all roles defined on the system, including details of all privileges included in each role.

System Report
This report provides a consolidated view of the system, which includes all information about instrument controllers, instruments, projects, roles, users, and groups.

User’s and Group’s Role Assignment Report
This report provides an overview of all users and groups with their assigned roles.

Authentication Provider
The authentication provider is described under Configure an OpenLab CDS File System Workstation. For details, see “Configure Authentication” on page 56.

Security Policy
The security policy is described under Configure OpenLab CDS. For details, see “Configure Security Policy” on page 57.

User Management
The user management is described under Configure OpenLab CDS. For details, see “Configure users, roles, and privileges” on page 58.
Shared Services Maintenance

The **Shared Services Maintenance** program is automatically installed with your OpenLab software to help administrators manage the system.

To open the utility, select **Start > All Apps > Agilent Technologies > OpenLab Shared Services > Shared Services Maintenance**. A user must have Windows administrator rights to access this utility.

**Windows Domain tab**

In this utility, the **Windows Domain** tab is relevant if you use Windows domain authentication to identify your OpenLab users.

OpenLab CDS must be given access to the server where these credentials are stored. In the **Windows Domain** tab, you specify or change the credentials that OpenLab CDS will use to access your Windows domain server.

For client/server systems: This feature can only access credentials that are stored on the computer where you launched the **Shared Services Maintenance** program. To specify or change the **Domain**, **User name**, or **Password** for the Windows account that will be used to access your Windows domain server, use the **Shared Services Maintenance** program that is installed on the server.

**Server Settings tab**

The **Server Settings** tab can be used to manage different server connections. In a workstation configuration, there is typically only the connection to the local machine.

**Activity Log Export tab**

Activity log databases can become large over time and affect performance of activity log related operations. Use the **Export** and **Purge** functions on the **Activity Log Export** tab to export the activity log entries to an XML file and purge them from the Activity Log database.

**Backup and Restore tab**

The Shared Services database contains information that is accessed by the Control Panel (such as users, roles, permissions, projects, instruments etc.). In order to simplify backup and restore tasks for the Shared Services database, the **Backup and Restore** tab provides a simple interface for performing these tasks.

---

1 In Windows 7: Start > All Programs >...
To perform a Shared Services database backup:

1. Specify the backup directory and retention time.
   The retention time is used to delete any files older than specified.

2. Click **Backup**.
   The backup is placed in the specified backup directory. Backups older than
   the retention time are deleted.

**NOTE**
The tool automatically generates filenames for the backup files. Never change
these filenames, as the tool relies on a specific naming convention.

To restore to the selected Shared Services backup in the list:

1. Verify that all connections to the system are shut down before performing a
   restore.

2. Select the backup that you want to restore, then click **Restore**.

For more information on a backup of data files, see “Data Backup Procedure” on
page 91.
Maintenance Procedures

Introduction

Disaster Recovery Planning

Prepare a recovery plan for the unlikely case of OpenLab CDS becoming inoperable due to a hardware or software failure. This plan must include information and procedures for completely restoring the operating system, the software, and data. Make sure that the disaster recovery plan has been tested and confirmed to be working.

The Disaster Recovery Plan must include the following:

• Hardware information: CPU, Memory, and Hard disk configuration information.

• Computer identity: Name, IP domain, URI, etc.
  • Computer administrator information: username and passwords for logging in to the server

• Software information: OS version, Patch level.

• Installation parameters:
  • Installation folder
  • Project folder
  • Installation log files
  • Shared Services language

• Installed licenses

• Registered applications

• 3rd party software information: applications and their revisions and install paths.

• Backup procedures (see "Software backup procedure" on page 85, "Data Backup Procedure" on page 91)

• Backup media location and organization details.

• Restore procedures (see "Software Restore Procedure" on page 94, "Data Recovery Procedure" on page 95)
Backup and Restore Procedure Overview

The backup procedure for an OpenLab CDS Workstation with local file system includes all software and data. It describes how to create an image of the current system on a portable USB hard drive and a Windows system repair disc. The USB drive and repair disc are used together to restore your system to the original state, if needed.

It is mandatory that every workstation is backed up regularly. Periodic full backups and differential backups between the full backups must be created by administrators. These backups are the only way to restore a system in the event of a hardware or software failure. It is also mandatory that a disaster recovery plan and restore procedures are tested to confirm that the backups are sufficient to restore your system.

The data backup procedure does not cover other products or databases, such as the GC Column Database. Create a new system image after changing other products or databases.

This procedure requires that the user has administrative rights on the workstation.
Software backup procedure

Before the backup, make sure that the Run Queue on all active instruments is in idle state (no active run items in the queue) and all Acquisition client application are closed. Use Close Connection in the Control Panel to close any acquisitions that may still be running.

Stop Windows Services

Open Windows Services and Stop the following services in the order listed below. See Microsoft Management Console help for more information on stopping these services.

1. Agilent OpenLab Shared Services
2. Agilent OpenLab Instrument Service
Create an Image of the Current System

Create a new system image after any change in your instrument configuration.

1. Connect a portable USB drive to a (blue) 3.0 USB port on the computer.

   **NOTE**

   The AutoPlay window displays the first time the drive is connected to the PC. Close the AutoPlay window.

2. Use the appropriate Windows program to create a system image. See Windows Help for more information.
   - In Windows 7, click **Backup and Restore** in the Microsoft Control Panel.

   ![Figure 4 Windows 7 Backup and Restore](image)
In Windows 10, click File History in the Microsoft Control Panel, then click System Image Backup.

![Control Panel with File History highlighted](image)

**Figure 5** Windows File History
Click Create a system image.

Click Next.

Select the drives you want to include in the backup.

If the OpenLab product was installed in a location other than C:\ drive, you must select that particular drive when asked Which drives do you want to include in the backup?
6 Click **Next**.

![Figure 7 Drives included in the backup](image)

7 Click **Start backup**.
If you are using Windows 7, create a system repair disc according to the Windows instructions.

![Create a system repair disc](image)

**Figure 8** Create a system repair disc

If you are using Windows 10, use the **Recovery** program from the Microsoft Control Panel and create a recovery drive according to the Windows instructions.

9 Close all remaining windows.
10 Eject the newly created Windows Recovery disc.
11 Disconnect the USB drive.
12 Complete the backup Solution Checklist.

**Start Windows Services**

Open **Windows Services** (services.msc) and Start the services in the order listed below. See Services Microsoft Management Console help for more information.

1 Agilent OpenLab Shared Services
2 Agilent OpenLab Instrument Service

You might need to wait a couple of minutes for the services to fully start.
Data Backup Procedure

Before the backup, make sure that the Run Queue on all active instruments is in idle state (no active run items in the queue) and all Acquisition client application are closed. Use Close Connection in the Control Panel to close any acquisitions that may still be running.

Stop Windows Services

Open Windows Services and Stop the following services in the order listed below. See Microsoft Management Console help for more information on stopping these services.

1. Agilent OpenLab Shared Services
2. Agilent OpenLab Instrument Service
Database Backup

1. Launch the **Shared Services Maintenance** utility and select the **Backup and Restore** tab.

   ![Backup utility](image)

   **Figure 10** Backup utility

2. Specify the backup directory and retention time. When a new backup is performed, the currently set retention time is used to delete any files older than specified.

   **NOTE**
   It is recommended that you use a safe location as the backup directory (for example, a thumb drive, a network location, or an external storage device).

3. Click **Backup**.

   The backup is placed in the specified backup directory. Backups older than the retention time are deleted.
Content Backup

1. Copy the contents of the project folder specified during installation into a safe location (for example, a thumb drive, a network location, or an external storage device).

If you are using Secure Storage, either run the backup as the Windows system user, or add your current Windows user to the AgtSfsGroup local group.

NOTE

Start Windows Services

Open Windows Services (services.msc) and Start the services in the order listed below. See Services Microsoft Management Console help for more information.

1. Agilent OpenLab Shared Services
2. Agilent OpenLab Instrument Service

You might need to wait a couple of minutes for the services to fully start.

Scheduled Backup

To automate the data backup procedure, you can create a batch file performing all of the steps above and schedule it to run regularly using Windows Task Scheduler.

For your convenience, there is an example provided in the installation folder (for example, C:\Program Files (x86)\Agilent Technologies) under \BackupScripts. Please examine it carefully and adjust according to your system configuration.

NOTE

The script needs to be run with administrative privileges and as a user who has access to the project folder. If the project folder is secure, the user must be a member of the AgtSfsGroup local group.
Software Restore Procedure

Use this procedure to restore your system from an existing backup system image. See the Windows Installation documentation for detailed information.

1. Connect the recovery USB drive to a (blue) USB 3.0 port and insert the Windows Recovery DVD in the DVD drive.

2. Start or restart the PC and watch the PC monitor carefully during the restart process for the message Press any key to boot from CD or DVD... Press the space bar or any other key when the message appears. The PC will boot from the DVD.

3. Enter the appropriate information to start the Install Windows program.

4. Select Repair your computer.

5. Specify system recovery options. If you are using Windows 7, select the system recovery options according to the Windows instructions.

6. In the Select a system image backup screen, Use the latest available system image is selected by default.
   - If the auto-filled information is correct, click Next.
   - If no image match is found,
     a. Select Select a system image and click Next
     b. Select the appropriate image and click Next.
     c. Select the date and time and click Next.
7 Select **Format and repartition disks** and click **Next**.
8 Click **Finish**.
9 When the re-image process is complete, restart the system to finish the restoration.

**Data Recovery Procedure**

**Stop Windows Services**

Open Windows Services and Stop the following services in the order listed below. See Microsoft Management Console help for more information on stopping these services.

1. Agilent OpenLab Shared Services
2. Agilent OpenLab Instrument Service

![Figure 12 Stop Services](image-url)
Content Restore

1. Copy the contents of previously preserved project folder to the location used at the moment of backup.

2. To restore a system with secured project folder:
   a. Your current Windows user needs to be a member of the *AgtSfsGroup* local group.
   b. Open an Administrative command prompt (type *cmd* into the Windows Start Menu search, right click *cmd.exe*, then select *Run as administrator*).
   c. Execute the following commands:

   ```
   cd C:\Program Files (x86)\Agilent Technologies\OpenLab Services\Server
   SecureFolder.exe /group C:\CDSProjects
   ```

   **NOTE**

   In case of a non-default installation, replace `C:\Program Files (x86)\Agilent Technologies\OpenLab Services\Server` and `C:\CDSProjects` with the OpenLab CDS installation path and project folder selected during installation.

   **NOTE**

   Incorrect usage of the *SecureFolder.exe* utility (specifying folder other than the Project Root) can harm other applications or even your operating system, and potentially prevent it from starting up.
Database Restore

1. Launch the Shared Services Maintenance utility and select the Backup and Restore tab.

![Backup utility](image)

*Figure 13  Backup utility*

2. Click Browse to select the folder with previously created backups.

   **NOTE** Backups older than the retention time will not be shown.

3. Select the backup you want to restore, and click Restore.
Start Windows Services

Open Windows Services (services.msc) and Start the services in the order listed below. See Services Microsoft Management Console help for more information.

1. Agilent OpenLab Shared Services
2. Agilent OpenLab Instrument Service

NOTE: In case of a successful restore, the Shared Services service will start automatically.
This chapter describes the upgrade from OpenLab CDS 2.0 or higher to the current version of OpenLab CDS.

**CAUTION**

This chapter is not applicable if you are migrating from OpenLab CDS ChemStation Edition or OpenLab CDS EZChrom Edition.

- If you are upgrading from OpenLab CDS ChemStation Edition or EZChrom Edition, be sure to refer to the corresponding migration guide (see Appendix) prior to configuring OpenLab CDS ("Migration guides" on page 123).
License Upgrade

Get Upgraded License File

You will need to upgrade your licenses in SubscribeNet prior to upgrading to the next version of OpenLab CDS. We strongly recommend upgrading your workstation licenses before upgrading the core software. Standalone workstations which are upgraded to the new core software version, without a new workstation license, will not work until the new workstation licenses are added to the OpenLab Control Panel.

If you are under SMA subscription, proceed as follows to upgrade your licenses:

1. During the following process, you will be prompted in SubscribeNet for the host name or MAC address of the workstation where OpenLab CDS is already installed.

   To retrieve this hostname and MAC address, open the Control Panel and browse to the Administration > Licenses section. Note down the host name and use the Copy MAC Address or Save MAC Address function to obtain the MAC address.

2. Log into the Agilent Electronic Software and License Delivery (https://agilent.subscribenet.com/).

3. Navigate to Manage Licenses by Host. In the Host ID field, enter the previously noted MAC address, and click Search.

   If the relevant host name does not appear, you may be managing your licenses in multiple SubscribeNet accounts. You will need to log into those accounts to upgrade those workstation licenses.
4 If your license(s) are eligible for an upgrade, you will see the Upgrade All button. Otherwise you will need to contact your Agilent Sales Representative to renew your Software Maintenance Agreement (see "Sales and Support Assistance" on page 123). To proceed with generating your upgrade license, click the button.

5 On the Upgrade All Licenses for License Host page, review the data, and confirm by clicking Upgrade All.

This upgrades the license file to the most current version. SubscribeNet will send you an email with a new license file.

6 Put the new license file on your system (see "Add Upgraded License File to the System" on page 101).

If you have multiple standalone Workstations, repeat this step for each individual workstation.

Note that each workstation's MAC address is the file name. This helps identify the correct license file to import into the workstation's Control Panel.

Add Upgraded License File to the System

If you have purchased new options, such as additional instrument controls or client license and regenerated your license in SubscribeNet, the upgraded license file must be re-applied to the system.

1 Start the Control Panel from any machine connected to the system you want to install the license for.

2 Navigate to Administration > Licenses.

3 In the ribbon, click Remove License $\times$.

4 In the ribbon, click Add License $\uparrow$.

5 Browse to and open the license file saved from the license generation process in SubscribeNet.

6 Restart the following Windows services:
   - Agilent OpenLab License Server
   - Agilent OpenLab Licensing Support
Upgrade OpenLab CDS Workstation to Latest Version

You can upgrade an OpenLab CDS standalone workstation to the latest version using the OpenLab CDS Installation Wizard.

1. Run the Setup.exe file from the installation medium as a user with administrative rights.
2. Select OpenLab CDS.
3. In the OpenLab CDS Installer, select the Installation screen.
4. Click Install/Upgrade.
5. Provide your OpenLab CDS credentials.
6. Click Upgrade.
7. In the Upgrade screen, click Next to start the reconfiguration.
8. In the Configuration screen, click Next to start the upgrade.
10. If you use a GC/MS instrument: Upgrade the GC/MS firmware to the latest revision. The upgrade is required for the GC/MS software to work properly with OpenLab CDS 2.4.

   The supported GC/MS firmware is available after installation of OpenLab CDS in Program Files (x86)\Agilent Technologies\OpenLab Acquisition\GCMS\Firmware. Open the appropriate MS folder (5977 or 5975) and run msupdate.exe to upgrade the MS firmware.

   For more information on driver upgrades, see "Install or Upgrade Driver Software" on page 36.

   It is recommended that you reconfigure the instrument in the Control Panel.

   **NOTE**

   Upgrading a OpenLab CDS 2.2 system with GPC/SEC Software ver 1.0 installed (G7860AA)

   If upgrading a OpenLab CDS 2.2 system with GPC/SEC Software ver 1.0 installed, the GPC/SEC software must also be upgraded to Ver 1.1 after completing the upgrade process of the CDS. If the GPC upgrade is not updated the Data Analysis program will crash on loading.
This chapter describes the uninstallation of the software.
Uninstall OpenLab CDS With All of its Components

Uninstall OpenLab CDS

1. Log in as an administrator.
2. In the Microsoft Control Panel, open Programs and Features.
3. To uninstall OpenLab CDS, double-click Agilent OpenLab CDS.
   - The Agilent Uninstallation Wizard opens. In the wizard, click Uninstall.
   - The OpenLab CDS instrument drivers are automatically uninstalled together with OpenLab CDS.
4. Double-click Agilent OpenLab Shared Services.
5. Double-click Agilent OpenLab Shared Services (64 bit).
7. After uninstalling OpenLab CDS, reboot.
Uninstall OpenLab Help and Learning Only

If you installed OpenLab Help and Learning only, follow this procedure to uninstall it.

1. Insert the USB media, right-click the setup.exe file, and run it as administrator. Alternatively, copy the content of the USB media to a network share, and run the setup.exe file from there.

   ![Image of file structure]

   **NOTE**
   If User Account Control (UAC) is switched on, this step requires active confirmation to continue.
2. On the start screen, select **OpenLab CDS**, and click **OK**.
3 On the **Documentation** page, select **Install OpenLab Help and Learning Only**.

The **Agilent OpenLab CDS Help and Learning** wizard opens.
4 Select the correct language, then click **Next**.
5 **Click Remove.**

The wizard removes OpenLab Help and Learning from your system.
12 Repair the Software

This chapter contains information on repairing your OpenLab CDS system using the OpenLab Installer.

The Repair Wizard can repair installations that are broken due to corrupted or missing files, registry entries, and Window shortcuts. It cannot replace or recreate any files or items that were created after the original installation.

Prerequisites

Ensure that you run the Repair Wizard with the exact same version as the installed product.

1. Log in as an administrator.
2. Copy the entire content of the USB media to a local drive, then remove the USB media from the PC. Right-click the setup.exe file, and run it as administrator.

NOTE If User Account Control (UAC) is switched on, this step requires active confirmation to continue.
Repair the Software
Uninstall OpenLab Help and Learning Only

3. On the start screen, select OpenLab CDS, and click OK.

4. Click Repair.
Repair the Software
Uninstall OpenLab Help and Learning Only

5 Click Repair to start the repair. All listed components are automatically repaired. To abort the repair, click Cancel.

6 When the repair has finished, click Next.
Repair the Software
Uninstall OpenLab Help and Learning Only

7 Click **Finish** to close the Repair Wizard.

8 Reboot the system to complete the repair.
Appendix

Privileges in the Control Panel 115
Project Privileges  115
Instrument Privileges  121
Administrative Privileges  121
Migration guides  123
Sales and Support Assistance  123
Appendix
Privileges in the Control Panel

Privileges in the Control Panel

The privileges described in the following can be associated with different roles in the Control Panel. The following roles are available:

- Everything
- Instrument User
- System Administrator
- Technician
- Instrument Administrator
- Chemist
- Project Administrator

In the Control Panel under Administration > Roles, you can view or change the associated privileges, or create your own roles.

Project Privileges

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage project or project group</td>
<td>User can create or edit project properties and can move the project but cannot view or edit the project access settings.</td>
</tr>
<tr>
<td>Manage project or project group access</td>
<td>User can view and edit the project access settings.</td>
</tr>
<tr>
<td>View project or project group</td>
<td>User can see a project and project details but cannot edit.</td>
</tr>
<tr>
<td></td>
<td>Note: This privilege is required for all users.</td>
</tr>
<tr>
<td>Access content using web client</td>
<td>User can view the data via the Content Management web interface.</td>
</tr>
<tr>
<td>Edit content of project</td>
<td>User can create new versions of documents (e.g. data, methods, or templates).</td>
</tr>
</tbody>
</table>
## Appendix

### Privileges in the Control Panel

**Table 5  **E-Signature

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>E-Signature Sign Data Files</td>
<td>User can sign data files</td>
</tr>
<tr>
<td>Revoke E-Signature</td>
<td>User can revoke the e-signature.</td>
</tr>
</tbody>
</table>

**Table 6  **Sample Prep

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and modify sample prep</td>
<td>View, edit, and save an autosampler sample prep file</td>
</tr>
</tbody>
</table>

**Table 7  **Acquisition Method

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and modify acquisition method</td>
<td>Create, edit and save an acquisition method file (* . amx)</td>
</tr>
</tbody>
</table>

**Table 8  **Processing Method

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create processing method</td>
<td>Create a new processing method (* . pmx), or save a method under a new name.</td>
</tr>
<tr>
<td>Save master method</td>
<td>Save changes to a processing method in the Methods folder.</td>
</tr>
<tr>
<td>Save result set method</td>
<td>Save changes to a processing method in the result set folder.</td>
</tr>
<tr>
<td>Edit integration parameters</td>
<td>View and edit the parameters in the Integration Events section of a method.</td>
</tr>
<tr>
<td>Edit identification parameters</td>
<td>View and edit the parameters in the Compounds &gt; Identification section of a method.</td>
</tr>
<tr>
<td>Edit chromatogram extraction parameters</td>
<td>View and edit the parameters in the Extraction &gt; Chromatogram section of a method.</td>
</tr>
<tr>
<td>Edit spectrum extraction parameters</td>
<td>View and edit the parameters in the Extraction &gt; Spectrum section of a method.</td>
</tr>
<tr>
<td>Edit MS library search parameters</td>
<td>View and edit the parameters in the MS Library Search &gt; Properties section of a method.</td>
</tr>
</tbody>
</table>
Appendix
Privileges in the Control Panel

Table 8  Processing Method

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit calibration parameters</td>
<td>View and edit the parameters in the Compounds &gt; Calibration section of method.</td>
</tr>
<tr>
<td>Edit spectra parameters</td>
<td>View and edit the parameters in the Compounds &gt; Spectra section of method.</td>
</tr>
<tr>
<td>Edit system suitability parameters</td>
<td>View and edit the parameters in the Compounds &gt; System Suitability section of method.</td>
</tr>
<tr>
<td>Edit custom calculation parameters</td>
<td>View and edit the parameters in the Tools &gt; Custom Calculation section of a method.</td>
</tr>
<tr>
<td>Edit signal parameters</td>
<td>View and edit the parameters in the General &gt; Signals section of a method.</td>
</tr>
<tr>
<td>Edit sample purity parameters</td>
<td>View and edit the parameters in the MS Sample Purity section of a method.</td>
</tr>
<tr>
<td>Edit reporting parameters</td>
<td>View and edit the parameters in the Reports &gt; Injection Report section of a method.</td>
</tr>
<tr>
<td>Edit general parameters</td>
<td>View and edit the parameters in the General &gt; Properties section of a method.</td>
</tr>
<tr>
<td>Load older master method</td>
<td>With Content Management, load an older version of a master method.</td>
</tr>
</tbody>
</table>

Table 9  Report Template

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unlock/lock report template items</td>
<td>Lock and unlock report template items (tables, chromatograms, groups of items, ...) to control who is allowed to modify those.</td>
</tr>
<tr>
<td>Validate report template</td>
<td>Confirm usage of report templates that have been modified outside OpenLab CDS.</td>
</tr>
<tr>
<td>Create report template</td>
<td>Create and edit report templates in the Reporting view.</td>
</tr>
</tbody>
</table>

Table 10  Sequence Template

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create and modify sequence template</td>
<td>Create, edit and save sequence creation templates (*.stx).</td>
</tr>
</tbody>
</table>
### Privileges in the Control Panel

#### Table 11 Sequence

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit any users running sequence</td>
<td>Edit any user's running sequence (status Acquiring in the Run Queue).</td>
</tr>
<tr>
<td>Create and modify sequence</td>
<td>Create, edit and save sequences (*.sqx)</td>
</tr>
<tr>
<td>Edit users own running sequences</td>
<td>Edit your own running sequences (status Acquiring in the Run Queue).</td>
</tr>
<tr>
<td>Edit method override parameters</td>
<td>Override parameters in a predefined acquisition method.</td>
</tr>
</tbody>
</table>

#### Table 12 Audit Trail

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change method audit trail settings</td>
<td>Edit and save method audit trail settings (project properties in the Control Panel).</td>
</tr>
<tr>
<td>Review audit trail</td>
<td>Confirm that you reviewed a changed audit trail.</td>
</tr>
<tr>
<td>Add manual audit trail entry</td>
<td>Add a manual entry to document your own actions in the audit trail.</td>
</tr>
</tbody>
</table>

#### Table 13 Control

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abort any running sample</td>
<td>Abort any running sequence or single run.</td>
</tr>
<tr>
<td>Manual control (in run)</td>
<td>Access manual control functions while the instrument is running.</td>
</tr>
<tr>
<td>Manual control (only when instrument idle)</td>
<td>Access manual control functions while the instrument is idle.</td>
</tr>
<tr>
<td>MS autotune and manual tuning</td>
<td>Access all MS tune and maintenance functionality, including manual tune, autotune, and check tune.</td>
</tr>
<tr>
<td>MS autotune</td>
<td>Perform MS autotune and check tune.</td>
</tr>
<tr>
<td>Delete any pending runs</td>
<td>Remove pending runs from the Run Queue.</td>
</tr>
<tr>
<td>Reorder pending runs</td>
<td>Change order of pending runs in the run queue.</td>
</tr>
</tbody>
</table>
### Appendix

#### Privileges in the Control Panel

**Table 14  Data Processing**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reprocess data</td>
<td>Reprocess injections or result sets.</td>
</tr>
<tr>
<td>Do manual compound identification</td>
<td>Manually assign a compound to a peak.</td>
</tr>
<tr>
<td>Do manual integration</td>
<td>Activate manual integration in the Chromatograms window.</td>
</tr>
<tr>
<td>Do manual chromatogram extraction</td>
<td>Manually extract UV wavelength chromatograms or MS (TIC-SIM/TIC-SCAN)</td>
</tr>
<tr>
<td></td>
<td>chromatograms from your data.</td>
</tr>
<tr>
<td>Do manual spectrum extraction</td>
<td>Manually extract UV or MS spectra from your data.</td>
</tr>
<tr>
<td>Do manual MS library search</td>
<td>Manually search for matches in an MS library.</td>
</tr>
<tr>
<td>Update master processing method</td>
<td>Save changes from a result set method to the corresponding master processing method in the Methods folder.</td>
</tr>
<tr>
<td>Create new result set</td>
<td>Combine single samples or sequences from different sources in a new, self-assembled result set.</td>
</tr>
<tr>
<td>Print results reports</td>
<td>Create reports for your methods or results.</td>
</tr>
<tr>
<td>Launch Custom Calculation Editor</td>
<td>Start the Custom Calculation Editor from Data Analysis.</td>
</tr>
</tbody>
</table>

**Table 15  File and Folder Operations**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete report templates</td>
<td>Delete report templates (*.rdl) in the Data Selection view of Data Analysis.</td>
</tr>
<tr>
<td>Delete sequence templates</td>
<td>Delete sequence templates (*.stx) files in the Data Selection view of Data Analysis.</td>
</tr>
<tr>
<td>Delete methods</td>
<td>Delete processing methods (<em>.pmx) or acquisition methods (</em>.amx) in the Data Selection view of Data Analysis.</td>
</tr>
</tbody>
</table>
## Privileges in the Control Panel

### Table 16 Data

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export data</td>
<td>Export data into an OpenLab archive (*.olax).</td>
</tr>
<tr>
<td>Import data</td>
<td>Import data from OpenLab archives (*.olax) into the OpenLab system.</td>
</tr>
<tr>
<td>Save reports to disk</td>
<td>Save or export a report to a location on a disk or network share.</td>
</tr>
<tr>
<td>Edit sample information</td>
<td>Edit information in the <a href="#">Injection List</a> window.</td>
</tr>
</tbody>
</table>

### Table 17 Lock

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lock Results</td>
<td>Lock a result set to protect it from being changed.</td>
</tr>
<tr>
<td>Unlock Results</td>
<td>Unlock a locked result set.</td>
</tr>
</tbody>
</table>

### Table 18 Custom Tools

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access Custom Tools section</td>
<td>Start external programs that were added to the application via the customization tool</td>
</tr>
</tbody>
</table>

### Table 19 Snapshot

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Review snapshot results</td>
<td>From Acquisition, open a currently running sample in Data Analysis.</td>
</tr>
</tbody>
</table>
Appendix
Privileges in the Control Panel

Instrument Privileges

Table 20  Instrument Management

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View instrument or location</td>
<td>User can view and access a location in the tree, but not edit access security, can view properties.</td>
</tr>
<tr>
<td>Manage Instrument or location</td>
<td>User can create and move locations and edit properties (name, description, etc).</td>
</tr>
<tr>
<td>Manage instrument or location access</td>
<td>User can view and edit the location access settings.</td>
</tr>
<tr>
<td>Run instrument</td>
<td>User can start an instrument session.</td>
</tr>
<tr>
<td>Service instrument</td>
<td>User can lock or unlock an instrument (to service it).</td>
</tr>
</tbody>
</table>

Administrative Privileges

Table 21  System Administration

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage printers</td>
<td>Can add/remove printers and print server.</td>
</tr>
<tr>
<td>Edit activity log properties</td>
<td>Can change the Activity log Settings in the Control Panel (that is, can turn logging on for the System Activity Log).</td>
</tr>
<tr>
<td>Create administrative reports</td>
<td>Can create any of the system admin reports.</td>
</tr>
<tr>
<td>Manage system components</td>
<td>Can install/remove components (applications).</td>
</tr>
<tr>
<td>Manage security</td>
<td>Can change security settings and assign security roles. Can edit (add, change etc) users, groups and roles. Can move and delete files and folders in the Content Management database. Note: A user with this privilege can grant himself access to all settings in Shared Services. Be careful who you grant the Manage Security privilege.</td>
</tr>
</tbody>
</table>
## Appendix

### Privileges in the Control Panel

#### Table 21  System Administration

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage instrument controllers</td>
<td>Can edit Instrument Controllers in the Control Panel.</td>
</tr>
<tr>
<td>Unlock any locked UI</td>
<td>Can log in to another user's locked session.</td>
</tr>
</tbody>
</table>

#### Table 22  Content Management

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Archive content</td>
<td>User can archive the content of the Content Management data repository.</td>
</tr>
<tr>
<td>Manage Templates</td>
<td>View, create, update and delete PDF templates.</td>
</tr>
</tbody>
</table>
Appendix

Migration guides

The following guides provide instructions for migrating data, instrument information, and user information. For migration from OpenLab CDS, the Migration Tool simplifies the migration process. You find these guides on the installation medium under \Setup\Tools\Migration\User Guides and Setup\Tools\Migration\Linked PDF docs.

- Agilent Migration Tools for OpenLab - OpenLab CDS ChemStation and EZChrom Edition to OpenLab CDS Workstation  
  (OpenLabMigrationTool_en.pdf)

- Migrating from OpenLab CDS ChemStation Edition to OpenLab CDS Version 2.3 – Workstation to Workstation  
  (MigrationGuide_OpenLabCDSChemStnToCDS2.3.pdf)

- Migrating from OpenLab CDS EZChrom Edition to OpenLab CDS Version 2.3 – Workstation to Workstation  
  (MigrationGuide_OpenLabCDSEZChromToCDS2.3.pdf)

- Migrating from ChemStation B to OpenLab CDS Version 2.3 – Workstation to Workstation  
  (MigrationGuide_ChemStationBToCDS2.3.pdf)

- Migrating from EZChrom Elite to OpenLab CDS Version 2.3 – Workstation to Workstation  
  (MigrationGuide_EZChromEliteToCDS2.3.pdf)

Sales and Support Assistance

Please check the following web site for your local sales and support contact:

In This Book

This document provides instructions for installation, configuration, administration, and maintenance of an OpenLab CDS Workstation. It includes information on the license generation with SubscribeNet and operating system configuration.

The manual describes the following:

- Install OpenLab CDS Workstation with Local File System
- Generating and Downloading Your Software License
- Configure OpenLab CDS Workstation
- Optional Procedures
- Customization
- About the OpenLab CDS software
- System Setup and Maintenance