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In this Guide ...

This installation guide provides instructions to install and configure Agilent Secure 
Workstation for OpenLab CDS ChemStation Edition.

1 Prepare your PC

This chapter describes how to configure a non-Agilent-delivered PC. 
Agilent-delivered PC Bundle systems are delivered with the supported pre-installed 
Windows operating system and are configured for optimum performance. 
Non-Agilent PCs require some manual configuration changes in order to provide 
optimum performance.

2 Install the Software

The installation is automated by the OpenLab CDS ChemStation Edition Installer. 
This tool installs all components needed.

3 Post Installation Tasks

This chapter describes tasks that are relevant after finishing the installation.

4 Optional Procedures

This chapter contains information on the Additional Drivers and Software wizard 
and other helpful procedures.

Table 1 Terms and abbreviations used in this document

Term Description

AIC Agilent's Analytical Instrument Controller

CDS Chromatography Data System

ChemStation OpenLab CDS ChemStation Edition

Control Panel OpenLab Control Panel

Microsoft Control Panel Part of the Microsoft Windows operating system

Secure Workstation Secure Workstation for OpenLab CDS ChemSta-
tion Edition
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5 Secure File I/O

This chapter describes how to protect your ChemStation folders with Secure File 
I/O.

6 Secure Workstation for OpenLab CDS ChemStation Edition Licensing

This chapter describes the licensing of a Secure Workstation for OpenLab CDS 
ChemStation Edition.

7 Configure Secure Workstation for OpenLab CDS ChemStation Edition

This chapter describes the configuration of Secure Workstation for OpenLab CDS 
ChemStation Edition.

8 Upgrade Secure Workstation

This chapter describes the upgrade of Secure Workstation for OpenLab CDS 
ChemStation Edition.

9 Uninstall the Software

This chapter contains information on the uninstallation by using the OpenLab 
Uninstallation Wizard.

10 Troubleshooting

The chapter gives some troubleshooting hints.
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This chapter describes how to configure a non-Agilent-delivered PC. 
Agilent-delivered PC Bundle systems are delivered with the supported 
pre-installed Windows operating system and are configured for optimum 
performance. Non-Agilent PCs require some manual configuration changes in 
order to provide optimum performance.
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1 Prepare your PC
Install and Update Windows

Install and Update Windows

1 Install the Windows operating system from the Microsoft installation media 
or qualified PC image media provided by your IT department. During the 
setup, provide the computer name, administrator password and network 
settings. Choose to either join an existing domain or set up the system in a 
workgroup mode.

2 For Windows 10 Pro users: Update to the latest Windows 10 edition in 
accordance to the guidelines of your local IT department.

3 To secure your system against viruses please install an antivirus program. Be 
sure to open the firewall ports listed in the Firewall Settings in the OpenLab 
CDS ChemStation Edition Requirements guide 
(CDS_CS_HW-SW-Requirements.pdf), including the ports listed for OpenLab 
Server in the tables 14 and 15..

4 In the Microsoft Control Panel under System> Windows activation, click 
Change product key. Enter a valid value to activate Windows.

5 Under Windows Update, click Check for updates to check for updates and apply 
all critical security patches. Make sure that all Windows updates have been 
performed before installing ChemStation (update settings may be configured 
centrally by your IT department).

6 Disable or defer Windows updates (update settings may be configured 
centrally by your IT department):
• Windows 7:

a In the Microsoft Control Panel, select Windows Update.
b Select Change settings.

NOTE Running antivirus programs might influence the behavior and performance of 
your computer. Some virus scanners might cause issues when used with 
OpenLab CDS. The application is tested with Symantec Endpoint Protection 14.0 
MP2 and with Microsoft Security Essentials.

NOTE This setting is important to avoid data loss due to system reboot during data 
acquisition.
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1 Prepare your PC
Install and Update Windows

c In the Important updates section, select Never check for updates. Clear 
the other update options.

d Restart the computer after update.
• Windows 10:

a Under Settings> Update & Security, select Advanced options.
b Enter the number of days by which the update should be deferred.

7 Windows 10 and Windows 7 only: To configure remote settings: In the 
Microsoft Control Panel navigate to System> Remote settings. On the Remote 
tab:
• In the Remote Assistance section, clear the check box Allow Remote 

Assistance connections to this computer.
• In the Remote Desktop section, select Don't allow connections to this 

computer.
8 In the Microsoft Control Panel under Date and Time: Choose the time zone of 

your regional location.
9 In the Microsoft Control Panel under Region (Region and Language for 

Windows 7):
a Regional format options should be set to English (United States) from the 

drop-down list.
b If regional format other than English (United States) is used, the following 

settings are mandatory. The settings can be defined by clicking on the 
Additional settings... button:
• Decimal symbol = . (point)
• Digit grouping symbol = , (comma)
• List separator =, (comma)

10 In the Microsoft Control Panel under Region (Region and Language for 
Windows 7), on the Administrative tab:
a In the Language for non-Unicode program section, click Change system 

locale....
b From the drop down list, select English (United States).

NOTE Do not change the system locale if you are using an English, Japanese or 
Chinese Operating System.
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1 Prepare your PC
Run the Site Preparation Tool

Run the Site Preparation Tool

1 Run the installer from the USB medium or from a centralized folder. From the 
Planning screen, select System Configuration Checker.

2 The Site Preparation Tool opens. From the drop-down list, select: Secure 
Workstation for OpenLab CDS ChemStation Edition.

3 Select OK.
4 Complete page 1 of the Contact Information—System details by typing in the 

fields provided.
• System Location fields
• System Information fields
• Configuration fields

5 Review the system details and make any necessary entries. The system will 
follow the paths specified.

6 Select the green check mark icon in the top left corner of the screen to begin 
the software check. A summary report is displayed showing the results for 
each check category. Results are expressed as Pass, Warning, Critical Warning, 
or Fail.
Fail results must be corrected before continuing with the installation. Agilent 
recommends investigating and correcting any Critical Warnings and Warnings 
whenever possible before proceeding.

7 To view details of the report, select the appropriate link: System Hardware 
Details, Operating System and Software Details, or Manual Verification Required.

8 To save the report, select the Save icon at the top left of the screen.
9 E-mail the saved report to your Agilent Service Representative for evaluation, 

and for validation of your personal computer for Agilent Software Systems 
Installs.

NOTE If the firewall is controlled by security software, the Site Preparation Tool cannot 
read the firewall settings because of security limitations and will display Status 
"Fail" for the firewall settings.

In this case, make sure the firewall is disabled and enter the status in the Site 
Preparation Tool report manually.
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1 Prepare your PC
Install and Configure Third Party Tools

Install and Configure Third Party Tools

Certain third party tools must be installed and configured on your PC. Some of 
these tools can be installed directly from the Installation screen if you run the 
OpenLab CDS ChemStation Edition Installer.

Install and Configure Adobe Acrobat Reader

Check if an existing Acrobat Reader version must be uninstalled
1 If Acrobat Reader is already installed, check its version number.

a Open Acrobat Reader.
b Select Help> About Adobe Acrobat Reader.

2 The version number has several ranges. The Continuous or Classic track is 
indicated by the first two digits of the third range.

20 = Continuous track
30 = Classic track

NOTE If an older version of Acrobat Reader (2016 or lower, XI or lower) or a Reader 
version from the Continuous track (even with Acrobat Reader 2017) is installed 
on your system, you must uninstall it first. Otherwise, the installation below 
would result in an Acrobat Reader version that pushes automatic updates.
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1 Prepare your PC
Install and Configure Third Party Tools

Install Adobe Acrobat Reader 2017 (Classic Track):
1 Under Third Party Tools, select Adobe PDF Reader.
2 The Acrobat Reader setup screen appears. Click Install to continue.
3 If Acrobat Reader was successfully installed, click Finish to exist the setup 

screen.
Alternatively, you can install Acrobat Reader from the ChemStation 
installation medium. It is available under Disk1/Tools/Adobe Reader.
Run AcroRdr_MUI.bat and follow the instructions of the Adobe Reader Setup 
wizard.

4 Open the newly installed Adobe Acrobat Reader to confirm the Adobe Reader 
license agreement. You will be asked only this one time.

Configure Adobe Acrobat Reader in Windows:
1 Set Adobe Acrobat Reader as your default PDF viewer.

a Windows 7: In the Microsoft Control Panel, navigate to Default Programs> 
Set default programs, select Adobe Acrobat Reader from the list, and click 
Set this program as default.
OR
Windows 10: Navigate to Settings> Apps> Default Apps, select Choose 
default apps by file type. In the list, navigate to .pdf and select Adobe 
Acrobat Reader as default.

b Select Adobe Acrobat Reader as default PDF viewer.
2 Disable the Adobe Update Service.

a In the Windows Start menu, search for Services. In the results, click the 
Services Desktop app.

b Stop the Adobe Acrobat Update Service.
c In the service properties, set the startup type to Manual.



Secure Workstation for OpenLab CDS ChemStation Edition Installation 13

1 Prepare your PC
Install and Configure Third Party Tools

Ensure correct Adobe Acrobat Reader settings:
1 Click Edit> Preferences in Acrobat Reader.
2 Select the General category.

a Ensure that the Open documents as new tabs in the same window check box 
is cleared. If it is selected, Acrobat Reader may interfere with the 
ChemStation Report Viewer feature.

b Clear the Show me messages when I launch Adobe Acrobat Reader check 
box. If it is selected, Adobe messages may interfere with the ChemStation 
software.

3 Select the Security (Enhanced) category.
a Ensure that the Enable Protected Mode at startup check box is selected.
b Ensure that the Enable Enhanced Security check box is selected.

4 Select the Tracker category.
Ensure that the Show notification icon in system tray check box is cleared.

Update Acrobat Reader regularly
1 Update Adobe Acrobat Reader on a regular basis to avoid push notifications 

from Adobe.
We recommend to include Acrobat Reader updates in a regular update 
schedule. Acrobat Reader updates usually come on a quarterly basis.

2 To update, open Acrobat Reader, and click Help> Check for Updates....
3 After an update, ensure that the Adobe Acrobat Update Service is still stopped.

Install Keysight IO Libraries Suite
IO Libraries are required only for LC/MS and CE/MS instruments.

To install IO Libraries:
1 From the installer, select Installation.
2 Under Third Party Tools, select Keysight IO libraries.The Keysight IO libraries 

setup screen opens.
3 Click Install to continue.
4 When Keysight IO libraries have been successfully installed, click Finish to exit 

the setup screen.
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1 Prepare your PC
Install and Configure Third Party Tools

Install the .NET Framework

Install .NET 3.5

If .NET 3.5 is not installed on your system, its installation will automatically be 
triggered by the installation wizard. Follow the procedure below to install it in 
advance.
1 Go to the Microsoft Control Panel.

In the Windows Start menu, enter "Control Panel" in the Search programs and 
files field (alternatively, press [Win+R] and enter "Control panel"). To view all 
items in the Control Panel view, select Small icons in the View by field.

2 Go to Programs and Features.
3 Go to Turn Windows features on or off.
4 Enable .NET 3.5 as follows:

This requires an internet connection.
• For Windows 10: Expand the .NET Framework 3.5 (includes .NET 2.0 and 

3.0) node,
• For Windows 7: Expand the Microsoft .NET Framework 3.5.1 node,
in both cases select the Windows Communication Foundation Non-HTTP 
Activation check box.

Figure 1 Enable .NET 3.5 (Win 10)

NOTE If this does not work as expected, or the computer has no internet access, install 
.NET 3.5 from the Windows installation media. For Windows 10, see details 10 
under https://support.microsoft.com/en-us/kb/2734782.

If you do not have installation media, create them as described under 
https://www.microsoft.com/en-us/software-download/windows10.
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1 Prepare your PC
Install and Configure Third Party Tools

Install .NET 4.7

If .NET 4.7.2 is not installed on your system, its installation will automatically be 
triggered by the installation wizard. When manually installing .NET 4.7.2, 
Windows requires write access to the installation files. Direct installation from 
USB media is therefore not possible.
1 Copy the folder Disk1\Tools\DotNet4.7 to a local disk.
2 Run dotNetFx_Full_x86_x64.bat.
3 Follow the installation wizard.
4 Restart the computer.
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1 Prepare your PC
Configure a Printer

Configure a Printer

Physical Default Printer

Make sure that a default printer is configured in Windows. Every Windows user 
who runs ChemStation needs a default printer configured in the user profile. The 
printer driver must be for a physical printer, even if the printer is not connected. 
Configuring a to-file printer such as a PDF or XPS writer is not sufficient.

This is done via the Microsoft Control Panel. If no default printer is configured the 
following problems may occur:
• Printing of a report preview will fail
• the Copy To Clipboard menu will have an error
• the Custom Report View will have problems with new templates

PDF XChange printer

During the installation of ChemStation C.01.10, a PDF XChange 6 printer driver is 
installed (revision 6.0.317.1).

Print Limitations

The maximum number of pages for one print job is 1500; for example, a 
sequence summary report is one print job.

When printing Multi-Page chromatograms (specified in the Specify Reports dialog 
box), the maximum number of pages that can be printed properly depends on the 
resolution of the printer. 300 dpi allows ten pages per chromatogram, 600 dpi 
allows up to six pages per chromatogram.
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1 Prepare your PC
Configure a Printer

Add a Network Printer as a Local Printer
Use physical printers to ensure correct function. Follow the steps below to add a 
network printer as a local printer. In Secure Workstation for OpenLab CDS 
ChemStation Edition, you will be able to choose this printer as a default printer 
when configuring instruments.
1 In the Microsoft Control Panel, navigate to Devices and Printers.
2 Click Add a Printer.
3 Click The printer I want isn't listed, then select Add a local printer and click Next.
4 Select Create a new port, then select Local Port for the port type and click Next.
5 For Port Name, enter the network path to the printer. The network path 

consists of two slashes, the computer name or local IP address of the PC 
sharing the printer, and the share name of the printer. For example, \\
PTPRINT\PG5-B or \\192.168.1.100\hpprinter.

6 Select the appropriate printer driver and click Next. If the exact model is not 
listed, try the closest model number or a generic printer.

7 Follow the rest of the wizard.

NOTE The print quality of graphics and pictures depends on the printer hardware, 
maintenance state, configuration, printing options, and paper quality. Resizing 
pictures and graphics during the print process may lead to a reduced print 
quality. Choose paper format and page margins that are suitable for your printer.
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1 Prepare your PC
Before You Begin the Installation of ChemStation

Before You Begin the Installation of ChemStation

To simplify installation of the software, it is helpful to decide on some 
configuration options before you begin the actual software installation.
1 Decide on a computer name.

The computer name will be reflected in the instrument configuration. To avoid 
considerable effort, it is recommend to keep the computer name unchanged 
after installing Secure Workstation for OpenLab CDS ChemStation Edition.

2 Make sure that you use only the following characters for user names:

3 May sure you have administrator privileges for your workstation. Power user 
privileges are not sufficient (the installation does not start).

4 Decide on a directory location to store all files related to the data system 
software, including data, methods, sequences, and configurations.

5 Decide on the software delivery approach you want to use:
• Install directly from the USB medium — Insert the USB medium directly at 

the workstation computer. (Recommended)
• Copy installation files to a centralized location — You can use the utility to 

copy the installation files, for example, to a network share folder, and run 
the installation from that location. However, some networks may interfere 
with installation (see “Copy installation Files to a Centralized Folder for 
Installation” on page 43).

NOTE To make sure that a DNS server can resolve the computer name, follow the 
internet standard for protocols(RFC952) and use only the following characters:

• Letters (a-z, A-Z)

• Digits (0-9)

• Hyphen (-)

Do not use an underscore.

A-Z, a-z, 0-9, _ (underscore), - (hyphen)
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1 Prepare your PC
Before You Begin the Installation of ChemStation

6 Before you install the software, check that your computer meets all 
requirements. You can access the OpenLab CDS ChemStation Edition 
Requirements guide (CDS_CS_HW-SW-Requirements.pdf) from the 
Documentation and Learning platform.
a On the installation media, go to Disk1\DOCS\ and open welcome.html to 

access Documentation and Learning.
b Select your language.
c On the Welcome page, navigate to Site Preparation> Site Preparation and 

Requirements, and select CDS ChemStation Edition Hardware and Software 
Requirements.
Use this PDF to check that your settings comply with the network 
requirements, and to determine whether your hardware and software will 
support the system.

7 Install all required hardware, including any A/D connections, interfaces, 
instrument detectors, and communication cables.

8 To allow the successful installation and activation of all components, make 
sure that the LAN-cable is connected and a network is available. A local 
network is sufficient. If you install the Secure Workstation without a network 
cable, the Content Management activation will fail, and trying to access 
Content Management will return an error.

9 Make sure that the antivirus software is disabled during the installation.
10 Ensure that the latest graphic card driver is installed. Install the latest 

vendor-specific driver. Do not use any generic driver.
11 Disable hardware acceleration. Ensure that the following registry key is 

present and correctly set:
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics]
"DisableHWAcceleration"=dword:00000001

12 Make sure .NET 3.5 and .NET 4.7 are activated as Windows features.
For installation instructions, see “Install .NET 3.5” on page 14 and “Install .NET 
4.7” on page 15.

13 Check the Agilent Service Notes for software updates for your installation 
package and software products. Service Notes are available from your Agilent 
support representative.
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Configure the Operating System

Configure the Operating System

PC Configuration Checker
The OpenLab CDS ChemStation Edition configuration check tool helps to prepare 
or troubleshoot the Operating System configuration and to prevent computer 
problems.

This tool offers two types of configuration checks:
• Mandatory: It checks and repairs all mandatory settings which should be 

applied before installing OpenLab ChemStation Edition.
• Optional: It checks the settings for performance and usability. The 

configuration settings are user-specific and must be set separately for each 
user.

The tool comes as .diagcab file, which is a file format used with the Microsoft 
Windows Troubleshooting Platform (WTP) program. The Microsoft Windows 
Troubleshooting Platform (WTP) is a platform to locate and fix hardware and 
software settings in Windows. It is used specifically for diagnosing and repairing 
computer settings.

In general, .diagcab files are useful for deploying troubleshooting packs because 
they are self-contained and require no installation. The .diagcab file name 
extension is a registered file name extension that can be executed by WTP.

Depending on whether it is a configuration check for mandatory or optional 
settings, different .diagcab files must be executed:
• To perform the configuration check for mandatory settings, you must use the 

file Agilent.Wtp.ChemStation.WindowsConfiguration.diagcab. This file is 
located in Disk1\Tools\Windows Configuration Tools\Mandatory Settings.

• To perform the configuration check for optional settings, you must use the file 
Agilent.Wtp.ChemStation.WindowsConfiguration.diagcab. This file is located in 
Disk1\Tools\Windows Configuration Tools\Optional Settings.

NOTE If User Account Control (UAC) is switched on, some configuration steps will 
require active confirmation to continue.
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1 Before starting the configuration check, copy the .diagcab files to a local disk.
2 Run the tool as administrator to ensure all settings will be applied: On the start 

page, select Advanced, then click Run as administrator.
After the settings have been applied, you can generate a report to see which 
settings have been changed.

3 To create the report:
a On the Troubleshooting Complete page, click View details.
b Click on the print button to generate the report.

4 Reboot the PC after running the configuration tool.

Manual Configuration Steps
Some Windows changes within this document are mandatory for Secure 
Workstation for OpenLab CDS ChemStation Edition to work properly on a 
Windows system. Some changes will optimize application performance. Other 
changes will have an impact on usability.

The configuration settings are grouped according to their relevance for the 
Windows system in the Mandatory, Performance, and Usability categories. 
Depending on your operating system, some special configuration steps may be 
required.

The following sections describe the configuration steps for each category 
separately. Configure your Windows system accordingly. Alternatively, run the 
OpenLab CDS configuration check tool (see “PC Configuration Checker” on 
page 20).

NOTE While using the Configuration Checker:

• Ensure that this computer is not turned off by another user.

• Win 7: Ensure that the menu bar is enabled (click Organize> Layout, and select 
Menu bar).

• It is very important that you reboot the PC after running the configuration tool.

NOTE The following Windows 10 descriptions apply to Windows 10 Build 1809. The 
settings for other builds may differ slightly.
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Mandatory Configuration Steps

The procedures of this section contain all the configuration steps required for 
installation and necessary to ensure proper installation and avoid data loss.

In the Microsoft Control Panel:

In the Windows Start menu, enter "Control Panel" in the Search programs and files 
field (alternatively, press [Win+R] and enter "Control panel"). To view all items in 
the Control Panel view, select Small icons in the View by field.
1 Administrative Tools: Configure security options:

a Double-click Local Security Policy.
b Navigate to Security Settings> Local Policies> Security Options.
c Double-click the following policy listed in the right hand panel: Network 

Access: Sharing and security model for local accounts.
d In the displayed dialog select the following item from the drop-down list: 

Classic - local users authenticate as themselves.
2 Network and Sharing Center:

a Select Change adapter settings. Right-click your Ethernet Adapter, then 
select Properties. On the General tab, click Configure.

b On the Power Management tab, clear all check boxes.
3 Power Options:

a As preferred plan select High performance.
b Click Change Plan settings.
c Set the option Put the computer to sleep to Never.
d Click Change advanced power settings.
e Open the nodes for Hard disk> Turn off hard disk after.
f Set the Minutes to 0 (=Never).

NOTE For Windows 7 users:

Ensure that Windows hotfix KB2999226 (Update for Universal C Runtime in 
Windows) is installed on your system before installing ChemStation. See 
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-ru
ntime-in-windows.
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4 Programs and Features:
a Click Turn Windows features on or off.
b Select the Telnet Client check box.
c Select the TFTP Client check box.
d Reboot the PC if necessary.

5 Windows 7 only:
Administrative Tools: Disable Services.
• Double-click Services.
• For the following services, set the startup type to Disabled:

• Application Experience
• Desktop Window Manager Session Manager

Other Windows settings:
1 To configure Windows logon options, right-click Start, select Run from the 

context menu, then type gpedit.msc in the Run field.
a Navigate to Local Computer Policy> Computer Configuration> Administrative 

Templates> System> Logon.
b Set Hide entry points for Fast User Switching and Always use classic logon to 

Enabled.
2 Windows 10 only: Start> Settings> Update & Security> Windows Security:

a Under App & browser control:
Turn off SmartScreen under Check apps and files, SmartScreen for 
Microsoft Edge, and SmartScreen for Windows Store apps.

b Under Virus & threat protection:
Ensure that a protection tool is turned on.
If you want to use Windows Defender: Enable and configure it in the 
Windows Control Panel under Windows Defender Firewall> Advanced 
Settings.

3 Windows 10 only: Start> Settings> Devices> Printers & scanners: Choose 
default printer.
a Turn off Let Windows manage my default printer.
b Click the printer that you want to set as default, then click Manage.
c In the printer settings, click Set as default.
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4 Windows 10 version 1903 only:
If the Net.TCP Port Sharing Service is disabled, enable it by running the 
PowerShell command: 
Enable-WindowsOptionalFeature -online -All -FeatureName 
WCF-TCP-Activation45

Performance Configuration Steps

The procedures of this section contain configuration steps that improve system 
performance. These settings are optional.

In the Microsoft Control Panel:
1 System: Change system properties:

a Click Advanced system settings.
b On the Advanced tab under Performance, click Settings.

• Advanced tab > Virtual Memory: For optimum performance use the 
Change button to adjust the paging file size to a value of 2 to 3 times of 
the physical RAM on the PC. If possible locate the paging file on a drive 
different from the system installation drive.

• Data Execution Prevention tab: Select Turn on DEP for essential Windows 
programs and services only.

Click OK to close the Performance Options dialog.
c For Windows 10 and Windows 7 only: On the System Protection tab:

Make sure that Protection is turned off. If required, click Configure and 
select Disable system protection.

2 Windows 10 and Windows 7 only: Indexing Options: Disable indexing.
Click the Modify button. Select Show all locations, and clear all drives and 
locations.

Other Windows settings:
1 Windows 10 only: Start> Settings> Personalization> Colors: Turn Transparency 

effects off.

Usability Configuration Steps

The procedures of this section contain configuration steps that improve the 
usability of the Windows application. These settings are optional.
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In the Microsoft Control Panel:
1 File Explorer Options (Folder Options for Windows 7): In the View tab:

• Select Always show menus.
• Select Display the full path in the title bar.
• Clear Hide extensions for known file types.
• Clear Use Sharing Wizard.

2 System: Change system properties:
a Click Advanced system settings.
b On the Advanced tab under Startup and Recovery, click Settings.

• In the System startup section:
Change both Time to display ... fields from 30 to 3 sec.

• For Windows 10 and Windows 7 only: In the System failure section:
a Select Automatically restart.
b In the Write debugging information subsection, select Kernel memory 

dump from the drop-down list.
Click OK to close the Startup and Recovery dialog.

c On the Advanced tab under Performance, click Settings. On the Visual 
Effects tab:
• Select Adjust for best performance, then click Apply.

Select Custom, then select the following check boxes for better 
usability:
• Show shadows under mouse pointer
• Show shadows under windows
• Smooth edges of screen fonts

Click OK to close the Performance Options dialog.

Other Windows settings:
1 Enable the navigation pane:

• Windows 10: Open Windows Explorer, then select View> Navigation pane 
from the ribbon and make sure that Navigation pane is selected.

• Windows 7: Open Windows Explorer, then select Organize> Details> Layout 
and make sure that Navigation pane is selected.
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2 Windows 7 only: Configure general layout of the Start Menu: (right-click Start> 
Properties)
a Start Menu Tab: In the Privacy section select both items
b Start Menu Tab > Customize button: In Customize Start Menu dialog:

• Clear the following option:
• Favorites menu

• Select the following options:
• Computer Display as a link
• Connect To
• Control Panel: Display as a menu
• Default Programs
• Devices and Printers
• Documents: Display as a link
• Enable context menus and dragging and dropping
• Games: Don't display this item
• Help
• Highlight newly installed programs
• Music: Don't display this item
• Network
• Open submenus when I pause on them with the mouse pointer
• Personal folder: Display as a link
• Pictures: Display as a link
• Run command
• Search other files and libraries Search with public folders
• Search programs and Control Panel
• Sort All Programs menu by name
• System administrative tools: Display on the All Programs menu and in 

the Start menu
• Use large icons
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3 Windows 10 and Windows 7 only: Configure Windows logon options: 
Right-click Start, select Run from the context menu, then type gpedit.msc in 
the Run field.
a Navigate to Local Computer Policy> Computer Configuration> Administrative 

Templates> System> Logon.
b Set Don't display the Getting Started welcome screen at logon to Enabled.

4 Recycle Bin Properties: (right-click on desktop icon Recycle Bin, then select 
Properties) Select the following options:
• Custom size: Select a size corresponding to approximately 10% of the 

complete disk space for the drive.
• Select Display delete confirmation dialog.
Repeat these steps for all drives of your computer.

5 Select Internet Explorer as default Web browser:
• Windows 10 only:

a Under Start> Settings> Apps> Default Apps, select the Internet Explorer 
as default Web browser.

• Windows 7 only:
a In the Microsoft Control Panel under Default Programs> Set your default 

programs, select Internet Explorer from the list.
b Click Set this program as default.

6 Windows 10 only: Start> Settings> System> Tablet Mode:
a For When I sign in, select Use desktop mode.
b For When this device automatically switches tablet on or off, select Don't ask 

me and don't switch.
7 Windows 10 only: Start> Settings> Apps> Offline Maps: Turn Metered 

connections and Map updates off.
8 Windows 10 only: Start> Settings> Privacy:

a On the General page, turn off the following:
• Let apps use advertising ID to make ads more interesting to you based on 

your app usage (turning this off will reset your ID)
• Let website provide locally relevant content by assessing my language list
• Let Windows track app launches to improve Start and search results

b On the Location page, make sure Location for this device is off. If not, click 
Change to turn it off.
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9 Windows 10 only: Start> Settings> Personalization: Disable advertising info:
a On the Lock screen page:

• Under Background, select Picture or Slideshow.
• Turn off Get fun facts, tips, tricks, and more on your lock screen.
• Turn off Show lock screen background picture on the sign-in screen.

b On the Start page:
Turn off Occasionally show suggestions in Start.

10 Windows 10 only: Start> Settings> Personalization: In the Taskbar tab, under 
Taskbar buttons select Combine when taskbar is full.
This will simplify switching between open CDS instances.
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Edit the Security Settings for LC/MS and CE/MS 
Systems
The following sections summarize all security settings required for LC/MS and 
CE/MS. All other security settings are set automatically by the OpenLab CDS 
ChemStation Edition Installer.

OpenLab CDS ChemStation Edition needs to be installed using an operating 
system Administrator user account. To run the system with the configured 
options outlined in this document, all users and power users should use the 
same settings.

Firewall

On PCs controlling LC/MS or CE/MS systems, it is recommended that you turn 
off the firewall.

Advanced Network Settings

The communication with the MS is sensitive to the order NICs in the Adapters and 
Bindings dialog.
1 Go to Start> Control Panel.

Go to Network and Sharing Center1.
2 Click Change adapter settings.
3 Press ALT to bring up the menu.

1 View the items by icon to see a list of all items.
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4 Select Advanced Settings....

Figure 2 Advanced Settings dialog, Adapters and Bindings tab

5 In the Adapters and Bindings tab (see Figure 2 on page 30):
a Make sure that the Local Area Connection pertaining to the LC/MS or 

CE/MS NIC is the first item in the list of connections

NOTE The names of your LAN cards may differ from those shown in the example. You 
can tell which LAN card is the Instrument LAN by comparing the IP addresses 
assigned to the LAN cards.

The LAN pertaining to the company intranet > internet will typically have an IP 
address assigned by organizations Static IP policy or by a DHCP server. Check 
with your network administrator.
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Prepare for Installation 32
Manage Passwords 32

Run the OpenLab CDS Installation Wizard 33
License Agreement Screen 33
Installation Folder Screen 33
Installation Type Screen 34
Summary Screen 35

The installation is automated by the OpenLab CDS ChemStation Edition Installer. 
This tool installs all components needed.
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Prepare for Installation

1 Make sure that the antivirus software is disabled during the installation.
2 Do not run the Windows Update Service during installation. Make sure that no 

Windows updates are performed during the installation of ChemStation.
3 Make sure that no system reboot is pending.

Pending reboots are indicated both in the Configuration Checker (see “PC 
Configuration Checker” on page 20) and in the Site Preparation Tool (see “Run 
the Site Preparation Tool” on page 10).

4 To begin installation, navigate to \Disk1\Setup.bat. Right-click the file and run 
it as administrator to proceed to the Planning screen.

Manage Passwords
During the installation, you will need to provide passwords for the following roles:
• Administration of PostgreSQL database
• Administration of Shared Services database
• Administration of Content Management database

Ensure that access to these passwords is restricted corresponding to your 
company's password management policy.

These passwords are only required for advanced database administration. They 
are not required for normal lab operation or lab administration. For normal lab 
operation you only need a Control Panel login, which is initially provided by the 
software (see “First Login” on page 60).
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Run the OpenLab CDS Installation Wizard

License Agreement Screen
1 From the OpenLab CDS ChemStation Edition Installer, select Installation.
2 Select Secure Workstation for OpenLab CDS ChemStation Edition.
3 The OpenLab CDS Installation Wizard opens. Read the terms of the License 

Agreement. The installer provides a printable PDF of the license agreement 
under the Resources option of the main menu.

4 Select I agree with the terms and conditions. You cannot proceed with 
installation unless you agree to these terms.

5 Select Next to proceed to the Installation Folder screen.

Installation Folder Screen
1 Type the folder name or browse to the directory where you want to store the 

application components (typically this is in the programs folder). Folders 
must have English names.

2 To install e-familiarization documents during installation, select Include 
e-familiarization. This will extend the installation time considerably.

3 To run an installation verification as part of this installation, select Run 
Software Verification. The Software Verification Tool provides documentary 
evidence that your system has been built and installed correctly, and that all 
design specifications have been met. You can run the Software Verification 
Tool at a later time if you prefer (see “Run an Software Verification after 
Software Installation” on page 37).

4 Select Next to proceed to the Installation type screens.

NOTE Installations into the root of a drive may cause problems during operation and 
are not supported.
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Installation Type Screen
1 Under OpenLab CDS ChemStation Edition, provide the following folder paths:

• Installation folder: directory where you want to store the ChemStation 
application components. Typically this is in the programs folder. Folder 
names must be entered without spaces.

• Instrument data folder: Instrument specific data such as methods, 
sequences, and results. The default data path is the public documents 
folder. If you plan to activate the Secure File I/O feature, this folder must 
not be shared at a later point in time. If your PC is equipped with a second 
disk drive, it is recommended to change the default data path to this 
alternative drive. Using a second disk drive increases the performance.

2 Select Next to proceed to the Additional items screen.
3 Under Content Management Content folder, Content Management Index Folder, 

and Content Management Archive Path, type the required folder names or 
browse to the directories. Folder names must be entered without spaces.

4 Under PostgreSQL, type the folder name or browse to the directory where you 
want to store the PostgreSQL database files. For example, C:\PostgreSQL 
Data.
Provide the password that will be set for the PostgreSQL administrator. Note 
that the password must be at least eight characters and contain at least one 
lower case letter, one upper case letter, one digit, and one special character.

5 Select Next to proceed with the Databases screen.
6 Under Shared Services and OpenLab Content Management, type the database 

names or use the default names, and create user and administrator accounts 
as required.

7 Select Next to proceed to the Summary screen.

NOTE Use a drive with sufficient space for the Data Store content.

It is recommended that you use the same drives for the Content Management 
Content folder and the Content Management Archive Path, but a different drive for 
the Content Management Index Folder. For example:

• D:\DSContent

• C:\DSIndex

• D:\DSArchive
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Summary Screen
1 An installation summary is shown. Select Back as necessary to change 

installation settings, or Cancel to cancel the installation.
Select Start to begin installation.

2 The system performs an automated system check before it proceeds with the 
listed activities.
If a system check passed message appears, installation continues.
If a system check failed message appears, you can either:
• Decline to view the system report, and continue installation.
• Decline to view the system report and postpone installation.
• View the system report, and decide to continue installation.
• View the system report and postpone installation until the problem is fixed.

3 If an installation verification was completed as part of this installation, review 
the Software Verification Report. If the report indicates failure, verify the 
computer requirements and reinstall the data system. Do not use the system 
until the Software Verification Report gives a ‘pass’ result.

4 Click Next to proceed to the Installed Features screen.
5 Click Finish to close the installation wizard.
6 Reboot the computer.

NOTE To view the system report as PDF file, Adobe PDF Reader must be installed.
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Run an Software Verification after Software Installation 37
Allow ChemMain Through Firewall 38
Configure the Antivirus Program 39

This chapter describes tasks that are relevant after finishing the installation.
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Run an Software Verification after Software 
Installation

The Software Verification Tool (SVT) provides documentary evidence that your 
system has been built and installed correctly, and that all design specifications 
have been met. You do not need to run the software verification again if it has run 
successfully at the end of the installation.
1 Using your Windows operating system, go to Start> All Programs> Agilent 

Technologies> Software Verification Tool.
2 Select the components to qualify.
3 Select Qualify.

The system will run the application and generate a Software Verification 
Report.

4 If the report indicates failure, verify the computer requirements and reinstall 
the data system.
Do not use the system until the Software Verification Report gives a ‘pass’ 
result.
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Allow ChemMain Through Firewall

Carry out the following procedure to prevent ChemStation from functioning 
incorrectly due to firewall restrictions. Consider using a second network card to 
isolate the instrument's data traffic, and carry out the following procedure for that 
second network card only.

Alternatively, ensure that all required firewall ports are open. For details, refer to 
the OpenLab CDS ChemStation Edition Requirements guide 
(CDS_CS_HW-SW-Requirements.pdf).

1 In the Microsoft Control Panel, click Windows Defender Firewall1.
2 Click Allow an app or feature through Windows Defender Firewall.
3 Click Change settings.

The Allow another app... button becomes active.
4 Click Allow another app....
5 Click Browse... and navigate to C:\Program Files (x86)\Agilent Technologies\

ChemStation\CORE.
6 Select ChemMain.exe and click Open.
7 Click Add.
8 In the list of allowed apps and features, find ChemStation ChemMain, and 

select the check boxes for all three network types.
9 Confirm your changes.
10 Repeat the procedure for ChemMainAcq.exe.

1 View the items by icon to see a list of all items
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Configure the Antivirus Program

Be sure to open the firewall ports listed in the Firewall Settings in the OpenLab 
CDS ChemStation Edition Requirements guide.

In order for the OpenLab software to function correctly, you should configure any 
antivirus real time protection software with the following folder exclusions. They 
should only be scanned while the instruments are idle and no data acquisition 
takes place. Refer to your specific antivirus software documentation on how to 
configure folder exclusions.

NOTE Running antivirus programs might influence the behavior and performance of 
your computer. Some virus scanners might cause issues when used with 
ChemStation. The application is tested with Symantec Endpoint Protection 14.0 
MP2 and with Microsoft Security Essentials.

Process Directory File name

Data acquisition %public%\Documents\Chem-
Station
(or the corresponding folder for 
instrument data that you pro-
vided during installation)

Data, methods, sequences, 
reports etc.

Standard reports %temp% for Windows users
(=Users' temp directory)

~p3d*.tmp
~job*.tmp
Hpspl00.que

CDS intelligent reports %LOCALAPPDATA%
%APPDATA%
%PROGRAMDATA%

Files on:
• Agilent
• Agilent Technologies
• Agilent_Technologies,_Inc
• IsolatedStorage
• Temp
e.g.: C:\Users\xxxxx\
AppData\Local\ Agilent 
Technologies\Intelligent 
Reporting\RawDataFile-
Cache
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If your antivirus software includes program or executable deny execution 
settings, ensure that the following program files are not denied execution. You 
can use the windows search feature to find the specific folder each program file 
is located in.
• agilentiolibrariesservice.exe
• chemmain.exe
• chemmainacq.exe
• apg_top.exe
• iprocsvr.exe
• iproc8491.exe
• msinsctl.exe
• httpdmsd.exe
• epcsetup.exe
• AcroRd32.exe
• Acrobat.exe

NOTE Depending on your specific configuration, some of the listed folders or files may 
not exist on your system.
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Install Additional Software and Drivers 42
Copy installation Files to a Centralized Folder for Installation 43
Add Shortcut to Public Folder 44

This chapter contains information on the Additional Drivers and Software wizard 
and other helpful procedures.
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Install Additional Software and Drivers

OpenLab CDS ChemStation Edition offers a wizard to help you installing 
additional software, such as the ADFExport Plug-in, or drivers for third-party 
instruments. To open the wizard, go to Start> All programs> Agilent Technologies> 
OpenLab Additional Software and Drivers. Follow the wizard to install the required 
software.

Prepare Network Drives

If the additional software is located on a network drive, you must prepare the 
network drive to make it accessible by the wizard. Without this preparation, 
Windows security prevents the wizard from accessing those drives.
1 Map the drive to a letter.

For example, map the drive as Z: using the shared path "\\<machine-name>\
OpenLabCDS".
This maps the drive for the logged-in user.

2 Open the command prompt in elevated mode (run as administrator), and map 
the drive using the net use command.
For example, 
net use Z: "\\<machine-name>\OpenLabCDS"

This maps the drive for the local administrator account. The mapped drive is 
now visible to both logged-in user and administrator, and can be selected in 
the wizard.
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Copy installation Files to a Centralized Folder for 
Installation

Completing this step will enable you to run an installation from a network share.
1 From the installer Planning screen, select Installation from the sidebar menu.
2 Select Preparation of an Installation from Network Share.
3 At the Network Share screen, browse to a directory and create a destination 

folder as follows:

a Select the button with the three dots.
b Navigate to the directory where you want to create the folder.
c Select Make New Folder.
d Type in the folder name.
e Select OK. The system will return you to the Network Share screen, with the 

path displayed.
f Select the Include Secure Workstation Installation media check box.
g Select Start.

4 When processing is complete, copy the files to the local drive or map the 
location to a network drive.

5 Close the application and navigate to the directory and folder you created. 
Open the folder.

6 Select the Disk 1 folder, then execute Setup.bat to run the application.
The system will display the installer Planning screen.

NOTE Installations into the root of a drive may cause problems during operations and 
are not supported.
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Add Shortcut to Public Folder

By default, user data such as master methods, sequence templates, report 
templates, raw data etc. is located in the public documents folder C:\Users\
Public\Documents\ChemStation. You define this folder during the installation. 
The system creates a shortcut to the defined folder under Instrument Data in the 
Windows Start menu.

In Windows 7, a shortcut to public documents is automatically available in the 
Windows Explorer.

In Windows 10, the Windows Explorer is organized differently. To provide easy 
access to that folder, we recommend that you pin the Instrument Data folder to 
the Start menu.

Figure 3 Windows Start menu in Windows 10

1 Navigate to the Instrument Data shortcut in the Start menu.
2 Right-click the icon, then select Pin to Start.
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5 Secure File I/O

About Secure File I/O 46
Prepare Secure File I/O in Windows 47
Enable Secure File I/O in ChemStation 48
Check privileges for ChemStation users 49
Important Notes for Working with Secure File I/O 50
Limitations 51

This chapter describes how to protect your ChemStation folders with Secure File 
I/O.
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About Secure File I/O

ChemStation metadata such as validated master methods or sequences 
templates must be stored in secured locations in your content management 
system. For usage with your instruments these methods or sequence templates 
are also stored in various local folders. By default, the content of these folders is 
not protected against modification or deletion from local file browsers or from 
file dialogs within ChemStation.

To ensure data integrity, enable the Secure File I/O function for ChemStation. All 
relevant local paths will then be protected. The relevant paths are set by default, 
but can also be configured. The content of protected paths can no longer be 
modified by Windows file operations because access is denied for members of 
the Windows user group Interactive1. The protected folders can only be used 
inside ChemStation. If user authentication is enabled, only users with sufficient 
privileges can delete the locally stored data for housekeeping purposes. If those 
methods or sequences have been actively used with your instrument, copies are 
also stored along with results and their associated audit trails.

1 In Windows, all users who log on interactively are automatically assigned to the 
Interactive group. The membership persists for the time the users remain logged in.
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Prepare Secure File I/O in Windows

1 Ensure that all relevant ChemStation folders are on an NTFS file system.
2 Do not use ChemStation folders on removable storage devices (for example, 

external disks or USB media).
3 Create a standard user account (local or domain) with the same or fewer 

privileges than a normal ChemStation user. Do not grant administration or 
power user privileges. Make sure that this user is not a member of any group, 
especially not the Interactive group.
This account will be used by the ChemStation for internal file operations. As 
the user is not supposed to log on interactively, do not use the option Change 
password at next logon.

NOTE Consider using a password that never expires. If this is not possible due to your 
security policy, plan a downtime for ChemStation while updating the password.

As long as the password for this user account is expired, do not use the 
ChemStation. ChemStation will not work properly until you have updated the 
password in the ChemStation Administration Tool.
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Enable Secure File I/O in ChemStation

1 Click Start> All Programs> Agilent Technologies> ChemStation Administration 
Tool to open the ChemStation Administration Tool.

2 In the ChemStation Administration Tool, select the enable secure file IO check 
box.

3 Provide the credentials of the special user account that you have prepared.
4 Click Apply.
5 A dialog lists all directories that are going to be protected. Click OK to confirm.

For all paths that are protected, a ProtectionInfo.xml file is stored in the root 
folder. This protection information file contains the time stamp and the 
Windows user who enabled protection - that is either the user who enabled 
the path from the ChemStation Administration tool, or the user who 
configured a new instrument.
The Protection Information file provides proof for a given folder when the last 
activation was performed. Any period of time before that date is unspecified. 
The file can be used to demonstrate the uninterrupted protection status of a 
folder since it contains the date, time and user who last enabled protection.
Enabling or disabling secure file I/O is not logged to the OpenLab Control 
Panel Activity Log or the Windows Event Logs (application or Security).
When the folder is unprotected, the ProtectionInfo.xml file is deleted. Note, 
deleting this file will not unprotect the folder.

6 For administrative tasks, you can temporarily disable the protection of 
specific folders:
a Shut down all ChemStation sessions.
b In the ChemStation Administration Tool, click Manage Secure File System.
c In the list of directories, find the relevant path and click Unprotect.

The protection information file is deleted to document the interruption of 
the protection state.

d After finishing your tasks, click Protect All to restore protection for all 
relevant folders.
New protection information files are created.

e Start ChemStation again.
ChemStation will only start if all folders are protected.
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Check privileges for ChemStation users

In the OpenLab Control Panel, specific privileges can be configured. Several 
privileges are relevant for Secure File I/O. They handle occasions when data, 
methods, or sequences need to be loaded from unprotected locations (which are 
outside of the secure folders). These privileges are enabled in the default 
ChemStation Roles to maintain the current workflows.

To ensure data integrity, it is recommended to uncheck these privileges when 
Secure File I/O is enabled.

The relevant privileges are:
• ChemStation: Data> Load data from not configured path

Required for loading data from unprotected paths, or adding data paths that 
are not empty to the ChemStation.

• ChemStation: Method> Load method from not configured path
Required for loading a method from an unprotected path, saving a method to 
an unprotected path, or adding method paths to the ChemStation 
(Preferences dialog).

• ChemStation: Sequence> Load sequence template from not configured path
Required for loading sequence templates from unprotected paths, saving 
sequence templates to unprotected paths, or adding paths that are to the 
ChemStation (Preferences dialog).
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Important Notes for Working with Secure File I/O

When using Secure File I/O to protect your ChemStation folders:
• Do not share protected folders. Sharing a folder will break the protection.

If your data resides within the public documents folder (default setting), do 
not turn on public sharing.

• Do not log in interactively with the user account provided in the ChemStation 
Administration Tool.
If this user logs in interactively, you will not be able to save any changed data 
in ChemStation until the user logs out again.

• If the password for this user account has expired, do not use the ChemStation 
until you updated the password in the ChemStation Administration Tool. 
ChemStation will not work properly as long as the password is outdated.
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Limitations

The following features are not supported when Secure File I/O is enabled:
• Import/Export eMethods
• Migration of non-container data to new result sets
• Download files (method, sequence, data) using the content management web 

interface, and storing them to a protected folder
These files must be downloaded from within the ChemStation application.

• GC Backflush Wizard
• G2887BA SIMDIS
• M8350AA MatchCompare
• M8370AA OpenLab Data Analysis Add-on
• Easy SamplePrep
• G7818A Cirrus GPC Software
• A2Prep software
• Method Scouting Wizard
• G4218A Evaporative Light Scattering Detector
• 2D-LC Add-on

Since Secure File I/O protects the folders/directories containing methods, 
sequences, data for OpenLab ChemStation, this prevents access from outside 
applications as Explorer or Notepad from making edits to ChemStation produced 
data, methods, etc. This also includes some of Agilent's Add-on programs such 
as A2Prep as these programs need to access ChemStation folders/directories. 
Any application that needs to access or write to a protected ChemStation 
folder/directory will not be allowed and therefore cannot be used when Secure 
File I/O is enabled.
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6 Secure Workstation for OpenLab CDS 
ChemStation Edition Licensing

About OpenLab Licensing 53
License Types 53
License File 53

Obtain your Software License 54
Generate and download your software license 55
Other Ways to Obtain a License 57

This chapter describes the licensing of a Secure Workstation for OpenLab CDS 
ChemStation Edition.
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About OpenLab Licensing

License Types
The license file is a collection of Product, Instruments and Add-on licenses (or 
activation keys), and is installed to your OpenLab CDS System.

The licenses or activation keys in the license file can either be Shared or Counted:
• Shared licenses — system computers and other components can have 

shared, or add-on, licenses — because they share a core license.
• Counted licenses — these licenses are part of the Secure Workstation for 

OpenLab CDS ChemStation Edition floating licensing strategy. They are not 
permanently assigned to any one component. Instead they are automatically 
assigned to components, such as AICs and instruments, while the 
components are starting up. The licenses are automatically returned when 
the component is closed. The license management program controls license 
issuance and retrieval.
In this case, the only requirement is that a component is licensed while 
running. You only need enough licenses for all components running 
concurrently, rather than for each installed component.

A startup license for the system allows you to run OpenLab CDS for 60 days after 
the installation. In order to run the data system software after the 60-day period, 
you must install your license file.

License File
A license file will contain your software license. This file is installed on the 
workstation. The license file is bound to this computer, and cannot be moved to 
another workstation without regenerating the license in SubscribeNet.

Information in the license file defines the number of instruments and other 
options that may be used concurrently with your system.

The most efficient way to manage and maintain your licensing is through the 
Internet.
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Obtain your Software License

The most efficient way to and manage and maintain your license is with 
SubscribeNet.

Flexera
License

Manager

Secure Workstation for OpenLab CDS ChemStation Edition uses a 3rd party tool 
called FlexNet Producer Suite from Flexera to manage the licenses. The required 
Licensing server components are installed by default on the Secure Workstation 
for OpenLab CDS ChemStation Edition.

License Management in OpenLab Shared Services requires an additional 
Windows service to be running. This Windows service is called Agilent OpenLab 
License Server. This service must be running on your Secure Workstation for 
OpenLab CDS ChemStation Edition.

If you are lacking an Internet connection, see “Other Ways to Obtain a License” on 
page 57. Gather the following information from the lavender envelope containing 
your Software Entitlement Certificate:
• The authorization code label
• The URL for SubscribeNet

If you have not received a lavender envelope, contact your vendor or internal 
support.
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Generate and download your software license
Use the following procedure to generate and download your license. In case you 
do not have internet access, skip to the section “Other Ways to Obtain a 
License” on page 57.

If you are a new user who has not registered with SubscribeNet, continue with the 
section New Users.

If you have registered with SubscribeNet, skip to the section Users registered with 
SubscribeNet.

Prerequisites To generate, download, and install a final license for your product, you will need:
• The authorization code label provided in the lavender envelope containing 

your Software Entitlement Certificate.
If you have not received a lavender envelope for your product, contact your 
vendor or internal support.

• The URL for SubscribeNet from the Software Entitlement Certificate.
• The host name of the computer where the Control Panel is running.
• The MAC address.

To retrieve your MAC address from a computer where Secure Workstation for 
OpenLab CDS ChemStation Edition is already installed, open the Control Panel 
and browse to the Administration> Licenses section. Use the Copy MAC 
Address or Save MAC Address function to obtain the MAC address for license 
generation.
During this process you will have to enter the MAC address of your license 
server. For workstations, this is the local computer. For client/server systems, 
this is the server.

NOTE If any changes are made to the computer name or domain reference after the 
license is installed, remove the license. A new license will need to be created in 
SubscribeNet, downloaded, and installed.

NOTE If the network adapter that provides the MAC address used during license 
creation is removed from the machine, your license will no longer be valid. A new 
license will need to be generated with a currently available MAC on the license 
server.



Secure Workstation for OpenLab CDS ChemStation Edition Installation 56

6 Secure Workstation for OpenLab CDS ChemStation Edition Licensing
Obtain your Software License

New Users
1 Go to https://agilent.subscribenet.com/control/agil/AgilRegisterToAccount 

to register the product with SubscribeNet.
2 On the registration page, enter the authorization code from the label and 

complete the profile information (required fields are marked with an asterisk 
*).
The email address you enter will become your login ID.

3 Click Submit. The system will generate and display an account name for you.
SubscribeNet will send a welcome email with your login ID and password.

4 Log in to SubscribeNet using your login ID and password.
Once you log in, you can use the online user manual link for help with any 
questions you have.

5 Select Generate or View licenses from the left navigation bar.
6 Follow the prompts to generate your new license.

You will be prompted for the HOST NAME of the computer. The host name 
you enter must match with the network name of the computer where the 
Control Panel is running. Do not include any DNS suffix (domain.com) 
references in the entered machine name.

7 When the system generated the license, view its details, then click Download 
License File. Save the license file to your computer and to a backup location 
(such as a portable storage device).
Use your login ID and password when you revisit the Agilent SubscribeNet site 
to regenerate a license file, add new authorization codes, or further configure 
the license for your system.
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Users registered with SubscribeNet
1 If you already have a SubscribeNet account, use 

https://agilent.subscribenet.com/.
Lost your SubscribeNet password? Use 
https://agilent.subscribenet.com/control/agil/password to have it emailed 
to you.

2 Select the SubscribeNet account associated with this authorization code, if 
you have more than one account.

3 From the SubscribeNet navigation pane, select Register Authorization Code.
This will allow you to enter your new authorization code and make available 
the new license entitlements.

4 Follow steps 5 through 7 in the previous procedure, New Users, to generate or 
view your new licenses.

Other Ways to Obtain a License
If you are unable to generate a license, contact your nearest Agilent technical 
support office. A representative will tell you how to submit an OpenLab CDS 
License Generation Form in your location.

Offline Licensing

If an internet connection is not available in your laboratory:

You or your local on-site service engineer will collect the necessary information 
from you to allow Agilent to create a license account on your behalf. For phone 
support in your region, call the sales and service number for your region. See the 
Appendix for contact information.
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Required Customer Information for Agilent License Support:

The following information must be provided to Agilent in order to enable us to 
create a licensing account on your behalf.
1 Collect Account Information:

Your account name will be your company name and Lab name separated by a 
comma. Employee information provided here will be used to define the first 
administrator of your account for future access to the system as required. 
Please prepare the following pieces of information prior to contacting your 
local Agilent sales and service center in order to expedite service:
• Company Name
• Lab/Department Name
• First Name
• Last Name
• E-mail address
• Job Title
• Phone #
• Address, City, State/Province, Postal Code, Country

2 Collect Authorization Code(s):
The authorization code is an alpha-numeric code provided on a label which is 
enclosed in a lavender envelope. If you have received more than one code you 
must provide all codes to ensure that all ordered licenses are granted to your 
account.

3 Receiving your license:
Once the above information is provided Agilent will then work on your behalf 
to generate a license file through SubscribeNet. The license file will either be 
sent to your shipping address (on a CD), or your local FSE will deliver it in 
person (usually on USB media). Once your license is received follow the below 
section on “Install your License” to finish installing your license on your CDS 
system(s).
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First Login 60
Add your License to the Control Panel 61
Add Users 62
Add Users to a Role 63

This chapter describes the configuration of Secure Workstation for OpenLab CDS 
ChemStation Edition.



Secure Workstation for OpenLab CDS ChemStation Edition Installation 60

7 Configure Secure Workstation for OpenLab CDS ChemStation Edition
First Login

First Login

During the installation, internal authentication is automatically configured, and a 
default user 'admin' is created with password ‘openlab'. For security and 
compliance reasons, change the password before proceeding any further.
1 Start the OpenLab Control Panel shortcut on the desktop or go to Start> All 

Programs> Agilent Technologies> OpenLab> OpenLab Control Panel.
2 Enter your login credentials for OpenLab Control Panel.

a In the Login field enter the user name 
admin.

b In the Password field enter the password 
openlab.

3 In the Administration view, select My Settings.
4 In the ribbon, click Change My Password.
5 Provide a new password that corresponds to your password policy, and 

confirm your settings.
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Add your License to the Control Panel

The license must be added to your system using the Control Panel.
1 Start the Control Panel shortcut on the desktop or go to Start> All Programs> 

Agilent Technologies> OpenLab Shared Services> Control Panel.
2 Navigate to Administration> Licenses.

3 In the ribbon, click Add License .

4 Choose to install the license by:
• Using the license file option to browse to and open the license file (.lic) 

saved from the license generation process in SubscribeNet.
• Selecting the License Text option and copying the license text from a text 

file received into the provided field.
5 Click OK.

The Administration interface in the Control Panel will now display the status of 
installed licenses.
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Add Users

1 From the navigation pane, select Administration> Users.
2 In the Users toolbar, select Create.
3 In the Create User dialog box enter a Name and Description for the user.
4 Select the General tab and enter a Password for the user. Confirm the 

password.
5 Under Security policy, set the minimum password length of at least five 

characters.
6 Set the expiration period of 180 days or less.
7 Limit the number of allowed login attempts to three.
8 Enter the user's full name, email address, and contact information if desired. 

The full name is used in activity log entries and the welcome message at the 
lower right of the Control Panel.

9 Select password options:
• To prevent the user from changing the password assigned here, enable 

the User cannot change password.
• To require the user to create a new password the next time they log on, 

enable the User must change password at next logon.
• To allow the user to use the password assigned here or change it at any 

time, disable both the User cannot change password and the User must 
change password at next logon.

10 To create a user profile but prevent the user from logging on Control Panel, 
enable User disabled.

11 Select OK.
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Add Users to a Role

1 From the navigation pane, select Administration> Roles.
2 In the roles window, select the role you want to assign to users.
3 In the roles toolbar, select Edit.
4 In the Edit Role dialog box, select the Members tab.
5 Select Add user or group.
6 In the Search Users and Groups dialog box, select Search to view a list of all 

users and groups.
7 Under Search Results, select a user or group and select Add.
8 Select OK.
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Planning your Upgrade 65
Convert Classic Instrument Drivers to RC.NET 66
Preparations for the Upgrade 69
License Upgrade 71
Get Upgraded License File 71
Add Upgraded License File to the System 72

Upgrade a Secure Workstation 73

This chapter describes the upgrade of Secure Workstation for OpenLab CDS 
ChemStation Edition.
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Planning your Upgrade

A direct upgrade, using the Upgrade Wizard, is supported from ChemStation 
C.01.07 SR3 or higher. Older ChemStation revisions must be upgraded to C.01.07 
SR3 in a first step. For details on the upgrade to C.01.07 SR3 or SR4, please refer 
to the C.01.07 SR3 installation guide.

Note that C.01.10 is supported on Windows 7 SP1 64 bit or Windows 10 only. An 
in-place upgrade from Windows 7 or 8.1 to Windows 10 on an existing 
ChemStation Workstation is not supported. Before upgrading a Secure 
Workstation, make sure that the Windows configuration meets all requirements. 
See “Configure the Operating System” on page 20.

For information on restoring your old database into a new installation, see the 
disaster recovery procedures in the Secure Workstation for OpenLab CDS 
ChemStation Edition Maintenance Guide (CDS_CS-SecureWS_maintenance.pdf).

Classic instrument drivers, with exception of MSD instrument drivers, are no 
longer supported. It is recommended that you convert the corresponding 
instrument methods to RC.Net driver methods prior to the upgrade (see “Convert 
Classic Instrument Drivers to RC.NET” on page 66).

If your system is configured to use one of the following ELSD drivers (G7102A, 
G4261A/B or G4260A/B), refer to the current ELSD Release Note for upgrade 
instructions. The version current at the release of ChemStation C.01.10is 
available in the Documentation and Learning platform.

The functions related to ADF Export will be available as an Add-On for 
ChemStation starting from revision C.01.10. To use the latest version, install the 
ADFExport Add-On separately (see “Install Additional Software and Drivers” on 
page 42). ADF Export functions have been included in ChemStation C.01.09. 
Therefore, if you upgrade ChemStation from C.01.09, always install the latest 
ADFExport Add-On on ChemStation revision C.01.10 in order to upgrade the 
outdated ADF Export functions.

NOTE As of C.01.08, the M8370AA OpenLab CDS Data Analysis Add-On is no longer 
supported in combination with ChemStation.

Also as of C.01.08, OpenLab CDS ChemStation Edition does no longer control 
Agilent 5890 GC instruments.

If you use either of them, do not upgrade to C.01.10. Use rev. C.01.07 SR3 or SR4 
instead.
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Convert Classic Instrument Drivers to RC.NET

With C.01.10, only RC.NET drivers are available (with exception of MSD 
instrument drivers). Instruments using the classic driver must be reconfigured to 
use the RC.net driver. Agilent recommends to do this before upgrading to 
C.01.10.

To determine which instruments are using the classic driver, go to the OpenLab 
Control Panel and select the instrument. Select Configure Instrument in the 
ribbon. The instrument is using the classic driver if the Use classic drivers check 
box is selected. Perform the following steps to reconfigure the instrument to use 
RC.NET.
1 Record the IP address for each classic driver instrument.
2 Verify there is a backup of the methods and data to another location.
3 For your reference: Print the classic driver method settings or save the 

method listing to disk.
4 To reconfigure the instrument, select the instrument in the OpenLab Control 

Panel.
5 In the ribbon, click Configure Instrument.
6 In the configuration dialog, clear the Use classic drivers check box.

The instrument is moved from the Selected Modules panel to the Configurable 
Modules panel.
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7 Select the instrument in the Configurable Modules panel, then click the arrow 
to add the instrument to the Selected Modules panel again.

8 Double-click the instrument under Selected Modules, and configure the 
previously recorded IP address. Click Get Serial Number and Firmware to get 
the corresponding entries.

Figure 4 Example for 35900 configuration

9 Launch the newly configured instrument.

NOTE • If a current RC.NET driver is not yet available, you must install it manually 
before upgrading OpenLab CDS ChemStation.

• For example, follow these steps to install the 35900E ADC RC.NET driver:

a Run the installer.

b Go to Installation and open OpenLab Additional Software and Drivers.

c When asked for the Add-on software, browse to Disk3 of the installation 
media, and to the Agilent 35900E RCNet folder to find the Agilent OpenLab 
CDS ChemStation 35900 AtoD Drivers.msi file. The corresponding 
software will then be listed in the installer.

d Select the software in the list, and continue to install. The installation 
verification will automatically follow and should complete without errors.
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10 To convert a method to RC.NET driver, load the method. If a dialog like the 
following opens, click OK.

Review the method, and if no updates are needed, add a comment such as 
"Updated to RC.NET" to the method when saving it.
Methods are converted to RC.NET when loaded. After saving to disk, 
converted methods have an additional Agilent folder and 
RapidControl.InstrumentConfig file.

 Only with RC.NET driver methods    



Secure Workstation for OpenLab CDS ChemStation Edition Installation 69

8 Upgrade Secure Workstation
Preparations for the Upgrade

Preparations for the Upgrade

1 Perform a backup of your system by following the procedure described in the 
maintenance guide (SecureWS_maintenance.pdf).

2 If not already present from a previous installation: Install .Net Framework 
4.7.2 (see “Install .NET 4.7” on page 15).

3 Disable Windows Updates
a Go to Control Panel> Windows Update.
b Click Change settings. In the Important updates section, select Never check 

for updates. Clear the other update options.

4 Verify that the locales defined in the postgreSQL database match the locales 
defined in the operating system.

a Open the postgreSQL administration tool (pgAdmin)
Start> Postgres 9.x> pgAdminIII

b Right-click Postgres SQL 9.x, select Connect, and type the password for the 
postgres user.

NOTE This setting is important to avoid a system reboot during the upgrade process

NOTE To perform this step you will need the password for the postgres user that has 
been defined during the original installation. It should be part of your personal 
documentation.

Contact your local Agilent support representative if you can’t retrieve the 
password of the postgres user.
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c Expand the Databases list by clicking on (+).

d Click on the different databases. In the Propertiestab, note the language for 
Collation and Character Type.

e Open the Windows settings Start> Control Panel> Region and Language> 
Format and compare with the language defined in the databases.

f Reboot the computer.

NOTE Note down the settings in the ChemStation Administration Tool. After the 
upgrade, check if the settings still match the original ones before the upgrade.
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License Upgrade

Get Upgraded License File
You will need to upgrade your licenses in SubscribeNet prior to upgrading to the 
next version of Secure Workstation for OpenLab CDS ChemStation Edition. We 
strongly recommend upgrading your workstation licenses before upgrading the 
core software. Standalone workstations which are upgraded to the new core 
software version, without a new workstation license, will not work until the new 
workstation licenses are added to the OpenLab Control Panel.

If you are under SMA subscription, proceed as follows to upgrade your licenses:
1 During the following process, you will be prompted in SubscribeNet for the 

host name or MAC address of the workstation where Secure Workstation for 
OpenLab CDS ChemStation Edition is already installed.
To retrieve this hostname and MAC address, open the Control Panel and 
browse to the Administration> Licenses section. Note down the host name 
and use the Copy MAC Address or Save MAC Address function to obtain the 
MAC address.

2 Log into the Agilent Electronic Software and License Delivery 
(https://agilent.subscribenet.com/).

3 Navigate to Manage Licenses by Host. In the Host ID field, enter the previously 
noted MAC address, and click Search.
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If the relevant host name does not appear, you may be managing your 
licenses in multiple SubscribeNet accounts. You will need to log into those 
accounts to upgrade those licenses.

4 If your license(s) are eligible for an upgrade, you will see the Upgrade All 
button. Otherwise you will need to contact your Agilent Sales Representative 
to renew your Software Maintenance Agreement (see “Sales and Support 
Assistance” on page 84). To proceed with generating your upgrade license, 
click the button.

5 On the Upgrade All Licenses for License Host page, review the data, and 
confirm by clicking Upgrade All.
This upgrades the license file to the most current version. SubscribeNet will 
send you an email with a new license file.

6 Put the new license file on your system (see “Add Upgraded License File to the 
System” on page 72.
If you have multiple standalone Workstations, repeat this step for each 
individual workstation.
Note that each workstation's MAC address is the file name. This helps identify 
the correct license file to import into the workstation's Control Panel.

Add Upgraded License File to the System
If you have purchased new options, such as additional instrument controls or 
client license and regenerated your license in SubscribeNet, the upgraded license 
file must be re-applied to the system.
1 Start the Control Panel from any machine connected to the system you want 

to install the license for.
2 Navigate to Administration> Licenses.

3 Select a license, then click Remove License .

4 In the ribbon, click Add License .
5 Browse to and open the license file saved from the license generation process 

in SubscribeNet.

NOTE A full restart is required in order for any license to have an immediate effect.
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Upgrade a Secure Workstation

Prerequisites You are using Secure Workstation for OpenLab CDS ChemStation Edition rev. 
C.01.07 SR3 or higher.

Older versions must first be upgraded to C.01.07 SR3. Multiple upgrade steps 
may be required.

1 If you protect your folders with Secure File I/O: disable Secure File I/O during 
the upgrade.
a Shut down all ChemStation sessions.
b Click Start> All Programs> Agilent Technologies> ChemStation 

Administration Tool to open the ChemStation Administration Tool.
c In the ChemStation Administration Tool, clear the enable secure file IO 

check box.
2 Run the installer from the same media type (for example, USB or network 

share) as you used to install the current version.
3 From the installer Planning screen, switch to the Installation screen.
4 Select Secure Workstation for OpenLab CDS ChemStation Edition.

If a Secure Workstation is already installed, this automatically opens the 
upgrade wizard.

5 The workstation license must be upgraded, see “Get Upgraded License 
File” on page 71.
Acknowledge that the license has been upgraded and click Next to continue.

6 Select I agree with the terms and conditions. You cannot proceed with the 
upgrade unless you agree to these terms. Click Next.

7 In the OpenLab Shared Services Settings for Registration screen, enter the 
username and password of a user with system administration privileges. 
Click Next.

8 In the Summary screen of the Upgrade Wizard, the components for the 
upgrade are listed. Click Start to proceed with the upgrade.
If an error occurs during the upgrade, an error message appears.

9 After the upgrade, check if the settings in the ChemStation Administration Tool 
still match your original system settings before the upgrade.
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10 If you disabled it before, enable Secure File I/O again after the upgrade is 
finished.
a Click Start> All Programs> Agilent Technologies> ChemStation 

Administration Tool to open the ChemStation Administration Tool.
b In the ChemStation Administration Tool, select the enable secure file IO 

check box.

Existing instrument configuration can remain unchanged after the upgrade.

NOTE The Classic drivers are not supported with ChemStation C.01.08 and later. 
Please check “Convert Classic Instrument Drivers to RC.NET” on page 66 for 
details.
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This chapter contains information on the uninstallation by using the OpenLab 
Uninstallation Wizard.
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About Uninstallation

Like the installation, the uninstallation is automated by the OpenLab CDS 
ChemStation Edition Installer.

For your convenience, the installer uses the same user interfaces for the 
software uninstallation of all configurations (standalone or networked 
workstation). The OpenLab Uninstallation Wizard is found under the Maintenance 
section of the installer. It guides you through the uninstallation steps.

NOTE Do not use the Windows uninstallation tool for uninstalling OpenLab CDS 
ChemStation Edition!

NOTE If the installer was not used for installation, any manually installed additional 
software such as Headspace, PAL, or third party drivers must be uninstalled 
using the Windows Control Panel before the core software can be uninstalled.
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Run the OpenLab CDS Uninstallation Wizard

1 Select Start> All Programs> Agilent Technologies> Uninstall OpenLab CDS.
The OpenLab Uninstallation Wizard opens.

2 In the Shared Components screen, select the Uninstall Software Verification 
and Uninstall PostgreSQL check box.
Note: Software Verification Tool needs to be uninstalled if you wish to 
re-install OpenLab CDS ChemStation Edition at a later time.

3 In the Summary screen under Uninstallation of OpenLab CDS ChemStation 
Components, there is a list of the components you want to uninstall.

4 Select Start to start the uninstallation.
If you want to abort the uninstallation, select Cancel. If you want to change 
any settings, select Back.
All listed components are automatically uninstalled, one after another.

5 When the uninstallation has finished, click Finish to close the uninstallation 
wizard.
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The chapter gives some troubleshooting hints.
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Reconfigure Instruments Using Classic Drivers 
After Upgrade to ChemStation C.01.08 or Higher

If you missed the recommendations from the driver preparation described in the 
OpenLab CDS ChemStation Edition Upgrade Guide (CDS_CS-Upgrade.pdf), 
ChemStation will start up, but instruments with the Classic driver will no longer 
be available. You will receive a notice that you need to reconfigure your 
instrument.

The classic driver instruments and methods are not updated to RC.NET 
automatically. To adjust them, perform the following steps.

To check if a classic method is used, go to Windows Explorer and view the 
contents of the corresponding method folder. The classic method will not have 
the Agilent folder listed.

1 Record the IP address for each classic driver instrument.
2 Verify there is a backup of the methods and data to another location.
3 To reconfigure the instrument, select the instrument in the OpenLab Control 

Panel.
4 In the ribbon, click Configure Instrument.

A message is displayed, requesting you to reconfigure your instrument.

 Only with RC.NET driver methods    
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5 Click OK.
The Configure Instrument panel opens. The Use classic drivers check box is no 
longer shown.

6 To update the instrument to use the RC.net driver, select the instrument in the 
Configurable Modules panel, then click the arrow to add it to the Selected 
Modules panel.

7 Enter the IP Address. Only for 35900E A/D instrument: Click Get Serial Number 
and Firmware to get the corresponding entries. For the example below the 
serial number and firmware version are updated upon successful connection 
to the 35900E A/D instrument.

This completes the setup of the instrument.
8 Click OK to load the instrument configuration.
9 Specify the Method Load on Startup option and select one of the following 

options:
a Always ask the user to choose an option
b Download method to instrument on start up (select this option to match the 

behavior of the classic driver)
c Upload method from instrument
d New method from instrument
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10 Click OK to complete.
11 Launch the newly configured instrument.
12 To convert a method to RC.NET driver, load the method. If a dialog like the 

following opens, click OK.

Review the method, and if no updates are needed, add a comment such as 
"Updated to RC.NET" to the method when saving it.
Methods are converted to RC.NET when loaded. After saving to disk, 
converted methods have an additional Agilent folder and 
RapidControl.InstrumentConfig file.

 Only with RC.NET driver methods    
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Change the PC Name

A change of the PC name may be scheduled to avoid duplicate names in a 
network or can be due to a policy change. Internally, the software components 
use localhost for the Workstation, so no additional action is required to continue 
running the software. However, if you need to change a PC name after 
installation, the license file for the PC will be no longer valid.

Instruments are licensed by installing files that are specifically created for a given 
configuration. The text of the license files contains references to the computer 
name and the hardware address of the network card. If one of the parameters is 
changed, the license no longer applies.

You will need to generate and install a license file with the new PC name (host 
name).
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11 Appendix
Sales and Support Assistance

Sales and Support Assistance

Please check the following web site for your local sales and support contact:

https://www.agilent.com/en/support
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