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This chapter describes a manual procedure for transferring 
ChemStation Sequences that were stored in containers (now 
called result sets), from a ChemStation file system into 
OpenLAB CDS ChemStation Edition with Data Store or ECM. 
 
These instructions support the transfer of data from 
ChemStation B.04.03 SP1 to OpenLAB CDS ChemStation 
C.01.04 or higher.

NOTE During an upgrade project there might be different versions of OpenLAB 
CDS in your environment. Please note that the analysis and reprocessing 
of data is supported only on versions same as or higher than the one used 
for the acquisition or last reprocessing. 

Agilent recommends that a mixed version system should be used only 
during the upgrade phase. For more information, please refer to the 
OpenLAB CDS Administration Guide (CDS_Admin.pdf on Disk 1).
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Reusing Your Data in OpenLAB CDS ChemStation Edition with OpenLAB Data Store or OpenLAB ECM

Sequence Data Stored in Result Sets

In order to strengthen the association between data files and 
methods, the usage of result sets has been introduced with 
ChemStation B.02.01 (result sets have been called sequence 
containers then). If you use a central data storage system 
(OpenLAB ECM or OpenLAB Data Store), the complete 
result set (sequence/methods/data files/report templates) is 
transferred to the central repository as one entity.

Figure 1 Sequence Acquisition with Unique Folder Creation ON

The methods in the folder Chem32\1\methods serve as 
master methods. They remain unchanged during acquisition 
and data analysis.

Similarly, the sequences in the folder Chem32\1\sequence 
serve as sequence templates that can be used to rerun (but 
not reprocess) a sequence several times.

Report Templates in the folder Chem32\repstyle serve as a 
starting point for developing your own report templates.

NOTE If your data is not in this format, Agilent recommends changing your 
configuration now, to be ready to migrate easily in the future. 

See “Step 1 – Verify Containers are in Use.”  on page 6, for more details on 
this. 
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Transferring ChemStation Data to OpenLAB Data Store or OpenLAB ECM

Requirements 

The user who will carry out this transfer must be part of 
the Local Administrator group.

The user should have administrative privileges in 
ChemStation and in OpenLAB Shared Services (the Everything 
privilege in OpenLAB Control Panel) so he can edit the 
method and sequence data path, select the ECM or Data 
Store path in the transfer settings, and create and configure 
instruments in OpenLAB Shared Services.

The data to be transferred must be stored in containers 
(result sets). 

Step 1 – Verify Containers are in Use.

Only data stored in a container (result set) will transfer to 
Data Store or ECM. 

Before continuing, verify that the data being transferred is in 
a container. Data in containers will look similar to the 
screen capture below. Notice that all the data files, the 
sequence file, and the methods used in the sequence are 
grouped in a single folder. This folder, known as the 
container in ChemStation B.04.03, is now called the result 
set. 

For old data that is not in a container, create one as described in 
step 2.

NOTE If you see the data is not in this format, Agilent recommends changing 
your configuration now, to be ready to migrate easily in the future.

Result Set for the sequence 
named “My Sequence”
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Reusing Your Data in OpenLAB CDS ChemStation Edition with OpenLAB Data Store or OpenLAB ECM

For more details on ChemStation data Structure please refer 
to the OpenLAB CDS ChemStation Edition Concepts and 
Workflows guide (M8301- 90016).

Step 2 – Create a Result Set for Results that are not in a Container. 

Use the Result Set Migration screen in ChemStation to make 
containers (result sets) for the data to be uploaded to Data 
Store or ECM. 

1 From the Data Analysis view of the OpenLAB 
ChemStation, select Sequence > Result Set Migration… to 
open the Result Set Migration dialog.

2 Navigate to, and select the sequence template from the 
ChemStation B.04.03 backup data acquired for that 
instrument folder. 

If you do not know which sequence was used, please 
refer to *.log in data folder. 

This figure highlights the log file (Test3.log) in the Test3 
data folder: 

NOTE Only use this procedure if you are certain about the sequence and method that 
was used to produce the data.
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This figure shows the Test3.log file opened in Notepad, 
with the name of the sequence file highlighted:

3 Select the Method folder from the ChemStation B.04.03 
backup location.

4 Select the source folder from the ChemStation B.04.03 
backup location. 

Test3.LOG

Sequence used
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Reusing Your Data in OpenLAB CDS ChemStation Edition with OpenLAB Data Store or OpenLAB ECM

5 Select the destination folder. Create a new subfolder 
within the data folder structure of the upgraded location 
and select it as the destination. 

6 Click Start. 

7 If the result set migration was successful, an appropriate 
message will be displayed as highlighted in the figure 
below.

For more information on result sets refer to ChemStation 
documentation.



Reusing Your Data in OpenLAB CDS ChemStation Edition with OpenLAB Data Store or OpenLAB ECM

Reusing B.04.03 ChemStation Data in OpenLAB CDS 10

Step 3 – Manually Transfer Data Into OpenLAB Data Store or OpenLAB 
ECM.

1 Setup a client PC with a Data Store or ECM connection. 

For ECM, please refer to the ECM Installation Guide.  
For Data Store, please refer to the Data Store Installation 
Guide.

2 Create folders for your data, methods, and sequences in 
Data Store or ECM.

3 In the ChemStation Method and Run Control view, browse to 
Data Store or ECM > Preferences. In the Preferences dialog:

a Click the Paths tab and enter the paths for Sequence, 
Data, and Methods that were used with the 
ChemStation file system.

b Click the Transfer Settings tab and select the Import After 
Reprocessing check box. Verify that the data transfer 
path is set to the correct path. 

Add Methods from a ChemStation File System to Data Store or 
ECM

1 From ChemStation Explorer, in the Method and Run Control 
view, click the Methods tab and then double- click a 
method to load it. 

2 Click Data Store or ECM > Save Method. 

3 Browse to a folder created in Data Store or ECM and 
save the method. 

4 The method icon in the ChemStation Navigation Pane 
will change from  to  indicating that the method 
has been saved to Data Store or ECM. 

5 If the instrument configuration of the method being 
saved does not match the current instrument 
configuration, the configuration may need to be resolved 
prior to saving.

NOTE If the Import After Reprocessing check box is cleared and grayed out in 
the Preferences, this option needs to be enabled for the entire workstation 
in the ChemStation Administration Tool. This tool is accessible to 
administrators (under Start Menu > Programs > Agilent Technologies> 
OpenLAB CDS ChemStation Edition).
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Add Sequence Templates from a ChemStation File System to Data 
Store or ECM

1 From ChemStation Explorer, in the Method and Run Control 
view, click the Sequence Templates tab and then 
double- click a sequence template to load it. 

2 Click Data Store or ECM > Save Sequence Template. 

3 Browse to a folder created in Data Store or ECM and 
save the sequence template.

4 The icon for the sequence template will change from 
 to  indicating the sequence template has been 

saved to Data Store or ECM.

Add Data from a ChemStation File System to a Data Store or ECM 
System

1 From ChemStation Explorer, in the Data Analysis view, 
click the Data tab. 

2 Double- click data that you want to add to Data Store or 
ECM. Please note that only data stored in a container or 
result set will be transferred.

3 Reprocess the data by choosing the Reprocessing Mode 
and clicking (Start Sequence Reprocessing) in the 
sequence reprocessing toolset.

4 Data from the file system will appear in Data Store or 
ECM. The sequence icon in the ChemStation Navigation 
Pane will change from  to  indicating that the 
sequence has been saved to Data Store or ECM.

Add Other Files from a ChemStation File System to a Data Store or 
ECM System

1 In the Method and Run Control view or in the Data Analysis 
view, Click Data Store or ECM > Upload Files. 

2 In the Upload file dialog, select the file to upload and the 
target folder in Data Store or ECM.

You can add UV- libraries (*.uvl), column databases 
(*.mdb), Easy Sequence templates (*.est) or classic report 
templates (*.frp). 

NOTE For this way of importing data, the Import After Reprocessing check box 
must be selected in the Preferences > Transfer Settings dialog or in the 
ChemStation Administration Tool.
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This chapter describes how to move methods, sequence and 
data files from a standalone ChemStation Workstation, 
version B.04.03 SP1 and SP2, to an OpenLAB CDS 
ChemStation Edition Workstation when the data is stored in 
the container mode. 
 
Also included in this chapter is a list of documents that 
contain more details on reusing data. 



13 Reusing B.04.03 ChemStation Data in OpenLAB CDS

Reusing Your Data in a Standalone Open LAB CDS ChemStation Edition System

Steps to Migrate

1 Manually backup data acquired for all ChemStation 
B.04.03 SP1 instruments. 

2 Run the Configuration Editor and record the following 
details of each configured instrument. You need these 
details to reconfigure your instruments in OpenLAB CDS 
ChemStation Edition.

a Instrument number

b Instrument name

c Instrument type

d Connection settings (for example, IP address or GPIB 
address)

3 Uninstall all Add- On Solutions. Refer to the Add- On 
Solution manual for specific uninstallation instructions.

4 Install OpenLAB CDS ChemStation Edition. During the 
installation, the Master Installer either uninstalls the 
previous ChemStation or moves it to a different folder 
before installing OpenLAB CDS ChemStation Edition.

• If you choose to keep the existing ChemStation folder, the 
installed ChemStation files are removed, and all 
user- created files are moved to a backup folder, for 
example, Chem32_001. 

• If you choose to create a new folder, the existing folder is 
retained with its original name.

5 To move data which was previously saved in a container 
mode, add the path from the ChemStation B.04.03 
version to the new directory/machine by using the 
Preferences > Path > Add function. 

a In the Data Analysis view, select View > Preferences to 
open the Preferences dialog box.

b Click the Paths tab. 

c Press Add and navigate to the location of the sequence 
templates, data, and master methods, that were 
created by the ChemStation B.04.03 system. (This 
could be from the backup folder of the ChemStation 
B.04.03 system, which was prepared before upgrading, 
or the backup folder Chem32_001 generated by the 
Master Installer.)
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d Click OK. 
 
The selected paths and all the sequence templates, 
data, and master methods stored in them are now 
displayed in the ChemStation Explorer.

6 Double- click each sequence, one at a time, to load the 
associated data files into ChemStation memory, then 
click the Start Reprocessing icon to reprocess the data and 
generate a ChemStation result set. Please see the 
Checksum.ini and Sequence.acaml file for the time stamp 
to confirm that the data was reprocessed.

Path identified in step 5

Start Reprocessing icon
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Reusing Your Data in a Standalone Open LAB CDS ChemStation Edition System

Facts to Know for Data Migration

Compatibility of ChemStation Entities

In general, forward compatibility is guaranteed. This means 
that it is possible to load methods, sequence templates and 
data from previous versions in newer versions. This is 
especially true for loading files from any ChemStation rev. 
B.xx.xx version into OpenLAB CDS ChemStation Edition rev. 
C.xx.xx. But there is no backward compatibility. Once a 
method or sequence template has been stored in OpenLAB 
CDS ChemStation Edition rev. C.xx.xx, it can no longer be 
used in a ChemStation rev. B.xx.xx. The same is true for 
data. Loading data files from OpenLAB CDS ChemStation 
Edition rev. C.xx.xx in ChemStation rev. B.xx.xx is not 
supported and could lead to serious issues with the data 
files creating wrong or incomplete results. Therefore Agilent 
recommends clearly separating ChemStation rev. B.xx.xx files 
from OpenLAB CDS ChemStation Edition rev. C.xx.xx files 
within ECM to make sure that files are not loaded in an 
older version by accident.

Migration of Reporting Templates

Currently there is no migration for old FRP report templates 
to the new RDL report template format. Old FRP templates 
will continue to work in OpenLAB CDS ChemStation Edition 
rev. C.xx.xx, but new RDL templates have to be created from 
scratch.

Migration of Classic Methods to RC.net Methods

RC.net methods were introduced in ChemStation rev. 
B.04.02. The method migration (migrating classic methods to 
RC.net methods) will still work the same way in OpenLAB 
CDS ChemStation Edition rev. C.xx.xx. An RC.net method 
cannot be converted back to a classic method. 

Estimated Time to Upgrade

The estimated time to upgrade from ChemStation B.04.03 
SP1 to OpenLAB CDS ChemStation Edition rev. C.xx.xx is 
approximately 30 minutes for software upgrade.
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List of Detailed Documents to Reference 

1 Overview of Upgrade procedures:

Please refer to the chapter Overview of the Upgrade 
Procedure in the OpenLAB CDS ChemStation Edition 
Upgrade Preparation Guide, (M8301- 90033, 
CDS_CS-Upgrade.pdf on disc 2)

2 Result Set Migration and more details on ChemStation 
data structure:

Please refer to the chapters Result Set Migration and 
ChemStation Data Structure in the OpenLAB CDS 
ChemStation Edition Concepts and Workflows Guide 
(M8301- 90016, CDS_CS_Concepts.pdf on disc 2)

3 Upload and reprocess workflows:

Please refer to the chapter Working with ChemStation 
and Central Data Storage in the OpenLAB CDS 
ChemStation Edition with Central Data Storage User's
Guide (M8301- 90084, CDS_CS-with-DataStorage.pdf on disc 2) 
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