Agilent

Software Status Bulletin


     

Known Problem Report as of Sep 21 2026 4:00AM

Preface
-------------------------
This Software Status Bulletin (SSB) documents all known problems in the software
product designated above. The SSB is derived from Known Problem Reports (KPR)
which result from user problems that have been classified as documentation
problems or software defects. When a KPR is written, an identifying number is
assigned to it, and the KPR is added to the next edition of the SSB.

User inputs that have been classified as Enhancement Requests are not documented
in the SSB. User problems that have been submitted, but that have not been
classified by the time the SSB is generated are not included in the SSB.

How to use the SSB
-------------------------
When you experience a problem with a product, first check this SSB to see if the
problem has been reported already, and if there is a temporary workaround
available for the problem, or if the problem has already been fixed by a new
revision. If the problem is not listed in this SSB then you may wish to report
it to the Response Center or to your field support representative.


To determine if your problem is documented in this SSB, first look in the
Keyword Index section of the SSB. Under each keyword is a listing of one-line
descriptions of related KPRs. If any of these sound like yours, locate the KPR
# in the Known Problem Reports section of the SSB, and read the full KPR. The
KPRs in the Known Problem Reports section are sorted by KPR #.


There are two sections in the SSB:
Keyword Index: This index is categorized by keyword. For each KPR there is a
brief description and a KPR #. A KPR may be associated with more than one
keyword.


Known Problem Reports: This section contains KPRs, with all the available
information relevant to the problem. KPRs in this section are sorted by KPR #.


Keyword Glossary



Administration
User Interface

Keyword Index


Keyword: Administration

KPR#:677257 Renaming the computer will fail OMS installation
KPR#:677527 No support for OpenLab MSSQL database
KPR#:759300 An error is displayed when exporting vial locations
KPR#:773937 An error is displayed when importing vial locations
KPR#:779788 "Unknown Error" while Updating CDS Methods in Configuration
KPR#:1383433 Activate Plugins not possible due to error "Could not ping RabbitMQ node rabbit@<hostname>. Error code: 69"

Keyword: User Interface

KPR#:795435 Host name temporarily not displayed correctly


KPR#:738034  Product:    Stage 2

Keyword: 

One-line Description:

Software seizes when refreshing Analytical Instruments 

Problem:

The configuration part of the Agilent Online LC Monitoring Software requires all instrument(s) (configured in OpenLab CDS) to be loaded prior to evaluating the suitability for Online Monitoring. Each connection to a configured instrument temporarily consumes a administration license from CDS. In case more instruments are configured than licenses are available, the loading instruments seizes.

Temporary Solution:

Best practice:
In OpenLab CDS assign a Default Project to your Online LC instrument. When configuration is anticipated, refresh / load only these project which refers to the respective "Default Project" of your instrument.

Fix Information:

n/a


KPR#:785671  Product:    Stage 2.5

Keyword: 

One-line Description:

"Exception of type 'Agilent.OpenLab.DataAnalysis.Api.ApiCommunicationException' was thrown."

Problem:

When configuring an Online LC Monitoring System the user might encounter the error "Exception of type 'Agilent.OpenLab.DataAnalysis.Api.ApiCommunicationException' was thrown."

Temporary Solution:

n/a

Fix Information:

Ensure that the underlying OpenLab CDS 2.7 is upgraded to OpenLab CDS 2.7 Update 02.


KPR#:787277  Product:    Stage 2.5

Keyword: 

One-line Description:

New acquisition method not listed as "Sleep / Wake-up"

Problem:

Intermittently, it can occur that after a method refresh a new acquisition method will not be listed as available method for "Sleep / Wake-up".

Temporary Solution:

As a workaround:
• Update methods from OpenLab CDS
• Cancel editing the Experiment Setup
• Select a different Experiment Setup from the list
• Return to the former Experiment Setup
By starting the editing again, the method shall now be available as selectable item for "Sleep / Wake-up".

Fix Information:

n/a


KPR#:809055  Product:    Stage 3

Keyword: 

One-line Description:

License server error when launching UI

Problem:

Sometimes the UI shows a license server error.

Temporary Solution:

n/a

Fix Information:

After starting the computer, the license server can take a while to startup. Try again a couple of minutes later.


KPR#:947803  Product:    Stage 2.5

Keyword: 

One-line Description:

Installer Aborts when Writing IQT Files

Problem:

If the IQT folders are write protected, then the installer will abort with an error when copying the IQT files. We currently don't know how these folders become write protected. We have only observed that it has happened a couple of times.

Temporary Solution:

In the folder C:\Program Files (x86)\Agilent Technologies\IQTool\IQProducts delete the following folders:
• Agilent Online LC Monitoring Software CDS Adapter
• Agilent Online LC Monitoring Software Services
• Agilent Online LC Monitoring Software UI
The rerun the setup.
If the above does not help:
• Open CMD as admin
• cd "C:\Program Files (x86)\Agilent Technologies\IQTool"
• attrib -r IQProducts*.* /s
Then rerun the setup.

Fix Information:

n/a


KPR#:1029549  Product:    Stage 2.5 Update 01

Keyword: 

One-line Description:

High dilution speed can lead to hardware error

Problem:

The dilutions speed can be restricted by the solvent used and the capillary system when using the "Diluted to Vial" sample setting. This can lead to a hardware error.

Temporary Solution:

Use a lower dilution speed.

Fix Information:

n/a


KPR#:1054066  Product:    Stage 3

Keyword: 

One-line Description:

Cannot Upgrade to OMS V1.3 or CDS 2.8

Problem:

When upgrading from OMS V1.3 you have two options:
• upgrade the CDS to 2.8 first
• upgrade OMS to 1.3 first.
Both options lead to problems. When upgrading any earlier version of OMS must be removed first.
If CDS is upgraded to 2.8 while OMS is installed, then this will leave OMS in a broken state: not all services are uninstalled (stuck in state 'Starting') and the programs folder is not deleted.
OMS V1.3 installer can fix this:
• if an earlier version is installed, then the user is prompted to remove that first.
• OMS 1.3 installer also does this:
• if any OMS defunct services are leftover, then these are removed
• installation folder is deleted, if not empty

Temporary Solution:

n/a

Fix Information:

n/a


KPR#:1066682  Product:    Stage 3

Keyword: 

One-line Description:

Cannot Upgrade to CDS 2.8 Server While OMS V1.2 is Installed

Problem:

When trying to upgrade CDS 2.7 Server to CDS 2.8 Server while OMS V1.2 is still installed, an error will occur:
The CDS 2.8 upgrade procedure cannot stop RabbitMQ, because OMS Services depend on it and refuse to shut down.

Temporary Solution:

Either retry the upgrade or manually remove all OMS service dependencies by removing the value 'DependOnService' from each of the following registry entries:
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software CDS Adapter",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Controller",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Execution Engine",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Notification Service",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software OPC API",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Persistence",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Reprocessing",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Services",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software System Monitor",
"HKLM:\SYSTEM\CurrentControlSet\Services\Agilent Technologies Online Monitoring Software Web API"

Fix Information:

n/a


KPR#:1071760  Product:    Stage 2.5 Update 01

Keyword: 

One-line Description:

All sample times show 00:00:00

Problem:

All sample times show 00:00:00 after chaning time, timezone or switching between daylight savings time or visa versa.

Temporary Solution:

n/a

Fix Information:

Workaround: Restart OMS services or restart machine. Also restart instrument.


KPR#:1073976  Product:    Stage 3

Keyword: 

One-line Description:

Changing time or timezone while services are running

Problem:

If the time or timezone is changed, then the shown times in the activity log are inconsistent.

Temporary Solution:

n/a

Fix Information:

Restart the services or the machine after changing the time or timezone of the machine.


KPR#:1074480  Product:    Stage 3

Keyword: 

One-line Description:

Anonymous Access to OPC UA Automation API Does Not Work

Problem:

If the authentication type OpenLab CDS is set to none, then a client cannot connect to the OPC API. This is intended behavior.
To activate anonymous access:
• Open the file <Program Files>\Agilent Technologies\Online Monitoring\bin\OpcApi\config.OpcApiServer.Config.xml
• Uncomment the code block:
 <ua:UserTokenPolicy>
    <ua:TokenType>Anonymous_0</ua:TokenType>
 </ua:UserTokenPolicy>

Temporary Solution:

n/a

Fix Information:

The end user can activate anonymous access, but at their own risk. This is not a certified solution.


KPR#:1083191  Product:    Stage 3

Keyword: 

One-line Description:

Error When Launching UI in Distributed System with ECM 3.6

Problem:

When launching UI user is shown this error:
"Failed to initialized API using server url: http://<servername>
Exception has been thrown by the target of an invocation.
Inner exception message: SOAP security negotiation with 'http://vhruskov-504/ECMCommApp/ECMCommService.svc/CertificateBinding' for target 'http://<servername>/ECMCommApp/ECMCommService.svc/CertificateBinding' failed. See inner exception for more details.
Inner exception message: SOAP security negotiation with 'http://vhruskov-504/ECMCommApp/ECMCommService.svc/CertificateBinding' for target 'http://<servername>/ECMCommApp/ECMCommService.svc/CertificateBinding' failed. See inner exception for more details.
Inner exception message: The client and server cannot communicate, because they do not possess a common algorithm"

Temporary Solution:

n/a

Fix Information:

The user has the option to disable TLS1.0/1.1, which are obsolete. This is not compatible with ECM 3.6.
If the user chose to disable this option, then this must be undone:
1. Open regedit as administrator
2. Navigate to the entry "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client"
3. Change value of "DisabledByDefault" to 0.
4. Change value of "Enabled" to 1.
5. Do the same for "Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.1\Client"
6. Reboot the machine.


KPR#:1134411  Product:    Stage 4

Keyword: 

One-line Description:

Online LC Monitoring SW Services fail to connect to remote Postgres Server

Problem:

When a remote server is used to host a postgres database, i.e., the database is not hosted on the OpenLab Server, then the Online LC Monitoring SW Services fail to connect to it.

Temporary Solution:

Workaround
After installing the package 'Services' open Persistence.Configuration.json and change the attribute 'DbHost' from the default value 'localhost' to the desired hostname.

Fix Information:

n/a


KPR#:1301467  Product:    Stage 2.5

Keyword: 

One-line Description:

CDS 2.7 Update 11 Breaks RabbitMQ Service

Problem:

If CDS 2.7 Update 11 is installed, then the RabbitMQ services is no longer functional. This service is required by the Online LC Monitoring Software.

Temporary Solution:

Do not use apply Update 11 for OpenLab CDS 2.7.

Fix Information:

Update CDS 2.7 to Update 12.


KPR#:1306083  Product:    Stage 4

Keyword: 

One-line Description:

Licenses cannot be returned in Failover Mode

Problem:

OMS might run out of licenses after recovering from failover, because they cannot be returned during failover.

Temporary Solution:

Restart license server on OpenLab Server.

Fix Information:

n/a


KPR#:1323666  Product:    Stage 5

Keyword: 

One-line Description:

Experiment Start Preparation fails with "BadInternalError" in UAExpert

Problem:

Experiment Start Preparation fails many times with "BadInternalError" in UAExpert

Temporary Solution:

This is a timeout issue on the client side. 
Workaround:
If this error occurs, the client should poll the experiment status and check if it transitioned to the desired state.

Fix Information:

n/a


KPR#:1361586  Product:    Stage 4

Keyword: 

One-line Description:

Cannot Activate RabbitMQ Federation Plugins with ActivatePlugins.ps1

Problem:

After installing the SW on a server with failover support, the RabbitMQ Federation plugins cannot be enabled using the script ActivatePlugins.ps1.
The plugins are not shown in the web interface https://<hostname>:15671/openlab/rabbitmq/

Temporary Solution:

Use RabbitMQ's web interface to shorten the cluster name, e.g.
rabbit@cds2d00087901s.agtlab.local -> rabbit@cds2d00087901s
Afterwards restart services (script in folder RabbitMqHelpers):
Services stop
Services start
Run ActivatePlugins.ps1 again
Optional: After the plugins have been activated, then cluster name change can be reverted.

Fix Information:

n/a


KPR#:1365924  Product:    Stage 4

Keyword: 

One-line Description:

Job status Failed because result file path length is bigger than 222 characters

Problem:

When using OMS with CDS 2.8 and ECM 3.6 you might get an error that the character limit exceeds 222 characters when running an experiment.
This is due to a limitation in ECM 3.6.

Temporary Solution:

User shorter names for experiment setups, method sets, etc.

Fix Information:

n/a


KPR#:1379609  Product:    Stage 3

Keyword: 

One-line Description:

Installation of OMS with MS SQL Server with Password Policies

Problem:

When installing OMS on a distributed system which uses MS SQL Server the installation can fail due to password policies defined for MS SQL Server. The installation fails during Data Repository registration.

Temporary Solution:

User SQL Server Management Studio to create the user 'instrumentonlinemonitoring' before executing the Online LC Monitoring SW. During the installation then use the password used in SQL Server Management Studio.

Fix Information:

n/a


KPR#:677257  Product:    Stage 2

Keyword: Administration

One-line Description:

Renaming the computer will fail OMS installation

Problem:

If the computer is renamed after OpenLab CDS has been installed, then the installation of Agilent Online LC Monitoring Software fails. After renaming the computer the CDS is misconfigured; the CDS needs to be fixed first.

Temporary Solution:

n/a

Fix Information:

In case the computer name of the computer dedicated for the use of OpenLab CDS and Online Monitoring Software has to be changed - do this BEFORE installing OpenLab CDS.


KPR#:677527  Product:    Stage 2

Keyword: Administration

One-line Description:

No support for OpenLab MSSQL database

Problem:

When installing OpenLab CDS, the user has the option to choose the type of database - MSSQL or PostgreSQL. The Online Monitoring Software however does not support the installed MSSQL database type. At this point only PostgreSQL is supported as database type.

Temporary Solution:

When installing OpenLab CDS 2.7 (or higher) use only PostgreSQL as database type when the intention is to use Online Monitoring Software

Fix Information:

n/a


KPR#:759300  Product:    Stage 2

Keyword: Administration

One-line Description:

An error is displayed when exporting vial locations

Problem:

When exporting vial locations during the experiment preparation an error is shown in some cases.

Temporary Solution:

n/a

Fix Information:

The cause of this error is that the default folder for exporting vial locations is pointing to a a folder in which the user does not have write access to.
Workaround:
• Close the UI
• Run the UI as administrator
• Export vial locations to a folder which the user has write access to
• Close the UI
• Open the UI as standard user
The last used folder will be suggested as a storage location the next time vial locations are exported.


KPR#:773937  Product:    Stage 2

Keyword: Administration

One-line Description:

An error is displayed when importing vial locations

Problem:

When importing vial locations during the experiment preparation an error is shown in some cases.

Temporary Solution:

n/a

Fix Information:

The cause of this error is that the default folder for exporting vial locations is pointing to a a folder in which the user does not have write access to.
Workaround:
• Close the UI
• Run the UI as Administrator (Operating System)
• Export vial locations to a folder which the user has write access to
• Close the UI
• Open the UI as Standard User
The last used folder will be suggested as a storage location the next time vial locations are exported.


KPR#:779788  Product:    Stage 2.5

Keyword: Administration

One-line Description:

"Unknown Error" while Updating CDS Methods in Configuration

Problem:

Updating methods form OpenLab CDS in the Agilent Online LC Monitoring Software can cause an "Unknown Error".

Temporary Solution:

n/a

Fix Information:

OpenLab CDS 2.7 methods are not suitable to be used with OpenLab CDS 2.6. In an unlike event that OpenLab CDS 2.7 methods are copied to an OpenLab CDS 2.6 system, the Agilent Online LC Monitoring Software might show "Unknown error" when retrieving the methods from the CDS. This scenario is not supported.


KPR#:1383433  Product:    Stage 4

Keyword: Administration

One-line Description:

Activate Plugins not possible due to error "Could not ping RabbitMQ node rabbit@<hostname>. Error code: 69"

Problem:

When activating RabbitMQ Federation plugins the user receives the error message "Could not ping RabbitMQ node rabbit@<hostname>. Error code: 69".

Temporary Solution:

Copy the cookie C:\Windows\System32\config\systemprofile\.erlang.cookie to the user's profile folder, then restart the service RabbitMQ.

Fix Information:

This is due to a mismatch of the .erlang.cookie files:
• C:\Windows\System32\config\systemprofile\.erlang.cookie
• C:\$USERPROFILE\.erlang.cookie
These files need to be identical for the rabbitmq control commands to work.


KPR#:795435  Product:    Stage 2.5

Keyword: User Interface

One-line Description:

Host name temporarily not displayed correctly

Problem:

In some cases the hostname in the audit trail shows the FQDN and not the hostname alone.

Temporary Solution:

Close the dialog when FQDN is shown and open it again. When re-opening the affected dialog, the FQDN is removed.

Fix Information:

n/a