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What is MassHunter BioConfirm?
What is MassHunter BioConfirm?

MassHunter BioConfirm provides automated and interactive protein and 
oligonucleotide confirmation for TOF and Q-TOF data, with the following features:
• Automated post acquisition data analysis and report generation.
• Biomolecule-centric navigation for peptides, proteins, released glycans, and 

oligonucleotides.
• Intact protein UI functionality, most notably the visualization of ion sets and 

showing deconvoluted spectra in a separate window.
• Protein sequence matching, including target protein and potential 

modifications for intact protein and protein digest sequence types.
• Finding glycans from the target glycan source.
• Finding targets and impurities for oligonucleotides.
• Confirming sequences for oligonucleotides.
• Letting you assign site specific variable modification for protein and protein 

digest sequence types.
• MFE algorithm - molecular feature extractor for finding peptides in complex 

LC MS/MS data.
• Relative protein level can be measured either by height from the deconvoluted 

spectrum or height/area of EIC using all ion set peaks.
• Protein biomolecule quality filters, which prevent “noise” peaks from the 

deconvoluted spectrum being considered a biomolecule, by requiring 
sufficient evidence in the m/z spectrum.

• Protein sequence editing/matching.
• Oligonucleotide sequence editing/confirming.
• Viewing fragment confirmation for oligonucleotides analyzed with Sequence 

Confirmation experiment.
• Linked navigation between biomolecules with assigned protein digest 

matches and peptide sequence within the Sequence Coverage Map.
• Multiple-enzyme digestion sequence coverage display (where each data file 

represents a single digestion result).
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What is MassHunter BioConfirm?
What’s New in 12.0
What’s New in 12.0

• BioConfirm has a new workflow to characterize oligonucleotides.
• You select one of the following experiments to use with the oligonucleotide 

workflow: Target Plus Impurities (TPI) or Sequence Confirmation (SC).
• The Oligonucleotides - Target Plus Impurities workflow is an MS1 analysis of 

an oligonucleotide and its impurities.
• The Oligonucleotide - Sequence Confirmation workflow is an MS/MS analysis 

of the full-length product to confirm the sequence of bases in an 
oligonucleotide.

• The Oligos - Impurity List window shows the impurity profile from running the 
Oligonucleotide - Target Plus Impurities workflow.

• The Results Compare window has a new tab to show the comparison 
between data files analyzed with the Oligonucleotide - Target Plus Impurities 
workflow.

• The Fragment Confirmation Ladder window shows sequence coverage 
results of the oligonucleotide from the Oligonucleotide - Sequence 
Confirmation workflow.

• The Sequence Manager allows you to define oligonucleotide sequences and 
their modifications.

• You can define Building Blocks, Linkers, and Modifications for 
oligonucleotides in the Chemical Data Dictionary.

• You can print a multi-sample report interactively on samples analyzed with the 
Oligonucleotide - Sequence Confirmation workflow.

• You can run the DAR calculations as part of the Intact Protein workflow.
• Incorporation of MFE allows for improvements in the detection of 

deamidation in peptide mapping analysis.
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Where to find more information
Where to find more information

Resource App

Look for these guides on the Agilent website (https://agilent.com.)
• MassHunter BioConfirm Introduction Guide
• This guide (MassHunter BioConfirm Quick Start Guide)

Online Help

Online Help for BioConfirm is available as part of the MassHunter Help and 
Learning. Online Help provides more information and can be displayed in the 
following ways:
• Click Contents from the Help menu.
• Press the F1 key to get more information about a window or dialog box.

Agilent Community

To get answers to your questions, join over 10,000 users in the Agilent 
Community. Review curated support materials organized by platform 
technology. Ask questions to industry colleagues and collaborators. Get 
notifications on new videos, documents, tools, and webinars relevant to your 
work.

https://community.agilent.com
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MassHunter BioConfirm Installation
Installing the software
MassHunter BioConfirm Installation

Installing the software

Refer to the MassHunter Workstation Installation Guide for complete installation 
details. Additional setup tasks are required in the OpenLab Control Panel, which 
are described in that guide.
1 From the M6025-10001 installation media, right-click Setup.exe, and then 

click Run as administrator.
2 Follow the instructions on the screen to install the software.
3 Get and add the MassHunter BioConfirm license. See the MassHunter 

Workstation for Agilent LC/MS Installation Guide for details.
4 On a Networked Workstation only, register OpenLab Shared Services.

For BioConfirm, if OpenLab Settings are not registered as the last step of 
BioConfirm installation, click Start > Agilent MassHunter BioConfirm > Tools 
for BioConfirm 12.0. Then, run Register OpenLab Settings. All default 
users/roles/groups are added, and permissions for BioConfirm are loaded 
into the OpenLab Control Panel.

Removing the software

Use Programs and Features in Windows Control Panel to remove Agilent 
MassHunter Workstation BioConfirm Software.
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Starting BioConfirm from the OpenLab Control Panel
Starting BioConfirm from the OpenLab Control Panel

To start the BioConfirm program, you need to select the project that you are 
using. If no projects exist, you need to first create the project.
1 Double-click the OpenLab Control Panel icon on the desktop. You can instead 

click Start > Agilent Technologies > Control Panel.
2 Click Projects in the left pane.
3 If needed, click Create > Create Project in Projects and Groups on the ribbon. 

All of your data files, methods, sequences, report templates, and databases 
are stored in a project. See the online Help for OpenLab Control Panel for 
more information.

4 Select the project that you want to use in the left pane.
5 On the ribbon in the BioConfirm group, click BioConfirm > Start BioConfirm. 

You can instead click BioConfirm > Create BioConfirm Shortcut to create a 
desktop icon that you can click to start BioConfirm with the selected project.

Migrating Methods from 10.0 or 11.0 to 12.0

Before you use a method in Worklist Automation that was created in a previous 
release of BioConfirm, open and save the method in the project in BioConfirm 
12.0. You only need to import a method in Networked Workstation mode.
1 In BioConfirm 12.0, click File > Import to Project > Method(s).
2 In the Method Import dialog box, select the methods you wish to import.
3 Click Import.
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User Interface
Main Functional Areas
User Interface

Main Functional Areas

The main BioConfirm window consists of three parts: (1) the Menu Bar, (2) the 
Toolbar, and (3) the Main Window. The main functional areas are shown in 
Figure 1, Figure 2 on page 10, Figure 3 on page 11, Figure 4 on page 12, and 
Figure 5 on page 13. Some windows are not shown because they are not in the 
default layout.

Figure 1. The main functional areas of BioConfirm for the Intact Protein workflow
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Main Functional Areas
Figure 2. The main functional areas of BioConfirm for the Protein Digest workflow
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Figure 3. The main functional areas of BioConfirm for the Released Glycans workflow
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User Interface
Main Functional Areas
Figure 4. The main functional areas of BioConfirm for the Oligonucleotides workflow when the Experiment is Target Plus Impurities
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User Interface
Main Functional Areas
1. Menu Bar

The menu bar (Figure 6) provides actions that are used for opening methods and 
data files, finding and identifying biomolecules, printing and exporting reports, 
and accessing the Sequence Manager and Chemical Data Dictionary.

Figure 5. The main functional areas of BioConfirm for the Oligonucleotides workflow when the Experiment is Sequence Confirmation

Figure 6. Menu bar
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User Interface
Main Functional Areas
2. Toolbar

The toolbar provides actions that are used for opening data files and closing data 
files. You can also save results and print a Biomolecule report. Two icons allow 
you to undo or redo the last actions performed. The last icon toggles whether the 
Method Editor window is open.

Toolbar Icon Action

• File > Open Data File
• File > Save Results
• File > Close Data File
• File > Print > Biomolecule Report

• Undoes last action performed
• Redoes last action undone.

• Toggles whether the Method Editor window is open.

• Loads the layout for the Intact Protein workflow. You can 
change the layout that loads when you click this button in 
either the Load BioConfirm Layout dialog box or the 
Save BioConfirm Layout dialog box.

• Loads the layout for the Protein Digest workflow. You 
can change the layout that loads when you click this 
button in either the Load BioConfirm Layout dialog box 
or the Save BioConfirm Layout dialog box.

• Loads the layout for the Released Glycans workflow. You 
can change the layout that loads when you click this 
button in either the Load BioConfirm Layout dialog box 
or the Save BioConfirm Layout dialog box.

• Loads the layout for the Oligonucleotides workflow when 
the Experiment is Target Plus Impurities. You can 
change the layout that loads when you click this button in 
either the Load BioConfirm Layout dialog box or the 
Save BioConfirm Layout dialog box.

• Loads the layout for the Oligonucleotides workflow when 
the Experiment is Sequence Confirmation. You can 
change the layout that loads when you click this button in 
either the Load BioConfirm Layout dialog box or the 
Save BioConfirm Layout dialog box.
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User Interface
Main Functional Areas
3. Main window

The main window, see Figure 2 on page 10, is further divided into many windows: 
Sample Table, Method Editor, Method Audit Trail, Results Audit Trail, Chemical 
Data Dictionary Audit Trail, Sample Chromatogram Results, Spectrum Preview, 
Biomolecule MS Chromatogram, Biomolecule MS Spectrum, Biomolecule 
Fragment Spectrum, Deconvolution Results, Deconvolution Mirror Plot, MS 
Spectrum Mirror Plot, Fragment Spectrum Mirror Plot, Biomolecule 
Chromatogram Mirror Plot, Sample Chromatogram Mirror Plot, MS Actuals, 
Biomolecules, Biomolecule Identification Results, Results Compare, Relative 
Quantitation Histograms, Sequence Coverage Map, Fragment Confirmation 
Ladder, Peptide Relative Quantitation Results, Glycan Structure Viewer, and 
Oligos - Impurity List. For most of these windows, you toggle whether these 
windows are visible in the View menu.

Sample Table The Sample Table shows information for each sample that is 
opened. The sample or samples which you select in this window are displayed in 
the other windows. You can reprocess the selected sample.

Method Editor A method is a set of parameters that are associated with the 
different algorithms that you can run. Methods containing these parameters can 
be saved using unique file names.

You select the section of the method to display in the left pane. The right pane 
contains either a single section or multiple tabs. You can get help for each tab or 
section in the Method Editor when you press F1.

Figure 7. Sample Table window
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User Interface
Main Functional Areas
Sample Chromatogram Results This window shows the chromatograms for 
each sample that is selected in the Sample Table window. The types of 
chromatograms include a Total Ion Chromatogram (TIC), a Base Peak 
Chromatogram (BPC), an Extracted Ion Chromatogram (EIC), and other 
chromatograms. You can overlay the chromatograms for the selected 
biomolecule.

Figure 8. Method Editor window

Figure 9. Sample Chromatogram Results window
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User Interface
Main Functional Areas
Spectrum Preview This window is used to quickly scan the spectra in a 
chromatogram. You start this window either when you click the Walk icon in the 
Sample Chromatogram Results toolbar or when you click View > Spectrum 
Preview. 

Biomolecule MS Chromatogram This window shows an Extracted Ion 
Chromatogram (EIC) for each of the biomolecules you selected in the 
Biomolecules window. You can display a legend in the upper right corner of the 
graphic if you select Overlaid mode for the chromatograms. You can add 
annotations to the graphic. You can also export or print the graphic.

Figure 10. Spectrum Preview window

Figure 11. Biomolecule MS Chromatogram window
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User Interface
Main Functional Areas
Biomolecule MS Spectrum This window shows any MS spectrum. MS/MS 
spectra are displayed in the Biomolecule Fragment Spectrum window. You can 
add annotations and calipers to a spectrum in this window. You can also see the 
peak list which is displayed in a table on the right-side of this window. In addition, 
you can deconvolute, print, and export spectra in this window.

Biomolecule Fragment Spectrum This window shows any MS/MS spectrum. MS 
spectra are displayed in the Biomolecule MS Spectrum window. You can also see 
a peak list, annotate, and add calipers to a Fragment Spectrum. 

Figure 12. Biomolecule MS Spectrum window

Figure 13. Biomolecule Fragment Spectrum window
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User Interface
Main Functional Areas
Deconvolution Results This window shows deconvoluted mass spectra. You 
can add annotations and calipers to a spectrum in this window. You can also 
display the peak list which is displayed in a table on the right-side of this window. 
You can see peak lists, print spectra, and export spectra in this window.

Deconvolution Mirror Plot This window displays two deconvoluted spectra 
selected from the Deconvolution Results window. The first deconvoluted spectra 
is displayed as the top plot, and the second deconvoluted spectra is displayed as 
the inverted or bottom plot. You can switch the order of the spectra.

Four additional mirror plots are available for other types of data
• MS Spectrum Mirror Plot
• Fragment Spectrum Mirror Plot
• Biomolecule Chromatogram Mirror Plot
• Sample Chromatogram Mirror Plot

Figure 14. Deconvolution Results window in Overlaid mode

Figure 15. Deconvolution Mirror Plot
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User Interface
Main Functional Areas
MS Actuals This window is used to review the Data Acquisition parameters for 
the selected spectrum. The four columns in the MS Actuals table are Category, 
Name, Value, and Unit. 

Biomolecules This window shows all of the biomolecules which were found for 
the selected sample files. You can add and remove columns from this table, and 
you can change the order of the columns.

Biomolecule Identification Results This window shows the results of running the 
Match Sequences algorithm on the biomolecules in the Biomolecules table. If 
you see Sequence Match as the value for the ID Techniques Applied column, 
then you can see additional information about that match in this window.

Figure 16. MS Actuals window

Figure 17. Biomolecules window
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User Interface
Main Functional Areas
Results Compare This window displays tables of information that let you 
compare different data files that have been processed with the same workflow. 
Results from each workflow are shown in different tabs in this window. The 
information shown on each tab is different.
• Intact Protein tab
• Protein Digest tab
• Released Glycans tab
• Oligos - Target Plus Impurities tab

Figure 18. Biomolecule Identification Results window

Figure 19. Protein Digest tab in the Results Compare window
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User Interface
Main Functional Areas
Relative Quantitation Histograms This window displays the relative quantitation 
values for the biomolecules that have the Use for %Quant check box marked. The 
Use for %Quant check box is in the Biomolecules table for Intact Protein and 
Released Glycans biomolecules, and it is in the Peptide Relative Quantitation 
Results table for Protein Digest biomolecules. You can visually compare the 
relative quantitation values for up to 10 samples. You can group the 
biomolecules by either Biomolecule ID or by Sample. For Intact Protein, this 
window shows Pred Mods vs %Area or %Height. For Released Glycans, this 
window shows Glycan Name vs %Area or %Height.

For the Protein Digest workflow, this window shows the relative quantitation 
values for different modifications. You mark the Use for %Quant check box in the 
Peptide Relative Quantitation Results window. The window shows Modification 
on the x-axis, and the plotted value that is clicked in the Histogram Display 
Options dialog box. You can click %Area, %Height, or %Volume (MS-Only Protein 
Digest).

Figure 20. Relative Quantitation Histograms window

Figure 21. Relative Quantitation Histograms window
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Main Functional Areas
Sequence Coverage Map This window displays information for the protein 
digest sequence selected in the Workflow and Sequences section of the Method 
Editor window and the biomolecule selected in the Biomolecules window. The 
highlighted area in the sequence shows where the current biomolecule matches 
the current sequence. Different lines underneath parts of the sequence show 
where a biomolecule was matched in the sequence. If you run Match Sequences 
on multiple sequences, then you can see multiple sequences in this window. 

Fragment Confirmation Ladder This window displays a sequence and shows the 
fragments that were confirmed in the selected data files. This window only displays 
data for the Oligonucleotides - Sequence Confirmation workflow. The nucleosides are 
displayed separated by lines. The lines can contain up to 9 dots that represent each of 
the fragment types expected to be found at each location. The fragments on the 
bottom limb apply to the nucleoside to the left of the line; the fragments on the top limb 
apply to the nucleoside to the right of the line.

If you run the Oligonucleotides - Sequence Confirmation workflow on multiple data 
files, then you can see fragments from multiple data files in the ladder.

Figure 22. Sequence Coverage Map window

Figure 23. Fragment Confirmation window
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Main Functional Areas
Peptide Relative Quantitation Results This window displays only the peptides 
that were matched and have a predicted modification. If an amino acid at a 
particular location has been found to have a modification in a particular file, it will 
be displayed as a row in the table. Each row has a nested level where the 
included biomolecule information is displayed. For Protein Digest workflow, you 
mark the Use for %Quant check box in the second level of this table.

Glycan Structure Viewer This window displays glycan structures. The structure 
is also shown in the Biomolecule MS Spectrum window.

Figure 24. Peptide Relative Quantitation Results window

Figure 25. Glycan Structure Viewer window
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User Interface
Main Functional Areas
Oligos - Impurity List This window displays information on the oligonucleotide 
impurities that are generated from the oligonucleotide sequence, based on the 
modifications and matching rules used. This window is only available for the 
Oligonucleotides - Target Plus Impurities workflow. You display this window 
when you click Sequence > Oligos - Impurity List. If you run Match Sequences on 
multiple sequences, then you can see multiple sequences in this window. 

Results Audit Trail This window shows Audit Trail information about the data file 
that is currently selected in the Sample Table window. The Audit Trail tracks what 
has changed in the results of the data file. It records who was logged in and when 
the change was made. On a compliance system, it will also display the version of 
the data file in which the change was saved. 

If a row has a pink background, that row has not been reviewed. To review the 
results, you click Review. Then, you enter a Review comment for the results that 
have not been reviewed. When you click OK on the Audit Trail Review dialog box, 
the Review comment is added to the Review Comment column. Two rows are 
added to the audit trail showing that the audit trail has been reviewed and saved 
and by whom, and the newly reviewed rows will turn white.

Three additional Audit Trail windows are available: Method Audit Trail, Chemical 
Data Dictionary Audit Trail, and Sequence Audit Trail (in Sequence Manager).

Figure 26. Oligos - Impurity List window
Agilent MassHunter BioConfirm Software Quick Start Guide 25



User Interface
Main Functional Areas
Figure 27. Results Audit Trail window
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BioConfirm Dialog Boxes

The following dialog boxes are some of the dialog boxes available in MassHunter 
BioConfirm. See online Help for more information.

Chemical Data Dictionary Dialog Box

Lets you customize proteins and oligonucleotides for use with MassHunter 
BioConfirm. For proteins, you can update the list of modifications, links, and 
reagents. The factory-supplied default file cannot be modified, but you can add to 
it and save to a custom copy. For oligonucleotides, you can update building 
blocks, linkers, and modifications. You can modify the factory supplied values.

To open this dialog box Click Open Chemical Data Dictionary Editor on the 
Sequence menu. In the Sequence Manager program, you can use the Open 
Chemical Data Dictionary Editor command on the Edit menu.

Show Sequence Description Dialog Box

Lets you review descriptive information that is stored with both method 
sequences and result sequences.

To open this dialog box Click Show Sequence Description on the Sequence 
menu. In the Sequence Manager program, you can use the Edit Description 
command on the Sequence menu or the Sequence Editor shortcut menu to 
change the description for a sequence; the Description dialog box opens. 

Modifications Dialog Box

Lets you view modifications to the protein sequence. This dialog box only applies 
to Protein sequences.

To open this dialog box Click Applied Modifications on either the Sequence 
menu or the Sequence Editor shortcut menu to open the Applied Modifications 
dialog box. This dialog box contains only the Specified Applied information from 
the Modifications dialog box.

In the Sequence Manager program, you can use the Edit Modifications item on 
the Edit menu or the Sequence Editor shortcut menu to add a modification to a 
sequence. The Modifications dialog box contains three tabs: Local, Global, and 
Specified Applied.
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Applied Links

Lets you review the amino acids linked in the sequence. This dialog box only 
applies to Protein sequences.

To open this dialog box Click Specified Applied Links on the Sequence menu or 
the Sequence Coverage Map shortcut menu to open the Specified Applied dialog 
box. This dialog box contains only the Specified Applied information from the 
Links dialog box. 

In the Sequence Manager program, you can use the Edit Links command on the 
Edit menu or the Sequence Editor shortcut menu to add a link to a sequence. The 
Links dialog box contains three tabs: Global, Specified Applied, and Unspecified 
Disulfide Links. See “Applying or editing protein links” on page 86.
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Workflows
Workflows and Sequences

In the Method Editor in the Method Automation > Workflow and Sequences 
section, you select the workflow and set workflow parameters. 

Workflows

You select a workflow in the Method Editor window in the Method Automation > 
Workflow and Sequences section. This workflow decides what operations are to 
be run and how the sequence match is to be done when you run the method. 
BioConfirm supports five workflows: Intact Protein, Protein Digest, Released 
Glycans, Oligonucleotides, and Custom.

Intact Protein

The workflow runs the Find by Protein Deconvolution algorithm, and then runs 
Intact Protein matching rules to match sequences.

A report is only generated if you run Run Method Automation (Workflow + 
Reports) or if you generate the report interactively. A Biomolecule report is 
generated using the Intact Protein report template selected on the Method 
Automation > Reports > Templates tab.

Figure 28. Method Automation > Workflow and Sequences section for Intact Protein workflow
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Workflows and Sequences
Workflows
Protein Digest

This workflow runs the Find Peptides algorithm, and uses protein matching rules 
(Protein Digest, Predicted Modifications) to match sequences. You can select 
whether or not to use Protein Truncation. The workflow also runs the Match 
Sequences algorithm with the Sequence or mass that you entered and digests 
the sequence using the enzyme selected. See Figure 29 on page 30.

A report is only generated if you run Run Method Automation (Workflow + 
Reports) or if you generate the report interactively. A Biomolecule report is 
generated using the Protein Digest report template selected on the Method 
Automation > Reports > Templates tab.

Released Glycans

This workflow runs the Find Glycans algorithm and uses the Target glycan 
source that you entered. See Figure 30 on page 31. This source by default is in 
the method but it can also be in the PCDL folder or other folders in the project. 
You can specify the Glycan Group name for this sample. Results in the Released 
Glycans tab in the Results Compare window are sorted by Glycan Group.

A report is only generated if you run Run Method Automation (Workflow + 
Reports) or if you generate the report interactively. A Biomolecule report is 
generated using the Released Glycans report template selected on the Method 
Automation > Reports > Templates tab.

Figure 29. Method Automation > Workflow and Sequences section for Protein Digest workflow
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Workflows
Oligonucleotides

For this workflow, you also select the Experiment: either Target Plus Impurities 
or Sequence Confirmation. For the Target Plus Impurities experiment, you enter 
the Sequence, Modifications, and Matching Rules; for the Sequence Confirmation 
experiment, you only enter the Sequence. See Figure 31 on page 31.

A report is only generated if you run Run Method Automation (Workflow + 
Reports) or if you generate the report interactively. A Biomolecule report is 
generated using the Target Plus Impurities report template or the Sequence 
Confirmation report template selected on the Method Automation > Reports > 
Templates tab.

Figure 30. Method Automation > Workflow and Sequences section for the Released Glycans workflow

Figure 31. Method Automation > Workflow and Sequences section for Oligonucleotides workflow with 
Target Plus Impurities experiment
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Sequences
Custom

This workflow runs the actions which you select in the Workflow and Sequences 
section. You select the actions from the Available actions list and place them in 
the Actions to be run list. The order of the actions in the Actions to be run list is 
the order in which the actions are executed. If you generate a biomolecule report, 
it uses the Protein Digest report template if you used the Find Peptides 
algorithm; otherwise, it uses the Intact Protein report template.

Sequences

You create and edit sequences in the Agilent MassHunter Sequence Manager 
program. You can add either Proteins or Oligonucleotides, and they are seen on 
separate tabs.

You can add a sequence manually, or you can add a sequence from a sequence 
file (psq), text file (txt), or FAST-A file. You edit sequences in the Sequence 
Manager program. For Oligonucleotides, you add Building Blocks, Modifications, 
and Linkers in the Chemical Data Dictionary dialog box. For Proteins, you add 
Modifications, Links, and Reagents.

You specify a sequence in the Method Editor window in the Method Automation > 
Workflow and Sequences section.

Figure 32. MassHunter Sequence Manager program
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Intact Protein Workflow

The topics in this section will help you get started using the Intact Protein 
workflow features of MassHunter BioConfirm.
• “Running the Intact Protein workflow” on page 34
• “Running the Intact Protein workflow with DAR” on page 35
• “Finding biomolecules by Protein Deconvolution” on page 37
• “Matching sequences for intact protein biomolecules” on page 39
• “Viewing protein deconvolution results” on page 40
• “Viewing deconvolution biomolecules” on page 44
• “Viewing DAR results for Intact Protein biomolecules” on page 45
• “Viewing relative quantitation results for intact proteins” on page 46
• “Printing a report with deconvolution results” on page 48
• “Automating protein confirmation” on page 49

What is deconvolution?

The Deconvolution algorithm does charge state deconvolution of mass spectra 
of large molecules with high charge states. Singly-charged ions with m/z values 
greater than a few thousand Daltons are beyond the mass range of the Agilent 
TOF instrument. However, multiply-charged ions can be observed if their 
mass-to-charge ratio (m/z) falls within the instrument range. This applies to 
proteins which typically become multiply-charged. Based on the maximum 
entropy result, peak modeling (pMod) automatically generates peak models 
without manual intervention and applies these models through fitting and 
validating procedures to provide a highly resolved zero-charge spectrum and a 
set of mass error assessments for each peak. You can select pMod as the 
Deconvolution algorithm on the Deconvolution tab. The other Deconvolution 
algorithms are Maximum Entropy and Large Molecule Feature Extraction 
(LMFE).
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Running the Intact Protein workflow

When you run an Intact Protein workflow, the workflow automatically does these steps:
• Find by Protein Deconvolution
• Match Sequences

1 Open the data file that contains the biomolecules of interest.
2 Open the BioConfirmIntactProtein-Default.m method. Click Method > Open.
3 Select Method Automation > Workflow and Sequences in the Method Editor 

window.
4 Select Intact Protein for the Workflow.
5 Select either reduced or non-reduced for the Condition.
6 Click the  button next to the Sequences/Masses parameter to select a sequence. 

You can instead enter one or more masses. 
7 Click the  button next to the Mods and Profiles parameter to select 

modifications and profiles.
8 Save the method. Click Method > Save As to save to a new name.

9 Click the  button on the Method Editor toolbar to run the method workflow. 
You can instead click Method > Run Method Workflow.

10 View biomolecules as described in “Viewing deconvolution biomolecules” on 
page 44.

Figure 33. Workflow and Sequences section for an Intact Protein workflow
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Running the Intact Protein workflow with DAR

For the Intact Protein workflow, you can also calculate DAR values.
1 Open the data file that contains the biomolecules of interest.
2 Open the BioConfirmIntactProtein-Default.m method. Click Method > Open.
3 Select Method Automation > Workflow and Sequences in the Method Editor 

window.
4 Select Intact Protein for the Workflow. Select either reduced or non-reduced 

for the Condition.
5 Type a mass for the Sequences/Masses parameter. If you are doing DAR 

calculations, you cannot enter a sequence.
• If you select non-reduced, enter one mass.For non-reduced, you enter the 

intact DAR 0 mass.
• If you selected reduced, enter two masses for the Reduced DAR light chain 

and Reduced DAR heavy chain.
• The Mods and Profiles parameter is ignored when running the DAR 

workflow. You can add them, but they are not considered.
6 Mark the Calculate Drug-to-Antibody Ratio (DAR) check box.
7 Select either Lysine-linked (All) or Cysteine-linked (Even) as the ADC type.
8 Enter The Drug + linker mass.
9 Select Intact Protein > DAR Calculation in the Method Editor window.
10 Enter the DAR 0 Mass(es).
11 Save the method. Click Method > Save As to save to a new name.

Figure 34. Workflow and Sequences section for an Intact Protein workflow
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12 Click the  button on the Method Editor toolbar to run the method workflow. 
You can instead click Method > Run Method Workflow.

13 View biomolecules as described in “Viewing DAR results for Intact Protein 
biomolecules” on page 45.
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Finding biomolecules by Protein Deconvolution

Use this procedure to deconvolute proteins and create a biomolecule list.
1 Open the data file that contains the spectra of interest as described in online 

Help.
2 In the Method Editor window, select Intact Protein > Deconvolute (Protein) in 

the left pane.
3 Set parameters in the Method Editor window in the Deconvolute (Protein) > 

Deconvolution section.
4 Click the  button on the Method Editor toolbar to start processing. You can 

instead click Find and Identify > Find by Protein Deconvolution.
5 Review results in the Deconvolution Results window. If this window is not 

currently displayed, click View > Deconvolution Results.
6 View deconvolution biomolecules as described in “Viewing deconvolution 

biomolecules” on page 44.
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Deconvoluting selected spectra

Use this procedure to deconvolute selected m/z spectra and create a 
biomolecule list.
1 Open the data file that contains the spectra of interest. Click File > Open Data 

File. This process is described in online Help.
2 Select a spectrum as described in online Help.

• Double-click the Sample Chromatogram Results window. or
• Select a range in the Sample Chromatogram Results window and 

double-click that range.
3 In the Method Editor window, select Intact Protein > Deconvolute (Protein) in 

the left pane.
4 Set parameters in the Method Editor window in the Deconvolute (Protein) > 

Deconvolution section.
5 Click the arrow next to the  button on the Method Editor toolbar and select 

Deconvolute Spectrum to start processing.

Tip You can also initiate deconvolution when you right-click an MS spectrum in 
the Biomolecule MS Spectrum window and click Deconvolute > Proteins from 
the shortcut menu. You can also deconvolute Oligonucleotides.

6 Review results in the Deconvolution Results window. If this window is not 
currently displayed, click View > Deconvolution Results. You can manually 
integrate peaks in the Deconvolution Results window.

7 View deconvolution biomolecules as described in “Viewing deconvolution 
biomolecules” on page 44.
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Matching sequences for intact protein biomolecules

Use this procedure to match sequences for biomolecules that were found using 
deconvolution. You need to specify the sequence and modifications and profiles 
in the Method Automation > Workflow and Sequences section.
1 Create biomolecules through deconvolution. See “Finding biomolecules by 

Protein Deconvolution” on page 37 or “Deconvoluting selected spectra” on 
page 38.

2 Select Method Automation > Workflow and Sequences in the Method Editor 
window.

3 Select Intact Protein for the Workflow.
4 Select either reduced or non-reduced for the Condition.
5 Click the  button next to the Sequences/Masses parameter to select a 

sequence.
6 Click the  button next to the Mods and Profiles parameter to select 

modifications and profiles.
7 In the Method Editor window, select Intact Protein > Match Tolerances in the 

left pane.

Make sure to choose the Intact Protein > Match Tolerances section. 

Do not select the Protein Digest > Match Tolerances section.
8 Review the parameters on the Mass Matching, Matching Rules, and Results 

tabs.
9 Click the  button on the Method Editor toolbar to run the Match Sequences 

algorithm. 

Tip You can also start Match Sequences when you click Find and Identify > 
Match Sequences.

10 View deconvolution biomolecules as described in “Viewing deconvolution 
biomolecules” on page 44.
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Viewing protein deconvolution results

Use this procedure to review the results from the following deconvolution 
process:

• “Running the Intact Protein workflow with DAR” on page 35
• “Finding biomolecules by Protein Deconvolution” on page 37
• “Deconvoluting selected spectra” on page 38

1 (optional) Click the Intact Protein Layout icon on the main toolbar.
2 If the Deconvolution Results window is not currently displayed, click View > 

Deconvolution Results.
3 If the Biomolecules window is not currently displayed, click View > 

Biomolecules.
4 Select a biomolecule in the Biomolecules window.
5 Use the following mouse actions to change the display of data:

• Click to select a single mass in the spectrum.
• Drag to select a mass range in the spectrum.
• Ctrl + drag to select another area and keeps the previous area/time 

selected.
• Drag axes to scroll the axes in the direction you are moving the mouse.
• Right-drag to expand the selected area. The area you define is shown as a 

rectangle outlined in black. The Y-scale of the zoomed in display is 
controlled by the Auto-Scale Y-axis mode.

• Right-drag axes to scale the axis. Dragging to the right (x-axis) or to the top 
(y-axis) zooms in on that axis. Dragging to the left (x-axis) or to the bottom 
(y-axis) zooms out on that axis. 

Tip To return to the previous display scale, click the Unzoom toolbar button . 
6 Use the following toolbar buttons in the Deconvolution Results window to 

change the display of data:

Table 1. Toolbar buttons in the Deconvolution Results toolbar

Toolbar button Action/Meaning

Scales the x-axis and y-axis automatically to fit the displayed data.

Scales the x-axis automatically to fit the displayed data.
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Scales the y-axis automatically to fit the displayed data.

Returns to the previous display scale (undoes last zoom operation).

• When this mode is on, the vertical plot range is automatically scaled to fit the data in 
the selected horizontal range when you zoom in. 

• When the Autoscale y-axis during Zoom mode is off, the vertical plot range is set to 
the limits you specify by dragging the mouse.

Toggles whether to scale the y-axis of all deconvoluted spectra to the same scale when 
you zoom in or out on the x-axis.

Plots each spectrum separately. The spectra share the same x-axis, but each spectrum 
has a separate y-axis.

Overlays all spectra. The spectra are shown with the same x- and y-axes.

Cycles to previous spectrum. This toolbar button is only available when you have 
overlaid the spectra.

Cycles to next spectrum. This toolbar button is only available when you have overlaid the 
spectra.

Turns on the Range Select tool.

Turns on the Manual Peak Integration tool. When you select a peak, two black boxes are 
drawn at the beginning and end of that peak. You can drag those boxes to change the 
integration.

Turns on the Annotate tool, which lets you add various annotations.

Turns on the Caliper tool, which lets you measure Modifications, Amino Acids, or Delta 
Mass between peaks or points.

Stops normalizing the deconvolution spectra.

Normalizes all deconvoluted spectra. All deconvoluted spectra are normalized to the 
largest peak in any of the chromatograms.

Normalizes all spectra. Each spectrum is normalized to the largest peak in itself.

Normalizes each spectrum to the highest peak within the selected range.

Table 1. Toolbar buttons in the Deconvolution Results toolbar

Toolbar button Action/Meaning
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7 Right-click the graph to display the following shortcut menu commands:
• Copy Deconvolution Settings to Method - Copies the settings that were used 

to create the Deconvolution Results the Deconvolute (MS): Maximum Entropy 
section of the Method Editor window.

• Include in %Quant - If you select the Manual Integration icon and you are 
displaying the results in List mode, then you can specify to include the 
selected peak in the Relative Quantitation results. The Use in %Quant check 
box for this peak is marked in the Biomolecules table.

• Delete - Deletes the currently highlighted spectra.
• Copy to Clipboard - Copies spectra that are currently visible in the 

Deconvolution Results window to the Clipboard for use with other 
applications.

• Print - Lets you print the Deconvolution Results window.
• Export - Lets you export data and graphics.
• Adjust Peak Threshold- Lets you change the threshold for identifying peaks.
8 (optional) To change the number of significant digits in the deconvoluted 

spectrum, click  in the Deconvolution Results toolbar. Set the Digits after 
the decimal value, and click OK.

9 To compare two deconvoluted spectra:
a Highlight the two spectra of interest in the Deconvolution Results window.
b Click the Deconvolution Mirror Plot Results button .

Displays the two, selected deconvoluted spectra in the Deconvolution Mirror Plot 
window. This button is only available if two deconvoluted spectra are selected.

Displays the Method Editor window as a floating window. This button is not a toggle.

Toggles the display of the peak list tabs in this window. If this option is on, then the right 
pane of this window contains a tab for each deconvoluted spectrum. Each tab contains 
a table of information about a deconvoluted spectrum.

Opens the Deconvoluted Spectra Display Options dialog box.

Prints an image of the contents of the Deconvolution Results window and puts it in a 
PDF file. This PDF is opened automatically.

Table 1. Toolbar buttons in the Deconvolution Results toolbar

Toolbar button Action/Meaning
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The Deconvolution Mirror Plot Results window appears with the first 
spectra displayed as the top plot and the second spectra displayed as the 
inverted or bottom plot. See “Deconvolution Mirror Plot” on page 19.

c Click the  button to reverse the two plots. 

See online Help for more display options in the Deconvolution Mirror Plot 
Results window.

10 (optional) To move the window, drag it to a new position on the screen. To 
return it to its docked position, right-click the title bar and click the Floating 
command.
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Viewing deconvolution biomolecules

Biomolecules are created for proteins that are confidently found. You can view 
these biomolecules as follows:
1 (optional) Click the Intact Protein Layout icon on the main toolbar.
2 If necessary, click View > Biomolecules.
3 If necessary, click View > Biomolecule Identification Results.
4 Click a biomolecule of interest. Associated data in the following windows is 

displayed:
• Deconvolution Results window
• Biomolecule MS Chromatogram window shows an EIC
• Biomolecule MS Spectrum window displays all the different peaks in the 

raw m/z spectrum that indicate the presence of the deconvoluted protein 
mass in the Biomolecule MS Spectrum Results window

• Biomolecule Identification Results if you also ran the Match Sequences 
algorithm.

5 Review the results in the Deconvolution Results window. See “Viewing protein 
deconvolution results” on page 40.

6 Click  on the Deconvolution Results toolbar.
7 View the following information for the deconvoluted spectrum in the 

Deconvolution Results window:

8 Review the columns in the Biomolecule Identification Results window.
9 Right-click the table in the Biomolecule Identification Results window to see 

the shortcut menu. You can add and remove columns, copy to Clipboard, 
print, export and other features.

• Peak • Charge • Mass • Height
• Fit • Max Abund • Expected m/z • Area
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Viewing DAR results for Intact Protein biomolecules

Biomolecules are created for proteins that are confidently found. If you 
calculated DAR values, you can view the DAR calculations as follows:
1 (optional) Click the Intact Protein Layout icon on the main toolbar.
2 If necessary, click View > Biomolecules.
3 Click a biomolecule of interest. Associated data in the following windows is 

displayed:
• Deconvolution Results window
• Biomolecule MS Chromatogram window shows an EIC
• Biomolecule MS Spectrum window displays all the different peaks in the 

raw m/z spectrum that indicate the presence of the deconvoluted protein 
mass in the Biomolecule MS Spectrum Results window

4 In the Deconvolution Results window, examine the DAR spectrum or DAR 
spectra. For a reduced data file, find the Light Chain DAR spectrum and the 
Heavy Chain DAR spectrum. For a non-reduced data file, find the DAR 
spectrum.

5 Click  on the Deconvolution Results toolbar.
6 View the following information for the DAR spectrum in the Deconvolution 

Results window:

7 In the Sample Table window, find the DAR value for the selected Data File. It is 
in the Workflow section of the table. If you do not see that column, click  in 
the Sample Table toolbar to add the DAR column to the Sample Table.

• Use in Calc • DAR Peak • Peak Mass (Da) • Area
• % Area • Max Y • Expected m/z • Mass (Start)

• Mass (End)
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Viewing relative quantitation results for intact proteins

You can only review relative quantitation results for intact proteins that have the 
Use for %Quant check box marked in the Biomolecules window. Samples are 
sorted by the Sequence or Mass.
1 Verify that the Sequence for your samples is the same if you want to compare 

results. 
2 Select one or more Intact Protein samples in the Sample Table window.
3 Click the Intact Protein Layout icon in the main toolbar.
4 Mark the Use for %Quant check box for one or more biomolecules. 
5 Compare intact proteins in the Intact Protein tab in the Results Compare 

window. The Results Compare window shows information for the 
biomolecules that have the Use for %Quant check box marked.

6 Mark or clear the Use for %Quant check box in the Biomolecules window if 
you want to change the results shown in the Results Compare window.

Figure 35. Intact Protein tab in the Results Compare window
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7 View the results in the Relative Quantitation Histograms window. You can 
right-click and drag on the axes to zoom in or zoom out. Once you have 
zoomed in, you can drag the cursor on the axes to scroll through the results.

Figure 36. Relative Quantitation Histograms window for an Intact Protein workflow
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Printing a report with deconvolution results

1 Select Method Automation > Reports in the Method Editor window.
2 Review the options in the Destination section. 
3 Review the parameters in both the Templates and Layouts tabs. Select the 

Intact Protein, the Protein Digest, the Released Glycans, the 
Oligonucleotides - report templates. By default, the following templates are 
used:
• IntactProteinReport.template.xml (for intact proteins)
• ProteinDigestReport.template.xml (for protein digests)
• ReleasedGlycanReport.template.xml (for released glycans)
• TargetPlusImpuritiesReport.template.xml (for Oligonucleotides - Target 

Plus Impurities)
• SequenceConfirmationReport.template.xml (for Oligonucleotides - 

Sequence Confirmation)
4 To print a report, do one of the following. The report template that is used 

depends on the workflow used to create the results for the selected sample. 
• Click Print Report in the Method Editor toolbar if you are in the Method 

Automation > Reports section.
• Click Biomolecule Report from the File > Print menu to print the report.
• Click the  button on the main toolbar.

Tip To print deconvolution spectra, right-click the graph area of the Deconvolution 
Results window and click Print from the shortcut menu.

Tip To print the relative quantitation histogram, right-click the graph area of the 
Relative Quantitation Histograms window and click Print from the shortcut 
menu.

Tip A report is automatically created if you run Method Automation. Method 
Automation first runs the method workflow and then generates a biomolecule 
report. You can run Method Automation when you click Method > Run 
Method Automation (Workflow + Reports).
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Automating protein confirmation

Use this procedure to do protein confirmation automatically for samples in a 
worklist. See the BioConfirm Introduction Guide for more information.
1 In the Method Editor window, select Method Automation > Workflow and 

Sequences.
2 Select Intact Protein as the Workflow.
3 Select either reduced or non-reduced as the Condition.
4 Click the  button to select a sequence. The Select Sequences dialog box 

opens. Select the sequence or sequences, and then click OK.
5 Click the  button to select the Mods and Profiles. The Select 

Modifications and Profiles dialog box opens. Select the modifications and 
profiles, and then click OK.

6 Save the method in any of the following ways:
• Click Save or Save As from the Method menu.
• Click  or  in the Method Editor toolbar.
• Click Save Method from Method Editor shortcut menu (right-click).

7 Assign this method to samples of interest when setting up a worklist in the 
Data Acquisition program as described in the online Help for your instrument.

8 To run this workflow interactively, do the following:
• Click Method > Run Method Workflow or
• Click the  button in the Sample Table.

9 To run this workflow and generate a report interactively, do the following:
• Click Method > Run Method Automation (Workflow + Reports).
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Protein Digest Workflow

The topics in this section will help you get started using the Protein Digest 
workflow features of MassHunter BioConfirm.
• “Running the Protein Digest workflow” on page 51
• “Finding peptides” on page 52
• “Matching sequences for protein digest biomolecules” on page 53
• “Viewing peptide biomolecules” on page 55
• “Viewing sequence coverage results for protein digests” on page 56
• “Viewing relative quantitation results for protein digests” on page 57
• “Printing a report with peptide results” on page 59
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Running the Protein Digest workflow

When you run a Protein Digest workflow, the workflow automatically does these 
steps:

• Find Peptides
• Match Sequences

1 Open the data file that contains the spectra of interest as described in online 
Help.

2 Open the BioConfirmProteinDigest-Default.m method. Click Method > Open.
3 Select Method Automation > Workflow and Sequences.
4 Select Protein Digest for the Workflow.
5 Select either reduced or non-reduced for the Condition.
6 Click the  button next to the Sequences/Masses parameter to select a 

sequence. 
7 Click the  button next to the Mods and Profiles parameter to select 

modifications and profiles.
8 Mark the check box for the appropriate Enzymes. You cannot match 

sequences unless at least one enzyme is marked.
9 Save the method. Click Method > Save As to save to a new name.

Figure 37. Workflow and Sequences section for a Protein Digest workflow
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10 Click the  button on the Method Editor toolbar to run the method workflow. 
You could instead click Method > Run Method Workflow.

11 View biomolecules as described in “Viewing peptide biomolecules” on 
page 55.

Finding peptides

Use this procedure to run the Find Peptides algorithm to create a biomolecule 
list. This algorithm is part of the Protein Digest workflow. 

The default method often does not need to be modified. The parameters for the 
Find Peptides algorithm are in the Protein Digest > Find Peptides section.
1 Open the data file.
2 Click Method > Open and open BioConfirmProteinDigest-Default.m.
3 Click Find and Identify > Find Peptides.
4 View biomolecules as described in “Viewing peptide biomolecules” on 

page 55.
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Matching sequences for protein digest biomolecules

Use this procedure to match sequences for biomolecules that were found using 
Find Peptides. You need to specify the sequence and modifications and profiles 
in the Method Automation > Workflow and Sequences section.
1 Create biomolecules using Find Peptides. See “Finding peptides” on page 52.
2 Select Method Automation > Workflow and Sequences.
3 Select Protein Digest for the Workflow.
4 Select either reduced or non-reduced for the Condition.
5 Click the  button next to the Sequences/Masses parameter to select a 

sequence.
6 Click the  button next to the Mods and Profiles parameter to select 

modifications and profiles.
7 Mark the check box for the appropriate Enzymes. You cannot match 

sequences unless at least one Enzyme is marked.
8 In the Method Editor window, select Protein Digest > Match Tolerances in the 

left pane.

Make sure to choose the Protein Digest > Match Tolerances section. 

Do not select the Intact Protein > Match Tolerances section.
9 Review the parameters on the Mass Matching, FDR, Matching Rules, and 

Results tabs.

Figure 38. Protein Digest > Match Tolerances section in the Method Editor
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10 Click the  button on the Method Editor toolbar to run the Match Sequences 
algorithm. 

Tip You can also start Match Sequences when you click Find and Identify > 
Match Sequences > Match Sequences (Proteins).

11 View peptide biomolecules as described in “Viewing peptide 
biomolecules” on page 55.
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Viewing peptide biomolecules 

You can view peptide biomolecules as follows:
1 If necessary, click View > Biomolecules.
2 If necessary, click View > Biomolecule Identification Results.
3 Click a biomolecule of interest. The following windows are updated when you 

select a biomolecule:
• Biomolecule MS Chromatogram window
• Biomolecule MS Spectrum window
• Biomolecule Fragment Spectrum window
• Biomolecule Identification Results if you also ran the Match Sequences 

algorithm
• Sequence Coverage Map if you also ran the Match Sequences algorithm

4 To see other information for biomolecules in the list, right-click the table, and 
then click Add/Remove Columns from the shortcut menu.

5 See “Viewing sequence coverage results for protein digests” on page 56. 
6 Review the columns in the Biomolecule Identification Results window.
7 Right-click the table in the Biomolecule Identification Results window to see 

the shortcut menu. You can add and remove columns, copy to Clipboard, 
print, export and other features.
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Viewing sequence coverage results for protein digests

The location in the sequence which was matched is highlighted.
1 To display the Sequence Coverage Map window, click View > Sequence 

Coverage Map. 
2 Click the following items on either the Sequence menu or the Sequence 

Coverage Map shortcut menu to view more information about the current 
sequence: 
• Applied Modifications 
• Specified Applied Links

3 Select another sequence match result to view by selecting a different row in 
the Biomolecules window which has a value in the Score (Bio) column. 
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Viewing relative quantitation results for protein digests

You can only review relative quantitation results for Protein Digests when you 
selected one or more modifications and when you mark the Use for %Quant 
check box for at least one biomolecule. By default, the Use for % Quant check 
box is marked, but you can clear any of these check boxes.
1 To display the Peptide Relative Quantitation Results window, click View > 

Peptide Relative Quantitation Results. 
2 Select one or more samples in the Sample Table window that has results from 

the Protein Digest workflow.
3 In the Peptide Relative Quantitation Results window, open a row in the first 

level of the table. Each row shows an amino acid at a particular location that 
has a modification in a selected file.

4 In the second level of the table, mark the Use for %Quant check box for the 
sequence that you want to compare.

Figure 39. Peptide Relative Quantitation Results window
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5 View the results in the Results Compare window. Information on the 
Sequence/Mass for the selected samples is shown in the same table.

6 View the results in the Relative Quantitation Histograms window.

Figure 40. Protein Digest tab in the Results Compare window

Figure 41. Relative Quantitation Histograms window
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Printing a report with peptide results

1 Select Method Automation > Reports in the Method Editor window.
2 Review the options in the Destination section. 
3 Review the parameters in both the Templates and Layouts tabs. Select the 

Protein Digest report template.
• ProteinDigestReport.template.xml (for protein digests)

4 To print a report, do one of the following. The report template that is used 
depends on the workflow used to create the results for the selected sample. 
• Click Print Report in the Method Editor toolbar if you are in the Method 

Automation > Reports section. This method does not show the Print 
Biomolecule Report dialog box.

• Click Biomolecule Report from the File > Print menu to print the report.
• Click the  button on the main toolbar.

Tip To print the relative quantitation histogram, right-click the graph area of the Relative 
Quantitation Histograms window and click Print from the shortcut menu.

Tip A report is automatically created if you run Method Automation. Method Automation 
first runs the method workflow. It then extracts additional chromatograms, and then 
generates a biomolecule report. Finally, it exports the results. You can run Method 
Automation when you click Method > Run Method Automation (Workflow + Reports).

Figure 42. Print Biomolecule Report Dialog Box
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Released Glycans Workflow

The topics in this section will help you get started using the Released Glycans 
workflow features of MassHunter BioConfirm.
• “Running the Released Glycans workflow” on page 61
• “Finding glycans” on page 62
• “Viewing released glycans biomolecules” on page 63
• “Viewing relative quantitation results for released glycans” on page 64
• “Printing a report with released glycans results” on page 66
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Running the Released Glycans workflow

When you run a Released Glycans workflow, the workflow automatically does 
these steps:

• Find Released Glycans
1 Open the data file that contains the data of interest.
2 (optional) Click the Released Glycans Layout icon in the main toolbar.
3 Click Method > Open and open the BioConfirmReleasedGlycans-Default.m 

method.
4 Select Method Automation > Workflow and Sequences in the Method Editor 

window.
5 Select Released Glycans for the Workflow.
6 (optional) Enter the Glycan group.
7 Select the Target glycan source.
8 Mark or clear the Require RT match if database contains an RT for the target 

glycan.
9 Select Released Glycans > Find Glycans.
10 Click the Tag tab in the Released Glycans > Find Glycans section.
11 Select the tag that was used with this data file. 2-AB and InstantPC are 

defined in the BioConfirm program.
12 Save the method. Click Method > Save As to save to a new name.

Figure 43. Workflow and Sequences section for a Released Glycans workflow
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13 Click the  button on the Method Editor toolbar to run the method workflow. 
You could instead click Method > Run Method Workflow.

View biomolecules as described in “Viewing released glycans biomolecules” on 
page 63.

Finding glycans

Use this procedure to run the Find Glycans algorithm to create a biomolecule list. 
This algorithm is part of the Released Glycans workflow. 

The parameters for the Find Glycans algorithm are in the Released Glycans > 
Find Glycans section. To find glycans, you need to specify the Target glycan 
source.
1 Open the data file.
2 Click Method > Open and open BioConfirmReleasedGlycans-Default.m.
3 Click the Released Glycans Layout icon in the main toolbar.
4 Select Released Glycans > Find Glycans in the Method Editor window.
5 Enter the Target glycan source. In this example method the Target glycan 

source is a small database that is part of the method. You can select a 
different Target glycan source that is in the project.

6 Click the Tag tab.
7 Select the tag that was used with this data file. 2-AB and InstantPC are 

defined in the BioConfirm program.
8 Click the  button on the Method Editor toolbar to run Find Glycans. 

View biomolecules as described in “Viewing released glycans biomolecules” on 
page 63.
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Viewing released glycans biomolecules 

You can view released glycans biomolecules as follows:
1 Click Released Glycans Layout in the main toolbar. The Biomolecules window 

and the Biomolecules Identification Results window are both open and tabbed 
in the lower left section of the main window. The Relative Quantitation 
Histograms window and the Results Compare window are both open and 
tabbed in the lower right section of the main window.

2 Click a biomolecule of interest. The following windows are updated when you 
select a biomolecule:
• Biomolecule MS Chromatogram
• Biomolecule MS Spectrum window
• Biomolecule Identification Results window
• Glycan Structure Viewer window (if a glycan structure is available)

3 To see other information for biomolecules in the list, right-click the table, and 
then click Add/Remove Columns from the shortcut menu. 

4 Review the columns in the Biomolecule Identification Results window.

Right-click the table in the Biomolecule Identification Results window to see the 
shortcut menu. You can add and remove columns, copy to Clipboard, print, 
export and other features.
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Viewing relative quantitation results for released 
glycans

You can only review relative quantitation results for Released Glycans that have 
the Use for %Quant check box marked in the Biomolecules window. Samples are 
sorted by the Glycan group.
1 Verify that the Glycan group for your samples is the same if you want to 

compare results. You set the Glycan group in the Method Automation > 
Workflow and Sequences section of the Method Editor. You can edit the 
Glycan Group directly in the Sample Table.

2 Select one or more Released Glycans samples in the Sample Table window.
3 Click the Released Glycans Layout icon in the main toolbar.
4 Select the glycans to compare by marking the Use for %Quant check box in 

the Biomolecules window.
5 Compare glycans in the Released Glycans tab in the Results Compare 

window.
6 Mark or clear the Use for %Quant check box in the Biomolecules window if 

you want to change the results shown in the Results Compare window.

Figure 44. Results Compare window
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7 View the results in the Relative Quantitation Histograms window. You can 
right-click and drag on the axes to zoom in or zoom out. Once you have 
zoomed in, you can drag the cursor on the axes to scroll through the results.

Figure 45. Relative Quantitation Histograms window
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Printing a report with released glycans results

1 Select Method Automation > Reports in the Method Editor window.
2 Review the options in the Destination section. 
3 Review the parameters in both the Templates and Layouts tabs. Select the 

Released Glycans report template.
• ReleasedGlycansReport.template.xml 

4 To print a report, do one of the following. The report template that is used 
depends on the workflow used to create the results for the selected sample. 
• Click Print Report in the Method Editor toolbar if you are in the Method 

Automation > Reports section. This method does not show the Print 
Biomolecule Report dialog box.

• Click Biomolecule Report from the File > Print menu to print the report.
• Click the  button on the main toolbar.

Tip A report is automatically created if you run Method Automation. Method Automation 
first runs the method workflow. It then extracts additional chromatograms and then 
generates a biomolecule report. Finally, it exports the results. You can run Method 
Automation when you click Method > Run Method Automation (Workflow + Reports).

Figure 46. Print Biomolecule Report Dialog Box
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Oligonucleotides Workflow

The topics in this section will help you get started using the Oligonucleotides 
workflow features of MassHunter BioConfirm.
• “Running the Oligonucleotides - Target Plus Impurities workflow” on 

page 68
• “Running the Oligonucleotides - Sequence Confirmation workflow” on 

page 70
• “Viewing results for Oligonucleotides - Target Plus Impurities” on page 72
• “Viewing results for Oligonucleotides - Sequence Confirmation” on page 74
• “Printing a report with oligonucleotides results” on page 75
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Running the Oligonucleotides - Target Plus Impurities 
workflow

When you run an Oligonucleotides workflow, the workflow runs one of the 
following experiment types:

• Target Plus Impurities
• Sequence Confirmation - see “Running the Oligonucleotides - Sequence 

Confirmation workflow” on page 70
1 Open the data file that contains the oligonucleotides of interest as described 

in online Help.
2 Open the BioConfirmOligoTPI-Default.m method. Click Method > Open.
3 Select Method Automation > Workflow and Sequences.
4 Select Oligonucleotides for the Workflow.
5 Select Target Plus Impurities for the Experiment.
6 Click the  button next to the Sequences/Masses parameter to select a 

sequence. 
7 Click the  button next to the Mods and Profiles parameter to select 

modifications and profiles.
8 Click the  button next to the Matching Rules parameter to select the 

matching rules to use.
9 (optional) Review parameters in the Oligonucleotides - Target Plus Impurities 

section of the Method Editor window.
10 Save the method. Click Method > Save As to save to a new name.
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11 Click the  button on the Method Editor toolbar to run the method workflow. 
You could instead click Method > Run Method Workflow.

12 View biomolecules as described in “Viewing results for Oligonucleotides - 
Target Plus Impurities” on page 72.

Figure 47. Workflow and Sequences section for an Oligonucleotides - Target Plus Impurities workflow
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Running the Oligonucleotides - Sequence Confirmation 
workflow

When you run an Oligonucleotides workflow, the workflow runs one of the 
following experiment types:

• Target Plus Impurities - see “Running the Oligonucleotides - Target Plus 
Impurities workflow” on page 68

• Sequence Confirmation
1 Open the data file that contains the oligonucleotides of interest as described 

in online Help.
2 Open the BioConfirmOligoSC-Default.m method. Click Method > Open.
3 Select Method Automation > Workflow and Sequences.
4 Select Oligonucleotides for the Workflow.
5 Select Sequence Confirmation for the Experiment.
6 Click the  button next to the Sequences/Masses parameter to select a 

sequence. 
7 (optional) Review parameters in the Oligonucleotides - Sequence 

Confirmation section of the Method Editor window.
8 Save the method. Click Method > Save As to save to a new name.

Figure 48. Workflow and Sequences section for an Oligonucleotide - Sequence Confirmation workflow
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9 Click the  button on the Method Editor toolbar to run the method workflow. 
You could instead click Method > Run Method Workflow.

10 View biomolecules as described in “Viewing results for Oligonucleotides - 
Sequence Confirmation” on page 74.
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Viewing results for Oligonucleotides - Target Plus 
Impurities

You can view biomolecules for Oligonucleotides - Target Plus Impurities as 
follows:
1 (optional) Click the Oligonucleotides - Target Plus Impurities Layout icon in 

the main toolbar.
2 If necessary, click View > Biomolecules.
3 Click a biomolecule of interest. The following windows are updated when you 

select a biomolecule:
• Biomolecule MS Chromatogram window
• Biomolecule MS Spectrum window
• Deconvolution Results window
• Biomolecule Identification Results window

4 To see other information for biomolecules in the list, right-click the table, and 
then click Add/Remove Columns from the shortcut menu.

5 Review the columns in the Biomolecule Identification Results window.
6 Right-click the table in the Biomolecule Identification Results window to see 

the shortcut menu. You can add and remove columns, copy to Clipboard, 
print, export and other features.

7 Float the Oligos - Impurity List window. Double-click the tab to float the 
window. By default, it is tabbed with the Biomolecules window. If it is not 
visible, click Sequence > Oligos - Impurity List.

8 Review the impurities in this window.

Figure 49. Oligos Impurity List window for the Oligonucleotide Target Plus Impurities workflow
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9 If necessary, click View > Results Compare. 
10 Click the Oligos - Target Plus Impurities tab. Review the results of multiple 

data file in this window.
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Viewing results for Oligonucleotides - Sequence 
Confirmation

You can view biomolecules for Oligonucleotides workflow with Sequence 
Confirmation as follows:
1 (optional) Click the Oligonucleotides - Sequence Confirmation Layout icon in 

the main toolbar.
2 If necessary, click View > Biomolecules.
3 Click a biomolecule of interest. The following windows are updated when you 

select a biomolecule:
• Biomolecule Fragment Spectrum window
• Biomolecule Identification Results 
• Fragment Confirmation Ladder

Each dot represents a fragment that has been confirmed for the nucleoside. The 
title bar shows the percentage of nucleosides that have at least one confirmed 
fragment. See the online Help for more information on the Fragment 
Confirmation Ladder.
4 To see other information for biomolecules in the list, right-click the Biomolecules 

table, and then click Add/Remove Columns from the shortcut menu.
5 Review the columns in the Biomolecule Identification Results window.
6 Right-click the table in the Biomolecule Identification Results window to see 

the shortcut menu. You can add and remove columns, copy to Clipboard, 
print, export and other features.

Figure 50. Fragment Confirmation Ladder with two data files selected
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Printing a report with oligonucleotides results

1 Select Method Automation > Reports in the Method Editor window.
2 Review the options in the Destination section. 
3 Review the parameters in both the Templates and Layouts tabs. Select the 

Target Plus Impurities report template and the Sequence Confirmation 
report template
• TargetPlusImpuritiesReport.template.xml (for Target Plus Impurities)
• SequenceConfirmationReport.template.xml (for Sequence Confirmation)

4 To print a report, do one of the following. The report template that is used 
depends on the workflow and experiment used to create the results for the 
selected sample. 
• Click Print Report in the Method Editor toolbar if you are in the Method 

Automation > Reports section. This method does not show the Print 
Biomolecule Report dialog box.

• Click Biomolecule Report from the File > Print menu to print the report.
• Click the  button on the main toolbar.

5 Review the parameters. For the Oligonucleotides - Sequence Confirmation 
workflow, see “Printing a multiple sample report” on page 77.

Figure 51. Print Biomolecule Report Dialog Box
Agilent MassHunter BioConfirm Software Quick Start Guide 75



Oligonucleotides Workflow
Printing a report with oligonucleotides results
6 Click OK.

Tip To print the Fragment Confirmation Ladder, right-click the graph area of the 
Fragment Confirmation Ladder window and click Print from the shortcut 
menu.

Tip A report is automatically created if you run Method Automation. Method 
Automation first runs the method workflow. It then extracts additional 
chromatograms, and then generates a biomolecule report. Finally, it exports 
the results. You can run Method Automation when you click Method > Run 
Method Automation (Workflow + Reports).
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Printing a multiple sample report

You can only print a report for multiple samples if the Workflow is 
Oligonucleotides and the Experiment is Sequence Confirmation. This report 
cannot be generated as part of automation. The multi-sample report is only 
available from the Print Biomolecule Report dialog box.

You cannot select a different template for the multiple sample report.
1 To print a report, do one of the following. The report template that is used 

depends on the workflow and experiment used to create the results for the 
selected sample. 
• Click Print Report in the Method Editor toolbar if you are in the Method 

Automation > Reports section. This method does not show the Print 
Biomolecule Report dialog box.

• Click Biomolecule Report from the File > Print menu to print the report.
• Click the  button on the main toolbar.

2 Mark the Multi-sample report (only supported for Oligonucleotide - Sequence 
Confirmation workflow) check box. The All results option is automatically selected. 
The other options in the Report contents section are not available.

3 Review the parameters in the Print report section and the Save report section.
4 Click OK.

Figure 52. Print Biomolecule Report Dialog Box
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Review Results

The topics in this section will help you get started using the Review Results 
features of MassHunter BioConfirm.
• “Reprocessing samples” on page 78
• “Using Result Review mode” on page 80

Reprocessing samples

You can reprocess data files using the Sample Table toolbar, and you can review 
results in the usual windows.
1 Open multiple data files.
2 Examine the Confirmation Status column. The values can be Confirmed, 

Partially Confirmed, Not Confirmed, and Undetermined.
3 Select a row that is Not Confirmed or Undetermined. 
4 (optional) Load a method to use with the sample you selected.
5 Click the  button in the Sample Table toolbar. The Reprocess Sample 

dialog box opens.
6 Select the Workflow.
7 If necessary, select the Condition.
8 If the Workflow is Oligonucleotides, select the Experiment.
9 Select the Sequences/Masses. Click the  button to select a different 

sequence.
10 (optional) If the Workflow is Released Glycans, enter the Glycan group.
11 If necessary, select the Mods and Profiles. Click the  button to select 

different modifications and profiles.
12 If the Workflow is Protein Digest, mark the Enzymes to use.
13 (optional) If the Workflow is Intact Protein, mark the Calculate 

Drug-to-Antibody Ratio check box. You can only do DAR calculations if you 
entered a Mass. Review other parameters in this section.
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14 If you have a choice, click either Use current method or Use sample result 
method. You can reprocess using the current method in the BioConfirm 
program or you can reprocess using the same method that was used to 
create previous sample results.

15 Click Reprocess.
16 Review results. See one of the following topics:

• “Viewing deconvolution biomolecules” on page 44
• “Viewing peptide biomolecules” on page 55
• “Viewing relative quantitation results for protein digests” on page 57
• “Viewing released glycans biomolecules” on page 63
• “Viewing relative quantitation results for released glycans” on page 64
• “Viewing results for Oligonucleotides - Target Plus Impurities” on 

page 72
• “Viewing results for Oligonucleotides - Sequence Confirmation” on 

page 74

Figure 53. Reprocess Sample Dialog Box
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17 Continue to reprocess other data files.

Using Result Review mode

Result Review mode disables the Method Editor window and the Find and 
Identify menu. You can reprocess data files using the Sample Table toolbar, and 
you can review results in the usual windows.
1 Click Configuration > Enable Result Review (Disables Method Editing). It has 

a check mark next to the command when it is enabled.
2 Observe that the Find and Identify menu is grayed out.
3 The Method Editor window is closed if it was open.
4 Click the Method menu. Most commands are grayed out.
5 You can still reprocess samples. See “Reprocessing samples” on page 78.
6 To end Result Review mode, click Configuration > Enable Result Review 

(Disables Method Editing).

Figure 54. Reprocess samples using the Sample Table
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Figure 55. BioConfirm window in Result Review mode 
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Setting Up Sequences 

Topics in this section include:
• “Creating or editing a protein sequence” on page 82
• “Adding or editing the protein sequence text” on page 83
• “Applying or editing protein modifications” on page 84
• “Applying or editing protein links” on page 86
• “Creating or editing an oligonucleotide sequence” on page 87
• “Adding or editing the oligonucleotide sequence text” on page 88
• “Adding a building block in the Chemical Data Dictionary” on page 89

Creating or editing a protein sequence

You create and edit either a protein or an oligonucleotide sequence in the 
Sequence Manager program.
1 Open the Sequence Manager program. In the BioConfirm program, click 

Sequence > Sequence Manager. 

Instead, in the OpenLab Control Panel program, you can click  and then 
click Start Sequence Manager.

2 Click the Proteins tab.
3 To add a sequence, type a sequence name and click the  button in the 

bottom left corner.
4 To edit a sequence, click the sequence in the left pane of the Sequence 

Manager.
5 In the Sequence Manager:

a Add or edit the sequence text as described in “Adding or editing the 
protein sequence text” on page 83.

b Apply or edit modifications as described in “Applying or editing protein 
modifications” on page 84. 
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c Apply or edit links as described in “Applying or editing protein links” on 
page 86. 

6 Click the Sequence > Export Sequences to save the sequence as a PSQ file or 
a Text file.

Adding or editing the protein sequence text

1 In the Sequence Manager program, select the sequence of interest.
2 Select the correct chain to add or edit. Chain A is selected by default.
3 Click the sequence in the right pane.

4 Enter or edit the amino acids in the sequence text box in either of the following 
ways. 
• Type in individual amino acids one at a time between the N-term and 

C-term symbols.
• Copy the sequence from a FASTA-formatted database or a text file. 

Right-click the sequence in the Sequence Manager and click Paste from 
the shortcut menu. The amino acid sequence will appear in the Sequence 
box, between the N-term and C-term symbols. 

NOTE
Only single-character (letter) amino acids are allowed for the protein sequence 
parameter. Three character amino acid symbols are not supported. 

Figure 56. Sequence Manager program
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Applying or editing protein modifications

1 Click the Proteins tab.
2 In the Sequence Manager program, select the sequence of interest. 
3 Right-click that sequence, and click Edit Modifications from the shortcut 

menu to open the Modifications dialog box.
4 To select and apply global modifications:

a On the Global tab, select the desired modification from the list of Available 
modifications. 

• If desired, you can customize the list of available modifications using the 
Chemical Data Dictionary; see the online Help for more information.

• Note that many N-linked glycans with numerical abbreviations, such as 
“2000 0A 0G”, are included in the Chemical Data Dictionary; see online help 
for more information.

b Select the amino acids to modify in the Apply to all list. Use Shift+click or 
Ctrl+click to select multiple amino acids, if desired.

c Click Apply to apply the specified modification to the selected amino acids 
throughout the sequence.

d Repeat step a - step c to select and apply other global modifications.
5 To select and apply local modifications:

a On the Local tab, select the location in the sequence to modify: C-terminus, 
N-terminus, or the position in the sequence. Use the blue index numbers 
shown for each row of the sequence in the Sequence Manager program to 
determine the proper index number for the selected position.

b Select the desired modification from the Applicable modifications list.
c Mark the Variable modification check box if you want to create a variable 

modification for sequence matching. When marked, sequences that 
contain that amino acid site are matched both with and without this 
modification.

d Click Apply to apply the selected modification to the specified location 
(amino acid) in the sequence.

e Repeat step a - step d to select and apply other local modifications.
6 Click OK to close the Modifications dialog box. Note that the molecular 

weight and formula have been updated in the Sequence Manager. 
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To remove modifications

1 Click Edit Modifications on either the Edit menu or the Sequence shortcut 
menu to open the Modifications dialog box.

2 Click the Specified Applied tab and review the list of modifications.
3 Click to select the modifications you want to delete.
4 Click Delete to remove the selected modifications.
5 Click OK.
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Applying or editing protein links

1 Click the Proteins tab.
2 In the Sequence Manager program, select the sequence of interest in the left 

pane. 
3 Right-click the sequence in the pane on the right side, and click Edit Links 

from the shortcut menu to open the Links dialog box. You can also click Edit > 
Edit Links.

4 Enter the index number for one end of the link in the From index box and 
select the chain (if other than the default Chain A).

5 Enter the index number for the other end of the link in the To index box and 
select the chain (if other than the default Chain A).

6 Select a link from the Link types list.

Tip You can customize the list of links types using the Chemical Data Dictionary; see 
online help for more information.
7 Click Apply to link the selected amino acids in the sequence.
8 Repeat Steps 3 -6 to create additional links.
9 Click OK to close the Links dialog box. Note that the molecular weight and 

formula have been updated in the Sequence Manager. 

To remove links

1 Click Edit Links on either the Sequence menu or the Sequence Manager 
shortcut menu to open the Links dialog box.

2 Click the Specified Applied tab and review the list of links.
3 Click the links you want to delete.
4 Click Delete to remove the selected links.
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Creating or editing an oligonucleotide sequence

You create and edit either a protein sequence or an oligonucleotide sequence in 
the Sequence Manager program.
1 Open the Sequence Manager program. In the BioConfirm program, click 

Sequence > Sequence Manager. 

Instead, in the OpenLab Control Panel program, you can click  and then 
click Start Sequence Manager.

2 Click the Oligonucleotides tab.
3 To add a sequence, type a sequence name and click the  button in the 

bottom left corner.
4 To edit a sequence, click the sequence in the left pane of the Sequence 

Manager.
5 In the Sequence Manager, add or edit the sequence text as described in 

“Adding or editing the oligonucleotide sequence text” on page 88. 
6 Click the Sequence > Export Sequences to save the sequence as a PSQ file.
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Adding or editing the oligonucleotide sequence text

1 In the Sequence Manager program, select the sequence of interest.
2 Click the sequence in the right pane between 5’ and 3’.

3 Enter or edit the Code for the Building blocks in the sequence text box in 
either of the following ways. 
• Type in individual building blocks one at a time between the 5’ and 3’ 

symbols.
• Copy the sequence from a FAST-A formatted database or a text file. 

Right-click the sequence in the Sequence Manager and click Paste from 
the shortcut menu. The sequence will appear in the Sequence box, 
between the 5’ and 3’ symbols. 

4 Mark or clear the If two building blocks are next to each other, insert linker 
check box.

NOTE
When you enter the Code, include the “/” if it is part of the code. Also, be sure to 
match the exact capitalization for the Building Block.

NOTE
If you want to add another building block, click Open definition manager to open 
the Chemical Data Dictionary dialog box. You can also add Linkers and 
Modifications for Oligonucleotides in the Chemical Data Dictionary dialog box.

Figure 57. Sequence Manager program
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Adding a building block in the Chemical Data Dictionary

You can add or modify Building Blocks for Oligonucleotides in the Chemical Data 
Dictionary. You can also add and modify Linkers and Modifications for 
Oligonucleotides in the Chemical Data Dictionary. 

Modifications and Modification profiles can be selected in the Workflow. 
Building Blocks and Linkers can be used to create a sequence in the Sequence 
Manager program.
1 Open the Chemical Data Dictionary.

• In the BioConfirm program, click Sequence > Open Chemical Data 
Dictionary. 

• In the BioConfirm program, click Sequence > Sequence Manager. In the 
Sequence Manager program, click the Oligonucleotides tab. Then, click 
Open definition manager.

2 To add a building block, type a New building block code, and click the  
button in the bottom left corner.
• The Code must be unique.
• The first letter of the Code needs to be a lower case letter or a special 

character. Numbers are not allowed.
• If you want the Code to be more than two characters, the Code must begin 

and end with a “/”.
• The Code cannot contain the following special characters: /, \, {, }, [, ], (, ), |, ,̂ !

3 Optional, edit the Name of the new Building block. This name can describe the 
Building block.

4 Enter the Molecular formula.
5 (optional) Mark The code represents a fragment.
6 If the code is not a fragment, enter the Base formula.
7 Click Close.
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Figure 58. Chemical Data Dictionary with a new Building block - kH
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