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In This Guide…
This guide contains information to learn to use your Agilent 
MassHunter Workstation Software - Qualitative Analysis with 
GC/MS data. Qualitative Analysis has two main programs.

• Qualitative Analysis Navigator - You use this program to 
examine chromatograms and spectra and identify ions in 
mass spectra. It is especially well suited to manual, ad-hoc 
examination of your data.

• Qualitative Analysis Workflows - You use this program’s 
compound mining algorithms to find evidence for 
compounds in your data. You can also use its identification 
algorithms to identify unknown compounds based on that 
evidence.

Different windows are available in each of these programs. The 
following windows are available in both views:

• Method Editor

• Difference Results

• Structure Viewer

• Formula Calculator

• Mass Calculator

Qualitative Analysis Navigator 
Program

In this program, you can use the Data Navigator window to 
interactively select different spectra and chromatograms. You 
can generate formulas or search a library/database for these 
spectra.

If you are looking at spectra that you have manually extracted 
or that are extracted by the Integrate and Extract Peak 
Spectra algorithm, then you want to use this program. 

Qualitative Analysis Workflow 
Program

This program provides a compound centric view of one or more 
data files. You can look at information on a single compound in 
different windows. You change the selected compound in the 
Compound List window. You switch between different data files 
in the Sample Table.

If you want to use any of the Compound Mining algorithms, you 
use this program.
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If you are using either of these programs and decide that you 
need to also use the tools available in the other program, that 
program can be launched using the Launch menu. You can also 
specify which of the currently open data files should be opened 
in the launched program.

Before you begin the exercises, please read the instructions in 
“Before you begin these exercises..." on page 7.

Exercise 1 Learn basics of qualitative analysis

In this exercise, you explore some of the many powerful 
capabilities of the Qualitative Analysis Navigator program. 
These tasks are important no matter what data type you are 
using.

Exercise 2 Find and identify

In these tasks, you find and identify compounds in GC/MS data 
files. You use the Qualitative Analysis Workflows program to do 
compound mining. You can also identify those compounds in 
this program.

Exercise 3 Use workflows, export and print

In these tasks, you learn to set up and run a workflow. Each of 
these tasks is done using a different workflow.

Reference

In this chapter, you learn some basics about the Qualitative 
Analysis program.
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What’s New

in B.08.00

The following features apply to both the Qualitative Analysis 
Navigator program and the Qualitative Analysis Workflows 
program.

• Windows 10 and Windows 7 are supported.

• Microsoft Excel 2016 is supported.

• The menus and windows have been simplified.

• The Method Explorer window and the Method Editor 
window are combined into one window.

• All toolbars have been simplified.

• The user interface configuration is set automatically based 
on the file or files that are loaded.

• Only relevant menus and windows are available, based on 
the types of data files loaded.

• Database Search and Library Search are combined and run 
as a single action. The software automatically runs the 
correct action based on your data and the database/library 
selected.

• You select one of four workflows for Method Automation: 
Target/Suspect Screening, Sample Purity, Compound 
Discovery, and Custom. In the Qualitative Navigator 
program, you can only run the Custom workflow. In the 
Qualitative Analysis Workflows program, you can run all of 
these workflows.

• Additional chromatograms can be extracted when you run a 
workflow.

• You can run the workflow from the Method menu. 

• The gray line that used to show the last location that was 
clicked is no longer shown in plots. A gray, vertical line 
shows the current location in the plot, but when the cursor is 
not in that window, the line is removed.

• Qualitative Analysis uses the latest version of algorithms 
shared with MassHunter Quantitative Analysis program.
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• Qualitative Analysis methods and results are backwards 
compatible. 

• BioConfirm features are removed from the Qualitative 
Analysis programs.

The following features apply to the Qualitative Analysis 
Navigator program.

• The Peak Select tool is the default tool for the Chromatogram 
Results window.

• The Peak Select tool behaves like the Range Select tool in 
that you can select arbitrary ranges with either tool if the 
chromatogram is not integrated. However, if the 
chromatogram is integrated and the range you draw overlaps 
one or more peaks, then the Peak Select tool selects the RT 
range of those peaks.

• The Spectrum Preview window is closed automatically.

• You can launch BioConfirm from the Qualitative Analysis 
Navigator program if BioConfirm is installed.

The following features are available in the Qualitative Analysis 
Workflows program.

• All features related to finding compounds are in the 
Qualitative Analysis Workflows software.

• You can select Auto-select compound mining for the 
Target/Suspect Screening workflow and the Compound 
Discovery workflow.

• The Compound Discovery workflow automatically runs the 
Compound Identification workflow.

• The Find by Fragments algorithm runs on GC/TOF or 
GC/Q-TOF data.

• You can specify a different report template for each 
workflow.

• The Score (Frag Ratio) column is available in the Compound 
List window.

• CI is supported for GC/Q-TOF All Ions workflow.

• You can create a CEF file when you run Fragment 
Confirmation with GC/Q-TOF EI data.
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• You can overlay the chromatograms from the selected 
compounds on the Sample Chromatogram.

• The Extract Chromatograms button is available on the 
Sample Chromatogram Results window.

• You can extract an EIC when you double-click in the 
Compound MS or MS/MS spectra.

• When you double-click in the Sample Chromatogram, a 
compound is extracted and added to the Compound List 
window, and the Mining Algorithm is Spectrum Extraction.

• The Compound Chromatogram Results window has relative 
zooming.

• The Sample Table window shows sample information details 
and Result Summary. You can edit the sample prep 
parameters.

• The title bar for the Compound List window shows summary 
details.

• The Compound List groups columns by their column 
category.

• The Compound List only has one level.

• The Find by Molecular Feature algorithm supports feature 
finding of GC/MSD and GC/Q-TOF data.

• The Q-Score is included when you create a CEF file with 
MFE compounds.

• New Qualitative Analysis columns are available in the 
Agilent Walkup program.

• New Qualitative Analysis columns are available in the 
Agilent Data Acquisition for TOF/Q-TOF program.

Before you begin these exercises...
• Install the software. See the Installation Guide for 

instructions.

• Copy the folder named Data from your installation disk in 
uncompressed format to any location on your hard disk.  
 
This folder contains all the data files needed for these 
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exercises. You may need to first extract the data files from 
their .zip format.

NOTE Do not reuse the example data files already on your system unless you 

know that you copied them from the originals on the disk and you are the 

only one using them. If the example data files already on the system do not 

match the original ones on the disk exactly, then the results obtained 

during these exercises will not match those shown in the guide.
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Agilent MassHunter Workstation Software Qualitative Analysis
Familiarization Guide for GC/MS
Exercise 1
Learn basics of qualitative analysis

Task 1. Open the Qualitative Analysis Navigator program    12

Task 2. Zoom in and out of the chromatogram    15

Task 3. Anchor a chromatogram    17

Task 4. Change window layouts    18

Task 5. Extract chromatograms    20

Task 6. Interactively integrate a GC/MS chromatogram    23

Task 7. Calculate System Suitability values    28

Task 8. Extract spectra from a chromatogram    32

Task 9. Add annotations    42

Task 10. Add a mass caliper    46

In this exercise, you explore some of the many powerful capabilities of the 
Qualitative Analysis Navigator program for working with GC/Q-TOF and 
GC/QQQ data. You can do many of these basic tasks in the Qualitative 
Workflows program, but the actual steps may be different.

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to explore 
the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
11Agilent Technologies



1 Learn basics of qualitative analysis  
Task 1. Open the Qualitative Analysis Navigator program
Task 1. Open the Qualitative Analysis Navigator program

In this task you open multiple data files in the Qualitative Analysis Navigator 
program using the current method. 

 

Task 1. Open the Qualitative Analysis program with multiple data files 

Steps Detailed Instructions Comments

1 Open the Qualitative Analysis 

program. 

• Open the data files, Pest - 200 - 
Scan.d, Pest - STD 200 MRM.d, 
Pest Strawb-01 SPIKED 1 ppb - 
1 ul inj.d and 

MSD_mix_4stds_DG_spl200_0
3.d in the folder  

\\MassHunter\Data, or in the 

folder where you copied them.

a Double-click the Agilent MassHunter 
Qualitative Analysis Navigator 
B.08.00 icon . 

The system displays the Open Data 

Files dialog box.

b Go to the folder \\MassHunter\
Data\GCMS Pesticide or the folder 

where the example files are located.

• The Pest - 200 - Scan.d file contains 

MS data, and the Pest - STD 200 

MRM.d and Pest Strawb-01 SPIKED 

1 ppb - 1 ul inj.d files contain both 

MS and MS/MS data (all GC/QQQ). 

MSD_mix_4stds_DG_spl200_03.d 

contains GC/Q-TOF data.

• You can get help for most windows, 

dialog boxes, and tabs by pressing 

the F1 key when that window is 

active.

• Click File > Open Data File if the 

files are in different folders.

• Make sure that the Use current 
method button is clicked.

• Make sure that the Load result 
data check box is clear or grayed 

out. If the Load result data 

check box is not available, then 

no results have been saved in 

the data file. You learn how to 

save results in “Task 17. Save 

results” on page 75.

Figure 1 Open data files when opening software
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Learn basics of qualitative analysis 1 
Task 1. Open the Qualitative Analysis Navigator program
c Press and hold the Shift key while you 

click 

MSD_mix_4stds_DB_spl200_03.d 
and then Pest Strawb-01 SPIKED 1 
ppb - 1 ul inj.d.

d Click Open. All four data files are 

displayed in the Data Navigator 

window, and 1 to 4 chromatograms are 

displayed in the Chromatogram 

Results window.

e In the Chromatogram Results toolbar, 

click the List Mode icon ( ).

• If you press the Ctrl key, you can 

pick files which are not directly next 

to each other in the list.

• What you see in the main window 

at this point depends on the 

method, layout, display, and plot 

settings used before you opened 

these files.

• When you click the List Mode icon, 

the background of the icon changes 

to orange.

Figure 2 Qualitative Analysis main window

Task 1. Open the Qualitative Analysis program with multiple data files (continued)

Steps Detailed Instructions Comments

Maximum Number of 
List Panes icon

Display Options 
icon

You click the X button to 
close this window.
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1 Learn basics of qualitative analysis  
Task 1. Open the Qualitative Analysis Navigator program
2 Restore the main window to the 

default layout and method. 

• Make sure you can see all four 

chromatograms.

a If necessary, click Configuration > 
Window Layouts > Restore Default 
Layout.

b Click the down arrow next to the 

Maximum Number of List Panes icon 

in the Chromatogram Results toolbar, 

and select 4.

c Click Method > Open.

d Select default-GCMS.m.

e Click Open.

f You may be asked whether or not to 

save method changes for your current 

method. Click Yes or No.

• The Qualitative Navigator program 

has an adaptive user interface that 

automatically configures itself 

based on the type(s) of data file(s) 

that you open.

Task 1. Open the Qualitative Analysis program with multiple data files (continued)

Steps Detailed Instructions Comments
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Learn basics of qualitative analysis 1 
Task 2. Zoom in and out of the chromatogram
Task 2. Zoom in and out of the chromatogram

In this task, you become familiar with the zoom in and zoom out features of 
the Qualitative Analysis Navigator program. You can use the zoom features in 
the Qualitative Analysis Workflows program, also.

Task 2. Zoom in and out of the chromatogram 

Steps Detailed Instructions Comments

1 Practice zooming in and out of only 

one of the four chromatograms 

(both x and y axes).

• Hide the others.

• Zoom in twice on last peak.

• Zoom in one more time 

autoscaling the y-axis.

• Zoom out once to the previous 

zoom position.

• Completely zoom out to the 

original chromatogram.

a Clear the check boxes in the Data 

Navigator window for the 

chromatograms you want to hide.

b Make sure that the Autoscale Y-axis 
during Zoom icon, , is not selected 

for the next step. 

c Click the right mouse button and drag 

over an area on the last peak. 

d Repeat step c.

e Click the Autoscale Y-axis during 
Zoom icon, , in the toolbar. 

f Click the right mouse button again and 

drag over an area of the last peak for 

the third time.

The Qualitative Analysis Navigator 

program and the Qualitative Analysis 

Workflows program automatically 

scale the y-axis to the largest point in 

the range.

g Click the Unzoom icon  to undo the 

last zoom operation. 

You can undo the last fifteen zoom 

operations.

h Click the Autoscale X-axis and Y-axis 
icon  to zoom out completely. 

• If a line is not checked in the Data 

Navigator window, that information 

is not displayed in any other 

window in the Qualitative Analysis 

program. You simply mark the check 

box for that information in the Data 

Navigator window, and the 

information is displayed in the other 

windows again.

• A selected icon has an orange 

background color.

• In the Qualitative Analysis 

Navigator program, you can also 

use these zoom features on spectra 

in other plot windows.

• In the Qualitative Analysis 

Workflows program, you can also 

use these features in the Sample 

Chromatogram Results window, the 

Compound Chromatogram Results 

window, the Compound MS 

Spectrum Results window, the 

Compound Fragment Spectrum 

Results window, and the Spectral 

Difference Results window.
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1 Learn basics of qualitative analysis  
Task 2. Zoom in and out of the chromatogram
2 Practice zooming in and out on 

each axis separately.

• Zoom in only along the x-axis.

Hint: Right-click the x-axis 

values and move cursor from 

left to right.

• Partially zoom out the x-axis.

Hint: Move cursor in opposite 

direction.

• Completely zoom out of the 

x-axis.

• Repeat the previous steps for the 

y-axis.

a To zoom in on the x-axis, move the 

cursor to the x-axis values until a 

horizontal double arrow appears.

b Click the right mouse button and drag 

the new cursor from left to right across 

the x-axis values. 

c To zoom out on the x-axis, click the 

right mouse button and drag from right 

to left on the x-axis values.

d Click the Autoscale X-axis icon  to 

completely zoom out on the x-axis. 

a To zoom in on the y-axis, move the 

cursor to the y-axis values until a 

vertical double arrow appears.

b Click the right mouse button and drag 

the new cursor from bottom to top 

across the y-axis values. 

c To zoom out on the y-axis, click the 

right mouse button and drag from the 

top towards the bottom of the y-axis 

values.

d Click the Autoscale Y-axis icon  to 

completely zoom out on the y-axis.

Task 2. Zoom in and out of the chromatogram (continued)

Steps Detailed Instructions Comments

Horizontal 
Double Arrow

New cursor 
appears when you 
right-click the 
x-axis values.

New cursor 
appears when 
you right-click 
the y-axis values.

Vertical Double 
Arrow
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Learn basics of qualitative analysis 1 
Task 3. Anchor a chromatogram
Task 3. Anchor a chromatogram

In this task, you anchor a chromatogram. When you anchor a chromatogram, 
the anchored chromatogram remains permanently on display as you scroll 
through the other chromatograms to display them.

Task 3. Anchor a chromatogram 

Steps Detailed Instructions Comments

• Anchor a chromatogram.

• Show all chromatograms.

• Make sure the chromatogram 

viewing list is set to 1.

• In the Chromatogram Results 

window, select the second TIC.

• Anchor this TIC.

• Scroll through the 

chromatograms.

• Clear the anchor.

a In Data Navigator mark the check 

boxes for the chromatograms you hid 

in the previous task.

b Set the maximum number of panes to 

1 in the Chromatogram Results 

window.

c In the Chromatogram Results window, 

scroll if necessary and select the 

second TIC.

d Right-click inside the chromatogram, 

and click Set Anchor.
e Use the scroll bar in the 

Chromatogram Results window to 

scroll through the list of 

chromatograms. The second TIC stays 

visible always as the first 

chromatogram. 

f Click Chromatograms > Clear Anchor.

• When you set an anchor for a 

chromatogram, an anchor icon 

appears in the Data Navigator 

window next to the name of the 

anchored chromatogram.

• Two chromatograms appear in the 

Chromatogram Results window 

after you anchor one even though 

the viewing list says 1. This now 

means you view one chromatogram 

in addition to the anchored 

chromatogram.

• You can also right-click the 

chromatogram and click Clear 
Anchor in the shortcut menu.

• You cannot anchor a chromatogram 

or spectrum in the Qualitative 

Analysis Workflows program.

Figure 3 Anchored TIC in the Chromatogram Results window
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide for GC/MS 17



1 Learn basics of qualitative analysis  
Task 4. Change window layouts
Task 4. Change window layouts

In this task, you move windows within the main view and create various 
window layouts. You can save layouts in both the Qualitative Analysis 
Navigator program and the Qualitative Analysis Workflows program.

Task 4. Change window layout 

Steps Detailed Instructions Comments

1 Change the window layout:

• Change the window size.

• Save a window layout.

• Unlock the layout.

• Change the Chromatogram 

Results window to be floating.

• Move the Chromatogram Results 

window.

• Display the tools for 

repositioning the windows.

• To change the size of a window, drag 

the boundary between the windows.

• To save a window layout, click 

Configuration > Window Layouts > 
Save Layout.

• To unlock a layout, click Configuration 
> Window Layouts > Lock Layout. 

• To make a window float, right-click the 

title bar of the window, and click 

Floating from the shortcut menu. You 

can instead double-click the title bar of 

the window to float the window.

• To move a window, click the title bar of 

the window and drag the window to 

the desired location. 

• To display the repositioning tools, drag 

the window over one of the other 

windows. When one window is 

overlapped with another, the program 

displays several layout tools, as shown 

in Figure 4.

• If the layout is unlocked, the system 

does not display a check mark next 

to the Lock Layout menu.

• You can only use the repositioning 

tools when the layout is unlocked.

• You can also make a window float 

by double-clicking the title bar of 

the window.

• The software has many different 

layouts created. You can also try 

loading different layouts.

• The software has several different 

workflows. Each workflow loads a 

different layout. Switching to a 

different workflow also changes the 

layout.

Figure 4 Window repositioning tools
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Learn basics of qualitative analysis 1 
Task 4. Change window layouts
2 Reposition the Chromatogram 

Results window.

• Move the window so that it is at 

the top, to the left, to the right 

and then at the bottom of the 

other windows.

• Move two windows together so 

that they are on top of one 

another and available only 

through the tabs at the bottom. 

• Restore the default layout.

• If, while dragging the window by its 

title bar, you drag the cursor over one 

of the smaller icons, the window you 

are dragging will be placed above, to 

the right, below, or to the left of all of 

the other windows. 

• Drag the cursor over the larger icon. 

The window can also be placed above, 

to the right, below, or to the left of the 

other window by dragging the cursor 

over the edges of the larger icon.

• To tab two windows together, drag the 

cursor over the center of the larger 

icon. You will see a shadow version of 

the two windows tabbed together. Stop 

dragging the mouse. The two windows 

will be tabbed together.

• To restore a floating window to its most 

recent docked position, you can 

double-click its title bar or right-click 

the title bar of the window and click 

Floating.

• Click Configuration > Window 
Layouts > Restore Default Layout.

• The cursor must be over one of the 

arrows in a box in order for 

repositioning to occur.

• Clicking the Restore Default Layout 
command restores the default 

layout. If you loaded a different 

layout, then you need to load that 

layout instead. To load a layout, 

click Configuration > Windows 
Layouts > Load Layout.

Task 4. Change window layout (continued)

Steps Detailed Instructions Comments
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1 Learn basics of qualitative analysis  
Task 5. Extract chromatograms
Task 5. Extract chromatograms

In this task, you extract and merge chromatograms from the original TIC using 
the Qualitative Analysis Navigator program. In the Qualitative Analysis 
Workflows program, you can extract additional chromatograms when you use 
the Extract Chromatograms tool on the Sample Chromatogram Results 
window’s toolbar. 

Task 5. Extract chromatograms 

Steps Detailed Instructions Comments

1 Extract extracted ion 

chromatograms (EICs) from two 

masses in the Pest - 200 - Scan.d 

data file.

• The m/z values are 129.0 and 

414.2.

• Do not merge the peaks from the 

individual masses into one 

chromatogram.

a In the Data Navigator window, clear 

the check boxes for the data files 

except for Pest - 200 - Scan.d.

b Open the Extract Chromatograms 

dialog box, using the option below or 

one of the options to the right: 

• Click Chromatograms > Extract 
Chromatograms.

c In the List of opened data files, click 

Pest - 200 - Scan.d.
d In the Type list box, select EIC.

e In the m/z value(s) box, type 

129.0, 414.2
f If necessary, clear the Merge multiple 

masses into one chromatogram check 

box to merge the EICs.

g If necessary, clear the Integrate when 
extracted check box.

h Click OK.

i Set the Maximum number of list 
panes to 4 or more in the 

Chromatogram Results toolbar.

• You can also extract 

chromatograms in one of the 

following ways:

• Right-click inside the 

chromatogram, and click Extract 
Chromatograms.

• From Data Navigator, highlight 

the TIC Scan for Pest - 200 - 
Scan.d; then, right-click TIC Scan 
and click Extract 
Chromatograms.

• You can use an MS level of either 

All or MS.

• Note that you can also choose to 

have the extracted chromatogram 

automatically integrated after 

extraction.

• You can also extract a 

chromatogram from a mass 

spectrum.

• Only three chromatograms are 

shown in the Chromatogram 

Results window because only three 

chromatograms are available.
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Figure 5 The Extract Chromatograms dialog box

Figure 6 Merged extracted ion chromatograms (EICs) compared to the 

original TIC

2 Extract extracted ion 

chromatograms (EICs) from two 

masses in the Pest - 200 - Scan.d 

data file.

• The m/z values are 129.0 and 

414.2.

• Do merge the peaks from the 

individual masses into one 

chromatogram.

a Open the Extract Chromatograms 

dialog box. Click Chromatograms > 
Extract Chromatograms.

b In the List of opened data files, click 

Pest - 200 - Scan.d.
c Mark the Merge multiple masses into 

one chromatogram check box to 

merge the EICs.

d Click OK.

• Four chromatograms are 

automatically shown in the 

Chromatogram Results window.

• The title for the fourth 

chromatogram is “+EI EIC(129.0000, 

414.2000) Scan Pest - 200 - Scan.D”. 

Both ions are merged in this 

chromatogram.

Task 5. Extract chromatograms (continued)

Steps Detailed Instructions Comments
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Figure 7 The Extract Chromatograms dialog box with Merge multiple 
masses into one chromatogram marked.

Figure 8 One merged extracted ion chromatogram (EIC) compared to 

the original TIC and two extracted ion chromatograms.

Task 5. Extract chromatograms (continued)

Steps Detailed Instructions Comments
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Task 6. Interactively integrate a GC/MS chromatogram

In this task, you learn different ways to integrate a chromatogram, change 
integration parameters to modify the results, and calculate the Signal-to-Noise 
for the integrated peaks for MS/MS data using the Qualitative Analysis 
Navigator program.

Task 6. Interactively integrate a chromatogram (GC/MS) 

Steps Detailed Instructions Comments

1 Integrate the TIC Scan 

chromatogram for the Pest - 200 - 
Scan.d data file, using any of the 

options listed at right.

a Mark the Pest - 200 - Scan.D data file 

in the Data Navigator window.

b Highlight the TIC Scan chromatogram, 

and use one of the following 

commands:

• From the menu bar click 

Chromatograms > Integrate 
Chromatogram.

• Right-click anywhere in the 

chromatogram window, and click 

Integrate Chromatogram.

• In the Data Navigator window, 

select Pest - 200 - Scan.D > 
Chromatograms > TIC Scan; then, 

right-click the TIC Scan, and click 
Integrate Chromatogram.

• Note that the program integrated 

practically all the peaks in the 

chromatogram.

• You select the integrator to use for 

MS data, MS/MS data, and GC data 

in the Method Editor window.

• This chromatogram is an MS 

chromatogram, so the values that 

are set in the Integrate (MS) section 

of the Method Editor are used when 

integrating this chromatogram.

2 Display only two chromatograms at 

the same time.

• Select 2 in the Maximum number of 
list panes box in the Chromatogram 

Results Toolbar.

Figure 9 Integrated TIC Scan Chromatogram with many small peaks

Many small peaks are integrated.
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3 Change the threshold to integrate 

fewer peaks.

• Change the threshold to retain 

only the three largest peaks.

a Click View > Method Editor.
b In the Method Editor window, click 

Chromatograms > Integrate (MS)
c Click the Integrator tab.

d Review the parameters.

e Click the Peak Filters tab.

f Under Maximum number of peaks, 

mark Limit (by height) to the largest, 
and type 3.

• Note the blue triangle that appears 

when you change a setting from the 

value saved in the current method. 

When you save the method, the 

triangles disappear.

Figure 10 Peak Filters tab with Limit (by height) to the largest marked

4 Reintegrate the chromatogram g Click  on the Method Editor toolbar 

to integrate using the new setting.

• Note that only the three peaks with the 

highest height are integrated now.

Figure 11 Integrated TIC Scan chromatogram when limiting the number of peaks

Task 6. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments

The Run button is 
labeled Integrate 
Chromatogram. 
The label changes 
depending on 
which tab is 
visible in the 
Method Editor 
and which action 
is selected.
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5 Integrate the TIC MRM 

chromatogram for the Pest - STD 
200 MRM.D data file.

a In the Data Navigator window, mark 

the Pest - STD 200 MRM.d data file. 

b In the Data Navigator window, select 

the TIC MRM for the Pest - STD 200 

MRM.d data file. 

c Use one of the following commands to 

integrate the chromatograms.

• From the menu bar click 

Chromatograms > Integrate 
Chromatogram.

• Right-click anywhere in the 

chromatogram window, and click 

Integrate Chromatogram.

• In the Data Navigator window, 

right-click the highlighted 

chromatogram and click Integrate 
Chromatogram.

d Click the Auto-scale Y-axis during 
Zoom icon  in the Chromatogram 

Results toolbar.

e Zoom in from 5.8 to 8.5 minutes.

f Set the Maximum number of list 
panes to 2.

• Note that the program integrated 

practically all the peaks in the 

chromatogram.

• These chromatograms are MS/MS 

chromatograms, so the values that 

are set in the Integrate (MS/MS) 

section of the Method Editor 

window are used when integrating 

this chromatogram. You can select 

one integrator to use to integrate 

MS chromatograms and a different 

integrator to use to integrate 

MS/MS chromatograms.

Figure 12 Integrated MRM chromatograms 

Task 6. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments
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6 Select the MS/MS (GC) 

integrator. Change the filter to only 

accept peaks with an absolute 

height greater or equal to 60,000.

a From the Method Editor window, 

select Chromatograms > Integrate 
(MS/MS).

b Click the Peak Filters tab.

c Under Filter on, click Peak height.
d Under Height filters, mark the 

Absolute height check box.

e Type 60000 as the Absolute height.

• Note the blue triangle that appears 

when you change a setting from the 

value saved in the current method. 

When you save the method, the 

triangles disappear.

Figure 13 Peak Filters tab with Absolute height marked

7 Reintegrate the chromatogram f Click the  button on the Method 

Editor toolbar.

• Note that only the largest peaks are 

now integrated.

Figure 14 Integrated TIC chromatogram with higher threshold setting

Task 6. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments

The smaller peak at 5.8 minutes is not 
included in the integration results any 
longer because the absolute height 
for this peak is lower than 60000 
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8 Restore the settings that are saved 

for the current method and close 

Method Editor.

a Select the Chromatogram > Integrate 

(MS/MS) section in the Method 

Editor.

b Click the  icon in the Method 

Editor.

c Select the Chromatogram > Integrate 

(MS) section.

d Click the . icon in the Method 

Editor.

e Close the Method Editor window.

• To cancel your changes and restore 

the values from the method that is 

loaded, click the Restore to last 
saved values from file icon on 

the Method Editor toolbar. 

9 Delete all chromatograms except 

the original. Delete the integration 

results from the original 

chromatogram.

a Under Chromatograms in the Data 

Navigator window, highlight all the 

chromatograms except the original.

b Right-click the highlighted 

chromatograms, and click Delete.

c Select all of the TIC chromatograms.

d Click Chromatograms >Clear Results.

• When you use the Clear Results 

command, the chromatograms are 

not deleted; the results that are 

connected to the chromatograms 

are removed. In this case, the 

integration values are cleared.

• Press the Ctrl key to highlight more 

than one chromatogram in the Data 

Navigator window.

Task 6. Interactively integrate a chromatogram (GC/MS) (continued)

Steps Detailed Instructions Comments
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Task 7. Calculate System Suitability values

In this task, you learn different ways to interactively integrate a 
chromatogram, change integration parameters to modify the results and view 
the signal-to-noise ratio for each peak. You also learn how to enable System 
Suitability calculations.

Task 7. Interactively integrate a chromatogram (MS) 

Steps Detailed Instructions Comments

1 Integrate the 
MSD_mix_4stds_DB_spl200_03.d 
and Pest - 200 - Scan.d 
chromatogram and using any of the 

options listed at right.

a Mark the check box next to the 

MSD_mix_4stds_DB_spl200_03.d 

data file in the Data Navigator window.

b Mark the check box next to the Pest - 

200 - Scan.d data file in the Data 

Navigator window.

c Highlight both TICs.

d Zoom out in the Chromatogram 

Results window. Click the . icon in 

Chromatogram Results.

e Integrate the TIC Scan for these two 

files, using any of the following 

options.

• From the main menu, click 

Chromatograms > Integrate 
Chromatogram.

• Highlight the chromatograms. Then, 

right-click the chromatogram, and 

click Integrate Chromatogram.

• In Data Navigator, highlight the TIC 
Scan for both data files. Then, 

right-click either chromatogram and 

click Integrate Chromatogram.

• You can change the integrator in the 

Chromatogram > Integrate (MS) > 

Integrator tab.

• Note that the integration with 

default parameters is detecting very 

small peaks.
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Figure 15 One of the shortcut menus in the Data Navigator and the integrated chromatograms

2 Enable system suitability 

calculations for the MS 

chromatograms.

a In the Method Editor, select 

Chromatograms > Integrate (MS) to 

display the Integrator tab.

b Click the Suitability tab.

c Mark Enable system suitability 
calculations.

d Select the United States 
Pharmacopoeia (USP).

e In the Column void time box, type 1.

f In the Column length box, type 3000.

• Note the blue triangle that appears 

when you change a setting from the 

value that is saved in the current 

method. When you save the 

method, the triangles disappear.

• The algorithms that are used to set 

several of the columns in the 

Integration Peak List change, 

depending on the selected 

pharmacopoeia. See the online Help 

for more information.

Task 7. Interactively integrate a chromatogram (MS) (continued)

Steps Detailed Instructions Comments
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Figure 16 Chromatograms > Integrate (MS) Suitability tab

3 Reintegrate the chromatogram. • Click the Integrate Chromatogram 

icon  on the Method Editor toolbar 

to integrate using the new setting.

4 View the system suitability 

calculations.

• Open the Integration Peak List 

window.

• Review the values for system 

suitability.

a Click View > Integration Peak List.
b Right-click the header of the Peaks 

window and click Floating.

c Right-click the column header of any 

column that you do not want to see 

and click Remove Column. 

d Right-click any column header and 

click Add/Remove Columns to change 

the columns that are visible.

• The system suitability calculations 

are included in the Integration Peak 

List table.

• These values include k’, Tailing 

factor, Plates, Plates/M, and 

Symmetry.

• You can also enable system 

suitability calculations for an MS, 

an MS/MS and a GC 

chromatogram.

Figure 17 Integrated Peaks table with system suitability values

Task 7. Interactively integrate a chromatogram (MS) (continued)

Steps Detailed Instructions Comments

The actual column void time and column length for these data files is different 
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5 Restore the settings for the default 

method, and close the Method 

Editor window and the Integration 

Peak List window.

a To cancel your changes and restore 

the values from the default method, 

click the Restore to last saved values 
from file icon on the Method 

Editor toolbar. 

b Close the Method Editor window.

c Right-click the title of the Integration 

Peak List window and click Floating.

d Click View > Integration Peak List.

• When you click the Floating 

command in the shortcut menu the 

second time, the Integration Peak 

List window is docked where it was 

originally.

Task 7. Interactively integrate a chromatogram (MS) (continued)

Steps Detailed Instructions Comments
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Task 8. Extract spectra from a chromatogram

In this task, you extract a spectrum from exactly where you specify in the 
chromatogram. The Qualitative Analysis Navigator program extracts a 
spectrum from a specific data point or extract an average spectrum from an 
average of multiple data points or ranges. 

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments

1 Walk a chromatogram to view the 

precursor ion and product ion for 

the last few peaks of Pest - STD 
200 MRM.d.

• Zoom in on the region between 

13 and 16 minutes.

• Use the Walk Chromatogram 

icon.

• Review the spectra starting at 

about 13 minutes, and move the 

arrow to the right. 

a Mark the Pest - STD 200 - MRM.D line 

in the Data Navigator window.

b Close the Method Editor window.

c Click the TIC MRM chromatogram in 

the Data Navigator window.

d Click the Autoscale Y-axis during 
Zoom icon  in the Chromatogram 

Results toolbar.

e Select 1 for the Maximum number of 

list panes.

f To zoom in on a few peaks, right-click 

the mouse above the peak at 13 

minutes and drag it to 16 minutes, and 

then release. 

g Click the Walk Chromatogram icon 

 in the Chromatogram Results 

toolbar.

h Move the Walk Chromatogram cursor 

to above the X axis at about 13 

minutes, and click. 

• The Spectrum Preview window is 

only opened when you click the 

Walk Chromatogram icon ( ).

• The Walk Chromatogram tool is 

particularly useful on MS/MS data 

for identifying precursor and 

product ions.
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i To navigate from spectrum to 

spectrum, click the chromatogram or 

press the right and left arrow keys on 

your keyboard. You can also press and 

hold one of those arrow keys to rapidly 

scan a retention time range.

• The spectrum for each point you 

click in the Chromatogram Results 

window is automatically displayed 

in the Spectrum Preview window, 

which is opened automatically.

• Sometimes, multiple spectra are 

displayed in the Spectrum Preview 

window. For example, two spectra 

are shown in the Spectrum Preview 

window for each point you click 

near the peak at 13.431 minutes.

Figure 18 Walk chromatogram to view the two MRM spectra for the peak at 13. 43 minutes

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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2 Extract spectra on specific data 

points for the peak at 5.2 minutes 

and the peak at 14.3 minutes of the 

Pest - STD 200 MRM.d data file.

• Extract a spectrum from the peak 

at or near 5.2 min. and then one 

of the valleys, using any one of 

the options described under 

Comments.

• Extract a spectrum from the peak 

at or near 14.3 minutes. (not the 

valley yet)

a Click the Range Select icon  from 

the Chromatogram Results toolbar.

b Click the Zoom Out icon, , in the 

Chromatogram Results toolbar.

c To zoom in to the peak at 5.2 minutes, 

right-click the mouse above the peak 

at 4.0 min. and drag it to 6.0 min., then 

release. 

d On a peak near 5.2 min. extract a 

spectrum in any of the ways listed in 

the Comments column.

e On a valley near 5.1 min., extract the 

spectrum.

f Click the Zoom Out icon, , in the 

Chromatogram Results toolbar.

g Zoom into the region between 14 and 

15 min. 

h On a peak near 14.3 minutes, extract a 

spectrum in any of the ways listed in 

the Comments column. (Do not extract 

the valley spectrum yet.)

• When you zoom, make sure the 

AutoScale Y-axis during Zoom icon, 

 has an orange background.

• You can extract a spectrum in any of 

the following ways:

• Double-click the data point in the 

chromatogram. 

• Click the data point in the 

chromatogram; then, right-click 

anywhere in the chromatogram. 

Click Extract MS Spectrum. The 

Extract Spectrum dialog box is 

displayed. Make sure the Pest - 
STD 200 MRM.d file is selected, 

and click Extract in the Extract 

Spectrum dialog box.

• Note that when you first extract a 

spectrum, the MS Spectrum Results 

window appears containing the 

spectrum, and the type of spectrum 

and retention time appear under 

Spectra. All subsequent extracted 

spectra appear in both places as well.

• When you extract an MS spectrum 

from the peak near 14.3 minutes, 

two spectra are extracted because 

two transitions occur at that peak.

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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• Change the display to show at 

least four spectra.

i If necessary, select 4 in the Maximum 
number of list panes icon in the MS 

Spectrum Results toolbar.

• Note that when you first extract a 

spectrum, the MS Spectrum Results 

window appears containing the 

spectrum, and the type of spectrum 

and retention time appear under 

Spectra. All subsequent extracted 

spectra appear in both places as well.

• When you extract an MS spectrum 

from the peak near 14.3 minutes, 

two spectra are extracted because 

two transitions occur at that peak.

Figure 19 Main window with two MRM spectra from the peak at 5.2 minutes and two MRM spectra from the 

peak at 14.3 minutes

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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3 Extract an MS Spectrum for the 

valley at 14.35 minutes of the Pest 
- STD 200 MRM.d data file. 

• Bring up Spectrum Preview.

• Extract a spectrum from the 

valley at RT 14.3 minutes.

• Copy this spectrum to the User 

Spectra folder.

• Change the display to show 6 

spectra.

• Turn off Spectrum Preview.

a Click the Walk Chromatogram icon 

 in Chromatogram Results.

b On a valley near 14.3 minutes extract a 

spectrum.

c Select both spectra in the Spectrum 

Preview window.

d Right-click the spectra in the Spectrum 

Preview window, and click Copy to 
Spectra. The spectra are copied to the 

Spectra section in the Data Navigator 

and are shown in the MS Spectrum 

Results window.

e Click the Range Select icon on the 

Chromatogram toolbar.

f Click the down arrow next to the 

spectrum pane list, and select 6.

• When Walk Chromatogram is 

selected, the system displays any 

manually-selected spectrum in the 

Spectrum Preview window but not 

in the Spectra section of Data 

Navigator.

• With Walk Chromatogram on, 

Qualitative Analysis Navigator 

overwrites the previous spectrum 

when you extract a new spectrum.

• Walk Chromatogram mode is useful 

when you quickly want to review 

the spectra in your chromatogram 

and save only a few of the spectra.

Figure 20 Chromatogram Results and MS Spectrum Results windows

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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4 Extract a spectrum that averages 

all points within a specified range 

for the peak at 14.3 minutes for the 

Pest - STD 200 MRM.d data file:

• Zoom out.

• Use the Range Select icon on the 

Chromatogram toolbar.

• Set the range across the entire 

peak. 

• Extract the spectrum, using any 

of the options listed.

a Click at the left side of the base of the 

peak at 14.3 minutes and drag to the 

base of that peak on the right. 

b Select 2 in the Maximum number of 

list panes in the MS Spectrum Results 

window.

c Extract the average spectrum using 

one of the options on the right.

• You can extract an average 

spectrum by double-clicking the 

selected range in the 

chromatogram. 

• Or, right-click anywhere in the 

chromatogram, and click Extract 
MS Spectrum from the shortcut 

menu.

• Note that two averaged MRM 

spectra appear.

Figure 21 Chromatogram Results and MS Spectrum Results showing two averaged spectra

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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5 Extract spectra that average the 

ranges of peaks at 5.2 minutes and 

at 14.3 minutes together for the 

Pest - STD 200 MRM.d data file.

• Hint: Use the Range Select icon 

and the Ctrl key to select the 

Peak 1 range taken from the 

halfway point.

• Extract the spectra, using any of 

the options on the right.

a Click the Zoom Out icon, , in the 

Chromatogram Results toolbar.

b Press the Ctrl key.

c Click at the left side of the peak at 5.2 

minutes and drag to the right of that 

peak, and release the mouse.

d Release the Ctrl key.

e Extract the averaged spectra using this 

option or the one on the right:

• Double-click inside the selected 

range in either peak.

• Remember that the second peak 

already has a range selected from 

step 4.

• To extract spectra, you can also 

right-click anywhere in the 

chromatogram and click Extract MS 
Spectrum. The Extract Spectrum 

dialog box is shown. Click Extract.

Figure 22 Two averaged spectra from two different ranges in the chromatogram

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments

The first spectrum has transitions 
from both time ranges. The second 
spectrum only has one time range 
because the 160.00 -> ** transition is 
not present in the peak at 5.2 
minutes.
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6 Subtract a background spectrum 

every time you extract a peak 

spectrum from Pest - STD 200 
MRM.d.

• Delete any scans under User 

Spectra in Data Navigator.

• Extract a background spectrum 

that is the average of a spectrum 

at the start of the peak and a 

spectrum at the end of the peak.

• Extract a peak spectrum from the 

integrated peaks.

a Click the Spectra line in the Data 

Navigator. Right-click the Spectra line, 

and click Delete.

b Click Yes.

c In Method Editor, select Spectra > 
Extract (MS/MS). 

d Click the Peak Spectrum Extraction 
(MS/MS) tab, if not visible.

e In the Peak spectrum background 

MS/MS box, select Average of 
spectra at peak start and end.

f In the Chromatogram Results toolbar, 

click the Peak Select icon, .

g Click the Chromatograms > Integrate 

command.

h Select the peak near 5.2 minutes.

i Right-click and click Extract Peak 
Spectrum from the shortcut menu.

• Note that at the end of this process, 

all extracted peak spectra will 

automatically have the designated 

background spectrum subtracted.

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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• If you extract a peak spectrum and it 

has no points, the Extraction Data 

Format may need to be changed. In 

the Method Editor window, click 

Spectra > Extraction Data Format. 
For Mass spectral data format, click 

an option that can extract either 

format. For these examples, click 

Profile when available, otherwise 
Centroid.

Figure 23 Peak spectrum with a background peak spectrum subtracted

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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7 Integrate and extract peak spectra 

from the Pest - STD 200 MRM.d 

data file.

a Click the TIC MRM chromatogram in 

the Data Navigator window.

b Click Chromatograms > Integrate and 
Extract Peak Spectra.

• The peak spectra that you extracted 

manually in the previous step is 

deleted automatically because by 

default the Clear previous peak 
spectra check box is marked in the 

Chromatograms > Integrate 

(MS/MS) > Results tab.

Figure 24 Integrate and Extract Peak Spectra

8 Remove the integration results and 

the peak spectra.

a Select the Pest - Std 200 MRM.d data 

file.

b Click Chromatograms > Clear Results 
> Include Peak Spectra.

• You can instead click 

Chromatograms > Clear Results > 
Only Chromatograms if you do not 

want to delete the peak spectra.

Task 8. Extract spectra from a chromatogram

Steps Detailed Instructions Comments
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Task 9. Add annotations

You can add an image annotation or a text annotation to the following 
graphics windows in the Qualitative Analysis Navigator window:

• Chromatogram Results window

• MS Spectrum Results window

• UV Spectrum Results window

You can add annotations to windows in the Qualitative Analysis Workflows 
program. If you save the results for the data file, annotations are also saved.

Task 9. Add an annotation 

Steps Detailed Instructions Comments

1 Select the 

MSD_mix_4stds_DG_spl200_03.d 

data file. Hide the other 

chromatograms.

a Mark the check box next to 

MSD_mix_4stds_DG_spl200_03.D in 

the Data Navigator window.

b Click Edit > Show > Only Highlighted.

• The chromatograms for the other 

data files are automatically hidden.

2 Select the location in the 

chromatogram to add a text 

annotation.

a In the Chromatogram Results window, 

click the Annotation tool ( )in the 

toolbar.

b Move the cursor to the location in the 

chromatogram pane where you want 

to add the annotation.

c Right-click and then click Add Text 
Annotation.

• The cursor changes to a cross-hair. 

You use this cursor to select the 

location to add the annotation.

• The Annotate toolbar is available in 

the Chromatogram Results window.

• You can also add annotations to the 

MS Spectrum Results window, and 

the UV Spectrum Results window.

3 Add the information about the text 

annotation in the Add/Edit Text 

Annotation dialog box.

a Type the Text for the annotation.

b Select the Text color.
c Select the Orientation.

d Select the Font style and Font size.

e Click either Anchored or Floating. If 

you click Anchored, select the options 

for the pointer to the text annotation. If 

you click Floating, you can change the 

relative position. It is easier to change 

the position interactively in the 

graphics window.

f Click OK.

• You can add multiple annotations to 

a chromatogram or spectrum.

• You can use the icons in the 

Annotate toolbar to select all of the 

annotations, delete annotations and 

edit annotations.
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Figure 25 Add/Edit Text Annotation dialog box and the Chromatogram Results window

4 Select the location in the 

chromatogram to add the image 

annotation.

a Move the cursor to the location in the 

chromatogram pane where you want 

to add the annotation.

b Right-click and then click Add Image 
Annotation.

• You can add a JPG or a MOL image 

file.

Task 9. Add an annotation (continued)

Steps Detailed Instructions Comments

The Annotate Toolbar is only available when the Annotate tool is 
selected.

You can move the annotation to a new location when you click 
and drag the annotation.
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5 Add the information about the text 

annotation in the Add/Edit Text 

Annotation dialog box.

a Select the image annotation.

b Type 50 for the Scale width.

c Mark the Lock aspect ratio check box.

d Click Floating. You can change the 

relative position. It is easier to change 

the position interactively in the 

graphics window.

e Click OK.

f Move the image to the upper, right 

corner of the chromatogram.

• The Agilent_Logo.tif file is included 

in the \\MassHunter\Report 

Templates\Qual\B.08.00\en-US\

Letter folder. You need to convert it 

to a JPG file.

• You can add multiple annotations to 

a chromatogram or spectrum.

Figure 26 Add/Edit Image Annotation dialog box and the Chromatogram Results window

Task 9. Add an annotation (continued)

Steps Detailed Instructions Comments
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6 Zoom in to the first peak. • Zoom to an area around the first peak 

at 5.5 minutes

Figure 27 Anchored and floating annotations in the Chromatogram Results window

7 Switch back to the Range Select 

tool in the Chromatogram Results 

window. Delete the annotation 

first.

a Click the  icon to remove all 

annotations.

b Click the  (Range Select) icon in 

the Chromatogram Results toolbar.

• If you want to save the annotations 

with the data file results, see “Task 

17. Save results” on page 75.

• You can switch between five 

different tools in the Chromatogram 

Results toolbar. Refer to the online 

Help for more information. The five 

tools are:

• Range Select

• Peak Select

• Manual Integration

• Walk Chromatogram

• Annotation Mouse

Task 9. Add an annotation (continued)

Steps Detailed Instructions Comments

If an annotation is anchored, it stays 
attached at the position where it is 
anchored. If you zoom into a different peak, 
an anchored annotation may not be visible. 
If an annotation is floating, then the 
annotation is always shown in the same 
position relative to the upper left corner of 
the window.
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Task 10. Add a mass caliper

A caliper shows the difference between two points in a spectrum. You can add 
a caliper to the MS Spectrum Results window.

If you save the results for the data file, calipers are also saved.

Task 10. Add a mass caliper 

Steps Detailed Instructions Comments

1 Integrate and extract peak spectra 

from 

MSD_mix_4stds_DG_spl200_03.d.

a Mark the check box next to 

MSD_mix_4stds_DG_spl200_03.D in 

the Data Navigator window.

b Click Edit > Show > Only Highlighted.

c Click Chromatograms > Integrate and 
Extract Peak Spectra.

• You can instead click the Show only 

the highlighted ( ) button in the 

main toolbar.

2 Add the caliper to the peak 

spectrum created in the previous 

task.

a In the MS Spectrum Results window, 

click the Delta Mass Caliper tool 

( )in the toolbar.

b (optional) Select Profile Point to Point 
for the type of caliper in the Caliper 

toolbar.

c Zoom in from 79 to 99 m/z.

d Move the cursor to the location in the 

spectrum pane where you want to add 

the caliper.

e Drag the cursor to the end point of 

caliper in the spectrum. As you drag 

the cursor, the value of the delta mass 

changes. When you release the mouse 

button, the caliper is added. 

• The cursor changes to an arrow. You 

use this cursor to select the start 

and end point of the caliper. 

• You cannot select the type of caliper 

if the spectrum is centroided 

because Profile Point to Point has 

no effect on centroid data.

• The “triangle” cursor is set to the 

point that is selected, or to the top 

of the peak if you are using Profile 
Peak to Peak.

3 Modify the caliper to use a 

different color.

a Click the caliper created in the 

previous step.

b Click the Caliper Properties button 

( ) in the MS Spectrum Results 

Caliper toolbar.

c (optional) Type the Start X and Start Y 

values.

d Select the Text color.
e Select the Font style and Font size.

f Click OK.

• You can add multiple calipers to a 

spectrum.

• You can use the icons in the Caliper 

toolbar to select all of the calipers, 

delete calipers and edit calipers.
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Figure 28 Delta Mass Caliper Settings dialog box and the MS Spectrum Results window

4 Delete integration results and 

spectra.

a Click Chromatograms > Clear Results 
> Include Peak Spectra.

b Click the Range Select tool in the MS 

Spectrum Results window.

• If you want to save the calipers with 

the data file results, see “Task 17. 

Save results” on page 75.

Task 10. Add a mass caliper (continued)

Steps Detailed Instructions Comments
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Task 10. Add a mass caliper
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Agilent MassHunter Workstation Software Qualitative Analysis
Familiarization Guide for GC/MS
Exercise 2
Find and identify

Task 11. Find Compounds by Chromatogram Deconvolution    50

Task 12. Identify compounds using the Search Library/Database search 

algorithm    54

Task 13. Find Compounds using MRM (MRM only)    57

Task 14. Find Compounds by Integration    61

Task 15. Find by Fragments    64

Task 16. Search library for mass spectra    71

Task 17. Save results    75

In these tasks, you find and identify compounds in GC/MS data files. You use 
the Qualitative Analysis Workflows program to do compound mining. You can 
also identify those compounds in this program.

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to 
explore the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about each 
step in the exercise.
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Task 11. Find Compounds by Chromatogram Deconvolution
Task 11. Find Compounds by Chromatogram Deconvolution

This compound mining algorithm identifies compounds in GC/MS data and 
creates a cleaned MS spectrum for each compound. This functionality is an 
easy way to “mine” information from complex data. You can only use the Find 
by Chromatogram Deconvolution algorithm on GC/MS sample data acquired 
in Scan, Product Ion scan, or Neutral Loss scan mode.

This task shows finding compounds by chromatogram deconvolution with 
accurate mass data. You can also find compounds by chromatogram 
deconvolution with unit mass data after you first change the extraction 
window.

Task 11. Find compounds using Chromatogram Deconvolution (GC/MS)

Step Detailed Instructions Comments

1 Open the TIC for the 

MSD_mix_4stds_DG_spl200_03.d 
data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon .  

 

Otherwise, click File > Open Data File.

b Click the 

MSD_mix_4stds_DG_spl200_03.d 
data file in the GC example data file 

folder.

c Clear the Load result data check box 

and click Open.

• The Find Compounds by 

Chromatogram Deconvolution 

algorithm works with both GC/QQQ 

and GC/Q-TOF data files.

• The user interface is updated 

automatically depending on the 

type of data files that are loaded.

Figure 29 TIC chromatogram from MSD_mix_4stds_DG_spl200_03.d
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Task 11. Find Compounds by Chromatogram Deconvolution
2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.

3 Find compounds using the 

chromatogram deconvolution 

algorithm.

• Select the Agile integrator.

• Enter an SNR threshold of 20.

• Enter 100 ppm for the Left m/z 
delta and Right m/z delta 

values.

a In the Method Editor window, select 

Compound Discovery > Find by 
Chromatogram Deconvolution.

b On the Settings tab under Peak filter, 

type 20 for the SNR threshold.

c Review the parameters for the m/z 
delta units, Left m/z delta, and the 

Right m/z delta.

• If you have unit mass data, you 

enter 0.3 AMU for the Left m/z 
delta value and 0.7 AMU for the 

Right m/z delta value.

Figure 30 Settings tab in the Find by Chromatogram Deconvolution sec-

tion

Task 11. Find compounds using Chromatogram Deconvolution (GC/MS)

Step Detailed Instructions Comments
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• Select to extract EIC, MS spectra 

and MS/MS spectra.

d Click  to run the Find Compounds 
by Chromatogram Deconvolution 
algorithm on the data file. 

e If necessary, click the View > 
Compound List command.

f Close the Method Editor window, and 

the Structure Viewer window.

• The Qualitative Analysis Workflows 

program finds 5 compounds under 

these conditions.

• You can instead click Find > Find by 
Chromatogram Deconvolution.

• If the data file is not indexed, it can 

take a long time when you run this 

algorithm.

Task 11. Find compounds using Chromatogram Deconvolution (GC/MS)

Step Detailed Instructions Comments
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Task 11. Find Compounds by Chromatogram Deconvolution
4 Examine the compounds. See 

Figure 31.

a Click the Hide Empty Columns icon in 

the Compound List window.

b Click the first compound in the 

Compound List window. 

c When the Compound List window is 

selected, use the arrow keys to switch 

compounds.

• Showing both spectra is a convenient 

way to display all the information for a 

single compound.

• Note that both the cleaned spectrum 

and the raw spectrum are shown.

Figure 31 Find Compounds by Chromatogram Deconvolution results

Task 11. Find compounds using Chromatogram Deconvolution (GC/MS)

Step Detailed Instructions Comments
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Task 12. Identify compounds using the Search Library/Database search algorithm
Task 12. Identify compounds using the Search Library/Database 
search algorithm

In this task, you identify and generate formulas for the compounds found in 
“Task 11. Find Compounds by Chromatogram Deconvolution” on page 50. You 
can do this task if you have purchased the NIST11.l library (or a later version) 
or if you use the demo.l library. If you have two libraries, you can even select 
both libraries.

Task 12. Identify compounds using the Search Library algorithm

Step Detailed Instructions Comments

1 Do a library /database search of all 

of the compounds in the 

MSD_mix_4stds_DG_spl200_03.d 

data file.

a Click View > Method Editor.
b In the Method Editor window, click 

Compound Identification > 
Identification Workflow.

c Note that the Identify by - Library / 
Database search check box is marked.

d (optional) Click the Add button. Select 

the NIST11.l library and click the OK 

button.

e (optional) Click Stop at first library 
match for the Multi-library search 
type.

f Click Identify > Identify All 
Compounds from the main menu. You 

can instead click the Identify All 
Compounds icon  to run the 

algorithm.

• Demo.l and Nist11should be 

installed in the \MassHunter\

Library folder.

• Note that many of the compounds 

are identified after searching the 

NIST11.l library.

• If you do not have the NIST11.l 
library, then select a second library 

if you have one available.

• If you have two or more libraries 

selected and you select Stop at first 
library match, the library search 

algorithm searches the first library 

in the list. If the compound is 

identified, then it stops. If the 

compound is not identified, then it 

searches the next library until the 

compound is identified or the last 

library is searched.

• You use the Library Editor program 

to modify .L libraries that you use 

with the Search Library algorithm. 

This program is installed with the 

Agilent MassHunter Quantitative 

Analysis program. You click the 

 icon to start this program.
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2 Change the displayed windows. a Click View > Difference Results.

b Click View > Structure Viewer.
c Click the tab of the Compound 

Identification Results window, if 

necessary to display this window.

d Highlight a row in the Compound List 

which has been identified.

e Click the Hide Empty Columns button 

( ) in the Compound List toolbar and in 

the Compound Identification Results 

window.

f Click each compound to review results.

• If a compound is identified, the 

Formula column has a value.

Figure 32 Compounds and the library / database search results

Task 12. Identify compounds using the Search Library algorithm

Step Detailed Instructions Comments
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Task 12. Identify compounds using the Search Library/Database search algorithm
3 Close the data file. a Click File > Close Data File.

b Click No when you are asked if you 

want to save results.

• If you want to save these results, 

see “Task 17. Save results” on 

page 75.

Task 12. Identify compounds using the Search Library algorithm

Step Detailed Instructions Comments
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Task 13. Find Compounds using MRM (MRM only)

The Find Compounds by MRM algorithm identifies compounds in MRM data 
from a Triple Quadrupole. The algorithm searches for compounds using the 
MRM transitions. All of the compounds in the acquisition method are 
extracted and shown in the Compound List. Compounds are not eliminated 
based on chromatogram integration results. You can only use the Find 
Compounds by MRM algorithm on data that was acquired using MRM 
transitions. The MRM algorithm uses information that is found in the data file 
if the data file is an MRM data file.

Task 13. Find compounds using MRM (MRM only)

Step Detailed Instructions Comments

1 Open the TIC for the Pest - STD 
200 MRM.d data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon. Otherwise, click File 
> Open Data File.

b Click the Pest - STD 200 MRM.d data 

file in the GC Pesticides example data 

file folder.

c Clear the Load result data check box 

and click Open.

• The user interface is updated 

automatically to show the 

appropriate features for the data file 

which you opened.

Figure 33 TIC chromatogram from Pest - STD 200 MRM.d

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.
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3 Find compounds using the MRM 

algorithm.

a In the Method Editor window, select 

Target/Suspect Screening > Find by 
MRM.

b Review the parameters.

Figure 34 Integrator tab in the Find by MRM section of the Method Editor

c Click  to run the Find by MRM 
algorithm on the data file. 

d If necessary, click the View > 
Compound List command.

e If necessary, click the tab for the 

Compound Identification Results 

window to make it visible. It is tabbed 

with the Method Editor window.

• The Qualitative Analysis Workflows 

program finds 28 compounds under 

these conditions.

4 Examine the compounds. See 

Figure 35 on page 59.

a Select 2 in the Maximum number of 
list panes box in the Compound MS 

Spectrum Results toolbar.

b Click the Hide Empty Columns button 

( ) in the Compound List toolbar.

c Click the first compound in the 

Compound List window. 

d When the Compound List window is 

selected, use the arrow keys to switch 

compounds. 

• The “Hide any currently empty 

columns” algorithm runs on the first 

level of a table.

Task 13. Find compounds using MRM (MRM only)

Step Detailed Instructions Comments
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5 Change the visible columns in the 

Compound Identification Results 

window.

a Right-click a row in the table and click 

Add/Remove Columns.

b Click Select All and click OK.

c Click the Hide Empty Columns button 

( ) in the Compound List toolbar.

d Click a column that you want to 

remove. Right-click that column and 

click Remove Column to remove a 

column.

e Close some of the windows.

• If you first show all columns and 

then hide empty columns, then all 

columns that have values are seen.

• The precursor ion is displayed in the 

Precursor (Acq) column, and the 

product ion is displayed in the Find 
by MRM Product Ion column in the 

Compound Identification Results 

window.

• The number of compounds is 

shown in the Sample Table window 

in the Result Summary column.

Figure 35 Find by MRM results

Task 13. Find compounds using MRM (MRM only)

Step Detailed Instructions Comments
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Task 13. Find Compounds using MRM (MRM only)
6 Close the data file. a Click File > Close Data File.

b Click Close.

• If you want to save these results, 

see “Task 17. Save results” on 

page 75.

Task 13. Find compounds using MRM (MRM only)

Step Detailed Instructions Comments
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Task 14. Find Compounds by Integration

The Find Compounds by Integration algorithm identifies compounds based on 
the integration results. A compound is created for each peak that is identified 
by the integrator.

Task 14. Find compounds using Integration

Step Detailed Instructions Comments

1 Open the TIC for the 

MSD_mix_4stds_DG_spl200_03.
D data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon. Otherwise, click File 
> Open Data File.

b Click the 

MSD_mix_4stds_DG_spl200_03.d 
data file in the GC example data file 

folder.

c Clear the Load result data check box 

and click Open.

Figure 36 TIC chromatogram from MSD_mix_4stds_DG_spl200_03.d

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.
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3 Find compounds using the Find by 

Integration algorithm.

a In the Method Editor window, select 

Compound Discovery > Find by 
Integration.

b Review the parameters.

• You can choose the region of the 

chromatogram from which you 

intend to find compounds.

Figure 37 Integrator tab in the Find by Integration section of the Method Editor

c Click  to run the Find Compounds 
by Integration algorithm on the data 

file. 

d If necessary, click the View > 
Compound List command.

• The Qualitative Analysis Workflows 

program finds ten compounds under 

these conditions.

4 Examine the compounds. See 

Figure 38 on page 63.

a Click the Hide any currently empty 
columns icon in the Compound List 

window.

b Click the first compound in the 

Compound List window. 

Task 14. Find compounds using Integration

Step Detailed Instructions Comments
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c When the Compound List window is 

selected, press the arrow keys to 

switch compounds. 

Figure 38 Find by Integration results

5 Close the data file. a Click File > Close Data File.

b Click No when asked whether or not to 

save results.

c Click Close.

• If you want to save these results, 

see “Task 17. Save results” on 

page 75.

Task 14. Find compounds using Integration

Step Detailed Instructions Comments
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Task 15. Find by Fragments

For LC/MS data acquired on a TOF or Q-TOF instrument in the All Ions 
MS/MS mode, the Find by Formula algorithm supports an optional Fragment 
Confirmation step. In that step, the algorithm tries to confirm the identity of 
the compounds by looking for fragment ions in the high-energy spectrum that 
coelute with the molecular ion and that are suggested by the fragments in a 
library spectrum for that compound.

Find by Fragments is a similar algorithm that is tailored to the characteristics 
of GC/Q-TOF EI data, which has only high energy spectra that exhibit mostly 
fragment ions and often do not have an appreciable amount of any molecular 
ion. The algorithm first selects “n” fragment ions from the EI-MS spectral 
library based on abundance and m/z value (higher m/z fragment ions are given 
preference because they contain more structural information). The algorithm 
then extracts ion chromatograms of those ions in a time window around the 
target retention times in the library and creates a list of target 
chromatographic peaks. It then attempts to find groups of peaks that cluster 
by RT and selects a reference ion and confirming fragment ions. The reference 
ion can be the molecular ion if present, but it does not have to be. The 
algorithm then calculates how well the selected chromatographic peaks 
co-elute. The target compound is qualified, if a user settable minimum number 
of ions is found to have a coelution score above a set threshold.

In all cases a "Cleaned HighE Scan" is generated which only shows the 
reference ion and confirming fragment ions, optionally annotated with their 
sub formulas.

Task 15. Find by Fragments

Step Detailed Instructions Comments

1 Open the TIC for the 

Tomato_spiked.D data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon. Otherwise, click File 
> Open Data File.

b Click the Tomato_spiked.d data file in 

the GCMS Pesticide example data file 

folder.

c Clear the Load result data check box 

and click Open.

• You use the General Workflow 

when working with GC/QQQ data.

• You can use either the General 

Workflow or the GC/Q-TOF 

Compound Screening workflow 

when working with GC/Q-TOF data.
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Task 15. Find by Fragments
Figure 39 TIC chromatogram from Tomato_spiked.d

2 Configure the user interface. • Click Configuration > Window 
Layouts > Restore Default Layout.

• For these examples, start from the 

Default-GCMS.m method.

3 Load the 

GCQTOF_Pesticide_Example.m 

method file.

a Click Method > Open.
b Select the 

GCQTOF_Pesticide_Example.m 
method and click Open.

c Click the Method Editor tab which is in 

the lower left corner of the program.

d If the Target Source on the 

Target/Suspect Screening > Find by 

Fragments has an error, fix the path.

• This method is installed in the  

\\MassHunter\methods\B.08.00 

folder.

• If you see any blue triangles when 

you load the method, you can ignore 

them for now.

• If you see any red errors, then fix 

the problem.

4 Save the method to 

iii_GCQTOF_Pesticide_Example.m, 

where “iii” are your initials.

a From the top menu, click Method > 
Save As.

b Type 

iii_GCQTOF_Pesticide_Example.m.

c Click the Save button.

• Note that saving the method causes 

all the blue triangles indicating 

value changes in the opened 

method to disappear.

5 Verify the parameters for Find by 

Fragments.

a In the Method Editor window, select 

Target/Suspect Screening > Find by 
Fragments.

b Click the Target Source tab.

c Select the Pesticide_Example.cdb 

library in the PCDL folder.

d Click the Match Tolerance tab.

e Select Symmetric (ppm) for the 

Possible m/z and review the value.

f Mark the Limit EIC extraction range 

check box, select Symmetric, and type 

1.0 for the Expected retention time.

• These values are already set in this 

example method.

• The value selected for Possible m/z 

may depend on whether you are 

running your acquisition method in 

high resolution mode or dual gain 

mode.

Task 15. Find by Fragments

Step Detailed Instructions Comments
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Figure 40 Target Source tab and Match Tolerance tab in the Find by Fragments section

g Click the Fragment Options tab.

h Click Use spectral library only and 

type 7 for the Number of most 
specific ions from spectral library.

i Type 0.2 for the RT difference.

• A higher number of ions produces a 

greater specificity and more 

confidence in the results; however, 

a higher number of ions results in a 

longer program run time.

• The recommended range for the RT 
difference is 0.1 to 0.2 This value is 

the difference that is allowed for the 

retention time shift of the reference 

ion. The reference ion is 

automatically chosen by the 

Qualitative Workflows program.

Task 15. Find by Fragments

Step Detailed Instructions Comments
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j Clear the S/N ratio check box.

k Type 70 for the Coelution score.

l Click Minimum number of qualified 
fragments and type 1.

• If the S/N ratio check box is 

marked, you have a high probability 

of producing false negatives (if the 

ratio is too low).

• The recommended starting value is 

1 to 3. A setting of 1 requires two 

qualified ions: a reference ion and a 

qualified ion.

• Leave the values in the other tabs 

the same.

Figure 41 Fragment Options tab in the Find by Fragments section

6 Run the Find by Fragments 

algorithm.

• Click  to run the Find by Fragments 
algorithm on the data file.

• Click Find > Find by Fragments.

• The Qualitative Workflows program 

finds five compounds under these 

parameter values.

7 Save the method. • Save the method in one of three ways:

•Click the Save Method icon 

in the Method Editor. 

• Right-click the Method Editor, and 

click Save Method.

• From the top menu click Method > 
Save.

Task 15. Find by Fragments

Step Detailed Instructions Comments
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Task 15. Find by Fragments
8 Examine the compounds. See 

Figure 42.

a Click the Compound Identification 

Results tab if it is not visible.

b Close the Structure Viewer window.

c Click View > Compound Fragment 
Spectrum Results.

d In the Compound List window, 

right-click the header of any column 

that you want to remove, and click 

Remove Column.

• Selecting a compound in the 

Compound List window displays 

results in the other windows.

Figure 42 Find by Fragments results

Task 15. Find by Fragments

Step Detailed Instructions Comments
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e Click or press the arrow keys to 

change compounds in the Compound 

List to review one compound at a time.

f Review the information in the 

Compound Identification Results 

window.

g Click the arrow icon at the beginning 

of a row to expand a level of the table. 

When the level of the table is 

expanded, the icon changes to a - 

icon.

• The first level of the table shows the 

summary information for all of the 

identification algorithms that you 

ran.

• The second level (blue) shows 

individual scores that were used to 

create the overall score. This row is 

only present when a molecular ion 

is found and reflects how well the 

molecular ion matches the expected 

mass, RT, and isotope distribution of 

the target compound.

• The table at the bottom shows the 

fragment ions and their coelution 

scores. It also shows whether or 

not the fragment ion is qualified.

Figure 43 Compound Identification Results window

Task 15. Find by Fragments

Step Detailed Instructions Comments
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h Review the results in the Compound 

Chromatogram Results window.

i Verify that the Coelution Plot pane is 

visible.

j Verify that the chromatograms are 

overlaid. The icons in the toolbar are 

set like this:

• The Compound Chromatogram 

Results window shows individual 

ion traces for each fragment ion.

• It also shows the Coelution Plot 

which displays how closely the 

Fragment ions coelute with the 

compound. For reference a black 

line is shown with the y-value of 1. 

A value of 1 shows the qualifier ions 

are exactly coeluting with the 

reference ion chromatogram. As the 

ratio approaches 1, the qualifier ion 

is more closely coeluting with the 

reference ion.

Figure 44 Compound Identification Results window

9 Close the data file. a Click File > Close Data File.

b Click No when asked whether or not to 

save results.

• If you want to save these results, 

see “Task 17. Save results” on 

page 75.

Task 15. Find by Fragments

Step Detailed Instructions Comments

Coelution Plot

Chromatograms for each 
fragment ion and the reference 
ion
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Task 16. Search library for mass spectra

In this task, you first integrate and extract peak spectra from a GC/Q-TOF data 
file. You use the MassHunter Qualitative Analysis Navigator program. Then, 
you generate possible formulas for each of the peak spectra.

Task 16. Search library for mass spectra

Step Detailed Instructions Comments

1 Open the TIC for the 

MSD_mix_4stds_DB_spl200_03.d 

data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Navigator icon. Otherwise, click File > 
Open Data File.

b Click the 

MSD_mix_4stds_DB_spl200_03.d 
data file in the GC example data file 

folder.

c Clear the Load result data check box 

and click Open.

• If the Load result data check box is 

not available, then no results have 

been saved in the data file. See 

“Task 17. Save results” on page 75 

for instructions on how to save 

results.

• The General workflow is loaded.

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.

3 Integrate and extract peak spectra. a Click View > Method Editor.

b Click the Chromatograms > Integrate 

(MS) section in the Method Editor 

window.

c Click the Peak Filters tab.

d Click the Peak height button.

e Mark the Relative height check box.

f Click Chromatograms > Integrate and 
Extract Peak Spectra.
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4 Do a library search for peak spectra 

1 to 4.

a In the Data Navigator window, click 

Spectra.

b In the Method Editor window, click 

Identify Spectra > Identification 
Workflow.

c Mark the Identify by - Library / 
Database search check box.

d Type 50 for the Score (rev) for demo.l.

e Select the Identify Spectra > Library 
Search Settings section.

f Click the Peak Filters tab.

g Clear the Absolute Height check box 

on the Peak Filters tab.

h In the Method Editor, click Identify 

Spectra > Generate Formulas.

i Click the Fragment Formulas tab.

j Mark the Annotate fragment 
spectrum peaks with formulas check 

box.

k Click Identify > Search Library/DB 
for Spectra in the main menu.

l Close the Method Editor window.

• You can have multiple libraries and 

databases in the Identification 

Workflow.

• If you click Search all 

libraries/databases, then the 

algorithm returns the matches from 

all libraries.

• If you mark the Annotate fragment 
spectrum peaks with formulas 
check box in the Fragment Formulas 

tab in the Identify Spectra > 

Generate Formulas section, then 

peak annotations are added to the 

spectra in the MS Spectrum Results 

window when you click Identify > 
Search Library / DB for Spectra. 

• Score (fwd) is the minimum value 

for the forward search score. Score 
(rev) is the minimum value for the 

reverse search score.

5 Modify the columns that are 

visible.

a Right-click the Spectrum Identification 

Results window and click 

Add/Remove Columns. In the 

Add/Remove Columns dialog box, 

mark the columns that you want to 

display. Click OK.

b Click the Hide any currently empty 

columns icon, ,in the Spectrum 

Identification Results window.

Task 16. Search library for mass spectra

Step Detailed Instructions Comments
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6 Review the results. • Review the Formula & Ion Species that 

are shown above the peaks in the MS 

Spectrum Results window.

• When the Data Navigator has the 

focus, you can press the Up and Down 

arrow keys to move between spectra.

• Note that the two-color display of 

annotated fragment ions (green) and 

“other” ions (red in this case) is only 

seen when fragment annotation is 

enabled. If you only see green, you can 

change the spectrum color (click Edit 
> Choose Defined Color) in order to 

see two colors.

Figure 45 Results for Library Search and Generate Formulas for first peak spectra

Task 16. Search library for mass spectra

Step Detailed Instructions Comments
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7 Review results for each spectrum 

in the MS Peaks One window.

a Click View >MS Spectrum Peak List 
1.

b Right-click and click Add/Remove 
Columns.

c Verify that the columns shown in 
Figure 46 are in the Show these 
columns list.

d Sort by the Ion Type column.

e If the Ion Type is Fragment Ion, then 

the Formula & Ion Species is shown in 

green on each peak in the MS 

Spectrum Results window.

• The Ion Type can be Molecular Ion, 

Fragment Ion or blank. If it is a 

Fragment Ion, then the Loss 

Formula and Loss Mass column 

shows the Formula and Mass that 

accounts for getting to that ion from 

the Molecular Ion. The Formula & 

Ion Species shows the formula and 

ion species for that ion.

Figure 46 MS Peaks One table with Ion Type, Loss Formula, Loss Mass,  

and Formula & Ion Species columns

8 (optional) Close the data file.

• You can proceed to the next task 

to learn how to save results.

a Click File > Close Data File.

b Click Close.

• If you want to save these results, 

see “Task 17. Save results” on 

page 75.

Task 16. Search library for mass spectra

Step Detailed Instructions Comments
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Task 17. Save results

In this task, you save the results for the current data file.

Task 17. Save results

Step Detailed Instructions Comments

1 Save the results for the current 

data file and close the data file.

a Click File > Save Results.

b Click File > Close Data File.

• You can only save one set of results 

with a data file. If you already have 

saved results with the current data 

file, then these results are 

overwritten when you click File > 
Save Results.

2 Open the data file and load the 

results.

a Click File > Open Data File. The Open 
Data File dialog box opens.

b Select a data file. For this example, 

select the data file 

MSD_mix_4stds_DG_spl200_03.d.

c Mark the Load result data check box.

d Click the Open button.

Figure 47 Open Data File dialog box

The Load result data check box is marked.
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3 Examine the results. a Click the Spectrum Identification 
Results window.

b Review the results.

Figure 48 Results for Library Search and Generate Formulas for first peak spectra

4 Close the data file. a Click File > Close Data File.

b Click No when asked whether or not to 

save results.

Task 17. Save results

Step Detailed Instructions Comments
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5 Open the data file again and do not 

load the results.

a Click File > Open. The Open Data File 

dialog box opens.

b Select a data file. For this example, 

select the data file 

MSD_mix_4stds_DG_spl200_03.d.

c Clear the Load result data check box.

d Click the Open button.

• If you do not load results, then by 

default a TIC is opened when you 

open a data file.

Figure 49 Results for Library Search and Generate Formulas for first peak spectra

6 Close the data file. a Click File > Close Data File.

b Click No.

Task 17. Save results

Step Detailed Instructions Comments
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Task 17. Save results
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Agilent MassHunter Workstation Software Qualitative Analysis
Familiarization Guide for GC/MS
Exercise 3
Use workflows, export and print

Task 18. Set up and run a Target/Suspect Screening workflow    79

Task 19. Set up and run a method using the Compound Discovery 

workflow    83

Task 20. Set up and run a method using the Custom workflow    87

Task 21. Export a CEF file    90

Task 22. Print an analysis report    93

Task 23. Print a compound report    97

In these tasks, you learn to set up and run a workflow. 

Each exercise is presented in a table with three columns:

• Steps – Use these general instructions to proceed on your own to 
explore the program.

• Detailed Instructions – Use these if you need help or prefer to use a 
step-by-step learning process.

• Comments – Read these to learn tips and additional information about 
each step in the exercise.

Task 18. Set up and run a Target/Suspect Screening workflow

When you first start to use the Qualitative Analysis Workflows program, the 
method default.m is loaded. For GC/MS, a better starting point is the 
Default-GCMS.m method. You can make changes to the opened method and 
save it, or open a new method, make changes and save the method. You cannot 
overwrite the method Default.m or Default-GCMS.m.
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Task 18. Set up and run a Target/Suspect Screening workflow
In the Qualitative Analysis Navigator program, you can only run the Custom 
Workflow. In the Qualitative Analysis Workflows program, you can run any of 
the workflows, but some of the actions in a Custom workflow cannot be 
executed. You can only edit the parameters for compound mining in the 
Qualitative Workflows program. You use the Qualitative Workflows program in 
this task.

Task 18. Set up and run a Target/Suspect Screening workflow

Steps Detailed Instructions Comments

1 Open the TIC for the 

Tomato_spiked.d data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon. Otherwise, click File 
> Open Data File.

b Click the Tomato_spiked.d data file in 

the GCMS Pesticide example data file 

folder.

c Clear the Load result data check box, 

and click Open.

• For GC/MRM data files, you can 

use the Target/Suspect Screening 

or Custom workflow.

• For GC/TOF and GC/Q-TOF files, 

you can use the Target/Suspect 
Screening, Compound Discovery, 

or Custom workflow.

• If you select Custom, some actions 

cannot be executed in the 

Qualitative Workflows program.

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.

3 Set up the method to run the 

Target/Suspect Screening 

workflow. 

• Select default_GC.csv as the 

target.

a In the Method Editor window, select 

Method Automation > Workflow.

b Select Target/Suspect Screening as 

the Workflow.

c If necessary, select the Compound 
mining algorithm. In this example, 

Find by Fragments is the only option.

d Select Pesticide_Example.cdb as the 

Target source.

e Mark the Only report qualified 
compounds check box.

• When only GC/Q-TOF or GC/TOF 

data files are open, Find by 
Fragments is the only option for the 

Compound Mining algorithm for the 

Target/Suspect Screening 

workflow.

• When only MRM data files are 

open, then Find by MRM is the only 

option for the Compound Mining 

algorithm for the Target/Suspect 

Screening Workflow.

• When you update the Target source 

on the Method Automation > 
Workflow section, the Target 
source on the Target/Suspect 
Screening > Find by Fragments > 
Target Source tab is also updated.
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Task 18. Set up and run a Target/Suspect Screening workflow
Figure 50 The Method Automation > Workflow section

4 Test the workflow to make sure 

that five compounds are found and 

qualified.

• Click the Run Method Workflow icon 

. You can instead click Method > 

Run Method Workflow. 

• If you click Method > Run Method 
Automation (Workflow + Reports), 

then first the method workflow is 

run, and then a report is generated.

5 Save the method to 

iii_GCexercise1, where “iii” are 

your initials.

a From the top menu, click Method > 
Save As.

b Type iii_GCexercise1.m.

c Click the Save button.

• Note that saving the method causes 

all the blue triangles indicating 

value changes in the opened 

method to disappear.

• You can click the Save Method icon 

to save the current method.

Task 18. Set up and run a Target/Suspect Screening workflow

Steps Detailed Instructions Comments

You can modify the parameters in the 
Target/Suspect Screening section.

You can click the Save Method icon 
to save the current method.
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide for GC/MS 81



3 Use workflows, export and print  
Task 18. Set up and run a Target/Suspect Screening workflow
6 Review the results. a Close the Structure Viewer window.

b Click View > Compound Fragment 
Spectrum Results.

c If necessary, click the Overlaid icon 

 in the Compound Chromatogram 

Results toolbar. 

d Click the second compound in the 

Compound List window.

e Review the other compounds to 

explore the results.

f Close the data file.

• The Compound Overlay mode is on. 

The red chromatogram in the 

Sample Chromatogram Results 

window is the compound 

chromatogram for the second 

compound.

Figure 51 After running the Target/Suspect Screening workflow

Task 18. Set up and run a Target/Suspect Screening workflow

Steps Detailed Instructions Comments
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Task 19. Set up and run a method using the Compound Discovery 
workflow

In this task you set up a qualitative analysis method that runs the Compound 
Discovery workflow. This workflow runs the selected compound mining 
algorithm and the identification algorithms that you mark.

In the Qualitative Analysis Navigator program, you can only run the Custom 
Workflow. In the Qualitative Analysis Workflows program, you can run any of 
the workflows, but some of the actions in a Custom workflow cannot be 
executed. You can only edit the parameters for compound mining in the 
Qualitative Workflows program. You use the Qualitative Workflows program in 
this task.

Task 19. Set up and run a method using the GC/Q-TOF Compound Screening workflow

Steps Detailed Instructions Comments

1 Open the TIC for the 

MSD_mix_4stds_DG_spl200_03.d 

data file.

a If the program is not open, double-click 

the MassHunter Qualitative Analysis 
icon. Otherwise, click File > Open 
Data File.

b Click 

MSD_mix_4stds_DG_spl200_03.d in 

the GCMS Pesticide example data file 

folder.

c Clear the Load result data check box 

and click Open.

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.
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3 Set up the method to run the 

Compound Discovery workflow. 

a In the Method Editor window, click 

Method Automation > Workflow.

b Select Compound Discovery as the 

Workflow.

By default, the Compound mining 

algorithm is Auto-Select Compound 
Mining, and Identify by 
Library/Database search is marked. 

By default, Identify by - Formula 
generation is cleared.

• Auto-Select Compound Mining 

selects the best of the available 

compound mining algorithms based 

on the type of data file that is being 

analyzed.

• Two library/database files are listed 

in the table in this method.

Figure 52 Method Automation > Workflow section when the Workflow is Compound Discovery

4 Save the method to 

iii_GCexercise2, where “iii” are 

your initials.

a From the top menu, click Method > 
Save As.

b Type iii_GCexercise2.

c Click the Save button.

Task 19. Set up and run a method using the GC/Q-TOF Compound Screening workflow

Steps Detailed Instructions Comments
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5 Test the workflow. a Click the Run Method Workflow icon 

 to run the workflow. You can 

instead click Method > Run Method 
Workflow or click Method > Run 
Method Automation (Workflow and 
Reports). 

b Review the results. 26 compounds 

were found, and the four most 

abundant compounds were identified. 

This information is provided in the 

Result Summary column in the 

Sample Table.

• When you run the method as part of 

an acquisition workflow, the 

workflow is run, and the report is 

generated.

• Once the method is set up, you just 

click the Run button. The system 

runs the compound mining 

algorithm, and it also tries to 

identify all of the compounds using 

a combination of accurate mass 

database search and spectral library 

matching.

Figure 53 Results from running Compound Screening Workflow

Task 19. Set up and run a method using the GC/Q-TOF Compound Screening workflow

Steps Detailed Instructions Comments
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6 Close the data file without saving 

results.

a Click File > Close Data File.

b Click No when asked to save results.

Task 19. Set up and run a method using the GC/Q-TOF Compound Screening workflow

Steps Detailed Instructions Comments
86 Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide for GC/MS



Use workflows, export and print 3 
Task 20. Set up and run a method using the Custom workflow
Task 20. Set up and run a method using the Custom workflow

In this task you set up a qualitative analysis method that contains a list of 
analysis actions to run in a specific order. The list of actions is different in the 
Qualitative Navigator program and the Qualitative Workflows program.

In the Qualitative Analysis Navigator program, you can only run the Custom 
Workflow. In the Qualitative Analysis Workflows program, you can run any of 
the workflows, but some of the actions in a Custom workflow cannot be 
executed. You can only edit the parameters for compound mining in the 
Qualitative Workflows program. You use the Qualitative Analysis Navigator 
program in this task.

Task 20. Set up and run a method using the Custom workflow

Steps Detailed Instructions Comments

1 Open the TIC for the 

MSD_mix_4stds_DG_spl200_03.d 

data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Navigator icon. Otherwise, click File > 
Open Data File.

b Click the 

MSD_mix_4stds_DG_spl200_03.d 
data file in the GC example data file 

folder.

c Clear the Load result data check box 

and click Open.

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.

3 Add actions to the Custom 

Workflow.

a If necessary, click View > Method 
Editor.

b In the Method Editor window, select 

Method Automation > Workflow.

c Select Custom for the Workflow.

By default, the custom workflow 

extracts additional chromatograms, 

integrates and extracts peak spectra, 

and identifies the selected spectra.

• The actions are run in the order that 

they are listed in the Actions to be 

run list. You can change the order of 

the items in the list using the arrow 

buttons in the Options tab.
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4 Review parameters for the Identify 

Selected Spectra action.

a Click the Identify Spectra > 
Identification Workflow section in the 

Method Editor window.

b Review the parameters.

c Click the Database Search Settings 

tab.

d Review the parameters.

e Click the Library Search Settings tab.

f Review the parameters.

• Note that blue triangles appear in 

other sections of Method Explorer. 

These indicate that the same 

parameter values have been 

changed elsewhere as well.

5 Save the method to 

iii_GCexercise3, where “iii” are 

your initials.

a From the top menu, click Method > 
Save As.

b Type iii_GCexercise3.

c Click the Save button.

6 Test the custom workflow. a Click the Method Automation > 
Workflows section in the Method 

Editor window.

b Click the Run Method Workflow icon 

 to run the workflow on the data 

file. You can instead click Method > 
Run Method Workflow.

Task 20. Set up and run a method using the Custom workflow

Steps Detailed Instructions Comments
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7 Review the results. a Click the Spectrum Identification 

Results tab to show the Spectrum 

Identification Results window. This 

window is tabbed with the 

Chromatogram Results window.

b Click the spectra at 9.2 minutes.

c Click View > Difference Results.

d Click View > Structure Viewer.
e Review the results.

• When you run a custom workflow, a 

report is generated if you click Run 
Method Automation (Workflow + 
Reports). 

• The Spectral Difference Results 

window is tabbed with the MS 

Spectrum Results window. 

Figure 54 Results from running a custom workflow in the Qualitative Analysis Navigator program

8 Close the data file without saving 

results.

a Click File > Close Data File.

b Click No when asked to save results.

Task 20. Set up and run a method using the Custom workflow

Steps Detailed Instructions Comments
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Task 21. Export a CEF file

You can export a CEF file containing compound information. This CEF file can 
be imported into other programs such as MassHunter Mass Profiler and Mass 
Profiler Professional. You can only export a CEF file from the MassHunter 
Qualitative Workflows program.

Task 21. Export a CEF file 

Steps Detailed Instructions Comments

1 Open the 

MSD_mix_4stds_DG_spl200_03.d 

data file.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon. Otherwise, click File 
> Open Data File.

b Click 

MSD_mix_4stds_DG_spl200_03.d in 

the GCMS Pesticide folder.

c Clear the Load result data check box.

d Click Open.

• You can export a CEF file 

interactively or when you run 

Method Automation (Workflow + 
Reports).

2 Configure the user interface. a Click Configuration > Window 
Layouts > Restore Default Layout.

b Click Method > Open.

c Select Default-GCMS.m.

d Click OK.

• For these examples, start from the 

Default-GCMS.m method.

3 Find compounds. • Run any compound mining algorithm. 

For example, click Find > Find by 
Molecular Feature.

• A CEF file is used to export 

compounds. 
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4 Export a CEF file. a To interactively export the file, click 

File > Export > as CEF.
b Click the All results option.

c Select the location of the export file.

d Click OK.

• You can import a CEF file in the 

Mass Profiler Professional software 

and the MassHunter Mass Profiler 

software.

Figure 55 Export CEF Options dialog box

5 Edit the method to export a CEF 

file.

a Click the Method Editor tab to see the 

Method Editor window. It is tabbed 

with the Compound Identification 

Results window by default.

b Click Method Automation > Export.

c Mark the CEF check box.

d Review the other parameters in this 

section.

• You can export results in multiple 

formats.

• You can modify Export parameters 

for some algorithms. You do not 

specify additional parameters when 

you export a CEF file.

Figure 56 Method Automation > Export section in the Method Editor window

Task 21. Export a CEF file (continued)

Steps Detailed Instructions Comments
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6 Run the Method Automation 

(Workflow + Reports) algorithm.

a Click Method Automation > 
Workflow.

b Click Method > Run Method 
Automation (Workflow + Reports). 

You can instead click the arrow next to 

the run icon  to run the workflow 

on the data file.

• When you run Method Automation 

(Workflow + Reports), the following 

algorithms are run:

• Method Workflow

• Extract additional 

chromatograms

• Generate a report

• Export results

Figure 57 Method Automation > Workflow section showing run options.

7 Save the method to 

iii_GCexercise4, where “iii” are 

your initials.

a From the top menu, click Method > 
Save As.

b Type iii_GCexercise4.

c Click the Save button.

Task 21. Export a CEF file (continued)

Steps Detailed Instructions Comments
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Task 22. Print an analysis report

Whenever you want to print an analysis report in the Qualitative Analysis 
Navigator program, use these instructions. 

An analysis report can contain the results from extracting and integrating 
chromatograms, extracting spectra, searching the database for peak spectra, 
or generating formulas from peak spectra. 

Task 22. Print an analysis report 

Steps Detailed Instructions Comments

1 If the 

MSD_mix_4stds_DG_spl200_03.d 

data file is not loaded, then open 

this data file and run the workflow 

for the method iii_GCexercise3.m 

which was created in “Task 20. Set 

up and run a method using the 

Custom workflow” on page 87.

a If the program is not open, double-click 

the MassHunter Qualitative 
Navigator icon. Otherwise, click File > 
Open Data File.

b Click the 

MSD_mix_4stds_DG_spl200_03.d 
data file in the GC example data file 

folder.

c Clear the Load result data check box.

d Click the Use current method button 

and click Open.

e Click Method > Run Method 
Workflow.

• If you finished “Task 20. Set up and 

run a method using the Custom 

workflow” on page 87, then the 

current method is 

iii_GCexercise3.m. This method is 

set up to extract additional 

chromatograms, integrate and 

extract peak spectra, and identify 

selected spectra.

• An analysis report contains 

integration information, and 

spectral information. If you identify 

the spectra, then this report can 

include that information.

2 Change the analysis report 

selections in the method:

• Mark the check boxes for the 

chromatograms, spectra or 

tables you want to print.

• Clear the check boxes for the 

chromatograms, spectra or 

tables which you do not want to 

print.

a Click View > Method Editor.

b In the Method Editor window, click 

Reports > Analysis Report.
c Mark the check boxes for any 

additional selections you want to print.

d Clear any check boxes for items which 

you do not want to print.

• The Analysis report only contains 

the information that you mark in 

this section. 

• You can instead click Method 

Automation > Reports to set up the 

reporting parameters. Changes 

made there are reflected in the 

Reports section, and vice versa.

• If some results are not available, 

then those results are not included, 

even if those results are marked in 

this section. For example, if you 

have not integrated the 

chromatogram, then the peak table 

is not included.
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Task 22. Print an analysis report
Figure 58 Analysis Report section in the Method Editor window

3 Review the Templates parameters. a In the Method Editor window, click 

Reports > Common Reporting 
Options.

b (optional) Select a different Analysis 

report template.

• Different report templates are 

available. These templates contain 

different information.

Figure 59 Common Reporting Options > Templates tab in the Method Editor window

Task 22. Print an analysis report (continued)

Steps Detailed Instructions Comments

You can select whether to use Microsoft Excel for 
reporting or to use PDF-based reporting.

If you click Use Microsoft Excel for reporting, then 
a different set of templates is available to select. 
You can use Excel to modify the selected template. 
See the online Help for the Report Designer to learn 
more about modifying a template.
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4 Print the report. a Print the report in one of these ways:

• From the main menu, click File > 
Print > Analysis Report.

• From the main toolbar, click the 

Printer icon.

• Click the Print Analysis Report icon, 

 in the Method Editor toolbar 

when the Analysis Report section is 

selected.

• Right-click the Analysis Report 

section in the Method Editor, and 

click Print Analysis Report.
• From the data file shortcut menu in 

the Data Navigator, click Analysis 
Report.

b Click one of the options under Report 
contents.

c (optional) Mark the Separate report 
per data file check box.

d Mark the Print report check box and 

select a printer.

e Mark the Print preview check box.

f Click the OK button.

• The Run icon  in the Method 

Editor toolbar sometimes allows you to 

choose an action from a set of possible 

actions. For example, if you switch to 

the Reports > Common Reporting 

Options section of the Method Editor 

window, four different actions are 

possible when you click the Run icon. 

If you click the arrow, a list of possible 

actions is shown, and you can choose 

which action to do. Choosing a 

different action from the list changes 

the default action. If you simply click 

the Run button, the current default 

action is performed.

• When you click Method > Run 
Method Automation (Workflow + 
Reports), the method workflow is run. 

Then, any additional chromatograms 

are extracted, and the report is printed. 

Finally, export files may be generated if 

marked in the Method Automation > 

Export section.

Figure 60 Print Analysis Report dialog box

Task 22. Print an analysis report (continued)

Steps Detailed Instructions Comments
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g Review the report.

h Click the Close Print Preview icon in 

the toolbar.

Figure 61 Preview of the Analysis Report

Task 22. Print an analysis report (continued)

Steps Detailed Instructions Comments
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Task 23. Print a compound report
Task 23. Print a compound report

Whenever you want to print a compound report, use these instructions. You 
print a compound report from the Qualitative Workflows program.

Task 23. Print a compound report

Step Detailed Instructions Comments

1 If the 

MSD_mix_4stds_DG_spl200_03.d 

data file is not loaded, then open 

this data file and run the workflow 

for the method iii_GCexercise2.m 

which was created in “Task 19. Set 

up and run a method using the 

Compound Discovery workflow” on 

page 83.

a If the program is not open, double-click 

the MassHunter Qualitative 
Workflows icon. Otherwise, click File 
> Open Data File.

b Click the 

MSD_mix_4stds_DG_spl200_03.d 
data file in the GC example data file 

folder.

c Clear the Load result data check box.

d Click the Use current method button 

and click Open.

• If you finished “Task 19. Set up and 

run a method using the Compound 

Discovery workflow” on page 83, 

then the current method is 

iii_GCexercise2.m. The workflow for 

this method is Compound 

Discovery. The Compound mining 

algorithm is automatically selected, 

and the Identify by - 

Library/Database search option is 

marked.

2 Run the workflow.

• A compound report includes a 

compound table.

• Click Method > Run Method 
Workflow.

• The compound mining algorithm is 

automatically selected.

• The Library/Database search 

algorithm is run on the compounds.

3 Review the template selected.

• If you want to choose a different 

template, then you need to know 

the workflow selected to know 

which report template parameter 

to modify.

• If you click Use Microsoft Excel 
for reporting, you can use Excel 

and the Report Designer add-in 

to customize any of the 

templates that have the 

extension XLTX. You cannot 

customize the acquisition 

method report.

a In Method Editor, click Method 
Automation > Reports.

b Click the Templates tab.

c (optional) Select a different report 

template for the Target screening 
report template.

d (optional) Select a different report 

template for the Compound Discovery 
report template.

e (optional) Select a different report 

template for the Sample purity report 
template.

f (optional) Select a different report 

template for the Compound report 
template.

• The report template that is used 

when you print a compound report 

depends on the current workflow.

• The Target screening report template is 

used with the Target/Suspect 
Screening workflow.

• The Compound Discovery report 

template is used with the 

Compound Discovery workflow.

• The Compound report template is 

used with the Custom workflow.

• The current workflow is selected on 

the Method Automation > 
Workflow section.
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4 Change some of the selections in 

the method for compound reports:

• Turn off viewing the MS spectra 

zoomed in on special peaks.

• Turn off the MS/MS options in 

the report.

a Click the Contents tab.

b Clear the Show MS spectrum 
(zoomed in on special peaks) check 

box.

c If visible, clear the Show MS/MS 
spectrum check box.

d If visible, clear the Show MS/MS 
peak table check box.

• These check boxes allow you to 

specify what information to include 

in a report if it is available. If the 

information is not available, that 

section is automatically skipped. 

For example, MS/MS results are 

never included when the data file 

only has MS data.

• The Compound spectrum 
(MS/MS) section is not visible 

when the opened data files only 

contain MS data.

• For GC/MS data, clear the Overlay 
compound chromatograms check 

box.

Figure 62 Compound Report section in the Method Editor

Task 23. Print a compound report

Step Detailed Instructions Comments
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Task 23. Print a compound report
5 Print the report. a Click File > Print > Compound Report. 
If you click the Print Report icon  

to print the compound report, it is 

printed immediately.

b Mark the Print preview check box.

c Click OK. Examine the report.

d Click the Close Print Preview icon.

• In the Print Compound Report dialog 

box, you can select a different 

printer, select to save the report to a 

PDF or Excel file, select whether to 

print all results or only the 

highlighted results, and whether or 

not to combine different data files 

into one report.

Figure 63 Print Preview window with the Compound Report

6 Close the data file without saving 

results.

a Click File > Close Data File.

b Click No when asked if you want to 

save the results.

Task 23. Print a compound report

Step Detailed Instructions Comments
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Qualitative Analysis Navigator Program
Qualitative Analysis Navigator Program

Main Functional Areas

When you first open the Qualitative Analysis navigator program, you see three 
parts: (1) the Menu Bar, (2) the Toolbar, and (3) the Main Window. The main 
functional areas are shown in Figure 64.

Figure 64 Overview of the Qualitative Analysis Navigator program
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1. Menu Bar

The menu bar (Figure 65) provides actions that are used for extracting 
chromatograms and spectra and identifying the spectra, printing and 
exporting reports, and launching the Qualitative Analysis Workflows program 
or the BioConfirm program. The online Help describes each menu.

2. Toolbar

The toolbar provides actions that are used for opening and closing data files. 
You can also open and save methods, print a compound report, and toggle 
whether a window is visible or not.

Figure 65 The menu bar for the Qualitative Analysis Navigator program

Figure 66 The toolbar for the Qualitative Analysis Navigator program

Toolbar Icon Action

File > Open Data File

File > Refresh Data File

File > Save Results

File > Close Data File

File > Print > Analysis Report

Edit > Choose Defined Color

Edit > Show > Highlighted

Edit > Show > Only Highlighted

Edit > Show > All Items

Edit > Undo

Edit > Redo

View > Linked Navigation

View > Data Navigator

View > Method Editor
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3. Main window

The main window (see Figure 64 on page 102) is further divided into up to 17 
windows: 

• Data Navigator

• Method Editor

• Chromatogram Results

• Spectrum Preview

• MS Spectrum Results

• Recalibration

• Difference Results

• UV Spectrum Results

• Integration Peak List

• MS Spectrum Peak List 1

• MS Spectrum Peak List 2

• MS Actuals

• Spectrum Identification Results

• Structure Viewer

• Sample Information

• Formula Calculator

• Mass Calculator

Chromatogram Results window

MS Spectrum Results window

Difference Results window

UV Spectrum Results window

Integration Peak List window

MS Spectrum Peak List 1 window

MS Spectrum Peak List 2 window

MS Actuals window

Spectrum Identification Results window

Structure Viewer window

Sample Information window

Toolbar Icon Action
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Two of these windows (Spectrum Preview and Recalibration) are started from 
one of the other windows, and two of these windows (Formula Calculator and 
Mass Calculator) are started from the Tools menu. When you first open the 
Qualitative Analysis navigator program, you see three windows in the default 
layout: Data Navigator, Chromatogram Results, and MS Spectrum Results. 
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Windows - Qualitative Analysis Navigator Program

Data Navigator The Data Navigator organizes all the results of extraction and 
spectrum selection either by data file or by data type. When sorting by data 
file, all of the extracted chromatograms are listed under Chromatograms for 
each data file. All of the extracted spectra are listed under either Spectra or 
Background Spectra. 

When you click a chromatogram or spectrum, the plot is automatically 
highlighted in the plot window, and the windows containing tables are 
updated. When Linked Navigation is activated (View > Linked Navigation), 
additional linking of a chromatogram to spectra extracted from that 
chromatogram (and vice versa) is active. Highlighting a chromatogram in Data 
Navigator also highlights the corresponding spectra. The corresponding 
chromatogram and spectrum graphic results are also highlighted. Linked 
Navigation only works if you have used the Integrate and Extract Peak 
Spectra command from the Chromatograms Menu.

Method Editor This window allows you to edit method parameters. These 
parameters are separated into different tabs, and related tabs are grouped 
together in different sections. The left-hand side of the window shows the 
different sections. You can get help on the currently viewed tab of the current 
section when you press the F1 key.

Figure 67 Data Navigator window with three data files opened
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Chromatogram Results You view any chromatogram in this window. You can 
view multiple chromatograms from different files at the same time. You can 
show these chromatograms overlaid or in list mode. Figure 69 shows the 
chromatograms in list mode.

Perform operations on the chromatogram

You can perform many operations on chromatograms.

Figure 68 Method Editor window

Figure 69 Chromatogram Results window showing three chromatograms in List Mode
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• You can change the appearance of the plots in the window via icons in the 
Chromatogram Results toolbar.

• You can extract additional chromatograms or mass spectra, or process 
chromatograms via the Chromatograms menu.

• You can initiate many operations via the shortcut menu. When you 
right-click a chromatogram in the Chromatogram Results window, you see 
the shortcut menu.

See the online Help for more information. The following table shows some 
possible operations.

Spectrum Preview You use this window to quickly scan the spectra in a data 
file. You start this window in the Chromatogram Results window when you 
select the “Walk Chromatogram” tool ( ). The spectra displayed in this 
window are not kept in the Data Navigator window unless you copy a 
spectrum to the Spectra section.

Action How to do it

Change peak labels in chromatogram Click  in the Chromatogram Results toolbar

Extract a chromatogram Chromatograms > Extract Chromatograms

Extract additional chromatograms Chromatograms > Extract Additional Chromatograms

Integrate the chromatogram Chromatograms > Integrate Chromatogram

Integrate and extract peak spectra Chromatograms > Integrate and Extract Peak Spectra

Smooth the chromatogram Chromatograms > Smooth Chromatogram

Calculate Signal-to-Noise Chromatograms > Calculate Signal-to-Noise

Figure 70 Spectrum Preview window showing spectra from 3 data files
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MS Spectrum Results You display MS and MS/MS spectra in this window. You 
can add annotations and calipers to these spectra. You can change the peak 
labels and the font in the MS and MS/MS Spectra Display Options dialog box. 
If you performed a library search and identified the spectrum, a structure may 
also be visible in the pane for that spectrum. You can also see predicted 
isotope distributions (from formula generation) and custom text or graphic 
annotations, including “calipers” to measure mass differences.

You can perform many operations on spectra.

• You can change the appearance of the plots in the window via icons in the 
MS Spectrum Results toolbar. You can also add annotations and calipers via 
the toolbar.

• You can add or subtract spectra, send spectra to PCDL, and recalibrate a 
spectrum via the Spectra menu.

• You can initiate many operations via the shortcut menu. When you 
right-click a spectrum in the MS Spectrum Results window, you see the 
shortcut menu.

See the online Help for more information on toolbars, menus, and shortcut 
menus. 

Recalibration You refine the mass calibration for TOF or Q-TOF data from this 
window. You specify the reference mass list, and the system finds matches to 
the reference masses in the spectrum from which you start the window. You 
can apply these values to a data file. You start this window from the shortcut 
menu in the MS Spectrum Results window. 

Figure 71 MS Spectrum Results window showing three MS spectra
Agilent MassHunter Workstation Software - Qualitative Analysis Familiarization Guide for GC/MS 109



4  
Windows - Qualitative Analysis Navigator Program
Spectral Difference Results After you run the Search Library algorithm and 
identify the spectrum with library search, this window shows three spectra. 
The first spectrum is the spectrum that was searched. The second spectrum is 
a difference spectrum. The spectra from the library is subtracted from the 
user spectrum to create the difference spectrum. The third spectrum is the 
spectrum from the library that is currently selected in the Spectrum 
Identification Results window.

Figure 72 Recalibrate window

Figure 73 Spectral Difference Results window
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UV Spectrum Results This window shows UV spectra. You can extract a UV 
spectrum from either an MS chromatogram or a UV chromatogram if you 
acquired UV data. You can add annotations to a UV spectrum.

Integration Peak List This window contains a table of the integration results 
for the selected chromatogram. Each peak in the chromatogram is listed on a 
separate row in the table. If you have more than one chromatogram 
highlighted, the first chromatogram in the Data Navigator window that is 
highlighted is shown in the Integration Peak List table. You can sort the 
contents of the table and change the columns that are displayed using the 
commands in the shortcut menu. You can drag columns to a different location 
in the table. Column headers and other cells have different shortcut menus.

MS Spectrum Peak List 1 and MS Spectrum Peak List 2 This table shows the 
peaks that are part of a spectrum. Each point in a spectrum is listed on a 
separate row in the table. If you have more than one spectrum highlighted, the 
first spectrum is shown in this table, and the other spectrum can be seen in 
the MS Spectrum Peak List 2 window. You can sort the contents of the table 

Figure 74 UV Spectrum Results

Figure 75 Integration Peak List window
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and change the columns that are displayed using the commands in the 
shortcut menu. You can drag columns to a different location in the table. 
Column headers and other cells have different shortcut menus.

MS Actuals This window shows acquisition information for the highlighted 
spectrum. Closing the MS Actuals window will increase performance. Only 
four columns are possible in this table: Category, Name, Value, and Unit.

Figure 76 MS Peaks One window

Figure 77 MS Peaks Two window
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Spectrum Identification Results This window shows the results from using the 
identification algorithms on a spectrum. If you run the Generate Formulas 
(MFG) or Search Library/DB, then those results are shown in this window. The 
results for one spectrum are shown in this window. When you highlight a 
different spectrum, the results in this window are changed to show any results 
from the new spectrum. This table has up to three levels. The first level shows 
the overall results for the spectrum. The second level shows the individual 
scores which were used to create the overall score for an algorithm. The third 
level of the table shows height and m/z values (both calculated and actual). 
This level is available for the Generate Formulas algorithm and the Search 
Database algorithm.

Figure 78 MS Actuals window showing instrument parameters for current spectrum

Figure 79 Spectrum Identification Results window
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Structure Viewer Structures can be attached to a spectrum when you run the 
Search Library/DB algorithm, and the database or library contains a structure 
for the best hit. A structure can also be attached when you add or edit a 
manual identification to the spectrum. The Structure Viewer contains two 
tabs. The Structure tab shows a graphical representation of the structure. The 
MOL Text tab contains text that describes the structure.

Formula Calculator This tool calculates possible empirical formulas 
corresponding to the mass or mass-to-charge value which you enter. The 
results may be viewed interactively, and printed or exported.

Figure 80 Structure Viewer window

Figure 81 Formula Calculator window
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Mass Calculator This tool allows you to enter a base formula and a list of ion 
species (positive or negative ions). When you run the Mass Calculator 
algorithm, the Mass Calculator table contains a row for each ion species and 
calculates the mass for each species.

Figure 82 Mass Calculator window
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Qualitative Analysis Workflows program

Main Functional Areas

When you first open the Qualitative Analysis Workflows program, you see 
three parts: (1) the Menu Bar, (2) the Toolbar, and (3) the Main Window. The 
main functional areas are shown in Figure 83.

Figure 83 Overview of the Qualitative Analysis Workflows program
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1. Menu Bar

The menu bar (Figure 84) provides actions that are used for finding and 
identifying compounds, printing and exporting reports, and launching the 
Qualitative Analysis Navigator program. The online Help contains detailed 
information on each menu.

2. Toolbar

The toolbar provides actions that are used for opening and closing data files. 
You can also open and save methods, print a compound report, and toggle 
whether a window is visible or not.

Figure 84 The menu bar for the Qualitative Analysis Workflows program

Figure 85 The toolbar for the Qualitative Analysis Workflows program

Toolbar Icon Action

File > Open Data File

File > Save Results

File > Close Data File

File > Print > Compound Report

Edit > Undo

Edit > Redo

View > Sample Table

View > Method Editor

View > Compound Chromatogram Results

View > Sample Chromatogram Results

View > Compound MS Spectrum Results

View > Compound Fragment Spectrum Results

View > Difference Results

View > Compound List

View > Compound Identification Results

View > MS/MS Formula Details

View > Structure Viewer
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3. Main window

The main window (see Figure 83 on page 116) is further divided into up to 13 
windows. When you first open the Qualitative Analysis Workflows program, 
you see a subset of the windows in the default layout: 

• Sample Table

• Compound List

• Compound Identification Results

• Method Editor

• Structure Viewer

• Sample Chromatogram Results

• Compound Chromatogram Results

• Compound MS Spectrum Results. 

• Compound Fragment Spectrum Results

• Difference Results

• MS/MS Formula Details

• Formula Calculator

• Mass Calculator. 

Windows - Qualitative Analysis Workflows

Sample Table The Sample Table shows information for each sample (data file) 
that is opened. Data from the sample or samples which you select in this 
window are displayed in the other windows. You can reprocess a selected 
sample.

Figure 86 Sample Table
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Compound List This windows shows all of the compounds which were found 
for the selected sample files. You can add and remove columns from this table, 
and you can change the order of the columns within a category.

Columns in the Compound List window are separated into categories. You can 
change the order of the columns within a category. These columns are also 
shown in the Add/Remove Columns dialog box. The categories are

• General

• Compound Identification

• Formula Generation

• Molecular Feature Extraction

• Database Search

• Library Search

• Sample Purity

• Target/Suspect Screening

Compound List Toolbar

Toolbar Icon Action

• Hides any currently empty columns

o • Toggles whether to auto size all columns. 

When On, the width of columns is 

automatically changed to show the 

information in that column.

• Switches to the previous compound. If the 

first compound is selected, this icon is not 

available.

• Switches to the next compound. If the last 

compound is selected, this icon is not 

available.
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Method Editor A method is a set of parameters that are associated with the 
different algorithms that you can run. Methods containing these parameters 
can be saved using unique file names. 

You select the section of the method to display in the left pane. The right pane 
contains either a single section or multiple tabs. You can get help for the 
currently selected tab or section in the Method Editor when you press F1.

Figure 87 Compound List window showing columns in five categories

Figure 88 Method Editor window
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Compound Chromatogram Results This window shows the chromatograms 
associated with the compound (or compounds) selected in the Compound List 
window including an Extracted Ion Chromatogram (EIC). You can display a 
legend in the upper right corner of the graphic if you select Overlaid mode for 
the chromatograms. You can add annotations to the graphic. You can also 
export or print the graphic.

Perform operations on the chromatogram

You can perform many operations on chromatograms.

• You can change the appearance of the plots in the window via icons in the 
Compound Chromatogram Results toolbar.

• You can add annotations to a chromatogram via the Annotation tool.

• You can initiate many operations via the shortcut menu. When you 
right-click a chromatogram in the Compound Chromatogram Results 
window, you see the shortcut menu.

See the online Help for more information. 

Figure 89 Compound Chromatogram Results window
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Compound Chromatogram Results Tools

Toolbar Icon Action

Zoom tools • Autoscale X-axis and Y-axis

• Autoscale X-axis

• Autoscale Y-axis

• Unzoom

• Autoscale Y-axis during Zoom

• Linked Y-axis mode

o

or

o

• List mode - chromatograms are drawn 

with each chromatogram having a 

separate Y-axis.

• Overlay mode - chromatograms are drawn 

with the same X-axis and the same Y-axis

• Number of chromatograms to show at 

the same time before adding a scroll bar. 

This option is shown when you click List 
mode.

• Cycle to Previous Plot or Cycle to next 
plot. These options are shown when you 

click Overlay mode.

• Show legend in Overlay mode - If you 

select Overlay mode, you can select 

whether or not to show a legend. If you 

show the coelution plot, this option also 

controls whether that legend is visible.

• Range Select – When On, you can draw a 

range for chromatogram, for which you 

can perform actions.

• Annotation – When On, you can add 

image and text annotations to the 

chromatograms.

Scaling tools • Stops scaling chromatograms

• Scales all chromatograms to the largest 

peak in any of the chromatograms

• Scales all chromatograms to the largest 

peak in itself

• Scales each chromatogram to the highest 

peak within the selected range
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Sample Chromatogram Results This window shows the chromatograms for 
each sample that is selected in the Sample Table window. This chromatogram 
may be a Total Ion Chromatogram (TIC) or a Base Peak Chromatogram (BPC). 
You can also overlay compound chromatograms. UV chromatograms that are 
extracted as part of the Find by Formula algorithm also are displayed in this 
window. You can export or print the graphic.

Sample Chromatogram Results Tools

Other tools • Toggles whether or not the Coelution Plot 

is visible

• Toggles whether the Integration Peak List 

is visible

• Opens Chromatogram Display Options 

dialog box

• Prints the displayed chromatograms

Figure 90 Sample Chromatogram Results window

Toolbar Icon Action

Zoom tools • Autoscale X-axis and Y-axis

• Autoscale X-axis

• Autoscale Y-axis

• Unzoom

• Autoscale Y-axis during Zoom

Toolbar Icon Action
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Compound MS Spectrum Results This window shows the mass spectra 
associated with the selected compound(s) if one or two compounds are 
selected. When you select more than two compounds, then only the spectra of 
the first two highlighted compounds are shown. MS/MS spectra are displayed 
in the Compound Fragment Spectrum window. You can add annotations and 
calipers to a spectrum in this window. You can display the peak list which is 
displayed in a table on the right-side of this window. A tab is added for each 
spectrum that is displayed. You can send the spectra to PCDL, export, and 
print a spectrum.

or

o

• List mode - chromatograms are drawn 

with each chromatogram having a 

separate Y-axis.

• Overlay mode - chromatograms are drawn 

with the same X-axis and the same Y-axis

• Number of chromatograms to show at 

the same time before adding a scroll bar. 

This option is shown when you click List 
mode.

• Cycle to Previous Plot or Cycle to next 
plot. These options are shown when you 

click Overlay mode.

• Compound Overlay mode - compound 

chromatograms are also shown in the 

Sample Chromatogram Results window.

• Extract Chromatograms - the Extract 
Chromatograms dialog box is opened.

Scaling tools • Stops scaling chromatograms

• Scales all chromatograms to the largest 

peak in itself

Other tools • Displays the peak list table for the 

chromatogram

• Opens Chromatogram Display Options 

dialog box

• Prints the displayed chromatograms

Toolbar Icon Action
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Compound MS Spectrum Results Tools

Figure 91 Compound MS Spectrum Results window

Toolbar Icon Action

Zoom tools • Autoscale X-axis and Y-axis

• Autoscale X-axis

• Autoscale Y-axis

• Unzoom

• Autoscale Y-axis during Zoom

or

o

• List mode - spectra are drawn with each 

spectrum having a separate Y-axis

• Overlay mode - spectra are drawn with the 

same X-axis and the same Y-axis

• Number of spectra to show at the same 

time before adding a scroll bar. This option 

is shown when you click List mode.

• Cycle to Previous Plot or Cycle to next 
plot. These options are shown when you 

click Overlay mode.

• Show Predicted Isotope Distribution

Select tools in order

One of these tools always has to be selected. The 

Range Select tool is selected in this image. The 

selected tool has an orange background.

• Range Select – When On, you can draw a 

range for spectra, for which you can 

perform actions

• Annotation – When On, you can add 

image and text annotations to the spectra.

• Calipers – When On, you can add a Delta 

Mass caliper to the selected spectrum. 

See the online Help for more information.
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Compound Fragment Spectrum Results This window shows the MS/MS spectra 
associated with the selected compound(s) if one or two compounds are 
selected. When you select more than two compounds, then only the MS/MS 
spectra for the first two highlighted compounds are shown. MS spectra are 
displayed in the Compound MS Spectrum window. You can also annotate and 
add calipers to a Compound Fragment Spectrum.

Compound Fragment Spectrum Results Tools

Other tools • Displays the peak list table for the 

spectrum

• Opens MS and MS/MS Spectra Display 
Options dialog box

• Prints the displayed spectra

Figure 92 Compound Fragment Spectrum Results window with corresponding peak list

Toolbar Icon Action

Zoom tools • Autoscale X-axis and Y-axis

• Autoscale X-axis

• Autoscale Y-axis

• Unzoom

• Autoscale Y-axis during Zoom

Toolbar Icon Action
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Difference Results After you run the Search Library algorithm and identify 
the compound with library search, this window shows three spectra. The first 
spectrum is the spectrum that was searched. The second spectrum is a 
difference spectrum. The spectra from the library is subtracted from the user 
spectrum to create the difference spectrum. The third spectrum is the 
spectrum from the library that is currently selected in the Spectrum 
Identification Results window.

or

o

• List mode - spectra are drawn with each 

spectrum having a separate Y-axis

• Overlay mode - spectra are drawn with the 

same X-axis and the same Y-axis

• Number of spectra to show at the same 

time before adding a scroll bar. This option 

is shown when you click List mode.

• Cycle to Previous Plot or Cycle to next 
plot. These options are shown when you 

click Overlay mode.

Select tools in order

One of these tools always has to be selected. The 

Range Select tool is selected in this image. The 

selected tool has an orange background.

• Range Select – When On, you can draw a 

range for spectra, for which you can 

perform actions

• Annotation – When On, you can add 

image and text annotations to the spectra.

• Calipers – When On, you can add a Delta 

Mass caliper to the selected spectrum. 

See the online Help for more information.

Other tools • Displays the peak list table for the 

spectrum

• Opens MS and MS/MS Spectra Display 
Options dialog box

• Prints the displayed spectra

Toolbar Icon Action
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Compound Identification Results This window shows the results of running an 
identification algorithm such as Generate Formulas or Search Library/DB.

MS/MS Formula Details This window contains a table that shows possible 
formulas calculated for fragments seen in an MSMS spectrum that are 
consistent with a proposed formula. Its contents are the results that are 
related to the currently-selected formula row in the Compound Identification 
Results table. The data in this table is used to compute the Score (MFG, 
MS/MS) column in the Compound Identification Results table.

Figure 93 Difference Results window

Figure 94 Compound Identification Results window
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Structure Viewer Structures can be attached to a spectrum when you run the 
Search Library/DB algorithm, and the database or library contains a structure 
for the best hit. A structure can also be attached when you add or edit a 
manual identification to the spectrum. The Structure Viewer window has two 
tabs. The Structure tab shows a graphical representation of the structure. The 
MOL Text tab contains text that describes the structure.

Figure 95 MS/MS Formula Details window

Figure 96 Structure Viewer window
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Qualitative Analysis Navigator and Workflows Programs

Layouts

You can open and save different layouts. You can modify any of the following 
attributes, and they are saved in the layout. Two default layouts are shipped 
with the software: default.xml (for the Qualitative Analysis Workflows 
program) and CDN_Default.xml (for the Qualitative Analysis Navigator 
program).

A layout consists of the following:

• Each window’s position and size

• Which windows are tabbed

• Which windows are floating

• Which tabbed window is on top

• Which windows are visible by default

• Whether the status bar is visible

For each plot window (in Qualitative Analysis Navigator: the Chromatogram 
Results window, the Spectrum Preview window, the MS Spectrum Results 
window, the Difference Results window, and the UV Results window; in 
Qualitative Analysis Workflows: the Sample Chromatogram Results window, 
the Compound Chromatogram Results window, the Compound MS Spectrum 
Results window, the Compound Fragment Spectrum Results window, and the 
Difference Results window), the following are saved:

• Whether or not the graphics are overlaid

• Whether or not the Autoscale Y-Axis during Zoom mode is on

• Whether or not the Linked Y-Axis mode is on

For each table window, the following are saved

• Which columns are visible

• The order of the columns

• The width of each column
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• Any filter that has been added to the table (only available for the Compound 
List table, the Compound Identification Results table, and the Spectrum 
Identification Results window).
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Customize a report template

Please refer to either the online Help for the MassHunter Report Designer 
Add-in, the Report Designer Familiarization Guide or the Reporting Training 
DVD for detailed information on how to modify a report template. The 
following steps give you a quick look at what it means to customize a template. 
These instructions apply to a Microsoft Excel report template only.

1 Go to the folder that contains the report templates. By default, this folder is  
\MassHunter\Report Templates\Qual\B.08.00\en-US\Letter. You can select a 
different folder in the Method Editor in the Method Automation > Reports > 
Templates tab.

2 Make a copy of the template which you intend to modify.
3 Right-click the copy and click Properties. If necessary, clear the Read-only 

check box. Then, right-click the copy and click Open from the shortcut menu.

When the template is open, you can modify headers and footers. You can also 
add, remove or move parameter columns. You can refer to the online Help for 
more information.

Many templates are installed with the Qualitative Analysis program.
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4 Make the changes you want to make.

For more information on how to modify a template, see either the online 
Help for the MassHunter Report Designer add-in, or the Agilent 
MassHunter Reporting - Training DVD.

5 To save the new template, either click Save or click Save As > Other Formats 
from the Microsoft Office button. 

6 Type an identifying name, and click Save.
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