Agilent OpenLAB Data Store

Installation Guide
Notices

© Agilent Technologies, Inc. 2014

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

M8620-90012

Edition

September 2014

Printed in USA

Agilent Technologies, Inc.
3501 Stevens Creek Blvd.
Santa Clara, CA 95051 USA

Microsoft ® is a U.S. registered trademark of Microsoft Corporation.

Software Revision

This guide is valid for A.02.02 Agilent OpenLAB Data Store software.

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

U.S. Government Restricted Rights. Software and technical data rights granted to the federal government include only those rights customarily provided to end user customers. Agilent provides this customary commercial license in Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212 (Computer Software) and, for the Department of Defense, DFARS 252.227-7015 (Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial Computer Software or Computer Software Documentation).

Safety Notices

CAUTION

A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

WARNING

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.
Contents

1 Introduction 7
   About This Guide 8
   The Agilent OpenLAB Data Store Software 8
   Before You Begin 9

2 Configuration of Windows Server 2012 R2 11
   Install Windows Server 2012 R2 12
   Configure Windows Server 2012 R2 Settings 12
      Configure Windows updates 12
      Disable the application experience service 13
      Set local security policy 13
      Set region and language options 13
      Set time zone 13
      Enable .NET Framework 3.5 14
      Enable non-http activation 14
   Configure SQL Server Settings 14
      Change server authentication to mixed mode 14
      Disable the Reporting Services feature 15

3 Install the OpenLAB Data Store Server Software 17
   Step 1: Start the Application 18
   Step 2: Run the System Configuration Checker 18
   Step 3: Prepare Third Party Tools 19
      Install Adobe PDF Reader 19
      Install Adobe Flash Player 19
      Enable Adobe Flash Player 19
      Disable Auto-Update Notification in Flash Player 19
   Step 4: Run OpenLAB Data Store Installer 20
      OpenLAB Master Installer 20
      License Agreement Screen 20
      Installation folder screen 20
Contents

7 Upgrade the OpenLAB Data Store Software 41
   Upgrade the OpenLAB Data Store Server Software 42
   Upgrade the OpenLAB Data Store Client Software 43

8 Uninstall the Software 45
   About Uninstallation 46
   Run the OpenLAB Uninstallation Wizard 46
1

Introduction

About This Guide 8
The Agilent OpenLAB Data Store Software 8
Before You Begin 9

This chapter gives you an overview of the OpenLAB Data Store software and includes the requirements needed for pre-installation.
1 Introduction

About This Guide

This installation guide is designed to help system administrators and other users install the Agilent OpenLAB Data Store software quickly and correctly.

The Agilent OpenLAB Data Store Software

The Agilent OpenLAB Data Store, along with Agilent OpenLAB Chromatography Data System (CDS), Agilent OpenLAB Enterprise Content Manager (ECM), plus several add-ons make up the Agilent OpenLAB software suite.

These integrated solutions form a system designed to grow with customer needs, from a small standalone analytical lab to a global network with hundreds of locations. Using the OpenLAB software, instruments from multiple vendors can connect to any size network; from individual workstations and workgroups to global enterprises. With full instrument control, centralized administration, and ease-of-support, users can achieve lower operational costs and better instrument use. See your Agilent representative to learn how other products in the OpenLAB suite can help you.
Before You Begin

1 Acquire administrator privileges for all servers and clients. Power user privileges are not sufficient (The installation will not start.).

2 Decide on a server and a directory location to store files related to Data Store content and indexes. Agilent recommends a dedicated server for OpenLAB Data Store.

3 Obtain the Data Store server:
   - Database name
   - Database administrator user name and password
   - Authentication mode - Windows domain and internal authentication are supported. If you are upgrading and used Windows local authentication in your last configuration, you must reconfigure your server to use internal or Windows domain authentication before beginning the upgrade.
   - Administrator user credentials (domain, user name, password)

4 Review the following PDFs in the Installer Planning and Resources menus before you install the software:
   Under the Installer Planning menu:
   - **Hardware and Software Requirements** – Use this PDF to determine if your hardware and software will support the system.
   - **Installation Guide for OpenLAB Data Store** – This installation guide is provided in PDF format for your convenience.
   Under the Installer Resources menu:
   - License Agreement – Use this PDF to review the license terms.

**CAUTION**

Before beginning this installation, remove any PostgreSQL server that you have installed outside of the OpenLAB software. Agilent only supports the use of the PostgreSQL server that is installed by the OpenLAB software.

Keep your computers disconnected from the Internet until you have installed the appropriate security patches and hot fixes.

Agilent strongly recommends installation of the latest security fixes and virus protections prior to connecting to a network.
1 Introduction
This chapter describes the necessary installation and configuration of the Windows Server to prepare it for the installation of the Data Store server.

Agilent recommends a dedicated server for OpenLAB Data Store.
Install Windows Server 2012 R2

1. Install Windows Server 2012 R2. During the setup of Windows Server 2012 R2, record the computer name, administrator password, and network settings.

2. Check for Windows updates and apply all critical security patches.

3. Install Windows hotfix KB2577795. This applies to Win7 and Win2008R2 only. (http://support.microsoft.com/kb/2577795).

4. Join an existing domain or set up the system in workgroup mode. Changing the server domain after the installation requires direct consultation with Agilent Support.

5. To guard your systems against viruses, install an AntiVirus program. Running AntiVirus programs can influence the behavior and performance of your computer. OpenLAB Data Store was tested to run with Symantec’s Norton AntiVirus.

6. Confirm that no server role or feature is installed.

Configure Windows Server 2012 R2 Settings

These settings optimize the application performance.

Configure Windows updates

1. Click Start > Control Panel.

2. Click System and Security > Windows Update > Check for updates.

3. Apply updates.

4. Click Change Settings. For Important updates, select Never check for updates. Disable the other update options.

5. Click OK to close the window.
Disable the application experience service

1. Go to **Start > Control Panel**.
2. Click **Administrative Tools > Services**.
3. In the **Services** list, right-click **Application Experience** and select **Properties**.
4. For **Startup type**, select **Disabled**, click **Apply**, and then click **OK** to close the window.
5. Close the **Services** window and the **Administrative Tools** window.

Set local security policy

1. Click **Start > Control Panel > Administrative Tools > Local Security Policy**.
2. Navigate to **Security Settings > Local Policies > Security Options**.
3. Double-click **Network Access: Sharing and security model for local accounts** listed in the right panel.
4. In the displayed dialog, select **Classical - local users authenticate as themselves** from the drop-down list.

Set region and language options

1. Click **Start > Control Panel > Regional and Language Options**.
2. From the **Formats** tab, **Format** list, select **English (United States)**, **Chinese (Simplified PRC)**, or **Japanese (Japan)**.
3. Click **OK** to close the window.

Set time zone

1. Click **Start > Control Panel > Date and Time > Change time zone**. Use the same time zone for server and clients.
2. From the **Date and Time** tab, click **Change time zone**.
3. Select your time zone from the **Time zone** list and click **OK**.
4. Click **OK** to close the window.
Enable .NET Framework 3.5

1. Click **Start > Control Panel > Programs and Features**.
2. Click **Turn Windows features on or off**.
3. Enable .Net 3.5 by selecting the **Microsoft .NET Framework 3.5** (includes .NET 2.0 and 3.0) check box.
   
   This option requires an Internet connection. If the computer has no Internet access, .NET Framework 3.5 will not install. For more details see http://support.microsoft.com/kb/2785188
4. To make sure that all the net.tcp components are properly initialized, non-http activation must be enabled. Expand the **.NET Framework 3.5** node and select **Windows Communication Foundation Non-HTTP Activation**.

Configure SQL Server Settings

If you plan to use a SQL server, complete these procedures before installing the OpenLAB Data Store software.

Change server authentication to mixed mode

1. Click **SQL Server Management Studio**.
2. In the **Object Explorer**, right-click the server name, and select **Properties** from the context menu.
3. In the **Server Properties** dialog, select the **Security** page.
4. Under **Server** authentication, select **SQL Server and Windows Authentication mode**.
5. Click **OK**.
6 Enable login for user *sa*.
   a In the **Object Explorer**, navigate to **Security > Logins**.
   b Right-click the user *sa*, and select **Properties** from the context menu.
   c In the **Login Properties** dialog, select the **General** page.
   d Provide a strong password.
   e Select the **Status** page.
   f Under **Login**, select **Enabled**.
   g Click **OK**.

7 Restart the **SQL Server** service, and log in with **SQL Server Authentication**.

**Disable the Reporting Services feature**

These services use port 80 and will conflict with the OpenLAB Data Store web server. See the SQL user information for details.
2  Configuration of Windows Server 2012 R2
3
Install the OpenLAB Data Store Server Software

Step 1: Start the Application  18
Step 2: Run the System Configuration Checker  18
Step 3: Prepare Third Party Tools  19
Step 4: Run OpenLAB Data Store Installer  20
Step 5: Tune the Java Virtual Machine (JVM)  24

The installation is automated for you by the included OpenLAB Master Installer. This tool installs the various components of OpenLAB Data Store.
Step 1: Start the Application

Insert the installation disk. Autorun.inf will automatically run Agilent.OpenLab.CDSInstaller.exe and display the OpenLAB Master Installer Planning screen. If the program does not start automatically, select setup.bat from the DVD.

Step 2: Run the System Configuration Checker

1. From the Planning screen, select System Configuration Checker.
2. From the Site Preparation Tool window, select Software list, select OpenLAB Data Store SQL Server A.02.02 or OpenLAB Data Store PostgreSQL Server A.02.02, depending on your installation type.
3. Select your operating system from the list.
4. Click OK.
5. Complete the Contact Information—System details by typing in the fields provided.
   - System Location fields
   - System Information fields
   - Configuration fields.
6. Click Go > Start to begin the software check. A summary report is displayed showing the results for each check category. Results are expressed as Pass, Warning, Critical Warning, or Fail.

   Fail results must be corrected before continuing with the installation. Agilent recommends investigating and correcting any Critical Warnings and Warnings whenever possible before proceeding.

7. To view details of the report, select the appropriate link: System Hardware Details or Operating System and Software Details.
8. Click Go > Save Report.
9. Click File > Exit, and Yes to close the Site Preparation Tool window.
10. Click Cancel to close the Site Preparation Tool window.
11. E-mail the saved report to your Agilent Service Representative for evaluation and validation of your personal computer for Agilent Software Systems Installs.
Step 3: Prepare Third Party Tools

The OpenLAB Master Installer offers a list of tools that can be installed directly from the Installation screen.

Install Adobe PDF Reader

1. From the Master Installer, select Installation and Third Party Tools, Adobe PDF Reader.
2. Follow the instructions in the Adobe Reader - Setup program to install.

Install Adobe Flash Player

1. From the Master Installer, select Installation and Third Party Tools, Adobe Flash Player.
2. Follow the instructions in the Adobe Flash Player Installer program to install.

Enable Adobe Flash Player

1. On the Windows Server 2012 desktop, locate and start the Server Manager.
2. Click Features.
3. Expand User Interfaces and Infrastructure, and select Desktop Experience.
4. Reboot the server.

Disable Auto-Update Notification in Flash Player

Adobe periodically updates the Flash Player with new features or security fixes, and notifies users with an installed Flash Player when an update is available. To disable the notification of updates:

1. Right-click on any Flash content, select Settings, Advanced, and click the Global Notifications Settings tab in the Flash Player Settings Manager.
2. Clear the Notify me when an update to Adobe Flash Player is available check box to stop receiving notifications.
3. Close the Settings Manager. The Flash Player automatically remembers the new settings.
Install the OpenLAB Data Store Server Software

Step 4: Run OpenLAB Data Store Installer

Record and store the selections that you use during this installation in a different physical location. The information is needed to restore your system in the unlikely case of your system becoming inoperable due to a hardware or software failure.

OpenLAB Master Installer

1. From the OpenLAB Master Installer, select Installation.
2. Select OpenLAB Data Store.

License Agreement Screen

1. Read the terms of the License Agreement. Master Installer provides a printable PDF of the license agreement under Resources.
2. Select I agree with the terms and conditions. You cannot proceed with the installation until you agree to these terms.
3. Click Next to proceed to the Installation Folder screen.

Installation folder screen

1. Type the folder name or browse to the folder where you want to store the application components. Folders must have English names.
2. To run an installation verification as part of this installation, select Run Software Verification. Because there is a separate installation procedure for each client computer in your system, you may prefer to run the Software Verification during the last installation, or after your system is completely installed (see “Run the Software Verification Tool” on page 40 for more information).
3. Click Next to proceed to the Installation type screen.

Installation type screens

1. Click Server.
2. Click Next to proceed to the Database Type Selection screen.
3. Select your database (PostgreSQL or Microsoft SQL).
4 For Select installation type, choose either New database server (PostgreSQL only) or Connect to existing database server (PostgreSQL that was installed by OpenLAB software or Microsoft SQL Server).

5 Use one of the procedures below according to your database installation.

To create and use a new PostgreSQL database server:
   a For Database Type Selection, select PostgreSQL.
   b For Selection installation type, select New database server.
   c Use the default Data file directory, or select a different location.
   d Click Next to proceed to the OpenLAB Shared Services Database screen.
   e Enter the Database name.
   f Select the authentication mode. If you select PostgreSQL server authentication, complete the username and password fields.

To use an existing OpenLAB installed PostgreSQL database server:
   a For Database Type Selection, select PostgreSQL.
   b For Select installation type, select Connect to existing database server.
   c Enter the Database server name.
   d Select Use default instance.
   e Click Next to proceed to the OpenLAB Shared Services Database screen.
   f Select Create new database or Connect to existing database.
   g Enter the Database name.
   h Select the authentication mode. If you select PostgreSQL server authentication, complete the username and password fields.
   i To verify the connection from this machine to the server, click Test Connection. The system displays a Connection succeeded message if the check is successful.

To use an existing Microsoft SQL Server:
   a For Database Type Selection, select Microsoft SQL Server.
   b Enter the Database server name.
   c Select Use default instance or Use named instance. If you select Use named instance, enter the Database instance name.
   d Click Next to proceed to the OpenLAB Shared Services Database screen.
   e Select Create new database or Connect to existing database.
f Enter the Database name.

g Select the authentication mode. If you select SQL authentication, complete the username and password fields.

h To verify the connection from this machine to the server, click Test Connection. The system displays a Connection succeeded message if the check is successful.

6 Click Next to proceed to the Additional Items screen.

7 In the Data Store Server Content files directory field, enter a suitable location to store the content files for OpenLAB Data Store or use the default content folder.

8 Under OpenLAB Shared Services Language, select the correct language from the list.

9 Click Next to proceed to the Summary screen.

## Summary screen

1 Review the installation activities. Click Back, as necessary, to change installation activities, or Cancel to cancel the installation.

2 Click Start to begin installation.

   The system performs an automated system check before it proceeds with the listed activities.

   If a system check passed, installation continues without a message.

   If a system check failed message appears, either:
   • Decline to view the system report, and continue installation.
   • View the system report, and decide to continue installation.
   • View the system report and postpone installation until the problem is fixed.
   • Decline to view the system report and postpone.

   If the installation of any vital application or component fails, the installation will roll back (uninstall). If a failed component can be installed at a later time without affecting basic installation, the installation will proceed. In this case, you will be notified of any failure, and that further steps are necessary to fully complete installation.

3 If an installation verification was completed as part of this installation, review the Software Verification Report.
If the report indicates failure, verify the computer requirements and reinstall the data system. Do not use the system until the Software Verification Report gives a pass result.

4 Click **Next** to proceed to the **Installed Features** screen.
5 Click **Finish** to close the installer.
6 Reboot the server after the installation.

**CAUTION**

Only apply Agilent provided service packs or Hotfixes to the OpenLAB PostgreSQL server.
Step 5: Tune the Java Virtual Machine (JVM)

1. From the **Data Store Server**, open an **Administrator: Command Prompt**.
2. Go to `C:\Program Files (x86)\Agilent Technologies\OpenLAB Data Store\tomcat\bin`.
3. From the command line, type: `tomcat6w.exe //ES//AlfrescoTomcat`.
4. From the **alfrescoTomcat properties** window, select the **Java** tab.
5. Under **Java Options**, update the `-Xmx` value based on your server memory as listed in Table 1. See the Agilent OpenLAB Data Store Hardware and Software Requirements guide for more information.
6. Click **OK**.
7. Reboot the server.

<table>
<thead>
<tr>
<th>Server memory GB</th>
<th>Memory setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>12</td>
<td>-Xmx4096m</td>
</tr>
<tr>
<td>16</td>
<td>-Xmx8192m</td>
</tr>
<tr>
<td>24</td>
<td>-Xmx12288m</td>
</tr>
<tr>
<td>32</td>
<td>-Xmx16384m</td>
</tr>
<tr>
<td>&gt; 32</td>
<td>Configure half of available memory</td>
</tr>
</tbody>
</table>
4

Configure OpenLAB Data Store

Configure OpenLAB Shared Services to use Data Store  26
Create Users       26
Install Your License 29
Configure OpenLAB Shared Services to use Data Store

During the installation, the OpenLAB Data Store server is automatically activated and configured using internal authentication with a default user, admin, and password, openlab.

1. Start the OpenLAB Control Panel shortcut on the desktop or go to Start > All Programs > Agilent Technologies > OpenLAB > OpenLAB Control Panel.

2. Log in with the user, admin, and password, openlab. On first login, the system requires the user to change this password before proceeding. You may now change the authentication mode, if required. See the Control Panel online help for more information.

Create Users

Use the OpenLAB Control Panel to manage the roles and privileges that affect Data Store users. You can create custom roles, or assign one or more of the predefined Data Store roles listed in Table 2, to give users varying degrees of Data Store access.

Table 2  Data Store predefined roles

<table>
<thead>
<tr>
<th>Privilege</th>
<th>Data Store Approver</th>
<th>Data Store Contributor</th>
<th>Data Store Reader</th>
<th>Archivist</th>
<th>System Administrator</th>
<th>Project Administrator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electronically sign files</td>
<td>X</td>
<td></td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Save or modify content</td>
<td>X</td>
<td>X</td>
<td></td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View content</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View projects</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Archive and de-archive content</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Modify system settings</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manage security</td>
<td></td>
<td></td>
<td></td>
<td>X</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Add users (Internal Authentication only)

1. From the navigation pane, click Administration > Users.
2. In the Users toolbar, click Create.
3. In the Create User dialog box enter a Name and Description for the user.
4. Select the General tab and enter a Password for the user. Confirm the password. Password length is set under Security policy.
5. Enter the users Full name, Email address, and Contact Information if desired. The full name is used in activity log entries and the welcome message at the lower right of the Control Panel.
6. Select password options:
   - To prevent the user from changing the assigned password, enable the User cannot change password.
   - To require the user to create a new password the next time they log on, enable the User must change password at next logon.
   - To allow the user to use the assigned password or change it at any time, disable both the User cannot change password and the User must change password at next logon.
   - To set the password to never expire, enable the Password never expires option.
7. To create a user profile, but prevent the user from logging onto the Control Panel, enable Account is disabled.
8. Click OK.

Import users (Windows Domain Authentication only)

To add users to your system, you must have privileges to obtain user and group information from the domain.

1. From the navigation pane, click Administration > Users.
2. In the Users toolbar, click Import.
3. In the Search Users dialog box, Enter search string for the Windows domain username.
4. From the Search Results list, select the user you want to import and click Add. The user is added to the Selected Users list.
5. Repeat steps 2 through 4 until you have added all the user names that you want to import to the Selected Users list, then click OK.
Add users to a role

1. From the navigation pane, click **Administration > Roles**.
2. In the **Roles** window, select the role you want to assign to users.
3. In the **Roles** toolbar, click **Edit**.
4. In the **Edit Role** dialog box, click the **Members** tab.
5. Click **Add user or group**.
6. In the **Search Users and Groups** dialog box, click **Search** to view a list of all users and groups.
7. Under **Search Results**, select a user or group, and click **Add**.
8. Click **OK**.
Install Your License

The license file contains your software license. This file is installed to the license server, the workstation computer, or the OpenLAB Shared Services Server where your product was installed. The license file is 'bound' to this server address, and cannot be moved to another server.

Information in the license file defines the number of instruments that may be used concurrently with your system.

Obtain your software license online

The most efficient way to manage and maintain your license is through the Internet, however if you lack an Internet connection, See “Obtain your software license offline” on page 30.

Gather the following information from the lavender envelope containing your Software Entitlement Certificate. If you have not received a lavender envelope, contact your vendor or internal support.

- The authorization code label
- The URL for SubscribeNet

Create a SubscribeNet account (New users only)

If you are a new user who has not registered with SubscribeNet, you must first create an account.

If you are already registered with SubscribeNet, skip to the section, Generate your License.

To create a new account

1. From any computer with Internet access, enter the SubscribeNet URL in an Internet browser.
2. At the bottom of the login page, click on click HERE to register.
3. On the registration page, enter the authorization code from the label and complete the profile information. The email address you enter will be your login ID.
4 Click **Submit**. An account name is generated and displayed. The system will also send an email message with the following information:

- Account name
- Login ID
- Password
- A link to access your license pool at the SubscribeNet site

**Generate your License**

1. From your Data Store server, use the link to open the SubscribeNet site.
2. Log into SubscribeNet using your login ID and password.
3. Select the SubscribeNet account associated with this authorization code, if you have more than one account.
4. Click **Generate licenses** from the left navigation bar and follow the prompts to generate your new license.

   - The computer **HOST NAME** you enter must match the network name of the computer where the OpenLAB Control Panel is running. Do not include any DNS suffix (domain.com) references in the entered machine name. If the computer name or domain are changed after the license is installed, this license must be removed and a new license must be created in SubscribeNet, downloaded, and installed.

   - The MAC address is that of the shared services server. To retrieve your MAC address, see the Control Panel online help topic, **Manage license server> To copy MAC address**. If the network adapter that provides the MAC address used during license creation is removed from the machine, your license will no longer be valid. A new license will need to be generated with a currently available MAC on the license server.

5. When the system generates the license, click **Download License File** and save the license file to your computer, and to a backup location (such as a portable storage device).

**Obtain your software license offline**

If you lack an Internet connection, you or your local on-site service engineer can collect the necessary information from you to allow Agilent to create a license account on your behalf.
To obtain your software license offline

1 Collect the required Customer Information
   * Company Name
   * Lab/Department Name
   * First Name
   * Last Name
   * E-mail address
   * Job Title
   * Phone number
   * Address, City, State/Province, Postal Code, Country
   * The authorization code label provided in the lavender envelope containing your Software Entitlement Certificate.

2 Contact your local Agilent sales and service center. Once the required information is provided, Agilent will work on your behalf to generate a license file through SubscribeNet. The license file will either be sent to your shipping address on a CD, or delivered by your local FSE on a USB-stick.

Add your license to the OpenLAB Control Panel

For your system to be fully operational, you must add your license to the OpenLAB Control Panel.

To add a license

1 Start the OpenLAB Control Panel from any machine connected to the Data Store server.
2 From the navigation pane, click Administration > Licenses.
3 In the Licensing toolbar, click Add.
4 In the Add Licenses dialog box.
5 Click Browse.
6 In the Open dialog box, navigate to and select the license file (on CD, USB, or network folder).
7 Click Open.
Configure OpenLAB Data Store
5
Install the OpenLAB Data Store Client Software

Step 1: Prepare Third Party Tools  34
Step 2: Run the OpenLAB Data Store Installer  36

Use these procedures to install the software to any number of clients connected to the server.
Step 1: Prepare Third Party Tools

The OpenLAB Master Installer offers a list of tools that can be installed directly from the Installation screen.

Install Adobe PDF Reader

1. From the Master Installer, select Installation and Third Party Tools, Adobe PDF Reader.
2. Follow the instructions in the Adobe Reader - Setup program to install.

Install Adobe Flash Player

1. From the Master Installer, select Installation and Third Party Tools, Adobe Flash Player.
2. Follow the instructions in the Adobe Flash Player Installer program to install.

Enable Adobe Flash Player

1. On the Windows Server 2012 desktop, locate and start the Server Manager.
2. Click Features.
3. Expand User Interfaces and Infrastructure, and select Desktop Experience.
4. Reboot the server.

Disable auto-update notification in Flash Player

Adobe periodically updates the Flash Player with new features or security fixes, and notifies users with an installed Flash Player when an update is available. To disable the notification of updates:

1. Right-click on any Flash content, select Settings, Advanced, and click the Global Notifications Settings tab in the Flash Player Settings Manager.
2. Clear the Notify me when an update to Adobe Flash Player is available check box to stop receiving notifications.
3. Close the Settings Manager. The Flash Player automatically remembers the new settings.
Disable compatibility view in Internet Explorer

When Compatibility View is turned on, the website you are viewing will be displayed as if you were using an earlier version of Internet Explorer. To disable Compatibility View on your workstations:

1. Open Internet Explorer.
2. Click the Tools menu, and then click Compatibility View Settings.
3. Clear the Display intranet sites in Compatibility View check box.
Step 2: Run the OpenLAB Data Store Installer

1. Insert the installation disk. Autorun.inf will automatically run Agilent.OpenLab.CDSInstaller.exe and display the installer Planning screen. If the program does not start automatically, select setup.bat from the DVD.

2. From the OpenLAB Master Installer screen, click Installation.

3. Select OpenLAB Data Store. The OpenLAB Installation Wizard opens.

License Agreement Screen

1. Read the terms of the License Agreement. Master Installer provides a printable PDF of the license agreement under the Resources option of the main menu.

2. Select I agree with the terms and conditions. You cannot proceed with installation until you agree to the terms.

3. Click Next to proceed to the Installation Folder screen.

Installation folder screen

1. Type the folder name or browse to the folder where you want to store the application components.

2. To run an installation verification as part of this installation, click Run Software Verification. The Software Verification Tool provides documentary evidence that your system has been built and installed correctly. You can run the Software Verification Tool at a later time if you prefer. See “Run the Software Verification Tool” on page 40.

3. Click Next to proceed to the Installation type screen.

Installation type screens

1. Click Client.

2. Enter or browse to a location to store files while they are waiting to be uploaded.

3. Click Next.

4. For OpenLAB Shared Services Settings for Registration, enter the Server name.
5 Choose your **Authentication Service Provider** from the list.

6 Enter the **User Credentials**.

7 To verify the connection from this machine to the server, click **Test Connection**. The system displays a Connection succeeded message if the check is successful.

8 Click **Next** to proceed to the **Summary** screen.

**Summary screen**

1 Review the installation activities that you have selected in the preceding steps. Click **Back**, as necessary, to change installation activities, or **Cancel** to cancel the installation.

2 Click **Start** to begin installation.

3 If an installation verification was completed as part of this installation, review the Software Verification Report. If the report indicates **failure**, verify the computer requirements and reinstall the data system. Do not use the system until the Software Verification Report gives a **pass** result.

4 Click **Next** to proceed to the **Installed Features** screen.

5 Click **Finish** to close the installer.
Install the OpenLAB Data Store Client Software
6
Run an Installation Verification after Software Installation

About the Software Verification Tool 40
Run the Software Verification Tool 40

The Software Verification Tool provides documentary evidence that your system has been built and installed correctly, and that all design specifications have been met.
Run an Installation Verification after Software Installation

About the Software Verification Tool

Because there is a separate installation procedure for each client computer in your system, you may choose to run the Software Verification Tool during installation or sometime after your system is completely installed.

Use this procedure if your system is completely installed and you want to verify that your system has been built and installed correctly, and that all design specifications have been met.

Run the Software Verification Tool

1. Using your Windows operating system, go to Start > All Programs > Agilent Technologies > Software Verification Tool.

2. Click Qualify. The system will run the application and generate a Software Verification Report. If the report indicates failure, verify the computer requirements and reinstall the data system. Do not use the system until the Software Verification Report gives a pass result.
The upgrade software installs the various components of OpenLAB Data Store and is automated for you by the OpenLAB Master Installer. 

- If using Data Store A.01.01, upgrade to version A.01.02 before upgrading to version A.02.02.

- If using Data Store A.01.03, upgrade to version A.02.01 before upgrading to version A.02.02.

OpenLAB Data Store A.02.01 and later do not support:

- Windows local authentication
  If you are upgrading from an OpenLAB Data Store version configured with Windows local authentication, you must reconfigure your server to use internal or Windows domain authentication before beginning the upgrade.

- Lab Applications
  If you are upgrading from an OpenLAB Data Store version with Lab Applications, these features will not be retained after upgrading with OpenLAB Data Store A.02.02.
Upgrade the OpenLAB Data Store Software

1. Insert the installation DVD. `Autorun.inf` will automatically run `Agilent.OpenLab.CDSInstaller.exe` and display the installer Planning screen. If the program does not start automatically, select `setup.bat` from the DVD.

2. From the OpenLAB Data Store Installer, click Installation.

3. Select OpenLAB Data Store. The OpenLAB Data Store Upgrade Wizard opens.

4. In the License Agreement screen, read the terms of the License Agreement. Master Installer provides a printable PDF of the license agreement under Resources.

5. Select I agree with the terms and conditions. You cannot proceed with the installation until you agree to these terms.

6. Click Next to proceed to the Upgrade Type screen.

7. In the Upgrade Type screen, verify the Server name and Authentication Service Provider that is detected by the installer for your current configuration. If you are upgrading from an OpenLAB Data Store version configured with local Windows authentication, you must cancel this installation and reconfigure your server to use internal or Windows domain authentication before attempting to upgrade.

8. Enter the User Credentials for the server administrator that was specified in the original installation.

9. To verify the connection from this machine to the server, click Test Connection. The system displays a Connection succeeded message if the check is successful.

10. Click Next the Additional Items window appears.

11. Click Next to proceed to the Summary screen.

12. In the Summary screen, review the upgrade activities. Click Back as necessary to change activities, or Cancel to cancel the installation.
13 Click **Start** to begin the upgrade.  
The system performs an automated system check before it proceeds with the listed activities.  
If a **system check passed**, installation continues without a message.  
If a **system check failed** message appears, either:  
- Decline to view the system report, and continue installation.  
- View the system report, and decide to continue installation.  
- View the system report and postpone installation until the problem is fixed.  
- Decline to view the system report and postpone.  
If the **Status**, reads **Successfully upgraded**, the upgrade continues.  
If the **Status**, reads **Error occurred** for a vital application or component, the installation will roll back (uninstall).  
If the **Status**, reads **Error occurred**, for a component that can be installed at a later time without affecting basic installation, the installation will proceed.  
In this case, you will be notified of any failure, and that further steps are necessary to fully complete installation.  
14 An installation verification is completed as part of this upgrade. Review the Software Verification Report. If the report indicates **failure**, verify the requirements and reinstall the data system. Do not use the system until the Software Verification Report gives a **pass** result.  
15 Click **Finish** to close the installer.  
16 Reboot the server after the installation.

**Upgrade the OpenLAB Data Store Client Software**

If you are using Data Store with another OpenLAB application, upgrade the client software from the installation disk from your specific OpenLAB application.
7 Upgrade the OpenLAB Data Store Software
8

Uninstall the Software

About Uninstallation  46
Run the OpenLAB Uninstallation Wizard  46

This chapter contains information on the uninstallation by using the OpenLAB Uninstallation Wizard.
About Uninstallation

The uninstallation of OpenLAB Data Store is automated by the OpenLAB Master Installer.

To uninstall OpenLAB Data Store, you need to have administrator privileges for all servers and clients. Power user privileges are not sufficient (the uninstallation does not start).

If you plan to reinstall OpenLAB Data Store, do not remove PostgreSQL/MSSQL; keep the database intact. Upon re-installation, select the existing server and OpenLAB Shared Services database and content directory as the previously installed version of Data Store.

Run the OpenLAB Uninstallation Wizard

1. Insert the installation disk.
2. From the Master Installer Planning screen, select Maintenance from the side bar menu.
3. Select OpenLAB Uninstallation. The OpenLAB Uninstallation Wizard opens.
4. Click Start to start the uninstallation.
   All listed components are automatically uninstalled.

When a component is uninstalled correctly, the status shown in the Status field of the Maintenance screen changes from Installed to Uninstalled successfully.

If you want to abort the uninstallation, click Cancel.

5. When the uninstallation has finished, click Finish to close the Uninstallation Wizard.

6. Reboot the system to complete the installation.