OpenLAB CDS
ChemStation Edition

Workstation Installation and Configuration Guide
Warranty
The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses
The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend
If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Safety Notices
A CAUTION notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met.

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.
This installation guide provides instructions to install and configure the Agilent OpenLAB Chromatography Data System (CDS) workstations.

**Table 1  Terms and abbreviations used in this document**

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDS</td>
<td>Chromatography Data System</td>
</tr>
<tr>
<td>ChemStation</td>
<td>OpenLAB CDS ChemStation Edition</td>
</tr>
<tr>
<td>Secure Workstation</td>
<td>Secure Workstation for OpenLAB CDS ChemStation Edition</td>
</tr>
<tr>
<td>Data Store</td>
<td>OpenLAB Data Store; as of rev. 2.1, the product name is OpenLAB Server</td>
</tr>
<tr>
<td>OpenLAB Server</td>
<td>New product name, formerly known as OpenLAB Data Store.</td>
</tr>
<tr>
<td>Content Management</td>
<td>Data storage component provided as part of OpenLAB Server</td>
</tr>
<tr>
<td>ECM</td>
<td>OpenLAB Enterprise Content Manager</td>
</tr>
<tr>
<td>AIC</td>
<td>Agilent Instrument Controller</td>
</tr>
<tr>
<td>Control Panel</td>
<td>OpenLAB Control Panel</td>
</tr>
<tr>
<td>Microsoft Control Panel</td>
<td>Part of the Microsoft Windows operating system</td>
</tr>
<tr>
<td>Shared Services</td>
<td>Set of components and services for licensing, users and roles, instrument configuration, security policy and more. Installed on all computers; accessed via the OpenLAB Control Panel.</td>
</tr>
<tr>
<td>OpenLAB CDS Shared Services Server</td>
<td>Server running the Shared Services. Formerly known as OpenLAB Shared Services Server.</td>
</tr>
</tbody>
</table>
In this Guide ...

1 Introduction
This chapter gives you an overview of the OpenLAB CDS ChemStation Edition software. It also includes certain requirements before starting the installation.

2 Configure your Workstation PC
Agilent-delivered PC Bundle systems are delivered with the supported pre-installed Windows operating system and are configured for optimum performance. Non-Agilent PC Bundle systems require some manual configuration changes in order to provide optimum performance. This chapter describes how to configure a non-Agilent PC Bundle system.

3 Install the Software
The installation is automated by the OpenLAB CDS Master Installer. This tool installs the various components of OpenLAB CDS.

4 Post Installation Tasks
This chapter describes tasks that are relevant after finishing the installation.

5 Optional Procedures
This chapter contains information on the Additional Drivers and Software wizard, on the Software Verification Tool, and other helpful procedures.

6 Licensing
This chapter contains information on how to obtain and install a license.

7 Configure OpenLAB CDS in the Control Panel
This chapter describes the initial configuration steps after installing the software. Refer to the online help for more information.
8 Upgrade ChemStation Edition to Latest Version

This chapter describes the upgrade from ChemStation C.01.0x. If you upgrade from an older ChemStation revision (A.0x or B.0x) please refer to the Upgrade Preparation guide.

9 Uninstall the Software

This chapter contains information on the uninstallation by using the OpenLAB CDS Uninstallation Wizard. It also describes post uninstallation tasks that are essential if you plan to reinstall ChemStation on the same computer.
1 Introduction 9
   Who Should Read This Guide? 10
   The Agilent OpenLAB CDS Software 11

2 Configure your Workstation PC 13
   About Configuration 14
   Installing Windows 15
   Windows Configuration Check for OpenLAB CDS ChemStation Edition 16
   Configuring Windows 7 17
   Configuring Windows 8.1 22
   Configuring Windows 10 27
   Editing the Security Settings for LC/MS and CE/MS Systems 32

3 Install the Software 35
   Before You Begin 36
   Step 1: Prepare for Installation 39
   Step 2: Install Third Party Tools 39
   Step 3: Copy Installation files to a Centralized Folder for Installation (Optional) 41
   Step 4: Run the System Configuration Checker 42
   Step 5: Run the OpenLAB CDS Installation Wizard 43
   What to do Next 46
   Scripted Installation 47

4 Post Installation Tasks 53
   Configure the Antivirus Program 54
   Set Required Windows User Privileges 56
Contents

5 Optional Procedures  57
   Install Additional Software and Drivers  58
   Run a Software Verification after Software Installation  59
   Transform a Workstation to a Networked Workstation  60
   Improve Performance on Offline Machines  62
   Protect ChemStation Folders with Secure File I/O  63
   Change the PC Name  64

6 Licensing  69
   About OpenLAB CDS Licensing  70
   Get a License  72
   Install Your License  76

7 Configure OpenLAB CDS in the Control Panel  77
   Configure Authentication  78
   Configure Security Policy  80
   Configure Users/Groups/Roles  80
   Install your License  84
   Configure Instruments  85

8 Upgrade ChemStation Edition to Latest Version  87
   Planning the Upgrade of a ChemStation C.01.0x  88
   Upgrade ChemStation to C.01.07 SR3  89
   License Upgrade  90
   Run the Upgrade Wizard  93

9 Uninstall the Software  95
   About Uninstallation  96
   Run the Master Installer  96
   Run the OpenLAB CDS Uninstallation Wizard  97

10 Appendix  99
   Sales and Support Assistance  100
1 Introduction

Who Should Read This Guide? 10
The Agilent OpenLAB CDS Software 11

This chapter gives you an overview of the OpenLAB CDS ChemStation Edition software. It also includes certain requirements before starting the installation.
Introduction

Who Should Read This Guide?

This installation guide is designed to help system administrators and other users install the Agilent OpenLAB Chromatography Data System (CDS) to individual workstations quickly and correctly.

Figure 1  OpenLAB CDS ChemStation Edition Workstation
The Agilent OpenLAB CDS Software

The Agilent OpenLAB CDS, along with OpenLAB Enterprise Content Manager (ECM) and OpenLAB Data Store plus several add-ons make up the Agilent OpenLAB software suite.

The Agilent OpenLAB CDS software suite is designed to grow with customers' needs, from a small standalone analytical lab to a global network with hundreds of locations. Using the OpenLAB software, instruments from multiple vendors can connect to any size network – from individual workstations and workgroups to global enterprises. With full instrument control, centralized administration and ease-of-support, users can achieve lower operational costs and better instrument use. See your Agilent representative to learn how other products in the OpenLAB suite can help you.

The Agilent OpenLAB CDS software is provided on read-only USB media that contain all required installables and documents.
1 Introduction
The Agilent OpenLAB CDS Software
2 Configure your Workstation PC

About Configuration 14
Installing Windows 15
Windows Configuration Check for OpenLAB CDS ChemStation Edition 16
Configuring Windows 7 17
Configuring Windows 8.1 22
Configuring Windows 10 27
Editing the Security Settings for LC/MS and CE/MS Systems 32
   Firewall 32
   Advanced Network Settings 33

Agilent-delivered PC Bundle systems are delivered with the supported pre-installed Windows operating system and are configured for optimum performance. Non-Agilent PC Bundle systems require some manual configuration changes in order to provide optimum performance. This chapter describes how to configure a non-Agilent PC Bundle system.
Some changes within this document are mandatory for OpenLAB CDS ChemStation Edition to work properly on a Windows system. Some changes will optimize application performance. Other changes will have a graphical or minor impact.

**NOTE**

To indicate the relative importance of individual settings, each item is categorized as:

- **MUST**: These changes must be applied.
- **PERFORMANCE**: These changes will improve system performance.
- **OPTIONAL**: Most of these changes will affect the graphical display of the application.

**NOTE**

If User Account Control (UAC) is switched on, some configuration steps will require active confirmation to continue.
Installing Windows

NOTE
Keep your PC disconnected from the internet until you have installed the appropriate security patches and hot fixes. Install the latest security fixes as supported from Agilent Technologies and virus definitions prior to connecting to a network.

1. Install Windows from the Microsoft installation media. During the setup, provide the computer name, administrator password and network settings. Choose to either join an existing domain or set up the system in a workgroup mode.

2. To secure your system against viruses please install an antivirus program. Be sure to open the firewall ports listed in the Firewall Settings in the OpenLAB CDS ChemStation Edition Requirements guide.

NOTE
Running antivirus programs might influence the behavior and performance of your computer. Some virus scanners might cause issues when used with OpenLAB CDS. The application is tested with Symantec Endpoint Protection 12.x and with Microsoft Security Essentials.
Windows Configuration Check for OpenLAB CDS ChemStation Edition

The OpenLAB CDS Configuration Checker helps to troubleshoot the Operating System configuration and to prevent computer problems. It checks and repairs all mandatory settings. It does not check optional settings or settings that improve the performance.

The OpenLAB CDS Configuration Checker comes as .diagcab file, which is a file format used with the Microsoft Windows Troubleshooting Platform (WTP) program. The Microsoft Windows Troubleshooting Platform (WTP) is a platform to locate and fix hardware and software settings in Windows. It is used specifically for diagnosing and repairing computer settings.

In general, .diagcab files are useful for deploying troubleshooting packs because they are self-contained and require no installation. They can be deployed onto web sites, network shares, or copied to USB keys. The .diagcab file name extension is a registered file name extension that can be executed by WTP.

To start the OpenLAB CDS Configuration Checker, call the file Agilent.Wtp.ChemStation.WindowsConfiguration.diagcab. This file is located in Disk6\Tools\OpenLAB CDS ChemStation Edition\Diagnostics\WindowsConfiguration\Cab\n
**NOTE**

While using the Configuration Checker:

- Ensure that this computer is not turned off by another user.

- Win 7: Ensure that the menu bar is enabled (click Organize > Layout and select Menu bar).
Configuring Windows 7

Configure Windows as described in the following steps. Alternatively, run the OpenLAB CDS Configuration Checker (see “Windows Configuration Check for OpenLAB CDS ChemStation Edition” on page 16).

[MUST] 1 System (Microsoft Control Panel): Register Windows with Microsoft.

[MUST] 2 Folder Options (Microsoft Control Panel): In the View tab,
   - Select Always show menus.
   - Select Display the full path in the title bar.
   - Clear Hide extensions for known file types.
   - Clear Use Sharing Wizard.

[MUST] 3 Windows Update (Microsoft Control Panel):
   a Click Check for updates to check for updates and apply all critical security patches.
   b Click Change settings. In the Important updates section, select Never check for updates. Clear the other update options.

This setting is important to avoid data loss due to system reboot during data acquisition.

   a Double-click Services.
   b Double-click the following services and set their startup type to Disabled:
      - Application Experience
      - Desktop Window Manager Session Manager

[MUST] 5 Administrative Tools (Microsoft Control Panel): Configure security options:
   a Double-click Local Security Policy.
   b Navigate to Security Settings > Local Policies > Security Options
   c Double-click the following policy listed in the right hand panel: Network Access: Sharing and security model for local accounts
   d In the displayed dialog select the following item from the drop-down list: Classic - local users authenticate as themselves

1 View the items by icon to see a list of all items.
Configure your Workstation PC

Configuring Windows 7

[MUST] 6 Indexing Options (Microsoft Control Panel): Disable indexing.
Click the Modify button. Clear all drives and locations.

[MUST] 7 Power Options (Microsoft Control Panel):
  a As preferred plan select High performance
  b Click Change Plan settings
  c Set the option Put the computer to sleep to Never.
  d Click Change advanced power settings.
  e Open the nodes for Hard disk > Turn off hard disk after.
  f Set the Minutes to 0 (=Never).

[MUST] 8 Region and Language (Go to Control Panel > Region and Language).
  a Regional options should be set to English (United States) from the drop-down list.
  b If regional format other than English (United States) is used, the following settings are mandatory. The settings can be defined by clicking on the Additional settings... button:
     * Decimal symbol = . (point)
     * Digit grouping symbol = , (comma)
     * List separator = , (comma)

[MUST] 9 Date and Time (Microsoft Control Panel): Choose the time zone of your machine's location.

[MUST] 10 Network and Sharing Center (Microsoft Control Panel):
  a Select Change adapter settings. Right-click Local Area Connection > Properties > Configure.
  b On the Power Management tab, clear all check boxes.

[MUST] 11 Programs and Features (Microsoft Control Panel): Enable non-http activation.
  a Click Turn Windows features on or off.
  b Expand the Microsoft .NET Framework 3.5.1 node and select the Windows Communication Foundation Non-HTTP Activation check box.
  c Select the Internet Explorer 11 check box.
  d Select the Telnet Client check box.
  e Select the TFTP Client check box.
  f Reboot the PC.
Configure your Workstation PC

Configuring Windows 7

[MUST] 12 Windows logon options (Start > search for ‘gpedit.msc’)
   b. Set Hide entry points for Fast User Switching and Always use classic logon to Enabled.

[MUST] 13 Disable Compatibility View in Internet Explorer.
   a. Open Internet Explorer.
   b. Click the Tools menu, and then click Compatibility View Settings.
   c. Clear the Display intranet sites in Compatibility View check box.

[MUST] 14 Enable the navigation pane:
   Open Windows Explorer, then select Organize > Navigation pane and make sure that Navigation pane is selected.

[PERFORMANCE] 15 System (Microsoft Control Panel): Change performance options:
   a. Click Advanced system settings.
   b. On the Advanced tab > Performance click Settings.
   d. Under Custom, select the following check boxes for better usability:
      - Smooth edges of screen fonts
      - Show shadows under mouse pointer
      - Show shadows under windows

NOTE This step is only required if you use OpenLAB Content Management (formerly known as OpenLAB Data Store).
Configure your Workstation PC
Configuring Windows 7

[PERFORMANCE] 16 System (Microsoft Control Panel): Change system properties:

   a  Click Advanced system settings.

   b  On the Advanced tab > Performance click Settings.

      • Advanced tab > Virtual Memory: For optimum performance use the Change button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible locate the paging file on a drive different from the system installation drive.

      • Data Execution Prevention tab: Select Turn on DEP for essential Windows programs and services only.

   c  Advanced > Startup and Recovery > Settings button:

      • System startup section:
         Change both Time to display ... fields from 30 to 3 sec.

      • System failure section:
         Select Automatically restart, in the Write debugging information section select Kernel memory dump from the drop-down list.

   d  System Protection tab

      Make sure that Protection is turned off. If required, click Configure and select Disable system protection.

   e  Remote tab

      • In the Remote Assistance section, clear the check box Allow Remote Assistance connections to this computer.

      • In the Remote Desktop section, select Don’t allow connections to this computer.

[OPTIONAL] 17 General Layout: (right-click Start > Properties)

   a  Start Menu Tab: In the Privacy section select both items

   b  Start Menu Tab > Customize button: In Customize Start Menu dialog:

      • Clear the following option:

         • Favorites menu

      • Select the following options:

         • Computer Display as a link

         • Connect To

         • Control Panel: Display as a menu

         • Default Programs
Configure your Workstation PC

Configuring Windows 7

- Devices and Printers
  - Documents: Display as a link
  - Enable context menus and dragging and dropping
- Games: Don't display this item
- Help
- Highlight newly installed programs
- Music: Don't display this item
- Network
  - Open submenus when I pause on them with the mouse pointer
  - Personal folder: Display as a link
- Pictures: Display as a link
- Run command
  - Search other files and libraries Search with public folders
- Search programs and Control Panel
- Sort All Programs menu by name
  - System administrative tools: Display on the All Programs menu and in the Start menu
  - Use large icons

[OPTIONAL] 18 Welcome Center (Start > search for ‘gpedit.msc’):
  b. Set Don't display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 19 Recycle Bin Properties: (right-click on desktop icon Recycle Bin) Select the following options:
  - Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
  - Select Display delete confirmation dialog.

Repeat these steps for all drives of your computer.

[OPTIONAL] 20 Region and Language (Microsoft Control Panel): Language for non-Unicode programs: On the Administrative tab, click Change system locale.... From the drop down list, select English (United States)

NOTE Do not change the system locale if you are using an English, Japanese or Chinese Operating System.
Configure your Workstation PC

Configuring Windows 8.1

[MUST] 1 System (Microsoft Control Panel): Register Windows with Microsoft.

[MUST] 2 Folder Options (Microsoft Control Panel): In the View tab,
   - Select Always show menus.
   - Select Display the full path in the title bar.
   - Clear Hide extensions for known file types.
   - Clear Use Sharing Wizard.

[MUST] 3 Windows Update (Microsoft Control Panel):
   a Click Check for updates to check for updates and apply all critical security patches.
   b Click Change settings. In the Important updates section, select Never check for updates. Clear the other update options.

   NOTE
   This setting is important to avoid data loss due to system reboot during data acquisition.

[MUST] 4 Disable Services (Microsoft Control Panel):
   a Double-click Services.
   b Double-click the Application Experience service. Set the startup type to Disabled.

[MUST] 5 Indexing Options (Microsoft Control Panel): Disable indexing.
   Click the Modify button. Clear all drives and locations.

1 View the items by icon to see a list of all items.
Configure your Workstation PC
Configuring Windows 8.1

[MUST] 6 Power Options (Microsoft Control Panel):
   a As preferred plan select High performance
   b Click Change Plan settings
   c Set the option Put the computer to sleep to Never.
   d Click Change advanced power settings.
   e Open the nodes for Hard disk > Turn off hard disk after.
   f Set the Minutes to 0 (=Never).

[MUST] 7 Administrative Tools (Microsoft Control Panel): Configure security options:
   a Double-click Local Security Policy.
   b Navigate to Security Settings > Local Policies > Security Options
   c Double-click the following policy listed in the right hand panel: Network Access: Sharing and security model for local accounts
   d In the displayed dialog select the following item from the drop-down list: Classic - local users authenticate as themselves

[MUST] 8 Region (Microsoft Control Panel):
   a Regional options should be set to English (United States) from the drop-down list.
   b If regional format other than English (United States) is used, the following settings are mandatory. The settings can be defined by clicking on the Additional settings... button:
      - Decimal symbol = . (point)
      - Digit grouping symbol = , (comma)
      - List separator =, (comma)

[MUST] 9 Date and Time (Microsoft Control Panel): Choose the time zone of your machine's location.

[MUST] 10 Network and Sharing Center (Microsoft Control Panel):
   a Select Change adapter settings. Right-click Local Area Connection > Properties > Configure.
   b On the Power Management tab, clear all check boxes.
Configure your Workstation PC
Configuring Windows 8.1

[MUST] 11 Programs and Features (Microsoft Control Panel): Edit .NET settings:

a  Click Turn Windows features on or off.

b  Enable .NET 3.5 by selecting the .NET Framework 3.5 (includes .NET 2.0 and 3.0) check box.

This option requires an internet connection.

[MUST] 12 Disable Compatibility View in Internet Explorer.

a  Open Internet Explorer.

b  Click the Tools menu, and then click Compatibility View Settings.

c  Clear the Display intranet sites in Compatibility View check box.

[MUST] 13 Windows logon options (Start > search for 'gpedit.msc')

a  Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.

b  Set Hide entry points for Fast User Switching and Always use classic logon to Enabled.

[MUST] 14 Enable the navigation pane:

Open Windows Explorer, then select View > Navigation pane from the ribbon and make sure that Navigation pane is selected.

NOTE If the computer has no internet access, .NET Framework 3.5 will not install. For more details see http://support.microsoft.com/kb/2785188.

NOTE This step is only required if you use OpenLAB Content Management (formerly known as OpenLAB Data Store).
[PERFORMANCE] 15 System (Microsoft Control Panel): Change performance options:
   a  Click Advanced system settings.
   b  On the Advanced tab > Performance click Settings.
   d  Under Custom, select the following check boxes for better usability:
      • Smooth edges of screen fonts
      • Show shadows under mouse pointer
      • Show shadows under windows

[PERFORMANCE] 16 System (Microsoft Control Panel): Change system properties:
   a  Click Advanced system settings.
   b  On the Advanced tab > Performance click Settings.
      • Advanced tab > Virtual Memory: For optimum performance use the
        Change button to adjust the paging file size to a value of 2 to 3 times of
        the physical RAM on the PC. If possible locate the paging file on a
        drive different from the system installation drive.
      • Data Execution Prevention tab: Select Turn on DEP for essential Windows
        programs and services only.
   c  Advanced > Startup and Recovery > Settings button:
      • System startup section:
        Change both Time to display ... fields from 30 to 3 sec.
      • System failure section:
        Select Automatically restart, in the Write debugging information section
        select Kernel memory dump from the drop-down list.
   d  System Protection tab
      Make sure that Protection is turned off. If required, click Configure and
      select Disable system protection.
   e  Remote tab
      • In the Remote Assistance section, clear the check box Allow Remote
        Assistance connections to this computer.
      • In the Remote Desktop section, select Don't allow connections to this
        computer.
2 Configure your Workstation PC
Configuring Windows 8.1

[OPTIONAL] 17 Welcome Center (Start > search for ‘gpedit.msc’):
   a  Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.
   b  Set Don’t display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 18 Recycle Bin Properties: (right-click on desktop icon Recycle Bin) Select the following options:
   - Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
   - Select Display delete confirmation dialog.
   Repeat these steps for all drives of your computer.

[OPTIONAL] 19 Region and Language (Microsoft Control Panel): Language for non-Unicode programs: On the Administrative tab, click Change system locale.... From the drop down list, select English (United States)

NOTE: Do not change the system locale if you are using an English, Japanese or Chinese Operating System.
Configure Windows 10

Configure Windows as described in the following steps. Alternatively, run the OpenLAB CDS Configuration Checker (see “Windows Configuration Check for OpenLAB CDS ChemStation Edition” on page 16).

**[MUST]** 1 **System** (Microsoft Control Panel): Register Windows with Microsoft.

**[MUST]** 2 **Folder Options** (Microsoft Control Panel): In the View tab,
   - Select *Always show menus*.
   - Select *Display the full path in the title bar*.
   - Clear *Hide extensions for known file types*.
   - Clear *Use Sharing Wizard*.

**[MUST]** 3 **Update and Security** (Windows Settings):
   a. Click **Check for updates** to check for updates and apply all critical security patches.
   b. Click **Advanced options**.
   c. Enable **Defers Upgrades**.
   d. Click **Choose how updates are delivered**.
   e. Turn off **Updates from more than one place**.

**[MUST]** 4 Settings for updates: **Windows Update** service MUST NOT be running during installation.

**[MUST]** 5 **Indexing Options** (Microsoft Control Panel): Disable indexing.
   Click the Modify button. Clear all drives and locations.

**[MUST]** 6 Windows logon options (*Start > search for ’gpedit.msc’*)
   a. Navigate to **Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon**.
   b. Set **Hide entry points for Fast User Switching** and **Always use classic logon** to **Enabled**.

1 View the items by icon to see a list of all items.
2  Configure your Workstation PC
   Configuring Windows 10

[MUST] 7 System > Tablet Mode (Microsoft Control Panel): Turn off Tablet Mode and select Remember what I used last.

[MUST] 8 Power Options (Microsoft Control Panel):
   a  As preferred plan select High performance
   b  Click Change Plan settings
   c  Set the option Put the computer to sleep to Never.
   d  Click Change advanced power settings.
   e  Open the nodes for Hard disk > Turn off hard disk after.
   f  Set the Minutes to 0 (=Never).

[MUST] 9 System > Offline Maps (Microsoft Control Panel): Turn Metered connections and Map updates off.

[MUST] 10 Administrative Tools (Microsoft Control Panel): Configure security options:
   a  Double-click Local Security Policy.
   b  Navigate to Security Settings > Local Policies > Security Options
   c  Double-click the following policy listed in the right hand panel: Network Access: Sharing and security model for local accounts
   d  In the displayed dialog select the following item from the drop-down list: Classic - local users authenticate as themselves

[MUST] 11 System and Security (Microsoft Control Panel):
   a  Click Change Windows SmartScreen settings.
      Select Don’t do anything (turn off Windows SmartScreen).

[MUST] 12 Date and Time (Microsoft Control Panel): Choose the time zone of your machine's location.

[MUST] 13 Network and Sharing Center (Microsoft Control Panel):
   a  Select Change adapter settings. Right-click Local Area Connection > Properties > Configure.
   b  On the Power Management tab, clear all check boxes.
[MUST] 14 Programs and Features (Microsoft Control Panel):
   a  Click **Turn Windows features on or off**.
   b  Enable .NET 3.5 by selecting the **.NET Framework 3.5 (includes .NET 2.0 and 3.0)** check box.
      This option requires an internet connection.
   c  To make sure that all the net.tcp components are properly initialized, non-http activation must be enabled. Expand the **.NET Framework 3.5 (includes .NET 2.0 and 3.0)** node and select the **Windows Communication Foundation Non-HTTP Activation** check box.
   d  Select the **.NET Framework 4.6 Advanced Services** check box.
   e  Select the **Internet Explorer 11** check box.
   f  Select the **Telnet Client** check box.
   g  Select the **TFTP Client** check box.
   h  Reboot the PC.


[MUST] 16 Disable Compatibility View in Internet Explorer.
   a  Open Internet Explorer.
   b  Click the Tools menu, and then click **Compatibility View Settings**.
   c  Clear the **Display intranet sites in Compatibility View** check box.

[MUST] 17 Enable the navigation pane:
   Open Windows Explorer, then select **View > Navigation pane** from the ribbon and make sure that **Navigation pane** is selected.
Configure your Workstation PC
Configuring Windows 10

[PERFORMANCE] 18 System (Microsoft Control Panel): Change performance options:
   a  Click Advanced system settings.
   b  On the Advanced tab > Performance click Settings.
   d  Under Custom, select the following check boxes for better usability:
      - Smooth edges of screen fonts
      - Show shadows under mouse pointer
      - Show shadows under windows

[PERFORMANCE] 19 Personalization > Colors (Windows Settings): Turn Make Start, taskbar, and action center transparent off.

[PERFORMANCE] 20 System (Microsoft Control Panel): Change system properties:
   a  Click Advanced system settings.
   b  On the Advanced tab > Performance click Settings.
      - Advanced tab > Virtual Memory: For optimum performance use the Change button to adjust the paging file size to a value of 2 to 3 times of the physical RAM on the PC. If possible locate the paging file on a drive different from the system installation drive.
      - Data Execution Prevention tab: Select Turn on DEP for essential Windows programs and services only.
   c  Advanced > Startup and Recovery > Settings button:
      - System startup section:
        Change both Time to display ... fields from 30 to 3 sec.
      - System failure section:
        Select Automatically restart, in the Write debugging information section select Kernel memory dump from the drop-down list.
   d  System Protection tab
      Make sure that Protection is turned off. If required, click Configure and select Disable system protection.
   e  Remote tab
      - In the Remote Assistance section, clear the check box Allow Remote Assistance connections to this computer.
      - In the Remote Desktop section, select Don’t allow connections to this computer.
[OPTIONAL] 21 Personalization (Windows Settings): Disable advertising info:
   a On the Lock screen page:
      • Under Background, select Picture or Slideshow.
      • Turn off Get fun facts, tips, tricks, and more on your lock screen.
      • Turn off Show lock screen background picture on the sign-in screen.
   b On the Start page:
      Turn off Occasionally show suggestions in Start.

[OPTIONAL] 22 Privacy (Windows Settings):
   a On the General page, turn off the following:
      • Let apps use my advertising ID
      • Turn on SmartScreen Filter to check web content
      • Send Microsoft info about how I write
   b On the Location page, turn off Location.

[OPTIONAL] 23 Welcome Center (Start > search for ‘gpedit.msc’):
   a Navigate to Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon.
   b Set Don't display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 24 Recycle Bin Properties: (right-click on desktop icon Recycle Bin) Select the following options:
   • Custom size: Select a size corresponding to approximately 10% of the complete disk space for the drive.
   • Select Display delete confirmation dialog.
Repeat these steps for all drives of your computer.

25 Region (Microsoft Control Panel): Language for non-Unicode programs:
   On the Administrative tab, click Change system locale.... From the drop down list, select English (United States).

   **NOTE**
   Do not the change system locale if you are using an English, Portuguese, Japanese or Chinese Operating System.

[OPTIONAL] 26 Right-click the taskbar to open the Taskbar and Start Menu Properties dialog. In the Taskbar tab, under Taskbar buttons select Combine when taskbar is full.
   This will simplify switching between open CDS instances.
Editing the Security Settings for LC/MS and CE/MS Systems

The following sections summarize all security settings required for LC/MS and CE/MS. All other security settings are set automatically by the OpenLAB CDS Master Installer.

OpenLAB CDS needs to be installed using an operating system Administrator user account. To run the system with the configured options outlined in this document, all users and power users should use the same settings.

Firewall

On PCs controlling LC/MS or CE/MS systems, it is recommended that you turn off the firewall.
Advanced Network Settings

The communication with the MS is sensitive to the order NICs in the **Adapters and Bindings** dialog.

1. Go to **Start > Control Panel**.
2. Go to **Network and Sharing Center**.
3. Click **Change adapter settings**.
4. Press **ALT** to bring up the menu.

4. Select **Advanced Settings**....

![Advanced Settings dialog, Adapters and Bindings tab](image)

---

View the items by icon to see a list of all items.
5. In the **Adapters and Bindings** tab (see Figure 2 on page 33):
   - Make sure that the Local Area Connection pertaining to the **LC/MS** or **CE/MS** NIC is the first item in the list of connections.

**NOTE**

The names of your LAN cards may differ from those shown in the example. You can tell which LAN card is the Instrument LAN by comparing the IP addresses assigned to the LAN cards.

The LAN pertaining to the company intranet > internet will typically have an IP address assigned by organizations Static IP policy or by a DHCP server. Check with your network administrator.
3

Install the Software

Before You Begin 36
Step 1: Prepare for Installation 39
Step 2: Install Third Party Tools 39
Install Adobe PDF Reader 39
Install .NET 4.5 40
Step 3: Copy Installation files to a Centralized Folder for Installation (Optional) 41
Step 4: Run the System Configuration Checker 42
Step 5: Run the OpenLAB CDS Installation Wizard 43
License Agreement Screen 43
Installation Folder Screen 43
Installation Type Screens 44
Summary Screen 45
What to do Next 46
Scripted Installation 47
About Scripted Installation 47
Export as XML 47
Parameters and Return Codes 48
Installation, Upgrade, or Repair 51
Uninstallation 52
Logging and Tracing 52

The installation is automated by the OpenLAB CDS Master Installer. This tool installs the various components of OpenLAB CDS.
Before You Begin

To simplify installation of the software, it is helpful to decide on some configuration options before you begin the actual software installation.

1. Decide on a computer name.
   The computer name will be reflected in the instrument configuration. To avoid considerable effort, it is recommend to keep the computer name unchanged after installing OpenLAB CDS ChemStation Edition.

   **NOTE**
   To make sure that a DNS server can resolve the computer name, follow the internet standard for protocols *(RFC952)* and use only the following characters:
   - Letters (a-z, A-Z)
   - Digits (0-9)
   - Hyphen (-)
   Do not use an underscore.

2. For installing OpenLAB CDS, you need to have administrator privileges for all servers and clients. Power user privileges are not sufficient (the installation does not start).

3. Decide on a directory location to store all files related to the data system software, including data, methods, sequences, and configurations. The directory must always be accessible to the PC running the software.

4. If you will be using OpenLAB ECM with your system, obtain the ECM server name.

   **NOTE**
   Make sure you have administrator privileges for both ECM and OpenLAB.

5. Decide on the software delivery approach you want to use:
   - *Install directly from the USB medium* — Insert the USB medium directly at the workstation computer. (Recommended)
   - *Copy installation files to a centralized location* — You can use the utility to copy the installation files, for example, to a network share folder, and run the installation from that location. However, some networks may interfere with installation.
6 When you launch the application, you will be able to review the following PDFs in the installer **Planning** menu before you install the software.

- *OpenLAB CDS Requirements* — Use this PDF to check that your settings comply with the network requirements, and to determine whether your hardware and software will support the system.
- *OpenLAB CDS Workstation* — An electronic copy of this installation guide is provided in PDF format for your convenience.

7 Install all required hardware, including any A/D connections, interfaces, instrument detectors, and communication cables.

8 Make sure that a default printer is configured in Windows.

   This is done via the Microsoft Control Panel. If no default printer is configured the following problems may occur:

   - Printing of a report preview will fail
   - the **Copy To Clipboard** menu will have an error
   - the **Custom Report View** will have problems with new templates

**NOTE**

During the installation of the ChemStation, a PDF XChange 6 printer driver is installed. This printer has the following limitations:

- The maximum number of pages for one print job is 1500. For example sequence summary report is one print job.
- When printing Multi Page chromatograms, the maximum number of pages which can be printed properly depends on the resolution of the printer. 300 dpi allows 10 pages, 600 dpi allows up to 5 pages per chromatogram.

9 Make sure .NET 3.5 and .NET 4.5 or .NET 4.6 are activated as Windows features.

   The .NET 4.5 installation files are available on the USB medium (Disk1\Tools\DotNet4.5). To install .NET 4.5, copy the files to a local disk.

**NOTE**

Run the .NET 4.5 installation from a local disk. Windows needs write access to the installation files.
3 Install the Software
Before You Begin

10 Make sure that the antivirus software is disabled during the installation.

11 Make sure that no upgrades will run for any software during the installation.

12 Make sure that no system reboot is pending.
   Pending reboots are indicated both in the Configuration Checker (see “Windows Configuration Check for OpenLAB CDS ChemStation Edition” on page 16) and in the Site Preparation Tool (see “Step 4: Run the System Configuration Checker” on page 42).
Step 1: Prepare for Installation

To prepare for an installation on your workstation:

1. For the direct approach, insert the OpenLAB CDS Installation medium.
2. For the shared file approach, copy all installation files to a centralized folder as described below.

To begin installation, navigate to \Disk1\Setup.bat. Right-click the file and run it as administrator to proceed to the Planning screen.

Step 2: Install Third Party Tools

The OpenLAB CDS Master Installer offers a list of tools that can be installed directly from the Installation screen.

Install Adobe PDF Reader

You need Adobe Reader DC Classic to ...

- view site prep or administrative reports (such as system reports)
- use the Report Viewer feature
- view Software Verification Reports

NOTE

If an older version of Acrobat Reader (11 or earlier) is installed on your system, you must deinstall it first. Adobe updates would raise those versions to Acrobat Reader DC Continuous, which pushes automatic updates on a regular basis.
**To install Adobe Reader DC Classic:**

1. Select **Third Party Tools** and then **Adobe PDF Reader**.
   
   a. The Adobe Reader setup screen appears. Click **Install** to continue.
   
   b. If Adobe Reader was successfully installed, click **Finish** to exit the setup screen.

   Alternatively, you can install Adobe Reader from the OpenLAB CDS installation medium. It is available under Disk1/Tools/Adobe Reader.

   Run AcroRdr2015_MUI.bat and follow the instructions of the Adobe Reader Setup wizard.

---

**NOTE**

If you install Adobe PDF Reader directly from the installation medium: When OpenLAB CDS users open a PDF file for the first time, they will be asked to confirm the Adobe Reader license agreement. This dialog will appear for each newly configured instrument.

---

**Install .NET 4.5**

For Windows 7 and Windows 8.1: If .NET 4.5 is not installed on your system, its installation will automatically be triggered by the installation wizard. However, Windows requires write access to the installation files. Installing directly from the USB medium will therefore not be possible.

1. Copy the folder Disk1\Tools\DotNet4.5 to a local disk.

2. Run dotNetFx45_Full_x86_x64.bat.

3. Follow the installation wizard.
Step 3: Copy Installation files to a Centralized Folder for Installation (Optional)

Completing this step will enable you to run an installation from a network share.

1. From the Master Installer **Planning** screen, select **Installation** from the sidebar menu.
2. Select **Preparation of an Installation from Network Share**.
3. At the **Network Share** screen, browse to a directory and create a destination folder as follows:
   a. Select the button with the three dots.
   b. Navigate to the directory where you want to create the folder.
   c. Select **Make New Folder**.
   d. Type in the folder name.
   e. Select **OK**. The system will return you to the **Network Share** screen, with the path displayed.
   f. Select the content you want to copy to the folder, corresponding to the required installation scenario.
   g. Select **Start**.
4. When processing is complete, copy the files to the local drive or map the location to a network drive.
5. Close the application and navigate to the directory and folder you created. Open the folder.
6. Select the Disk 1 folder, then execute Setup.bat to run the application. The system will display the installer **Planning** screen.

**NOTE** Installations into the root of a drive may cause problems during operations and are not supported.
Step 4: Run the System Configuration Checker

1. Run the Master Installer from the USB medium or from a centralized folder. From the Planning screen, select System Configuration Checker.

2. The Site Preparation Tool opens. Select OpenLAB CDS ChemStation Edition C.01.XX from the drop-down list.

3. Select OK.

4. Complete page 1 of the Contact Information—System details by typing in the fields provided.
   - System Location fields
   - System Information fields
   - Configuration fields

5. Review the system details and make any necessary entries. The system will follow the paths specified.

6. Select the green check mark icon in the top left corner of the screen to begin the software check. A summary report is displayed showing the results for each check category. Results are expressed as Pass, Warning, Critical Warning, or Fail.
   - Fail results must be corrected before continuing with the installation. Agilent recommends investigating and correcting any Critical Warnings and Warnings whenever possible before proceeding.

7. To view details of the report, select the appropriate link: System Hardware Details, Operating System and Software Details, or Manual Verification Required.

8. To save the report, select the Save icon at the top left of the screen.

9. E-mail the saved report to your Agilent Service Representative for evaluation, and for validation of your personal computer for Agilent Software Systems Installs.

---

**NOTE**

If the firewall is controlled by security software, the Site Preparation Tool cannot read the firewall settings because of security limitations and will display Status "Fail" for the firewall settings.

In this case, make sure the firewall is disabled and enter the status in the Site Preparation Tool report manually.
Step 5: Run the OpenLAB CDS Installation Wizard

License Agreement Screen

1. From the OpenLAB CDS Master Installer screen, select Installation.
2. Select OpenLAB CDS.
3. The OpenLAB CDS Installation Wizard opens. Read the terms of the License Agreement. Master Installer provides a printable PDF of the license agreement under the Resources option of the main menu.
4. Select I agree with the terms and conditions. You cannot proceed with installation unless you agree to these terms.
5. Select Next to proceed to the Installation Folder screen.

Installation Folder Screen

1. Type the folder name or browse to the directory where you want to store the application components. Folders must have English names.

**NOTE** Installations into the root of a drive may cause problems during operation and are not supported.

2. To run an installation verification as part of this installation, select Run Software Verification. The Software Verification Tool provides documentary evidence that your system has been built and installed correctly, and that all design specifications have been met. You can run the Software Verification Tool at a later time if you prefer (see “Run a Software Verification after Software Installation” on page 59).
3. Select Next to proceed to the Installation type screen.
3 Install the Software
Step 5: Run the OpenLAB CDS Installation Wizard

Installation Type Screens

1. Under **Installation Type**, select **Standalone Workstation**.
2. Select **Next** to proceed to the **CDS Edition** screen. Select the edition of your data system.
3. Select **Next** to proceed to the installation screens specific to your edition.
4. Select **OpenLAB CDS ChemStation Edition**.
   - Under **Installation folder**, type the folder name or browse to the directory where you want to store the application components. Folder names must be entered without spaces.
   - Select the **Install IO Library** check box if you want to install the Agilent IO library suite. The suite can be installed manually at a later time if you prefer.
5. Select **Next** to proceed to the **Additional items** screen.
6. If you want to use **OpenLAB ECM** with your data system:
   a. Check the **ECM Server** option button. Type in a server name and press the **Test Connection...** button.
   b. The system will perform a connectivity check to verify access to a functional OpenLAB ECM server. If the connectivity check is successful, the message **Connection succeeded** appears. Click **OK** to continue. If the connectivity test fails, you will be returned to the **Additional items** screen. From here you can select **Next** to run the test again. If the test is still unsuccessful:
      - Enter a new OpenLAB ECM server and try another test.
      - Call internal support for assistance if you cannot connect to an OpenLAB ECM server.
      - You can uncheck the box and run the installation without OpenLAB ECM at this time. You will be able to add it to your data system at a later time, when a server is determined.

**NOTE**
The storage type **Data Store Server** is only available for a Networked Workstation or a Distributed System.

7. Select **Next** to proceed to the **Summary** screen.
Summary Screen

1 Review the installation settings that you have selected in the preceding steps. Select Back as necessary to change installation settings, or Cancel to cancel the installation.

2 Before starting or canceling the installation, you can save an XML file with your installation settings. This XML can then be used for a scripted installation (see “About Scripted Installation” on page 47).

To save the XML file, click the file symbol in the Summary screen.

3 Select Start to begin installation.

4 The system performs an automated system check before it proceeds with the listed activities.

   If a system check passed message appears, installation continues.

   If a system check failed message appears, you can either:
   • Decline to view the system report, and continue installation.
   • Decline to view the system report and postpone installation.
   • View the system report, and decide to continue installation.
   • View the system report and postpone installation until the problem is fixed.

   To view the system report as PDF file, Adobe PDF Reader must be installed (see “Install Adobe PDF Reader” on page 39).

5 If an installation verification was completed as part of this installation, review the Software Verification Report. If the report indicates failure, verify the computer requirements and reinstall the data system. Do not use the system until the Software Verification Report gives a ‘pass’ result.

6 Click Next to proceed to the Installed Features screen.

7 Click Finish to close the installation wizard.
What to do Next

The basic installation of the data system software is complete.

There is a 60-day Startup License for this system, and the expiration period starts with your first launch of an application.

To request and download your final software license, and add the license file to your system, see the Licensing chapter in this guide.

After you have acquired and installed your final software license, you will continue to prepare your data system for operation by end users by configuring projects, users, and instruments. This is accomplished through the OpenLAB CDS Control Panel.
Scripted Installation

The OpenLAB CDS Master Installer supports a command line mode for installation, the *scripted installation*. This mode supports installation, upgrade, repair, and uninstallation. You can execute scripted installations either manually or as part of software management systems such as LANDesk or HP CM. With the corresponding parameter (-q), the scripted installation completes unattended.

About Scripted Installation

The OpenLAB CDS Master Installer supports a command line mode for installation, the so-called *scripted installation*. This mode supports installation, upgrade, repair, and uninstallation. You can execute scripted installations either manually or as part of software management systems such as LANDesk or HP CM. With the corresponding parameter (-q), the scripted installation completes unattended.

Export as XML

The Master Installer supports a feature to export the installation parameters into an XML file which you can then use for the scripted installation.

This feature is also supported for upgrade and repair. However, for these cases the exported installation XML file is not appropriate. For scripted repair and upgrade, you must prepare specific XML files using the respective Master Installer wizards.

1 Launch the OpenLab CDS Installation Wizard.
2 Follow the instructions as described under *Install the Software* in this manual.
3 When you have reached the **Summary** screen, click the icon on the top right corner to export the installation parameters to XML. Save the file on a physical drive.

**NOTE**
Installation file and XML file must not be in the same file path.

You can now use the XML file for the scripted installation.
Parameters and Return Codes

Parameters

You can call Agilent.OpenLAB.CDSInstaller.exe in command line mode with the following parameters:

- `-i`
  Installation, upgrade or repair
- `-u`
  Uninstallation
- `-q`
  Silent mode — no installation or uninstallation wizard will be shown.
- `-reboot`
  Reboot automatically after successful installation, repair, upgrade, or uninstallation. The system will reboot if the return code is either 0 or 17.
  A warning message will be shown in the command prompt 10 min before the system is rebooted. In addition, a Windows dialog opens 2 min before reboot.
- `KeepComponents`
  Optional parameter for the uninstallation process, which can contain one or more shared components that should stay on your system. Without this parameter, all OpenLAB CDS components will be removed from your system. To keep certain shared components, list the corresponding IDs from the table below in double quotes and separated by comma.

<table>
<thead>
<tr>
<th>Component Name</th>
<th>Id</th>
</tr>
</thead>
<tbody>
<tr>
<td>Software Verification Tool</td>
<td>IQT</td>
</tr>
<tr>
<td>Microsoft SQL Server</td>
<td>SQLServer</td>
</tr>
<tr>
<td>IO Library</td>
<td>IOLibraries</td>
</tr>
</tbody>
</table>
• *ConfigurationXML="<ConfigurationXMLFilePath>"*

The XML file contains all required inputs of the Master Installer to install, upgrade, or repair a certain topology (see “Export as XML” on page 47). Replace `<ConfigurationXMLFilePath>` with the correct file path and XML file name.

**NOTE**

Do not enter a blank before or after the equals (=) sign. The scripted installation and uninstallation mode will not work as expected.

**Return Codes**

After installation, uninstallation, upgrade, or repair in the command line mode, the system will return a number code which is explained below.

**Table 2 Return codes**

<table>
<thead>
<tr>
<th>Error/Return Code</th>
<th>Return value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unknown (default)</td>
<td>-1</td>
</tr>
<tr>
<td>Success</td>
<td>0</td>
</tr>
<tr>
<td>CoreComponentFailure</td>
<td>1</td>
</tr>
<tr>
<td>NonCoreComponentFailure</td>
<td>2</td>
</tr>
<tr>
<td>TestConnectivityFailure</td>
<td>3</td>
</tr>
<tr>
<td>ExpectedWindowsInstallerNotInstalled (WI 4.5 missing)</td>
<td>4</td>
</tr>
<tr>
<td>ParameterMismatchError</td>
<td>5</td>
</tr>
<tr>
<td>CannotProceedWithFreshInstallation</td>
<td>6</td>
</tr>
<tr>
<td>CannotProceedWithUpgrade</td>
<td>7</td>
</tr>
<tr>
<td>CannotProceedWithUninstallation</td>
<td>8</td>
</tr>
<tr>
<td>CannotProceedWithRepair</td>
<td>9</td>
</tr>
<tr>
<td>CannotProceedWithReRegistration</td>
<td>10</td>
</tr>
<tr>
<td>ReRegistrationNotSupported</td>
<td>11</td>
</tr>
<tr>
<td>IncompleteTopologyFound</td>
<td>12</td>
</tr>
<tr>
<td>InvalidUNCPath</td>
<td>13</td>
</tr>
</tbody>
</table>
### Table 2  Return codes

<table>
<thead>
<tr>
<th>Error/Return Code</th>
<th>Return value</th>
</tr>
</thead>
<tbody>
<tr>
<td>MissingInstallable</td>
<td>14</td>
</tr>
<tr>
<td>NotAStrongPassword</td>
<td>15</td>
</tr>
<tr>
<td>DowngradeNotSupported</td>
<td>16</td>
</tr>
<tr>
<td>RestartRequired</td>
<td>17</td>
</tr>
<tr>
<td>RegistryCleanupError</td>
<td>18</td>
</tr>
<tr>
<td>InvalidInputXML</td>
<td>19</td>
</tr>
<tr>
<td>InvalidMode</td>
<td>20</td>
</tr>
<tr>
<td>SitePrepFailure</td>
<td>21</td>
</tr>
<tr>
<td>DatabaseConnectionFailed</td>
<td>22</td>
</tr>
<tr>
<td>DotNetFramework4NotInstalled</td>
<td>23</td>
</tr>
<tr>
<td>OLSSConnectionFailed</td>
<td>24</td>
</tr>
<tr>
<td>PDFReaderNotInstalled</td>
<td>25</td>
</tr>
<tr>
<td>AllComponentsInstallationFailed</td>
<td>26</td>
</tr>
<tr>
<td>SomeComponentsInstallationFailed</td>
<td>27</td>
</tr>
<tr>
<td>Failed</td>
<td>28</td>
</tr>
<tr>
<td>AddOnListEmpty</td>
<td>29</td>
</tr>
<tr>
<td>EULANotAccepted</td>
<td>30</td>
</tr>
<tr>
<td>ScriptedNotSupported</td>
<td>31</td>
</tr>
</tbody>
</table>
Installation, Upgrade, or Repair

In installation mode, the OpenLAB CDS Master Installer checks if .Net Framework is present on your system. If not, it will automatically be installed. Select **Accept** to agree with the license agreement.

The Master Installer evaluates the products already installed on your system. Depending on the installed components, the Master Installer will offer one of the following options:

- Start a fresh installation
- Upgrade
- Repair

If a required installable is missing, the Master Installer will create an entry in a log file, and, depending on the component type, will continue or rollback the installation. A corresponding error code will be returned in such scenarios.

**Preparations**

You must have copied all disks to a centralized folder (see "Step 3: Copy Installation files to a Centralized Folder for Installation (Optional)" on page 41). This step is mandatory for scripted installation.

1. Right-click the executable of the command prompt or PowerShell prompt, and run it as administrator.
   
   You will get a return code for the scripted installation only if you start it as administrator.

2. Navigate to the drive where you have saved the disks.
   
   For example: C:\CDS_DVD

3. To start the installation, call Agilent.OpenLab.CDSInstaller.exe with the following syntax:
   
   ```
   Agilent.OpenLab.CDSInstaller.exe -i ConfigurationXML="<path to xml file>" -q -reboot
   ```
   
   For example:
   
   ```
   Agilent.OpenLab.CDSInstaller.exe -i ConfigurationXML="c:\settings\ConfigurationXML.xml" -q -reboot
   ```
   
   With this command, you start the installation wizard without a user interface, and automatically reboot the system.
Uninstallation

1. Right-click the executable of the command prompt or Power shell prompt, and run it as administrator.
   You will get a return code for the scripted uninstallation only if you start it as administrator.

2. Navigate to the drive where you have saved the disks.
   For example: C:\CDS_DVD

3. To start the uninstallation, call Agilent.OpenLab.CDSInstaller.exe with the following syntax:
   Agilent.OpenLab.CDSInstaller.exe -u KeepComponents="<list of components>" -q -reboot
   For Example:
   Agilent.OpenLab.CDSInstaller.exe -u KeepComponents="IQT,IOLibraries" -q -reboot
   With the KeepComponents parameter, you can specify a list of shared components that you want to keep on the system (see “Parameters” on page 48). With the command given in the example, the OpenLAB CDS components Software Verification Tool (IQT) and IO Library (IOLibraries) will be kept.

Logging and Tracing

All exceptions, errors and information messages are logged in the following locations:
- During installation, upgrade, or repair: under <BaseInstallDirectory>\Logs
- During uninstallation: under <User's Temp>\<Company Name>\Logs\<Log folder>\<Wizard Name>.txt
4
Post Installation Tasks

Configure the Antivirus Program  54
Set Required Windows User Privileges  56

This chapter describes tasks that are relevant after finishing the installation.
Configure the Antivirus Program

Be sure to open the firewall ports listed in the Firewall Settings in the OpenLAB CDS ChemStation Edition Requirements guide.

**NOTE**
Running antivirus programs might influence the behavior and performance of your computer. Some virus scanners might cause issues when used with OpenLAB CDS. The application is tested with Symantec Endpoint Protection 12.x and with Microsoft Security Essentials.

In order for the OpenLAB software to function correctly, you should configure any antivirus real time protection software with the following list of folder exclusions. These folders should only be scanned while the instruments are idle and no data acquisition takes place. Refer to your specific antivirus software documentation on how to configure folder exclusions.

- C:\chem32, D:\chem32, etc.
- C:\programdata\agilent
- %programfiles%\agilent
- %programfiles(x86)%\agilent
- %programfiles%\common files\agilent
- %programfiles%\common files\agilent technologies
- %programfiles(x86)%\common files\agilent technologies
- %programfiles%\common files\agilent technologies
- %programfiles(x86)%\common files\agilent technologies
- %programfiles%\common files\agilent shared
- %programfiles(x86)%\common files\agilent shared
### Configure the Antivirus Program

If your antivirus software includes program or executable deny execution settings, ensure that the following program files are not denied execution. You can use the windows search feature to find the specific folder each program file is located in.

- `agilentiolibrariesservice.exe`
- `chemmain.exe`
- `apg_top.exe`
- `iprocsvr.exe`
- `iproc8491.exe`
- `msinsctl.exe`
- `httpdmsd.exe`
- `epcssetup.exe`

<table>
<thead>
<tr>
<th>Process</th>
<th>Directory</th>
<th>File name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECM upload/download</td>
<td>%temp% for Windows users (=Users' temp directory)</td>
<td>*.ssizip</td>
</tr>
<tr>
<td>Standard reports</td>
<td>%temp% for Windows users (=Users' temp directory)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>/chem32/core</td>
<td>~p3d*.tmp</td>
</tr>
<tr>
<td></td>
<td></td>
<td>~job*.tmp</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Hpspl00.que</td>
</tr>
<tr>
<td>CDS intelligent reports</td>
<td>%LOCALAPPDATA%</td>
<td>Files on:</td>
</tr>
<tr>
<td></td>
<td>%APPDATA%</td>
<td>• Agilent</td>
</tr>
<tr>
<td></td>
<td>%PROGRAMDATA%</td>
<td>• Agilent Technologies</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Agilent_Technologies,_Inc</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• IsolatedStorage</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Temp</td>
</tr>
<tr>
<td></td>
<td></td>
<td>e.g.: <code>C:\Users\xxxxx\</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td>AppData\Local\Agilent</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Technologies\Intelligent</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Reporting\</td>
</tr>
<tr>
<td></td>
<td></td>
<td>RawDataFileCache</td>
</tr>
</tbody>
</table>

Depending on your specific configuration, some of the listed folders or files may not exist on your system.
Set Required Windows User Privileges

Every Windows user who runs ChemStation needs the following minimum privileges and settings to run ChemStation:

- Default printer configured in the user profile. The configured printer must not be a to-file printer such as a PDF or XPS writer. It must be a physical printer, even if the printer does not exist.
- Full access to the chemstation.ini file in the Windows folder.
- Full access to every file inside the Chem32 folder.
- Full access to every folder that Chemstation needs to access. This includes:
  - \C:\programdata\agilent
  - %programfiles%\agilent
  - %programfiles(x86)%\agilent
  - %programfiles%\common files\agilent
  - %programfiles(x86)%\common files\agilent
  - %programfiles%\agilent technologies
  - %programfiles(x86)%\agilent technologies
  - %programfiles%\common files\agilent technologies
  - %programfiles(x86)%\common files\agilent technologies
  - %programfiles%\common files\agilent shared
  - %programfiles(x86)%\common files\agilent shared
5
Optional Procedures

Install Additional Software and Drivers 58
Run a Software Verification after Software Installation 59
Transform a Workstation to a Networked Workstation 60
Improve Performance on Offline Machines 62
Protect ChemStation Folders with Secure File I/O 63
Change the PC Name 64

This chapter contains information on the Additional Drivers and Software wizard, on the Software Verification Tool, and other helpful procedures.
Install Additional Software and Drivers

OpenLAB CDS offers a wizard to help you installing additional software, such as drivers for third-party instruments. To open the wizard, go to Start > All programs > Agilent Technologies > OpenLAB > OpenLAB Additional Software and Drivers. Follow the wizard to install the required software.

Prepare Network Drives

If the additional software is located on a network drive, you must prepare the network drive to make it accessible by the wizard. Without this preparation, Windows security prevents the wizard from accessing those drives.

1 Map the drive to a letter.
   For example, map the drive as Z: using the shared path "\<machine-name>\OpenLABCDS".
   This maps the drive for the logged-in user.

2 Open the command prompt in elevated mode (run as administrator), and map the drive using the net use command.
   For example,
   \net use Z: "\<machine-name>\OpenLABCDS"
   This maps the drive for the local administrator account. The mapped drive is now visible to both logged-in user and administrator, and can be selected in the wizard.
Run a Software Verification after Software Installation

The Software Verification Tool (SVT) provides documentary evidence that your system has been built and installed correctly, and that all design specifications have been met.

1. Using your Windows operating system, go to Start > All Programs > Agilent Technologies > Software Verification Tool.

2. Select Qualify.
   The system will run the application and generate a Software Verification Report.

3. If the report indicates failure, verify the computer requirements and reinstall the data system.
   Do not use the system until the Software Verification Report gives a ‘pass’ result.
Transform a Workstation to a Networked Workstation

With Networked Workstations, you use a separate OpenLAB Shared Services server to control the system. You can access all information provided by OpenLAB Shared Services from any Networked Workstation. For example, you can see on each workstation which instruments are available and which status (Online, Offline, Error, In Run, Not Ready, etc.) the instruments currently have. Also licenses and user accounts are managed centrally on the OpenLAB Shared Services server.

**NOTE**
- You must already have installed an OpenLAB Shared Services server. See *OpenLAB CDS ChemStation Edition Networked and Distributed System Installation and Configuration* (CDS_NWSDS-Installation.pdf on disk 1).
- Make sure that the Shared Services versions on the workstation and the server are identical. If not, upgrade your system before doing the transformation. See “Upgrade ChemStation Edition to Latest Version” on page 87.

For more information on temporary support of mixed version systems during an upgrade phase, refer to the *OpenLAB CDS ChemStation Edition Guide for Administrators* (CDS_Admin.pdf).

**CAUTION**
Conflict of multiple instruments having the same name

Check if the instruments used on the Workstation have a name that already exists in the network. If this is the case, or if you are not sure:

- Before starting the transformation: Copy the data, methods, and sequences from the relevant instrument to a local backup folder. Then delete the instrument on the Workstation.
- After the transformation, configure a new instrument, and copy back the data from the local folder.
Transform a Workstation to a Networked Workstation

1. From the OpenLAB CDS Master Installer screen, select Maintenance.
2. Select Transformation of an OpenLAB Standalone Workstation into a Networked Workstation.
3. Enter the server name and the authentication service used by the server.
   If the server requires authentication, you will be asked for the credentials of an OpenLAB Shared Services administrator.
4. Start the transformation.
   All instruments will be registered on the OpenLAB Shared Services Server.
Improve Performance on Offline Machines

Computers running OpenLAB CDS ChemStation Edition may exhibit slow performance when they are not connected to the Internet.

The windows operating system has routines built into its operation that causes it to continuously search for an online connection in order to update to all the latest Windows security certificates when using secure software.

Use the following system settings on all workstations, clients, AICs, and servers to remedy this problem.

1. Open Internet Explorer and select **Tools > Internet Options.** In the **Advanced** tab, clear the following check boxes:
   - **Security > Check for publisher’s certificate revocation**
   - **Security > Check for server certificate revocation**

2. Windows 7 and windows 8.1: Change the following registry keys:
   - On 32bit and 64bit systems:
     - \[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SystemCertificates\AuthRoot\]
     - "DisableRootAutoUpdate"=dword:00000001
   - On 64bit systems:
     - \[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Policies\Microsoft\SystemCertificates\AuthRoot\]
     - "DisableRootAutoUpdate"=dword:00000001

3. Document that you turned off the Root Certificates, as this can prevent users from installing other applications.
Protect ChemStation Folders with Secure File I/O

ChemStation files such as data, methods, or sequences are stored in various local folders. To ensure data integrity, ChemStation offers the *Secure File I/O* function. If you enable this function, all folders will be protected against modifications from outside ChemStation or in *Open* or *Save As* dialogs.

For more information, refer to the *Folder Protection with Secure File I/O* chapter in the *OpenLAB CDS ChemStation Edition Guide for Administrators*. 
Change the PC Name

Considerations

A change of the PC name may be scheduled to avoid duplicate names in a network or can be due to a policy change. If you need to change a PC name after installation of OpenLAB CDS, consider the following:

- The license file for the PC is no longer valid

OpenLAB CDS instruments are licensed by installing files that are specifically created for a given configuration. The text of the license files contains references to the computer name and the hardware address of the network card. If one of the parameters is changed, the license no longer applies.

- The instrument controller will no longer be resolved

An instrument controller is a workstation or AIC that is used to control an instrument. This can be either a physical instrument for acquisition or for Data Analysis only.

During installation of a standalone workstation the PC name of this workstation is registered as the Instrument Controller. If the name is changed after installation, the registered name is not updated automatically. Instead the old name remains as an unresolved orphan and instruments that are configured with this name will no longer start.
• Instruments connected to an unresolved instrument controller cannot be started and cannot be deleted

All instruments that are connected to the relevant instrument controller must be deleted. *before* changing the PC name.

**NOTE**
To make sure that a DNS server can resolve the computer name, follow the internet standard for protocols *(RFC952)* and use only the following characters:

• Letters (a-z, A-Z)
• Digits (0-9)
• Hyphen (-)

Do not use an underscore.
Steps After Changing the PC Name

1. In the **Instruments** section in the OpenLAB CDS Control Panel, delete any instruments that are still assigned to the unresolved instrument controller.

2. In the **Administration > Instrument Controllers** section in the OpenLAB Control Panel, click **Delete Instrument Controller** in the ribbon to remove the old name from the list of instrument controllers.

3. After the change to the new name, register this new PC name with OpenLAB Shared Services. This is done by executing the file **RegisterCS.bat** in the ChemStation Core folder:

4. Install a license file that is generated with the new PC name (host name).

The following figure shows the procedure as a flow chart:
Optional Procedures
Change the PC Name

Figure 3  PC name change - flow chart
5 Optional Procedures

Change the PC Name
6 Licensing

About OpenLAB CDS Licensing 70
   License Types 70
   License File 71
Get a License 72
   Obtain a License with SubscribeNet 72
   Other Ways to Obtain a License 74
Install Your License 76

This chapter contains information on how to obtain and install a license.
About OpenLAB CDS Licensing

License Types

There is a 60-day Startup License for the system. The expiration period starts with the first launch of an application. In order to run the data system software after that period, you must install your final license file.

OpenLAB CDS ChemStation Edition licensing requirements for system components are satisfied in three ways:

1. Core license – this is the final product license that you must install to your system within the 60-day trial period to continue use. The core license is installed to the license server – the OpenLAB CDS ChemStation Edition Workstation PC, or the server to which OpenLAB CDS ChemStation Edition was installed in a client/server system.

2. Shared licenses – system computers and other components can have shared, or add-on, licenses – because they share a core license.

3. Counted licenses – these licenses are part of the OpenLAB CDS ChemStation Edition floating licensing strategy. They are not permanently assigned to any one component. Instead they are automatically assigned to components, such as AICs and instruments, while the components are starting up. The licenses are automatically returned when the component is closed. The license management program controls license issuance and retrieval.

In this case, the only requirement is that a component is licensed while running. You only need enough licenses for all components running concurrently, rather than for each installed component.
License File

A license file will contain your software license. This file is installed on the workstation. The license file is bound to this computer, and cannot be moved to another workstation without regenerating the license in SubscribeNet.

Information in the license file defines the number of instruments and other options that may be used concurrently with your system.

The most efficient way to manage and maintain your licensing is through the Internet. To generate, download, and install a final license for your product, you will need:

- The authorization code label provided in the lavender envelope containing your Software Entitlement Certificate.
- The URL for SubscribeNet from the Software Entitlement Certificate.

If you have not received a lavender envelope for your product, contact your vendor or internal support.
Get a License

Obtain a License with SubscribeNet

If you have Internet access, use the following procedure to generate and download your license for your OpenLAB CDS system.

If you do not have Internet access, skip to the section “Other Ways to Obtain a License” on page 74.

If you are a new user who has not registered with SubscribeNet, continue with the section New Users.

If you have registered with SubscribeNet, skip to the section Users registered with SubscribeNet.

New Users

1. From a computer with Internet access, enter the URL provided in the Software Entitlement Certificate in an Internet browser.

2. At the bottom of the login page, click click here to register.

3. On the registration page, enter the authorization code from the label and complete the profile information (required fields are marked with an asterisk *).

   The email address you enter will become your login ID.

4. Click Submit. The system will generate and display an account name for you. SubscribeNet will send a welcome email with your login ID and password.

5. Log in to SubscribeNet using your login ID and password.

   Once you log in, you can use the online user manual link for help with any questions you have.

6. Select Generate or View licenses from the left navigation bar.

7. Follow the prompts to generate your new license.

   You will be prompted for the HOST NAME of the computer. The host name you enter must match with the network name of the computer where the Control Panel is running. Do not include any DNS suffix (domain.com) references in the entered machine name.
During this process you will have to enter the MAC address of your license server. For workstations, this is the local computer. For client/server systems, this is the server.

To retrieve your MAC address from a computer where OpenLAB CDS ChemStation Edition is already installed, open the Control Panel and browse to the Administration > Licenses section. Use the Copy MAC Address or Save MAC Address function to obtain the MAC address for license generation.

If any changes are made to the computer name or domain reference after the license is installed, remove the license. A new license will need to be created in SubscribeNet, downloaded, and installed.

If the network adapter that provides the MAC address used during license creation is removed from the machine, your license will no longer be valid. A new license will need to be generated with a currently available MAC on the license server.

8 When the system generated the license, view its details, then click Download License File. Save the license file to your computer and to a backup location (such as a portable storage device).

Use your login ID and password when you revisit the Agilent SubscribeNet site to regenerate a license file, add new authorization codes, or further configure the license for your system.

Users registered with SubscribeNet
1 Login to SubscribeNet with your e-mail address and password.
2 Select the SubscribeNet account associated with this authorization code, if you have more than one account.
3 From the SubscribeNet navigation pane, select Register Authorization Code. This will allow you to enter your new authorization code and make available the new license entitlements
4 Follow steps 7 through 9 in the previous procedure, New Users, to generate or view your new licenses.
Other Ways to Obtain a License

If you are unable to generate a license, contact your nearest Agilent technical support office. A representative will tell you how to submit an OpenLAB CDS License Generation Form in your location.

Offline Licensing

If an internet connection is not available in your laboratory:

You or your local on-site service engineer will collect the necessary information from you to allow Agilent to create a license account on your behalf. For phone support in your region, call the sales and service number for your region. See the Appendix for a list of numbers for various countries.

Required Customer Information for Agilent License Support:

The following information must be provided to Agilent in order to enable us to create a licensing account on your behalf.

1 Collect Account Information:

Your account name will be your company name and Lab name separated by a comma. Employee information provided here will be used to define the first administrator of your account for future access to the system as required. Please prepare the following pieces of information prior to contacting your local Agilent sales and service center in order to expedite service:

- Company Name
- Lab/Department Name
- First Name
- Last Name
- E-mail address
- Job Title
- Phone #
- Address, City, State/Province, Postal Code, Country

2 Collect Authorization Code(s):

The authorization code is an alpha-numeric code provided on a label which is enclosed in a lavender envelope. If you have received more than one code
you must provide all codes to ensure that all ordered licenses are granted to your account.

3 Receiving your license:

Once the above information is provided Agilent will then work on your behalf to generate a license file through SubscribeNet. The license file will either be sent to your shipping address (on a CD), or your local FSE will deliver it in person (usually on USB media). Once your license is received follow the below section on “Install your License” to finish installing your license on your CDS system(s).

Request a license by FAX

If you do not have Internet access or an FSE on-site, you can fax your license request as follows:

1 Complete the OpenLAB CDS License Generation Form (P/N: M8301-90071) with:
   - Email address
   - Authorization code
   - User profile information (including exact computer name and MAC address)

2 Fax the form to your local Agilent Sales and Service Center. You will receive a reply FAX with your new account name, login ID, and password. The system will also send this information to you via email.

3 Add the license file to your system.
Install Your License

The license must be added to your system using the Control Panel.

1. Start the Control Panel shortcut on the desktop or go to Start > All Programs > Agilent Technologies > OpenLAB Shared Services > Control Panel.
2. Navigate to Administration > Licenses.
3. In the ribbon, click Add License.

4. Choose to install the license by:
   - Using the license file option to browse to and open the license file (.lic) saved from the license generation process in SubscribeNet.
   - Selecting the License Text option and copying the license text from a text file received into the provided field.
5. Click OK.

The Administration interface in the Control Panel will now display the status of installed licenses.
Configure OpenLAB CDS in the Control Panel

Configure Authentication 78
Configure Security Policy 80
Configure Users/Groups/Roles 80
  Create or import users 81
  Groups 81
  Roles and Privileges 82
    Specific Roles for Individual Instruments 83
Install your License 84
Configure Instruments 85

This chapter describes the initial configuration steps after installing the software. Refer to the online help for more information.
Configure Authentication

Authentication Provider

Authentication providers are used to prove the identity of users that log in to the system. OpenLAB CDS Shared Services support the following Authentication providers:

• None

In this mode, no login screen is shown when you access the OpenLAB Control Panel. The user is automatically logged in to the application with security disabled. All log entries record the user as "Anonymous". With the authentication provider **None**, the Security Policy and User Management nodes are unavailable in OpenLAB Control Panel.

**NOTE**
With the authentication provider **None**, any activity logs will display a generic **System** operator with no additional identification. This is not recommended for regulated environments.

• Internal

In this mode, the user's credentials are created and stored in the OpenLAB CDS Shared Services database. You are asked to create an administrator account for OpenLAB CDS Shared Services before setting up other users. This is the only mode in which you can create new users within the system.

• Windows Domain

You import existing Windows users into OpenLAB CDS Shared Services. The authentication is done either by a Windows Active Directory domain or NT 4.0 Domain within the Enterprise. Shared Services only use the identity and password of the mapped users; roles and privileges for OpenLAB CDS are still configured with the Shared Services.

• ECM

In this mode, an OpenLAB ECM system is responsible for authentication. When you start the OpenLAB Control Panel, the application will prompt for ECM credentials to validate a user. You must choose an existing ECM user as an administrator for the Shared Services. The Search function helps you to find specific ECM users. The Shared Services only use the identity and password of the mapped users; roles and privileges for OpenLAB CDS are still configured with the Shared Services.
Configure OpenLAB CDS in the Control Panel

Configure Authentication

1. Launch the Control Panel.
2. Navigate to Administration.
3. In the navigation pane, select System Configuration.
4. In the ribbon, click Edit System Settings.
5. Select the required authentication provider from the drop-down list, then click Next.
6. Provide user credentials:
   a. For Windows Domain: Select the check box to use a domain user, and provide user credentials with the rights to obtain user and group information. Then click Select Account to open the Search Users dialog and select an administrator account.
   b. For Internal: Click Create Account to create a new administrator account for OpenLAB CDS ChemStation Edition.
7. Confirm your settings. When complete, the Control Panel will restart.
Configure Security Policy

If you need to comply with specific standards, adjust the security policy as required.

With the authentication provider Internal, you can set all parameters in the Control Panel. With an external authentication provider, you can only set the inactivity time in the Control Panel; all other parameters are defined by the external system.

1. Launch the Control Panel and navigate to Administration.
2. In the navigation pane, select Security Policy.
3. In the ribbon, click Edit Security Policy.

Configure Users/Groups/Roles

With internal authentication, you create the required users in the OpenLAB Control Panel. With external authentication system such as Windows domain, you import the users.

To define what users are allowed to view or do, OpenLAB CDS ChemStation Edition offers predefined roles and allows you to define your own specific roles. Roles are equipped with numerous specific privileges.

Each user can be member of multiple groups. You must assign one or more specific roles to each group. You can also assign roles to single users; however, for the sake of clarity, it is strongly recommended to assign roles only on the group level. Every member of a group automatically has all roles of this group.

1. Launch the Control Panel and navigate to Administration.
2. In the navigation pane, select Users, Groups, or Roles.
3. Create new items, or edit the existing ones.
Create or import users

Use the OpenLAB Control Panel to manage the roles and privileges. You can create custom roles, or assign one or more of the predefined roles to give users varying degrees access.

Add users (Internal Authentication only)

1. From the navigation pane, click Administration > Users.
2. In the Create User dialog, provide the relevant parameters:
   - Enter the name and password for the new user.
   - By default, the new user will need to change the password at next logon. If this is not required, clear the User must change password at next logon check box.
   - In the Role Membership tab, assign the user to an appropriate role. You can use the default roles, or prepare your own roles in the Control Panel under Administration > Roles.
3. Click OK.

Import users

To add Windows domain users to your system, you must have privileges to obtain user and group information from the domain.

1. From the navigation pane, click Administration > Users.
2. In the ribbon, click Import.
3. In the Search Users dialog box, enter search string for the username.
4. From the Search Results list, select the user you want to import, and click Add. The user is added to the Selected Users list.
5. Repeat steps 2 through 4 until you have added all the user names that you want to import to the Selected Users list, then click OK.

Groups

If you use an external authentication provider, you can either import the names of groups that exist in the external system, or create new internal groups. There is no limit on the number of groups that can be mapped or created.
Configure OpenLAB CDS in the Control Panel
Configure Users/Groups/Roles

Assign users to groups either in the external system or in the Control Panel. If you need additional user assignments that are relevant only for OpenLAB CDS ChemStation Edition, create them in the Control Panel. Otherwise it is sufficient to only import the groups and assign the required roles to the groups.

If you delete or unmap a group, the users who were members in this group remain unchanged.

Roles and Privileges

Roles are used to assign privileges to a user or a user group globally or for a specific instrument or location. The system contains a list of predefined roles which are installed as part of the system installation (for example, Instrument Administrator, Instrument User, or Everything). Each role has certain privileges assigned.

Privileges are grouped according to the three main role types (Project role, Instrument role, and Administrative role). When you assign privileges to a role, you first select the required role type and then select the privileges related to this role type. Each role can only have privileges of one specific role type; the only exception is the predefined role Everything, which has all privileges of all role types. Users or groups may require multiple roles to perform system functions. For example, a user with the role Chemist may need another role such as Instrument User with the privilege to run an instrument.

You can create a tree of different locations in the Control Panel, and add instruments to the relevant locations. For each instrument or instrument group, you can assign different Instrument roles (see also “Specific Roles for Individual Instruments” on page 83). For example, a user can have the role Instrument Administrator for one instrument, and Instrument User for another instrument.

You can also create a tree of different projects or project groups in the Control Panel, and assign different Project roles for different projects (see also “Specific Roles for Individual Instruments” on page 83). For example, a user can have the role Project Administrator in one project, so that he can manage the settings in the Control Panel. In a second project, he may have a role that allows him to edit the content of a project, but not to change the project settings.
Configure Users/Groups/Roles

Specific Roles for Individual Instruments

By default, the roles of users or groups are globally set for all locations or instruments. The role settings are inherited from the root node Instruments. In order to assign a different role to a user or group for one specific node, you can deselect the Inherit privileges from parent check box in the Edit Privileges dialog for the required node. Afterwards, you can assign a different role that will be valid only for the specific node.

You can assign Instrument roles to individual locations or instruments.

Administrative roles are always set globally.

<table>
<thead>
<tr>
<th>Table 3</th>
<th>Description of role types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Role Type</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Administrative privileges</td>
<td>These privileges are globally assigned to a user or group and cannot be changed on the instrument/location level. They are the typical administration privileges such as Backup and restore, Manage security, Manage printers etc.</td>
</tr>
<tr>
<td>Instrument privileges</td>
<td>These privileges can be assigned globally or on the instrument/location level. Privileges for instruments are, for example, View instrument or location and Run instrument. Users need the View instrument or location privilege on the global level to see the locations and instruments tree in the Control Panel.</td>
</tr>
<tr>
<td>Project privileges</td>
<td>Privileges for accessing or modifying different levels of data. You can assign these privileges globally or on project level.</td>
</tr>
</tbody>
</table>
Install your License

The license must be added to your system using the Control Panel.

1. Start the Control Panel shortcut on the desktop or go to Start > All Programs > Agilent Technologies > OpenLAB Shared Services > Control Panel.

2. Navigate to Administration > Licenses.

3. In the ribbon, click Add License +.

4. Choose to install the license by:
   - Using the license file option to browse to and open the license file (.lic) saved from the license generation process in SubscribeNet.
   - Selecting the License Text option and copying the license text from a text file received into the provided field.

5. Click OK.

The Administration interface in the Control Panel will now display the status of installed licenses.
Configure Instruments

1. Launch the OpenLAB Control Panel and navigate to **Instruments**.
2. Click **Create** in the ribbon to create a new instrument.
3. Select the new instrument, and click **Configure Instrument** in the ribbon.
4. It is recommended that you use Auto Configuration to configure your instruments: Select a module, click **Auto Configuration**, and provide the instrument's IP address or hostname.
5. Confirm your settings

Configure OpenLAB CDS in the Control Panel

Configure Instruments
8
Upgrade ChemStation Edition to Latest Version

Planning the Upgrade of a ChemStation C.01.0x  88
Upgrade ChemStation to C.01.07 SR3  89
License Upgrade  90
  Get Upgraded License File  90
  Add Upgraded License File to the System  92
Run the Upgrade Wizard  93

This chapter describes the upgrade from ChemStation C.01.0x. If you upgrade from an older ChemStation revision (A.0x or B.0x) please refer to the Upgrade Preparation guide.
Planning the Upgrade of a ChemStation C.01.0x

Revision C.01.07 SR3 introduces the support of Windows 10 and a new OpenLAB Control Panel version.

Before upgrading, make the following basic decisions.

**Do you intend to run ChemStation on Windows 10?**

An in-place upgrade from Windows 7 or 8.1 to Windows 10 on an existing ChemStation Workstation is not supported.

Implications are:

- You will have to install ChemStation Edition C.01.07 SR3 on your new Windows 10 PC. See “Install the Software” on page 35.
- You will have to move your data to the new system.
- The M8370AA OpenLAB Data Analysis Add-On is not part of ChemStation C.01.07 SR3. It is not supported on Windows 10.

**Do you want to keep your current Windows 7 or Windows 8.1 operating system and only upgrade your ChemStation?**

See “Upgrade ChemStation to C.01.07 SR3” on page 89.
Upgrade ChemStation to C.01.07 SR3

ChemStation C.01.07 SR3 introduces the support of Microsoft Windows 10 and has a new user interface for the (OpenLAB) Control Panel. The procedure depends on the revision of your currently installed ChemStation Edition:

- **Rev. C.01.05 or higher:**
  Run the upgrade wizard. ChemStation will be upgraded to C.01.07 SR3. The Control Panel will be upgraded to rev. 2.1 and has a different look now.

![Figure 4](Control_Panel_2.1_User_Interface.png)

- **Rev. C.01.04 or lower:**
  Uninstall the old Chemstation, and install C.01.07 SR3.

After the upgrade, the new Control Panel user interface will be available except in the following two cases:

- M8370AA OpenLAB Data Analysis Add-On is present.
- OpenLAB CDS ChemStation Edition rev C.01.07, C.01.07 SR1 or C.01.07 SR2 is present.

In these cases, the Control Panel will only be upgraded to rev. A.02.02, which still supports the OpenLAB Data Analysis Add-On. The Control Panel style remains unchanged.

![Figure 5](Control_Panel_A.02.02_User_Interface.png)
License Upgrade

Get Upgraded License File

If you are upgrading from a version C.01.06 or older, you will need to upgrade your licenses in SubscribeNet prior to upgrading to the next version of OpenLAB CDS ChemStation Edition. We strongly recommend upgrading your workstation licenses before upgrading the core software. Standalone workstations which are upgraded to the new core software version, without a new workstation license, will not work until the new workstation licenses are added to the OpenLAB Control Panel.

If you are under SMA subscription, proceed as follows to upgrade your licenses:

1. During the following process, you will be prompted in SubscribeNet for the host name or MAC address of the workstation where OpenLAB CDS ChemStation Edition is already installed.

   To retrieve this hostname and MAC address, open the Control Panel and browse to the Administration > Licenses section. Note down the host name and use the Copy MAC Address or Save MAC Address function to obtain the MAC address.

2. Log into the Agilent Electronic Software and License Delivery (https://agilent.subscribenet.com/).
3 Navigate to **Manage Licenses by Host**. In the **Host ID** field, enter the previously noted MAC address, and click **Search**.

If the relevant host name does not appear, you may be managing your licenses in multiple SubscribeNet accounts. You will need to log into those accounts to upgrade those workstation licenses.

4 If your license(s) are eligible for an upgrade, you will see the **Upgrade All** button. Otherwise you will need to contact your Agilent Sales Representative to renew your Software Maintenance Agreement (see “Sales and Support Assistance” on page 100). To proceed with generating your upgrade license, click the button.

5 On the **Upgrade All Licenses for License Host** page, review the data, and confirm by clicking **Upgrade All**.

This upgrades the license file to the most current version. SubscribeNet will send you an email with a new license file.

6 Put the new license file on your system (see “Add Upgraded License File to the System” on page 92.

If you have multiple standalone Workstations, repeat this step for each individual workstation.

Note that each workstation's MAC address is the file name. This helps identify the correct license file to import into the workstation's Control Panel.
Add Upgraded License File to the System

If you have purchased new options, such as additional instrument controls or client license and regenerated your license in SubscribeNet, the upgraded license file must be re-applied to the system.

1. Start the Control Panel from any machine connected to the system you want to install the license for.
2. Navigate to Administration > Licenses.
3. In the ribbon, click Remove License \(\times\).
4. In the ribbon, click Add License \(+\).
5. Browse to and open the license file saved from the license generation process in SubscribeNet.
6. Restart the following Windows services:
   - Agilent OpenLAB License Server
   - Agilent OpenLAB Licensing Support
Run the Upgrade Wizard

Prerequisites

To preserve the instrument’s column table during the upgrade, go into each of the existing instrument folders (Chem32\1, Chem32\2, ...) and rename the file Config.reg into Config.bak. This step is not required if you use LC column tags to store the LC column information, or if GC column injection counts are irrelevant.

**NOTE**

Previous settings in the ChemStation Administration Tool may change during the update process. After the upgrade, check if the settings in the ChemStation Administration Tool still match your original system settings before the upgrade.

**NOTE**

As of ChemStation C.01.07 SR2, the ChemStation Administration Tool includes a function for folder protection. For details, refer to the ChemStation Administration Tool section in the OpenLAB CDS ChemStation Edition Guide for Administrators.

1. From the Master Installer Planning screen, switch to the Installation screen.
2. Select OpenLAB CDS Installation.
   
   If OpenLAB CDS is already installed, this automatically opens the OpenLAB CDS Upgrade Wizard.

3. When upgrading from a version prior to ChemStation C.01.06, the workstation license must be upgraded see “Get Upgraded License File” on page 90.

   Acknowledge that the license has been upgraded and click Next to continue.

4. Select I agree with the terms and conditions. You cannot proceed with the upgrade unless you agree to these terms. Click Next.

5. If an Authentication Provider has been configured: Enter the username and password of a user with system administration privileges in the OpenLAB Shared Services Settings for Registration screen. Click Next.

6. In the Summary screen of the Upgrade Wizard, the components for the upgrade are listed. Click Start to proceed with the upgrade.

   If an error occurs during the upgrade, an error message appears.

7. After the upgrade is finished, select Finish to close the OpenLAB CDS Upgrade Wizard.

   Existing instrument configuration can remain unchanged after the upgrade.
Upgrade ChemStation Edition to Latest Version

Run the Upgrade Wizard

NOTE For 35900 instruments, *classic driver* is automatically installed by Master Installer. If you need to use RC.NET drivers (for example, to split channels between two instruments on an AIC), you must first install the new drivers, and then reconfigure the instruments. For details, refer to the *OpenLAB CDS ChemStation Edition Instrument Configuration Guide* under *Installation of Agilent 35900 RC.Net Driver* (CDS_CS-InstrumentConfig.pdf).

Note that methods created with the classic drivers cannot be used anymore. You will have to create new methods with RC.Net drivers.

NOTE Starting with C.01.07 SR3, classic drivers for fraction collectors are not supported. You must change your instrument configuration and create new methods with RC.NET drivers.
9

Uninstall the Software

About Uninstallation  96
Run the Master Installer  96
Run the OpenLAB CDS Uninstallation Wizard  97

This chapter contains information on the uninstallation by using the OpenLAB CDS Uninstallation Wizard. It also describes post uninstallation tasks that are essential if you plan to reinstall ChemStation on the same computer.
About Uninstallation

If the Master Installer was not used for installation, any manually installed additional software such as Headspace, PAL, or third party drivers must be uninstalled using the Windows Control Panel before the OpenLAB CDS can be uninstalled.

Like the installation, the uninstallation of OpenLAB CDS is automated by the OpenLAB CDS Master Installer.

For your convenience, the Master Installer uses the same user interfaces for the software uninstallation of all OpenLAB CDS configurations (standalone or networked workstation). The OpenLAB CDS Uninstallation Wizard under the Maintenance section of the Master Installer guides you through the uninstallation steps.

Do not use the Windows uninstallation tool for uninstalling OpenLAB CDS.

Run the Master Installer

To run the Master Installer on your workstation choose one of the following approaches:

- For the portable data storage device approach, insert the device in a computer USB port, navigate to \Disk1 and run Setup.bat to proceed to the Planning screen.
- For the share file approach, copy the contents to the local drive and navigate to the respective share file folder. Then navigate to \Disk1 and run Setup.bat to proceed to the Planning screen.
Run the OpenLAB CDS Uninstallation Wizard

1. From the Master Installer **Planning** screen, select **Maintenance** from the side bar menu.

2. Select **OpenLAB CDS Uninstallation**.
   The **OpenLAB CDS Uninstallation Wizard** opens.

3. In the **Shared Components** screen, check the **Uninstall Software Verification** check box.
   
   *Note:* Software Verification Tool needs to be uninstalled if you wish to re-install OpenLAB CDS at a later time.

4. In the **Summary** screen under **Uninstallation of OpenLAB CDS Components**, there is a list of the components you want to uninstall.

5. Select **Start** to start the uninstallation.
   
   If you want to abort the uninstallation, select **Cancel**. If you want to change any settings, select **Back**.
   
   All listed components are automatically uninstalled, one after another.

6. When the uninstallation has finished, click **Finish** to close the uninstallation wizard.
9  **Uninstall the Software**

Run the OpenLAB CDS Uninstallation Wizard
Appendix

Sales and Support Assistance 100
Sales and Support Assistance

Please check the following web site for your local sales and support contact:

In This Book

This installation guide provides instructions to install and configure the Agilent OpenLAB Chromatography Data System (CDS) workstations.