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In this Guide ...
In this Guide ...

This installation guide is designed to help system administrators and other 
users install and configure the Agilent OpenLAB Chromatography Data 
System (CDS) to Networked Workstations or Distributed Systems quickly 
and correctly.

1 Introduction

This chapter gives you an overview of the OpenLAB CDS software. It also 
includes certain requirements before starting the installation. 

2 Workflows - Overview

This chapter provides an overview of the required and optional steps for 
the installation and configuration of Networked Workstations or 
Distributed Systems.

3 Configure the Operating System

This chapter describes the configuration of the different operating systems 
for workstations, clients, and OpenLAB Shared Services servers.

Table 1 Terms and abbreviations used in this document

Term Description

ChemStation OpenLAB CDS ChemStation Edition

EZChrom OpenLAB CDS EZChrom Edition

ECM OpenLAB Enterprise Content Manager

Data Store OpenLAB Data Store

AIC Agilent Instrument Controller
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In this Guide ...
4 Install the Software

This chapter describes the preparation of third- party tool and the 
installation of OpenLAB CDS on an OpenLAB Shared Services server, 
Networked Workstation, CDS Client, or Agilent Instrument Controller.

5 Scripted Installation

This chapter describes the syntax and parameters for an installation or 
uninstallation in command line mode.

6 Optional Procedures

This chapter describes the installation of OpenLAB Data Analysis as an 
add- on or standalone application. It also contains information on the 
Additional Drivers and Software wizard, the Software Verification Tool, 
and the creation of an Enterprise Path with Advanced File Security. 

7 Upgrade to a New Software Version

This chapter describes the upgrade from different revisions to OpenLAB 
CDS A.02.02.

8 Uninstall the Software

This chapter contains information on the uninstallation by using the 
OpenLAB CDS Uninstallation Wizard.

9 Troubleshooting

The chapter gives some troubleshooting hints. 

10 Appendix

This chapter contains additional information on default settings and on 
Microsoft SQL Server 2008 R2 SP1/SP2 or SQL Server 2012.
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This chapter gives you an overview of the OpenLAB CDS software. It also 
includes certain requirements before starting the installation. 
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Who Should Read This Guide?
Who Should Read This Guide?

This installation guide is designed to help system administrators install 
and configure the Agilent OpenLAB Chromatography Data System (CDS) 
to Networked Workstations or Distributed Systems quickly and correctly.

See your Agilent representative for other system configuration installation 
guides.

Figure 1 Networked Workstation Configuration
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Figure 2 Distributed System Configuration
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1 Introduction
The Agilent OpenLAB CDS Software
The Agilent OpenLAB CDS Software

The Agilent OpenLAB CDS, along with OpenLAB Enterprise Content 
Manager (ECM) and OpenLAB Data Store plus several add- ons make up 
the Agilent OpenLAB software suite. 

The Agilent OpenLAB CDS software suite is designed to grow with 
customers' needs, from a small standalone analytical lab to a global 
network with hundreds of locations. Using the OpenLAB software, 
instruments from multiple vendors can connect to any size network — 
from individual workstations and workgroups to global enterprises. With 
full instrument control, centralized administration and ease- of- support, 
users can achieve lower operational costs and better instrument use. See 
your Agilent representative to learn how other products in the OpenLAB 
suite can help you.

The Agilent OpenLAB CDS software is provided on DVDs. The following 
table lists the disks you will receive for your software edition.

Table 2 OpenLAB CDS Components

Disk Name ChemStation Edition EZChrom Edition

OpenLAB Shared Services Software X X

OpenLAB CDS ChemStation Edition Core 
Software

X

OpenLAB CDS ChemStation Edition Drivers X

OpenLAB CDS EZChrom Edition Core 
Software

X

OpenLAB CDS EZChrom Edition Drivers X

OpenLAB Support & Utilities X X

OpenLAB Data Analysis1

1 Only supported with an OpenLAB CDS Workstation, or with OpenLAB CDS EZChrom systems using 
an Enterprise Path without Advanced File Security. 

X X
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Introduction 1
Before You Begin
Before You Begin

To simplify installation of the software, it is helpful to decide on some 
configuration options before you begin the actual software installation.

1 For installing OpenLAB CDS, you need to have administrator privileges 
for all servers and clients. Power user privileges are not sufficient (the 
installation does not start).

2 Decide on a Shared Services server and a directory location to store all 
files related to the data system software, including data, methods, 
sequences, and configurations.

• CDS clients must be connected via network to the Shared Services 
server.

• If you plan to use a central data storage, CDS client users must have 
read/write access to the repository location.

• If you plan to use the Oracle DB server, make sure to set up the 
Oracle database as described in CDS_oracle12.pdf on Disk1/docs/enu.

3 If you are installing OpenLAB CDS EZChrom Edition, create an 
Enterprise path folder on the file server, with a share status Everyone > 
Full permissions (see “Create and Configure an Enterprise Path for 
EZChrom Edition” on page 43). Because the system must access this 
folder as a uniform naming convention (UNC) share path, it must be 
created prior to actual installation. UNC paths define the common 
syntax pattern for share folder location and retrieval.

4 For the Shared Services database, obtain the:

• Database name

• Database administrator user name and password

• Authentication mode

• Administrator user credentials (domain, user name, password)

5 If you plan to use OpenLAB Data Store, refer to the Data Store 
documentation.

6 If you plan to use OpenLAB ECM with your system, obtain the ECM 
server name.
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1 Introduction
Before You Begin
7 In order to install and configure OpenLAB ECM (Shared Services 
configuration on the server) the installing user must be both ECM 
administrator as well as internal OpenLAB Shared Services 
administrator.

8 Only for Distributed Systems with EZChrom: Create and define the 
service account of a domain user for the Agilent Instrument Controller 
(AIC) configuration. You will need to enter this service account 
information after you install the first AIC in your system.

9 Decide on the software delivery approach you want to use:

• Install directly from the DVDs to your computer — Load the disks as 
required directly to the workstation disk drive. (Recommended)

• Copy DVDs to a network share folder for installation — You can use 
the utility to copy DVD content to a network share folder or USB 
drive, and run an uninterrupted installation from that location. This 
approach will save time; when you install from the folder, you won’t 
have to reload the disks. However, some networks may interfere with 
installation.

10 Remember that when you launch the application, you will be able to 
review the following PDFs in the installer Planning and Resources menus 
before you install the software:

Under the Installer Planning menu, you will find:

• Hardware and Software Requirements—Use this PDF to determine 
whether your hardware and software will support the system.

• Installation Guide for Networked or Distributed Systems—An 
electronic copy of this installation guide is provided in PDF format 
for your convenience.

Under the Installer Resources menu, you will find:

• OpenLAB CDS Network Requirements—Use this PDF to check that 
your settings comply with the network requirements.

11 Set up the necessary power, equipment and hardware connections to 
run your system. Connections could include any A/D boards, cables, 
GPIB boards, instrument detectors, and communication cables. For 
detailed requirements, refer to the OpenLAB CDS Network 
Requirements guide.
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2
Workflows - Overview

Networked Workstation 14

ChemStation Edition or EZChrom Edition 14

Data Analysis Workstation 15

Distributed System 16

ChemStation Edition or EZChrom Edition 16

Data Analysis Only Client 17

This chapter provides an overview of the required and optional steps for the 
installation and configuration of Networked Workstations or Distributed 
Systems.
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2 Workflows - Overview
Networked Workstation
Networked Workstation

ChemStation Edition or EZChrom Edition

Follow these steps to install OpenLAB CDS ChemStation or EZChrom 
Edition on a networked system.

Prerequisites If you want to connect to an OpenLAB ECM server or an OpenLAB Data Store server, this 
server must already exist.

1 On the OpenLAB Shared Services server:

“Configure Windows Server 2012 R2” on page 22

OR

“Configure Windows Server 2008 R2 SP1” on page 25

2 For EZChrom Edition without ECM or Data Store: “Create and 
Configure an Enterprise Path for EZChrom Edition” on page 43.

3 On the Workstation PCs:

“Configure Windows 8.1” on page 29

OR

“Configure Windows 7” on page 35

4 These steps are optional:

a “Copy DVDs to a Centralized Folder for Installation” on page 48.

b “Run the System Configuration Checker” on page 49.

c “Prepare the Third Party Tools” on page 51.

5 “Install OpenLAB CDS on the Server” on page 53.

6 “Set up the Authentication Provider and Storage Location” on page 58.

Alternatively, this can also be done after the installation is complete.

7 “Install OpenLAB CDS on a Networked Workstation” on page 61.

8 After installation: “Configure the Antivirus Program” on page 79 .
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Workflows - Overview 2
Networked Workstation
Data Analysis Workstation

OpenLAB Data Analysis Workstation

Follow these steps to install the new and enhanced OpenLAB Data 
Analysis as stand- alone application (that is, without ChemStation or 
EZChrom) on a networked system.

Prerequisites An OpenLAB Shared Services server and an Enterprise Path must already exist.

1 On the Workstation PCs:

“Configure Windows 8.1” on page 29

OR

“Configure Windows 7” on page 35

2 “Install OpenLAB Data Analysis as Add- on or Stand- alone 
Application” on page 92.

3 After installation: “Configure the Antivirus Program” on page 79 .

ChemStation Data Analysis Only Workstation

For a ChemStation Data Analysis Only Workstation, the installation 
workflow is the same as for OpenLAB CDS ChemStation Edition. You 
simply configure a specific DA- only instrument afterwards. There are 
several instrument types with (DA-only) in the type name.

NOTE OpenLAB Data Analysis does not support systems using ECM or Data Store as a central 
data storage.
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2 Workflows - Overview
Distributed System
Distributed System

ChemStation Edition or EZChrom Edition

Follow these steps to install OpenLAB CDS ChemStation or EZChrom 
Edition on a Distributed System.

Prerequisites If you want to connect to an OpenLAB ECM server or OpenLAB Data Store, this server must 
already exist.

1 On the OpenLAB Shared Services server:

“Configure Windows Server 2012 R2” on page 22

OR

“Configure Windows Server 2008 R2 SP1” on page 25

2 For EZChrom Edition without ECM or Data Store: “Create and 
Configure an Enterprise Path for EZChrom Edition” on page 43.

3 Configure the AIC. If you purchased an Agilent ChemStation AIC 
bundle system, see ChemStation Edition AIC (M8304AA) Setup Guide.

4 On the OpenLAB CDS Clients:

“Configure Windows 8.1” on page 29

OR

“Configure Windows 7” on page 35

5 These steps are optional:

a “Copy DVDs to a Centralized Folder for Installation” on page 48.

b “Run the System Configuration Checker” on page 49.

c “Prepare the Third Party Tools” on page 51.

6 “Install OpenLAB CDS on the Server” on page 53.

7 “Install OpenLAB CDS on a CDS Client” on page 67.

8 “Install OpenLAB CDS on an Instrument Controller (AIC)” on page 72.
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Workflows - Overview 2
Distributed System
9 In a Distributed System, you can also install Networked Workstations in 
addition to the AIC and OpenLAB CDS Clients, thus creating a mixed 
topology. For more information on Networked Workstations in 
Distributed Systems, refer to the OpenLAB CDS Administration Guide.

10 After installation: “Configure the Antivirus Program” on page 79 .

Data Analysis Only Client

OpenLAB Data Analysis

Follow these steps to install OpenLAB Data Analysis as stand- alone 
application on a Distributed System.

Prerequisites An OpenLAB Shared Services server and an Enterprise Path must already exist.

1 On the OpenLAB CDS Clients:

“Configure Windows 8.1” on page 29

OR

“Configure Windows 7” on page 35

2 “Install OpenLAB Data Analysis as Add- on or Stand- alone 
Application” on page 92.

3 After installation: “Configure the Antivirus Program” on page 79 .

ChemStation Data Analysis Only Client

There is no specific ChemStation Data Analysis Only Client in a 
Distributed System. It makes no difference if you use a client only for data 
analysis or also for acquisition. All instruments (including the ones with 
(DA-only) instrument types) are configured on the AIC.

NOTE OpenLAB Data Analysis does not support systems using ECM or Data Store as a central 
data storage.
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2 Workflows - Overview
Distributed System
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3
Configure the Operating System

About Configuration 20

Security Notes 21

Configure Windows Server 2012 R2 22

Configure Windows Server 2008 R2 SP1 25

Configure Windows 8.1 29

Edit the Security Settings for LC/MS and CE/MS Systems 33

Configure Windows 7 35

Using the OpenLAB CDS Configuration Checker 35

Configure Windows 36

Edit the Security Settings for LC/MS and CE/MS Systems 41

Create and Configure an Enterprise Path for EZChrom Edition 43

Create and Share a Folder on Windows Server 43

Configure an Enterprise Path on a Windows Server 44

This chapter describes the configuration of the different operating systems for 
workstations, clients, and OpenLAB Shared Services servers.
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3 Configure the Operating System
About Configuration
About Configuration

The procedures in this document describe all parameters necessary to 
configure a non- Agilent Windows system for use with OpenLAB CDS.

OpenLAB CDS needs to be installed using an operating system 
Administrator user account. To run the system with the configured 
options outlined in this document, all users and power users should use 
the same settings.

Some changes within this document are mandatory for OpenLAB CDS to 
work properly on a Windows system. Some changes will optimize 
application performance. Other changes will have a graphical or minor 
impact. To indicate the relative importance of individual settings, each 
item is categorized as:

• MUST: These changes must be applied.

• PERFORMANCE: These changes will improve system performance.

• OPTIONAL: Most of these changes will affect the graphical display of 
the application.

NOTE If User Account Control (UAC) is switched on, some configuration steps will require active 
confirmation to continue.

NOTE For all server-based products, dedicated servers are strongly recommended to avoid 
conflicts with other applications and maximize performance.
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Configure the Operating System 3
Security Notes
Security Notes

• Install Windows from the Microsoft installation media. During the setup, 
provide the computer name, administrator password and network 
settings. Choose to either join an existing domain or set up the system 
in a workgroup mode.

• On the OpenLAB Shared Services server, do not install or configure any 
server role or feature.

• To secure your system against viruses please install an antivirus 
program. Be sure to open the firewall ports listed in the Firewall 
Settings in the OpenLAB CDS Network Requirements guide.

NOTE Keep your computer disconnected from the internet until you have installed the appropriate 
security patches and hot fixes. It is strongly recommended to install the latest security fixes 
as supported from Agilent Technologies and virus definitions prior to connecting to a 
network.

NOTE Running antivirus programs might influence the behavior and performance of your 
computer. Some virus scanners might cause issues when used with OpenLAB CDS. 
OpenLAB CDS was tested to run with Symantec's Endpoint Protection.
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3 Configure the Operating System
Configure Windows Server 2012 R2
Configure Windows Server 2012 R2

[MUST] 1 Go to Start > Control Panel > System1, and activate Windows.

[MUST] 2 Explorer and Folder Options (right- click Start > Open Windows Explorer): 
Check the following default settings.

a Choose Organize > Layout.

• Enable Menu Bar.

• Enable Navigation Panel.

b Set View to Details.

c Click View > Options to open the Folder Options dialog. In the View tab,

• Clear Hide extensions for known file types.

• Enable Display the full path in the title bar (Classic them only).

d Apply these settings to all folders by selecting the Apply to Folders 
button.

[MUST] 3 Go to Start > Control Panel > Windows Update.

a Check for updates and apply all critical security patches.

b Click Change Settings. Set the Important updates selection to Never check 
for updates. Deselect the other update options.

[MUST] 4 Disable Services (Go to Control Panel > Administrative Tools):

a Double- click Services.

b Double- click the Application Experience service. Set the startup type to 
Disabled.

[MUST] 5 Adjust Power Options (Go to Control Panel > Power Options):

a Enable power plan High performance (Show additional plans).

b Click Change Plan settings.

c Click Change advanced power settings.

d Open the nodes for Hard disk, Turn off hard disk after and check that 
Minutes are set to 0 (=Never).

1 View the items by icon to see a list of all items.
22 CDS Networked and Distributed System Installation and Configuration



Configure the Operating System 3
Configure Windows Server 2012 R2
[MUST] 6 Local Security Policy: (Control Panel > Administrative Tools > Local Security 
Policy)

a Navigate to Security Settings > Local Policies > Security Options.

b Double- click the following policy listed in the right hand panel: 
Network Access: Sharing and security model for local accounts.

c In the displayed dialog select the following item from the drop- down 
list: Classical - local users authenticate as themselves.

[MUST] 7 Region and Language (Go to Control Panel > Region).

a Regional options should be set to English (United States) from the 
drop- down list.

b If regional format other than English (United States) is used, the 
following settings are mandatory. The settings can be defined by 
clicking the Additional settings... button:

• Decimal symbol = . (point)

• Digit grouping symbol = , (comma)

• List separator = , (comma)

c Language for non- Unicode programs:

• On the Administrative tab click Change system locale....

• From the drop- down list, select English (United States).

[MUST] 8 Time Zone (Control Panel > Date and Time > Change time zone): We recommend 
to use the same time zone for server and clients.

[MUST] 9 Power Management for network devices (From Control Panel > Network and 
Sharing Center):

a Select Change adapter settings.

b Right- click Ethernet, then select Properties.

c Click Configure.

d On the Power Management tab, uncheck all items.

[MUST] 10 Screen layout (right- click on Control Panel > Display):

a Click Change window colors.

b Make sure that Windows Basic is selected.
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3 Configure the Operating System
Configure Windows Server 2012 R2
[MUST] 11 .NET settings (Go to Control Panel > Programs and Features):

a Click Turn Windows features on or off.

b Enable .NET 3.5 by selecting the .NET Framework 3.5 (includes .NET 2.0 and 
3.0) check box.

This option requires an internet connection.

c To make sure that all the net.tcp components are properly initialized, 
non- http activation must be enabled. Expand the .NET Framework 3.5 
(includes .NET 2.0 and 3.0) node and select the Windows Communication 
Foundation Non-HTTP Activation check box.

[PERFORMANCE] 12 System Properties: Control Panel > System: click Advanced system settings.

a On the Advanced tab > Performance hit the Settings button.

• Visual Effects tab, uncheck all entries.

• Advanced tab > Virtual Memory: For optimum performance use the 
Change button to adjust the paging file size to a value of 2 to 3 
times of the physical RAM on the PC.

• Data Execution Prevention tab: Enable Turn on DEP for essential Windows 
programs and services only.

b Advanced > Startup and Recovery > Settings button:

• System startup section: Change both Time to display ... fields from 30 
to 3 sec.

[OPTIONAL] 13 Recycle Bin Properties: (right- click on desktop icon Recycle Bin). 
Enable the following options:

• Custom size; select a size corresponding to approximately 10% of the 
complete disk space for the drive.

• Check Display delete confirmation dialog.

[OPTIONAL] 14 For OpenLAB CDS ChemStation Edition: Apply the security settings for 
Terminal Services suggested by Microsoft at: 
http://technet.microsoft.com/en- us/library/cc264467.aspx

NOTE If the computer has no internet access, .NET Framework 3.5 will not install. For more details 
see http://support.microsoft.com/kb/2785188.
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Configure the Operating System 3
Configure Windows Server 2008 R2 SP1
Configure Windows Server 2008 R2 SP1

[MUST] 1 Go to Start > Control Panel > System1, and activate Windows.

[MUST] 2 Explorer and Folder Options (right- click Start > Open Windows Explorer):

a Choose Organize > Layout.

• Enable Menu Bar.

• Enable Navigation Panel.

b Set View to Details.

c Choose Tools > Folder Options > View tab.

• Disable the option Hide extensions for known file types.

• Enable the option Display the full path in the title bar (Classic theme only).

d Apply these settings to all folders by selecting the Apply to Folders 
button.

[MUST] 3 Go to Start > Control Panel > Windows Update.

a Check for updates and apply all critical security patches.

b Click Change Settings. Set the Important updates selection to Never check 
for updates. Deselect the other update options.

[MUST] 4 Go to Control Panel > Administrative Tools. Select Services.

a Right click on the Desktop Window Manager Session Manager service. In 
the context menu select Properties.

• Set the startup type to Disabled.

b Right- click on the Application Experience service. In the context menu, 
select Properties.

• Set the startup type to Disabled.

Confirm by clicking OK and close the Services window. Close 
Administrative Tools.

1 View the items by icon to see a list of all items.
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3 Configure the Operating System
Configure Windows Server 2008 R2 SP1
[MUST] 5 Adjust Power Options (Go to Control Panel > Power Options):

a Enable power plan High performance (Show additional plans).

b Click Change Plan settings.

c Click Change advanced power settings.

d Open the nodes for Hard disk, Turn off hard disk after and check that 
Minutes are set to 0 (=Never).

[MUST] 6 Local Security Policy: (Control Panel > Administrative Tools > Local Security 
Policy)

a Navigate to Security Settings > Local Policies > Security Options.

b Double- click the following policy listed in the right hand panel: 
Network Access: Sharing and security model for local accounts.

c In the displayed dialog select the following item from the drop- down 
list: Classical - local users authenticate as themselves.

[MUST] 7 Region and Language Options (Control Panel > Regional and Language 
Options):

a Regional options should be set to English (United States) from the 
drop- down list.

b If regional format other than English (United States) is used, the 
following settings are mandatory. The settings can be defined by 
clicking the Customize this format button:

• Decimal symbol = . (point)

• Digit grouping symbol = , (comma)

• List separator = , (comma)

c Language for non- Unicode programs:

• On the Administrative tab click Change system locale....

• From the drop- down list, select English (United States).

[MUST] 8 Time Zone (Control Panel > Date and Time > Change time zone): We recommend 
to use the same time zone for server and clients.
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Configure the Operating System 3
Configure Windows Server 2008 R2 SP1
[MUST] 9 Power Management for network devices (From Control Panel > Network and 
Sharing Center):

a Select Change adapter settings.

b Right- click Ethernet, then select Properties.

c Click Configure.

d On the Power Management tab, uncheck all items.

[MUST] 10 Screen layout (right- click on Control Panel > Display):

a Click Change window colors.

b Make sure that Windows Basic is selected.

[MUST] 11 Enable non- http activation (Go to Control Panel > Programs and Features):

a Click Turn Windows features on or off.

b Expand the Microsoft .NET Framework 3.5.1 node and select the Windows 
Communication Foundation Non-HTTP Activation check box.

[PERFORMANCE] 12 System Properties: Control Panel > System: click Advanced system settings.

a On the Advanced tab > Performance hit the Settings button.

• Visual Effects tab, uncheck all entries.

• Advanced tab > Virtual Memory: For optimum performance use the 
Change button to adjust the paging file size to a value of 2 to 3 
times of the physical RAM on the PC.

• Data Execution Prevention tab: Enable Turn on DEP for essential Windows 
programs and services only.

b Advanced > Startup and Recovery > Settings button:

• System startup section: Change both Time to display ... fields from 30 
to 3 sec.

[OPTIONAL] 13 Welcome Center (Start > search for 'gpedit.msc')

• Navigate to Local Computer Policy > Computer Configuration > Administrative 
Templates > System > Logon.

• Enable Don't display the Getting Started welcome screen at logon.
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[OPTIONAL] 14 Recycle Bin Properties: (right- click on desktop icon Recycle Bin). 
Enable the following options:

• Custom size; select a size corresponding to approximately 10% of the 
complete disk space for the drive.

• Check Display delete confirmation dialog.

[OPTIONAL] 15 For OpenLAB CDS ChemStation Edition: Apply the security settings for 
Terminal Services suggested by Microsoft at: 
http://technet.microsoft.com/en- us/library/cc264467.aspx
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Configure Windows 8.1

[MUST] 1 Go to Start > Control Panel > System1, and register Windows with Microsoft.

[MUST] 2 Folder Options (Go to Start > Control Panel > Folder Options): In the View 
tab,

• Clear Hide extensions for known file types.

• Enable Display the full path in the title bar.

• Clear Use Sharing Wizard.

[MUST] 3 Check for updates and apply all critical security patches (Go to Control 
Panel > Windows Update):

Click Check for updates.

[MUST] 4 Settings for updates (Go to Control Panel > Windows Update):

Click Change settings. In the Important updates section, select Never check for 
updates. Clear the other update options. 

[MUST] 5 Disable Services (Go to Control Panel > Administrative Tools):

a Double- click Services.

b Double- click the Application Experience service. Set the startup type to 
Disabled.

[MUST] 6 Disable indexing (Go to Control Panel > Indexing Options):

Click the Modify button. Clear all drives and locations. 

1 View the items by icon to see a list of all items.

NOTE This setting is important to avoid data loss due to system reboot during data acquisition.
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[MUST] 7 Adjust Power Options (Go to Control Panel > Power Options):

a As preferred plan select High performance

b Click Change Plan settings

c Set the option Put the computer to sleep to Never.

d Click Change advanced power settings. 

e Open the nodes for Hard disk > Turn off hard disk after.

f Set the Minutes to 0 (=Never).

[MUST] 8 Local Security Policy: (Go to Control Panel > Administrative Tools):

a Double- click Local Security Policy.

b Navigate to Security Settings > Local Policies > Security Options

c Double- click the following policy listed in the right hand panel: 
Network Access: Sharing and security model for local accounts

d In the displayed dialog select the following item from the drop- down 
list: Classic - local users authenticate as themselves

[MUST] 9 Region settings (Go to Control Panel > Region).

a Regional options should be set to English (United States) from the 
drop- down list. 

b If regional format other than English (United States) is used, the 
following settings are mandatory. The settings can be defined by 
clicking on the Additional settings... button:

• Decimal symbol = . (point)

• Digit grouping symbol = , (comma)

• List separator =, (comma)

[MUST] 10 Time Zone (Go to Control Panel > Date and Time): Choose the time zone of 
your machine's location.

[MUST] 11 Power Management for network devices (Go to Control Panel > Network and 
Sharing Center):

a Select Change adapter settings. Right- click Local Area Connection > 
Properties > Configure.

b On the Power Management tab, clear all check boxes. 
30 CDS Networked and Distributed System Installation and Configuration



Configure the Operating System 3
Configure Windows 8.1
[MUST] 12 .NET settings (Go to Control Panel > Programs and Features):

a Click Turn Windows features on or off.

b Enable .NET 3.5 by selecting the .NET Framework 3.5 (includes .NET 2.0 and 
3.0) check box.

This option requires an internet connection.

c To make sure that all the net.tcp components are properly initialized, 
non- http activation must be enabled. Expand the .NET Framework 3.5 
(includes .NET 2.0 and 3.0) node and select the Windows Communication 
Foundation Non-HTTP Activation check box.

[MUST] 13 Disable Compatibility View in Internet Explorer.

a Open Internet Explorer.

b Click the Tools menu, and then click Compatibility View Settings. 

c Clear the Display intranet sites in Compatibility View check box.

[PERFORMANCE] 14 Performance options (Go to Control Panel > System):

a Click Advanced system settings.

b On the Advanced  tab > Performance click Settings.

c On the Visual Effects tab, select Adjust for best performance.

d Save the settings.

[PERFORMANCE] 15 System Properties (Go to Control Panel > System):

a Click Advanced system settings.

b On the Advanced tab > Performance click Settings. 

• Advanced tab > Virtual Memory: For optimum performance use the 
Change button to adjust the paging file size to a value of 2 to 3 
times of the physical RAM on the PC. If possible locate the paging 

NOTE If the computer has no internet access, .NET Framework 3.5 will not install. For more details 
see http://support.microsoft.com/kb/2785188.

NOTE This step is only required if you use OpenLAB Data Store.
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file on a drive different from system and ChemStation installation 
drive.

• Data Execution Prevention tab: Select Turn on DEP for essential Windows 
programs and services only.

c Advanced > Startup and Recovery > Settings button:

• System startup section: 

Change both Time to display ... fields from 30 to 3 sec. 

• System failure section: 

Select Automatically restart, in the Write debugging information section 
select Kernel memory dump from the drop- down list.

d Remote tab

• In the Remote Assistance section, clear the check box Allow Remote 
Assistance connections to this computer. 

• In the Remote Desktop section, select Don't allow connections to this 
computer. 

[OPTIONAL] 16 Welcome Center (Start > search for 'gpedit.msc'):

a Navigate to Local Computer Policy > Computer Configuration > Administrative 
Templates > System > Logon.

b Set Don't display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 17 Recycle Bin Properties: (right- click on desktop icon Recycle Bin) Select the 
following options: 

• Custom size: Select a size corresponding to approximately 10% of the 
complete disk space for the drive.

• Select Display delete confirmation dialog.

Repeat these steps for all drives of your computer.

[OPTIONAL] 18 Language for non- Unicode programs (Go to Control Panel > Region): On 
the Administrative tab, click Change system locale.... From the drop down 
list, select English (United States)

NOTE Do not the change system locale if you are using an English, Japanese or Chinese 
Operating System. 
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Edit the Security Settings for LC/MS and CE/MS Systems

The following sections summarize all security settings required for LC/MS 
and CE/MS. All other security settings are set automatically by the 
OpenLAB CDS Master Installer.

OpenLAB CDS needs to be installed using an operating system 
Administrator user account. To run the system with the configured 
options outlined in this document, all users and power users should use 
the same settings.

Firewall

On PCs controlling LC/MS or CE/MS systems, it is recommended to turn 
off the firewall.

Advanced Network Settings

The communication with the MS is sensitive to the order NICs in the 
Adapters and Bindings dialog.

1 Go to Start > Control Panel.

Go to Network and Sharing Center1.

2 Click Change adapter settings.

3 Press ALT to bring up the menu.

1 View the items by icon to see a list of all items.
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4 Select Advanced Settings....

Figure 3 Advanced Settings dialog, Adapters and Bindings tab

5 In the Adapters and Bindings tab (see Figure 3 on page 34):

a Make sure that the Local Area Connection pertaining to the LC/MS 
or CE/MS NIC is the first item in the list of connections

NOTE The names of your LAN cards may differ from those shown in the example. You can tell 
which LAN card is the Instrument LAN by comparing the IP addresses assigned to the LAN 
cards.

The LAN pertaining to the company intranet > internet will typically have an IP address 
assigned by organizations Static IP policy or by a DHCP server. Check with your network 
administrator.
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Using the OpenLAB CDS Configuration Checker

The OpenLAB CDS Configuration Checker checks and repairs all 
mandatory settings. It does not check optional settings or settings that 
improve the performance.

The OpenLAB CDS Configuration Checker comes as .diagcab file, which is a 
file format used with the Microsoft Windows Troubleshooting Platform 
(WTP) program. The Microsoft Windows Troubleshooting Platform (WTP) is 
a platform to locate and fix hardware and software settings in Windows. 
It is used specifically for diagnosing and repairing computer settings.

In general, .diagcab files are useful for deploying troubleshooting packs 
because they are self- contained and require no installation. They can be 
deployed onto web sites, network shares, or copied to USB keys. The 
.diagcab file name extension is a registered file name extension that can 
be executed by WTP.

To start the OpenLAB CDS Configuration Checker, call the file 
Agilent.Wtp.ChemStation.WindowsConfiguration.diagcab. This file is located on the 
OpenLAB CDS disc 6 under Tools\OpenLAB CDS ChemStation Edition\Diagnostics\
WindowsConfiguration\Cab\

NOTE This tool is only available for OpenLAB CDS ChemStation Edition on Windows 7.

NOTE While using the Configuration Checker:

• Ensure that this computer is not turned off by another user.

• Ensure that the menu bar is enabled.
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Configure Windows

[MUST] 1 Go to Start > Control Panel > System1, and register Windows with Microsoft.

[MUST] 2 Folder Options (Go to Start > Control Panel > Folder Options): In the View 
tab,

• Clear Hide extensions for known file types.

• Enable Display the full path in the title bar.

• Clear Use Sharing Wizard.

[MUST] 3 Check for updates and apply all critical security patches (Go to Control 
Panel > Windows Update):

Click Check for updates.

[MUST] 4 Settings for updates (Go to Control Panel > Windows Update):

Click Change settings. In the Important updates section, select Never check for 
updates. Clear the other update options. 

[MUST] 5 Disable Services (Go to Control Panel > Administrative Tools):

a Double- click Services.

b Double- click the following services and set their startup type to 
Disabled:

• Application Experience

• Desktop Window Manager Session Manager 

[MUST] 6 Disable indexing (Go to Control Panel > Indexing Options):

Click the Modify button. Clear all drives and locations. 

1 View the items by icon to see a list of all items.

NOTE This setting is important to avoid data loss due to system reboot during data acquisition.
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7 Windows logon options (Start > search for 'gpedit.msc')

[MUST] a Navigate to Local Computer Policy > Computer Configuration > Administrative 
Templates > System > Logon.

b Set Hide entry points for Fast User Switching and Always use classic logon to 
Enabled.

[MUST] 8 Adjust Power Options (Go to Control Panel > Power Options):

a As preferred plan select High performance

b Click Change Plan settings

c Set the option Put the computer to sleep to Never.

d Click Change advanced power settings. 

e Open the nodes for Hard disk > Turn off hard disk after.

f Set the Minutes to 0 (=Never).

[MUST] 9 Local Security Policy: (Go to Control Panel > Administrative Tools):

a Double- click Local Security Policy.

b Navigate to Security Settings > Local Policies > Security Options

c Double- click the following policy listed in the right hand panel: 
Network Access: Sharing and security model for local accounts

d In the displayed dialog select the following item from the drop- down 
list: Classic - local users authenticate as themselves

[MUST] 10 Region and Language (Go to Control Panel > Region and Language).

a Regional options should be set to English (United States) from the 
drop- down list. 

b If regional format other than English (United States) is used, the 
following settings are mandatory. The settings can be defined by 
clicking on the Additional settings... button:

• Decimal symbol = . (point)

• Digit grouping symbol = , (comma)

• List separator =, (comma)

[MUST] 11 Time Zone (Go to Control Panel > Date and Time): Choose the time zone of 
your machine's location.
CDS Networked and Distributed System Installation and Configuration 37



3 Configure the Operating System
Configure Windows 7
[MUST] 12 Power Management for network devices (Go to Control Panel > Network and 
Sharing Center):

a Select Change adapter settings. Right- click Local Area Connection > 
Properties > Configure.

b On the Power Management tab, clear all check boxes. 

[MUST] 13 Enable non- http activation (Go to Control Panel > Programs and Features):

a Click Turn Windows features on or off.

b Expand the Microsoft .NET Framework 3.5.1 node and select the Windows 
Communication Foundation Non-HTTP Activation check box.

[MUST] 14 Disable Compatibility View in Internet Explorer.

a Open Internet Explorer.

b Click the Tools menu, and then click Compatibility View Settings. 

c Clear the Display intranet sites in Compatibility View check box.

[PERFORMANCE] 15 Performance options (Go to Control Panel > System):

a Click Advanced system settings.

b On the Advanced  tab > Performance click Settings.

c On the Visual Effects tab, select Adjust for best performance.

d Save the settings.

NOTE This step is only required if you use OpenLAB Data Store.
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[PERFORMANCE] 16 System Properties (Go to Control Panel > System):

a Click Advanced system settings.

b On the Advanced tab > Performance click Settings. 

• Advanced tab > Virtual Memory: For optimum performance use the 
Change button to adjust the paging file size to a value of 2 to 3 
times of the physical RAM on the PC. If possible locate the paging 
file on a drive different from system and ChemStation installation 
drive.

• Data Execution Prevention tab: Select Turn on DEP for essential Windows 
programs and services only.

c Advanced > Startup and Recovery > Settings button:

• System startup section: 

Change both Time to display ... fields from 30 to 3 sec. 

• System failure section: 

Select Automatically restart, in the Write debugging information section 
select Kernel memory dump from the drop- down list.

d Remote tab

• In the Remote Assistance section, clear the check box Allow Remote 
Assistance connections to this computer. 

• In the Remote Desktop section, select Don't allow connections to this 
computer. 

[OPTIONAL] 17 General Layout: (right- click Start  > Properties)

a Start Menu Tab: In the Privacy section select both items

b Start Menu Tab > Customize button: In Customize Start Menu dialog: 

• Clear the following option:

• Favorites menu

• Select the following options:

• Computer Display as a link

• Connect To

• Control Panel: Display as a menu

• Default Programs

• Devices and Printers

• Documents: Display as a link
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• Enable context menus and dragging and dropping

• Games: Don't display this item

• Help

• Highlight newly installed programs

• Music: Don't display this item

• Network

• Open submenus when I pause on them with the mouse pointer

• Personal folder: Display as a link

• Pictures: Display as a link

• Run command

• Search other files and libraries Search with public folders

• Search programs and Control Panel

• Sort All Programs menu by name

• System administrative tools: Display on the All Programs menu and in 
the Start menu

• Use large icons

[OPTIONAL] 18 Welcome Center (Start > search for 'gpedit.msc'):

a Navigate to Local Computer Policy > Computer Configuration > Administrative 
Templates > System > Logon.

b Set Don't display the Getting Started welcome screen at logon to Enabled.

[OPTIONAL] 19 Recycle Bin Properties: (right- click on desktop icon Recycle Bin) Select the 
following options: 

• Custom size: Select a size corresponding to approximately 10% of the 
complete disk space for the drive.

• Select Display delete confirmation dialog.

Repeat these steps for all drives of your computer.

[OPTIONAL] 20 Language for non- Unicode programs (Go to Control Panel > Region and 
Language): On the Administrative tab, click Change system locale.... From the 
drop down list, select English (United States)

NOTE Do not the change system locale if you are using an English, Japanese or Chinese 
Operating System. 
40 CDS Networked and Distributed System Installation and Configuration



Configure the Operating System 3
Configure Windows 7
Edit the Security Settings for LC/MS and CE/MS Systems

The following sections summarize all security settings required for LC/MS 
and CE/MS. All other security settings are set automatically by the 
OpenLAB CDS Master Installer.

OpenLAB CDS needs to be installed using an operating system 
Administrator user account. To run the system with the configured 
options outlined in this document, all users and power users should use 
the same settings.

Firewall

On PCs controlling LC/MS or CE/MS systems, it is recommended to turn 
off the firewall.

Advanced Network Settings

The communication with the MS is sensitive to the order NICs in the 
Adapters and Bindings dialog.

1 Go to Start > Control Panel.

Go to Network and Sharing Center1.

2 Click Change adapter settings.

3 Press ALT to bring up the menu.

1 View the items by icon to see a list of all items.
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4 Select Advanced Settings....

Figure 4 Advanced Settings dialog, Adapters and Bindings tab

5 In the Adapters and Bindings tab (see Figure 4 on page 42):

a Make sure that the Local Area Connection pertaining to the LC/MS 
or CE/MS NIC is the first item in the list of connections

NOTE The names of your LAN cards may differ from those shown in the example. You can tell 
which LAN card is the Instrument LAN by comparing the IP addresses assigned to the LAN 
cards.

The LAN pertaining to the company intranet > internet will typically have an IP address 
assigned by organizations Static IP policy or by a DHCP server. Check with your network 
administrator.
42 CDS Networked and Distributed System Installation and Configuration



Configure the Operating System 3
Create and Configure an Enterprise Path for EZChrom Edition
Create and Configure an Enterprise Path for EZChrom Edition

In the Windows Server 2008 version, new caching and enumeration 
features for file sharing were introduced. These features are not supported 
by OpenLAB CDS EZChrom Edition and must be disabled on the shared 
Enterprise Path.

When using a Windows Server 2008 or 2012 operating system to host the 
Enterprise Path of an OpenLAB CDS EZChrom Edition networked or 
distributed system, the following steps are required to allow a proper 
operation.

Create and Share a Folder on Windows Server

1 Create the shared folder. For example, D:\Share1.

2 Right- click the newly created folder and click Properties.

3 Select the Sharing tab.

4 To set share permissions, click the Advanced Sharing button.

5 Select the Share this folder check box.

6 Click the Permissions button.

7 To give full permission on the folder, click Everyone in the group name 
field and click the Add... button.

The created folder is shared.
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Configure an Enterprise Path on a Windows Server

1 To edit the Enterprise Path in its current state, obtain the login 
credentials of a domain user that has administrative rights.

2 Log in to the server hosting the shared folder.

3 To launch the management window, click Start > Administrative Tools > 
Server Manager.

4 Windows Server 2012 R2:

a From the navigation pane, select File and Storage Services, then click 
Shares.

b Right- click the share name, for example Share1, and select Properties 
from the context menu.

c In the navigation pane, click Settings.

d Clear the Enable access-based enumeration check box.

e Clear the Allow caching of share check box.

5 Windows Server 2008 R2 SP1:

a From the navigation pane, select Roles > File Services > Share and Storage 
Management.

b Right- click the share name, for example Share1, and select Properties 
from the context menu.

c On the Sharing tab, click the Advanced button.

d Clear the Enable access-based enumeration check box.

e On the Caching tab, select No files or programs from the share are available 
offline.

6 Save the settings.

The share folder is ready to be used as Enterprise Path.

Preparations • You have created and shared a folder. 
• The Advanced File Security (AFS) is disabled.
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This chapter describes the preparation of third-party tool and the installation of 
OpenLAB CDS on an OpenLAB Shared Services server, Networked 
Workstation, CDS Client, or Agilent Instrument Controller.
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Run the Application

To run the application for the first time on a server computer or 
networked workstation:

1 For the direct DVD approach, insert the OpenLAB CDS Installation disk 
(Disk1). The Planning screen starts automatically after inserting the DVD.

If the installer is not launched automatically, run Autorun.inf to open this 
screen.

2 For the portable data storage device approach, insert the device in a 
computer USB port, navigate to \Disk1\Setup.bat and run the application 
to proceed to the Planning screen.

3 For the share file approach, copy all DVDs to a centralized folder as 
described in Step 2 below.
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Copy DVDs to a Centralized Folder for Installation

Completing this step will enable you to run an uninterrupted installation 
directly from a folder—i.e., you will not have to load individual disks 
during actual installation.

1 From the Master Installer Planning screen, select Installation from the 
sidebar menu.

2 Select Preparation of an Installation from Network Share.

3 At the Network Share screen, browse to a directory and create a 
destination folder as follows:

a Select the button with the three dots.

b Navigate to the directory where you want to create the folder (you 
can navigate to a USB drive port to create the folder on a USB 
drive).

c Select Make New Folder.

d Type in the folder name.

e Select OK. The system will return you to the Network Share screen, 
with the path displayed.

f Select the disks you want to copy to the folder: All disks, ChemStation 
disks, EZChrom disks, or OpenLAB Data Analysis disks.

g Select Start.

h Follow the prompts to insert new disks as they appear.

4 When processing is complete, copy the files to the local drive or map 
the location to a network drive.

5 Close the application and navigate to the directory and folder you 
created. Open the folder.

6 Select the Disk 1 folder, then execute Setup.bat to run the application.

The system will display the installer Planning screen.

NOTE Installations into the root of a drive may cause problems during operations and are not 
supported.
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Run the System Configuration Checker

1 At the Planning screen, select System Configuration Checker.

2 The Site Preparation Tool opens. Select the correct edition and setup of the 
OpenLAB CDS software you are installing from the drop- down list:

• For the server configuration check, select OpenLAB CDS Shared Server 
Core A.01.XX.

• If you want to install ChemStation Edition:

• Select OpenLAB CDS ChemStation Edition C.01.XX to check a CDS 
networked workstation.

• Select OpenLAB CDS ChemStation Edition (CDS client) to check a CDS 
client.

• Select OpenLAB CDS ChemStation Edition (Instrument Controller) to check 
an AIC.

• If you want to install EZChrom Edition: Select OpenLAB CDS EZChrom 
Edition A.04.XX to check a CDS client or AIC.

• If you want to install an OpenLAB Data Analysis stand- alone 
workstation: Select OpenLAB Data Analysis A.01.XX.

3 Select OK.

4 Complete page 1 of the Contact Information—System details by typing in the 
fields provided.

• System Location fields

• System Information fields

• Configuration fields

5 Review the system details and make any necessary entries. The system 
will follow the paths specified.

6 Select the green check mark icon in the top left corner of the screen to 
begin the software check. A summary report is displayed showing the 
results for each check category. Results are expressed as Pass, Warning, 
Critical Warning, or Fail. 

Fail results must be corrected before continuing with the installation. 
Agilent recommends investigating and correcting any Critical Warnings 
and Warnings whenever possible before proceeding.
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7 To view details of the report, select the appropriate link: System 
Hardware Details, Operating System and Software Details, or Manual Verification 
Required.

8 To save the report, select the Save icon at the top left of the screen.

9 E- mail the saved report to your Agilent Service Representative for 
evaluation, and for validation of your personal computer for Agilent 
Software Systems Installs.

NOTE If the firewall is controlled by security software, the Site Preparation Tool cannot read the 
firewall settings because of security limitations. As a consequence, the Site Preparation 
Tool will display Status "Fail" for the firewall settings.

In this case, make sure the firewall is disabled and enter the status in the Site Preparation 
Tool report manually.
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Prepare the Third Party Tools

The OpenLAB CDS Master Installer offers a list of tools that can be installed 
directly from the Installation screen.

Install Adobe PDF Reader

You need version 11 of Adobe PDF Reader to ...

• view site prep or administrative reports (such as system reports)

• use the Report Viewer feature (ChemStation Edition only)

• view Software Verification Reports

If Adobe PDF Reader is not installed on your system, or if an older 
version is installed:

1 Select Third Party Tools and then Adobe PDF Reader.

a The Adobe Reader setup screen appears. Click Install to continue.

b If Adobe Reader was successfully installed, click Finish to exist the 
setup screen.

Alternatively, you can install Adobe Reader version 11 from the 
OpenLAB CDS installation DVDs. It is available on Disk1/Tools/Adobe 
Reader in four language versions (English, Japanese, Chinese and 
Portuguese).

Run the self- extracting exe- file of your choice and follow the 
instructions of the Adobe Reader XI Setup wizard.

NOTE If you install Adobe PDF Reader directly from the DVDs: When OpenLAB CDS users open a 
PDF file for the first time, they will be asked to confirm the Adobe Reader license 
agreement. This dialog will appear for each newly configured instrument.
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Install Adobe Flash Player

Adobe Flash Player must be installed on machines connecting to the Data 
Store server.

1 Select Third Party Tools and then Adobe Flash Player.

2 In the Adobe Flash Player InstallShield Wizard click Install to continue.

3 When Adobe Flash Player was successfully installed, click Finish to 
return to the Installation screen.

Disable Auto-Update Notification in Flash Player

Adobe periodically updates the Flash Player with new features or security 
fixes, and notifies users with an installed Flash Player when an update is 
available. To disable the notification of updates:

1 Right- click on any Flash content, select Settings, Advanced and click the 
Global Notifications Settings tab in the Flash Player Settings Manager. 

2 Clear the Notify me when an update to Adobe Flash Player is available check box 
to stop receiving notifications.

3 Close the Settings Manager. The Flash Player automatically remembers 
the new settings. 

NOTE This procedure is only required if the PC is connected to a Data Store server.
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Install OpenLAB CDS on the Server

At this point, you will be installing to the Shared Services server either 
directly from the DVDs or from a local drive (mapped to either 
USB/eSATA drive or a network location). The installation steps are 
identical until you start the installation wizard: you won’t be prompted to 
load the DVDs if you are installing from a centralized location.

License Agreement Screen

1 If you plan to host the OpenLAB Shared Services database by an Oracle 
database management system, make sure to set up the Oracle database 
as described in CDS_oracle12.pdf on Disk1/docs/enu.

2 Select OpenLAB CDS.

3 The OpenLAB CDS Installation Wizard opens. Read the terms of the License 
Agreement. Master Installer provides a printable PDF of the license 
agreement under the Resources option of the main menu.

4 Select I agree with the terms and conditions. You cannot proceed with 
installation unless you agree to these terms.

5 Select Next to proceed to the Installation Folder screen.

NOTE Agilent recommends that you record and store the selections that you use during this 
installation in a different physical location. The information will be needed to restore your 
system in the unlikely case of your system becoming inoperable due to a hardware or 
software failure.
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Installation Folder Screen

1 Type the folder name or browse to the directory where you want to 
store the application components. Folders must have English names.

2 To run an installation verification as part of this Shared Services server 
installation, select Run Software Verification .

Because there can be several separate installation procedures for 
networked or distributed systems, you may prefer to run the Software 
Verification Tool during the last installation, or sometime after your 
system is completely installed (see the “Optional Procedures” on 
page 91).

3 Select Next to proceed to the Installation type screen.

Installation Type Screens for Shared Services Server

1 Under the Installation type screen, select Networked System.

2 Select Next to proceed to the Networked system screen.

3 Select Shared Services Server (w/o Data Store).

4 Select Next.

5 Complete the Database Type Selection screen by selecting the a database 
type and the installation type. Configure the database as described in 
the following steps.

6 If you selected New database server with PostgreSQL:

a Type the path or browse to the directory where you want to store 
the application components. Directory names must be entered 
without spaces.

b Select Next to proceed to the OpenLAB Shared Services Database screen.

c Complete the Database name field.

NOTE Installations into the root of a drive may cause problems during operation and are not 
supported.
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d Select the authentication mode.

If you use the database's server authentication, provide the required 
user credentials.

e Select Next to proceed to the Additional items screen.

7 If you connect to an existing PostgreSQL or Microsoft SQL Server database 
server:

a Type the database server name in the field provided.

If the database resides on the same computer use localhost as 
database server name. 

b For Microsoft SQL Server: Select Use default instance or Use named 
instance.

If you select Use named instance, complete the Database instance name 
field.

c Select Next to proceed to the OpenLAB Shared Services Database screen.

d Select either Create new database or Connect to existing database.

e Provide the required database name and user credentials.

f Click Test Connection... to run a connectivity check.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

g Select Next to proceed to the Additional items screen.

8 If you connect to an existing Oracle database server:

a Type the database server name in the field provided.

b Select Next to proceed with the server connection type.

c Select the Initialize data check box.

d Provide the required database name, user credentials, and the 
Listener port number. By default, the Listener port number is 1521.

e Click Test Connection... to run a connectivity check.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

f Select Next to proceed to the Additional items screen.
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9 In the Additional Items screen, select either No Central Storage, or ECM 
Server.

a If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

b Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

10 Under OpenLAB Shared Services Language, select the correct language from 
the drop- down list.

11 Select Next to proceed to the Summary screen.

Summary Screen: Server Software Installation

1 Review the installation settings that you have selected in the preceding 
steps. Select Back as necessary to change installation settings, or Cancel 
to cancel the installation.

2 Select Start to begin installation.

If OpenLAB CDS has been installed and uninstalled before, a warning 
will be shown that the system detected existing OpenLAB Shared 
Services database files. You can either:

• Click Yes to create new database files.

• Click No to reuse existing database files.

NOTE Before starting or canceling the installation, you can save an XML file with your installation 
settings. This XML can then be used for a scripted installation (see “About Scripted 
Installation” on page 84).
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3 The system performs an automated system check before it proceeds 
with the listed activities.

If a system check passed message appears, installation continues.

If a system check failed message appears, you can either:

• Decline to view the system report, and continue installation.

• View the system report, and decide to continue installation.

• View the system report and postpone installation until the problem is 
fixed.

• Decline to view the system report and postpone.

4 Your installation settings determine which disks need to be copied 
during installation. If you are installing directly from the DVDs, follow 
the Insert Disk prompts as they appear.

If you are installing from a local drive, you won’t insert disks or browse 
to disk folders — the entire installation will run automatically, based on 
your installation settings.

If the OpenLAB CDS Installation Wizard cannot locate a necessary file 
(whether on a disk or in a folder), a Disk or File not found prompt will 
appear.

For disks, follow the prompts to:

• Retry using the same disk.

• Insert the correct disk (if you made an error), and select OK.

• Select Cancel to cancel the installation. The system will uninstall any 
components installed so far.

If a file in a centralized folder cannot be found, you may have to 
recreate the folder. See “Copy DVDs to a Centralized Folder for 
Installation” on page 48 above.

NOTE To view the system report as PDF file, Adobe PDF Reader must be installed (see “Install 
Adobe PDF Reader” on page 51).
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If the installation of any vital application or component fails, the 
installation will roll back (uninstall). If a failed component can be 
installed at a later time without affecting basic installation (e.g. ECM 
API, Driver) the installation will proceed. In this case you will be 
notified of any failure(s), and that further steps are necessary to fully 
complete installation.

5 If an installation verification was completed as part of this installation, 
review the Software Verification Report. If the report indicates failure, 
verify the computer requirements and reinstall the data system. Do not 
use the system until the Software Verification Report gives a ‘pass’ 
result.

6 Click Next to proceed to the Installed Features screen.

7 Click Finish to close the installation wizard.

8 Reboot the server after the installation.

Post Installation Tasks on the Server

After installing OpenLAB CDS on the server, you can already set up the 
authentication provider and storage location. Alternatively, this can also be 
done after the installation of Networked Workstations or Clients is 
complete.

Set up the Authentication Provider and Storage Location

Execute the following procedure on the OpenLAB Shared Services server.

1 Open OpenLAB Control Panel from the OpenLAB Control Panel 
shortcut on the desktop, or go to Start > All Programs > Agilent Technologies 
> OpenLAB > OpenLAB Control Panel.

2 From the navigation pane, select Administration > System Configuration.
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3 In the System Configuration toolbar, select Edit System Settings.

Figure 5 Edit System Settings dialog in the OpenLAB Control Panel

4 In the Edit System Settings window, select your authentication provider 
from the drop- down list.

If you installed a Data Store server, the Internal authentication provider 
is automatically configured and a user called 'admin' with password 
'openlab' is created during the installation of the Data Store server. If 
required, you can change the authentication provider to Windows domain. 

5 Select your storage provider from the drop- down list.

The storage type Data Store is available only if Data Store has been 
deployed.

6 Select Next.
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7 Select a user to administrate the system.

a If you selected Internal as an authentication provider:

• Select Create Account.

• In the Create Administrator Account dialog box, enter a Name and a 
Password.

b If you selected Windows Local as an authentication provider:

• Select Select Account.

• Enter a search string.

• In the Search Users dialog box, select Search to view a list of users.

• Select a user.

c If you selected Windows Domain as an authentication provider:

• Select the check box to activate the input fields.

• Enter a Domain, User, and Password.

• Select Select Account.

• Enter a search string.

• In the Search Users dialog box, select Search to view a list of users.

• Select a user.

d If you selected ECM as an authentication provider:

• Provide the ECM Server URL and enter the ECM user credentials.

• Select Select Account.

• Enter a search string.

• In the Search Users dialog box, select Search to view a list of users.

• Select a user.

8 Select OK.

9 Select Next.

10 Review your settings and select Apply.
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Use these procedures to install the software to any number of 
workstations linked to the Shared Services server.

You’ll either be running your installation(s) using the DVDs directly, or 
from a centralized folder. The installation steps are identical until you 
start the installation wizard: you won’t be prompted to load the DVDs if 
you are installing from a centralized location.

License Agreement Screen

1 From the OpenLAB CDS Master Installer screen, select Installation.

2 Select OpenLAB CDS.

3 The OpenLAB CDS Installation Wizard opens. Read the terms of the License 
Agreement. Master Installer provides a printable PDF of the license 
agreement under the Resources option of the main menu.

4 Select I agree with the terms and conditions. You cannot proceed with 
installation unless you agree to these terms.

5 Select Next to proceed to the Installation Folder screen.
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Installation Folder Screen

1 Type the folder name or browse to the directory where you want to 
store the application components.

2 To run an installation verification as part of this installation, select Run 
Software Verification. The Software Verification Tool provides documentary 
evidence that your system has been built and installed correctly, and 
that all design specifications have been met. You can run the Software 
Verification Tool at a later time if you prefer (see “Run a Software 
Verification after Software Installation” on page 96).

3 Select Next to proceed to the Installation type screen.

Installation Type Screens

1 Under the Installation type screen, select Networked System.

2 Select Next to proceed to the Networked system screen.

3 Select Networked Workstation and hit Next.

4 Complete the Networked workstation component screen by selecting the 
CDS edition you want to install.

5 Select Next.

6 In the OpenLAB Shared Services Settings for Registration screen complete the 
Server name field.

a Choose the authentication service provider which you configured on 
the OpenLAB Shared Services server.

b Provide the corresponding user credentials (see “Set up the 
Authentication Provider and Storage Location” on page 58).

NOTE Installations into the root of a drive may cause problems during operation and are not 
supported.
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7 Select Next. The system will perform a connectivity check for the server.

If the connectivity test fails, verify that the server name was entered 
correctly, without spaces, and select Next to run the test again. If the 
test is still unsuccessful, you can:

• Enter a new server and try another test.

• Call internal support for assistance if you cannot connect to a server.

8 If you have chosen the  OpenLAB ChemStation Edition:

a Complete the OpenLAB CDS ChemStation Edition screen.

b Under Installation folder, type the path or browse to the directory 
where you want to store the application components. Directory 
names must be entered without spaces.

c Select the Install IO Library check box if you want to install the Agilent 
IO library suite. The suite can be installed manually at a later time if 
you prefer.

d Select Next to proceed to the Additional Items screen.

e In the Additional Items screen, select either No Central Storage, Data Store 
Server or ECM Server.

• If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

• Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

f Select Next to proceed to the Summary screen.

9 If you have chosen the OpenLAB EZChrom Edition:

a Select the Install OpenLAB Data Analysis check box if you want to install 
this application in addition to your CDS edition. OpenLAB Data 
Analysis can be installed as add- on version at a later time if you 
prefer (see “Install OpenLAB Data Analysis as Add- on or 
Stand- alone Application” on page 92).

NOTE OpenLAB Data Analysis is not supported for installations with ECM or Data Store as central 
data storage. 
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b Select the Install print server check box if you want to install the 
OpenLAB CDS print server.

c Enter a valid Enterprise Path in the format \\<host name>\<share 
name>[\<object name>]. The Enterprise Path has been prepared 
during the configuration of the OpenLAB Shared Services server (see 
“Create and Configure an Enterprise Path for EZChrom Edition” on 
page 43).

d Select Next to proceed to the Additional Items screen.

e In the Additional Items screen, select either EZChrom Enterprise Path, Data 
Store Server, or ECM Server.

• If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

• Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

f Select Next to proceed to the Summary screen.

Summary Screen

1 Review the installation settings that you have selected in the preceding 
steps. Select Back as necessary to change installation settings, or Cancel 
to cancel the installation.

2 Select Start to begin installation.

If OpenLAB CDS has been installed and uninstalled before, a warning 
will be shown that the system detected existing OpenLAB Shared 
Services database files. You can either:

• Click Yes to create new database files.

• Click No to reuse existing database files.

NOTE Before starting or canceling the installation, you can save an XML file with your installation 
settings. This XML can then be used for a scripted installation (see “About Scripted 
Installation” on page 84).
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3 The system performs an automated system check before it proceeds 
with the listed activities.

If a system check passed message appears, installation continues.

If a system check failed message appears, you can either:

• Decline to view the system report, and continue installation.

• View the system report, and decide to continue installation.

• View the system report and postpone installation until the problem is 
fixed.

• Decline to view the system report and postpone.

4 Your installation settings determine which disks need to be copied 
during installation. If you are installing directly from the DVDs, follow 
the Insert Disk prompts as they appear.

If you are installing from a local drive, you won’t insert disks or browse 
to disk folders — the entire installation will run automatically, based on 
your installation settings.

If the OpenLAB CDS Installation Wizard cannot locate a necessary file 
(whether on a disk or in a folder), a Disk or File not found prompt will 
appear.

For disks, follow the prompts to:

• Retry using the same disk.

• Insert the correct disk (if you made an error), and select OK.

• Select Cancel to cancel the installation. The system will uninstall any 
components installed so far.

If a file in a centralized folder cannot be found, you may have to 
recreate the folder. See “Copy DVDs to a Centralized Folder for 
Installation” on page 48 above.

If the installation of any vital application or component fails, the 
installation will roll back (uninstall). If a failed component can be 
installed at a later time without affecting basic installation (e.g. ECM 
API, Driver) the installation will proceed. In this case you will be 

NOTE To view the system report as PDF file, Adobe PDF Reader must be installed (see “Install 
Adobe PDF Reader” on page 51).
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notified of any failure(s), and that further steps are necessary to fully 
complete installation.

5 If an installation verification was completed as part of this installation, 
review the Software Verification Report. If the report indicates failure, 
verify the computer requirements and reinstall the data system. Do not 
use the system until the Software Verification Report gives a ‘pass’ 
result.

6 Click Next to proceed to the Installed Features screen.

7 Click Finish to close the installation wizard.
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Use these procedures to install the software to any number of CDS clients 
connected to the Shared Services server.

Other than EZChrom, ChemStation is not installed directly on the CDS 
client but on the AIC. You can access the ChemStation instance on the 
AIC machine from any ChemStation CDS client via a Remote Desktop 
Services connection.

Here again you will be running your installation(s) either using the DVDs 
directly, or from a centralized folder. The installation steps are identical 
until you start the installation wizard: you won’t be prompted to load the 
DVDs if you are installing from a centralized location.

License Agreement Screen

1 From the OpenLAB CDS Master Installer screen, select Installation.

2 Select OpenLAB CDS.

3 The OpenLAB CDS Installation Wizard opens. Read the terms of the License 
Agreement. Master Installer provides a printable PDF of the license 
agreement under the Resources option of the main menu.

4 Select I agree with the terms and conditions. You cannot proceed with 
installation unless you agree to these terms.

5 Select Next to proceed to the Installation Folder screen.
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Installation Folder Screen

1 Type the folder name or browse to the directory where you want to 
store the application components.

2 To run an installation verification as part of this CDS client 
installation, select Run Software Verification.

Because there can be several separate installation procedures for a 
distributed system, you may prefer to run the Software Verification Tool 
during the last installation, or sometime after your system is completely 
installed (see “Optional Procedures” on page 91 in this manual).

3 Select Next to proceed to the Installation type screen.

Installation Type Screens

1 Under the Installation type screen, select Networked System.

2 Select Next to proceed to the Networked system screen.

3 Select CDS client.

4 Select Next.

5 Under CDS Edition select the OpenLAB CDS edition you want to install.

6 Select Next.

7 In the OpenLAB Shared Services Settings for Registration screen complete the 
Server name field.

a Choose the authentication service provider which you configured on 
the OpenLAB Shared Services server.

b Provide the corresponding user credentials (see “Set up the 
Authentication Provider and Storage Location” on page 58).

8 Select Next. The system will perform a connectivity check for the server.

If the connectivity test fails, verify that the server name was entered 
correctly, without spaces, and select Next to run the test again. If the 
test is still unsuccessful, you can:

• Enter a new server and try another test.

• Call internal support for assistance if you cannot connect to a server.
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9 If you have chosen the OpenLAB ChemStation Edition:

a In the Additional Items screen, select either No Central Storage, Data Store 
Server or ECM Server.

• If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

• Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

b Select Next to proceed to the Summary screen.

10 If you have chosen the OpenLAB EZChrom Edition:

a Select the Install OpenLAB Data Analysis check box if you want to install 
this application in addition to your CDS edition. OpenLAB Data 
Analysis can be installed as add- on version at a later time if you 
prefer (see “Install OpenLAB Data Analysis as Add- on or 
Stand- alone Application” on page 92).

b Select the Install print server check box if you want to install the 
OpenLAB CDS print server.

c Enter a valid Enterprise Path in the format \\<host name>\<share 
name>[\<object name>]. The Enterprise Path has been prepared 
during the configuration of the OpenLAB Shared Services server (see 
“Create and Configure an Enterprise Path for EZChrom Edition” on 
page 43).

d Select Next to proceed to the Additional Items screen.

e In the Additional Items screen, select either EZChrom Enterprise Path, Data 
Store Server, or ECM Server.

• If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

• Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

NOTE OpenLAB Data Analysis is not supported for installations with ECM or Data Store as central 
data storage. 
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The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

f Select Next to proceed to the Summary screen.

Summary Screen

1 Review the installation settings that you have selected in the preceding 
steps. Select Back as necessary to change installation settings, or Cancel 
to cancel the installation.

2 Select Start to begin installation.

If OpenLAB CDS has been installed and uninstalled before, a warning 
will be shown that the system detected existing OpenLAB Shared 
Services database files. You can either:

• Click Yes to create new database files.

• Click No to reuse existing database files.

3 The system performs an automated system check before it proceeds 
with the listed activities.

If a system check passed message appears, installation continues.

If a system check failed message appears, you can either:

• Decline to view the system report, and continue installation.

• View the system report, and decide to continue installation.

• View the system report and postpone installation until the problem is 
fixed.

• Decline to view the system report and postpone.

NOTE Before starting or canceling the installation, you can save an XML file with your installation 
settings. This XML can then be used for a scripted installation (see “About Scripted 
Installation” on page 84).

NOTE To view the system report as PDF file, Adobe PDF Reader must be installed (see “Install 
Adobe PDF Reader” on page 51).
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4 Your installation settings determine which disks need to be copied 
during installation. If you are installing directly from the DVDs, follow 
the Insert Disk prompts as they appear.

If you are installing from a local drive, you won't insert disks or browse 
to disk folders — the entire installation will run automatically, based on 
your installation settings.

If the OpenLAB CDS Installation Wizard cannot locate a necessary file 
(whether on a disk or in a folder), a Disk or File not found prompt will 
appear.

For disks, follow the prompts to:

• Retry using the same disk.

• Insert the correct disk (if you made an error), and select OK.

• Select Cancel to cancel the installation. The system will uninstall any 
components installed so far.

If a file in a centralized folder cannot be found, you may have to 
recreate the folder. See “Copy DVDs to a Centralized Folder for 
Installation” on page 48.

If the installation of any vital application or component fails, the 
installation will roll back (uninstall). If a failed component can be 
installed at a later time without affecting basic installation (e.g. ECM 
API, Driver) the installation will proceed. In this case, you will be 
notified of any failure, and that further steps are necessary to fully 
complete installation.

5 If an installation verification was completed as part of this installation, 
review the Software Verification Report. If the report indicates failure, 
verify the computer requirements and reinstall the data system. Do not 
use the system until the Software Verification Report gives a ‘pass’ 
result.

6 Click Next to proceed to the Installed Features screen.

7 Click Finish to close the installation wizard.
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License Agreement Screen

1 From the OpenLAB CDS Master Installer screen, select Installation.

2 At the Installation screen, select OpenLAB CDS Installation.

3 The OpenLAB CDS Installation Wizard opens. Read the terms of the License 
Agreement. Master Installer provides a printable PDF of the license 
agreement under the Resources option of the main menu.

4 Select I agree with the terms and conditions. You cannot proceed with 
installation unless you agree to these terms.

5 Select Next to proceed to the Installation Folder screen.

Installation Folder Screen

1 Type the folder name or browse to the directory where you want to 
store the application components.

2 To run an installation verification as part of this Instrument Controller 
installation, select Run Software Verification.

Because there can be several separate installation procedures for a 
distributed system, you may prefer to run the Software Verification Tool 
during the last installation, or sometime after your system is completely 
installed (see “Optional Procedures” on page 91 in this manual).

3 Select Next to proceed to the Installation type screen.

NOTE If the AIC is running with Windows Server 2012: Log in as a Windows domain user with 
administrative privileges to install OpenLAB CDS.
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Installation Type Screens

1 Under the Installation type screen, select Networked System.

2 Select Next.

3 Select Instrument Controller.

4 Select Next.

5 Under CDS Edition select the OpenLAB CDS edition you want to install.

6 In the OpenLAB Shared Services Settings for Registration screen complete the 
Server name field.

a Choose the authentication service provider which you configured on 
the OpenLAB Shared Services server.

b Provide the corresponding user credentials (see “Set up the 
Authentication Provider and Storage Location” on page 58).

7 Select Next. The system will perform a connectivity check for the server.

If the connectivity test fails, verify that the server name was entered 
correctly, without spaces, and select Next to run the test again. If the 
test is still unsuccessful, you can:

• Enter a new server and try another test.

• Call internal support for assistance if you cannot connect to a server.

8 If you have chosen the OpenLAB ChemStation Edition:

a Under Installation folder, type the path or browse to the directory 
where you want to store the application components. Directory 
names must be entered without spaces.

b Under Instrument accounts you can choose to select the Use customized 
instrument accounts check box.

NOTE For disk performance reasons, the installation folder of a ChemStation AIC should be 
different from the physical drive hosting the operating systems. Use drive D: for installing a 
ChemStation AIC.

CAUTION Installation folder must not be shared.

➔ The installation folder of ChemStation on the AIC must not be shared. Doing so will 
disable launching the instrument from the CDS client.
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If you clear the check box, the system will use default instrument 
accounts.

If you select the check box, type the path in the Accounts file field, or 
browse to the directory where your customized instrument accounts 
are stored. Directory names must be entered without spaces.

c Select Next to proceed to the Additional Items screen.

d In the Additional Items screen, select either No Central Storage, Data Store 
Server or ECM Server.

• If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

• Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

e Select Next to proceed to the Summary screen.

9 If you have chosen the OpenLAB EZChrom Edition:

a The Install OpenLAB Data Analysis and Install printer server check boxes in 
the OpenLAB CDS EZChrom screen are deactivated, because the 
installation of these components is not supported for AICs.

b Enter a valid Enterprise Path in the format \\<host name>\<share 
name>[\<object name>]. The Enterprise Path has been prepared 
during the configuration of the OpenLAB Shared Services server (see 
“Create and Configure an Enterprise Path for EZChrom Edition” on 
page 43).

c Select Next to proceed to the Additional Items screen.

d In the Additional Items screen, select either EZChrom Enterprise Path, Data 
Store Server, or ECM Server.

• If you select ECM Server the Server name field will be enabled. Enter 
the server name without spaces.

• Click Test Connection... to run a connectivity check. The system will 
verify that the connection from this machine to the ECM server is 
functioning.

The system will display a Connection succeeded message if the check is 
successful. Click OK to close the message.

e Select Next to proceed to the Summary screen.
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Summary Screen

1 Review the installation settings that you have selected in the preceding 
steps. Select Back as necessary to change installation settings, or Cancel 
to cancel the installation.

2 Select Start to begin installation.

If OpenLAB CDS has been installed and uninstalled before, a warning 
will be shown that the system detected existing OpenLAB Shared 
Services database files. You can either:

• Click Yes to create new database files.

• Click No to reuse existing database files.

3 The system performs an automated system check before it proceeds 
with the listed activities.

If a system check passed message appears, installation continues.

If a system check failed message appears, you can either:

• Decline to view the system report, and continue installation.

• View the system report, and decide to continue installation.

• View the system report and postpone installation until the problem is 
fixed.

• Decline to view the system report and postpone.

4 Your installation settings determine which disks need to be copied 
during installation. If you are installing directly from the DVDs, follow 
the Insert Disk prompts as they appear.

If you are installing from a local drive, you won't insert disks or browse 
to disk folders — the entire installation will run automatically, based on 
your installation settings.

NOTE Before starting or canceling the installation, you can save an XML file with your installation 
settings. This XML can then be used for a scripted installation (see “About Scripted 
Installation” on page 84).

NOTE To view the system report as PDF file, Adobe PDF Reader must be installed (see “Install 
Adobe PDF Reader” on page 51).
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If the OpenLAB CDS Installation Wizard cannot locate a necessary file 
(whether on a disk or in a folder), a Disk or File not found prompt will 
appear.

For disks, follow the prompts to:

• Retry using the same disk.

• Insert the correct disk (if you made an error), and select OK.

• Select Cancel to cancel the installation. The system will uninstall any 
components installed so far.

If a file in a centralized folder cannot be found, you may have to 
recreate the folder. See “Copy DVDs to a Centralized Folder for 
Installation” on page 48.

If the installation of any vital application or component fails, the 
installation will roll back (uninstall). If a failed component can be 
installed at a later time without affecting basic installation (e.g. ECM 
API, Driver) the installation will proceed. In this case, you will be 
notified of any failure, and that further steps are necessary to fully 
complete installation.

5 If an Software Verification Tool was completed as part of this 
installation, review the Software Verification Report. If the report 
indicates failure, verify the computer requirements and reinstall the 
data system. Do not use the system until the Software Verification 
Report gives a ‘pass’ result.

6 Click Next to proceed to the Installed Features screen.

7 Click Finish to close the installation wizard.

NOTE The installation of a ChemStation AIC requires a reboot. It is very important that the 
installing user logs on again to the AIC after the reboot. Otherwise the CDS clients cannot 
configure or launch any ChemStation instrument on this machine.
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EZChrom Only: Identify a Domain Account for Running Instrument 
Services

- first AIC installation only-

This essential step must be completed for EZChrom edition after you have 
installed your first instrument controller using the procedures above.

1 Go to Start > Programs > Agilent Technologies > OpenLAB CDS EZChrom Edition > 
AIC and Driver Install Tool.

2 At the OLSS EZChrom Tool —Login screen, type your User Name, Password, 
and Domain in the fields provided.

3 Select Login.

4 At the OpenLAB Shared Services EZChrom Registrations Functions screen, select 
the Instrument Service Account tab.

5 Type the Service Account Credentials in the fields provided:

• User name

• Password

• Domain

The user specified for this service account must be set as a local 
administrator on all AICs.

This user must have the privilege to access the Enterprise Path.

6 Select Store.

7 Close the tool.

From this point forward you can install the software to any number of 
additional instrument controllers linked to the network server and 
instruments, omitting this step—the system will retrieve the domain 
account information automatically.
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Install a Networked Workstation (Mixed Topology)

In a Distributed System, you can also install Networked Workstations in 
addition to the AIC and OpenLAB CDS Clients, thus creating a mixed 
topology. For more information on the mixed topology, refer to the 
OpenLAB CDS Administration Guide.
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Post Installation Tasks

Configure the Antivirus Program

Be sure to open the firewall ports listed in the Firewall Settings in the 
OpenLAB CDS Network Requirements guide.

In order for the OpenLAB software to function correctly, you should 
configure any antivirus real time protection software with the following 
list of folder exclusions. These folders should only be scanned while the 
instruments are idle and no data acquisition takes place. Refer to your 
specific antivirus software documentation on how to configure folder 
exclusions.

• C:\chem32, D:\chem32, etc.

• C:\programdata\agilent

• %programfiles%\agilent

• %programfiles(x86)%\agilent

• %programfiles%\common files\agilent

• %programfiles(x86)%\common files\agilent

• %programfiles%\agilent technologies

• %programfiles(x86)%\agilent technologies

• %programfiles%\common files\agilent technologies

• %programfiles(x86)%\common files\agilent technologies

• %programfiles%\common files\agilent shared

• %programfiles(x86)%\common files\agilent shared

NOTE Some virus scanners might cause issues when used with OpenLAB CDS. OpenLAB CDS 
was tested to run with Symantec's Endpoint Protection.

NOTE The following sections contain general information and also specific details only applicable 
for OpenLAB CDS ChemStation Edition (e.g. the chem32 folder).
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If your antivirus software includes program or executable deny execution 
settings, ensure that the following program files are not denied execution. 
You can use the windows search feature to find the specific folder each 
program file is located in.

• agilentiolibrariesservice.exe

• chemmain.exe

• apg_top.exe

• iprocsvr.exe

• iproc8491.exe

• msinsctl.exe

• httpdmsd.exe

• epcsetup.exe

Process Directory File name

ECM upload/download
(if applicable)

%temp% for Windows users
(=Users' temp directory)

*.ssizip

Standard reports %temp% for Windows users
(=Users' temp directory)
/chem32/core

~p3d*.tmp
~job*.tmp
Hpspl00.que

CDS intelligent reports %LOCALAPPDATA%
%APPDATA%
%PROGRAMDATA%

Files on:
• Agilent
• Agilent Technologies
• Agilent_Technologies,_Inc
• IsolatedStorage
• Temp
e.g.: C:\Users\xxxxx\
AppData\Local\ Agilent 
Technologies\Intelligent 
Reporting\
RawDataFileCache

NOTE Depending on your specific configuration, some of the listed folders or files may not exist 
on your system.
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What to do Next

The basic installation of the data system software is complete.

There is a 60- day Startup License for this system, and the expiration 
period starts with your first launch of an application.

To request and download your final software license, and add the license 
file to your system, see the Software License Installation Guide.

After you have acquired and installed your final software license, you will 
continue to prepare your data system for operation by end users by 
configuring projects, users, and instruments. This is accomplished through 
the OpenLAB CDS Control Panel.

OpenLAB Shared Services Configuration

Refer to the online help for directions on how to do the following tasks. 

Configure License Server

1 Select Licenses in the navigation window. Add a valid license file or 
server to activate the OpenLAB CDS Workstation Software. 

Configure Users/Groups/Roles

1 Launch the OpenLAB Control Panel and navigate to Administration

2 Select Users in the Navigation Window. Import/Create Users that will 
have access to the OpenLAB CDS Workstation.

3 Select Groups in the Navigation Window. Import or Create Groups that 
will have access to the OpenLAB CDS Workstation.

4 Select Roles in the Navigation Window. Create/edit Roles and assign 
Users or Groups to those Roles.
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Configure Instruments

1 Launch the OpenLAB Control Panel and navigate to Instruments.

2 Create and configure an Instrument.

For details on instrument configuration, refer to the corresponding 
manuals:

• For ChemStation: Instrument Configuration Guide 
(CDS_CS-InstrumentConfig.pdf on disc 2.

• For EZChrom: Instrument Installation Guide 
(CDS_EZ-Instrument-Installation.pdf on disc 5).
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This chapter describes the syntax and parameters for an installation or 
uninstallation in command line mode.
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About Scripted Installation
About Scripted Installation

The OpenLAB CDS Master Installer supports a command line mode for 
installation, the so- called scripted installation. This mode supports 
installation, upgrade, repair, and uninstallation. You can execute scripted 
installations either manually or as part of software management systems 
such as LANDesk or HP CM. With the corresponding parameter (- q), the 
scripted installation is completely UI- less.
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Export as XML 

The Master Installer supports a feature to export the installation 
parameters into an XML file which you can then use for the scripted 
installation.

This feature is also supported for upgrade and repair. However, for these 
cases the exported installation XML file is not appropriate. For scripted 
repair and upgrade, you must prepare specific XML files using the 
respective Master Installer wizards.

1 Launch the OpenLab CDS Installation Wizard.

2 Follow the instructions as described under Install the Software in this 
manual.

3 When you have reached the Summary screen, click the icon  on the 
top right corner to export the installation parameters to XML. Save the 
file on a physical drive.

You can now use the XML file for the scripted installation.

NOTE Installation file and XML file must not be in the same file path.
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Parameters and Return Codes

Parameters

You can call Agilent.OpenLAB.CDSInstaller.exe in command line mode with the 
following parameters:

• - i

Installation, upgrade or repair

• - u

Uninstallation

• - q

Silent mode — no installation or uninstallation wizard will be shown.

• - reboot

Reboot automatically after successful installation, repair, upgrade, or 
uninstallation. The system will reboot if the return code is either 0 or 
17.

A warning message will be shown in the command prompt 10 min 
before the system is rebooted. In addition, a Windows dialog opens 
2 min before reboot.

• KeepComponents

Optional parameter for the uninstallation process, which can contain 
one or more shared components that should stay on your system. 
Without this parameter, all OpenLAB CDS components will be removed 
from your system. To keep certain shared components, list the 
corresponding IDs from the table below in double quotes and separated 
by comma.

Component Name Id

Software Verification Tool IQT

Microsoft SQL Server SQLServer

IO Library IOLibraries
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• ConfigurationXML="<ConfigurationXMLFilePath>"

The XML file contains all required inputs of the Master Installer to 
install, upgrade, or repair a certain topology (see “Export as XML” on 
page 85). Replace <ConfigurationXMLFilePath> with the correct file 
path and XML file name.

Return Codes

After installation, uninstallation, upgrade, or repair in the command line 
mode, the system will return a number code which is explained below.

NOTE Do not enter a blank before or after the equals (=) sign. The scripted installation and 
uninstallation mode will not work as expected.

Table 3 Return codes

Error/Return Code Return value

Unknown (default) -1

Success 0

CoreComponentFailure 1

NonCoreComponentFailure 2

TestConnectivityFailure 3

ExpectedWindowsInstallerNotInstalled (WI 4.5 missing) 4

ParameterMismatchError 5

CannotProceedWithFreshInstallation 6

CannotProceedWithUpgrade 7

CannotProceedWithUninstallation 8

CannotProceedWithRepair 9

CannotProceedWithReRegistration 10

ReRegistrationNotSupported 11

IncompleteTopologyFound 12
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InvalidUNCPath 13

MissingInstallable 14

NotAStrongPassword 15

DowngradeNotSupported 16

RestartRequired 17

RegistryCleanupError 18

InvalidInputXML 19

InvalidMode 20

SitePrepFailure 21

DatabaseConnectionFailed 22

DotNetFramework4NotInstalled 23

OLSSConnectionFailed 24

PDFReaderNotInstalled 25

AllComponentsInstallationFailed 26

SomeComponentsInstallationFailed 27

Failed 28

AddOnListEmpty 29

EULANotAccepted 30

ScriptedNotSupported 31

Table 3 Return codes

Error/Return Code Return value
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Installation, Upgrade, or Repair

In installation mode, the OpenLAB CDS Master Installer checks if .Net 
Framework is present on your system. If not, it will automatically be 
installed. Select Accept to agree with the license agreement.

The Master Installer evaluates the products already installed on your 
system. Depending on the installed components, the Master Installer will 
offer one of the following options:

• Start a fresh installation

• Upgrade

• Repair

If a required installable is missing, the Master Installer will create an 
entry in a log file, and, depending on the component type, will continue or 
rollback the installation. A corresponding error code will be returned in 
such scenarios.

1 Right- click the executable of the command prompt or Power shell 
prompt, and run it as administrator.

You will get a return code for the scripted installation only if you start 
it as administrator.

2 Navigate to the drive where you have saved the disks.

For example: C:\CDS_DVD

3 To start the installation, call Agilent.OpenLab.CDSInstaller.exe with the 
following syntax: 

Agilent.OpenLab.CDSInstaller.exe - i ConfigurationXML="<path to xml 
file>" - q - reboot

For example:

Agilent.OpenLab.CDSInstaller.exe - i ConfigurationXML="c:\settings\
ConfigurationXML.xml" - q - reboot

With this command, you start the installation wizard without a user 
interface, and automatically reboot the system.

Preparations You must have copied all disks to a centralized folder (see “Copy DVDs to a Centralized Folder for 
Installation” on page 48). This step is mandatory for scripted installation.
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1 Right- click the executable of the command prompt or Power shell 
prompt, and run it as administrator.

You will get a return code for the scripted uninstallation only if you 
start it as administrator.

2 Navigate to the drive where you have saved the disks.

For example: C:\CDS_DVD

3 To start the uninstallation, call Agilent.OpenLab.CDSInstaller.exe with 
the following syntax:

Agilent.OpenLab.CDSInstaller.exe - u KeepComponents="<list of 
components>" - q - reboot

For Example:

Agilent.OpenLab.CDSInstaller.exe - u KeepComponents="IQT,IOLibraries" 
- q - reboot 

With the KeepComponents parameter, you can specify a list of shared 
components that you want to keep on the system (see “Parameters” on 
page 86). With the command given in the example, the OpenLAB CDS 
components Software Verification Tool (IQT) and IO Library 
(IOLibraries) will be kept.

Logging and Tracing

All exceptions, errors and information messages are logged in the 
following locations:

• During installation, upgrade, or repair: under <BaseInstallDirectory>\Logs

• During uninstallation: under <User's Temp>\<Company Name>\Logs\<Log 
folder>\<Wizard Name>.txt
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Install OpenLAB Data Analysis as Add-on or Stand-alone Application 92

Install Additional Software and Drivers 95
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Configure Advanced File Security (AFS) 97

Enable Advanced File Security 97

This chapter describes the installation of OpenLAB Data Analysis as an add-on 
or standalone application. It also contains information on the Additional Drivers 
and Software wizard, the Software Verification Tool, and the creation of an 
Enterprise Path with Advanced File Security. 
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Install OpenLAB Data Analysis as Add-on or Stand-alone Application
Install OpenLAB Data Analysis as Add-on or Stand-alone 
Application

If you have not installed OpenLAB Data Analysis together with OpenLAB 
CDS, you can install OpenLAB Data Analysis as an add- on to OpenLAB 
CDS or as a stand- alone application.

1 Run the Master Installer. 

2 From the Master Installer screen, select Installation.

3 Select OpenLAB Data Analysis.

4 The OpenLAB Data Analysis Installation Wizard opens. Read the terms of the 
License Agreement. The Master Installer provides a printable PDF of the 
license agreement under the Resources option of the main menu.

5 Select I agree with the terms and conditions. You cannot proceed with 
installation unless you agree to these terms.

6 Click Next to proceed to the Installation Folder screen.

7 If you already have installed OpenLAB CDS on your PC, OpenLAB Data 
Analysis will be installed as an add- on. 

a To run an installation verification as part of this installation, select 
Run Software Verification. The Software Verification Tool provides 
documentary evidence that your system has been built and installed 
correctly. You can run the Software Verification Tool at a later time 
if you prefer.

b Click Next to proceed to the OpenLAB Shared Services Settings for 
Registration screen.

c Enter the server name and authentication provider.

NOTE OpenLAB Data Analysis is not supported for installations with ECM or Data Store as central 
data storage.
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d Click Test Connection ... to run a connectivity check.

The system will display a Connection succeeded message if the check is 
successful. 

e Continue with step 10.

8 If you have not installed OpenLAB CDS on your PC, OpenLAB Data 
Analysis will be installed as a stand- alone application.

a You can use the default folder, type a new folder name or browse to 
the directory where you want to install OpenLAB Data Analysis.

b To run an installation verification as part of this installation, select 
Run Software Verification. The Software Verification Tool provides 
documentary evidence that your system has been built and installed 
correctly. You can run the Software Verification Tool at a later time 
if you prefer.

c Click Next.

d Select the required installation type.

9 If you have selected Networked Workstation:

a Click Next.

b In the OpenLAB Shared Services Settings for Registration screen complete 
the Server name field.

c Select the authentication provider as set in the OpenLAB Control 
Panel.

d When you type in the Server name, the Test Connection... button will be 
activated. You can test connectivity for this server before completing 
the rest of this screen.

NOTE An installation on a networked workstation is only supported in combination with OpenLAB 
CDS EZChrom Edition. For this type of installation, only the Enterprise path without 
Advanced File Security (AFS) is supported as storage.
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e Select Next. The system will perform a connectivity check for the 
server.

If the connectivity test fails, verify that the server name was entered 
correctly, without spaces, and select Next to run the test again. If the 
test is still unsuccessful, you can:

• Enter a new server and try another test.

• Call internal support for assistance if you cannot connect to a 
server.

When a connectivity test has run successfully, the system will 
proceed to the Additional items screen.

f In the Additional Items screen, EZChrom Enterprise Path is selected.

10 Click Next to proceed to the Summary screen.

11 Click Start to begin installation.

12 When the installation is finished, click Next to proceed to the Installed 
Features screen.

13 Click Finish to close the installation wizard.
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Install Additional Software and Drivers

OpenLAB CDS offers a wizard to help you installing additional software, 
such as drivers for third- party instruments. To open the wizard, go to 
Start > All programs > Agilent Technologies > OpenLAB > OpenLAB Additional 
Software and Drivers. Follow the wizard to install the required software.

Prepare Network Drives

If the additional software is located on a network drive, you must prepare 
the network drive to make it accessible by the wizard. Without this 
preparation, Windows security prevents the wizard from accessing those 
drives.

1 Map the drive to a letter.

For example, map the drive as Z: using the shared path "\\
<machine- name>\OpenLABCDS".

This maps the drive for the logged- in user.

2 Open the command prompt in elevated mode (run as administrator), 
and map the drive using the net use command.

For example, 
net use Z: "\\<machine-name>\OpenLABCDS"

This maps the drive for the local administrator account. The mapped 
drive is now visible to both logged- in user and administrator, and can 
be selected in the wizard.

Configure Third-Party Instruments

For details on the configuration of third- party instruments with EZChrom 
Edition, please refer to the OpenLAB CDS EZChrom Edition Instrument 
Installation Guide.
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Run a Software Verification after Software Installation

The Software Verification Tool provides documentary evidence that your 
system has been built and installed correctly, and that all design 
specifications have been met.

1 Using your Windows operating system, go to Start > All Programs > Agilent 
Technologies > Software Verification Tool.

2 Select Qualify.

The system will run the application and generate a Software 
Verification Report.

3 If the report indicates failure, verify the computer requirements and 
reinstall the data system.

Do not use the system until the Software Verification Report gives a 
‘pass’ result.
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Configure Advanced File Security (AFS)

Advanced file security is an optional configuration for OpenLAB CDS 
EZChrom Edition networked systems. It provides enhanced security on the 
enterprise path in order to prevent any unauthorized access to project 
data outside of the data system. This configuration sets the appropriate 
Windows sharing and security settings to allow only a defined group to 
access the enterprise data from Windows Explorer. This may only be 
configured if your system is configured to use Windows Domain as the 
Shared Services authentication provider.

Enable Advanced File Security

1 Prepare your system.

a Verify that your system is configured to use Windows Domain as the 
authentication provider. (See Configure Security and Storage > Set the 
authentication provider and the storage system in the online help.)

b Verify that your system is configured to use a storage path that is 
directly beneath the defined enterprise path.

c Create or define a Windows Domain group that will have access to 
the enterprise path outside of the data system.

d Define a minimum of two users who are members of the group 
defined above.

e Under Local Security Policy > Local Policies > User Rights Assigment, grant 
the users or the group the following rights:

• Act as part of the operating system

• Allow log on locally

f Close all connections to the OpenLAB CDS system (i.e. clients, 
instrument runs, control panels).
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g Obtain the login credentials of a domain user that has administrative 
rights to edit the enterprise path in its current state.

h Obtain the administrative login credentials of the OpenLAB Control 
Panel that were defined during the configuration of domain 
authentication.

2 On any OpenLAB CDS EZChrom Edition client, browse to the directory 
where the software was installed.

(by default: C:\Program Files\Agilent Technologies\EZChrom)

3 Launch EnterpriseConfig.exe.

4 An Enterprise Setup Login dialog will display:

a In the OpenLAB Control Panel Login section enter the user name, 
password, and domain of the OpenLAB Control Panel Administrator.

b In the Windows User Information section enter the user name and 
password of the user with edit permission to the enterprise path.

• If this is a domain user account, select Logon from Windows Domain 
and enter the domain name (recommended).

• If this is a local PC account, select Windows Local PC. This may only 
be an account local to the machine where the EnterpriseConfig.exe 
program is being run.

c Click OK.

5 The system will process the above credentials. If they are valid, a 
warning will display to advise that once this process is completed, it 
cannot be reversed.

Click OK if you are prepared to proceed.

6 An Enterprise Service Account dialog will display:

a Enter the user name, password, and domain of a user defined to be 
a member of the AFS group.

b Enter the group name that will have access to the enterprise path 
under the restrictions of AFS.

c Click OK.
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License Upgrade
License Upgrade

If you are upgrading from a version older than A.02.01, you will need to 
get a new license to upgrade to the new version of the software.

If you are under SMA subscription, proceed as follows to upgrade your 
licenses: 

1 Log into the Agilent Electronic Software and License Delivery 
(https://agilent.subscribenet.com/).

2 Navigate to Manage Licenses by Host, and search for OpenLAB Shared 
Services server. Alternatively, select the machine from the drop- down 
list.

3 Click Upgrade All to upgrade all licenses on this host to the most recent 
version. Confirm the upgrade on the next screen.

This upgrades the license file to the most current version. SubscribeNet 
will send you an email with a new license file.

4 Put the new license file on your system.

You only need to provide the license file once, as licenses are managed 
on the central OpenLAB Shared Services server.

5 Download the most recent version of OpenLAB CDS software from 
SubscribeNet and install it.

For a Distributed System, approach the Agilent PSO for the license 
upgrade.
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Upgrade Process

Order of Upgrading Servers and PCs

The upgrade process starts with the Shared Services Server, then the AICs 
and the CDS Clients or Networked Workstations.

Data Compatibility Between Different Versions

During an upgrade project there might be different versions of OpenLAB 
CDS in your environment. Please note that the analysis and reprocessing 
of data is supported only on versions same as or higher than the one used 
for the acquisition or last reprocessing.

Agilent recommends that a mixed version system should be used only 
during the upgrade phase. For more information, please refer to the CDS 
Administration Guide (CDS_admin.pdf on Disk 1).
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Step 1: Upgrade the OpenLAB Shared Services Server

To upgrade to A.02.02, perform the following steps:

1 To upgrade a Data Store system, you must start the Master Installer 
from the ol- ds disk (this includes both upgrading the Data Store server 
and the OpenLAB Shared Services server). To upgrade a system without 
Data Store, start the Master Installer from disk 1.

2 From the Master Installer Planning screen, switch to the Installation 
screen.

3 Select OpenLAB CDS Installation. As OpenLAB CDS is already installed, 
this automatically opens the upgrade wizard.

4 In the Upgrade Type screen, enter the credentials for OpenLAB Shared 
Services.

5 Select Next to proceed to the Summary screen.

6 In the Summary screen of the Upgrade Wizard, the components for the 
upgrade are listed. Select Start to start the upgrade.

If an error occurs during the upgrade, an error message appears. When 
a component is upgraded correctly, the status shown in the Status field 
changes from Installed to Successfully Upgraded.

7 After the upgrade is completed, a warning message appears, stating that 
you must restart Windows for some changes to take effect.

Select Yes to restart Windows.

Select No if you want to restart Windows at a later time.

After the upgrade, the OpenLAB Server Utility tool has changed, for 
example the Activity Log Export tab, the Windows Domain tab and the 
Server Settings tab. For more information on server administration, refer 
to the OpenLAB CDS Guide for Administrators.
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Step 2: Upgrade a Networked Workstation or a Client

Upgrade a Networked Workstation or a Client with ChemStation 
Edition

Upgrading From A.01.01 or A.01.02

First upgrade your application to OpenLAB CDS A.01.03. In a second step, 
upgrade to A.02.02.

Upgrading From A.01.03 or Higher

You can upgrade to OpenLAB CDS A.02.02 in one step, using the OpenLAB 
CDS Upgrade Wizard in the Master Installer. 

1 From the Master Installer Planning screen, switch to the Installation 
screen.

2 Select OpenLAB CDS Installation.

If OpenLAB CDS is already installed, this automatically opens the 
OpenLAB CDS Upgrade Wizard.

3 When upgrading from a version prior to OpenLAB CDS A.02.01, the 
workstation license must be upgraded see “License Upgrade” on 
page 100.

Acknowledge that the license has been upgraded and click Next to 
continue.

4 Select I agree with the terms and conditions. You cannot proceed with the 
upgrade unless you agree to these terms. Click Next. 

5 If an Authentication Provider has been configured: Enter the username 
and password of a user with system administration privileges in the 
OpenLAB Shared Services Settings for Registration screen. Click Next.

NOTE The settings in the ChemStation Administration Tool may change during the update 
process. After the upgrade, check if the settings in the ChemStation Administration Tool 
still match your original system settings before the upgrade.
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6 In the Summary screen of the Upgrade Wizard, the components for the 
upgrade are listed. Click Start to proceed with the upgrade.

If an error occurs during the upgrade, an error message appears.

7 After the upgrade is finished, select Finish to close the OpenLAB CDS 
Upgrade Wizard.

Existing instrument configuration can remain unchanged after the 
upgrade. 

After an upgrade of a ChemStation, configuration files for every 
instrument should be deleted.

1 Open the Windows Explorer on the instrument controller (Stand- alone 
Workstation, Networked Workstation, or AIC).

2 Navigate to the ChemStation installation folder.

By default, this folder is named C:\Chem32.

3 Make sure all online and offline ChemStation sessions are closed.

4 Go into each of the existing instrument folders (Chem32\1\, Chem32\2\, 
...) and delete the files with the names Config.reg and Conf_off.reg.

Do not delete any other files.

Upgrade a Networked Workstation or a Client with EZChrom Edition

Upgrading From A.01.01

Uninstall OpenLAB CDS A.01.01, then install A.02.02.

Upgrading From A.01.02

First upgrade your application to OpenLAB CDS A.01.03. In a second step, 
upgrade to A.02.02.

NOTE If you reconfigure existing instruments: For 35900 ADC instruments, do not switch from 
classic drivers to RC.NET drivers. 35900 ADC may no longer write data afterwards.
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Upgrading From A.01.03 or Higher

You can upgrade to OpenLAB CDS A.02.02 in one step, using the OpenLAB 
CDS Upgrade Wizard in the Master Installer. 

1 From the Master Installer Planning screen, switch to the Installation 
screen.

2 Select OpenLAB CDS Installation.

If OpenLAB CDS is already installed, this automatically opens the 
OpenLAB CDS Upgrade Wizard.

3 When upgrading from a version prior to OpenLAB CDS A.02.01, the 
workstation license must be upgraded see “License Upgrade” on 
page 100.

Acknowledge that the license has been upgraded and click Next to 
continue.

4 Select I agree with the terms and conditions. You cannot proceed with the 
upgrade unless you agree to these terms. Click Next. 

5 If an Authentication Provider has been configured: Enter the username 
and password of a user with system administration privileges in the 
OpenLAB Shared Services Settings for Registration screen. Click Next.

6 In the Summary screen of the Upgrade Wizard, the components for the 
upgrade are listed. Click Start to proceed with the upgrade.

If an error occurs during the upgrade, an error message appears.

7 After the upgrade is finished, select Finish to close the OpenLAB CDS 
Upgrade Wizard.

Existing instrument configuration can remain unchanged after the 
upgrade. 

NOTE The settings in the ChemStation Administration Tool may change during the update 
process. After the upgrade, check if the settings in the ChemStation Administration Tool 
still match your original system settings before the upgrade.

NOTE If you reconfigure existing instruments: For 35900 ADC instruments, do not switch from 
classic drivers to RC.NET drivers. 35900 ADC may no longer write data afterwards.
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About Uninstallation

Like the installation, the uninstallation of OpenLAB CDS is automated by 
the OpenLAB CDS Master Installer. 

For your convenience, the Master Installer uses the same user interfaces 
for the software uninstallation of all OpenLAB CDS configurations 
(standalone or networked workstation). The OpenLAB CDS Uninstallation 
Wizard under the Maintenance section of the Master Installer guides you 
through the uninstallation steps.

For uninstalling OpenLAB CDS, you need to have administrator privileges 
for all servers and clients. Power user privileges are not sufficient (the 
uninstallation does not start).

Run the Master Installer

To run the Master Installer on your workstation choose one of the 
following approaches:

• To run the uninstallation from disk, insert the OpenLAB CDS 
Installation disk (Disk 1).

Autostart will automatically run 
Agilent.OpenLABCDSSetupFromDVD.exe and display the installer 
Planning screen.

NOTE If the Master Installer was not used for installation, any manually installed additional 
software such as Headspace, PAL, or third party drivers must be uninstalled using the 
Windows Control Panel before the OpenLAB CDS can be uninstalled.

NOTE Do not use the Windows uninstallation tool. 
108 CDS Networked and Distributed System Installation and Configuration



Uninstall the Software 8
Run the OpenLAB CDS Uninstallation Wizard on a CDS Client
• For the portable data storage device  approach, insert the device in a 
computer USB port, navigate to \Disk1 and run Setup.bat to proceed to 
the Planning screen.

• For the share file  approach, copy the contents to the local drive and 
navigate to the respective share file folder. Then navigate to \Disk1 and 
run Setup.bat to proceed to the Planning screen.

Run the OpenLAB CDS Uninstallation Wizard on a CDS Client

1 From the Master Installer Planning screen, select Maintenance from the 
side bar menu.

2 Select OpenLAB CDS Uninstallation.

The OpenLAB CDS Uninstallation Wizard opens.

3 In the Shared Components screen, check the Uninstall Software Verification 
check box.

Note: Software Verification Tool needs to be uninstalled if you wish to 
re- install OpenLAB CDS at a later time

4 In the Summary screen under Uninstallation of OpenLAB CDS Components, 
there is a list of the components you want to uninstall.

5 Select Start to start the uninstallation.

If you want to abort the uninstallation, select Cancel. If you want to 
change any settings, select Back.

All listed components are automatically uninstalled, one after another.

6 When the uninstallation has finished, click Finish to close the 
uninstallation wizard.
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Run the OpenLAB CDS Uninstallation Wizard on an Instrument 
Controller

1 From the Master Installer Planning screen, select Maintenance from the 
side bar menu.

2 Select OpenLAB CDS Uninstallation.

The OpenLAB CDS Uninstallation Wizard opens.

3 In the Shared Components screen, check the Uninstall Software Verification 
check box.

Note: Software Verification Tool needs to be uninstalled if you wish to 
re- install OpenLAB CDS at a later time

4 In the Summary screen under Uninstallation of OpenLAB CDS Components, 
there is a list of the components you want to uninstall.

5 Select Start to start the uninstallation.

If you want to abort the uninstallation, select Cancel. If you want to 
change any settings, select Back.

All listed components are automatically uninstalled, one after another.

6 When the uninstallation has finished, click Finish to close the 
uninstallation wizard.
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Run the OpenLAB CDS Uninstallation Wizard on the OpenLAB 
Shared Services Server

1 From the Master Installer Planning screen, select Maintenance from the 
side bar menu.

2 Select OpenLAB CDS Uninstallation.

The OpenLAB CDS Uninstallation Wizard opens.

3 In the Shared Components screen, check Uninstall Software Verification and 
Uninstall MS SQL Server 2008 R2.

Under SQL Instance, select the instance that you want to uninstall from 
the drop- down list.

4 Select Next to proceed to the Summary screen.

5 In the Summary screen under Uninstallation of OpenLAB CDS Components, 
there is a list of the components you want to uninstall.

6 Select Start to start the uninstallation.

7 If you want to abort the uninstallation, select Cancel. If you want to 
change any settings, select Back.

All listed components are automatically uninstalled, one after another.

When a component is uninstalled correctly, the status shown in the 
Status field of the Maintenance screen changes from Installed to Uninstalled 
successfully.

When the uninstallation has finished, click Finish to close the 
Uninstallation Wizard.

NOTE The Software Verification Tool needs to be uninstalled if you want to reinstall OpenLAB 
CDS at a later time.
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Run the OpenLAB CDS Uninstallation Wizard on a Networked 
Workstation

1 From the Master Installer Planning screen, select Maintenance from the 
side bar menu.

2 Select OpenLAB CDS Uninstallation.

The OpenLAB CDS Uninstallation Wizard opens.

3 In the Shared Components screen, check the Uninstall Software Verification 
check box.

Note: Software Verification Tool needs to be uninstalled if you wish to 
re- install OpenLAB CDS at a later time

4 In the Summary screen under Uninstallation of OpenLAB CDS Components, 
there is a list of the components you want to uninstall.

5 Select Start to start the uninstallation.

If you want to abort the uninstallation, select Cancel. If you want to 
change any settings, select Back.

All listed components are automatically uninstalled, one after another.

6 When the uninstallation has finished, click Finish to close the 
uninstallation wizard.
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About Troubleshooting
About Troubleshooting

The OpenLAB CDS Master Installer configures a Windows Server machine 
with the minimum footprint and effort, so its Remote Desktop Services 
functionality can be used to remotely control ChemStation instruments.

This comprises the creation of a number of local users required for 
launching the ChemStation instruments from a remote client. It also 
comprises configuring the machine as a Remote Desktop Services host and 
performing the registration tasks necessary to access and run ChemStation 
from a remote client.

Experience shows that there are numerous ways to restrict access to a 
server machine and local network so that the default installation will no 
longer work. This chapter is intended to list the known restrictions and 
provide means to get the AIC working even if there are several 
restrictions.

NOTE The following refers to ChemStation AIC only.
114 CDS Networked and Distributed System Installation and Configuration



Troubleshooting 9
Consider Before Installation
Consider Before Installation

Password Policy not Satisfied by Default Passwords

The local users created during installation by default have a password 
consisting of a random mixture of 3 uppercase letters, 3 lowercase letters, 
3 digits and 3 special characters. This should satisfy almost any password 
restriction rules.

To check if the user password matches the password restriction rules:

• Create a test user on the AIC.

• Set the test user's password to “uK0%wJ8+kA6+” for example.

If the password does not conform to the password rules:

• Create 9 compliant passwords and enter them during installation of the 
AIC (see section “Configure ChemStation Instrument Users 
Manually” on page 121 under Remedial Procedures).

Configure a Network Printer

1 Click Start > Devices and Printers.

2 Click tool button Add a Printer.

3 Click Add a local or network printer as administrator.

4 Click Add a local printer or Add a network, wireless or Bluetooth printer.

5 For network printers: Select Configure a new port, and in the drop- down 
box select Standard TCP/IP Port.

6 Click Next. Verify that the box Query the printer and automatically select the 
driver to use is checked.

7 Enter the hostname or IP address (use fully qualified name: e.g. 
<printer name>.germany.agilent.com). The port name is displayed 
identically.

8 Click Next. Windows will communicate with the printer and install the 
driver if required. Then select Use this driver that is currently installed 
(recommended) (default). Optionally it can be replaced.
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9 Click Next. Use the default displayed printer name or change it to a 
suitable expression if required.

10 Click Next. The printer will be installed.

11 After installation, verify that the radio button Do not share this printer is 
selected.

12 Click Next. Check the box Set as the default printer if required. Print a test 
page.

13 Click Finish when test page is successfully printed.
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Login Delay

If you are experiencing high response times during logon to the system or 
reconnecting after a session lock, the following causes might apply:

• DNS not set up correctly.

Check that the name resolution is working properly for all affected 
computers.

• Ports blocked by firewall.

Check that the ports listed in OpenLAB CDS Network Requirements are 
not blocked by your firewall.

Network Level Authentication Required

Remote Desktop Services provides a higher level of security if the client's 
access is checked by the domain controller before actually accessing the 
AIC. Your IT department may require the use of this security level.

To switch an AIC to Network Level Authentication, perform the following 
steps:

1 Start Server Manager.

2 Select Roles > Remote Desktop Services > RD Session Host Configuration > 
RDPTCP Properties.

3 Under General, mark the check box Allow connections only from computers 
running Remote Desktop with Network Level Authentication.

4 Click OK.
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Performance Monitoring and Optimization on OpenLAB CDS 
ChemStation AICs 

Whenever attempting to increase ChemStation AIC performance it is 
important to monitor and classify potential performance issues carefully. 

A simple method for monitoring disk performance is by reprocessing a 
large example sequence data for benchmarking purposes. The run time of 
the reprocessing cycle can be graphically displayed by importing the 
sequence logfile to Microsoft® Excel® and plotting the start time versus the 
sequence line number.

By repeating these benchmark tests on a regular base – ideally after 
performing a maintenance procedure – slow digression of performance can 
be identified earliest.

Software operations typically start a whole chain of processes where the 
slowest step determines the overall performance. If the slowness of this 
step is exceeding the other processes by magnitudes this single bottleneck 
might be corrected by a single action.

In cases where the individual processes along the chain show equivalent 
performance the bottleneck may become hard to identify as it jumps along 
the chain as soon as a single parameter gets optimized. A multi- step 
optimization becomes necessary then.

The following parameters do have potential impact on AIC performance 
and can be tuned for performance optimization:

• Network configuration

• Memory configuration

• Disk configuration

Network Configuration

Please refer to the Network Requirements document on disc 1 of the 
OpenLAB CDS DVD suite.
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Memory Configuration

Troubleshooting: Monitor the overall memory usage and the private Bytes 
used by each ChemMain.exe process. If memory usage exceeds 95% of the 
available memory Windows starts to swap memory content into virtual 
memory – which is a slow process as the pagefile (virtual memory) is 
typically hosted by a spinning disk.

Possible Causes for insufficient free memory: The memory usage increases 
with the server load or the application in use may also suffer from 
memory leaks.

As the server load is typically constant on larger time scales the memory 
consumption due to memory leaks increases over time. If performance and 
free memory can be re- gained by rebooting the AIC the system might 
suffer from memory leaks. Please ensure that Microsoft hot fix 2636613 is 
installed (http://support.microsoft.com/kb/2636613/en- us).

If 95% of the memory is already consumed after a reboot of the AIC and 
all instruments connected more physical memory should be added. 

If a ChemStation OpenLAB CDS ChemStation instance is operated for 
several weeks in a row with no shut- down the chemmain.exe process 
associated with this instrument may allocate 500 MB private memory or 
even more. Hence it is recommended to restart every instrument instance 
after 2- 3 weeks of operation. This does also trigger the clean- up of 
temporarily stored files with positive impact on disc performance. 

Disc Configuration

Troubleshooting: In order to identify disc- related performance problems it 
is recommended to monitor the average disk queue for logical and physical 
disks (http://technet.microsoft.com/en- us/library/cc938625.aspx). With a 
volume set a queue that is never shorter than the number of active 
physical disks indicates that you are developing a bottleneck.

Another method for monitoring disk performance is by reprocessing a 
large sequence of example data. The reprocessing time on an idle system 
may increase over time, indicating a disk- related problem.
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Possible causes for disc- related performance problems:

• If OpenLAB CDS ChemStation gets installed on a single disc drive, this 
disc has to handle the following I/O intensive processes:

• Windows pagefile (virtual memory)

• Windows user's temp directories (unzipping of data downloaded from 
OpenLAB ECM)

• ChemStation raw data writing 

• The load on this disk gets additionally increased if the ChemStation 
data storage location is not excluded from real- time protection of virus 
scanners as recommended.

• The main goal is to keep the AIC disks as empty as possible and to 
distribute I/O intensive processes across multiple disk drives. This can 
be achieved by various means:

• Delete locally stored data after transfer to OpenLAB ECM or 
OpenLAB data store.

• Install or configure OpenLAB CDS ChemStation on a drive that do 
not host the Windows page file or the Windows user's temp 
directories (default: c:\users\<current user\AppData\Local\Temp).

• Install OpenLAB CDS ChemStation on the c: drive and change the 
default paths for sequences methods and data files after configuring 
a new instrument.
120 CDS Networked and Distributed System Installation and Configuration



Troubleshooting 9
Remedial Procedures
Remedial Procedures

Configure ChemStation Instrument Users Manually

During installation of OpenLAB CDS, the instrument users names and 
passwords can be configured by an XML file.

The default XML file has the following structure: 

<xml version="1.0" encoding="utf-8">

<users>

<user UserName="CSIUser0" />

<user UserName="CSIUser1" />

<user UserName="CSIUser2" />

<user UserName="CSIUser3" />

<user UserName="CSIUser4" />

<user UserName="CSIUser5" />

<user UserName="CSIUser6" />

<user UserName="CSIUser7" />

<user UserName="CSIUser8" />

<user UserName="CSIUser9" />

<user UserName="CSIUser10" />

</users>

OpenLAB CDS Master Installer fills the structure with the created 
passwords and the machine- prefixed user names: 

<?xml version="1.0" encoding="utf-8" ?>

<users>

<user UserName="wwadpl03\CSIUser0" Password="aZ1=kE4$nP8#" />
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<user UserName="wwadpl03\CSIUser1" Password="hM6%cB2!kE4#" />

<user UserName="wwadpl03\CSIUser2" Password="yU7&lF9$oG6(" />

<user UserName="wwadpl03\CSIUser3" Password="rS3=bC3!jE4)" />

<user UserName="wwadpl03\CSIUser4" Password="xS8%vM8=qX0)" />

<user UserName="wwadpl03\CSIUser5" Password="nW9%uM7!xZ7^" />

<user UserName="wwadpl03\CSIUser6" Password="uK0%wJ8+kA6+" />

<user UserName="wwadpl03\CSIUser7" Password="lM5!mT9+vQ3#" />

<user UserName="wwadpl03\CSIUser8" Password="gZ2[nJ8[aL6&" />

<user UserName="wwadpl03\CSIUser9" Password="rT8%vM9-qX0" />

<user UserName="wwadpl03\CSIUser10" Password="hM6%cY1!kE5#" />

</users>

Please retain this file in a safe location for later troubleshooting.

Configure ChemStation Instrument Users Manually

OpenLAB CDS Master Installer offers the option to specify different user 
names or passwords during the installation of an AIC. When using domain 
users, it might become necessary to change their passwords on a regular 
basis.

1 Specify different user names or passwords:

a Provide domain users in the form: UserName="<domain name>\<user 
name>".

b Provide special passwords in the form: Password="<user defined 
password>”.

c Enforce addition of users to the Local Administrators group by 
setting the users attribute: 
<users unsafe="true”>

NOTE Make sure that at least 11 different user names are provided. If you provide the same 
username twice, instrument access conflicts will arise.
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2 Change domain user passwords:

a Press Ctrl- Alt- Del and select Change a Password.

b Enter <domain>\<user name> in the User name box, together with the 
old password and new password (2 times) in the respective boxes.

c Repeat step 2b for each instrument user.

d Copy the passwords to the users.xml file (make sure the passwords 
comply with the domain policy for passwords).

e Register the new passwords with OpenLAB Shared Services as 
described in section “Register ChemStation Instrument Users with 
OpenLAB Shared Services” on page 123.

f Restart OpenLAB Control Panel before launching the reconfigured 
instruments.

Register ChemStation Instrument Users with OpenLAB Shared 
Services

To re- register the retained, if necessary edited, users.xml file perform the 
following steps:

1 On the AIC, select Start > Command Prompt.

2 Type cd <ChemStation installation directory>\Core and press Enter.

3 Type registerCSData.exe /remote /InstrumentUsers=<Path to users.xml 
file> /url=net.tcp://<OpenLAB Shared Services 
server>:6577/Agilent/OpenLAB/ /user:<name of OpenLAB Shared 
Services admin user> /password:<password of OpenLAB Shared 
Services admin user> and press Enter.
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Privilege “Allow Log-on Through Remote Desktop Services” not 
Granted for Remote Desktop Users Group by Group Policy

Some IT departments revoke the privilege Allow log- on through Remote 
Desktop Services from the Remote Desktop Users group (to which it is 
granted by default) by domain policy.

To check if the logon privilege is granted:

1 Select Start > Run...

2 Type secpol.msc.

3 Check the security setting for Local Policy > User Rights Assignment > Allow 
log-on through Remote Desktop Services. If the security setting does not 
include the Remote Desktop Users group:

a Negotiate with the local IT department to get an exception for this 
policy (preferred solution).

OR

Check if the logon privilege is granted to the Local Administrators 
group (workaround solution).

b If the privilege is granted: Set the unsafe=”true” switch during 
installation of the AIC (see “Configure ChemStation Instrument Users 
Manually” on page 121).

Not Possible to Launch the Instrument from the CDS Client

Make sure that the ChemStation installation folder is not shared. Doing so 
will disable launching the instrument from CDS client.

NOTE It is not possible to configure or launch ChemStation instruments remotely on this AIC if 
the instrument user does not have the described privilege.
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Remote Desktop Users Group is Emptied by Group Policy

Some IT departments empty the Remote Desktop Users group periodically by 
Group Policy.

To check if the Remote Desktop Users group is emptied:

1 Create a local test user.

2 Add the test user to the Remote Desktop Users.

3 Wait until the Group Policy application period has elapsed (in most 
cases within 24 hours).

4 Check in the Computer Management tool under Local Users and Groups > 
Groups > Remote Desktop Users if the test user is still present in this 
group. If the user is not present:

a Negotiate with the local IT department to get an exception for this 
policy (preferred solution).

OR

Check whether the security setting for Local Policy > User Rights 
Assignment > Allow log-on through Remote Desktop Services > > includes the 
Local Administrators group (workaround solution).

b If the security setting includes the Local Administrators group: Set 
the unsafe=”true” switch during installation of the AIC (see 
“Configure ChemStation Instrument Users Manually” on page 121). 

NOTE It is not possible to configure or launch ChemStation instruments remotely on this AIC if 
the instrument users do not have the described privilege.
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No Access to Domain Printers

Some IT departments allow the use of network printers only for domain 
users but not for local users.

1 Select Start > Devices and Printers.

2 Check the security properties of the printers set up on the AIC.

If the Local Users group or Remote Desktop Users group does not have Print 
privilege on the selected printer, do one of the following:

• Install and use a local printer (preferred solution, see below for 
instructions).

• Negotiate with the local IT department to get an exception for this 
security setting.

• Use domain users as instrument users:

• Create 11 domain users.

• Register the users and passwords during installation of the AIC 
(see “Register ChemStation Instrument Users with OpenLAB 
Shared Services” on page 123)

• Check whether the security setting includes the Local Administrators 
group (workaround solution).

If this is the case: Set the unsafe=”true” switch during installation of 
the AIC (see “Configure ChemStation Instrument Users Manually” on 
page 121).

NOTE This requires domain administrator privileges.

NOTE It is not possible to use the redirected printers that are installed on the client. These 
printers might become inaccessible when the instrument control is switched to a different 
client PC.
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Error Message “Your Credentials did not Work” when Configuring 
or Launching an Instrument

After selecting the Configure Instrument or Launch button in the OpenLAB 
Configuration Panel an error message appears, stating that the logon to the 
AIC failed.

1 Log on by selecting Use another account.

2 Type in the user name and password from the retained users.xml file 
(see “Configure ChemStation Instrument Users Manually” on page 121).

If this logon attempt succeeds, the logon information registered on the 
OpenLAB Shared Services server for this AIC is corrupt.

3 Re- register the users.xml file as described in “Register ChemStation 
Instrument Users with OpenLAB Shared Services” on page 123.

4 Check if the ChemStation instrument user still has the necessary access 
rights (see “Configure ChemStation Instrument Users Manually” on 
page 121 and “Remote Desktop Users Group is Emptied by Group 
Policy” on page 125):

a Apply the remedy or workaround as described in the sections 
mentioned above.

b On the AIC check if this account is locked out, using the Computer 
Management tool under Local Users and Groups > Users.

c Uncheck the box Account is disabled.
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Error Message “Program Execution Failed” when Configuring or 
Launching an Instrument

After selecting the Configure Instrument or Launch button in the OpenLAB 
Configuration Panel an error message appears, stating that program 
execution failed.

1 On the AIC, start Server Manager. Select Roles > Remote Desktop Services > 
RemoteApp Manager Properties.

2 Check that the RemoteApp Programs list SetupWizardLauncher with the 
attribute Unrestricted in column Arguments.

3 On the AIC, start Windows Explorer and check that the instrument users or 
Local Users group or Remote Desktop Users group have read/write and 
execute access to the ChemStation installation directory.

Emergency Procedures

If there is no connection to the OpenLAB Shared Services server, you can 
use an emergency procedure. For details, refer to the OpenLAB CDS 
Administration Guide.
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This chapter contains additional information on default settings and on 
Microsoft SQL Server 2008 R2 SP1/SP2 or SQL Server 2012.
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Change SQL Server Authentication to Mixed Mode

This procedure desribes how you can switch to Mixed Mode in an existing 
Microsoft SQL Server 2008 R2 SP1/SP2 or SQL Server 2012 installation.

1 Start SQL Server Management Studio.

2 In the Object Explorer, right- click the server name, and select Properties 
from the context menu.

3 In the Server Properties dialog, select the Security page.

4 Under Server authentication, select SQL Server and Windows Authentication 
mode.

5 Click OK.

6 Enable login for user sa.

a In the Object Explorer, navigate to Security > Logins.

b Right- click the user sa, and select Properties from the context menu.

c In the Login Properties dialog, select the General page.

d Provide a strong password.

e Select the Status page.

f Under Login, select Enabled.

Click OK.

7 Restart the SQL Server service, and log in with SQL Server 
Authentication.
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